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About This Guide

This release contains several fixes for issues identified by and with the help of
PTC Arbortext users. This guide lists those fixes for reference purposes. Fixes are
categorized by general product area and are ordered by Software Performance
Report (SPR) number. Descriptions typically apply to the specific reported issue.

Related Documentation

You can access online help from the Help menu in PTC Arbortext Editor,PTC
Arbortext Styler or Arbortext Publishing Engine. Help Center includes both web-
based HTML and PDF versions of all information and is accessed from the Help »
Help Center menu option.

You can find release notes to accompany this release in the Reference Documents
area of www.ptc.com/support.

Technical Support

Contact PTC Technical Support using the PTC website, email, phone, or fax if
you encounter problems using your product or the product documentation.

Use the Contact Support links on the PTC website at:
http://www.ptc.com/support/

The PTC website also provides a search facility for technical documentation of
particular interest. To access this search facility, use the URL above and select
Search Our Knowledge.

You must have a Service Contract Number (SCN) before you can receive
technical support. If you do not have an SCN, contact PTC Maintenance
Department using the contact instructions found in your Customer Support Guide.


http://www.ptc.com/support/
http://www.ptc.com/support/

Documentation for PTC Products

You can access PTC product documentation using the following resources:
* Online Help

Click Help from the user interface for online help available for the product.

» Reference Documents

Individual product manuals are available from the Reference Documents link
of the PTC website at the following URL:
http://www.ptc.com/support/
» Help Center
Help Centers for the most recent product releases are available from the PTC

website at the URL given below. Select the Support Center for the relevant
products to access the Help Centers link.

http://www.ptc.com/support/

You must have a Service Contract Number (SCN) before you can access the
Reference Documents or Help Centers links. If you do not have an SCN, contact
PTC Maintenance Department using the contact instructions found in your
Customer Support Guide.

Global Services

PTC Global Services delivers the highest quality, most efficient and most
comprehensive deployments of the PTC Product Development System including
PTC Creo, PTC Windchill, PTC Arbortext, and PTC Mathcad. PTC’s
Implementation and Expansion solutions integrate the process consulting,
technology implementation, education and value management activities customers
need to be successful. Customers are led through Solution Design, Solution
Development and Solution Deployment phases with the continuous driving
objective of maximizing value from their investment.

Contact your PTC sales representative for more information on Global Services.

Comments

PTC welcomes your suggestions and comments on our documentation. You can
submit your feedback to the following email address:

arbortext-documentation@ptc.com

Please include the following information in your email:
* Name

+ Company
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http://www.ptc.com/support/
http://www.ptc.com/support/
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Product

Product Release

Document or Online Help Topic Title

Level of Expertise in the Product (Beginning, Intermediate, Advanced)

Comments (including page numbers where applicable)

Documentation Conventions

This guide uses the following notational conventions:

About This Guide

Bold text represents exact text that appears in the program's user interface. This
includes items such as button text, menu selections, and dialog box elements.
For example,

Click OK to begin the operation.
A right arrow represents successive menu selections. For example,
Choose File > Print to print the document.

Monospaced text represents code, command names, file paths, or other
text that you would type exactly as described. For example,

At the command line, type version to display version information.

Italicized monospaced text represents variable text that you would
type. For example,

installation-dir\custom\scripts\

Italicized text represents a reference to other published material. For example,

If you are new to the product, refer to the Getting Started Guide for basic
interface information.






PTC Arbortext Editor Fixes

SPR Fix Description

2119014 | The Crop Marks and Registration Marks options are available for
selection when generating an APP preview from PTC Arbortext Editor
when connected to PTC Arbortext Publishing Engine.

2142084 | A keyboard mapping that is mapped to a specific window is no longer
available in all windows.

2153294 |Using a CTRL-Shift-letter combination to call a macro is valid, and no
longer issues a beep sound.

2170513 |PTC Arbortext Editor handles ISO graphics from PTC Creo Illustrate
successfully.

2205097 | ACL functions involving counts continue running and updating output
until complete, even if minimized to a background task.

2214617 | Adding symbols with the Insert Symbol dialog works with a PTC
Arbortext Editor ActiveX control embedded in a modal XUI dialog.

2217180 |PDF graphics are fully supported in PTC Arbortext Editor - they can
be displayed in Edit view. Double-clicking on a displayed PDF image
will launch the associated application.

2217375 | Small CGM graphics are handled correctly in PTC Arbortext Editor.

2217559 |Multiple <ElementOption> elements in a DCF file for a single
XML tag are supported. Values that originate from attribute defaults
will be ignored.

2219039 | The saved caret option of PTC Arbortext Editor's data merge feature
works as expected. When a document is reopened, the caret appears in
the position of the last authoring before closing.

2221755 |PTC Arbortext Editor now ignores context errors in markup that is
marked as deleted in change tracking.

2222135 | XIncludes in a bookmap that reference XML files that only contain




SPR

Fix Description

graphic tags are retained when the bookmap is checked out.

2222229

Using X to close PTC Arbortext Editor no longer generates an error
message in the Event Log.

2223590

Global attribute/value aliases are available in an alias map as expected.

2224443

EPS graphics are fully supported in Edit view in PTC Arbortext
Editor.

2226094

PTC Arbortext Editor no longer terminates unexpectedly when topics
are opened individually from a large ditamap.

2227700

PTC Arbortext Editor now handles insertion of EPS images
successfully.
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Publishing Fixes

SPR

Fix Description

2077473

Indent settings for numbers and bullets implemented with tabs are
placed correctly in PDF output generated by the APP engine.

2092466

Unwanted empty rows are no longer added to a table pasted from
Excel when it is published to PDF.

2103313

The width attribute set for an image is respected in PDF output
generated by the APP engine.

2105257

The width attribute set for an image is respected in PDF output
generated by the APP engine.

2114359

A newpage instruction no longer causes PDF publishing with the
APP engine via PTC Arbortext Publishing Engine to terminate
unexpectedly.

2118764

Links in PDF output generated by the APP engine point to the correct
page.

2120337

Post space settings for an index title are respected in PDF output based
on a one-column layout.

2121166

The content of a hidden element is no longer repeated when it is used
in generated text, in PDF output generated by the APP engine.

2125430

Cross references to titles with no text content are resolved correctly in
PDF output generated by the APP engine.

2125445

Document titles are shown in the correct localized language in PDF
output generated by the APP engine.

2127977

A table’s title now repeats as expected in PDF output when the table
carries onto a subsequent page.

2136364

The content of a hidden element is no longer repeated when it is used
in generated text, in PDF output generated by the APP engine.
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SPR

Fix Description

2149269

The addition of SFE elements to content no longer causes issues with
publishing PDF output.

2151472

The generated wrapping table for a note includes the note's content,
even if the output of the note is set to Hidden in the stylesheet.

2152485

In a Print Preview generated by the FOSI engine, the background color
set for an element no longer extends beyond the text content of the
element.

2154166

Condition-based generated numbering of sections is calculated
correctly in PDF output generated by the APP engine.

2155345

Table formatting based on an align="char" command is respected in
PDF output generated by the APP engine.

2155694

EPS graphics are output correctly in PDF output generated by the APP
engine.

2157693

An element set to start on a new odd page no longer starts on an even
page in a Print Preview generated by the APP engine.

2163504

A document attempting to save to PRTDV no longer causes issues
with publishing with the FOSI engine.

2164061

Numbering of an element that is set to restart at each instance of its
parent element is generated correctly in PDF output generated by the
APP engine.

2170192

Generated content no longer causes a PDF publishing action to
terminate unexpectedly.

2175627

Print and Save PDF File actions have been removed from the APP
Preview window. Access these actions from the File menu in PTC
Arbortext Editor.

2175817

Table cell formatting described via processing instruction is applied as
expected in PDF output generated by the APP engine.

2189232

All cross reference types are resolved correctly with a page number in
PDF output generated by the APP engine.

2193772

A hidden document division is taken into consideration when
formatting a bookmark hierarchy in PDF output generated by the APP
engine.

2193939

Tilde characters are output as expected in PDF output generated by the
APP engine.

2194793

Valid PDF bookmarks are created if the bookmark is also referenced
by a xref.

2196481

An index set to start a new page no longer includes an unwanted page
before the index itself in PDF output.
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SPR

Fix Description

2201051

A Follow number and suffix with setting configured to tab to a measure
defined with a Size object is obeyed in PDF output generated by the
APP engine.

2201331

A negative indent set for a numbered title in the Number Details dialog
is respected in output.

2208853

URLSs generated during a Publish For HTML Help action no longer have
lowercase characters converted to uppercase unexpectedly,
invalidating links.

2212655

Column balancing works as expected in PDF output generated by the
APP engine.

2215219

Publishing with a 64-bit installation of PTC Arbortext Editor no longer
generated runtime/DLL load errors.

2215583

Referencing a Chinese font with a combined font in PTC Arbortext
Styler no longer causes PDF publishing with the APP engine to
terminate unexpectedly.

2217527

Footnote numbering resets at the specified element/context in PDF
output generated by the APP engine.

2217570

Publishing to PDF with a particular custom stylesheet no longer causes
PTC Arbortext Styler to terminate unexpectedly.

2220623

Publishing tables where the morerows attribute is set on all entries in a
row no longer results in misplaced data and extra blank rows in PDF
output generated by the APP engine.

2221723

Links to images are resolved correctly to a local file when a PTC
Windchill service structure document is published to PDF with the
APP engine and PTC Arbortext Publishing Engine.

2222123

Row skipping no longer causes issues with column start and end in
subsequent rows in PDF output generated by the APP engine.

2223510

Text in CGM graphics is included in PDF output generated by the APP
engine. The text is searchable.

Include the set option set appgraphictransform="cgm:pdf"
to convert CGM graphics directly to PDF and enable availability of
graphic text.

2226814

Extra space no longer appears between characters in text output in the
Minion Pro font.

2227678

The final page number of a PDF output by the APP engine is updated
correctly if objects are added to the TOC during formatting.

Publishing Fixes 13




SPR Fix Description

2228249 | Unused fonts are no longer included in an output PDF file when it
includes EPS graphics.

2238159 | Footer text that is set to be translated with a UFE inside a cross
reference conditional on the value of the xml:lang attribute is output in
the expected language.
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DITA Support Fixes

SPR

Fix Description

1204084

Table rows that are defined via conref are displayed as expected.

2226431

Attributes are no longer cascaded from a parent map to topicrefs that
contain the keys attribute (a key definition), when creating a key
context.
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PTC Arbortext Styler Fixes

SPR

Fix Description

1355731

Custom tables, graphics, and links are output as expected from
separate print and Edit view stylesheets that define the objects
differently.
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PTC Arbortext Advanced Print
Publisher Fixes

SPR Fix Description

2124749 |10 Pantone color books are provided for the APP print engine - refer
to files scb_pantone *.3ad in the folder Arbortext-path/

app.
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PTC Arbortext Publishing Engine

Fixes

SPR

Fix Description

2205096

A new environment variable APTPENOWCFE has been added to the
PTC Arbortext environment. If the variable is set to a value of 1,
Arbortext PE sub-processes will not refer to arbortext .wcf files.

2219553

PTC Arbortext Publishing Engine (PE) server URL information set in
the PTC Arbortext Publishing Engine Test Utility is retained when the
utility is relaunched.

2224152

When accessed via PTC Arbortext Publishing Engine, custom zipped
applications that include filenames with non-ASCII characters now
generate a message suggesting that the zip is rebuilt using valid
characters.

2224944

PTC Arbortext Publishing Engine now recognizes catalog.xml
files when performing a composition configuration scan.

2227556

PTC Arbortext Publishing Engine processes graphics correctly for
inclusion in PDF output.
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PTC Server connection and
Repository Adapter Fixes

SPR

Fix Description

2219673

The order of objects in a service structure is synchronized between the
view of the structure in PTC Windchill Service Information Manager
and the browser view in PTC Arbortext Editor.

2220436

The check in of a modified document after it has been uploaded to a
PTC Windchill server completes successfully, creating a new iteration
of the document as expected.

2221384

An error message is generated if an out of date version of a document
being opened in PTC Arbortext Editor exists in the currently active
workspace.

2221506

Checking out and saving a document that contains a referenced child
element into PTC Windchill no longer generates error messages.

2222117

Object values appear in the correct language when working in a non-
English locale of PTC Arbortext Editor via the PTC Server
connection.

2222930

Checking a document into Documentum via the PTC Arbortext
Adapter to Documentum/WDK no longer generates an error message.

2223300

The time taken to connect PTC Server connection to a PTC Windchill
server when working with a product context that includes a large
number of document templates has been improved.

2223636

Two-way toxml metadata rules are working as expected during view
operations for nested hierarchies using PTC Arbortext Editor and PTC
Arbortext Content Manager.
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SPR Fix Description

2226427 | Document types listed in the Search dialog of a PTC Arbortext Editor
session connected to PTC Windchill are presented in logical order.
2226812 | The Revise action is no longer available in menus invoked in the
Resolved Document for Editing (RDE) or Resolved Document for
Styling (RDS) when PTC Arbortext Editor is connected to PTC
Windchill.
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PTC Arbortext Import Fixes

SPR

Fix Description

2205729

Table rows are ordered correctly in a table whose header is set to
repeat on each page, in the output of a . doc to XML transformation.

2206750

Footnotes are numbered correctly in the output of a . doc to XML
transformation.
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XUI Fixes
SPR Fix Description

2217552 | The backgroundcolor attribute for a window is respected in XUI
dialogs.

27






D
DITA support fixes, 15

P

PTC Arbortext Advanced Print
Publisher fixes, 19

PTC Arbortext Editor fixes, 9

PTC Arbortext Import fixes, 25

PTC Arbortext Publishing Engine
fixes, 21

PTC Arbortext Styler fixes, 17

PTC Server connection fixes, 23

Publishing fixes, 11

R
repository adapters fixes, 23

X
XUI fixes, 27

Index

29



	About This Guide 
	PTC Arbortext Editor Fixes 
	Publishing Fixes 
	DITA Support Fixes 
	PTC Arbortext Styler Fixes 
	PTC Arbortext Advanced Print Publisher Fixes 
	PTC Arbortext Publishing Engine Fixes 
	PTC Server connection and Repository Adapter Fixes 
	PTC Arbortext Import Fixes 
	XUI Fixes 
	Index 

