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About this Guide

The PTC Arbortext Editor, PTC Arbortext Styler, and PTC Arbortext Architect
Release Notes contain release information for the 6.1 M030 release of PTC
Arbortext Editor and its optional modules. These release notes document the
changes and new features in this release of PTC Arbortext Editor, as well as any
known limitations. If you are upgrading from a version prior to PTC Arbortext
Editor 6.1 F00O0, refer to the release notes of any interim versions by visiting the
Reference Documents area of www.ptc.com/support.

Changes to documentation and the software itself may occur after the publication
of these release notes. For documentation updates and descriptions of software
functionality changes, alternative techniques, and common software issues, review
the available Solutions using the Update Advisor also available in the Support
area at http://www.ptc.com.

For a list of software fixes included in this release, please refer to the Reference
Documents section of www.ptc.com/support.

Prerequisite Knowledge

To use the information in these release notes, you should be familiar with the
operating system at your site and with standard system administration tasks.

Technical Support

Contact PTC Technical Support using the PTC website, email, phone, or fax if
you encounter problems using your product or the product documentation.

Use the Contact Support links on the PTC website at:
http://www.ptc.com/support/


http://www.ptc.com/support
http://www.ptc.com
http://www.ptc.com/support
http://www.ptc.com/support/

The PTC website also provides a search facility for technical documentation of
particular interest. To access this search facility, use the URL above and select
Search Our Knowledge.

You must have a Service Contract Number (SCN) before you can receive
technical support. If you do not have an SCN, contact PTC Maintenance
Department using the contact instructions found in your Customer Support Guide.

Documentation for PTC Products
You can access PTC product documentation using the following resources:
*  Online Help

Click Help from the user interface for online help available for the product.

e Reference Documents

Individual product manuals are available from the Reference Documents link
of the PTC website at the following URL:

http://www.ptc.com/support/
* Help Center

Help Centers for the most recent product releases are available from the PTC
website at the URL given below. Select the Support Center for the relevant
products to access the Help Centers link.

http://www.ptc.com/support/

You must have a Service Contract Number (SCN) before you can access the
Reference Documents or Help Centers links. If you do not have an SCN, contact
PTC Maintenance Department using the contact instructions found in your
Customer Support Guide.

Global Services

PTC Global Services delivers the highest quality, most efficient and most
comprehensive deployments of the PTC Product Development System including
PTC Creo, PTC Windchill, PTC Arbortext, and PTC Mathcad. PTC’s
Implementation and Expansion solutions integrate the process consulting,
technology implementation, education and value management activities customers
need to be successful. Customers are led through Solution Design, Solution
Development and Solution Deployment phases with the continuous driving
objective of maximizing value from their investment.

Contact your PTC sales representative for more information on Global Services.
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Comments

PTC welcomes your suggestions and comments on our documentation. You can
submit your feedback to the following email address:

arbortext-documentation@ptc.com

Please include the following information in your email:

Name

Company

Product

Product Release

Document or Online Help Topic Title

Level of Expertise in the Product (Beginning, Intermediate, Advanced)
Comments (including page numbers where applicable)

Documentation Conventions

This guide uses the following notational conventions:

Bold text represents exact text that appears in the program's user interface. This
includes items such as button text, menu selections, and dialog box elements.
For example,

Click OK to begin the operation.
A right arrow represents successive menu selections. For example,
Choose File » Print to print the document.

Monospaced text represents code, command names, file paths, or other
text that you would type exactly as described. For example,

At the command line, type version to display version information.

Italicized monospaced text represents variable text that you would
type. For example,

installation-dir\custom\scripts\

Italicized text represents a reference to other published material. For example,

If you are new to the product, refer to the Getting Started Guide for basic
interface information.
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Platform Support

For a complete list of supported platforms, including post-release updates, refer to
www.ptc.com/partners/hardware/current/support.htm. PTC only provides product
support for PTC Arbortext Editor used on hardware or operating systems
described here.

Browser Support

Browser support for web and HTML preview and output is listed in the software
compatibility matrix for this release. Refer to www.ptc.com/partners/hardware/
current/support.htm.

The Web/Wireless Composer is available on all PTC Arbortext Editor supported
platforms and systems.

If this installation of PTC Arbortext Editor will be using Arbortext Publishing
Engine to perform document publishing, Print Composer and/or the Web/Wireless
Composer product options also must be installed on the PTC Arbortext Editor
client to make the publishing menu choices available. These options are installed
automatically when installing on Windows when you specify that Arbortext
Publishing Engine is being used at your site.

Localization

This release of PTC Arbortext Editor supports English, French, German, Italian,
Japanese, Korean, Simplified Chinese, Spanish, and Traditional Chinese
localizations of the user interface and online help. Refer to the online help topic
titled LC-MESSAGES — Specitying the locale for user interface for details on
enabling alternate localizations of PTC Arbortext Editor.

As in previous releases, the topics targeted to document authors are localized in
the online help. Localized online help will appear based on your system locale.
You may need to set the LC_ MESSAGES environment variable if the appropriate
system locale is not enabled.

The CJK language locales (Chinese, Japanese, or Korean) are automatically
enabled for the appropriate corresponding system locale in PTC Arbortext Editor.

The PTC Arbortext Editor online help and following documents are localized in
this release:

* PTC Arbortext Editor Help

* Installing PTC Arbortext Editor, PTC Arbortext Styler, and PTC Arbortext
Architect

* PTC Arbortext Editor, PTC Arbortext Styler, and PTC Arbortext Architect
Release Notes

PTC® Arbortext® Editor™, PTC® Arbortext® Styler™, andPTC® Arbortext® Architect™
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* SPR Fixes Included with PTC Arbortext Editor and PTC Arbortext Publishing
Engine
* PTC Arbortext Editor Tutorial

Support for IPv6

PTC Arbortext Editor and PTC Arbortext Publishing Engine support Internet
Protocol version 6, or IPv6, networking. IPv6 has a much larger pool of unique
internet addresses by having an extended internet address length of 128 bits. PTC
Arbortext Editor clients on the same network as Arbortext Publishing Engine will
need to use the same protocol as the server.

Note that the Arbortext Command Language (ACL) channel functions do not
support IPv6.

Uninstalling PTC Arbortext Editor

If you need to uninstall PTC Arbortext Editor, be sure to log off and back on to
your system before beginning the uninstall process. This ensures that the PTC
Arbortext Editor will be completely removed from your system.

Release Requirements and Support 11






Updates in this Release
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The following sections describe the new and changed features in this release. SPR
Fixes in this Release on page 18 describes where to find a list of specific fixes
included in this release.
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DITA Support Changes

New Resolved Document for Styling (RDS) Format to Support DITA
Documents

An optional new format RDS supports the styling and publishing of DITA
documents in this release. It has been updated to support other publishing
processes and has some differences to the old format:

* NoReferredTopics section
* Does not contain all the metadata from topics in the FlattenedMap section

* Does not include some of the options controlled by dita.acl (control of
certain customizations)

You may see changes in the output from DITA content so ensure that you check
the output to confirm that it still meets your requirements.

You can change to the new format RDS by setting the value of the set
ditanewusenewrds command to on. By defaultitis setto of f.

PTC Arbortext Styler Changes

Change to Context Matching for Index Content

In previous releases, context matching for an element occurring in an index acted
as if the index was a discrete document. Context matching only considered the
elements in the index. Now, context matching correctly takes into account the
index’s location in the larger document.

For example, a stylesheet context sfe:IndexHeading Main index
anywhere inmaint index would not have matched in previous releases
(assuming that the maint index element is outside the index). Now it will
match if the index is located inside amaint index element.

With this change, stylesheet writers have more control over the formatting of
indexes. It is possible that output from existing stylesheets will change with this
release, with some contexts that were not matched previously appearing in an
index. Please check your output to ensure it still meets your requirements.

This changes applies when publishing with the APP engine.

Ul Changes

The Titles to include field has been removed from the Table of Contents (TOC)
list. Use the Customize Title Contexts option to open the Customize Table of
Contents window, where you can select contexts to be included in a TOC.

PTC® Arbortext® Editor™, PTC® Arbortext® Styler™, andPTC® Arbortext® Architect™
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PTC Arbortext Advanced Print Publisher
(APP) Changes

New XML Configuration File for PDF Publishing

APP provides a new XML-based configuration file to support PDF publishing,
Arbortext-path\app\standard.appct. It contains the same default
settings as the previous standard. 3sppdf configuration file it replaces.

You can create and use custom versions of the file to support particular PDF
publishing requirements. Open the file in PTC Arbortext Editor, make changes,
and save it to a location where it can be located during a publish action:

* Publishing PDF from PTC Arbortext Editor or PTC Arbortext Styler — you
can browse for a custom file, or locate it in the APTCUSTOM\ app directory
where APP will find it

» Publishing PDF via Arbortext Publishing Engine — a custom file must be
located on the PE server, in any of these locations:
O Arbortext-path\app
O any APTCUSTOM\ app directory

O an application or custom doctype \nnn directory, where nnn is the
short doctype name of the doctype of the document being published.

Note that files of type . 3sppdf are no longer supported by PTC.

Refer to PDF Configuration File for the APP engine and APP PDF Configuration
File (standard.appcf) in PTC Arbortext Styler User's Guide for information.

Publishing Changes

New Default Configuration File for APP Publishing

PDF publishing with the APP engine is now supported by a new XML-based
configuration file, standard.appcf. The file is located at Arbortext-
path\app. It contains the same default settings as the previous
standard. 3sppdf file.

The file is selected by default in the Config File field of all PDF publishing dialogs
when the PTC Arbortext environment is set up to use the APP engine.

You can revert to the previous custom . 3sppdf files for publishing. Browse for
and select the required file in the Use File dialog, accessed by clicking Browse
next to the Config File field. Select Old-format files (*.3sppdf) in file type drop
down list. Note that files of type . 3sppdf are no longer supported by PTC.

Refer to PTC Arbortext Advanced Print Publisher (APP) Changes on page 15 for
information.
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Publishing Actions Removed from APP Preview Window

Print and Save PDF File actions have been removed from the APP Preview
window in this release. Access these actions from the File menu in PTC Arbortext
Editor.

PTC Server connection Changes

New User Authentication Process

The PTC Server connection now has an optional new authentication process that
supports the following types of user authentication:

» User name and password authentication
* Forms-based authentication
e HTTPS client authentication

The process to connect to a PTC Server is changed, so that the initial options on
the Connect dialog box only request the name of the PTC Server to which you
want to connect. The dialog displayed after that depends on the type of
authentication used by the server. Once the user is authenticated, the Connect
dialog box enables you to select the context and workspace in which you want to
work. For more information, refer to Connecting to a PTC Server in the PTC
Arbortext Editor help.

In the case of HTTPS client authentication, no authentication dialog is displayed if
only a single client certificate is available in the designated Microsoft Windows
certificate store or stores. If multiple client certificates are available, a new
Authentication Required dialog box displays enabling you to select the certificate
to use for authentication.

The new authentication process is not used by default. There is a new
UseNewAuthentication parameter in the userprefs.xml configuration file
that specifies whether to use the new authentication. Set the value of this
parameter to True to use the new process.

Supported Microsoft Windows Certificate Stores

The SecurityCertiticateStoreName parameter in the siteprefs.xml
configuration file now supports a new value PTC_SEARCH IN ALL KEY
STORES. When the parameter is set to this value, the PTC Server connection
searches all PTC supported Microsoft Windows certificate stores for the certificate
specified in the SecurityCertificateSerialNumber parameter.

For more information, refer to Configuration Files in the PTC Arbortext Content
Management Guide.

PTC® Arbortext® Editor™, PTC® Arbortext® Styler™, andPTC® Arbortext® Architect™
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Automatic Workspace Creation

When the context you select in the Connect dialog box does not have a
workspace, the PTC Server connection now creates one for you automatically. The
default new workspace name is Workspace on context. The new workspace is
created when you click the Finish or OK button to connect to the PTC Server. If
you want to create the new workspace with a name you choose, click the New
button to open the Create New Workspace dialog box.

Translated Names in Information Structure Elements

If you have set the PRO_LANG environment variable on your system to a
language for which the PTC Server has translated values available, the PTC
Server connection now displays those translated values for the names of the
following Information Structure elements:

* Information Structure root
* Information group

This only applies to a PTC Server running release 10.2 M022 or later.

Context Assignment When an Information Element is Opened from
the PTC Server

When you use the Open in Arbortext Editor action in the PTC Server HTML
interface to edit an information element, the default context and workspace to
which that element is assigned has changed. If PTC Arbortext Editor is already
running, the document opens in the currently active context and workspace. If
PTC Arbortext Editor is invoked by the action, the document opens in the last
active context and workspace. If the element is opened from a context of a
workspace details page in the PTC Server HTML interface, then PTC Arbortext
Editor will prompt you to change to this workspace before opening the element.

This only applies when the information element is opened from a folder, structure,
or details page in a product or library context.

Environment Variable Changes

New Environment Variables
The following environment variables are new in this release:

APTJAVAVMMEMORY
This variable sets the size of the Java Virtual Machine (JVM) embedded in
PTC Arbortext Editor. Its value should be an integer, which will be interpreted
as the size of the JVM in megabytes.

Updates in this Release 17



This environment variable is similar in effect to the ACL set
javavmmemory option. The value of APTJAVAVMMEMORY is processed
on startup of PTC Arbortext Editor. The value of set javavmmemory is set
when the command is called, which could be after PTC Arbortext Editor has
started the JVM, depending on the installation. The size of the JVM must be
determined before it starts — employing APTJAVAVMMEMORY ensures that
is always is.

See APTJAVAVMMEMORY in the PTC Arbortext Customizer's Guide for
more information.

SPR Fixes in this Release

The list of fixes for issues identified by and with the help of PTC Arbortext users
can be found in the Reference Documents area of www.ptc.com/support. Fixes are
categorized by product area and are ordered by Software Performance Report
(SPR) number. Descriptions typically apply to the specific reported issue.

Search for SPR Fixes Included with PTC Arbortext Editor and PTC Arbortext
Publishing Engine in the Release Notes category.

PTC® Arbortext® Editor™, PTC® Arbortext® Styler™, andPTC® Arbortext® Architect™
18 Release Notes


http://www.ptc.com/support

For More Information

PTC Arbortext DocumMENtatioN ..........o.ouiieiei s 20

Documentation supporting PTC Arbortext Editor and PTC Arbortext Publishing
Engine is delivered in the PTC Arbortext Editor Help Center. Documentation for
this and all recent releases can also be downloaded from the Reference Documents
area of the PTC website at www.ptc.com/support.

19


http://www.ptc.com/support

PTC Arbortext Documentation

PTC Arbortext Editor comes with supporting documentation delivered in several
methods.

* PTC Arbortext Editor online help thoroughly covers how to use PTC
Arbortext Editor to create and edit documents; work with each of the PTC
Arbortext Editor features, toolbars, menus, and dialog boxes; understand
structured documentation; and how to customize PTC Arbortext Editor using
the powerful Arbortext Command Language (ACL). Access the online help in
PTC Arbortext Editor by choosing Help » PTC Arbortext Editor.

* PTC Arbortext Styler (optional) online help provides instruction on using PTC
Arbortext Styler to create simple to complex stylesheets for publishing to

multiple outputs. Access the online help in PTC Arbortext Styler by choosing
Help » PTC Arbortext Styler.

» The Help Center is a complete library of all documentation supporting PTC
Arbortext Editor, PTC Arbortext Styler, PTC Arbortext Architect, and
Arbortext Publishing Engine. The PTC Arbortext Help Center contains the
online help and all of the PDFs supporting these products. HTML versions of
all PDF documents are also delivered in the Help Center.

Access the PTC Arbortext Help Center in PTC Arbortext Editor by choosing
Help » Help Center.

All online help and PDF documentation delivered with this release is current.
Release versions identified on the covers of PDF documents state the most recent
release in which the particular document's content was updated. The following
PTC Arbortext PDF documents are included in this release.

Release notes and installation

* PTC Arbortext Digital Media Publisher Release Notes

* PTC Arbortext Editor, PTC Arbortext Styler, and PTC Arbortext Architect
Release Notes

» Installing PTC Arbortext Editor, PTC Arbortext Styler, and PTC Arbortext
Architect

» Installing PTC Arbortext Publishing Engine
Administration

* PTC Arbortext Administrator's Guide

* PTC Arbortext Content Management Guide

* PTC Arbortext Digital Media Publisher Tutorial
* PTC Arbortext Document Types Guide

* PTC Arbortext Editor Deployment Kit Guide

PTC® Arbortext® Editor™, PTC® Arbortext® Styler™, andPTC® Arbortext® Architect™
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Configuring PTC Arbortext Publishing Engine
PTC Arbortext Publishing Engine Test Utility User's Guide

Authoring

PTC Arbortext Editor Tutorial

Stylesheet development

PTC Arbortext Styler User's Guide

PTC Arbortext Advanced Print Publisher for PTC Arbortext Styler Users
PTC Arbortext Advanced Print Publisher Stylesheet Developer’s Guide

PTC Arbortext Advanced Print Publisher Formatting Object Model Reference
PTC Arbortext FOSI Reference

PTC Arbortext XSL Support (PTC Arbortext 5.2)

MIL-PRF 28001C — Appendix B: PTC Arbortext Print Composer Support
Version

Programming

PTC Arbortext Customizer's Guide

PTC Arbortext Content Pipeline Guide

PTC Arbortext Digital Media Publisher Developer's Guide
PTC Arbortext Programmer's Reference

PTC Arbortext Publishing Engine Programmer's Guide
PTC Arbortext Import Reference

PTC Arbortext Import Tutorial

Arbortext Command Language Reference
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