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Introduction to Windchill Quality
Solutions

Thank you for your interest in Windchill Quality Solutions®. Windchill Quality
Solutions represents the next generation in reliability analysis software, and it is
your key to achieving reliability excellence.

With Windchill Quality Solutions, you can predict the reliability and
maintainability of your system, evaluate critical failure modes, model your
complete system to analyze reliability and availability metrics, and perform a wide
array of additional reliability analysis functions.

Once installed, your Tryout version is active for 30 days. When the 30-day trial
period expires, a message box will appear when you attempt to operate Windchill
Quality Solutions. Please contact us at that time if you are ready to purchase Wind-
chill Quality Solutions or need further information about your evaluation.

The Tryout version limits the amount of data you can add to your Projects, but it
will still enable you to fully explore all of the software’s capabilities. During
operation, if the data limit for a particular data element is reached, you will receive
a warning message that no further data can be added.

There are a few important points to take note of when using this guide:

» First, please review the sections Getting Started on page 9 and Common
Features on page 23. These sections will introduce you to the basic concepts of
Windchill Quality Solutions. Once you have reviewed these sections, you may



continue with any of the module-specific sections or progress step-by-step
through each section.

* You do not have to complete the module-specific sections in any particular
order. However, this guide assumes that, individually, each section is
completed from beginning to end.

» This guide assumes that you are operating the Windchill Quality Solutions
Tryout version. You may also use this guide with a licensed version of Wind-
chill Quality Solutions.

* The Windchill Quality Solutions Tryout version is based on the Team Edition.
You may use this guide with the Enterprise Edition as well. While there will be
some notable differences in these cases, the overall features and functionality
will remain the same across the Editions. One significant difference is that in
the Enterprise Edition, you are required to log in using a Windchill Quality Sol-
utions user name and password. It is also possible that some of the functions
detailed in the guide may be unavailable to you in the Enterprise version,
depending on the permissions established for you by your Windchill Quality
Solutions Administrator.

* You can open an Adobe Acrobat® version of this guide by clicking View the
Getting Started Guide PDF in the Links section of the Start Page. You may also
print the PDF version if you prefer a hard copy of this guide.

We hope that you find this guide helpful as an introduction to Windchill Quality
Solutions. Once you are comfortable with the basics, you will find further details
on the wide array of features available by accessing the help; the help provides
comprehensive information about all aspects of your Windchill Quality Solutions
package.

Welcome!
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This section of the Windchill Quality Solutions Getting Started Guide introduces
you to the interface and describes how to work with projects. You learn how to
start and exit Windchill Quality Solutions and how to use the Project Navigator to
create new Projects and open and close existing Projects.

Note

Because Projects can be tully customized, your screens may not look like the ones
shown in this guide.
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Starting Windchill Quality Solutions

You can start Windchill Quality Solutions using either of the standard Windows®
methods:

* Double-click the shortcut to Windchill Quality Solutions 10.0 Tryout on your
Windows desktop.

*  From the Windows Start menu, select [All] Programs » Windchill Quality
Solutions 10.0 Tryout » Windchill Quality Solutions 10.0 Tryout.

Note

If you are running a licensed version, the program name does not include the word
“Tryout.”

Selecting the Modules to Evaluate

Once Windchill Quality Solutions is started, the Modules Selection window opens.
The Modules Selection window lists all modules. In the Tryout version, no
modules are selected for use by default, and you must select at least one module to
start. Clicking a module button alternates between enabling and disabling the
module for use.

1. Click Prediction. Make sure that this button is enabled (depressed) and all other
buttons are disabled (raised).

Note

If you are not using a Tryout version, all the product modules that you have
purchased are available for selection. Click Clear All and then click Prediction.

2. Click OK to display the Start Page

Exiting Windchill Quality Solutions

To exit Windchill Quality Solutions at any time, do one of the following:
» Select File » Exit.

* Click the Close button in the top right corner of the application window.
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Start Page

The Start Page is the startup center for Windchill Quality Solutions. The following
sections provide all of the information you need to put the many advanced features
of the Start Page to immediate use.

The following topics discuss:

1. Start Page Sections on page 11
2. Start Page Additional Features on page 13

Start Page Sections

The Start Page has a number of sections designed to help you use your Windchill
Quality Solutions package efficiently.

Recent Files

The Recent Files list displays the latest files that you have opened. When file
names appear in this list, you can simply click the file name to open the file.

Notice also the New Project link in the title bar of the Recent Files list. Clicking
this link starts the New Project Wizard, allowing you to create a new Project right
from the Start Page. This window and the New Project Wizard are described later
in this guide.

Announcements

The Announcements section provides the ability to post announcements and to
review announcements posted by others. This is a great mechanism for
communication within your team.

Each announcement includes a title, the name of the person posting the
announcement, and the announcement itself. Announcements marked “High
Priority” appear in red.

To add a new announcement:

1. Click New on the right side of the Announcements title bar. The Add New
Announcement window opens.

For Title, enter ANew Announcement.
For Message, enter T 've postedmy first announcement.

For Expiration, use the date control to select tomorrow's date. Do not select the
High priority check box for this announcement.

5. When finished, click OK to post your new announcement in the list.

Getting Started 11



To delete an announcement:

1. Right-click the announcement you just entered and select Delete.
2. Click OK when asked to confirm the deletion.

Your announcement is deleted from the list.

Note that there is also an Edit command on the menu which enables you to update
an announcement title or message.

Links

The Links section enables you to add a hyperlink to your Start page for quick and
easy access to a specific internet resource. For example, if you have a website that
you visit frequently, you can create a link to it and include it in the Links section.

Several important links are already listed for you, including:
1. The Getting Started Guide: A Step-by-Step Tutorial link displays this guide on
your screen.

2. The View the Getting Started Guide PDF link displays an Adobe Acrobat
version of the Windchill Quality Solutions Getting Started Guide.

3. The Windchill Quality Solutions Website link takes you to the Windchill Quality
Solutions home page on the PTC website.

4. The PTC Customer Support link takes you to the technical support area of the
PTC website. To access some features of the technical support area, you must
have an active customer support online account.

To add a link:

1. Click New on the right side of the Links title bar. The Add New Link window
opens.

2. For Display text, enter Google.

3. For Link, enter www .google.com.

4. Click OK to add the Google® link to the Links list. If you have Internet access,

you can click this link to go to this website.
To delete a link:

1. Right-click the Google link and select Delete.
2. Click OK when asked to confirm the deletion.

Note that there is also an Edit command on the menu, which you can use to modify
a link.
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Note

If you are using the Enterprise Edition, two additional sections appear on the Start
Page: Workflow and Alerts.

Workflow

Workflow capabilities allow you to control your process flow by notifying
appropriate personnel when actions are required. By utilizing the Workflow
feature, you can effectively manage your processes to keep your reliability
activities on track.

The Workflow section of the Start Page displays all the workflow items assigned to
you. When you place the mouse cursor over an item in the Workflow list, a popup
window displays the email message associated with that workflow item. If you
click an item in the list, Windchill Quality Solutions opens the corresponding file
and displays the associated data.

Alerts

The Alert application automatically notifies users when specified events occur. By
monitoring your reliability data, this application detects when key events occur and
then automatically sends out alert emails.

Similar to the Workflow section, the Alerts section displays all alerts that have been
sent to you. Simply place the mouse cursor over an item in the Alert list; a popup
window displays the email message associated with that alert item. When you click
an item in the list, Windchill Quality Solutions opens the corresponding file and
displays the associated data.

Start Page Additional Features

The Start Page includes the following additional features.

Expand/Collapse

In the right corner of each section's title bar, notice the small icon that looks like
two arrows. This is the Expand/Collapse button. If you want to collapse a
particular section of the Start Page, click the collapse button &l o expand the

section back, click the expand button 9]
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Refresh

On the upper right side of the Start Page, there is a Refresh link. If you click this
link, the Start Page is updated with the most current information.

e

e
Customize

In the Enterprise Edition, the Customize link appears to the right of the Refresh
link. If you click this link, the Customize Start Page window opens. In this

window, you can selectively enable and disable the five sections that appear on the
Start Page in Enterprise Edition: Recent Files, Announcements, Workflow, Alerts,

and Links.

Note
The Customize link appears only in the Enterprise Edition.

O O Logged in as Admin | Change Log-in

Link Bar

In the header area of the Start Page, a number of icons and links appear on the
rightmost side.

@ O Logged in as Admin | Change Ln@

Refresh Customize

«  The about icon € displays information about your software.

» The help icon & opens the Help.

* In the Enterprise Edition, the Logged in as information displays the user name
you used when you logged in to this session.

* In the Enterprise Edition, the Change Log-in link allows you to change your
login to a different user without having to restart.

Note

The Logged in as option and Change Login link appear only in the Enterprise
Edition.
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Let’s put some of these features to use.

1. Click the about icon  to open the About Windchill Quality Solutions window.

When using this type of window, you can click any item in the left pane to
change the contents in the right pane so that the selected property page is
shown.

a.

f.

If the Copyright page is not selected, select it. You can see the copyright
notice about your software.

Select the License page. If you are running a licensed version, your
Customer ID, Serial Number, and Edition are displayed.

Select the Authorized Options page. On this page, you can see all the
modules that you can activate.

Select the File Versions page. You can see a listing of the Windchill Quality
Solutions files and their identifying version numbers and dates.

Select the My Data Directories page. You can see the where your data files,
Library files, and personal options are stored.

To close the About Windchill Quality Solutions window, press OK.

2. The help icon @ activates the HTML-based help system installed with your
software.

For more information, see “Windchill Quality Solutions Documentation and
Help” in the “Welcome!” section of the help.

Project Navigator

At the heart of Windchill Quality Solutions is the Project Navigator.
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The Project Navigator allows you to easily open Projects and files, generate reports
and graphs, create files, and access many other frequently used functions from a
single location. The following section describes the Project Navigator.

Project Navigator - #

B4 Create new Project
] Create new file
£ Collapse files

Projects

G < Click to close Project »

B &5 Project: My Tablet PC
=@ Systems
Tablet PC
E Reports
Support Files

¥ My Filter File

The Project Navigator is an auto-hide window. Initially, it is in auto-hide mode. A
tab for sliding this window out into view is located on the left side of the main
window.

Windchill Qui

-
i
O
@
5]
a
z
w
=
@
m
o
S
-=

= Recent Files

File Name

Tablet PC

When you place the mouse cursor over this tab, the window slides into view. When
you move the mouse cursor outside of the Project Navigator window (or any

window operating in the auto-hide mode), the window slides out of view. Thus, the
Project Navigator can easily be shown when you need it, then hidden when you do

not.

You can also dock the window, so that it is always available to you. To take the
window out of the auto-hide mode:

1. Place the mouse cursor over the Project Navigator tab to bring the window into
view.

2. Click the pushpin icon # in the upper right corner of the window.
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The pushpin icon changes to a vertical orientation (), indicating that the
window is now “pinned” into place. This means that the Project Navigator does
not slide out of view when you move the mouse cursor outside of the window.
Any time the pushpin icon in the upper right corner of an auto-hide window is
shown vertically, the window is pinned into place.

To unpin the window and put it back into auto-hide mode, click the pushpin icon
% again. The pushpin icon changes to a horizontal orientation ( #), indicating that

the window is now operating in the auto-hide mode.

You can either keep the Project Navigator in the auto-hide mode, sliding it in or out
of view as needed, or dock it into place in the main window. Select the setting that
you prefer.

With the exception of the Project Navigator, auto-hide windows can be closed by
clicking the x in the upper right corner of the window.

Working with Projects

Your starting point is the Project. The Project contains the framework in which you
enter data, run calculations, generate reports and graphs, and perform all of your
reliability analysis tasks.

In some cases, you may want to start with a new Project. In other instances, you
may want to create a Project based on an existing Project.

We begin by creating a Project.
Note

If someone has previously run through the Windchill Quality Solutions Getting
Started Guide using the same copy of the software, the Project My Tablet PC would
be listed in the Project Navigator and/or the Recent Files list on the Start Page.
Before running through the rest of this guide, delete this Project by right-clicking
on the Project name in the Project Navigator and selecting Delete.

Creating a Blank Project

1. In the Project Navigator, click Create new Project.

Project Navigator A

@Create new Proj@

1 Create new file
# Collapse files
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When the Create Tryout Project window opens, the Directory and Name fields
are filled in.

In the Name ficld, enter My New Project.
Select Run New Project Wizard.
Click OK.

Note

If a Project with this name is found, Windchill Quality Solutions displays a
message that the Project already exists. You would need to either cancel the
Project creation or enter a different name to create the Project.

The New Project Wizard starts and displays the Select Project Starting Point
page.

Select Create a new Project and click Next. The Select Project Modules page
appears.

You can use the Select All and Clear All buttons to select or clear all check
boxes. Repeatedly clicking a check box switches between selecting and
clearing it.

Click Select All and then click Next. The Set Project Properties page appears.
For this Project, accept the defaults.

Click Next. The Select Common Library Files page opens. It lists all of the files
in the Common Library, a special Project where you keep the files that you
want available to all Projects that you create. All of the supplied Report Design
and Graph Template files are included in the Common Library by default. For
this Project, accept the defaults.

Click Next. The Specify FMEA Setup page appears.

9. Use the default selection of Set up FMEA now and click Next. The Select FMEA

10.

11.

Worksheet Type page appears.

The FMEA Worksheet Type allows you to select from a set of supplied standard
FMEA layouts for performing your FMEA (Failure Mode and Effects
Analysis) tasks.

Use the default selection of FMEA Standard Template, and then click Next. The
Select FMEA Modes Library page appears.

The Select FMEA Modes Library allows you to select from the list of FMEA
Modes Libraries to use when performing component FMEAs.

Use the default selection of FMD97 Modes - Tryout; then, click Next. The Set
FMEA Options page appears.

This page enables you to specify whether any local effects that are entered
during FMEA data entry are automatically rolled up as failure modes at the
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next level of your FMEA hierarchy. You can also enable the display of tables
for control plans and DVPs here.

12. For this example, make sure all check boxes are cleared so that modes are not
rolled up and control plans and DVP are not enabled. Then, click Next. The
Wizard Complete page appears.

13. Click Finish to complete Project creation.

Progress indicators appear as the Project is created and opened. Once the
process is completed, an empty System file opens.

14. Slide the Project Navigator into view. Your newly created Project is now open
and appears in the Project Navigator list. You can see the name of your new
Project in the top heading designated by the open folder icon - My New Project.

Project Navigator ~H

i Create new Project
1 Create new file
# Collapse files

Projects

O < Click to close Project » -

El &5 Project: My New Project
EG| Systems
My New Project

] Reports
I:i Graphs
Support Files

S My Filter File

The term Project is used to denote the entire entity that encompasses all of your
analysis files. For example, in the Project Navigator, you can see Systems,
Reports, and Graphs headings. These are some of the types of files that are
contained in your Project.

The first heading, Systems, refers to the main files which contain reliability
analysis data. For example, all of your data is stored in System files. In this
case, you can see one System file listed: My New Project. You may have
more than one System file open in a Project; in this case, we only use one.

The other files in your Project, such as Reports and Graphs, are used to support
your reliability tasks, such as generating reports and graphical outputs of your
data.

15. Slide the Project Navigator out of view. Because your new System is empty,
there is no data displayed in the windows.
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Closing a Project File

Close the My New Project Project.

1. Slide the Project Navigator into view.
2. Click Click to close Project.

The Project Navigator shows a list of Projects, which includes the supplied samples
as well as the new Project that you just created.

Opening a Project and System File

To open a System file, follow these steps:

1. In the Project Navigator, under My New Project, click My New Project to open
your System file.

2. Once again, close your Project by clicking Click to close Project in the Project
Navigator.

Notice that My New Project appears in the Recent Files list on the Start
Page.

Tip
Clicking the links in the Recent Files list is another way to open Project and
System files.

Creating a Project from an Existing Project

In some cases, you might want to create a new Project from an existing Project.
The existing Project can be one you set up yourself or it can be created from a
supplied template. Windchill Quality Solutions includes both sample Projects and
templates that can be used as a starting point for creating your own Project. You
may find they are close to what you require and only need some minor
modifications.

This topic describes how to create a Project based on the Tablet PC Sample
Project. The new Project that we create in this section can then be used as a basis
for the remainder of this guide.

1. In the Project Navigator, click Create new Project. The Create Tryout Project
window opens.

2. In the Name field, enter My Tablet PC.
3. Select Run New Project Wizard.

4. Click OK. The New Project Wizard starts and displays the Select Project
Starting Point page.
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If a Project with this name is found, a window appears with the message that
the Project already exists. You can either cancel the Project creation or enter a
different name to create the Project.

5. Select the Create from a Sample Project option and click Next. The Select
Project page appears.

6. Select the Tablet PC Sample Project and click Next. The Wizard Complete page
of the wizard appears.

7. Click Finish to complete Project creation.
Progress indicators appear as the Project is created and opened. Once the process is

completed, the System file opens and shows all of the data from the System file in
the Tablet PC Sample Project.

Module Selections Toolbar

In the procedures in this guide, we make use of the Module Selections toolbar. This
toolbar is enabled by default and appears in the toolbar area at the top of the
window.

D L0 A G a\@: Lil

The Module Selections toolbar allows you to activate and deactivate modules.
Using this toolbar enables you to concentrate on the modules you are actively
working with, making your desktop easier to navigate. For this guide, we activate
one module at a time in order to show only the windows associated with the
modules we are actively working with.

If you selected only the Prediction button in the Modules Selection window when
first starting Windchill Quality Solutions, only the Prediction button is enabled.
The buttons for enabled modules are highlighted.

1. Click the FTA icon A on the Module Selections toolbar to enable Windchill
FTA along with Windchill Prediction.

With both Windchill FTA and Windchill Prediction enabled, tabbed windows
for both of these modules are shown.

(\I
2. Click the Prediction icon /Q to remove the Windchill Prediction windows.

You can also hide and show the windows associated with particular modules
using the first button on the toolbar. The tooltip for this button indicates that it
opens a window for configuring selected modules.

©

3. Click the all modules icon on the Module Selections toolbar.
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A window opens for making multiple module selections.
4. In this window, do the following:

a. Click Clear All.

b. Click Prediction.

c. Click OK.

Moving On

This section introduced you to some of the introductory features of Windchill Qual-
ity Solutions. You can now explore some of the features common to all of the
modules.
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Windchill Quality Solutions supports a number of features common across all
modules. You can run calculations, view outputs such as graphs or reports, import
information from files, filter for desired data, and customize tables.

Although the functions covered in this section are available across all modules,
they are covered here, rather than in the specific module sections, in order to avoid
the constant repetition of these common tasks. Instead, this section uses Windchill
Prediction as a starting place for reviewing this functionality.

Note
Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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Getting Started

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill Prediction module.

For more information, see Starting Windchill Prediction on page 24.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If'the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill Prediction

On the Module Selections toolbar at the top right of the window, make sure the

-
Prediction icon Aﬁ 1s selected and all other module icons are deselected.
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Tour of the Interface

When you open a system, the tables and forms for the selected module(s) appear
by default in the upper and lower panes of the main window. When multiple tables
and forms are available in either the upper or lower pane, tabs are shown. To
display the window for a particular table or form, select its tab.

In the Prediction module you are currently viewing, you see the System Tree Items
in the top pane and information for the selected system tree item in the bottom
pane; the type of information displayed in the bottom pane depends on the tab
selected. These are the default views; however, almost all elements of your user
interface can be customized. You customize the appearance of your tables in a later
section.

Reviewing Data

In the System Tree Items table, select the Motherboard assembly.

2. Ifnecessary, select the Prediction Parts table in the lower pane to make it
active. The list of parts that make up the Motherboard assembly is shown.

3. In the Prediction Parts table, click the Static RAM part. This part has a part
number of SRAMO31.

4. Review the fields available in the Prediction Parts table. You can see that this
part is a memory device. There are four of these parts on the Motherboard,
which are assigned reference designators of U3 through U6.

Click Prediction Data to view the specific parameters associated with this part.

Click General Data to view the general data associated with this part.

Performing Calculations

To perform calculations:

1. Select System » Calculate, or click the calculate = icon on the Standard

toolbar. The Calculate window opens.
In the left pane, select Calculation Selection (if necessary).

In the right pane, click Clear All and select Prediction to perform calculations
only for the Prediction module.

4. In the left pane, select Prediction.

Leave Mission calculations selected and all other check boxes cleared.
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6. Leave Derating calculations set to Nominal and Mission profile set to Default
Profile.

?1 Prediction Calculation Options

=Fl -4 e M
|| Mission calculations

Derating calculations: [Nominal V‘

Mission profile: [Defath Profile V‘

7. Click OK to perform the calculations. The Calculation Progress pane opens and

displays status information. When the calculations are complete, the View
Calculation Results window opens.

Tip

You can print your calculation results by clicking Print in the View Calculation
Results window. You can also save them to a Microsoft® Excel® spreadsheet
by clicking Excel.

8. Click Close when you have finished reviewing results.

To redisplay the results at any time, select System > View Calculation Results. If
you have only one module enabled, the results are displayed for that module. If
you have more than one module enabled, select the appropriate page to view the
results. When finished, click Close.

Generating Reports

The reporting capabilities within Windchill Quality Solutions are extensive, and
include the ability to view a report, print a report, generate a report to a file, and
create a custom report. We begin by selecting one of the supplied Report Designs
to generate a report.

Viewing a Report

1. In the Project Navigator, under Reports > Prediction Reports, select (Common)
Prediction (Summary) to generate this default report in the Preview window.

This report outputs data on all assemblies in the System file, including
assembly names, part numbers, reference designators, quantities, and
calculation results for failure rate and MTBF.

You can use the various toolbar buttons in the Preview window to page through
your report, zoom in and out, and print the report.
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2. When finished viewing the report, do one of the following to close the Preview

window:

* Select Preview » Close.

¢ Click the close icon EI on the toolbar.

Alternatively, you can preview a report by selecting File > Print Preview.

Printing a Report

When previewing a report, you can print it by clicking the print icon =l in the
Print Preview toolbar.

You can also print directly to a printer:

1. Select File » Print. The Select Report to Print window opens.
2. Select the appropriate report.

3. Click OK. The Print window opens and allows you to select the printer.

Generating a Report to a File

You may also print a report to a file, which is useful if you wish to email report
files to colleagues or save report files for later viewing. Windchill Quality Solu-
tions supports several file formats for reports.

1. Select File » Print. The Select Report to Print window opens.

Select (Common) Prediction (Summary).

2
3. For Print to file, click the browse icon ==/ to display the Print to File window.
4

For Save as type, select a file format that you know you can view on your

computer. For example, if you have Adobe Reader installed, you can select
PDF Format (*.pdf). If you have Microsoft Word installed, you can select

Microsoft WordDocument (*.doc). If you are unsure, select Rich Text Format(*.

rtf).
For File name, enter My Reliability Prediction.

Ensure Open file in editor after printing is selected.
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Note

If you were unsure in step 4 whether you have the correct application needed
for viewing the file, such as Microsoft Word® or Adobe® Reader®, please
clear Open file in editor after printing. If this option is selected and the
appropriate viewing application is not installed, the file is created, but it cannot
be opened on-screen.

Click Create. The Select Report to Print window becomes active again, with
the Print to file field completed appropriately.

Click OK. Progress bars appear while the report file is generated and opened in
the associated application.

When you have finished viewing this file, close the application. Or, if the file is
opened in the main window, select File » Close.

Creating Custom Reports

The Report Wizard enables you to easily create custom Report Designs to use. The
wizard provides a step-by-step process to walk you through a series of questions
regarding the Report Design to create. Once you have created a Report Design,
you can save it for continued use.

1.
2.
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To start, select the Prediction Parts table in the lower pane to make it active.

Select Tools » Report Wizard. The Report Wizard starts, and the Select Data
Fields page appears.

Notice that the fields that are shown in the Prediction Parts table are
automatically selected for you. The Report Wizard initializes the selected fields
based on the table or form you have selected to ease the creation of the Report
Design.

For Table type, sclect Prediction Parts. Ensure the selected fields include Name
(Prediction Parts), Part Number (Prediction Parts), and Part Classification
(Prediction Parts). If this is not the case, click Cancel to exit the Report Wizard

and start over at step 1 again.

For Selected fields, select Part Classification (Prediction Parts) and click
Remove to remove it from the list.

Also remove the following fields:
¢ Calculation Model (Prediction Parts)
¢ Tagged Part? (Prediction Parts)

* Failure Rate, Percentage (Prediction Parts)

Make sure the following fields are in the Selected fields list: Name
(Prediction Parts); Part Number (Prediction Parts); Category (Prediction
Parts); Subcategory (Prediction Parts); Reference Designator (Prediction
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Parts); Quantity (Prediction Parts); and Failure Rate, Predicted (Prediction
Parts).

Click Next. The Select Filter page appears.

6. For Filter, leave — No Filter — selected and click Next. The Specify Data
Grouping page appears. Here you can group data into categories.

For example, if you selected to group based on the field Category, your report
would show all integrated circuits together in a section, all resistors together in
a section, etc. For this example, we do not group items in any way.

7. Leave Selected fields blank and click Next. The Specify Sort page appears.

In the first selection box, select Failure Rate, Predicted (Prediction Parts). Clear
the Ascending check box so that the failure rate data is sorted in descending
order; then, click Next. The Select Layout page appears.

9. For Layout, select Horizontal.

10. For Orientation, select Landscape, then click Next. The Report Style page
appears.

11. Select Corporate and click Next. The Report Title page appears.

12. For the Title, enter My Prediction Report and click Next. The Wizard
Complete page appears.

13. Click Finish. The report is generated and displayed on-screen, where you see a
listing of all parts in order of descending failure rate.

You may notice a few items you want to modify in the Report Design. For
example, perhaps you want to rename a column heading to make it more
descriptive or to shorten it.

Also, notice that some columns are wrapping. In this case, you can choose to

edit the Report Design to change the width of these columns. The Report
Wizard is designed to create a Report Design file similar to what you want,

which you can then modify to suit your needs. Though you can directly place
data fields onto your report using the Report Designer, the Report Wizard is far
more efficient. All you need to do is modify the resulting Report Design file to
make the necessary minor adjustments.

14. Select Preview > Close to close the report preview. The Report Design file
remains open.

In the Report Design view, you can see the layout used to generate the report.
In the Design view, you can do things like add new data fields, delete fields,
change column widths, rename column labels, and change the report heading,
as well as change colors, fonts, and other visual properties. You can also access
more advanced features such as sorting, grouping, and filtering data, and
defining formulas to be used on reports. The Report Designer is extremely
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powerful and supports a wide array of features and functions that enable you to
completely customize reports to suit your needs.

15. At this point, you can choose to save the Report Design file. To save the Report
Design file:

a. Select File » Save As. The Save File As window opens.
b. For Name, enter My Prediction Report and click OK.

c. Select File » Close to close the Report Design file. If you are asked if you
want to save your changes, click No.

Your new Report Design file is now available in the Project Navigator under
Reports > Prediction Reports. To regenerate this report at any time, select the report

name in the Project Navigator.

Reports can also include subreports, grouping, sorting, as well as embedded
calculations. For more information on all the reporting features and functions
available, please refer to the help.

Creating Graphs

Windchill Quality Solutions has an extensive array of impressive graphical
capabilities, including the ability to view a standard graph or create a custom
graph. You begin by viewing one of the supplied graphs.

Viewing a Graph

1. In the Project Navigator, under Graphs > Prediction Graphs, select (Common)
Prediction FR v Temperature 3D to generate this supplied graph.

This graph displays as a three-dimensional line graph the predicted failure rate
for each assembly in the system tree for a range of temperatures from 0 to 100
degrees C, in increments of 10.

2. When finished viewing the graph, do one of the following to close the graph.
» Select File » Close.

* Click the X in the upper right corner of the window.

Alternatively, you may select Tools » Graph or click the graph icon @ on the
Standard toolbar. When the Select Graph Template window opens, select the

appropriate graph.
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Creating a Custom Graph

The Graph Wizard enables you to easily create custom graphs of your System data.
The Wizard walks you through a series of questions about the graph you wish to
create. Once you have created a graph, you can save the selections you have made
to a Graph Template file, which enables you to quickly recreate the same graph at a
later time.

1.

Select Tools » Graph Wizard. The Graph Wizard starts and displays the Load
Graph Template page.

2. Select Create a custom graph and click Next. The Prediction Graph Type page
appears.
3. Select Calculation result by System Tree item (uses last calculation result) and
click Next. The Select Calculation page appears.
Select Failure Rate, Predicted and click Next. The Filter Data page appears.
Select Graph only assemblies and click Next. The Graph Options page appears.
The default type is a cylinder bar graph.
6. For Graph title, enter My Prediction Graph.
7. Select 3D and Pareto. Leave all other options cleared.
8. Click Next. The Save Graph Template page appears.
9. To save the settings to a Graph Template file, do the following:
a. For File name, click the browse button “**!. A window opens, listing all
existing Graph Template files.
b. Click < Create new file > and enter My Prediction Graph.
)
c. Click the green checkmark .
d. Make sure the Create corresponding Report Design file check box is
cleared.
10. Click Next. The Wizard Complete page appears.
11. Click Finish to generate the graph.
The resulting graph shows the assemblies in your system ordered by overall
failure rate. This is a good way to see the items in your system that contribute
the most to overall system failure rate.
Modifying the Graph

You can rotate your 3-D graphs while they are displayed to view your graphs from
different angles.
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Select Graph » Enable Mouse Rotation to allow rotation of your graph.

2. Move the mouse cursor into the Graph window. The cursor changes to a hand
Cursor.

3. Hold down the left mouse button and move the mouse cursor to change the
angle of your graph. While moving, the graph appears unclear. Once you
release the mouse button, the graph redraws clearly.

Select Graph » Enable Mouse Rotation again to turn off mouse rotation.

You can also modify the appearance of your graph. In the Graph window, right
click and select Properties to bring up the Graph Properties window. You can
view the many graph settings that you can modify. Click Cancel to close the
Graph Properties window.

Select File » Close to close the graph.

If you are asked if you want to save your changes, click No.

Filtering Data

When viewing your System data, you may want to view a portion of all the items
in your Project. With large quantities of data, filtering techniques enable you to
display a subset of items that are of interest to you. Filters can be applied not only
for viewing purposes but also prior to performing calculation, reporting, and
graphing functions.

The filtering capabilities enable you to view items matching a certain parameter or
multiple parameters, find a specific item or set of items based on a parameter
entered “on the fly” and even sort items. It is helpful to experiment with the
filtering features.

Windchill Quality Solutions supports both fixed-value filters and parameterized
filters. When you create a parameterized filter, you must supply a parameter value
when the filter is applied. You can also build filters with multiple parameters.
When building a parameterized filter, be aware that the request for a parameter
value occurs whenever the filter is used, even during report or graph generation.

Using Predefined Filters

Windchill Quality Solutions includes a number of predefined filters that can be
applied.

1. Inthe System Tree Items table, select Motherboard.

2. Select the Prediction Parts table. The list of parts in the Motherboard assembly
are shown.
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3. In the toolbar, use the Filter selection box to select the Reference Designator
filter.

Tip
If you do not see the Reference Designator in the Filter dropdown menu, ensure
you have the Prediction Parts table selected.

¥ - Mo Filter —-

.........

Q| Alternate Part Number
IQ| overstressed

Q| Part Number

‘Q Reference Designator

Note

The filters available in the Filter dropdown depend on the pane or window
selected.

The Select Filter window opens. Since this type of filter is a parameterized
filter, you must supply a parameter before the filter can be applied.

4. For Reference Designator is equal to, enter U8 and click OK.

The item with the matching reference designator appears in the Prediction Parts
table. If you place the mouse cursor over the filter icon ¥ in the upper left
corner of the Prediction Parts table, parameters for the filter are shown as a

tooltip.

Parts Table
Filter M = 8 2 5 2 5 2 5
5 | Name Part Number | Part Classificat... | Category
1 Reference Designator is equal to 'U8' And Parent Assembly is equal to |rcuit

'MBOB0415’

*

5. Use the Filter selection box to select the — No Filter — option and remove the
applied filter.

Creating Custom Filters

You can create custom filters for ad hoc queries. To create a custom data filter:

1. Select the Prediction Parts table.

2. Select Filter » Filter Wizard. The Filter Wizard starts and displays the Specify
Filter Features page.

3. Select Selects records only and click Next. The Specify Filter Field page
appears.

4. For Select the table type, select Prediction Parts.
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I1.
12.

13.
14.
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From the list of data fields, select Temperature Rise and click Next. The
Specify Condition page appears.

Select is greater than or equal to and click Next. The Specify Field Value page
appears.

Select Use a fixed value (specify the value below).

For Specify the value here, enter 20 and click Next. The Review Filter page
appears.

Leave |1 want to add more conditions to the filter clear, to indicate that the filter is
complete and click Next. The Save Filter page appears.

Select | want to save my filter for later use.
For Filter name, enter Prediction - High Temperature Parts.
Select Save filter to My Filter File.

You have the option of saving filters to two different locations.

» Ifyou select Save filter to My Filter File, your new filter is stored in a file
accessible only to you; the filter is not accessible to other users with filter
permissions.

» Ifyou select Save filter to the Filter File in this Project, the filter is accessible
to other users with filter permissions.

In some cases, you may be creating a filter that is for your own use. In that
case, it is best to save it to the My Filter file. In other cases, if you are
creating a filter you know would be helpful to all team members, save it to
the Project Filter file to allow everyone to use it.

Click Next. The Wizard Complete page appears.
Click Finish.

If this is the first time you have saved a filter, Windchill Quality Solutions asks

to create a Filter file in which to store your newly constructed filter. In the
Create Support File window, click Yes to create this Support file. If you have

previously created a Filter file, this message does not appear. If a message

appears asking you if you want to overwrite or use the existing file, select the
Use Existing option.

The filter is applied to your data so that all parts with a temperature rise of 20

degrees Celsius or higher are shown. Your new filter is shown in the Filter
Selection box. Notice that when you drop down the list in the Filter Selection

box, your new filter, Prediction - High Temperature Parts, is preceded with a
person icon instead of a Windchill Quality Solutions icon. This indicates that
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the filter is stored in your My Filter file and not the Project Filter file, because
Project filters are preceded with a folder icon.

15. To return to the original data view, select — No Filter — in the Filter selection
box.

You can also modify your filters. Open the Filter file by selecting the Filter option
under the Support Files>Setup headings in the Project Navigator. New filters can
then be added directly to the Filter file.

Additionally, you can quickly build filters using the Filter Bar, which is located
above the column headers of the table. You can use the Filter Bar to sort records
and/or select the data to be shown in the table. You can also save filters created
using the Filter Bar by clicking the save icon ™ at the top left of the Filter Bar.

Parts Table
Filte@ =l

g
al 'Microprocessor

Customizing Tables

Virtually all tables in the System file can be customized using the Format Builder,
which enables you to easily change the layout of your tables.

For this example, we modify the layout of the Prediction Parts table.

1. Right-click the Prediction Parts table and select Format Builder. The Format
Builder opens and displays all of the fields available for insertion in the table.

The checkboxes to the left of the fields indicate which fields are shown in the
table. If the checkbox is cleared, the field is not shown.

2. Select the 217 Quality check box. The Prediction Parts table is updated to

include this column at the end. If you cannot see the last column, use the scroll

bar to view it.
3. Now, clear the 217 Quality checkbox to remove this field.
4. Close the Format Builder.

When you use the Format Builder, fields are inserted at the end of the table. If a
column is not in the desired location, you can click and drag it to where you want
it.
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Importing Data

The Import Wizard enables you to easily import data into your System by asking
you a series of questions about the data that you wish to transfer. When you have
completed the process once, you can save the selections you have made to an
Import/Export Template file. This template enables you to perform the same import
or corresponding export process later without needing to complete the wizard.

For this example, we import data into a new System file.

1.

10.
I1.

12.
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Under Navigator Tasks in the Project Navigator, click Create new file. The
Create File window opens. The Project field is automatically filled in with the

current Project.

Set the File type to System. For Name, enter My Imported Data and make
sure the Run Create File Wizard option is cleared. Click OK to create and open
the new System file.

Select Tools > Import Wizard. The Import Wizard starts and displays the Load
Template page.

Select Perform a custom import and click Next. The Select Source File page
appears.

For Source file name, click the browse button ===/, The Open window opens.
For Files of type, choose Microsoft Excel.

Navigate to the My Tablet PC directory under your

My Windchill Quality Solutions Files directory. Select
ReliabilityPredictionlmport.xls and click Open. You are returned to the Select
Source File page, where the selected file and its directory location are shown.

Click Next. The Specify Worksheet Format page appears.

Leave First row of cells has column names selected and click Next. The Select
Data Type page appears.

Select Parts only and click Next. The Select Import Type page appears.

Select | want to add records and click Next. The Select Field Assignments page
appears. In this page, you map the data being imported to Windchill Quality
Solutions fields. The first column is automatically selected.

Map the data:

a. For Data field, select Part Number. The column heading of the first column
changes to Part Number.

To make selections, you can either scroll through the Data Field choice list,
or you can type in the letters of the field name until the correct match is
located.

b. Click the second column and, for the Data field, select Quantity.
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c. Click the third column and, for the Data field, select Reference Designator.
d. Click the fourth column and, for the Data field, select Name.

13. Click Next to indicate that mapping is complete. The Save Template page
appears. For this example, we do not save our selections to an Import/Export
Template file.

14. Click Next. The Wizard Complete page appears.

15. Click Finish. Importing begins and the Parent Assembly Selection window
opens.

16. Select System as the parent assembly and select Do not ask me this again. Use
the current selections as the default. This lets the Import Wizard know which

parent assembly you want to associate the new imported parts with.

17. Click OK to continue the import. When the import is complete, the Import/
Export window shows “Import completed.” If errors or warnings occur during

your imports, you can select the View Log button to review them. In this case,
there are no errors or warnings, and all parts were imported.

18. Click Close to dismiss the Import/Export window. You can see the newly
imported parts in the Prediction Parts and System Tree Items tables.

19. When you are finished reviewing your new data, select File » Close.
For this example, we are going to delete the newly created System file.

20. In the Project Navigator, right-click the System file named My Imported Data
and select Delete.

21. When asked if you are sure, click Yes.

Moving On

While these two introductory sections introduced you to some basic features,
Windchill Quality Solutions offers an extensive array of additional capabilities to
explore. By completing this section, you have a foundation on which to move
forward into any of the following sections about the analysis modules. These
sections assume that you have successfully completed this section and are
comfortable with the features described.

At any time during operation, help is available. To access the help at any time, do
one of the following:

* Click the help icon @ on the Start Page.
» Select Help » Help.
* Press the F1 key to display context-sensitive help.
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about reliability predictions and how to perform this type of
analysis using Windchill Prediction. In this section, you learn how to enter data,
perform calculations, and view outputs such as reports and graphs.

Note
Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.

39



Reliability Prediction Overview

Reliability prediction is a quantitative analysis technique used to predict the failure
rate of a system based on the components of the system and its operating
conditions. A reliability prediction is typically performed using an accepted,
published handbook, which defines failure rate equations for various components
used in the system design. These equations were developed by using statistical
techniques to analyze failure data gathered on actual operating equipment. The
equations take into account the various parameters, such as part quality and
operating stresses, which have an effect on component reliability.

To begin a reliability prediction analysis, you must first define your system and all
of its component parts. You then use the model equations to determine the failure
rate of each particular component in your system. To get the overall system failure
rate, you add up all the component failure rates.

For example, consider a system that is comprised of subsystem A and subsystem
B. Assume subsystem A has 5 parts, each of which has a predicted failure rate of 1
failure/million hours obtained from using failure rate equations from a selected
handbook. Assume subsystem B has 5 parts, each of which has a failure rate of 3
failures/million hours, computed using the same handbook. The failure rate of
subsystem A is 5 failures/million hours and the failure rate of subsystem B is 15
failures/million hours. Thus, the failure rate of the overall system is 20 failures/
million hours.

Doing this analysis by hand can be tedious, time-consuming, and error prone.
Using a software application such as Windchill Prediction to perform this work can
dramatically increase the efficiency and accuracy in performing analyses.

If you are unfamiliar with reliability prediction analysis and would like to study
this topic in more detail, the following selections are excellent references:

* Reliability: A Practitioner's guide (Chapter 3)

» Practical Reliability Engineering by Patrick D.T. O'Connor, 4th edition, John
Wiley & Sons Ltd. (2002)

» The specific reliability prediction handbook of interest to you. For details, see
the “Ordering Reliability Standards” help topic.
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Getting Started with Windchill Prediction

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill Prediction module.

For more information, see Starting Windchill Prediction on page 41.

If Windchill Quality Solutions is not started
If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» Ifthe Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

» If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill Prediction

On the Module Selections toolbar at the top right of the window, make sure the

9
Prediction 1&5 button is selected and all other module buttons are deselected.

The tabbed panes for the Prediction module are shown in Windchill Quality Solu-
tions window.
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Using Windchill Prediction

In the top pane, the System Tree Items table shows the hierarchical breakdown of
your system. In the bottom pane, the Prediction Parts table shows a complete
listing of all the components in the assembly selected in the system tree.
Depending on whether an assembly or part is active, the bottom pane may also
display additional tabbed panes.

When an assembly is selected in the System Tree Items table, the General Data

pane displays general information about the selected assembly, and the Calculation
Data pane displays the calculation parameters to be used for the selected assembly.

When a part is selected in the System Tree Items or Prediction Parts tables, the
Prediction Data pane displays calculation parameters to be used for the selected

part, and the General Data pane displays general information about the selected
part.

Reviewing Prediction Data

1. In the System Tree Items table, select the Motherboard assembly.

2. Select Prediction Parts. The list of parts that make up the Motherboard
assembly is shown.

3. In Prediction Parts, click the Static RAM part with a part number of SRAMO31.

4. Review the fields available in Prediction Parts. You can see that this is a
memory device. There are four of these parts on the Motherboard.

Select the Prediction Data tab to view the parameters associated with this part.

Click Pi Factors to display the factors used in the equation for computing the
failure rate of this part. In the Pi Factors window, you can also see the failure
rate of the part. For information about how these factors are computed, as well
as the failure rate equations, refer to the help.

7. Click Close to close the Pi Factors window.

Entering Assemblies and Parts
Perform the following steps to enter a new assembly and its parts:

1. In the System Tree Items table, select the Hard Disk Assembly assembly.

2. Select Insert > Sibling Assembly to insert a new assembly at the same level as
Hard Disk Assembly. Inserting a child assembly inserts an assembly one level
below the currently selected assembly.

For Name, enter My Demo Assembly for the new assembly.

Select the Prediction Parts table. Notice that there are currently no parts in the
new assembly.
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12.

13.
14.

In the empty row, leave the Name field blank, enter ABC as the Part Number,
and press Tab.

The first time that you enter a part number, Windchill Prediction initializes all
the Prediction Parts Libraries that are enabled for searching. As a result, this
first entry may take a few moments.

If not already selected, for Part Classification, select General.
For Category, select Integrated Circuit.
For Subcategory, select Logic, CGA or ASIC.

For Reference Designator, enter U27.

. Select the Prediction Data tab. All the data fields are blank. To accurately

compute a failure rate, correct values should be entered in these fields.
Click Defaults.

A number of data fields are now filled in with values. These values represent
average values for these fields; the calculation engine uses these average values
if you do not enter specific data values. Because Windchill Prediction uses
typical values for this part to produce preliminary failure rate estimates, using
these default values is a good way to start your analyses. As data becomes
available, you can go back and enter it on the Prediction Data tab.

Click Defaults again to hide the default values from view.

The Defaults button is there only for informational purposes. Windchill Predic-
tion automatically uses the defaults “behind the scenes” during calculations,
and you do not need to click the Defaults button in order for this to occur.

Click Pi Factors to see the computed failure rate of your newly inserted part.

Click Close to close the Pi Factors window.

Using the Prediction Parts Libraries

A much more efficient way of entering parts is to use the extensive Prediction Parts
Libraries supplied with the Prediction module. These component databases include
hundreds of thousands of parts, along with the associated data needed for
performing reliability prediction analysis.

I.
2.

Select Prediction Parts.

In the empty row at the end of the table, for Part Number, enter 74L.S00 and
press Tab. The Prediction module searches through the Prediction Parts
Libraries and automatically fill in the appropriate part information.

Select the Prediction Data tab and review the data that has been automatically
entered. You can see that almost all of the data fields have been filled in. A few
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fields, such as InitialTemperature Rise, are dependent on the operating
conditions of your system, and you would need to enter these types of values.

Viewing the Parts in the Parts Libraries

In some cases, you may not know an exact part number. In these cases, you can
browse through the information in the Prediction Parts Libraries to select the

component.

1. Select Prediction Parts.

2. Right-click the table row with the asterisk (*) and select Browse Libraries. The
Library Browse window opens.
Leave Search for set to Prediction Parts.

4. For Part Number, enter 74HCT * and click Search.

Search L}

All parts that begin with 74HCT are shown in the Results table below.
In the Results table, scroll down to locate 74HCT373.

Click this row to see the associated part parameter values in the Preview pane
below.

Click the + Insert button in the Results pane to insert the part into Prediction
Parts on the right.

Tip

You may also drag and drop parts to insert them into Prediction Parts. Select

the desired part’s row in the Results pane and, holding down your left mouse
button, drag the part to Prediction Parts.

Filtering to Locate Parts

1.
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In the Search pane of the Library Browse window, for Part Number, clear the
field.

For Description, enter *transistor* and click Search.

The Results pane lists all the parts that include the text “transistor” in any part
of the Description field. As you can see, you can perform a wide variety of
filtered searches using all types of configurations for searching parameters.
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Entering Parts Using the NPRD/EPRD Libraries

Windchill Prediction also includes libraries of failure rates based on collected field
information on a number of electro-mechanical parts. This data is stored in
databases known as the NPRD and EPRD libraries. To access the data in these

libraries:

1. In the Library Browse window, for Search for, select NPRD Parts.

For Category, sclect Battery

2
3. For Subcategory, seclect General.
4

Click Search. The resulting matches for a general battery in the NPRD Library
appear in the Results pane.

Select NPRD-610 by clicking it.

Click + Insert in the Results pane to insert the part into the Prediction Parts

table.

7. Close the Library Browse window by clicking the X at the top right of the pane.

Performing Calculations

The Windchill Prediction tool calculates a number of metrics, including failure
rate, MTBF, reliability, availability, and MTTR, which are briefly described below.
For more information, see the help.

Calculation

Description

Failure Rate

In a reliability prediction analysis, failure rate is a value
which represents the number of failures likely to occur
over a time period, usually defined in units of failure per
million hours (FPMH) or failures per billion hours
(FITs).

For example, if a unit has a failure rate of 2 FPMH, that
unit is likely to fail twice in a million hours. Failure rates
are predictive values computed using equations based on
statistical field data analysis.

Mean Time Between
Failures (MTBF)

The Mean Time Between Failures (MTBF) represents
the number of hours a unit operates between failures.

For units which cannot be repaired once a failure occurs
(i.e. non-repairable units), the MTBF is equivalent to
Mean Time to First Failure (MTTF). Therefore, the
terms "MTBF" and "MTTEF" are sometimes used

Windchill Prediction

45



Calculation

Description

interchangeably, though the usage is not theoretically
accurate. In Windchill Prediction, however, the term
MTBEF is used.

Reliability

The probability that a system remains operational until a
specified time.

Reliability is a time-based probability value, so it is
always a metric between 0 and 1. A reliability of 0
means that a system is infinitely unreliable, or never
functioning. A reliability value of 1 indicates that a
system is infinitely reliable, or always operating.

Availability

The probability that a system is operating properly at a
specific time point. Availability, like Reliability, is a
time-based probability metric between 0 and 1.

Auvailability is a function of both reliability (how quickly
a system fails) and of maintainability (how quickly the
system can be repaired).

The common term "five nines" refers to a system which
has an availability of 0.99999, i.e. is operational
99.999% of the time.

Mean Time to Repair
(MTTR)

Mean Time to Repair (MTTR) is the average time it
takes to repair a failed unit and return it to an operational
state, based on the average repair time for its replaceable
components. The MTTR is calculated by rolling up the
average repair times for lower-level components to
subassembly and system repair values.

If Windchill Maintainability is used in conjunction with
Windchill Prediction, the MTTR values of components
and subassemblies can be obtained from Maintainability
computed MTTR values. Units for MTTR values are
typically hours or minutes.

MTTR is also referred to as Mean Corrective Time
(MCT).

Windchill Prediction can also compute these same measures utilizing mission
phases. To utilize mission calculations, you define a mission profile, which
describes the phases of a mission your system experiences. For example, the
mission of an airplane may consist of three phases — take-off, flight, and landing —
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each one involving different environments and conditions. You can also define
phases as dormant or active in order to factor in the lower failure rates experienced
during dormant phases.

The Prediction module performs mission-based calculations by factoring in the
environment, temperature, state (dormant or active), and percentage of time in each
phase. You can view the compiled metrics of the entire mission as well as
individual phase metrics.

Windchill Prediction supports derating analysis as part of prediction calculations.
Derating analyses allow you to assess which components in your system are
overstressed. You can use the results of derating analyses to ensure your system
components are operating within acceptable limits.

The Prediction module can also be used to compute reliability allocations based on
a variety of supported allocation methodologies. Reliability allocations allow you
to allot the MTBF values across the subassemblies and/or components of your
system, and then, based on specified weighting factors, calculate the projected
failure rate of the components and/or subassemblies within that system.

Reliability allocations are useful when you have reliability goals which must be
met. For example, if contractual requirements dictate that your overall system
MTBF must be at least 10,000 hours, you can split up that 10,000 hour goal across
the various items in your system based on a weighting system of your choosing.
Perhaps you allow one highly complex subsystem to meet a 5,000 hour MTBF,
while all other subsystems must meet a combined 5,000 MTBEF. In this way, you
can apportion MTBF goals to ensure that your overall objectives are met.

Running Calculations

To compute the predicted failure rate of your system:

1. Select System » Calculate, or click the calculate icon on the Standard

toolbar. The Calculate window open.
In the left pane, select the Calculation Selection page (if necessary).

3. In the right pane, click Clear All and select Prediction so that Prediction
calculations are performed.

4. In the left pane, select the Prediction page.

Leave Mission calculations selected and all other check boxes cleared.
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6. Leave Derating calculations set to Nominal and Mission profile set to Default
Profile.

?1 Prediction Calculation Options

=Fl -4 e M
|| Mission calculations
Il -

| | allacations

u Use alternate MIL-HDBK-217 resistor calculation

Derating calculations: [Nominal V‘

Mission profile: [Defauit Profile V‘

7. Click OK to perform the calculations. The Calculation Progress window
displays status information. When the calculations are complete, the View

Calculation Results window opens.

Tip

You can print your calculation results by clicking Print in the View Calculation
Results window. You can also save them to a Microsoft Excel spreadsheet by

clicking Excel.

8. Click Close when you have finished reviewing results.
To redisplay the results at any time, select System » View Calculation Results. If
you have only one module enabled, the results are displayed for that module. If

you have more than one module enabled, select the appropriate page to view the
results. When finished, click Close.

Viewing a Report

1. In the Project Navigator, under Reports > Prediction Reports, select (Common)
Prediction (Summary) to generate this default report in the Preview window.

This report outputs data on all assemblies in the System file, including
assembly names, part numbers, reference designators, quantities, and
calculation results for failure rate and MTBF.

You can use the various toolbar buttons in the Preview window to page through
your report, zoom in and out, and print the report.

="g €2 | gty | G @|

2. When finished viewing the report, do one of the following to close the Preview
window:
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* Select Preview » Close.

*  Click the close icon EI on the toolbar.

Alternatively, you can preview a report by selecting File » Print Preview.

Graphing Data

1. In the Project Navigator, under Graphs > Prediction, sclect (Common)
Prediction FR v Temperature 3D to generate this supplied graph.

This graph displays a three-dimensional line graph of the predicted failure rate
for each assembly in the system tree for a range of temperatures from 0 to 100
degrees C, in increments of 10.

2. When finished viewing the graph, do one of the following to close the graph.
* Select File » Close.
*  Click the X in the upper right corner of the window.

Alternatively, you may select Tools » Graph or click the graph icon i on the
Standard toolbar. When the Select Graph Template window opens, select the

appropriate graph.

Windchill Prediction Features

Many more features and functions are available within Windchill Prediction. A
brief listing of other topics of interest is shown below. To try out these features,
please refer to the help.

» Support for all current prediction standards, including MIL-HDBK-217,
Telcordia, PRISM, 217Plus, HRD5, RDF 2000, IEC TR 62380, NSWC
Mechanical, Chinese 299, Siemens SN 29500, and FIDES.

* For high-powered analyses, combine models within a Project, and apply
MTBF adjustment techniques such as PRISM Process Grades and Telcordia
Methods, across any model.

* Prediction Derating files store minimum and maximum derating criteria based
on the part type.

» Prediction Defaults files store default part parameters based on the part type.

» Prediction Values files store your own user-defined environments and quality
levels.

» Mission profile files store data associated with various mission phases,
including dormancy information and the total mission time.
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User-defined Prediction Parts Libraries can be created and saved and then used
along with Parts Libraries.

Prediction Correlation Library files allow you to search library components
based on in-house part numbers instead of manufacturer part numbers.

Prediction Process Grade files store a scoring profile whose total value is
translated into a quantitative Pi-factor multiplier that impacts the predicted
failure rate.

Prediction Bayesian files store test and field data in order to modify predicted
failure rates with known field data for more real-world predicted values.
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about a FMEA (failure modes and effects analysis) and how to
perform this type of analysis using Windchill FMEA. In this section, you enter
FMEA data, perform calculations, and view reports and graphs.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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FMEA Overview

A FMEA consists of breaking a system down into what can fail, how it can fail,
and why it fails, and then determining the effects of those failures on your system.
FMEAs can also include the analysis of criticality, and in this case is referred to as
FMECAS (failure mode, effects, and criticality analysis).

FMEAss are typically performed based on published standards or guidelines;
however, some organizations develop their own guidelines for FMEA. The most
common FMEA standards include MIL-STD-1629, various automotive FMEA
standards, and SAE ARP5580.

The FMEA process is a bottom-up approach to system analysis. The analyst begins
at the lowest level desired for analysis, such as a part or a step in a process, and
ascertains the possible failure modes associated with that item. The next step is to
establish, based on system knowledge, what the resulting effect of the failure
modes are. Along with each end effect, the analyst might also determine the
severity of that effect, the probability of occurrence of that effect, and how the
effect could be detected.

This process continues up the system tree until overall system end effects are
evaluated. Once this detailed analysis is complete, some type of ranking criteria is
employed. The ranking is then used to determine how critical failures can be
eliminated or the risks mitigated. The main objective of a FMEA is to evaluate all
parts of your system or process to ensure that system reliability and safety
objectives are met.

If you are unfamiliar with FMEA/FMECA and would like to learn more, the
following selections are excellent references:

» Reliability: A Practitioner's guide (Chapter 6)

* Failure Mode and Effect Analysis - FMEA from Theory to Execution by D.H.
Stamatis

* Failure Modes & Effects Analysis by Paul Palady

Getting Started with Windchill FMEA

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable Windchill FMEA; for more

information, see Starting Windchill FMEA on page 53.
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If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill FMEA

On the Module Selections toolbar, select the FMEA button Ej and deselect all
other module buttons.

The tabs for Windchill FMEA are shown in your System file.

Using Windchill FMEA

The top pane contains the following tabbed panes:

* System Tree Items, which shows the hierarchical breakdown of your system,
and which is shared with several other modules.

* FMEATable, which shows a list of all your FMEAs.

* FMEATree Items tab, which shows the hierarchical breakdown of your FMEA
structure. By default, the name of the FMEA Tree tab contains Functional,

Process, or Component to indicate the type of FMEA selected in the FMEA
Table.
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Additional tabs display control and DVP data.

The lower pane displays the FMEA Worksheet, where failure mode, cause, and
effect data is entered for each item.

In Windchill FMEA, you can customize FMEAS. You can select which data fields
appear and give them custom names. You can also change the appearance of
FMEA cells, adding in fonts, colors, notes, and checkmarks as you like. With this
functionality, you can completely customize the structure of your FMEA data.

Additionally, you can perform FMEA activities on the web using the web version
of Windchill Quality Solutions.

Types of FMEAS

FMEAs can basically be classified into one of three possible types: process,
functional, or component. All three of these FMEA types assess the impact of
failures on system performance and safety to determine which failure modes
require efforts to prevent, mitigate, or detect occurrence. The selection of a
particular FMEA type indicates the intended scope of the analysis.

For example, you might choose to limit your assessment of possible failures to
those that can occur during the manufacturing or assembly process of a product.
Or, you might choose to limit it to failures that prevent you from meeting the
functional requirements for a product design. When a comprehensive assessment
of a product design is required, you would not want to limit your assessment in any
manner but rather consider all possible failure modes for all system components.

The advantage of Windchill FMEA is that it supports any type of FMEA you want
to perform. Additionally, if you have your own hybrid type of FMEA, or some
customized FMEA format, the FMEA module can be adapted to meet your needs.

For the examples in this guide, we discuss and show the most common types
employed: process, functional, and component. The following sections briefly
discuss these types.

Process FMEA

A process FMEA examines the ways that failures in a manufacturing or assembly
process can affect the operation and quality of a product or service. A process
FMEA can be performed at any level to evaluate possible failure modes in the
process and limitations in equipment, tooling, gauges, or operator training. The
information collected can help to determine what can be done to prevent potential
failures prior to the first production run. You can then take actions to reduce your
exposure to risks deemed unacceptable.
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Functional FMEA

A functional FMEA examines the intended functions that a product, process, or
service is to perform rather than the characteristics of the specific implementation.
When a functional FMEA is developed, a functional block diagram is typically
used to identify the top-level failures for each block in the diagram. For example, a
functional FMEA would consider that a capacitor is intended to regulate voltage
and then to analyze the effects of the capacitor failing to regulate voltage. It would
not analyze what would occur if the capacitor fails open or fails shorted.

Component FMEA

A component FMEA examines the characteristics of a specific implementation to
ensure that the design complies with requirements for failures that can cause loss
of end-item function, single-point failures, and fault detection and isolation. Once
individual items of a system are identified in the later design and development
phases, component FMEASs can assess the causes and effects of failure modes on
the lowest-level system items. Component FMEAs for hardware, commonly
referred to as piece-part FMEAs, are the most common type.

Reviewing Types of FMEAs
To review the types of FMEAS:

1. Select the FMEA Table.

2. Select the System Functional FMEA.

3. In FMEA Tree ltems - Functional, select Processing Section.
4

In the lower pane, select the FMEA Worksheet to review the functional FMEA
for the processing section of the tablet PC.

5. In FMEA Tree Items - Functional, select Touchpanel to review a functional
FMEA for the touchpanel section of the tablet PC.

Select the FMEA Table again.
Select the Battery Process FMEA.

In FMEA Tree Items - Process, expand Battery, and then select Solder to review
a process FMEA for the process that occurs during soldering of the battery for
the Tablet PC.

9. In FMEA Tree Items - Process, sclect Assembly to review a process FMEA for
the process of assembling the battery of the Tablet PC.

10. Select the FMEA Table again.
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11.
12.

Select the Tablet PC Component FMEA.

In FMEA Tree Items - System, expand Industrial Tablet PC and select
Motherboard to review a component FMEA for the motherboard of the tablet

PC.

Entering Data

© NSk D=

10.
I1.
12.
13.
14.
15.

16.
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Select the FMEA Table.

Select System Functional FMEA.

In FMEA Tree Items - Functional, select Processing Section.

Select the FMEA Worksheet.

Select the Function/Process Transfer data and provide computing functions.
Select Insert » Mode to insert a new failure mode for this function.

For Failure Mode, enter Hard drive failure.

For Mode Percentage, enter 25. Change the ModePercentage for the other
three failure modes to 25.

Failure Mode percentages of all failure modes for a single item should add up
to 100 percent. For this example, we’re going to assume that all our failure
modes have an equal likelihood of occurring. In real-world situations, some
failure modes are more likely to occur than others, and this can be reflected by
designating the appropriate failure mode percentages.

For Local Effect, enter Hard drive cannot be accessed and press Tab.

The Add List Item window opens. Because the local effect you just entered is
new, you are being asked whether to add it to the list of possible effects for this
FMEA. A significant advantage of keeping a list of effects in FMEA is to
ensure consistency. The next time a failure results in “Hard drive cannot be
accessed,” you would not need to type in the phrase again, but can simply
select it from the list.

Click Yes to add the new effect to the list.

For End Effect, sclect Tablet PC not functional from the list.

For Sev, which stands for “Severity,” select 9 to indicate a high severity.
Leave Class blank.

For Cause of Failure, enter Bad sector on hard drive.

For Occ, which stands for “Occurrence,” select 2 to indicate a low probability
of occurrence.

For Current Controls, enter Test hard drive on bootup.

Getting Started Guide



17. For Det, which stands for “Detection,” select 6 to indicate a moderate detection
mechanism is in place; press Tab to move to the next field.

Note that Windchill FMEA has automatically computed the RPN (Risk Priority
Number) for this failure mode. Depending on your system and your
requirements, you may need to determine the RPN values that represent high,
medium, and low risk. Failure modes identified to be high risk should be
further analyzed to determine if controls can be established either to eliminate
or mitigate the risk of their occurrence.

18. For Recommended Actions, enter Add periodic hard drive tests
during normal operation.

19. For Responsibility, enter Anthony - HD Engr.

o]
20. For Target Date, click the calendar icon *'. The Calendar control appears.

1 September, 2011 »
Sun Mon Tue Wed Thu Fri 5at

26 29 30 31 1 3

4 s 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 1

2 3 4 5 6 7 8
[ | Today: 9/2/2011

21. Select one month from today for the target completion date.

Once the recommended actions have been put into place, you would complete the
remaining data fields: Actions Taken, Severity Results, Occurrence Results, and
Detection Results.

You have now completed data entry of a new failure mode. Entry of additional
FMEA data can be accomplished in the same manner. You may enter any level of
FMEA data — items, modes, causes, and effects — by using the Insert commands on
the menu and on the shortcut menu accessed by a right-mouse click. You may also
enable the Insert FMEA Items toolbar to insert FMEA data by accessing toolbar
buttons.

FMEA data structures are customizable, so you can vary the hierarchical
relationship of your FMEA data, as well as the data to collect.
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Working with the List Library

List Library files allow you to define list items that are used throughout your
FMEA, which ensures that your FMEA data is consistent and organized. The
sample Project you are using contains a List Library file.

1. In the Project Navigator, click Expand files to display Support files.
Note
If this option is not available, click Collapse files, then Expand files.

2. Under Support Files > Setup > List Library, select List Library to open it.

Select the following values in the List Definition table to view corresponding
list choices in the List Choices table: Location, Local Effect, and Manufacturers.

4. When complete, close the List Library file by selecting File » Close.
5. In the Project Navigator, click Collapse files to hide all Support files.

As you saw while editing the My Tablet PC file, you can select the Local Effect
column to see the list and select an item from it. You can also choose to enter an
entirely new local effect by directly typing it in the cell. In that case, Windchill
FMEA asks if you want to add this new item to the List Library file.

You see how using List Library files can ensure that you and all team members use
the same wording consistently.

Performing Calculations

FMEA calculations are designed to help you determine what failures in your
system need to be addressed and, after a redesign to address critical failures, how
much those changes have affected the overall risk of failure in your system.

The metrics calculated by the FMEA module include:

Calculation Description

Risk Priority Number |The RPN reveals the overall risk of a particular failure

(RPN) mode occurring in your system. The RPN is calculated
as:

Severity * Occurrence * Detection
Where:

* Severity is an assigned value that indicates the se-
verity of the effect of a particular failure mode.

*  Occurrence is an assigned value that designates how
frequently that particular failure mode is likely to
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Calculation

Description

OocCcCur.

* Detection is an assigned value that indicates how
often that particular failure mode can be detected.

While RPN values are computed automatically as you
enter the severity, occurrence, and detection values, they
are computed again when you perform FMEA calcula-
tions to ensure that all your RPN values are current.

RPN Results

RPN Results are RPN values calculated after design
changes are implemented to address failure modes with
high RPNs. The RPN Result is calculated as:

Severity Results * Occurrence Results * Detection
Results

RPN Improvement

RPN Improvement Percentage indicates the percentage

Percentage of improvement between the original RPN (before any
corrective actions have been taken) and the RPN Result
(after corrective actions have been taken).

Criticality Rank The Criticality Rank is a value that provides an assess-

ment of the failure mode’s severity and probability of oc-
currence. A failure mode with a rank of 1 is the most
severe with the highest likelihood of occurring. The re-
sult is a categorized breakdown of failure modes based
on risk. This approach is described in the SAE FMEA
5580 document.

Item Failure Rate

The number of failures of a specific item over a time pe-
riod, usually defined in units of failures per million hours
(FPMH) or failures per billion hours (FITs).

Mode Failure Rate The number of occurrences of a specific failure mode
over a time period, usually defined in units of failures
per million hours (FPMH) or failures per billion hours
(FITs).

Mode Criticality How critical the failure mode is under a particular se-

verity classification. This criticality value is calculated as
described in MIL-STD-1629, Procedures for Performing
a Failure Mode, Effects and Criticality Analysis:

Mode Failure Rate * Mode Operating Time * Failure Ef-
fect Probability

Where:
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Calculation

Description

* Mode Failure Rate is a value representing the num-
ber of occurrences of a specific failure mode over a
time period.

*  Mode Operating Time is the duration of applicable
mission phase(s), usually expressed in hours or num-
ber of operating cycles.

» Failure Effect Probability is the probability that the
failure occurs.

Detection Percentage

The probability that the failure mode is detected.

Detection Failure Rate

A value representing the number of detectable occur-
rences of a failure mode over a time period, usually de-
fined in units of detectable failures per million hours
(FPMH) or detectable failures per billion hours (FITs).

Isolation Percentage

The percentage of probability that the failure mode can
be attributed to a specific part.

Isolation Failure Rate

A value representing the number of occurrences of a fail-
ure mode over a time period that can be attributed to a
specific part, usually defined in units of isolation failures
per million hours (FPMH) or isolation failures per billion
hours (FITs).

Running Calculations
To compute FMEA results:

1. Select System » Calculate, or click the calculate /=

icon on the Standard

toolbar. The Calculate window appears.

In the left pane, select the Calculation Selection page (if necessary).

In the right pane, click Clear All and select the FMEA check box to perform
calculations only for the FMEA module.

4. In the left pane, expand the FMEA heading, then select the Mission Phase page.

You can see that you have options to select the mission profile and the mission
phase for your FMEA calculations. In this example we are not considering
mission phases. Leave Mission profile set to Default Profile and Mission phase

set to Ignore Phases.
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|- | Mission Phase Calculation Options

Miszion profile: IDefauIt Profile

3

Mission phase: [Ignnre Phases

al

5. In the left pane, under FMEA, select the Risk page. This page allows you to
customize risk level calculations and graphs. For this example, accept the

default settings.

-] FMEA Criticality Matrix Options

Criticality matrix ¥ axis: [Sev
Criticality matrix Y axis: [Occ

Rizk Level ¥ Level ' Level
Low
Medium 3.00

High 7.00

6. Click OK to perform the calculations. The Calculation Progress window
displays status information. When the calculations are complete, a window

opens.

7. Click OK to dismiss the window.

Viewing a Report

1. In the Project Navigator, under Reports > FMEA Reports, select (Common)
FMEA Standard Design. The Select FMEA window opens.

2. Select System Functional FMEA and click OK to generate this default report in

the preview window.

You can use the toolbar buttons in the Preview window to page through your
report, zoom in and out, and print the report.

3. When finished viewing the report, do one of the following to close the Preview

window:

* Select Preview » Close.

*  Click the close icon El on the toolbar.

Windchill FMEA
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Graphing Data
1. In the Project Navigator, under Graphs > FMEA Graphs, select (Common)

FMEA Top 10 RPN to view a graph of the failure modes with the highest RPN
values. The Select FMEA window opens.

2. Select System Functional FMEA and click OK to generate the graph.

This graph displays the failures modes with the highest RPN (risk priority
number) values in a cylinder bar graph.

3. When finished viewing the graph, select File » Close.

Windchill FMEA Features

Windchill Quality Solutions supports many more FMEA features and functions. A
brief listing of other topics of interest is shown below. For more information on
these features, see the help or guide for Windchill FMEA.

*  You can use the web version of Windchill Quality Solutions to perform your
FMEA analyses across the Web. This zero-client, web-based interface provides
a rich Windows-like user interface, enabling FMEA analysts to move between
the desktop and web versions with ease. The web version of Windchill Quality
Solutions provides significant advantages for enabling FMEASs to be performed
in a collaborative environment through its global accessibility.

* You can use the unique Roll Up FMEA and Build FMEA features to construct
FMEAs more effectively. These features ensure your FMEAs are
comprehensive and efficient. The Roll Up FMEA feature is used to roll up
local effects as failure modes for the next higher level in the FMEA Worksheet.
The Build FMEA feature is used to progress down through FMEA data levels
to fill in end effects, next effects, severities, and failure effect probabilities.

* You can create custom calculations to perform any number of FMEA
computations. This feature also enables you to override built-in RPN
calculations, so if you have another method of computing them, you can set
specify your custom equations.

* The FMEA Design file allows you to customize your FMEA data hierarchy for
ultimate flexibility in meeting the needs of your FMEA process.

* The FMEA Modes Library file includes failure modes associated with specific
component types. By using a FMEA Modes Library file along with your Wind-
chill Prediction analyses, your FMEA process can be streamlined by the
automatic addition of failure modes to piece-part FMEAs. Windchill FMEA is
also supplied with a number of standard FMEA Modes Library files.

* You can create completely customized FMEA forms for data entry of your
FMEA information.
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The “on-the-fly”” Format Builder allows you to modify the columns of your
FMEA Table, FMEA Tree, and FMEA Worksheet with a simple right-click.

Windchill FMEA supports all types of FMEAs: component, functional, and
process. You can select which FMEA type to use during new FMEA creation.

The FMEA Fault Equivalence file provides for consistency and efficiency in
FMEA construction by supporting the concept of fault equivalencies as defined
in the SAE FMEA standard. Essentially, fault equivalencies reduce the level of
effort needed to complete a FMEA by allowing you to group failure
consequences based on failure modes. If failure modes are duplicated in your
FMEA, the resulting like consequence data can be automatically pulled in from
your FMEA Fault Equivalence file.

Windchill Quality Solutions includes support for control plans in the FMEA
module. Control plans provide a structured plan for designing, selecting, and
implementing controls for the system, which ensures that the process remains
in a state of control throughout the product life cycle.

Windchill Quality Solutions also includes support for DVP&R (design
verification planning and reporting). A DVP&R is a group of tests that help
ensure product designs are meeting customer specifications and that product
development is correctly focused.
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about fault tree analysis and how to build and evaluate fault trees
using Windchill FTA. In this section, you enter fault tree data, perform calculations
on the data, and view outputs such as reports and graphs.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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Fault Tree Analysis (FTA) Overview

FTA is an event-oriented analysis technique, which means that it allows for the
consideration of hardware failures and other undesirable events, such as software
failures, human errors, operation and maintenance errors, and environmental
influences. Fault tree analysis offers a simple and powerful approach for reliability
and safety analysis. It is a deductive, top-down approach that begins with a single
event to be analyzed, usually an undesirable or catastrophic failure, and then aids
in the process of determining the specific causes which may lead to the occurrence
of that event. It is based on a simple set of rules and logic symbols (e.g. AND
gates, OR gates, and many others) from probability theory and Boolean algebra.
Fault tree analysis consists of generating a logic model that allows for both
qualitative and quantitative evaluation of system reliability or availability.

A fault tree is a pictorial representation of a system and the events that could lead
to an undesired event in the system. From a qualitative perspective, you can
generate minimal cut sets, which are the smallest sets of events, such that if they all
occur, cause the undesired top-level event to occur. From a quantitative
perspective, you can determine the likelihood of occurrence of the top event and
any intermediate events given the necessary probabilities of the contributing lower-
level events.

If you are unfamiliar with fault tree analysis and would like to study this topic in
more detail, the following selections are excellent references:

» Reliability: A Practitioner's guide (Chapter 5)

* Fault Tree Analysis Application guide from the Reliability Information
Analysis Center

» Fault Tree Handbook, NUREG-0492, from the U.S. Nuclear Regulatory
Commission

Getting Started with Windchill FTA

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill FTA module; for more

information, see Starting Windchill FTA on page 67.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.
+ If'the Project Navigator has the My Tablet PC Project open (you see Project: My

Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Starting Windchill FTA

On the Module Selections toolbar, select the FTA button A and deselect all other
module buttons.

The FTA panes are shown in your System file.

Using Windchill FTA

The two Windchill FTA panes display the same information about your fault tree,
but in different formats.

The FTA Table at the top displays a table with columns of data. It provides an
expandable/collapsible spreadsheet-like view of the same fault tree data contained
in the graphical view. This table provides a compact, convenient method of
reviewing the various gates and events and their relationships. Using the table, you
can quickly view and edit the properties of the gates and events.

The FTA Diagram, below, displays a graphical view of the fault tree, which is the
most common format for developing and modifying fault trees. The top figure in
this window is referred to as the top event. This is the primary event that the fault
tree is built around. Shown below the top event is a set of gates and events. The
events, either alone or in combination, cause the top event to occur. You can
double-click a gate or event to view and edit its properties.
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Reviewing Gate and Event Properties

All gates and events have properties associated with them. You can edit the
properties of a gate or event by double-clicking it, or by right-clicking it and
selecting Properties. To review these properties:

1. In the FTA Diagram, double-click the TS-1 event (labeled Temperature Sensor
Failure). The Properties window for this event appears. Review the data values

on the various pages.

The General page displays the event type and identifying text.

The Calculation Data page displays information about the event’s
quantitative properties, used during fault tree calculations.

The Library Event page displays information about the library associated
with this event. In this case, this event was not inserted from a library.

The Graphic page enables you to associate a graphic image of your
choosing with the event.

The User Properties page provides extra data fields you can use for any
purpose you desire.

The Remarks page allows you to enter a lengthy notation about this
particular event.

2. Click Cancel to close the Properties window.

3. Double-click the BAT-FIRE gate labeled Battery catches on fire. This gate is
also referred to as the top gate of the fault tree. The Properties window for this
gate appears. You can see that there are several more pages of information
associated with gates, along with those pages that appear for events. Review
the additional pages:

The Inputs page provides a table view of all the events and gates which are
inputs to this gate.

The last three pages, Cut Sets, Reliability Importance Measures, and FTA
Results, display the results from calculations. If calculations have not been
performed, no data appears on these tabs.

4. Click Cancel to close the Properties window.
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Inserting a New Fault Tree

For this example, you create a new fault tree to model the failure of the hard drive
of our tablet PC.

1. Select Insert » New Top Gate. A new fault tree diagram opens and shows a new
top gate.

2. In the FTA Diagram, double-click the new gate to show the properties for this
gate.

In the left pane, select the General page.

For Identifier, enter HD Failure.

For Description, enter Hard drive not functioning.
Click OK.

AN AN

Inserting and Editing Individual Gates and Events
To insert and edit gates or events one at a time:

In the FTA Diagram, select the HD Failure OR gate.

Right-click and select Insert Input. The Insert Input window opens.
Select OR Gate as the input type and click OK to insert the gate.
Double-click the new gate to bring up the properties.

In the left pane, select the General page.

For Identifier, enter Mech Fault.

For Description, enter Mechanical failure and click OK.
Select the OR gate labeled HD Failure again.

Right-click and select Insert Input to insert another OR Gate.

A S RS o A
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. Double-click the new gate to bring up the properties.

p—
p—

. In the properties, for Identifier, enter Elec/SW Fault.

[S—
\S]

. For Description, enter Electrical or software failure and click OK.
. Select the HD Failure OR gate.
. Right-click and select Insert Input to insert another OR Gate.

—_—
whn B~ W

. Double-click the new gate to bring up the properties.

p—
N

. In the properties, for Identifier, enter Ext Fault.

—
~

. For Description, enter External failure and click OK.

Inserting Multiple Gates or Events

To insert multiple gates or events:
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In the FTA Diagram, select the Mech Fault OR gate.

2. Select Insert » Event. The Insert Event window opens.

The default input type is Basic Event.
3. Click OK to insert a basic event.

The mouse cursor changes shape to show the type of gate or event you are
inserting. In this case, it is the circle icon, which indicates a basic event, along
with a label showing a plug. The red warning symbol around the plug icon
indicates that you cannot insert a basic event in that location.

&

4. Move the cursor so that the circle shape is over the gate labeled Mech Fault and
notice that the warning symbol on the plug icon disappears, indicating that you
can insert a basic event in this location.

&
5. Click to insert a basic event. The cursor retains the shape of the basic event so
you can continue to insert basic events.
Insert one more basic event under the Mech Fault gate.
Move the mouse over to the Elec/SW Fault gate and insert a single basic event.

Right-click to exit the insertion mode. The mouse cursor returns to its normal
shape.

Changing an Event to a Gate

At times, you may need to change an event to a gate or a gate to an event. For this
example, assume that rather than completing the External Failure logic at this time,
we’d prefer to change it to an Undeveloped Event, indicating that we can come
back later and more fully analyze this failure path. This type of failure may be
caused by such events as the tablet PC being dropped, or someone spilling coffee
on it. For now, we’ll leave this open-ended. We can further develop this branch
when we have more information.

1. In the FTA Diagram, double-click the OR Gate Ext Fault. The Properties
window for this gate open.

For Type, select Undeveloped Event.

For Identifier, enter External Fault.

For Description, External failure - Undeveloped.
Click OK.

A
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Editing Event Properties

All gates and events have properties associated with them. You can edit the
properties of a gate or event by double-clicking it or by right-clicking it and
selecting Properties from the right mouse menu. To review these properties:

1.

10.
I1.
12.
13.
14.

15.
16.
17.

18.
19.
20.
21.

22.
23.

In the FTA Diagram, beneath the OR gate labeled Mech Fault, double-click the
left event that you inserted. The Event Properties window opens.

On the General page, for the Identifier, enter Bearing Fault.
For Description, enter Mechanical Bearing Failure.

In the left pane, select the Calculation Data page. Leave Input Type set to
Constant probability.

For Probability, enter 0. 0015.
Click OK.

In the FTA Diagram, beneath the OR gate Mech Fault, double-click the second
event that you inserted.

On the General page, for Identifier, enter Media Fault.
For Description, enter Hard drive media failure.
In the left pane, select the Calculation Data page.

For Input Type, select Failure rate/MTBF.

For Failure rate, enter 0.0001.

Click OK.

In the FTA Diagram, beneath the OR gate labeled Elec/SW Fault, double-click
the event that you inserted.

On the General page, for Identifier, enter Controller Fault.
For Description, enter Hard drive controller failure.

In the left pane, select the Calculation Data page. Leave Input Type set to
Constant probability.

For Probability, enter 0. 0125.
Click OK.
In the FTA Diagram, double-click the Undeveloped Event External Fault.

Select the Calculation Data page. Leave the Input Type set to Constant
probability.

For Probability, enter 0. 0002.
Click OK.

Windchill FTA
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Using Transfer Gates

In some situations, fault trees can become quite large and complex with many
gates and events. In these cases, for ease of analysis, it may be helpful to break the
single fault tree up into smaller fault trees that are all linked together. Additionally,
in some cases you may want to repeat the same logic in two different places. In
both of these cases, a type of gate called a transfer gate is very useful. Transfer
gates are not associated with any logic operation themselves, but they enable you
to break up fault trees for visual reasons as well as to handle repeated logic.

1. Inthe FTA Diagram, select the gate Mech Fault.
2. Right-click and select Break into Transfer.

A new fault tree is inserted. The Mech Fault gate is the top gate and all of its
lower inputs are intact. The triangular symbol shown with this top gate
indicates that it is part of another fault tree.

3. To return to the original fault tree, right-click the top gate of the new fault tree
and select Transfer » HD Failure. In the original fault tree, a Mech Fault
Transfer gate has replaced the Mech Fault OR gate.

You can bring the newly created Mech Fault fault tree back into its original
location in the main fault tree.

4. Right-click the new Mech Fault Transfer gate and select Transfer » To Mech
Fault to go back to the Mech Fault tree.

5. In the Mech Fault tree, right-click the Mech Fault gate and select Collapse
Transfer to return the fault tree to its original state.

New Transfer gates can also be inserted directly into your fault trees just like any
other gate.

Performing Calculations

Windchill FTA includes both qualitative and quantative calculations. Qualitative
calculations analyze the unwanted event (the top gate in the fault tree) and
determine the minimum combination of events that cause that event to occur.

These calculations are useful for identifying unexpected root cause combinations,
designing for weak points in a system, and finding common causes for an issue.
Quantitative calculations measure the unreliability and unavailability of the system
based on the fault tree, and provide a more precise and less subjective evaluation of
a fault tree.

A sampling of supported calculations is outlined below and very brief descriptions
are provided. For more details on these calculations, see the help or guide for
Windchill Quality Solutions.
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Calculation

Description

Minimal cut sets

A cut set identifies which unique combination of compo-
nent failures and/or events can cause an undesired event to
occur. A minimal cut set is the smallest set of events,
which, if they all occur, cause the top event to transpire.

Reliability Impor-
tance Measures

A method of ranking the basic events in the fault tree to
show their relative culpability in causing the top event to
occur.

Importance measures are used to detect critical design
weaknesses and component failures. They can assist you in
identifying the fault tree event that, if improved, is most
likely to produce the greatest improvement in system per-
formance. They can also help you determine if allocating
additional resources or adding redundancy to the system
would improve the overall system reliability.

Unavailability The probability that, at a given time, the system does not
function, due to either a failure or a repair.

Unreliability The probability that, during a given time period, the top
event occurs, and the system is unable to function.

Frequency The frequency of failures over a time period.

Number of failures

The number of failures in a period of time.

Running Calculations

To perform a fault tree calculation:

1. In the FTA Table, select BAT-FIRE.

2. Select System » Calculate, or click the calculate

icon on the Standard

toolbar. The Calculate window opens.

3. In the left pane, select the Calculation Selection page (if necessary).

4. In the right pane, click Clear All and select FTA to perform calculations only for

the FTA module.

5. In the left pane, under FTA, select the General page.

The General and Advanced pages contain a number of calculation options.

Under Reliability/Availability Evaluation, for Through end time, enter 30000.

For Primary time point, enter 30000.

Select Perform exact calculations.

Windchill FTA
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Under Calculations, leave Cut sets selected. Select the following options as
well:

Reliability importance measures

Unavailability
Unreliability
Frequency

Number of failures

10. Select Calculate all gates.

11. Leave the remaining options set to the defaults.

A FTA Calculation Options

[ qualitative analysis only

Reliability/availability evaluation

From start time: 0
Through end time: 30000
Mumber of data points: 11

Primary time paint: 30000

Calculations
Cut sets

[¥] relibility importance measures

[¥] Unavailability

[¥] Unreliability

Frequency

Mumber of failures

Ignare cut sets with probabilities less than:

Ignore cut sets with an order greater than:

[#] Perform exact calculations

Start calculating at:
@ Topmost gate

& Current gate
= (top of current page)

) Calculate top gate only
@ Calculate &l gates

12. In the left pane, select the Advanced page.

13. For Calculation method, select Exact.
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For more information regarding all of these options, click the help icon @ to
access the help.
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14. Click OK to perform the calculations. The Calculation Progress window

displays status information. When the calculations are complete, the View
Calculation Results window opens.

Tip
You can print your calculation results by clicking Print in the View Calculation
Results window. You can also save them to a Microsoft Excel spreadsheet by

clicking Excel.

15. Click Close when you have finished reviewing results.
To redisplay the results at any time, select System > View Calculation Results. If
you have only one module enabled, the results are displayed for that module. If

you have more than one module enabled, select the appropriate page to view the
results. When finished, click Close.

Viewing Cut Sets

A cut set is a set of events that together cause the top event to occur. A Minimal
Cut Set (MCS) is the smallest set of events, which, if they all occur, cause the top
event to occur.

During calculations, cut sets are determined if you select them in the Calculation
settings. You can view the cut sets on screen. You can cycle one at a time through
all the cut sets. To view cut sets:

1. Select the FTA Diagram if it is not active.
2. In the FTA Diagram, select the top BAT-FIRE gate.
3. Select FTA » Highlight Cut Sets.

The Cut Set Highlighting window opens and the first cut set is highlighted in
blue in the FTA Diagram.

Task List - QX
Cut Set Highlighting -
[BATFIRE -
[1:Q=0.0392106 -
Next cut set

Note

If you have the Project Navigator pinned into view, you may choose to
temporarily unpin it and slide it out of view while viewing cut sets.
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4. Click Next cut set to view the next cut set for the BAT-FIRE gate. You can
continue clicking this button until it becomes unavailable, indicating that the
last cut set has been viewed. To go back, click Previous cut set.

Note

If the Next cut set and Previous cut set buttons are both unavailable, there is

only one cut set to view.

5. On the FTA menu, clear Highlight Cut Sets to turn off cut set highlighting.

Viewing a Report

1.

4. Click OK to generate this default report in the Preview window.

76

In the Project Navigator, under Reports > FTA Reports, select (Common) Fault

Tree (Summary). The Select Top Gate window opens.
If BAT-FIRE is not selected, select it.

For the remaining parameters, use the values automatically set as the defaults.

Select Top Gate ﬁ

BAT-FIRE

HD Failure

Show only top gates
|:| Print all top gates

Print option ’Frint All Pages - ]
Paging option ’Autumat‘icallv Page Reports (Minimizing Pages) - ]
|:| Use stacking
Scaling factor 1

[ OK J [ Cancel I [ Help I

=

L8

4

This report outputs data related to a fault tree (top gate) in the System file, and
includes calculation data, gate and event details, and the fault tree diagram.
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You can use the various toolbar buttons in the Preview window to page through
your report, zoom in and out, and print the report.

When finished viewing the report, do one of the following to close the Preview
window:

¢ Select Preview » Close.

¢ Click the close icon EI on the toolbar.

Graphing Data

1.

In the Project Navigator, under Graphs > FTA Graphs, select (Common) Fault
Tree Unavailability v Time. The Select the Gate to Graph window opens.

Select BAT-FIRE and click OK to generate the graph.

This graph displays system unavailability for gates at the points in time
specified in the Calculate window for FTA calculations.

When finished viewing the graph, select File » Close.

Windchill FTA Features

Windchill Quality Solutions supports many more fault tree features and functions.
A brief listing of other topics of interest is shown below. For more information, see
the help or guide for Windchill Quality Solutions.

Windchill FTA

Common cause failures (CCFs) are supported. An event or mechanism that can
cause two or more failures (basic events) simultaneously is referred to as a
common cause, and such failures are referred to as common cause failures.

Repeated events are supported. Repeated events are basic events that are used
in more than one place in the fault tree but are identical.

Commonly used failure and repair parameters may be stored in a Fault Tree
Event Library file. This allows you to enter frequently used data once and
retrieve it as needed.

Exact calculations are supported. Cut set approximations are also supported to
expedite the analysis of large trees.

The appearance of gates and events, including colors, fonts, bitmap images,
and sizing, may be customized.

You may define very long descriptions for your gates and events and have the
size of the figures automatically increased to fit the text.

You can link Windchill FTA events to other modules. If the linked data
changes, these changes are automatically reflected within Windchill FTA. This
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module can link to Windchill Prediction, Windchill FMEA, and Windchill
Markov.

Automatic paging is supported to help in the management of large fault trees.

A Windchill FTA license includes Windchill Event Tree, which provides full
ETA (event tree analysis) capabilities. Event trees enable you to analyze the
consequences that result from a sequence of events occurring in your system.
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about building and evaluating block diagrams using Windchill
RBD. In this section, you learn how to create a block diagram, insert and link
blocks, and assign calculation properties. You also run calculations and view
reports and graphs.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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Block Diagrams Overview

Block diagrams are used to model systems which incorporate varying
configurations outside of the basic series (in-line) configuration, and are especially
useful in analyzing configurations that include redundant components.

When system components are connected in series, it indicates that all components
must be operational for the system to be successful. Once a single component fails
in the chain, the entire system is non-operational. But if the system utilizes backups
for components, then one failure does not cause the entire system to fail. Instead, a
backup unit can take over to keep the system up and running. Designing
redundancy into a system can, therefore, often lead to increased reliability and
availability.

There are different types of redundancy, such as parallel operating and standby
non-operating. When items are in a parallel operating configuration, all are not
necessarily needed to be operational in order for the system to be operating. For
example, in a simple system, there may be two batteries set up in redundant
configuration so that if one battery fails, the backup battery can take over. In this
simple scenario, only one of the two components needs to be operational for
system success. In block diagram terms, this is usually described as a 1::2 parallel
operating configuration. In the case of a standby non-operating configuration, a
system component is in standby mode awaiting failure of the first unit. In block
diagram terms, this is referred to as a 1::2 standby configuration.

Models may become even more complex when you begin to consider factors such
as the switch delay encountered in standby situations when the backup unit must
be switched on. You may also need to account for the fact that a parallel operating
unit may have a higher failure rate than a standby unit because it is always
powered. You can envision how analyzing reliability metrics of these systems can
become difficult without the help of software analysis packages.

Redundancy in system design is essential in cases where repair is either
impossible, such as in a launched space probe, or extremely costly, such as in a
ship at sea. In other systems, redundancy can play a vital role in ensuring system
availability is kept to a maximum.

Block diagrams can be used to model series systems, parallel systems, and
combinations of series and parallel systems. Parallel systems can be operating or in
standby.

If you are unfamiliar with block diagrams and would like to study this topic in
more detail, the following are excellent resources:
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» Reliability: A Practitioner's guide (Chapter 4)

* Practical Reliability Engineering by Patrick D.T. O'Connor, 4th edition, John
Wiley & Sons Ltd. (2002)

» Reliability Analysis and Prediction: A Methodology Oriented Treatment by K.

B. Misra, Elsevier Science Publishers B.V. (1992)

Optimization and Simulation

While a standard block diagram process lets you compute reliability and
availability, optimization and simulation tools take this a step further by allowing
you to incorporate information on maintenance activities, spare parts, and repair
resources.

Optimization and simulation tools such as Windchill RBD effectively address
multiple facets of component maintenance, including the definition and allocation
of repair teams, the stocking and shipping to and from offsite spares pools, and
more. You can define maintenance plans that specify the time interval, cost, and
the type of maintenance being performed. You can also specify labor costs and
designate if repair is partial or perfect.

If you are unfamiliar with optimization and simulation techniques and would like
to study this topic in more detail, the following is an excellent resource:

* Optimal Reliability Design, by Way Kuo, V. Rajendra Prasad, Frank. A.
Tillman, Ching Lai Hwang, Cambridge University Press (2001)

Getting Started with Windchill RBD

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the RBD module. For more

information, see Starting Windchill RBD on page 82.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.

Windchill RBD
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the
System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.
+ If'the Project Navigator has the My Tablet PC Project open (you see Project: My

Tablet PC in the Project Navigator), click Tablet PC under the Systems heading
to open this System file.

Starting Windchill RBD

-
On the Module Selections toolbar, select the RBD button B and disable all other
module buttons.

Tabbed panes for Windchill RBD are shown in your System file.

Using Windchill RBD

The RBD Diagrams table in the top pane lists all the diagrams present in the active
System file. These diagrams are organized into two folders: Block Diagrams and
Phase Diagrams. This System file currently contains three block diagrams. The
first two model the entire Tablet PC in different phases of use, while the third
models the hard drive assembly, which includes two hard drives. These hard drives
are placed in parallel in order to increase availability through the use of
redundancy. In addition, this System file includes a phase diagram, which is
designed to evaluate the components of Tablet PC during various phases of the
mission.

The RBD Blocks tab in the top pane displays a table view of the block diagram
selected in RBD Diagrams.
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The RBD Diagram pane below displays a graphical view of the block diagram
selected in the RBD Diagrams table. For ease of viewing, you may want to resize
your RBD Diagram using the splitter control, which appears when you hover the
mouse cursor between the two panes.

For this example, you add an additional block diagram to model the memory board
assembly of the tablet PC. First, you create a simple block diagram and insert
blocks into it. Then you connect the blocks, assign calculation properties, and link
one of the blocks to an assembly in the system tree.

Creating a Simple Block Diagram
1. In the RBD Diagrams table, select the Block Diagrams heading.

2. Select Insert » New Block Diagram. A new block diagram is listed under the
Block Diagrams heading and, in the RBD Diagram tab below, a new block
diagram appears with only Start and End nodes present.

All block diagrams start at the Start node and then provide one or more paths
through the blocks to the End node. When a functioning path exists from the
Start node through the End node, the system is operating.

3. For Identifier, enter Memory Board, and then press the Tab key.

4. For Description, enter Block Diagram for the Memory Board
Assembly. Do not press the Tab key.

Inserting Blocks into a Block Diagram

Ensure you have selected the Memory Board block diagram.
2. Select the RBD Diagram pane.

Right-click and select Insert Default Block. The cursor changes in appearance to
show that you are inserting blocks.

4. Click near the start node to insert a block.
Move to the right and click again to insert another block.

Right-click to exit insertion mode.

Connecting Blocks in a Block Diagram

1. Hover the mouse cursor over the triangle connection point on the right side of
the Start node, until the cursor changes shape to a long arrow.

2. Select the triangle connection point on the start node.
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3.

Select the first block to connect the start node to the block. The two are
connected.

Repeat to connect the first block to the second block and the second block to
the end node.

Tip
You can also select RBD » Auto Connect Blocks to automatically connect
blocks based on entry order.

Assigning Calculation Properties

The memory assembly consists of the memory board controller and two memory
boards. For the purposes of this example, we’ll assume that the memory boards are
operating in a redundant configuration so that we can learn how to model
redundancy in Windchill RBD.

1.

2.
3.
4

84

Double-click the left block to display the Calculation Properties window.
On the General page, for Assembly, enter MEM061789.

For Part Number, enter DRAM512-31.

In the left pane, select the Failure page.

For Failure Distribution, click the browse button == to show the Distribution
window.

Leave Distribution set to Exponential.

From the dropdown menu, select Failure rate, and then enter 0.396516 for
the failure rate.

Click OK in the Distribution window to save your selections. The specified
Exponential Failure Rate is displayed in the Calculation Properties window.
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9. For the remaining parameters, use the default values:

Failure

Failure Distribution: Exponential: FR = 0.336518

Standby failure properties

Standby Aging Percentage:  0.00

Standby Failure Detection: [5e|f announcing "]
Standby Failure Type: [Percentage of online failure rate "]
Standby FR Percentage: 0.00

Exponential: FR =

10. In the left pane, select the Redundancy page.
11. For Quantity, enter 2.
12. For Redundancy Type, select Parallel Operating.

13. Leave Quantity Required as 1 and Switch Probability of Success as
1.000000.

14. When finished, click OK. The first block is redrawn to show redundancy is
designated.

Linking Blocks to Other Modules

If the block diagram you are creating includes assemblies from your system tree,
there is a more efficient way to access this data.

RBDs can be linked to data from other modules in order to pull in information
obtained from other analyses. Not only does linking the data make data entry much
easier, it has the additional advantage of keeping the linked data up-to-date, so if
you make changes to your assemblies and recompute failure rates, the new values
are automatically used in your block diagram.

To create a block that is linked to an assembly in the system tree:

1. Right-click the right-most block and select Data Linking > Link Data. The Link
Data window opens.

For Data Source, select Prediction to link to Windchill Prediction results.
For Configuration, click the dropdown control to display a selection window.

Select Configuration1.

A

For System Tree Item, click the dropdown control to display a selection
window.
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6. Expand the memory assembly MEM061789 and select the DRAMC7001 part.
7. Click OK to close the Link Data window.

The block now appears with a small link icon Ed in the upper right corner as a
visual indicator that the block is linked to data in another module. You can see that
the DRAMC7001 part information now appears in the block.

Additionally, if both Windchill Prediction and Windchill RBD are enabled, you
can drag items from your system tree and drop them into the RBD module to
create linked blocks.

Performing Calculations

Windchill RBD computes a variety of reliability and availability metrics. A
sampling of supported calculations is outlined below and very brief descriptions
are provided. For more information on calculations, see the guide or help for Wind-
chill Quality Solutions.

Calculation

Description

MTBF

The Mean Time Between Failures (MTBF) represents the
mean number of hours between two consecutive system
failures in a long run. It includes both operational and
downtime hours between two consecutive failures, and is the
average distance in hours between two failures in a long run.

In Windchill RBD, the run length is specified using Number of
System Failures to Reach Steady-State, which is available in

the RBD Advanced Calculation Options.

MTTF

The Mean Time To Failure (MTTF) or the expected time to
failure.

The MTTF is the average time to failure, in hours. For
repairable systems, it is the average time to reach the first
system failure. Hence, it is also called Mean Time To First
Failure (MTTFF).

When Account for Repair in Reliability is selected, then
reliability is calculated using blocks' failure and repair
information, and this function is used to calculate MTTF.

MTTR

Mean Time To Repair (MTTR) is the average time it takes to
repair a failed system and return it to an operational state,
based on the repair time distributions for its repairable
components or blocks. The MTTR can be calculated by
considering the frequency of each failure scenario and its
respective average repair times.
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Calculation

Description

Optimal Number
of Spares

The Optimal Number of Spares is the number of spares that
minimizes or maximizes a specified objective function (or the
goal). If the goal is minimizing the total cost, then the Optimal
Number of Spares represents the number of spares
corresponding to the minimum total cost. Similarly, if the goal
is maximizing the mean availability, then the Optimal Number
of Spares is the number of spares that maximizes the mean
availability.

The optimal number of spares is calculated by evaluating the
function specified in the goal with varying number of spares.
For example, if the goal is minimizing the total cost, then the
total cost is calculated for different number of spares. The
optimal number of spares corresponds to the minimum value
of the total cost.

Optimal
Maintenance
Intervals

The Optimal Maintenance Intervals value is the value of the
periodic maintenance interval that minimizes or maximizes a
specified objective function or the goal. If the goal is
minimizing the total cost, then it is the value of the
maintenance interval corresponding to the minimum total
cost.

The optimal maintenance intervals are calculated using
optimization algorithms integrated within the simulation
engine.

Optimal Repair
Resources

The Optimal Repair Resources value is the number of the
repair resources that minimizes or maximizes a specified
objective function or the goal. If the goal is minimizing the
total cost, then it is the number of repair resources
corresponding to the minimum total cost.

The optimal repair resources are calculated using optimization
algorithms integrated within the simulation engine.

Reliability

The probability that a system remains operational until a
specified time.

Reliability is a time-based probability value, so it is always a
metric between 0 and 1. A reliability of 0 means that the
system always fails before the specified time or never
functions until the specified time. A reliability value of 1
indicates that the system is always successful or never fails
during the specified time.

Windchill RBD
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Calculation

Description

The system reliability value is calculated using both the
system configuration specified in the block diagram and the
failure distribution specified in the calculation properties of
the blocks. If all blocks are in series, and all of them follow
exponential failure distributions, then the system itself follows
an exponential failure distribution, and the failure rate is the
sum of the failure rates of its components.

When Account for Repair in Reliability is selected, then
reliability is calculated using both the failure information and
the repair information specified in the block properties.

Unreliability

The probability that a failure occurs during a given time
period.

Failure Rate

It indicates the chances of failure at a specified time given that
the system is not yet failed. It also represents the expected
number of system failures per unit time given that no failure
has occurred in the system until the specified time. It is a
time-based metric and also known as instantaneous failure
rate.

The failure rate function can be used to study the behavior of
the system's failure over time. Furthermore, the failure rate
function, (f), is an important representation in the lifetime
modeling of the system due to its intuitive interpretation as the
amount of risk of failure associated with the system at time t.

When Account for Repair in Reliability is selected, then
reliability is calculated using blocks' failure and repair
information, and this function is used to calculate failure rate.

Availability

The probability that the system is operating properly at a
specified time. Availability, like reliability, is a time-based
probability metric, so it is always a metric between 0 and 1.
Hence, it is also called point availability or instantaneous
availability. When availability is calculated without
considering logistic delays, then it is called inherent
availability. When logistic delays are considered in the
availability calculation, then it is called Operational
Availability. Therefore, Windchill RBD can calculate either
Auvailability or Operational Availability in a single calculation.

Availability is a function of both reliability (how quickly the
system fails) and maintainability (how quickly the system is
repaired).
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Calculation

Description

A common term, "five nines", refers to a system which has an
availability 0 0.99999, i.e., it is operational 99.999% of the
time.

Mean Availability

Mean availability is the average availability over a specified
time interval. It is the ratio of the mean total uptime to the
total time over a specified interval.

Steady State
Availability

The steady-state availability is the availability in a long run, i.
e. as time tends to infinity. It is the ratio of the total uptime to
total time in a long run. In Windchill RBD, the run length is

specified using Number of System Failures to Reach Steady-
State, which is available in the RBD Advanced Calculation
Options.

Unavailability

The probability that, at a given time, the system does not
function, due to either a failure or a repair.

Total Downtime

The total downtime of the system during the specified time
interval.

Running Calculations

To calculate results:

1. In the RBD Diagrams table, select Tablet PC.

2. Select System » Calculate, or click the calculate

=4 icon on the Standard

toolbar. The Calculation Properties window appears.

3. In the left pane, select the Calculation Selection page (if it is not already

selected).

4. In the right pane, click Clear All and then select RBD to perform calculations
only for the RBD module.

5. In the left pane, under RBD, select the General page.

The General and Advanced pages contain a number of calculation options.

6. Leave all defaults. The page should appear as follows:
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From start time:

Through end time: 30000
Mumber of data paoints: 11
Display results for blocks at time: 30000
Required capacity: —1[.'|L'.‘|

Reliability

[ MTTF [#] Account for repair in reliability
Failure rate

Equivalent failure rate

Availability Steady state avaiability
MTEF Total downtime

Effective MTEF Expected number of failures
MTTR Failure frequency

Hazard rate Operational availability
Mean availability Capacity

Calculate cut sets Calculate path (tie) sets

Ignare cut seks with probabilities less than:

Ignore cut sets with an order greater than;

Cost Reliability equation

7. In the left pane, select the Advanced page.

8. Leave the defaults. The page should appear as follows:
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'!.'i RBD Advanced Calculation Options

Simulation

[]Force Monte Carlo simulation

Mumber of simulation iterations: 1000
Mumber of system failures to reach steady state: 1
Begin repairs {default): [Immediatel\,r ']
MNetwork type: [Electrical Metwork. ']
[¥] specify random number seed: 1

[¥] Companents continue to operate when system is failed

[ Recard simulation log for first iteration of availability measures

Confidence intervals

[F] reliability 95 | 24
[ Availability 55| %
[ mTer | |
[T 95| %

Linked diagrams

[¥] save linked diagram results

9. When finished, click OK to perform the calculations. When completed, the
View Calculation Results opens.

10. In the left pane, under RBD Results, select the General page to view the results.
Tip
You can print your calculation results by clicking Print in the View Calculation
Results window. You can also save them to a Microsoft Excel spreadsheet by

clicking Excel.

11. Click Close when you have finished reviewing results.
To redisplay the results at any time, select System > View Calculation Results. If
you have only one module enabled, the results are displayed for that module. If

you have more than one module enabled, select the appropriate page to view the
results. When finished, click Close.
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Viewing the Reliability Equation

When Windchill RBD analytically computes the diagram results, you can view the
equation which was used for the calculation. To obtain the Reliability Equation,
select Reliability Equation under Other Calculations when calculating.

To view the reliability equation:

1. In the RBD Diagrams table, select Tablet PC.

2. Select System » View Calculation Results. The View Calculation Results
window opens.

3. If necessary, expand the RBD Results heading.

In the left pane, select the Equation page to view the reliability equation used to
calculate the results for the Tablet PC diagram.

5. Click Close to close the View Calculation Results window.

Viewing a Report

1. In the Project Navigator, under Reports > RBD Reports, select (Common) RBD
(Summary) Portrait to preview this report on-screen. The Select Block Diagram

window opens.
Select Tablet PC from the list of diagrams.

3. Select Select single diagram and click OK to generate the report in the Preview
window.

You can use the various toolbar buttons in the Preview window to page through
your report, zoom in and out, and print the report.

4. When finished viewing the report, do one of the following to close the Preview
window:

¢ Select Preview » Close.

¢ Click the close icon EI on the toolbar.

Graphing Data

1. In the Project Navigator, under Graphs > RBD Graphs, select (Common) RBD
Reliability v Time 3D to generate this graph. The Select RBD Diagrams window

opens.
Leave Tablet PC selected and click OK to generate the graph.
3. When finished viewing the graph, select File » Close.
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Windchill RBD Features

Windchill RBD supports many more block diagram features and functions. A brief
listing of other topics of interest is shown below. For more information, see the
help or guide for Windchill Quality Solutions.

To change the visual properties of a block, select the block, right-click, and
select Visual Properties. To change the visual properties of a connector, select
the connector, right-click and select Properties.

Windchill RBD supports a wide array of system complexities including limited
repair resources, fixed and variable costs, switching mechanisms, switch
delays, transportation delays, and logistic delays.

To place a bitmap in your diagram, right-click the block and select Visual
Properties to display the Block Visual Properties window. On the Graphic tab,

use the browse button =**! from the Image file field to navigate to and select a
graphic file.

Windchill RBD supports hot, cold, and warm spares.

To insert a junction, which can be used to connect multiple connectors
together, select Insert » Junction. Junctions can be used to model a redundant
configuration.

Windchill RBD supports conditional repair policies.

To display multiple pages in the Block Diagram window, select Diagram »
Properties and complete the Pages page in the Diagram window.
Windchill RBD can compute confidence intervals for various reliability
metrics.

To link blocks together to create child diagrams, diagram links can be used.

Right-click a block and select Diagram Linking > Set Diagram Link. The Select
Diagram Link window opens so that you can select the diagram to which to

link.

The RBD module supports a large number of distributions, including
exponential, lognormal, normal, Rayleigh, time independent, Weibull, uniform,
and constant time.

Windchill RBD supports both Electrical and Flow type networks.
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This section of the Windchill Quality Solutions Getting Started Guide provides
information about a FRACAS (failure reporting, analysis, and corrective action
system) and how to use it to track, measure, and ultimately improve the reliability
of a product, service, process, or software application.

In this section, you learn how to enter incidents in Windchill FRACAS, how to
filter your data, and how to view outputs such as reports and graphs.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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Overview of FRACAS

A FRACAS is a closed-loop incident reporting and corrective action system. This
type of system is also known as a DRACAS (data reporting, analysis, and
corrective action system), PRACA (problem reporting, analysis, and corrective
action), and various other names. Reducing the cost of poor quality (COPQ),
improving the next generation of product design, reducing warranty costs, and
ensuring compliance are some of the key reasons organizations deploy closed-loop
corrective action systems.

A FRACAS can be the means by which the reliability of a product, service,
process, or software application is tracked, measured, and ultimately improved. A
FRACAS must provide for accurately recording and analyzing significant incident
information so that effective corrective actions can be quickly identified,
implemented, and verified.

Windchill FRACAS allows you to create a completely customized FRACAS tool
for data entry, analysis, and reporting.

If you are unfamiliar with FRACAS and would like to study this topic in more
detail, the following are some recommended resources:

» Failure Reporting, Analysis, and Corrective Action System (FRACAS)
Application and guidelines, a 1999 publication of the Reliability Analysis
Center (RAC)

*  MIL-STD-2155(AS): Failure Reporting, Analysis and Corrective Action
System

Getting Started with Windchill FRACAS

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill FRACAS module; see

Starting Windchill FRACAS on page 97 for more information.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If'the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill FRACAS

On the Module Selections toolbar, select the FRACAS / button and deselect all
other module buttons.

The tabbed Windchill FRACAS panes are shown in your System file.

Using Windchill FRACAS

The upper pane displays the System Tree Items table, which is the hierarchical
representation of your system assemblies and components and is shared with
several other modules. The lower pane displays all your FRACAS specific data.

FRACAS applications built with Windchill FRACAS are extensively
customizable. You can select which fields appear on your FRACAS and the names
of the fields, as well as completely customize your data entry forms and reports.

Additionally, you can perform your FRACAS activities on the Web using the web
version of Windchill Quality Solutions.
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Entering Incidents

The main data element of your FRACAS is an incident or a failure report of some
type. The data associated with the entry of an incident can be completely
customized in Windchill FRACAS. For our example, we'll enter an incident using
our sample Project, but please note that the entire data entry screen can be
modified to suit your needs.

1. In the System Tree Items table, select Touchpanel to display the incidents
associated with the touchpanel assembly in the FRACAS Incidents table in the
lower pane.

2. In the FRACAS Incidents table, click the last row, labeled < Click here to insert
a new record >. A new incident is entered and Incident ID and System Tree Item

are filled in automatically.

Note that the newly selected incident appears in red. We have our table set to
display all open incidents in red in order to highlight them. This is an optional
setting that you can customize.

For Location, select Austin.
For Technician, select Arnold Palmer.
For Serial Number, enter 42661.

AN AN o

-~ ]
Click Occurrence Date and click the calendar icon ®'. The Calendar control
appears.

1 September, 2011 r
Sun Mon Tue Wed Thu Fri 5at

28 29 30 31 1 3

4 5 6 7 8 9 10

11 12 13 14 15 16 17

18 19 20 21 22 23 24

25 26 27 28 29 30 1

2 3 4 5 6 7 8
[ | Today: 9/2/2011

7. Select today's date.

8. Tab to Incident Description, enter Customer reports that the
touchpanel is non-responsive in a certain area. Press Tab.
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Closed? is used to indicate if the incident has been analyzed and corrective
action implemented. Because this is a new incident report, leave Closed?
cleared.

9. View the other data fields in the FRACAS Incidents table. Most of these fields
are related to subsequent steps in the FRACAS process, such as corrective
action, analysis, and close out. For this example, do not enter any further data.

It may often be easier to enter and modify your FRACAS data in a form view. A
form allows you to view the data for one record at a time in a larger format for ease
of editing. Deciding whether to use a table view or a form view is a personal
preference. One of the advantages of Windchill FRACAS is that both views can be
available so that you can select the method you find most comfortable.

To review the incident data on a form:

1. Select the FRACAS Incident Form tab.

2. In the Incident Analysis section, for Date, enter today’s date.
3. For Analysis By, select Ethan.
4

For Analysis Description, enter Found hairline crack in upper right
portion of the touch panel. Contacted customer who
reported that original shipping container had arrived
slightly damaged.

For Failure Mode, select Cracked, Fractured.
Click the FRACAS Incidents tab to return to the table.

Filtering Data

Due to the large number of incidents that can be accumulated over time, Windchill
Quality Solutions supports data filtering to allow you to view a subset of your
entered data set based on criteria you specify. For example, you can view only the
incidents for which you are responsible, all the incidents that are currently open, or
a combination of the two.

Windchill FRACAS supports both fixed-value filters and parameterized filters.
When you create a parameterized filter, you must supply a parameter value when
the filter is applied. You can also build filters with multiple parameters. When
building a parameterized filter, be aware that the request for a parameter value
occurs whenever the filter is used, even during report or graph generation.

Using Predefined Filters
Windchill FRACAS is supplied with a number of predefined filters.
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Select the FRACAS Incidents tab in the lower pane.

2. In the toolbar, use the Filter selection box to select Open Incidents. The data is
filtered to show only incidents not marked as closed.

3. In the Filter selection box, select — No Filter — to remove the applied filter.

Creating Custom Filters

To create a custom data filter:

1. Select Filter » Filter Wizard. The Filter Wizard starts and displays the Specify
Filter Features page.

2. Leave Selects records only selected and click Next. The Specify Filter Field
page appears.

For Table type, sclect FRACAS Incidents.

4. From the list of fields, select Technician and click Next. The Specify Condition
page appears.

5. Leave is equal to selected and click Next. The Specify Field Value page
appears.

Leave Use a fixed value (specify the value below) selected.
For Specify the value here, click the dropdown control to display a selection
window.
b
Select Hugh Downs and click the green checkbox icon .
Click Next. The Review Filter page appears.

10. Make sure | want to add more conditions to the filter is cleared to indicate that
the filter is complete and click Next. The Save Filter page appears.

11. In the Save Filter page, select | want to save my filter for later use.
12. For Filter name, enter Technician Hugh Downs.
13. Select Save filter to My Filter File .

You have the option of saving filters to two different locations.

» Ifyou select Save filter to My Filter File, your new filter is stored in a file
accessible only to you; the filter is not accessible to other users with filter
permissions.

+ Ifyou select Save filter to the Filter File in this Project, the filter is accessible
to other users with filter permissions.

In some cases, you may be creating a filter that is for your own use. In that
case, it is best to save it to the My Filter file. In other cases, if you are
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creating a filter you know would be helpful to all team members, save it to
the Project Filter file to allow everyone to use it.

14. Click Next. The final page of the wizard appears.
15. Click Finish.

If this is the first time you have saved a filter, you are asked if you want to

create a Filter file in which to store your newly constructed filter. In the Create
Support File window that opens, click Yes to create this Support file. If you

have previously created a Filter file, this message does not appear. If a message

appears asking you if you want to overwrite or use the existing file, select the
Use Existing option.

The filter is applied to your data so that all incidents handled by technician
Hugh Downs are shown. Your new filter is shown in the Filter Selection box.
Notice that when you drop down the list in the Filter Selection box, your new
filter Technician Hugh Downs is preceded with a person icon instead of a
Windchill Quality Solutions icon. This indicates that the filter is stored in your
My Filter file and not the Project Filter file.

16. From the Filter selection box, select the — No Filter — option to return to the
original data view.

You can also modify your filters by selecting the My Filter File option in the Project
Navigator to open up the Filter file. New filters can then be added directly to the

Filter file.

Additionally, you can quickly build filters using the Filter Bar, which is located
above the column headers of the table. You can use the Filter Bar to sort records
and/or select the data to be shown in the table. You can also save filters created
using the Filter Bar by clicking the save icon ™ at the top left of the Filter Bar.
FRACAS Incidents
Fiter B |5 |
¥ | Incident ID

You can create the same custom filter from the previous exercise using the Filter
Bar:

1. Select the FRACAS Incidents table by clicking it.

2. In the Filter Bar, for Technician, click the icon for selecting a filtering
condition.

=©

Technician

3. Select is equal to as the condition.

To the right of this condition, click the dropdown control to display a selection
window.
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5. Select Hugh Downs from the list.

2 = ® =

Angelina Jaolie

Arnold Palmer

Harrison Ford >
i|Hug

Jimmy Buffett

|| John Travaolta
Kurt Russell
Morgan Freeman

[ Selectall ][ Clearal ]

=
6. Click the green checkbox icon .

The selection window closes and the FRACAS Incidents table reflects the
newly applied filter.

If you want to save your filter, click the save icon ™ to save for later use.

To return to the original data view, in the Technician column, click the filter
selection box and select (not filtered).

Viewing a Report

1. In the Project Navigator, under Reports > FRACAS Reports, select (Common)
FRACAS Incidents by Part Number to generate this report in the Preview

window.

This report outputs data on all incidents by part number. For each part number,
this summary report includes incident identifiers, descriptions, and incident
occurrence and entry dates. It also indicates who entered the incidents and
analyzed the incidents, supplies descriptions of the corrective actions taken,
and notes which incidents are closed.

You can use the various toolbar buttons in the Preview window to page through
your report, zoom in and out, and print the report.

2. When finished viewing the report, do one of the following to close the Preview
window:

* Select Preview » Close.
¢  Click the red Close button on the toolbar.

Graphing Data

1. In the Project Navigator, under Graphs > FRACAS Graphs, sclect (Common)
FRACAS Incidents per Part Number to generate this graph.
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This graph displays the number of incidents for each part number as a cylinder
bar graph.

2. When finished viewing the graph, select File » Close.

Windchill FRACAS Features

Windchill FRACAS includes a number of features and functions. A brief listing of
other topics of interest is shown below. For more information, see the help or guide
for Windchill Quality Solutions.

You can use the web version of Windchill Quality Solutions to perform your
FRACAS tasks via the Web. This zero-client, web-based interface provides a
rich Windows-like user interface. The web version provides significant
advantages for enabling FRACAS tasks to be performed in a collaborative
environment through its global accessibility.

Windchill FRACAS can perform MTBF calculations using your actual
incident, or field, data. Using the optional Operating Time to track the
operational time of your system, the FRACAS module can compute a wide
variety of MTBF metrics. Also, MTBF calculations can be customized through
filters to provide you with the key metrics you require.

The Form Designer enables you to create completely custom data entry forms
with any fields in any format you choose. The Form Designer provides
ultimate flexibility. Additionally, multiple forms can be grouped together in a
Form Set to enable you to create different forms for different process steps or
different users.

List Libraries allow you to define a list of selections for choice list fields so that
all users working on the same Project use the same terms. List Libraries ensure
data consistency as well as process efficiency.

The Enterprise Edition of Windchill FRACAS supports a customizable
workflow process. When an incident is moved from one process state to
another, automatic email notifications are sent to the appropriate personnel,
notifying them of the update.

The Enterprise Edition of Windchill FRACAS includes an alerts feature, which
enable you to send customized notifications to system users based on criteria
you define.

The FRACAS Incidents table and other FRACAS tables can be modified during
data entry by invoking the Format Builder with a simple right-click. You can
add columns as required “on the fly.”
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+  FRACAS data can also be imported using the Import Wizard. This feature
enables you to directly populate your FRACAS data with incident data
collected from other sources.

* The Enterprise Edition of Windchill FRACAS includes an Audit Trail module,
which tracks data modifications for audit requirements.

* The Windchill Quality Solutions Implementation Services team is available to
aid in design, development, and deployment of your FRACAS.
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Windchill Weibull
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about Weibull analysis and how to evaluate failure data using
Windchill Weibull.

In this section, you create a new data set in Windchill Weibull and find the
distribution that best fits the data points. You then view and customize the resulting
plot.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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Weibull Analysis Overview

The Weibull distribution is widely used in reliability engineering. While the
Weibull distribution is important for life data analyses, Weibull packages typically
encompass support for various other significant distributions used in statistical
analyses, such as exponential, normal, and lognormal.

Weibull techniques can be used on a variety of failure data, including field failures
and test failures, and in a wide variety of applications. The idea is to determine a
best fit distribution for the collected sample data in order to predict or uncover
trends.

In order to perform a Weibull analysis, the first and most important step is to gather
sound life data. You must identify the failure usage scale — units for the age of the
component or system being tested. Age of the component can be measured in
terms of hours, miles, cycles, or any other metric. It is also important to analyze
one failure mode at a time.

Once you identify the data associated with failure, you can enter the data, select the
distribution and estimation method, calculate and graph the results for the life data
set, and predict future trends using the results.

If you are unfamiliar with Weibull analysis or failure data analysis and would like
to study this topic in more detail, the following three selections are excellent
references:

» Reliability: A Practitioner's guide (Chapter 7)
» The New Weibull Handbook, 5th ed., by Dr. Robert B. Abernethy

Further details are available at http://www.bobabernethy.com/
products_handbook.htm.

Getting Started with Windchill Weibull

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill Weibull module; for

more information, see Starting Windchill Weibull on page 107.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If'the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill Weibull

On the Module Selections toolbar, select the Weibull button [A and deselect all
other module buttons.

The tabbed panes for Windchill Weibull are shown in your System file.
The Windchill Weibull interface consists of three panes.

LDA Navigator

The LDA Navigator displays your list of data sets. When you select a data set in the
LDA Navigator, the other two panes display information specific to that data set.

Data sets are organized into three analysis types, which can be accessed by
clicking the appropriate link under Analysis type:

1. Life Data, which may consist of Life Data, Non-Parametric Life Data, and
Reliability Growth Data, as well as Multiple Data Sets, which enable you to
display multiple data sets concurrently on a plot.

2. Warranty Analysis, which enables you to input and analyze warranty
information (information about the date a product was produced or sold and the
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date it was returned from the field). You can also extrapolate a life data set
from warranty data and analyze it using typical life data analysis techniques.

3. Degradation Analysis, which uses the changing rate of degradation of a
product and a critical value at which the unit is assumed to fail to create a
model for predicting the times at which the product fails in the future. You can
also extrapolate a life data set from degradation information and analyze it
using typical life data analysis techniques.

In the LDA Navigator, you can create new data sets and delete sets you no longer
need. You can also further organize your data by creating new sub-folders within
the data types.

Weibull Parameters

The pane beneath the LDA Navigator consists of any number of tabs, depending on

the analysis type. For Life Data, this pane consists of up to three tabs: Parameters,
Advanced (where available), and Plot Options. For Warranty Analysis and

Degradation Analysis, additional tabs would be available. These tabs display
options for specifying plot parameters and displaying plots.

The Parameters tab enables you to specify parameters for the selected data set. The
Advanced tab displays additional options for defining estimation methods and

other parameters of the distribution. Finally, the Plot Options tab provides control
over the number and type of plots displayed in the Weibull Plot tab on the right side
of the interface.

When a data set is analyzed, the results are displayed at the bottom of all three
windows in the Weibull Parameters pane. You can also fix one or more of the

calculations in the Calculation results section. The values displayed in the
Calculations results arca of the Parameters window differ based on the distribution

selected.

The Weibull Parameters pane also includes a toolbar, which gives you access to
common tasks, including:

» Calculate

« Show Plot

» Additional Data Set Calculations (Summary Calculator)
» Best Fit Distribution Analysis

Weibull Data Points

To the right of the LDA Navigator and Weibull Parameters panes is a pane
consisting of two tabs — Weibull Data Points and Weibull Plot.
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Weibull Data Points displays information about each item in the data set selected in
the LDA Navigator. The column headings in this display vary, depending on the
selected data type.

Note

You can modify the column heading names to suit your process needs. Simply

double-click on the column heading, then specify the desired name in the Change
Column Name window.

Weibull Plot displays a plot representing the selected data set and the distribution(s)

applied to it. The parameters, distribution, and number of plots displayed in
Weibull Plot are all controlled by the Weibull Parameters.

You can also modify the appearance of your Weibull plots using the Plot
Properties. You change the plot properties later in this section.

Using Windchill Weibull

You now create a data set, enter data points, and find the distribution that best fits
your data points.

Creating a Data Set
To create a new data set:

1. In the LDA Navigator, under Analysis type, click Life Data to ensure you are
viewing the Life Data data sets.

2. In Data Sets, select Life Data.

3. Select Insert » LDA Data Set. A new Life Data Analysis data set appears under
Data Sets. This new row is automatically selected.

4. Enter My Weibull Data Set as the name of the new data set.
Select the Parameters tab in the Weibull Parameters pane.
In Parameters, use the data values automatically set as the defaults:

Weibull Parameters

Data type: [Exact'ﬁmes

!;‘- Suspensions
Distribution: ['.-'u'eibull
Model: [2 Parameters

Windchill Weibull 109



Entering the Data Points

Once the analysis parameters are specified, you can enter data points in the Weibull
Data Points table. You can either specify the data points manually, or you can copy

and paste them from a word-processing file, spreadsheet, or other electronic file.

For this example, you use the built-in random data set generator to automatically
create a set of data points. In actual use you would not create a data set in this
manner; it is a feature available for testing and example purposes.

1. Select the Weibull Data Points tab.

2. Select LDA » Generate Random Data Points. The Generate Random Data
Points window opens.

3. Use the values automatically set as the defaults:

Generate Random Data Points
Quantity: inp  Percent suspensions: 0
p: 2
n: 10
l 0K ] l Cancel J l Help

L

4. Click OK to generate the random data points.

Finding the Best Fit Distribution

Once you have entered your data, you can determine the failure distribution that
best represents your life data. Windchill Weibull includes a Best Fit Distribution
analysis tool that recommends the best possible distribution for the selected data
set.

1. Select LDA » Find Best Fit Distribution. The Best Fit Distribution window opens
and shows all of the available failure distributions. You can select which
distributions you want to check against the data set, then direct Windchill Wei-
bull to analyze the selected distributions for the one that best fits. In this case,
leave all distributions selected.

2. Click Analyze to determine the distribution that best fits your data. A ranking
for each distribution appears in the Rank column.

Depending on your data set, the recommended distribution may not be the
distribution currently selected for the data set (in this case, the Weibull [2
Parameters] distribution). If the optimal distribution is not Weibull (2
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Parameters), you would see the Change button at the bottom of the window,
along with a query as to whether you want to change the distribution setting to
match the optimal determination.

For this example, ignore the Change option if it appears, and keep the
distribution setting as Weibull (2 Parameters).

3. Click Close.

Viewing Calculations

Calculations, which in Windchill Weibull are performed dynamically, are based on
the distribution specified. In the case of the Weibull distribution, the Weibull
module calculates the Beta (B), the slope of the line; the Eta (1), the characteristic
life, or the point at which 63.2% of the items in the data set have failed; the Rho
(p), a value between -1 and 1 that expresses how well the data fits the probability
line; and the Rho-squared (p?2), the 10th percentile of the correlation coefficient.

To view these values, select Parameters in Weibull Parameters.

Viewing Plots

When performing Weibull analyses, the resulting Weibull plots are automatically
generated and can be viewed on the Weibull Plot. These plots are updated
dynamically as you make changes. So, for example, if you change the distribution,
the Weibull Plot is dynamically updated to display the newly-selected distribution.

To view the resulting Weibull graph:
1. Select the Weibull Plot tab.

There are many things you can learn by examining a Weibull plot. For
example, if points are concentrated in one particular area, a batch problem may
have occurred due to production or assembly processes, maintenance or
overhaul schedules, or increases in service usage.

Sharper corners or dogleg bends, on the other hand, may indicate multiple
competing failure sources. For example, many components have a high infant
mortality due to production and quality problems, then another group of
failures later in life when they begin to wear out. In this case, you may choose
to make a separate Weibull plot for each failure mode, with the failure points
for other failure modes treated as suspensions, since Weibull analysis is most
effective when each data set concentrates on one failure mode.

You can also determine if the distribution selected is a good fit for your data
set. For example, if the failure data points curve in comparison to the best fit

Windchill Weibull 111



line, then the Weibull distribution probably wasn’t the best fit for the data, and
you could use Best Fit Distribution Analysis to determine a more appropriate
distribution.

Determine the B10 Life, which is the time at which 10% of the items in the
data set have failed. To do so, move your cursor to the intersection of the plot
line and the horizontal line at 0.10 Probability.

Probability Line

Time: 1.159618
Probability: 0.056515

Probability

Your time varies, depending on the random data points you generated.

Tip
You can always zoom in on a specific area of the plot by holding down the left

mouse button and drawing a selection box around the area you want to view
more closely. To reset your zoom, right-click and select Reset Zoom.

Customizing the Plots

The Weibull graph is very easy to customize. The Plot Properties window enables
you to change the plot colors, labels, and fonts to suit your needs.

I.
2.
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Select the Weibull Plot tab.

Right-click in the plot and select Edit Plot Properties. The Plot Properties
window opens.

On the General page, change Title to My Weibull Plot.
For Legend location, select Inside Movable.

In the left pane, select the Axis page. Here you can change the range of your
axes, as well as specify a minimum and maximum value. Make no changes.

In the left pane, select the Color page.

Under Style, for Quickstyle, select Light Line. Quickstyles apply a predefined
set of colors to the plot and its background. If you set the Quickstyle to General
or No Style, you can also specify your own color preferences using the color
selection controls in the Color section.
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8. In the left pane, select the Series Colors page. This page enables you to set the
colors of each plot line when plotting multiple data sets.

9. In the left pane, select the Font and Font Size pages. On these pages, you can
set specific fonts for the titles and plot labels. You can also adjust the sizes of
all fonts using the slider bars and preview the resulting changes as you make
adjustments.

10. Click OK. Note the changes to your plot. The title is now “My Weibull Plot”
the color palette has changed, and the legend is now on top of your plot rather
than at the center right of the plot pane. Because you set the legend to Movable,
you can now place this legend wherever you’d like it on the pane.

11. Hover your mouse pointer over the legend until your cursor changes to a hand.
Select the legend and drag it to the bottom right of your plot.

Viewing Plots for Multiple Data Sets

Multiple Data Sets enable you to plot sets with similar parameters and the same
distribution simultaneously on the same graph. You can use this type of plot to
compare any number of things, including:

* Data sets from different failure modes for the same product

» Data sets collected at different operating conditions (e.g. one data set with
circuit board test to failure data at 50 deg C vs. the same at 60 deg C)

» Data sets of similar products (e.g. failure data for bearings from two different
suppliers)

» Data sets from different time frames (e.g. if data is recorded by calendar year)
» Data sets collected from a system before and after a redesign

In this case, you view data sets for a hard disk before and after a redesign.

To view both hard disk data sets on one plot:

1. Select the LDA Navigator.

2. In Data Sets, select Multiple Data Set Plots.

3. Select Insert » Multiple Data Set Plot. A new data set row appears under the
Multiple Data Set Plots heading. This new row is automatically selected.

4. Enter My Weibull Multiple Data Set Plot.

5. In Weibull Plot Options, select the following data sets in Data sets:
* Hard Disk Revision A
» Hard Disk Revision B

The plot in the Weibull Plot tab is automatically updated with each new data set
as you add it.
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Windchill Weibull Additional Features

Windchill Weibull includes a number of other functions and features. A brief
listing of other topics of interest is shown below. For more information about these
features, see the help or guide for Windchill Quality Solutions.

» The Set Location Parameter (t0 shift) function allows you to establish a
minimum life value for the failure data set, signifying a guaranteed failure-free
period at the beginning of the cycle. Typically used with the Weibull
distribution, this parameter straightens plots of data values if the data shows a
pronounced curve compared to the failure distribution line.

*  Windchill Weibull supports reliability growth analysis, which tracks the
increase in the reliability of a product over time. In reliability growth analysis,
the reliability, mean life, or failure rate is tracked over time, enabling you to
predict future reliability values based on the current rate of growth of the
measurement of interest. Windchill Quality Solutions uses the Duane/Crow-
AMSAA model to perform reliability growth analysis.

* You can analyze data without specifying an underlying distribution using the
Non-Parametric Life Data Analysis type. The Weibull module supports the
Kaplan-Meier and standard actuarial methods.

*  Windchill Weibull includes support for Degradation Analysis, which enables
you to forecast future failures based on measurements of degradation or
performance over time. The Weibull module supports a number of degradation
models, including Linear, Exponential, and Power.

» The General Statistics Calculator enables you to perform a number of different
statistical calculations, including Binomial, Chi-Squared, Life-Usage
Interaction, Mean and Eta, Poisson, Random Point Interaction, Strength-Load
Interaction, and Student T.

» The Test Planning Calculator enables you to determine the number of
components to test or the amount of time for which to test. The Test Planning
Calculator supports three methods: Parametric Binomial, Non-Parametric
Binomial, and Exponential Chi-Squared.

* The Summary Calculator allows you to perform additional calculations on data
sets that are analyzed based on parametric distributions, e.g. Life Data
Analysis, Reliability Growth, and Warranty Analysis data sets. These
additional calculations include Standard Probability, Conditional Probability,
Failure Rate, Warranty Time, Time to Failure, etc.

* You can optimize your component replacement strategy with the Optimal
Replacement Wizard. Optimizing your replacement strategy can help you
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minimize system downtime and the overall cost of the system over the long
term.

* The common Windchill Quality Solutions database allows you to link Weibull
data with Windchill Prediction and Windchill RBD. This level of integration
allows you to incorporate results of Weibull analyses in your reliability
predictions and reliability block diagrams for more accurate metrics.
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about accelerated life testing and how to accomplish it using the
Windchill ALT module.

In this section, you create a new data set in Windchill ALT, run calculations, and
view the resulting graph.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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ALT Overview

ALT (accelerated life testing) is a technique for finding the reliability
characteristics of a product more quickly than with typical reliability estimation
methods. When ALT techniques are applied, products are tested in high-stress
situations that typically shorten product life or hasten degradation of product
performance (where “stress” means any accelerating variable). By statistically
fitting an acceleration model to the test data and extrapolating the fitted model, you
can then estimate the life or degradation of the product at the lower stress levels
encountered in normal use. Thus, accelerated testing plays a key role in meeting
the requirements of shorter product development cycles.

This technique is especially useful for determining or demonstrating the field
reliability performance of highly reliable products. When tested under normal use
stress levels, products with high reliability last so long, or degrade so little, that
their performance and lifetime cannot be estimated. Accelerated testing yields
reliability estimates of such products in a much shorter time.

In a simple situation, the components under test are divided into multiple groups
containing one or more components. Each group of the components is tested at
specific combinations of stress levels. You enter the failure and suspended times
corresponding to the stress levels in the software. Under this setup, each
component is subjected to a specific combination of stresses where the stresses are
constant with respect to time. Hence, it is known as a constant stress test.

In some cases, the accelerated stresses on the components are changed with time.
The variations in the stresses are specified using stress profiles. Generally, the
stresses are increased with time such that the test can be completed within a
predetermined time with some failures.

For further information, see the following references.

* Meeker, William Q., and Escobar, Luis A., Statistical Methods for Reliability
Data, John Wiley & Sons, Inc., New York, 1998

*  Meeker, William Q., A Comparison of Accelerated Life Test Plans for Weibull
and Lognormal Distributions and Type I Censoring, Technometrics, Vol. 26,
No. 2, pp. 157-171, 1984

» J. E. Dennis, Jr. and Robert B. Schnabel, Numerical Methods for
Unconstrained Optimization and Nonlinear Equations, Classics in Applied
Mathematics 16

» Numerical Recipes: C++ Version (2007)
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Getting Started with Windchill ALT

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill ALT module; for more

information, see Starting Windchill ALT on page 119.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.

If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If'the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill ALT

On the Module Selections toolbar, select the ALT button @ and deselect all other
module buttons.

The tabbed panes for Windchill ALT are shown in your System file. The Windchill

ALT interface consists of three panes: LDA Navigator, ALT Parameters, and ALT
Data Points.
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The LDA Navigator displays the list of data sets. When you select a data set in the
LDA Navigator, the other two panes display information specific to that data set.

There are two types of data sets, Accelerated Life Testing and Accelerated
Degradation.

The bottom left pane, located beneath the LDA Navigator, consists of the
Parameters tab and the Plot Options tab. The Parameters tab enables you to

specify parameters for the selected data set, while the Plot Options tab provides
control over the number and type of plots displayed in the ALT Plot tab on the
right-hand side of the interface. When a data set is analyzed, the results are
displayed at the bottom of both of these tabs. In this section, the Calculation results
section, you can also fix one or more of the calculations. This pane also includes a
toolbar, which gives you access to common tasks.

On the right is a pane consisting of three tabs — the ALT Data Points tab, the ALT
Results tab, and the ALT Plot tab.

The ALT Data Points tab displays information about each item in the data set
currently selected in the LDA Navigator. The column headings in this display vary,
depending on the selected data type. The ALT Results tab displays the results for
the selected data set, while the ALT Plot tab displays a plot representing the selected
data set and the distribution applied to it. The parameters, distribution, and number
of plots displayed in the ALT Plot tab are all controlled by the ALT Parameters
pane.

Using Windchill ALT

You now create a data set, enter data points, and find the distribution that best fits
your data points.

Creating a New Data Set

In this section, you create a random data set and specify the stress factors for this
set. Accelerated life test stresses and stress levels should be chosen so that they
accelerate the failure modes under consideration but do not introduce failure modes
that would never occur under use conditions. Normally, these stress levels fall
outside the product specification limits but inside the design limits. If these stresses
or limits are unknown, multiple tests with small sample sizes can be performed in
order to ascertain the appropriate stress (stresses) and stress levels.

In this case, you specify one stress factor — Temperature.

To create a new data set:
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1. In the LDA Navigator, under Analysis type, click Accelerated Life Testing to
ensure you are viewing the Accelerated Life Testing data sets.

In Data sets, select Life Data.

3. Select Insert » ALT Data Set. A new Life Data Analysis data set appears under
Data Sets. This new row is automatically selected.

4. Enter My ALT Data Set as the name of the new data set.
Select Parameters in ALT Parameters.
6. In Parameters, use the default values automatically set as the defaults:

ALT Parameters

Data type: [Exact Times

_ ] Suspensions [ _ Grouped
Distribution: ['r'u'eibull vJ
Stress: Constant
Life stress model: Arrhenius

Stress Model

7. Click Stress Model. The Stress Model window opens.

8. In the first row, select Name (labeled Stress 1) and enter Temperature.
9. For Usage Stress, enter 310.

10. For Default Value, enter 350.

11. Click OK to dismiss the Stress Model window.

Entering the Data Points

Once the analysis parameters are specified, you can enter data points in the table
on the ALT Data Points tab. You can either specify the data points manually, or you
can copy and paste them from a word-processing file, spreadsheet, or other
electronic file.

For this example, you use the built-in random data set generator to automatically
create a set of data points. In actual use you would not create a data set in this
manner; it is a feature available for testing and example purposes.

1. Select the ALT Data Points tab.

2. Select LDA » Generate Random Data Points. The Generate Random Data
Points window opens.

For Beta B, enter 6.
For B, enter 17000.
For C, enter 3.0e-12.
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6. On the right, select < Click here to add a stress level >.
7. For Quantity, enter 2.
8. For Temperature, enter 493.
9. Repeat steps 68 to add the following:
Quantity Temperature
4 513
5 533

10. Click OK to generate the random data points.

Viewing Calculations in Windchill ALT

Calculations determine the required parameters for the selected life stress model,
and are based on the distribution specified.

To run calculations:

1. Select System » Calculate, or click the calculate = icon on the Standard

toolbar. The Calculate window opens.

2. In the left pane, select the Calculation Selection page (if it is not already
selected).

3. In the right pane, click Clear All and then select ALT to perform calculations
only for the ALT module.

In the left pane, select the ALT page.

Select Selected data set only and click OK. When completed, the View
Calculation Results window opens.

Tip
You can print your calculation results by clicking Print in the View Calculation

Results window. You can also save them to a Microsoft Excel spreadsheet by
clicking Excel.

6. Click Close when you have finished reviewing results.

Viewing Windchill ALT Plots

After performing calculations, the resulting ALT plots are generated and can be
viewed on the ALT Plot tab. Because the plot parameters are based on the stress
parameters, you would have to recalculate if you change the distribution, stress
type, or stress model.

To view the resulting ALT graph:
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1. At the bottom left, select the Plot Options tab.
2. For Plot type, select Acceleration Factor vs Stress.

3. In the right pane, view the plot in the ALT Plot tab.

This plots displays the acceleration factor with respect to the defined
Temperature stress. If we had added other stresses, they would have been
considered fixed at the usage stress level(s).

Tip

You can always zoom in on a specific area of the plot by holding down the left
mouse button and drawing a selection box around the area you want to view
more closely. To reset your zoom, right-click and select Reset Zoom.

Windchill ALT Additional Features

includes a number of features and functions. A brief listing of other topics of
interest is shown below. For more information, see the help and guide for Wind-
chill Quality Solutions.

*  Windchill ALT includes support for both Constant and Time-Varying stresses
and the Weibull, Exponential, and Lognormal distributions.

* The ALT module supports all commonly-used accelerated life testing models,
including Arrhenius, Eyring, Inverse Power Law, Temperature-Humidity,
Temperature-NonThermal, Generalized Eyring, Proportional Hazards, and
General Log-Linear.

»  While this section demonstrates the Acceleration vs. Stress plot type, you can
plot many different types of graphs in Windchill ALT, including Reliability vs.
Time, PDF Plot, Life vs. Stress, etc.

* As in Windchill Weibull, you can compare and contrast multiple plots in Wind-
chill ALT by setting the number of plots to Multiple in the ALT Plot Options
tab. You can also import data sets, just as you do in Windchill Weibull. For an
introduction to this functionality, please see Using Windchill Weibull on page
109.

Windchill ALT 123






11

Windchill Maintainability

Maintainability Prediction OVEIVIEW ..............uiiiiiiiiii e 126
Getting Started with Windchill Maintainability ..............ccooooiiii e, 126
Using Windchill Maintainability .............ooooiii e 127
Performing CalCulations .............. i 128
VIEWING REPOIS ...ttt e e e e e e eeaaas 132
Windchill Maintainability Additional Features...............coooiiiiiii 132

This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about maintainability predictions and how to perform them using
Windchill Maintainability.

In this section, you review and enter data in Windchill Maintainability, perform
calculations on that data and view a report.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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Maintainability Prediction Overview

Maintainability predictions provide metrics related to the repair of equipment. The
main goal of performing a maintainability prediction analysis is to determine the
amount of time required to perform repairs and maintenance tasks, so that you are
aware of the time it would take and what tasks would be required to bring the
system back to an operable state after a failure.

The main metric in maintainability predictions is MTTR (mean time to repair),
which is computed using various methods depending on the maintainability
analysis method employed. Various other repair metrics are important as well, such
as MCMT (mean corrective maintenance time) and MPMT (mean preventive
maintenance time). MTTR influences system availability, which is the measure of
the likelihood that a system is in an operable state. In many industries, availability
is a key measure of system performance, so having an accurate measurement of
this metric is crucial. Also, availability can be a metric to verify if the system, as
designed, would meet operational requirements.

Maintainability predictions can also help you to identify areas of poor
maintainability, which may justify a change in design and/or repair procedures.

To complete a maintainability prediction, you would need failure rate data for the
repairable items and data regarding the tasks and associated times to complete
repairs. Maintainability predictions are often performed based on established
standards. One of the most prominent is MIL-HDBK-472, specifically procedures
2, 5A, and 5B.

If you are unfamiliar with maintainability prediction analysis and would like to
study this topic in more detail, please refer to MIL-HDBK-472.

Getting Started with Windchill
Maintainability

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill Maintainability

module; for more information, see Starting Windchill Maintainability on page 127.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If'the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill Maintainability

On the Module Selections toolbar, select the Maintainability button /N and
deselect all other module buttons.

The panes for Windchill Maintainability are shown in your System file.

Using Windchill Maintainability

When you have activated Windchill Maintainability, the upper pane displays the
System Tree Items table, which is the hierarchical representation of your system

assemblies and components and is shared with several other modules. The lower
pane, Maintainability Data, displays all your maintainability specific data.

You now review and enter data and learn about Maintainability Task Libraries.

Reviewing and Entering Data

1. In the System Tree Items table, select Motherboard. The maintainability data
for this item is shown in Maintainability Data.

2. Review the Repair definition, Repair level, and other fields on the
Maintainability Data pane, including the existing Repair tasks.
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3. Select Touchpanel and Memory Board and review the maintainability data for
each of those assemblies.

4. Select Hard Disk Assembly. Currently there is no data entered for repairing this
assembly.

5. In Maintainability Data, under Repair tasks, click < Click here to insert a new
record >.

In the new record, for Task Code, select Remove HD Assy.

Select < Click here to insert a new record > again and for Task Code, select R/R
Hard Disk as the second task.

Note
R/R stands for “Remove and Replace.”

8. Select < Click here to insert a new record > again and for Task Code, select
Replace HD Assy for the third and final repair task for the Hard Drive.

The display-only fields in Totals, Numberof items, Total time, and Manminutes,
have also been automatically updated.

Maintainability Task Libraries

Maintainability repair times can be stored in Maintainability Task Library files and/
or Maintainability FD&I Output files. To see the data in the Maintainability Task
Library file for this sample:

1. In the Project Navigator, click Expand files to display all Support files.

Note
You may have to click Collapse files first, then Expand files.

2. Under Support Files>Maintainability>Task Library, select Maintainability Task
Library.

3. Select various tasks in the Tasks pane on the left to see the associated repair
data.

4. When finished, select File » Close to close the Maintainability Task Library
file.

5. In the Project Navigator, click Collapse files to hide the Support files.

Performing Calculations

Windchill Maintainability computes a number of maintenance related values, such
as MTTR (mean time to repair), MCMT (mean corrective maintenance time), and
MPMT (mean preventive maintenance time).
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A sampling of supported calculations is outlined below and very brief descriptions
are provided. For more information on these calculations, see the guide or help for
Windchill Quality Solutions.

Calculation Description

Maintainability Index | The total maintenance effort, including both preventive
and corrective maintenance, that is required to maintain
a product in operational status during a specific time
period.

Corrective maintenance restores a failed system to opera-
tional status by repairing or replacing failed component
(s). Preventive maintenance is the practice of replacing
components or subsystems before they fail in order to
promote continuous system operation.

The Maintainability Index is calculated based on MIL-
HDBK-472 Procedure 2. This calculation uses the values
from both (1) and (2) of the MAMT calculation.

Mean Time to Repair |MTTR is the average time it takes to repair a failed unit
(MTTR) and return it to an operational state, based on the average
repair time for its replaceable components. The MTTR is
calculated by rolling up the average repair times for low-
er-level components to compute subassembly and sys-
tem repair values.

If Windchill Maintainability is used in conjunction with
Windchill Prediction, the MTTR values of components
and subassemblies can be obtained from Windchill
Maintainability computed MTTR values. Units for
MTTR values are typically hours or minutes.

MTTR is also referred to as MCT (mean corrective
time).

Availability The probability that a system is operating properly at a
specific time point. Availability, like Reliability, is a
time-based probability metric between 0 and 1.

Availability is a function of both reliability (how quickly
a system fails) and of maintainability (how quickly the
system can be repaired).

Mean Corrective Main- | The mean time required to perform all corrective mainte-
tenance Time (MCMT) |nance actions, i.e. the average time required to restore a
failed system to operational status by repairing or replac-
ing failed component(s).
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Calculation Description
Mean Active Mainte- | The average time required to perform all corrective and
nance Time (MAMT) |preventive maintenance actions. Corrective maintenance

restores a failed system to operational status by repairing
or replacing failed component(s), while preventive main-
tenance is the practice of replacing components or sub-
systems before they fail in order to promote continuous
system operation.

The calculation is taken from MIL-HDBK-472 Proce-
dure 2.

Max Corrective Main-
tenance Time
(MAXCMT) for Sigma
Percentile

The time needed to accomplish the specified percentage
of potential corrective maintenance tasks, frequently the
90th or 95th percentile.

For example, if you specify a value of 90, the MAXCMT
is the time within which 90% of all maintenance actions
can be accomplished.

The calculation is taken from MIL-HDBK-472, Proce-
dure II1.

Mean Maintenance
Manhours per Repair
(MMH/Repair)

This calculation is identical to the MTTR calculation ex-
cept manhour values are substituted for time values.

Mean Maintenance
Manhours per Mainte-

This calculation is similar to the MMH/Repair calcula-
tion except that the time spent as a result of false alarms

nance Action (MMH/ |is also taken into account.

MA)

Mean Maintenance The sum of all corrective, preventive, and false alarm re-
Manhours per Operat- | pair times divided by the total operating hours.

ing Hour (MMH/OH)

Mean Maintenance The sum of all corrective, preventive, and false alarm re-
Manhours per Flight | pair times divided by the total flight hours.

Hour (MMH/FH)

Mean Preventive Main- | The mean time required to perform all preventive main-

tenance Time (MPMT) |tenance actions, i.e. the average time required to replace

components or subsystems before they fail in order to
promote continuous system operation.

The calculation is taken from MIL-HDBK-472 Proce-
dure 2.

Percent Isolation to a
Single RI

The percentage of faults detected that can be isolated to
a single part.

Percent Isolation to a

The percentage of faults detected that can be isolated to
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Calculation Description

Group of RIs n or fewer replaceable items, where n is a specified

quantity.

Running Calculations

To perform Windchill Maintainability calculations:

I.

Select System » Calculate, or click the calculate
toolbar. The Calculate window opens.

1con on the Standard

In the left pane, select the Calculation Selection page if necessary.

In the right pane, click Clear All and select Maintainability to perform
calculations only for the Maintainability module.

In the left pane, select the Maintainability page.
A number of calculations are available.

Leave the default values:

"« Maintainability Calculation Options

Repair level: =

[[]Percent isclation to a single replaceable item
[TIPercent isclation to a group of replaceable items

[#] Mean maintenance manhours per repair (MMH/Repair)

[#] Mean maintenance manhaours per maintenance action (MMH/MA)
[#] Mean maintenance manhours per operating hour (MMH/OH)

[ Mean maintenance manhours per flight hour (MMH/FH)

D Max corrective maintenance time for sigma percentile

E] Mean corrective maintenance time
L'_-ﬂ Mean preventive maintenance time
E Mean active maintenance time

[T Maintainability index

6. Click OK to perform the calculations. The Calculation Progress pane displays

status information. When the calculations are complete, the View Calculation
Results window opens.
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Values that aren’t calculated display a value of #.#. These are calculation
options you left unchecked on the Calculate window.

Tip
You can print your calculation results by clicking Print in the View Calculation
Results window. You can also save them to a Microsoft Excel spreadsheet by

clicking Excel.

7. Click Close when you have finished reviewing results.

To redisplay the results at any time, select System » View Calculation Results. If
you have only one module enabled, the results are displayed for that module. If
you have more than one module enabled, select the appropriate page to view the
results. When finished, click Close.

Viewing Reports

1. In the Project Navigator, under Reports > Maintainability Reports, sclect
(Common) Maintainability Standard to generate this report in the preview

window.

This report outputs basic maintainability information about the system and its
components, including item names, part numbers, reference designators,
quantities, and calculated results for failure rate, MMH/OH, and MTTR.

You can use the various toolbar buttons in the preview window to page through
your report, zoom in and out, and print the report.

2. When finished viewing the report, do one of the following to close the preview
window:

* Select Preview » Close.
¢ Click the red Close button on the toolbar.

Windchill Maintainability Additional
Features

Windchill Maintainability includes a number of other features and functions. A
brief listing of other topics of interest is shown below. For more information on
these features, see the help or guide for Windchill Quality Solutions.
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Windchill Maintainability includes a Maintainability Tasks Library file with
standard maintenance tasks and repair times taken from MIL-HDBK-472. This
data makes the process of entering repair tasks and times more efficient.

You have the option of performing maintainability calculations based on MIL-

HDBK-472 Procedure 2, 5A, or 5B standards. You can select or clear the
Procedure 5A check box under the Maintainability heading in the File

Properties for the System file.

Windchill Maintainability supports user-created Maintainability Tasks Library
files. You can create your own Libraries and then use them in any of your
Project files.

Maintainability Groups files support the definition of maintainability groups
for use when performing MIL-HDBK-472 Procedure 5A calculations.

Windchill Maintainability links with other modules such as Windchill Predic-
tion and Windchill RBD.

Custom repair levels can be defined in place of using the default
Organizational, Intermediate, and Depot choices.

You can export data to LSAR compatible formats. Select System » Generate
LSAR File.
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about Markov analysis and how to perform one using Windchill
Markov.

In this section, you review Markov state properties and create a simple Markov
diagram. You then perform calculations and view a standard report and graph on
the Markov data.

Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.

135



Markov Analysis Overview

Markov analysis is a technique used to study dynamic system behavior. In terms of
all reliability analysis techniques, Markov analysis is the only method which can
be used to accurately model many complex systems which may include common
cause failures, imperfect coverage, shared load redundancy, complex repair
policies, degradation, shock effects, induced failures, dependent failures, and other
sequence-dependent events. While other modeling methods, such as fault trees and
reliability block diagrams, can model some of these unique system complexities,
Markov analysis provides the broadest capabilities in terms of handling diverse
system characteristics.

To complete a Markov analysis, a Markov diagram, also known as a state
transition diagram, must be constructed. The state transition diagram is a graphical
representation of the system's operational, degraded, and failed states as well as the
transitions between them. Most commonly, transition rates are failure rates or
repair rates for continuous Markov models. The Markov diagram ultimately
represents the system as a set of random variables and their interdependencies. The
results of a Markov analysis can include many parameters such as reliability,
availability, MTBF, and failure rate.

If you are unfamiliar with Markov analysis and would like to study this topic in
more detail, the following is an excellent resource:

» Reliability: A Practitioner's guide (Chapter 8)

Getting Started with Windchill Markov

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill Markov module; for

more information, see Starting Windchill Markov on page 137.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.

» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):

1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If'the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill Markov

rag)
On the Module Selections toolbar, select the Markov button @. and deselect all
other module buttons.

The panes for Windchill Markov are shown in your System file.

Using Windchill Markov

The Markov Diagrams table lists all the Markov diagrams in your System file. The
Markov Diagram pane displays the graphical representation of the Markov model

selected in the Markov Diagrams table.

The states of the Markov diagram are denoted as colored graphical symbols. The
transitions are symbolized by arrows connecting two states together.

You now review Markov state properties and create a simple Markov diagram.
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Reviewing Markov State Properties

For ease of viewing, you may want to resize the Markov Diagram pane using the
splitter control, which appear when you move the mouse cursor between the two
panes. You can also use the horizontal and vertical scroll bars in the Markov
Diagram pane to reposition the diagram. Finally, you can zoom in on an area of the
diagram by right-clicking and choosing a zoom option.

This sample Markov diagram is modeling the sequence of events leading to a
memory failure. The memory begins in an operational state. If one SRAM SIM
fails, the system operates in a degraded mode, and ultimately fails if all three
SRAM SIMs fail.

1. In the Markov Diagram pane, double-click State5 to open the Calculation
Properties window for this state. Notice that you can set the condition of the

state to Good, Failed, or Degraded. You can also associate a Cost Gain or Loss
with the state.

The Results page displays the most recent calculated results for this state. Note
that if calculations are not yet available, this page is empty.

Click Cancel to close the Calculation Properties window.

3. Select Markov > View States to display the Markov States window, which
contains a listing of all the states currently in your Markov diagram. In this
window, you can edit the associated data in one place, which is useful when
you have a large Markov diagram and need to manage many states. Click
Close to close the Markov States window.

4. Move the mouse cursor over the leftmost black arrow between State5 and
State10 in the Markov diagram until the cursor changes to a four-sided arrow;
then, double-click. You can see the Rate associated with this transition and also
the associated Cost Gain or Loss.

The Results page displays the most recent calculated results for this transition.
Note that if calculations are not yet available, this page is empty.

Click Cancel to close the window for the transition.

Select Markov > View Transitions to display the Markov Transitions window,
which contains a listing of all the transitions currently in your Markov diagram.
In this window, you can edit the associated data — useful when you have a large
Markov diagram and need to manage many transitions.

7. Click Close to close the Markov Transitions window.

Creating a Simple Markov Diagram

Now that you have seen what a Markov diagram looks like in Windchill Markov,
you create a simple diagram:
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9.

10.
11.

12.
13.

14.
15.

Select the Markov Diagrams table.
Click < Click here to insert a new record > to insert a new diagram.

For Identifier, enter My Markov Diagram. An initial state is already added
for you.

Select the Markov Diagram pane.
Select Insert » State. The Insert State window opens.

Click OK to select the default style. When you move the mouse cursor into the
diagram pane, the cursor changes into the shape of the selected style.

Move the cursor to the right of the initial state and click the mouse button. The
cursor remains in the shape of the figure to let you know that you can continue
to insert states, if desired.

Right-click to exit the insertion mode.
Select Markov > Auto Connect States to automatically connect the states.
Double-click the top transition line to display its Properties window.

For Rate, enter 0. 00015 to indicate a failure rate of 0.00015 failures/hour;
then, click OK.

Double-click the bottom transition line to display its Properties window.

For Rate, enter 12 . 5 to indicate a repair rate of 12.5 repairs/hour; then, click
OK.

Double-click the right-most state to display its properties.
For State, select Failed and click OK.

This simple diagram models a system which begins in an operational state then
fails at failure rate of 0.00015 failures/hour, at which time the system reaches the
failed state. When repaired, at a repair rate of 12.5 repairs/hour, the system returns
to the operational, or good, state.

Performing Calculations

Windchill Markov computes an extensive set of reliability related values. A
sampling of supported calculations is outlined below and very brief descriptions
are provided. For more information on these calculations, see the help or guide for
Windchill Quality Solutions.

Calculation Description

Availability The probability that a system is operating properly at a spe-

cific time point. Availability is a time-based probability
metric between 0 and 1.
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Calculation Description
Availability is a function of both reliability (how quickly a
system fails) and of maintainability (how quickly the sys-
tem can be repaired).

Capacity The average throughput, profit, or reward of the system per

unit time at a specified point in time.

MTBF (Mean Time
Between Failures)

The MTBF represents the number of hours a unit operates
between failures.

MTTFF (Mean
Time to First
Failure)

The average time until the first failure of the system. Fre-
quently, it is simply called MTTF.

Reliability

The probability that a system remains operational until a
specified time.

Reliability is a time-based probability value, so it is always
a metric between 0 and 1. A reliability of 0 means that a
system is infinitely unreliable, or never functioning. A reli-
ability value of 1 indicates that a system is infinitely reli-
able, or always operating.

Unavailability

The probability that, at a given time, the system would not
function, due to either a failure or a repair.

Unreliability

The probability that a failure would occur during a given
time period.

Running Calculations

To perform Windchill Markov calculations:

1. Select System > Calculate, or click the calculate &

1con on the Standard

toolbar. The Calculate window opens.

2. In the left pane, select the Calculation Selection page (if necessary).

In the right pane, click Clear All and select Markov to perform calculations only
for the Markov module.

4. In the left pane, under Markov, select the Reliability Calculation page.

The Reliability Calculation page allows you to specify information for
reliability and availability evaluation.

For Through end time, enter 30000.

For Display results for states at time, enter 30000.
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7. Leave the rest of the defaults. The page should appear as follows:

@ Reliability Calculation Options

Reliability/availability evaluation

From start time: 0
Through end time: 30000
Number of data points: 11
Display results for states at time: W
Required capacity: 100
Precision: 0.0001 -

Diagram verification

Warn on the presence of non-failed absorbing states
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8. In the left pane, select the Calculation Options page. Leave the default values:

@5 Markov Calculation Options

Availability

Capacity
Caonditional failure intensity
Conditional repair intensity
Cost per unit time
Failure density

Failure frequency
Failure rate

Frequency of departures
Frequency of transitions
Frequency of visits

Mean availability

Mean capacity

Mean cost

Mean state probability
Mean unavailability
MTBF

Mean time to failure, steady state
Mean time to first failure
MTTR

Mumber of departures
Number of failures
Mumber of repairs
Number of transitions
Mumber of visits
Probability

Reliahility

Repair frequency

Time spent in state

Total capacity

Total cost

Total downtime

Total uptime
Unavailability
Unreliability

i
V!

) o

RRRRRROREEERRECE]

9. Click OK to perform the calculations. The Calculation Progress pane displays

status information. When the calculations are complete, the View Calculation
Results window opens.

Tip
You can print your calculation results by clicking Print in the View Calculation
Results window. You can also save them to a Microsoft Excel spreadsheet by

clicking Excel.

10. Click Close when you have finished reviewing results.
To redisplay the results at any time, select System » View Calculation Results. If
you have only one module enabled, the results are displayed for that module. If

you have more than one module enabled, select the appropriate page to view the
results. When finished, click Close.
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Once results have been calculated for a Markov diagram, the results calculated for
a state appear on the Results page in its Calculation Properties window and the

results calculated for a transition appear on the Results page in its Calculation
Properties window.

Viewing a Report
1. In the Project Navigator, under Reports > Markov Reports, select (Common)

Markov (Summary). The Select Markov Diagram window opens.

2. Select Memory Analysis, make sure Print all diagrams is cleared, and click OK
to generate the report in the Preview window.

This report outputs data related to a Markov analysis in the System file, and
includes the calculation results, state summary, and diagram.

You can use the various toolbar buttons in the Preview window to page through
your report, zoom in and out, and print the report.

3. When finished viewing the report, do one of the following to close the Preview
window:

* Select Preview » Close.
*  Click the red Close button on the toolbar.

Graphing Data

1. In the Project Navigator, under Graphs > Markov Graphs, select (Common)
Markov Availability v Time to generate this graph. The Select Markov Diagram

window opens.

2. Select Memory Analysis and click OK to generate the graph.

This graph displays system availability at the points in time specified in the
Calculate window for Markov calculations.

3. When finished viewing the graph, select File » Close.

Windchill Markov Additional Features

Windchill Markov includes a number of additional features and functions. A brief
listing of other topics of interest is shown below. For more information on these
features, see the help or guide for Windchill Quality Solutions.
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* You can specify the cost to be associated with each state and transition. The
cost can be a gain or loss per unit time for a state or for a transition. Mean and
total capacity and cost values can then be calculated for the system.

* You can change the visual properties of a state or transition by right-clicking
the object and selecting VisualProperties.

* You can use a graphic file in your diagram by right-clicking a state, selecting
Visual Properties, and selecting an image file on the Graphic tab.

* You can add descriptive text labels to any state diagram. Select Insert » Label,
and choose the label style. You can then place the label in the diagram and
enter the desired text.
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This section of the Windchill Quality Solutions Getting Started Guide provides
basic information about LCC (life cycle cost) analyses and how to perform them
using Windchill LCC.

In this section, you enter a fixed cost item in Windchill LCC , review other cost
equation functions, and learn about using cost variables. Next, you perform
calculations and view standard reports and graphs on the life cycle cost data.
Note

Because Projects can be fully customized, your screens may not look like the ones
shown in this guide.
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LCC Analysis Overview

LCC (life cycle cost) analysis is used to compute the cost of a product or system
over its lifetime. By including all costs such as design, production, warranty,
repair, and disposal, LCC analyses provide an accurate assessment of total system
cost.

During the system design phase, LCC analysis is valuable for determining the most
cost-effective solutions before substantial costs are incurred; it is also an excellent
method by which you can compare the costs of different alternatives, such as
redesigning an existing system versus designing a completely new system.

LCC analysis considers factors such as inflation and the time value of money to
make realistic cost computations; such analyses can also be used to perform
sensitivity analysis so that you can pinpoint variables which have the most
influence on system cost.

If you are unfamiliar with LCC analysis and would like to study this topic in more
detail, the following text reference is an excellent resource:

» Life-Cycle Cost and Economic Analysis by Wolter J. Fabrycky and Benjamin
S. Blanchard (1991)

Getting Started with Windchill LCC

If Windchill Quality Solutions is started and the Tablet PC System file
is open

If you are already using Windchill Quality Solutions and your Project with the
Tablet PC System file is open, you can enable the Windchill LCC module; for

more information, see Starting Windchill LCC on page 147.

If Windchill Quality Solutions is not started

If Windchill Quality Solutions is not started, please start it. For more information,
see Starting Windchill Quality Solutions on page 10.
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If your copy of the Tablet PC System file is not open

The Tablet PC System file in your My Tablet PC Project is used to demonstrate
module features in this guide. If this System file is not open, open it by doing one
of the following:

» If the Recent Files list of the Start Page shows a link for the Tablet PC System
file in the My Tablet PC Project, click it to open the file.

» If the Project Navigator shows a listing of your Projects and Systems (you see a
Click a file to open link), click Tablet PC under My Tablet PC to open the

System file.
» If the Project Navigator has a Project other than My Tablet PC open (you see a
name other than My Tablet PC after the Project: label):
1. Close all open files by clicking <Click to close Project>.
2. Under My Tablet PC, click Tablet PC to open the System file.

+ If'the Project Navigator has the My Tablet PC Project open (you see Project: My
Tablet PC in the Project Navigator), click Tablet PC under the Systems heading

to open this System file.

Starting Windchill LCC

2

On the Module Selections toolbar, select the LCC button (\
module buttons.

and deselect all other

The panes for Windchill LCC are shown in your System file.

Using Windchill LCC

The LCC table at the top shows the cost breakdown structure as defined for the
system. The cost breakdown structure can be as detailed as you wish. Windchill
LCC also supplies some cost breakdown templates that you can use as a starting
point for LCC studies.

The lower pane, LCC - Equation Editor, displays the cost equation associated with
the selected item in the cost breakdown tree. All equations are completely user-
customizable.

You now enter a fixed cost item, review other cost equation functions, and learn
how to insert cost variables.
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Entering a Fixed Cost Item

Select the LCC table.

Select Maintenance Cost and review the associated cost equation. In this case,
the cost is linked to data related to repair and failure metrics found in other
modules.

Select Insert » Sibling to insert a new cost item.
Enter Disposal Cost as the name of the new item.

In the LCC - Equation Editor, for Cost Equation, enter 500 to indicate it costs
$500 to dispose of a system.

Reviewing Other Cost Equation Functions

Many costs may not be constant, and Windchill LCC offers a number of ways for
defining how cost is computed.

1.

In the LCC - Equation Editor, click Data Fields to open the Insert Field window.
In this window, you can insert fields from other modules for use in your
equation.

Click Cancel to close the Insert Field window.

Another method of adding data fields is to use the Data Fields toolbar. Select
LCC » Data Fields Toolbar. The Data Fields toolbar, an auto-hide window, is
shown. You can select from the list of available metrics and use easy drag and
drop operations to put data fields into your equation.

Click the X in the upper right corner of the Data Fields toolbar to close it.

Click Date Functions to see the list of date-related functions available for use in
cost equations.

Click Math Functions to see the list of math functions that can be used in cost
equations.

Using Cost Variables

1.

2.
3.

In the LCC - Equation Editor, select Variables to bring up the Insert Variable
window.

Drop down the list of variables available for inserting into your cost equations.

Click Cancel to close the Insert Variable window.

The variables available are defined in the LCC Variables file. To open the sample
LCC Variables file to see where these variables have been defined:
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In the Project Navigator, click Expand files to display Support files.
2. Under Support Files>LCC, select Variables to open the LCC Variables file.

In the LCC Variables file, you can see the list of variables that appeared in the
dropdown list associated with the Variables button in the LCC - Equation

Editor.

LCC Variables can be defined as:

* Constant: the variable value is fixed

* Varies over Time Intervals: meaning the variable changes based on the
defined time interval, which could be by month or by year for example

* Varies over Alternatives: the variable value changes based on alternative
system designs that you define, which could be a redesign and a new

design

* Varies over Alternatives and Time Intervals: the variable varies based on
both time intervals and alternatives

3. Select File » Close to close the Variables file.

In the Project Navigator, click Collapse files to hide the Support files.

Performing Calculations

Windchill LCC enables you to compute costs based on the entire product lifecycle,
from inception to product disposal. One of the significant benefits of Windchill
LCC is that it enables you to factor reliability metrics into lifecycle cost — an often
hidden, but significant, factor in overall product lifetime cost. By accounting for
component failures and repairs along with related labor costs and maintenance
activity costs, you can obtain a thorough analysis of true product cost.

Windchill LCC encompasses a variety of cost calculations:

Calculation

Description

Total System
Cost

The most basic of cost computations, total system cost reflects
the cost of your system over its entire lifecycle by using a cost
breakdown structure (CBS) of your system.

Line Item Costs

Windchill LCC computes the cost of each of the line items in
your CBS. Depending upon the granularity of your CBS, you
can see the costs associated with the various parts of your prod-
uct lifecycle: design costs, R&D expenses, maintenance costs,
labor fees, etc.

NPV (net
present value)

With the time intervals functionality of Windchill LCC, you
can take into account inflation rates over the specified time in-
terval you want to assess. Windchill LCC then projects the

Windchill LCC
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Calculation

Description

NPV of your system, i.e. the cost of your system in today’s dol-
lars based on inflation rates.

Costs Based on
Design
Alternatives

With the alternatives feature of Windchill LCC cost, you can
compare the cost of various design alternatives.

For example, to fix a known issue, you could look at the cost of
retrofitting a current design with a corrective action solution
versus the cost of a redesign.

Costs Based on

Using a combination of the time intervals and alternatives fea-

Design Alterna- |tures, you can factor in inflation rates to analyze the cost of de-
tives and Infla-  [sign alternatives.

tion Rates

Sensitivity Windchill LCC supports sensitivity analyses, which enable you
Analyses to see which variables have the most impact on your system

cost. By varying different cost items over a range of fluctua-
tions, you can see which variables have the most significant in-
fluence on total cost. Ensuring highly sensitive variables
remain stable enables you to more easily keep costs in check.

Running Calculations
To perform a Windchill LCC calculation:

1. Select System » Calculate, or click the calculate

icon on the Standard

toolbar. The Calculate window opens.

2. In the left pane, select the Calculation Selection page if necessary.

3. In the right pane, click Clear All and select LCC to perform calculations only for
the LCC module.

4. In the left pane, under LCC, select the Alternatives page.
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5. Use the default settings.

Calculate using alternatives

@ All alternatives

() selected alternatives

Awailable: Selected:
Altl [ Add > ]
Alt2

| addai» |

l < Remaove ]

l << Remowve All ]

6. In the left pane, select the Time Intervals page.
7. Use the default settings.

Calculate using time intervals

@l All ime intervals
() selected time intervals

Awailable: Selected:
Yearl l Add > l
Year2

| addai» |

l < Remaove ]

l << Remowve All ]

8. In the left pane, select the Sensitivity Analysis page.
9. Use the default settings.
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Calculate sensitivity analysis

@ Wariable: [RepairCustRate

() Data field: [MT[R {System Tree Configurations)
From %a:

Increment:

10. In the left pane, select the Link to System Tree Items page.

11. Use the default settings.

Select which System Tree items you want to use as the source for System Data fields used in LCC equations.

Alternative System Tree Item
All Alternatives PCO70101

Altl

Alt2

12. In the left pane, select the Link to Block Diagram page.
13. Use the default settings.
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(% Block Diagram Linking
Select which Block Diagrams you want to use as the source for RBD fields used in LCC equations.

Alternative RBD

All Alternatives Tablet PC
Alt1

Alt2

14. Click OK to perform the calculations. The Calculation Progress pane displays

status information. When the calculations are complete, the View Calculation
Results window opens.

When LCC calculations are finished running, cost and NPV results can be
viewed in the View Calculation Results window.

Tip
You can print your calculation results by clicking Print in the View Calculation

Results window. You can also save them to an Excel spreadsheet by clicking
Excel.

15. Click Close when you have finished reviewing results.

To redisplay the results at any time, select System > View Calculation Results. If
you have only one module enabled, the results are displayed for that module. If
you have more than one module enabled, select the appropriate page to view the
results. When finished, click Close.

Viewing a Report

1.

In the Project Navigator, under Reports > LCC Reports, select (Common) LCC
to generate this report in the Preview window.

This report outputs the life cycle cost data from the System file, including the
cost breakdown structure (CBS) item names, equations, time intervals, and
calculated costs and net present values (NPVs).
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You can use the various toolbar buttons in the Preview window to page through
your report, zoom in and out, and print the report.

2. When finished viewing the report, do one of the following to close the Preview
window:
* Select Preview > Close.
*  Click the red Close button on the toolbar.

Graphing Data

1. In the Project Navigator, under Graphs > LCC Graphs, select (Common) LCC
Cost per Time Interval and Alternative to generate the graph.

This graph displays the cost calculation results by time interval for all
alternatives in a cylinder bar graph.

2. When finished viewing the graph, select File » Close.

Windchill LCC Additional Features

Windchill LCC includes a number of features and functions. A brief listing of other
topics of interest is shown below. For more information on these features, see the
guide or help for Windchill Quality Solutions.

*  Windchill LCC can perform a sensitivity analysis which is used to determine
how much of an effect a particular variable has on overall system cost. When
performing a sensitivity analysis, you specify a variable to modify and a
percentage range over which to modify the variable. You can then view how
the cost varies with the changes to the underlying variable.

» The Equation Editor is very powerful and enables you to create both simple
and complex equations. Click Verify at any time to verify the syntax of the
entered equation.
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Conclusion

We hope that you have found this guide to be a useful demonstration of the
capabilities of Windchill Quality Solutions. The information presented in this
Getting Started Guide is only the beginning of what can be accomplished with the
feature-rich power of Windchill Quality Solutions.

As a Windchill Quality Solutions customer, you have access to a full complement
of resources, including: Windchill Quality Solutions Help; getting started tutorials;
FAQs and tips; knowledgeable, experienced customer support; and an extensive
library of reliability-related documents.

You can also boost your productivity by learning from the experts at PTC
University. Whether you're looking for specific training courses, ways to improve
the proficiency of experienced users, or a personalized corporate learning program
that meets your training schedule and budget requirements, PTC University can
help you boost your productivity through online courses, leadership training,
consulting, and other services to optimize your business.

We welcome your feedback! Contact us at 800-477-6435 (press 5 and then 1), or
email relex-doc@ptc.com. If you are evaluating Windchill Quality Solutions, email
relex-eval@ptc.com, or contact your Account Manager today with suggestions,
comments, or feedback of any kind. We look forward to hearing from you!
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