
Suggested Technique on Performing a Dynamic Suggested Technique on Performing a Dynamic Time and Frequency AnalysisTime and Frequency Analysis

IntroductionIntroduction

Almost any type of structural system may be subjected to one form or another of dynamic loading during its lifetime.

Generally two different approaches are available for evaluating structural response to dynamic loading, deterministic

and statistical. If the exact time history (Dynamic Time) or driving frequency and their amplitudes (Dynamic

Frequency) is known then the analysis is termed deterministic. If the loading variation is not completely known but

can be defined in a statistical sense, the analysis is termed nondeterministic or statistical. For this suggested

technique only deterministic analyses will be discussed.

There are two general categories of deterministic loading, periodic and non-periodic. A periodic type loading exhibits

the same time variation successively for a large number of cycles, for example constant shaking of a table without

changes in the shaking pattern over a long time . This simplest periodic loading has the sinusoidal variation as shown

in Figure 1, which is termed simple harmonic. Loading of this type may involve unbalanced rotating machinery. Other

forms of more complex periodic loading are inertial unbalanced reciprocating engines. The moving parts of a

reciprocating engine produce dynamic forces, which may result in undesirable vibrations. Figure 2 shows a more

complex periodic input load. With the use of Fourier analysis any periodic loading can be represented as a sum of  a

series of simple harmonic components. 

 
  
 

Figure 1 -  Simple Harmonic
A Fourier series is a linear combination of sine and cosine functions designed to approximate periodic functions. In
other words, a Fourier series is to periodic functions what a Taylor series is to a general function.
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Figure 2 - Complex
Non-periodic loads may be either short-duration (impulsive) loading or long-duration. For example, an impact event
which grows then dies out such as a bomb blast pressure on a building. The choice to use a Dynamic Time or
Frequency analysis in any given case depends upon whether the loading is periodic or non-periodic. If the forcing
load is periodic then it is more convenient to perform a Dynamic Frequency analysis. Conversely if the loading is
non-periodic (impulsive) then a Dynamic Time analysis would be more convenient.

Figure 3 - Impulsive

Figure 4 - Long Duration
Four types of dynamic analyses - Dynamic Time, Dynamic Frequency, Dynamic Dynamic Time, Dynamic Frequency, Dynamic ShockShock, and Dynamic RandomDynamic Random can
performed using Pro/MECHANICA Vibrations. The focus of this suggested technique is Dynamic Time Dynamic Time and Frequency Frequency
analysis.analysis.
Dynamic Time Dynamic Time - Pro/MECHANICA calculates displacements, velocities, accelerations, and stresses in the model at

different times in response to a time varying load. Pro/MECHANICA also calculates all valid measures for Dynamic

Time analyses that have been defined for the model.

Dynamic Frequency Dynamic Frequency  - Pro/MECHANICA calculates the amplitude and phase of displacements, velocities,

accelerations, and stresses for a given model in response to a load oscillating at different frequencies.

Pro/MECHANICA also calculates all valid measures for Dynamic Frequency analyses that have been defined for the

model.

The purpose of the following suggested technique is to demonstrate how to perform a Dynamic Time and Frequency
analysis on an after-market exhaust pipe. In order to determine if the pipe is well engineered, the following
questions must be answered:

Will the design withstand a 10ms, 20g, half-sine, shock load encountered while covering off-road terrain at a

fast pace?

How will the vibration frequencies of the engine affect the design?

Will fatigue be a problem?

The above questions can be answered by evaluating the displacements and stresses for either off-road travel or
attachment to the engine. 
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For this suggested technique base excitation is used. In order to use base excitation, the analysis study must contain

at least one constrained modal analysis. If no loads are defined on the model, the user can only define the dynamic

analysis using base excitation.

Generally two types of problems can be solved using Dynamic Time or Dynamic Frequency:

1) The system is held firmly and the load is modulated in time or frequency. An example of this scenario is someone

beating the motorcycle exhaust pipe with a hammer.

2) The constraints not only hold the model but are the path through which the vibration is introduced. An example of

this is the motorcycle exhaust pipe being bolted to a running motor. This case is commonly referred to as a base

excitation problem.

For base excitation Pro/MECHANICA can provide results with respect to the ground or supports.

In base excitation case (A), Pro/MECHANICA reports displacements, velocities, and other quantities as if standing at a

distance 
 watching the vibration test take place (with respect to ground).

In the modulating gravity case (B), Pro/MECHANICA reports displacements, velocities, and other quantifies, as sitting

on the cylinder head watching the 
 exhaust pipe move from this position (with respect to supports).

Refer to the following diagram: 
  

  
 

Figure 5
Note: The above diagram is generally accurate, but not for all types of measures. Stresses will be the same in both
cases, but displacements, velocities, and accelerations will be different. The difference between these quantities is
due to the frame of reference in which they are measured.
To move from one frame to the other is a straightforward operation in the time domain, but is a more complex issue

in the frequency domain due to phase 

issues. Stresses though, are the same no matter what frame.

ProcedureProcedure

1. The part shown in Figure 6 was created in independent mode of Pro/MECHANICA. Notice that this is a half
model of the exhaust pipe. Due to the load direction the symmetry the model is simplified by adding
symmetrical constraints and running the analysis on only half of the model. This method will miss all non-
symmetric modes, but because this example has only in-phase loads, it does not matter.
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Figure 6

2. Use Insert > Symmetry ConstraintInsert > Symmetry Constraint to apply symmetric constraints to all the curves in the XY plane. Select
NewNew to give the Constraint set another name than the default one. 
  
  

Figure 7



Figure 8

3. Use Insert > Gravity LoadInsert > Gravity Load to create a unit gravity load. The unit system used for this analysis is Inch Pound
Seconds (IPS).
 
 

   

  
  

 

Figure 9

4. Create the modal analysis as shown below using Analysis > Mechanica Analysis > Mechanica Analyses/Studies Analyses/Studies and then select
File > New ModalFile > New Modal. Since Pro/MECHANICA uses a modal analysis to solve all dynamic problems, the
number of modes captured in the modal analysis becomes very important. Determining the desired
number of modes may rely on a mass participation requirement determined by the user, or the frequency
range in which model is expected to operate.



 
  

Figure 10

Figure 11

Figure 12



5. Define valid measures using Insert > Simulation Measure > Insert > Simulation Measure > New  New  and the following data form appears. For
dynamic analyses, turn on Time/Freq Eval. MeasuresTime/Freq Eval. Measures are a key part of any dynamic analysis. With
measures, the results of various quantities at any point on the model can be determined. Pro/MECHANICA
computes pre-defined measures automatically for static and modal analyses. These are called pre-defined
measures. But for dynamic analyses, additional measures must be created.
 
 

 

Figure 13

 

The following block diagram indicates which measures are valid for Dynamic Time and Frequency

analyses. Also, the Measure Definition Form lists the names of analyses for which a particular measure

will be calculated as shown in Figure 14.



Figure 14

6. Create the following measures:
 
 

MeasureMeasure QuantityQuantity ComponentComponent SpatialSpatial
EvalEval

Time/FreqTime/Freq
EvalEval

Disp_y_max Displacement Y Max
Over
Model

At Each
Step

Stress_vm_max Stress Von Mises Max
Over
Model

At Each
Step

Accel_y_tip Acceleration Y At a
Point

At Each
Step

Figure 15
The acceleration measure is created on the mid-point on the circular curve at the tip of the exhaust pipe
(the bottom left end as shown in Figure 6.)

7. Create an initial Dynamic Time analysis called p_init as shown below and specify the following under the
Modes Modes tab.
Modes Included - Modes Included - The option All  All simply means all of the modes captured in the modal analysis are

included in the dynamic analysis. Below Specified FrequencyBelow Specified Frequency means that only modes with natural

frequencies below a specified value will be included in the dynamic analysis. Based on the results from a

shock analysis, it was determined that all of the modes above a frequency of 400 Hz did not contribute

significantly to the total mass percentage, therefore they may be excluded for the dynamic analyses.

Damping Damping - Use this item to specify damping coefficients for the modes in the analysis. The damping

coefficient is the percentage of critical damping. A damping coefficient of 100% means the model is
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critically damped. A damping coefficient of 1% means the amplitude decays by about 6% over one period

of oscillation. Typically a simple uniform percentage is used. For this case, assuming little flexibility in the

bolted interface between the cylinder head and exhaust flange, use 3% damping.

One of three methods of assigning damping coefficients may be selected from the pulldown menu: 
  

For All ModesFor All Modes - Select this option to assign a single damping coefficient to all modes. You enter a

single value, without a % symbol, in the entry box. By default, All is selected with a value of 0.

For Individual ModesFor Individual Modes - Select this option to assign a separate damping coefficient to each mode in

the analysis, or to edit damping coefficients you entered previously.

Function of FrequencyFunction of Frequency - Select this option to define damping as a function of frequency. Select a new

or existing function by selecting the f(x)f(x) button.

 

Figure 16
Specify the following under the Previous AnalysisPrevious Analysis tab, Figure 17.
Use modes from previous design study - Use modes from previous design study - select this option to use results from a previously run Modal

analysis in the Dynamic analysis. If this option is not selected, Pro/MECHANICA runs the Modal analysis as



part of the Dynamic analysis. If more than one Modal analysis is defined, use the pulldown menu  to

specify which Modal analysis will be used for the analysis. The constraint set will automatically default to

the constraint set used in the associated Modal analysis.

Figure 17
Specify the following under the OutputOutput tab, Figure 18. 

  

Stresses - Stresses - Directs Pro/MECHANICA to calculate stresses. If you do not need stress results, you can

save disk space by deselecting this item. This also results in dramatically reduced analysis time.

Rotations -Rotations - Directs Pro/MECHANICA to calculate the rotation about each WCS axis over the entire

model. Pro/MECHANICA never calculates rotations if your model consists only of 3D solid, 2D solid,

or 2D plate elements, even if this item is selected. Rotations are always zero for these element types.

 

The focus of this first-pass time sweep is to determine which resonant frequencies are excited by this half-

sine wave time input. Then for the second and following passes, a detailed full set of results are needed to

produce the desired fringe plots. Since this is the case, leave the Output Intervals at Automatic IntervalsAutomatic Intervals

within Range.within Range. Pro/MECHANICA then selects appropriate intervals at which to report results but does not

calculate full results at any step.

Enter the Minimum and Maximum times for the range over which you want Pro/MECHANICA to report

results for a dynamic time analysis. The default maximum time is Automatic, which is three times the

period of the first mode, i.e. the range will cover three oscillations for the first mode. In this analysis we

will use Automatic.

Figure 18



8. Use the f(x)f(x) button next to the y_gravity load set in Figure 16 to change the Amplitude function from the
default impulse load, to the desired 20g, 10ms half-sine pulse. Create the new time function called half-
sine. The function value will be multiplied with the load value. Hence to get the the desired 20g load, the
sine function will need to have an amplitude of 20.
 

Figure 19

 

Press ReviewReview to graph the half-sine input between 0 and 0.025. 
   

   
  



Figure 20 

9. Create an initial Dynamic Frequency analysis called pf_init. The Dynamic Frequency analysis definition
form is very similar to the Dynamic Time. The settings under the ModesModes, Previous AnalysisPrevious Analysis and OutputOutput
tabs are identical to the Dynamic Time analysis, p_init, see Figure 16, 17 and 18. A new functionality in
Pro/MECHANICA 2001, is the possibility to specify phase shifts for each of the loads in a dynamic
frequency analysis. The phase function is defined in radians and when the frequency phase function is
zero, a zero degree phase angle over the frequency range is applied to the load. For this analysis we will
leave it to be zero.
 

 

Figure 21

10. Use the f(x)f(x) button next to the y_gravity load set to change the amplitude function from the default
uniform load, to the desired function. Create a new function called engine_input of type Table - refer to
the tabular data shown below. Also graph the data between 2 and 3200 Hz to make sure the data looks
correct. The graph shown has its Y axis in log format.
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Figure 22

FrequencyFrequency ValueValue

2 0.3

120 6

270 2

376 11

640 2.5

770 8

1170 1.5

1360 1.5

1920 4

2880 0.4

3200 0.4

Figure 23



Figure 24

11. The purpose of performing an initial run for both the Dynamic Time and Frequency analysis is to
determine at what time or at what frequency results in high stresses and/or displacements. Once the time
and frequency ranges at which the highest stresses and displacements occur a final Dynamic Time and
Frequency analysis will be performed so that full results at these locations can be calculated. The results
for the defined measures for the initial Dynamic Time analysis is shown below in Figures 25, 26, and 27.

Figure 25 - Maximum Von Mises Stress over model at each time step
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Figure 26 - Maximum displacement in the Y-direction over model at each time step

Figure 27 - Acceleration in the Y-direction at a point at each time step

12. When viewing the above graphs use Format > GraphFormat > Graph to view the range of  times at which the stress,
displacement, and acceleration peaks occur. Based on the above results the time range at which the
highest stress, displacement, and acceleration peaks occur is between 0 and 0.03 seconds.
 



Figure 28 - Maximum Von Mises Stress over model at each time step between 0 and 0.03s

13. Create a new time analysis called pt_final. Based on the initial run of the Dynamic Time analysis, pt_init,
leave everything the same but the settings under the OutputOutput tab.
When Automatic Intervals within RangeAutomatic Intervals within Range is selected from the Output Intervals pulldown menu,

Pro/MECHANICA only calculates measures. This was the case for pt_init. When User-defined OutputUser-defined Output

IntervalsIntervals is selected, the following options appear: 
  

Number of Master IntervalsNumber of Master Intervals - Enter the number of master intervals at which you want

Pro/MECHANICA to report results. You can specify up to 999 intervals. A row is added to the table for

each interval. In general, computation time increases with the number of intervals.

Measure Output Intervals per Master IntervalMeasure Output Intervals per Master Interval - Includes the number of intermediate points at which

only measures are calculated.

 

Select User-Defined StepsUser-Defined Steps to define the master intervals and obtain full results at times of interest. Since

the stress peaks occur at t = 0.0114s and t = 0.0234s based on Figure 28, full results at these times are

selected. 

  
  



Figure 29

14. The fringe plot of the final Von Mises Stress at time equals 11.4 ms, is shown below in Figure 30.
 

 



Figure 30 - Fringe plot of Von Mises Stress at time step 1 (11.4ms)

15. The results of the initial Dynamic Frequency analysis, pf_init,  is shown below in Figures 31, 32, and 33. The
frequency at which the maximum stress and acceleration occur is at 395 Hz. Also the frequency at which
the maximum Y-displacement occurs is 138.9 Hz.
 



Figure 31 - Maximum Von Mises Stress over model at each frequency step

Figure 32 - Maximum displacement in the Y-direction over model at each frequency step



Figure 33 - Acceleration in the Y-direction at a point at each frequency step

16. Finally create a new Dynamic Frequency analysis called pf_final. Based on the initial run of the Dynamic
Frequency analysis, pf_init, leave everything the same but the settings under the OutputOutput tab. Select full
results for the frequencies 138.9Hz and 395Hz, since this is where the initial analysis reported the highest
stresses, accelerations and displacements.
 



Figure 34

17. The fringe plot of the Von Mises stress at Step 2, 395 Hz, is shown below. The motorcycle engine has a
peak near the third pipe natural frequency, resulting in rather high stresses around the exhaust flange.



Figure 35 - Fringe plot of Von Mises stress at 395 Hz

SummarySummary
Recall the general equation which governs a dynamic analysis -- M(a)+C(v)+K(x) = F(time or freq). When

running a static analysis, just the stiffness (K) and the external force (F) are important. In a modal analysis,

add to that the need to model the mass (M) correctly. Now running a dynamic analysis,  the additional

damping (C) must be considered as well.

The accuracy of any dynamic analysis depends heavily on the quality of the modal solution, both in how

well it has converged and making sure enough modes were captured. For base excitation problems, like

the exhaust pipe, running a Dynamic Shock analysis will give the total mass percentage. The mass

participation can also be calculated during a Dynamic Time or Frequency analysis using base excitation

only.

Remember to create measures before running any initial dynamic analyses. Other wise there will not be

any data to look at in the results, unless some master intervals have been defined.

Master intervals are intervals for which full results are output: sub-intervals are intervals for which only

measures are output.

Files for this document can be downloaded here. 
  

http://support.ptc.com/cs/cs_27/howto/mst2477/mst2477.zip



