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Pro/ENGINEER Fundamentals 

Fundamentals Overview 

The Fundamentals Help describes basic functions for all areas of Pro/ENGINEER Wildfire. Refer 

to these topics for information on using the user interface, on configuring Pro/ENGINEER for 

Fundamentals, and on performing basic operations. 

Tasks for Fundamentals 

 

Working with the User Interface 

Using the Main Window 

Working with Files 

Using Systems Colors 

Using Related Applications 

 

Working with the Model 

Using the Model Tree 

Viewing the Model 

Making Selections 

Searching for Entities 

Creating Cross Sections 

Regenerating Models 

Integrating Changes 

 

Working with Core Functions 

Analyzing Model Parameters 

Managing Annotation Features and 

Annotations 

Setting Up Model Properties 

Working with Relations and Parameters 

Constructing Chains and Surface Sets  

 

Getting Productive 

Using the Layer Tree 

Using Family Tables 

Using Configuration Options 

Customizing Pro/ENGINEER 

Getting Information 

Using Trail Files and Training Files 
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Configuring Pro/ENGINEER Fundamentals 

About Configuring Pro/ENGINEER Fundamentals 

You can customize the way you configure Pro/ENGINEER by entering config.pro 

configuration file options and their values in the Options dialog box (Tools > 

Options). 

Pro/ENGINEER Fundamentals Help provides a list of configuration options arranged in 

alphabetical order. Each option contains the following information:  

• Configuration option name. 

• Default and available variables or values. All default values are in italic. 

• Brief description and notes describing the configuration option. 

To Set Pro/ENGINEER Fundamentals Configuration Options 

1. Click Tools > Options. The Options dialog box opens. 

2. Click the Show only options loaded from file check box to see currently 

loaded configuration options or clear this check box to see all configuration 

options. 

3. Select the configuration option from the list or type the configuration option 

name in the Option box. 

4. In the Value box type or select a value.  

Note: The default value is followed by an asterisk (*). 

5. Click Add/Change. The configuration option and its value appear in the list. A 

green status icon confirms the change. 

6. When you finish configuring, click Apply or OK.  

System Color Options 

In the system colors file (system_colors_file) within the config.pro file, you can 

provide default RGB values (<0.000000 0.000000 0.000000>) for the display of 

various graphics. See the next table. The three decimal values (from 0–100) specify 

a percentage of red, green, and blue, respectively, in the resulting color. For 

example, 0 0 49 defines a medium blue. The RGB values match those in the R, G, 

and B boxes in the Color Editor dialog box. To access this dialog box, View > 

Display Settings > System Colors and click a color in the System Colors dialog 

box. 
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Configuration Option Graphics Affected User Interface 

Option 

system_background_color  background of the 

graphics window 

Background 

system_curves_color  curve entities Curves 

system_dimmed_menu_color  unavailable menu 

items 

Highlight - 

Secondary 

system_edge_high_color  edges Highlight - Edge 

system_geometry_color solid wireframe 

entities 

Geometry 

system_hidden_color  hidden, solid 

wireframe entities 

Hidden Line 

system_highlight_color primary highlight 

color 

Highlight - 

Primary 

system_letter_color datum entity labels 

or tags 

Letter 

system_section_color sections Sketched Curve 

system_sheetmetal_color sheetmetal parts Sheet Metal 

system_volume_color  Manufacturing 

volumes 

Manufacturing 

Volume 

add_lower_level_comps_to_layer 

no, yes  

Activates the Favor Current Layer option, which allows lower-level components to 

be added to top-level layers. 

af_copy_references_flag 

no, yes 

Controls whether the Backup Refs column in the Annotation Feature dialog box is 

displayed. This column specifies whether the system creates backup references 

during creation or redefinition of an Annotation Element. 

allow_confirm_window 

yes, no 

Displays a confirmation window when you exit Pro/ENGINEER. 
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angular_tol 

0 0.000000 <integer tolerance> 

Sets default angular tolerance dimensions. The integer sets the number of decimal 

places, and the tolerance is the actual tolerance value. For example, 6 0.000025 

sets a tolerance to 6 decimal places, and the default tolerance value is 0.000025. 

For integer dimensions, the integer value is 0, and the tolerance is an integer. For 

example, 0 1 sets a tolerance of 1 for integer dimensions. 

A value affects only models created after the tolerance option is specified in the 

configuration file.  

auto_ae_param_file 

<full path> 

Specifies the location of the file in which Annotation Element parameters are 

automatically added each time you create an annotation element. 

autohide_copied_group_af 

yes, no 

Copies a feature group containing Annotation features and automatically hides from 

display the Annotation features in the new group. 

auto_regen_views 

yes, no 

Regenerates the drawing display whenever you change from one window to another. 

yes—Regenerates both the drawing and the drawing view. 

no—Regenerates the drawing but not the view unless you select View > Repaint, 

View > Update, or Edit > Regen. 

autoplace_single_comp 

yes, no 

Activates the Component Placement dialog box in drag-and-drop operations. 

bell 

no, yes 

Rings the keyboard bell when prompts appear.  

blank_layer 

0 
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Displays the specified layer as empty, or blank, when you begin a Pro/ENGINEER 

session. 

bmgr_pref_file 

<path> 

Specifies the location of the graph preference file for the Graph Tool settings, such as 

axis, line weights, label fonts, and so forth. Pro/ENGINEER uses the settings in the 

text file to render your graphs to your specifications. After you create the text file, 

you add the bmgr_pref_file option to your config.pro file. 

A sample graph preference file with the possible values follows: 

X_Axis_Color 5.019608e-01f,5.019608e-01f,1.000000e+00f  

X_Axis_DisplayLabel 1  

X_Axis_GridColor 5.019608e-01f,5.019608e-01f,0.000000e+00f  

X_Axis_GridEnabled 1  

X_Axis_GridStyle 2  

X_Axis_LabelColor  1.000000e+00f,1.000000e+00f,1.000000e+00f 

X_Axis_LabelEnabled 1  

X_Axis_LabelFont graphtool_font  

X_Axis_LabelFontHeight 1.500000e-01f  

X_Axis_Thickness 4  

X_Axis_TickColor  1.000000e+00f,1.000000e+00f,1.000000e+00f  

X_Axis_TickFont graphtool_font  

X_Axis_TickFontHeight 1.000000e-01f  

X_Axis_TickHorizontal 1  

Y_Axis_Color 1.000000e+00f,0.000000e+00f,0.000000e+00f  

Y_Axis_DisplayLabel 1  

Y_Axis_GridColor 5.019608e-01f,5.019608e-01f,0.000000e+00f  

Y_Axis_GridEnabled 1  

Y_Axis_GridStyle 2  

Y_Axis_LabelColor 1.000000e+00f,1.000000e+00f,1.000000e+00f  

Y_Axis_LabelEnabled 1  

Y_Axis_LabelFont graphtool_font  

Y_Axis_LabelFontHeight 1.500000e-01f  

Y_Axis_Thickness 2  

Y_Axis_TickColor 1.000000e+00f,1.000000e+00f,1.000000e+00f  
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Y_Axis_TickFont graphtool_font  

Y_Axis_TickFontHeight 1.000000e-01f  

Y_Axis_TickHorizontal 1 

bom_format 

<file path> 

Specifies the location of the BOM format file for a customized BOM. 

browser_favorite 

<full directory path name> 

Specifies the directory for the local file system that appears in the Folder navigator in 

the Pro/ENGINEER browser. 

button_name_in_help 

no, yes 

Specifies whether to display Help text associated with a menu command or a button. 

clearance_triangulation 

none, low, medium, high 

Specifies the quality of surface triangulation used to obtain initial points for clearance 

and interference calculations. 

clock 

yes, no 

Determines whether a clock is displayed while Pro/ENGINEER is working on a task. 

color 

yes, no 

Determines whether the model takes its assigned appearance. 

yes⎯Displays the model in the assigned colors. 

no⎯Displays the model in white for nonshaded display styles and in light gray for 

shaded display styles. 

color_ramp_size 

-1 

Specifies the number of shades in a color ramp for the display of multicolor, shaded 

models of simulation or analysis results or both. Your system graphics must support 

256 colors and color maps that compress. 



Pro/ENGINEER Fundamentals 

7 

color_resolution 

0.100000 

Specifies minimum allowable deviation between user-defined colors. Colors having 

RGB values within the tolerance of existing colors cannot be created. Decreasing this 

setting allows the definition of colors similar in RGB value. 

color_windows 

one_window, all_windows 

Specifies in which windows the model displays in color. 

all_windows—Displays the model in color in all windows. 

one_window—Displays the model in color only in the graphics window. In auxiliary 

windows, the model appears in the default system color. 

compress_output_files 

yes, no 

Specifies whether to store object files in a compressed format. Compressed files are 

slower to read and write, but are 30–50% smaller and are fully compatible across 

systems.  

Note: If you want to copy a compressed object file from a UNIX system to a 

Windows NT or Windows 95 machine or vice versa, use the operating-system 

command rcp -b from the Windows machine.  

conf_mouse_anim 

no, yes 

Displays the presenter's mouse movements on the screen during a shared 

Pro/ENGINEER session. 

create_numbered_layers 

no, yes 

Creates the default layers numbered 1 through 32. 

def_layer 

layer_<item_type> 

Adds item types to the specified default layer name. The variables, or item types, 

follow: 

layer_assem_member, layer_assy_cut_feat, layer_axis, layer_chamfer_feat, 
layer_comp_design_model, layer_comp_fixture, layer_comp_workpiece, 
layer_copy_geom_feat, layer_corn_chamf_feat, layer_cosm_round_feat, 
layer_cosm_sketch, layer_csys, layer_curve, layer_curve_ent, 
layer_cut_feat, layer_datum, layer_datum_plane, layer_datum_point, 
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layer_detail_item, layer_dgm_conn_comp, layer_dgm_highway, 
layer_dgm_rail, layer_dgm_wire, layer_dim, layer_draft_constr, 
layer_draft_dim, layer_draft_dtm, layer_draft_entity, layer_draft_feat, 
layer_draft_geom, layer_draft_grp, layer_draft_hidden, 
layer_draft_others, layer_draft_refdim, layer_driven_dim, 
layer_dwg_table, layer_ext_copy_geom_feat, layer_feature, 
layer_geom_feat, layer_gtol, layer_hole_feat, layer_intchg_funct, 
layer_intchg_simp, layer_nogeom_feat, layer_note, layer_parameter_dim, 
layer_part_refdim, layer_point, layer_protrusion_feat, layer_quilt, 
layer_refdim, layer_rib_feat, layer_ribbon_feat, layer_round_feat, 
layer_sfin, layer_shell_feat, layer_skeleton_model, layer_slot_feat, 
layer_snap_line, layer_solid_geom, layer_surface, layer_symbol, 
layer_thread_feat, layer_trim_line_feat, layer_weld_feat 

default_dec_places 

2  

Sets the default number of decimal places (0-14) for nonangular dimensions in all 

model modes. It does not affect the decimal places as modified using Num Digits. 

For Sketcher, use the option sketcher_dec_places.  

default_dim_num_digits_changes 

yes, no 

Sets the default number of digits in a dimension to the last entered value. If you set 

this option to no, the system defaults to the value specified for the configuration 

option default_dec_places. 

default_geom_analysis_type 

quick, saved, feature 

Sets the default analysis type in geometry analysis tools. Some geometry analysis 

tools such as Offset, Draft, Reflection, and Shadow do not have the Feature analysis 

type. For such tools, Pro/ENGINEER sets the default analysis type to Quick even if 

you set this configuration option to feature. 

default_layer_model 

<model name> 

Specifies the name of the model that is used to drive the rule-based layer. 

default_placement_surfacefinish 

normal_to_Entity, with_leaders, on_entity, free 

Sets the default placement type for surface finish annotations within the Surface 

Finish dialog box. 
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normal_to_Entity—Attaches the symbol directly to a surface of the model such that 

the annotation is placed normal to the selected surface and in the annotation plane. 

However, if the annotation plane is not normal to the selected entity, then the 

surface finish annotation too is not normal to the entity. 

with_leaders—Attaches the symbol to model surfaces using leaders.  

on_entity—Attaches the symbol directly to a surface of the model. 

free—Places the symbol without attaching it to model geometry. 

disable_search_path_check 

no, yes  

Controls whether the search path is checked for name conflicts when creating, 

renaming, or copying models. A check ensures that only models with unique names 

are in session. 

display 

shade, wireframe, hiddenvis, hiddeninvis 

Displays the model with all lines as specified. The display of lines is reflected in 

plotter, DXF, and IGES files.  

shade⎯Displays all surfaces shaded except for drawing models. 

wireframe⎯Displays all lines in white. 

hiddenvis⎯Displays hidden lines in grey. 

hiddeninvis⎯Removes hidden lines from the display. 

display_annotations 

yes, no 

Controls the display of annotations in the graphics window in 3D models. 

display_axes 

yes, no 

Displays the datum axes. 

display_axis_tags 

yes, no 

Displays the name tags for the datum axis. 

display_coord_sys 

yes, no 

Displays the datum coordinate systems. 
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display_coord_sys_tags 

yes, no 

Displays the name tags for the coordinate system.  

display_full_object_path 

no, yes 

Displays the object’s file name (including its object-type suffix and its version 

number) and its file path in the window title and Model Info display. 

no—Displays only the object's name.  

yes—Displays the object's full name and its file path. 

display_layer 

0, <layer ID> 

Displays the specified layer when you begin a Pro/ENGINEER session. 

display_plane_tags 

yes, no  

Displays the datum tags. 

display_planes 

yes, no  

Displays the datum planes. 

display_point_tags 

yes, no  

Displays datum point tags. 

display_points 

yes, no  

Displays datum points and their names.  

display_tol_by_1000 

no, yes 

Displays tolerances for nonangular dimensions multiplied by 1000. 

display_z_extension_lines 

yes, no 
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Controls the creation of Z-extension lines in driven dimensions. 

dm_http_compression_level 

0 

Sets the data compression factor (0–9, 0 = no compression) for data exchange with 

a Windchill server. Higher compressions can speed up uploads for a client over a 

slow network. 

edge_display_quality 

normal, high, very_high, low 

Controls the display quality of an edge for a wireframe and for hidden-line removal 

by varying the tessellation. 

normal—Provides a normal quality of edge display. 

high—Increases tessellation by a factor of 2. 

very_high—Increases tessellation by a factor of 3. 

low—Decreases tessellation compared to normal, thus speeding up the display of an 

object. 

enable_popup_help 

yes, no 

Enables pop-up Help in the dialog boxes. 

fast_highlight 

no, yes 

Improves the performance of highlighting and reorienting large assembly models, 

regardless of display style (wireframe, hidden line, no hidden line, and shaded). 

no—Uses standard highlight. 

yes—Uses fast highlight. When you select components, the model geometry (solid, 

surface) and associated annotations, curves, and cables are highlighted. Datums of a 

selected component do not highlight unless they are also selected. For models of 

modest size and complexity, the slight increase in performance may not warrant the 

additional memory required to support this option. 

file_timestamp_format 

%dd-%Mmm-%yy %Hh:%mi:%ss %PM 

Controls the format of timestamps when you view a listing of files and directories in 

Web pages generated by Pro/ENGINEER in the Pro/ENGINEER browser and in dialog 

boxes. The format for the value of the configuration option is a string consisting of 
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up to seven part: the year, month, and date, the hours, minutes, seconds, and the 

AM or PM designator. You can specify the parts in any order. 

The default value is %dd-%Mmm-%yy %Hh:%mi:%ss %PM in most languages. However, 

in Japanese-language sessions, the default value is %yyyy/%mm/%dd %hh:%mi:%ss. 

You can use the following formats when specifying the value of the timestamps: 

%yyyy—4-digit year (for example 2005) 

%yy—2-digit year (for example 05) 

%MMM—Month (for example SEP) 

%Mmm—Month (for example Sep) 

%Month—Full month name (for example September) 

%mm—Month number, padded to 2 digits (for example 09) 

%m—Month number (for example 9) 

%dd—Date, padded to 2 digits (for example 05) 

%d—Date, no padding (for example 5) 

%Hh—Hour, 12-hour format (for example 12) 

%hh—Hour, 24-hour format (for example 00) 

%PM—AM or PM 

%mi—Minutes 

%ss—Seconds 

file_open_default_folder 

working_directory, in_session, my_documents, pro_library, workspace, 

commonspace 

Sets default directory from which to open a file when using File > Open.  

working_directory—Searches the working directory.  

in_session—Searches objects in session.  

my_documents—Searches the My Documents folder. 

pro_library—Searches the Pro/Library directory in Pro/LIBRARY.  

workspace—Searches the Workspace in PDM application.  

commonspace—Searches the Commonspace in Pro/INTRALINK. 

default—Searches for the My Documents folder on Windows or for the working 

directory on UNIX. Subsequently, when you click File > Open, Pro/ENGINEER opens 

the directory where the previous File Open dialog box was closed. In a linked 

session with a PDM application, searches the active workspace. 
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flip_arrow_scale 

1.000000 

Sets a scale factor for enlarging the flip arrow for the direction for feature creation. 

force_new_file_options_dialog 

no, yes 

Forces the use of the New File Options dialog box when you click File > New. The 

Use default template check box in the New dialog box becomes unavailable. 

full_hlr_for_cables 

full, partial, none 

Determines whether hidden lines are shown or hidden with cables. 

full—Removes the hidden lines from view when cables hide other geometry (only 

available when Hidden line is active).  

partial—Cables hide other noninterfering cables, except when cables are routed 

together between the same locations. 

none—Hidden lines are displayed, so the display process is faster.  

general_undo_stack_limit 

50 

Sets the number of undo or redo operations. If the number of operations exceeds 

50, the first operation in the stack of operations is removed first, and so on. 

global_appearance_file 

<directory name> 

Sets the default directory for the global.dmt file. Use the full path to avoid 

problems. 

highlight_geometry 

yes, no 

Specifies whether items you select on the Model Tree are highlighted in the graphics 

area. 

highlight_layer_items 

yes, no 

Specifies whether items you select in the Layer Tree highlight in the graphics area. 
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info_output_format 

html, text 

Sets the default format type for presentation of system information.  

info_output_mode 

both, choose, file,screen 

Sets the default method of presenting system information for audit trails, BOMs, 

names, and models. All other output displays on the screen. 

both—Displays the output and writes it to a file. 

choose—Displays the INFO OUTPUT menu, so you can choose the method of 

output. 

file—Writes the output to a file. 

screen—Displays the output. 

kbd_cmd_abbreviation 

off, on  

Enables or disables the use of abbreviations when you enter commands from the 

keyboard. 

kbd_selection 

no, yes 

Enables or disables the keyboard for selecting locations in the graphics area. If set to 

no, use of the mouse is required. 

linear_tol 

0 0.000000-1 

Sets the default linear tolerance dimensions. The integer sets the number of decimal 

places, and the tolerance is the actual tolerance value. For example, 6 0.000025 

sets a tolerance to 6 decimal places, and the default tolerance value is 0.000025. 

For integer dimensions, the integer would be 0 and the tolerance would be an 

integer. For example, 0 1 sets a tolerance of 1 for integer dimensions. 

Any modifications to these options affect only new models that are created after the 

option modification. 
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lods_enabled 

no, yes 

Uses level of detail (lod) in shaded models during dynamic orientation (panning, 

zooming, and spinning). During runtime, you can override this setting by clicking 

Tools > Level of Detail > Environment.  

maintain_limit_tol_nominal 

no, yes 

Maintains the nominal value of a dimension regardless of the changes that you make 

to the tolerance values.  

mdl_tree_cfg_file 

<path> 

Specifies the Model Tree configuration file to be loaded when you start 

Pro/ENGINEER.  

measure_dec_places 

-1, <integer> 

Controls the number of digits displayed after the decimal point for the measure 

analysis tools. If you do not change the default of -1, Pro/ENGINEER uses the setting 

of the measure_sig_figures configuration option. 

measure_sig_figures 

6 

Sets the number of significant figures in the results when you use the Model Size 

dialog box from the Info menu. The maximum value is 11.  

menu_font 

<variables> 

Specifies the font used in the Pro/ENGINEER menu bar, menus, and all their children. 

Provide the comma-delimited variables in any order, for example, italic bold, 24, 

times or 24,times, italic bold have the same effect. Any omitted variable uses the 

standard setting. 

menu_mapper_location 

<directory path> 

Sets the path to the Menu Mapper. When you click Help > Menu Mapper, 

Pro/ENGINEER launches the Menu Mapper from the specified location. 
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The default path is 

http://www.ptc.com/community/proewf3/menu_mapper/en/index.htm. 

mesh_spline_surf 

no, yes 

Displays the blue mesh surface lines. 

model_notes_as_labels 

no, yes  

Determines whether model notes display as full text (default) or labels. 

model_tree_start 

yes, no 

Displays the Model Tree with its model (default). 

native_kbd_macros 

no, yes 

Specifies support of keyboard macros in a native language, for example, German, 

rather than only English. 

number_user_colors 

200 

Specifies the maximum number of user-defined colors that are available within the 

Appearance Editor and the Entity Colors dialog boxes.  

old_style_set_datum  

yes, no 

Specifies whether to display  in the Datum or Axis dialog box. The 

 button allows you to create set datum tags with the old-style display. 

Note: Even if the value of old_style_set_datum configuration option is set to no, 

the  appears in the Datum or Axis dialog box when modifying a pre-

existing old-style set datum. 

online_resources_location 

<directory path> 
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Sets the path to Online Resources. When you click Help > Online Resources, 

Pro/ENGINEER launches the Online Resources page from the specified location. 

The default path is http://www.ptc.com/community/proewf3/newtools/index.htm. 

open_simplified_rep_by_default 

no, yes 

Opens the Open Rep dialog box by default if you click Open on the File Open 

dialog box.  

orientation 

trimetric, isometric, user_default 

Establishes the initial default view position, or orientation. After you set the 

configuration options for x_axis and y_axis,the system defaults to the user-defined 

values. To override the orientation at runtime, click View > Orientation > 

Standard Orientation. 

trimetric—Orients the model trimetrically.  

isometric—Orients the model isometrically.  

user_default—Orients the model in the position specified in the configuration 

options x_axis and y_axis. If you do not define these options, the system defaults 

to trimetric.  

orientation_style 

dynamic, anchored 

Sets the default viewing style irrespective of whether the Orient mode is enabled or 

disabled, that is, you are outside Orient mode or in the Orient mode, respectively. 

When Orient mode is enabled,you may change the viewing style as required. 

dynamic—The Orientation Center is displayed as . Orientation is updated as the 

pointer moves. The model spins freely about the Orientation Center. 

anchored—The Orientation Center is displayed as . The orientation is updated as 

the pointer moves. Model rotation is controlled by the direction and distance the 

pointer is moved from its initial position. The Orientation Center changes color at 

each 90-degree interval. When the pointer returns to the original position, the view 

is reset to where you started. 

override_store_back 

no, yes 

Stores all retrieved objects in the current working directory.  

no—Stores objects in their original directories. If you do not have write permission to 

the original directory, the configuration option save_object_in_current takes 

effect. 
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yes—Stores objects in the current working directory. 

parenthesize_ref_dim 

no, yes 

Encloses reference dimensions in parentheses. If set to no, the reference dimensions 

are followed with the text "REF." 

pick_aperture_radius 

7.000000 

Specifies the size of the area about the mouse when making selections. Units are 

1/1000 of screen size. 

plot_names 

yes, no 

no—Gives plot files, except PostScript plots, the extension plt.  

yes—Gives all plot files descriptive extensions: 

hp—For Hewlett-Packard  

hp2—For Hewlett-Packard hpgl2  

cal—For Calcomp  

ver—For Versatec  

ger—For Gerber photoplotters 

ps—For PostScript (including color) 

preferred_save_as_type 

*.prt *.igs *.set *.vda *.neu *.stp *.ntr *.ct *.cat *.stl *.iv *.obj 
*.slp *.unv *.wrl *.enm *.evs *.mdb *.edn *.emp *.evs *.edp *.gbf *.asc 
*.facet *.sat *.model *.ed *x_t *.ed*.jpg *.shd *.eps *.tif*.pic *.zip 

Sets the order of the file types to customize the Type list in the Save a Copy dialog 

box. 

prehighlight 

yes, no 

Highlights selectable items beneath the pointer before selection. Prehighlighting 

provides a visual check to confirm that you will select the intended item. 

prehighlight_tree 

no, yes 
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Specifies whether the selectable items beneath the pointer on the Model Tree or the 

Layer Tree are highlighted before you select them.  

pro_colormap_path 

<directory path> 

Specifies the directory path for a color map (.map) file to be loaded from disk. Use 

the full path to avoid problems. 

pro_crosshatch_dir 

<directory name> 

Specifies a default directory for your crosshatch library in which you can save 

crosshatching patterns for later retrieval. Use the full path of the default directory.  

pro_editor_command 

<command> 

Enables an editor other than the system editor when the optional editor has been 

specified as the value for the options drawing_file_editor or 

relation_file_editor. 

The command specified will be executed as it is typed in the config.pro file. If the 

command does not open a new window, you can start the editor in the system 

window used to start Pro/ENGINEER.  

pro_material_dir 

<directory name> 

Sets the default directory for the part material library. Use the full path to avoid 

problems. For example, /home/users/library/material. 

pro_plot_config_dir 

<directory name> 

Sets the directory of your user-defined plotter configuration file. Use the full path to 

avoid problems. For example, /home/users/plot_dir. 

pro_unit_length 

unit_inch, unit_foot, unit_mm, unit_cm, unit_m 

Sets the default units for new objects. 

pro_unit_mass 

unit_pound, unit_ounce, unit_ton, unit_gram, unit_kilogram, unit_tonne 

Sets the default units for mass for new objects. 



Pro/ENGINEER Fundamentals – Help Topic Collection 

20 

prompt_on_erase_not_disp 

no, yes 

Displays a prompt so you can choose whether to save undisplayed objects before 

they are erased. This option is used with the Erase > Not Displayed command on 

the View menu.  

no—Erases all undisplayed objects without a prompt.  

yes—Prompts you to choose whether to save undisplayed objects.  

prompt_on_exit 

no, yes 

Prompts you whether to save objects when you exit a Pro/ENGINEER session. Your 

objects are not saved unless you set the option to yes. 

propagate_change_to_parents 

no, yes 

Determines which parent models to save when the option save_objects is set to 

changed or changed_and_specified. 

no—Saves only parent models that have actually been changed. 

yes—Saves any model that is a parent of a changed model. 

provide_pick_message_always 

no, yes 

Displays a description of an item in the message area after each selection. 

no—Displays descriptions for an item only while querying  

yes—Displays descriptions for items in all case, even when Query is not used. 

Queries include preselection highlighting, Next and Previous, and selections. 

quick_print_drawing_template  

<path and drawing template name> 

Specifies the path and name of a drawing template to be used by the File> Quick 

Print command. 

quick_print_plotter_config_file 

<path name to the plotter .pcf file> 

Specifies the path and name of the default plotter configuration file (*.pcf) to be 

used by the File > Quick Print command.  
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If plotter is set to ms_print_mgr, no other options are necessary. If it isn't set to 

ms_print_mgr, adding to the plotter configuration file the values for plot_file_dir 

and plotter_command is recommended. 

read_famtab_file_on_retrieve 

no, yes 

no—Ignores filename.ptd. 

yes—Creates and saves filename.ptd and uses that file on generic retrieval.  

regen_backup_using_disk 

no, yes 

Specifies whether the current model is backed up before each regeneration. 

relation_file_editor 

<editor> 

Sets the editor used to edit relations. 

relation_text_trail_output 

yes, no 

Includes or excludes changes in the text area of the Relations dialog box in the trail 

file. 

relation_tool_mapkey_behavior 

Increment, full_output 

Controls how Pro/ENGINEER runs mapkeys in the Relations dialog box.  

Increment—Records the text set added or removed in the text area and saves it to 

the mapkey. Subsequently, on running the mapkey, adds or removes text 

incrementally to the current text set in the text area.  

full_output—Records the original text set in the text area and saves it to the 

mapkey. Subsequently, on running the mapkey, the current text set in the text area 

 is replaced with the recorded text set. 

Note: You cannot record mapkeys if the value of relation_text_trail_output is 

set to no. However, you can run a mapkey that was recorded with this configuration 

option set to yes, regardless of this options's setting when you run the mapkey. 

relations_num_const_units 

yes, no 

Checks for units in a relation, issues a warning if units are missing, and prompts you 

to apply units. 
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If you want to add a relation to nonsolid models, such as layouts and bulks, you 

must always specify units for numeric constants. The setting of this configuration 

option is ignored for nonsolid models. 

relations_units_sensitive 

yes, no 

Checks for units when solving relations. 

yes—Takes units into account. If units are missing, a warning appears. 

no—Ignores units. 

rename_drawings_with_object 

none, part, assem, both 

Controls whether the system automatically copies drawing files associated with the 

part or assembly object types. The drawing files must have the same name as their 

objects.  

none—Excludes the associated drawing when saving copies. 

part—Copies the associated drawings of a part.  

assem—Copies the associated drawings of an assembly and its components. 

both—Copies the associated drawings for both parts and assemblies.  

To ensure that only objects with unique names are in session, use the default no for 

disable_search_path_check. The system checks the search path for objects with 

duplicate names.  

restricted_gtol_dialog 

yes, no, 

Controls the restrictions in the Geometric Tolerance dialog box when picking 

certain GTOL types.  

yes—Adheres to standards. 

no—Drops all restrictions. 

restricted_val_definition 

<file name> 

Specifies the location and name of the external file that contains definitions of the 

restricted-value parameters. Use the full directory path and name. 

retain_display_memory 

yes, no 
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Determines whether the display of an object on the screen is kept in memory when 

you quit the window. The default yes speeds up the retrieval of objects. 

retrieve_data_sharing_ref_parts 

no, yes, ignore_missing 

Retrieves the referenced parts for dependent features with shared data, such as 

Inheritance, External Copy Geometry, External Shrinkwrap, and External Merge. 

no—Ignores referenced parts in the retrieval. 

yes—Prompts the user to accept each referenced part during the retrieval. 

ignore_missing—Skips any missing referenced part, sends a message to that effect, 

and continues the retrieval process. 

save_clipped_view 

no, yes 

Specifies whether to save the model in the view clipped state. 

save_display 

no, yes 

Displays the geometry and detail items, such as solid dimensions, in View-Only 

mode. Use this option to decrease model retrieval time. To override this setting 

during runtime, click Tools > Environment, and then select or clear Save Display 

under Default Actions. 

save_instance_accelerator 

saved objects, none, explicit, always 

Determines how instances are saved with the Family Tables of solid parts. 

saved objects—Saves instance accelerator files if, 

• The instance is modified in one of the following ways. 

o Feature redefinition  

o Feature rerouting  

o Reference replacement 

o Feature reordering     

o Component replacement 

o Object integration 

• The instance verification status is not set to Failed. 
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• The instance verification status is set to Unverified. In this case, when creating 

the accelerator file, Pro/ENGINEER displays a message stating that the 

accelerator file was created for the nonverified instance. 

none—Does not save instance accelerator files. 

explicit—Saves instance accelerator files only when you explicitly save instances. 

always—Always saves instance accelerator files, regardless of whether you are 

saving an instance explicitly or through a higher-level object. 

You can override this configuration option at runtime by clicking File > Instance 

Operations, and clicking another command on the associated INST DBMS menu.  

save_model_display  

shading_lod, wireframe, shading_high, shading_low 

Sets the amount of graphical data stored in the assembly and part files. By default, 

the system always stores wireframe data in both parts and assemblies. The only 

information that the system saves in the assembly .asm file is the display setting of 

components that are intersected by assembly features. The system also saves the 

tessellated data for the low, medium, high, and lod options. The display setting at 

the time the assembly is saved is stored in the part and assembly files.  

shading_lod—Saves all levels of tessellation according to the setting in the View 

Performance dialog box. 

wireframe—Stores wireframe data in both parts and assemblies for a wireframe of 

the components without shading. 

shading_high—Saves the most detail in a finer tessellation for a shaded version of 

the components. 

shading_low—Saves the least detail in a coarser tessellation for a shaded version of 

the components. 

save_modified_draw_models_only 

yes, no 

Determines whether the system saves the model after you have changed it. If set to 

no, the system saves the model every time that you store the drawing. 

save_object_in_current 

no, yes 

Saves the object retrieved from a directory where you do not have write permission. 

See the override_store_back option. The objects to be saved are set by the 

save_objects configuration option. 

no—Does not save the object.  

yes—Saves the object in the current directory.  
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save_objects 

changed_and_specified, all, changed, changed_and_updated 

Determines when an object and its dependent objects, such as a part used in an 

assembly, are stored. 

changed_and_specified—Saves the top-level object plus any modified, dependent 

objects. 

all—Stores all objects.  

changed—Stores only modified objects. 

changed_and_updated—Stores changed and modified objects. 

save_unchanged_pdm_object 

as_ref, as_copy 

Determines how to save an object retrieved from a Pro/PDM database. The object is 

saved in the current working directory.  

as_ref—Saves the object as a reference only, that is, as a pointer to the Pro/PDM 

database.  

as_copy—Saves the unchanged object. 

search_path 

<directory path> 

Specifies an ordered list of directories in which to search for object or file retrieval. 

These directories, along with the current (working) directory and any directories in 

the search.pro file (see the configuration file option search_path_file) make up 

the Pro/ENGINEER search path.  

Separator Characters and Search Paths 

You must enclose in quotation marks any search path with a separator character 

(space, comma, or semicolon) in a directory name, for example: 

• Windows: search_path "C:\Program Files\proe2001\models" 

• UNIX: search_path "/home/user/smith/odd,dir;name" 

Note: For Windows NT, omit the last backslash (\) from the path, or enclose the 

path in quotation marks, or add a trailing space after the backslash. 

Relative and Absolute Paths 

The directory path names can be relative or absolute. You can use special characters, 

such as ".." in UNIX and Windows, in specifying a relative path name.  

Relative path names are initially resolved relative to the startup directory. If you 

subsequently reload the configuration file, the system reevaluates the relative path 
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names relative to the current working directory and appends the new directories (if 

any) to the search path (the previous path remains in place).  

It is better, therefore, to specify the full path names always (in other words, from 

root) so as to avoid problems if you change working directories or use the same 

configuration file in another startup directory.  

Using More Than One Path 

The option can have several path names on a single line, separated by commas, 

semicolons, or spaces. Whichever delimiter you choose, you must then use 

consistently. The option can appear any number of times in the configuration file, so 

it is not necessary to have more than one path name to a line. If objects with the 

same name are stored in more than one search-path directory, the system retrieves 

the first one that it finds, regardless of which object is the most recent. 

Previously Defined Environment Variables 

Search paths may also include previously defined environment variables. This is done 

by preceding the variable with $ in the search path definition. For example, the 

environment variable OBJ_TYPE can be used as follows: 

search_path /partlib/$OBJ_TYPE/objs 

search_path_file 

<path> 

Specifies the location of the search.pro file, which contains a list of directory path 

names. These directories, along with the current working directory, and any 

directories specified by the configuration option search_path, make up the 

Pro/ENGINEER search path.  

In the search.pro file, you specify an individual directory path on each line, starting 

with the first line in the file. Blank lines and comment lines (which begin with !) are 

permitted.  

You can specify either the path for the search.pro file or just the path to the 

directory containing that file. In the latter case, the system looks for search.pro in 

that directory. Use the full path rather than a relative one to avoid problems if you 

change working directories or use the same configuration file in another startup 

directory. 

Separator Characters and Search Paths 

You must enclose in quotation marks any search path with a separator character 

(space, comma, or semicolon) in a directory name, for example: 

• Windows: search_path "C:\Program Files\proe2001\models" 

• UNIX: search_path_file "/home/user/smith/odd,dir;name/search.pro" 

Note: For Windows NT, omit the last backslash (\) from the path, or enclose the 

path in quotation marks, or add a trailing space after the backslash. 
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sel_insts_on_comp_retrieval 

no, yes 

Prompts you to choose an instance when you retrieve instances of a family of 

assemblies and the table-driven components used in the assembly instances are 

themselves generics. 

select_on_dtm_edges 

all_modes, sketcher_only 

Specifies the method of selecting a datum plane. If you use Query frequently, set 

this option to sketcher_only. 

all_modes—Click the visual boundary of the datum plane.  

sketcher_only—Click the tag of the datum plane in modes other than Sketcher.  

set_trail_single_step 

no, yes 

Enables a trail file to be single-stepped by pressing ENTER. 

shade_mfg_ref_models 

yes, no 

Determines whether to process reference parts when generating the shaded image. 

no—Does not shade reference parts (to save time).  

yes—Shades reference parts. 

shade_surface_feat 

yes, no 

Displays surface features with shading.  

shade_with 

curves, no  

Displays datum curves on shaded objects.  

show_dim_sign 

no, yes 

Shows positive or negative values for dimensions. Dimensions for coordinate 

systems and datum point offsets always show negative or positive values, even if 

this option is set to no. 

no—Displays positive dimensions by creating the geometry to the opposite side, if 

you enter a negative value for the dimension. 
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yes—Displays negative dimensions by creating the geometry to the same side, if the 

dimension you modify is negative, and if you enter a negative value. 

show_selected_item_id 

no, yes 

Specifies whether to display IDs of the items listed in the Pick From List dialog box 

for the queried model geometry or dimensions. 

show_shaded_edges 

no, yes 

Controls the brightness of edge color compared to the surfaces to which they belong 

when shading objects.  

no—Displays the edges of the same color. 

yes—Displays brighter edges.  

spherical_map_size 

256x256, 512x512, 1024x1024 

Specifies the size of the texture image of the spherical map (resolution) to be used 

for realtime rendering. Increasing the image size affects performance but improves 

quality of the image. 

Note: This option is valid only in the OpenGL graphics mode and for graphics cards 

that do not support cubic environment mapping. 

spin_center_display 

yes, no 

Determines whether the spin center symbol is displayed. 

To override the display setting during runtime, click Tools > Environment, and 

then select or clear Spin Center under Display in the Environment dialog box.  

spin_rate_zoom_sensitive 

no, yes 

Controls the sensitivity of the model to rotation.  

yes-Reduces the sensitivity of the model to rotation. 

spin_with_orientation_center 

yes, no 

Displays the orientation center while reorienting the model. 
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spin_with_part_entities 

no, yes 

Displays datum features during the dynamic spinning of a model. 

spin_with_silhouettes 

no, yes 

Displays silhouette lines during the dynamic spinning of a model. 

start_model_dir 

<directory path> 

Provides the full path to the directory containing start parts and assemblies. For 

example: 

start_model_dir C:\Users\Johndoe\Pro\Start_Models 

start_model_dir/users/johndoe/pro/start_models 

system_background_color 

<0.000000 0.000000 0.000000> 

Defines the background color of the graphics window. The three real numbers from 

0–100 specify a percentage of red, green, and blue, respectively, in the resulting 

color. For example, 0 0 49 defines a medium blue.  

system_colors_file 

<path> 

Specifies the full path within the  config.pro file that sets the default color of the 

graphics. To change the colors in session, click View > Display Settings > System 

Colors, and then choose a tab in which to change a system color. 

In the system colors file, you can define default RGB values (<0.000000 0.000000 
0.000000>) for the various graphics. See the next table. The three real numbers 

from 0–100 specify a percentage of red, green, and blue, respectively, in the 

resulting color. For example, 0 0 49 defines a medium blue. The RGB values are 

identical to those in the R, G, and B boxes in the Color Editor dialog box. To access 

this dialog box, click a color in the System Colors dialog box. 

Configuration Option Graphics Affected User Interface 

Option 

system_background_color  background of the 

graphics window 

Background 

system_curves_color  curve entities Curves 

system_dimmed_menu_color  unavailable menu Highlight - 
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Configuration Option Graphics Affected User Interface 

Option 

items Secondary 

system_edge_high_color  edges Highlight - Edge 

system_geometry_color solid wireframe 

entities 

Geometry 

system_hidden_color  hidden, solid 

wireframe entities 

Hidden Line 

system_highlight_color primary highlight 

color 

Highlight - 

Primary 

system_letter_color  datum tags Letter 

system_section_color  datum entity labels 

or tags 

Sketched Curve 

system_sheetmetal_color sheet metal parts Sheet Metal 

system_volume_color  Manufacturing 

volumes 

Manufacturing 

Volume 

system_curves_color 

<0.000000 0.000000 0.000000> 

Defines the default color for curve entities. The three real numbers from 0–100 

specify a percentage of red, green, and blue, respectively, in the resulting color. For 

example, 0 0 49 defines medium blue. 

system_dimmed_menu_color 

<0.000000 0.000000 0.000000> 

Defines the default color of unavailable menu items. The three real numbers from 0–

100 specify a percentage of red, green, and blue, respectively, in the resulting color. 

For example, 0 0 49 defines a medium blue. 

system_edge_high_color 

<0.000000 0.000000 0.000000> 

Defines the default color in which edges are highlighted. The three real numbers 

from 0–100 specify a percentage of red, green, and blue, respectively, in the 

resulting color. For example, 0 0 49 defines a medium blue. 
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system_geometry_color 

<0.000000 0.000000 0.000000> 

Defines the default color of solid, wireframe entities. The three decimal values 

specify in order the percentage of red, green, and blue in the resulting color. For 

example, 0 0 49 defines a medium blue.  

system_hidden_color 

<0.000000 0.000000 0.000000> 

Defines the default color for the display of hidden, solid wireframe entities. The three 

real numbers from 0–100 specify a percentage of red, green, and blue, respectively, 

in the resulting color. For example, 0 0 49 defines a medium blue.  

The system ignores this option if use_part_color_for_hidden_lines is set to yes. 

system_highlight_color 

<0.000000 0.000000 0.000000> 

Defines the default color for the primary highlight color. The three real numbers from 

0–100 specify a percentage of red, green, and blue, respectively, in the resulting 

color. For example, 0 0 49 defines a medium blue.  

system_letter_color 

<0.000000 0.000000 0.000000> 

Specifies the default RGB color for datum tags. The three real numbers from 0–100 

specify a percentage of red, green, and blue, respectively, in the resulting color. For 

example, 0 0 49 specifies a medium blue. 

system_section_color 

<0.000000 0.000000 0.000000> 

Specifies the default color for sections. The three real numbers from 0–100 specify a 

percentage of red, green, and blue, respectively, in the resulting color. For example, 
0 0 49 defines a medium blue. 

system_sheetmetal_color 

<0.000000 0.000000 0.000000> 

Specifies the default RGB value for sheetmetal parts. The three real numbers from 

0–100 specify a percentage of red, green, and blue, respectively, in the resulting 

color. For example, 0 0 49 specifies a medium blue. 

system_volume_color 

<0.000000 0.000000 0.000000> 
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Specifies the default color for Manufacturing volumes. The three real numbers from 

0–100 specify a percentage of red, green, and blue, respectively, in the resulting 

color. For example, 0 0 49 defines a medium blue. 

tangent_edge_display 

solid, no, centerline, phantom, dimmed 

Determines how edges between tangent surfaces are displayed.  

solid—Displays edges as solid lines.  

no—Does not display edges.  

centerline—Displays edges in centerline font.  

phantom—Displays edges in phantom font.  

dimmed—Displays edges in a dimmed system color.  

template_drawing 

c_drawing.drw 

Specifies the file name of the default drawing template. 

template_solidpart 

<filename> 

Specifies the file name of the default drawing template for a part. 

tol_display 

no, yes 

Displays dimensions without or with tolerances. 

tol_mode 

limits, nominal, plusminus, plusminussym, plusminussym_super 

Sets the default display for dimension tolerances. Groups brought in from other 

models carry the tolerance display mode that was in effect when they were created. 

limits—Displays dimensions as upper and lower limits.  

nominal—Displays dimensions without tolerances. 

plusminus—Displays dimensions as a nominal with plus-minus tolerances (the 

positive and negative values are independent). 

plusminussym—Displays dimensions as a nominal with a single value for both the 

positive and negative tolerances. 

plusminussym_super—Same as plusminussym. However, displays the plus-minus 

tolerance value at the half-way point of the dimension text and extending upwards. 
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tolerance_class 

fine, medium, coarse, very_coarse 

Sets the default tolerance class for ISO-standard models. The system uses the 

tolerance class in conjunction with the dimension value when retrieving tolerances 

for general or broken-edge dimensions. 

tolerance_standard 

ansi, iso 

Sets the tolerance standard used when creating the model. 

tolerance_table_dir 

<directory path> 

Sets the default directory for user-defined tolerance tables for ISO-standard models. 

All Holes and Shafts tables overwrite existing tables when loaded. 

trail_delay 

0 

Sets a delay in seconds between steps in a trail file. 

trail_dir 

<directory path> 

Creates the trail file in the specified directory rather than in the startup directory. 

use_8_plotter_pens 

no, yes  

Specifies whether to support up to 8 plotter pens. The initial default is 4 pens.  

use_part_color_for_hidden_lines 

no,yes 

Uses a dimmed, user-defined part color for hidden lines and ignores the setting for 

system_hidden_color. 

use_software_linefonts 

no, yes  

no—Plots lines using the line font that most closely resembles the font used in 

Pro/ENGINEER. 

yes—Plots the exact line style used in Pro/ENGINEER, dot by dot, dash by dash, and 

space by space.  
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warn_if_iso_tol_missing 

no, yes 

Controls the display of a warning message in the Invalid ISO Tolerance dialog box. 

The Invalid ISO Tolerance dialog box is displayed when Pro/ENGINEER validates 

an ISO tolerance table and finds a missing tolerance value in the selected table. 

no—Pro/ENGINEER does not display a warning message. 

yes—Pro/ENGINEER displays a warning message if a tolerance value in the selected 

table is missing. 

When regenerating the model or the drawing, Pro/ENGINEER saves a warning 

message in a log file for each dimension that has no corresponding tolerance value in 

the ISO tolerance table. After regenerating the model or the drawing, you can access 

this log file by clicking Info > Session Info > Message Log. 

web_browser_history_days 

20 

Stores history records for the Pro/ENGINEER browser for the number of days 

specified. 

web_browser_homepage 

http://www.ptc.com/community/proewf/newtools/index.htm 

Specifies the path of the home page for the Pro/ENGINEER browser. 

windows_scale 

1.000000 

Scales Pro/ENGINEER windows with a given coefficient from 0.050000 through 

1.000000. A value of 0.85 is usually adequate to allow dynamic menus to display to 

the right of the Pro/ENGINEER window. 

x_angle 

0.000000 

Sets a default view orientation in degrees for models. The default orientation 

depends on which option—x_angle, y_angle, or orientation—is last in the 

configuration file. If none is used, the default is trimetric. See the orientation 

option. 

Note: If these variables are in the configuration file, the settings appear in the 

Orientation dialog box: choose View > Orientation, select Preferences under 

Type, and look under Default Orientation. 

y_angle 

0.000000 
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Sets a default view orientation in degrees for models. The default orientation 

depends on which option—x_angle, y_angle, or orientation—is last in the 

configuration file. If none is used, the default is trimetric. See the orientation 

option. 

Note: If these variables are in the configuration file, the settings appear in the 

Orientation dialog box: choose View > Orientation, select Preferences under 

Type, and look under Default Orientation. 

User Interface Basics 

Working with Pro/ENGINEER Windows and Dialog Boxes 

About the Pro/ENGINEER Main Window 

Each Pro/ENGINEER object that you open appears in its own Pro/ENGINEER window. 

You can perform many operations from the top-level menus in multiple windows 

without canceling pending operations. Only one window is active at a time, but you 

can still perform some functions in the inactive windows. To activate a window, click 

Window > Activate or press CTRL+A. 

The Pro/ENGINEER main window consists of a navigation area, the Pro/ENGINEER 

browser, the menu bar, toolchests, and information areas. The main window also 

contains the graphics window, where your model is displayed.  

Navigation Area 

The navigation area includes the Model Tree and Layer Tree, Folder browser, 

Favorites, and Connections. 

Pro/ENGINEER Browser  

The Pro/ENGINEER browser provides access to internal and external Web sites.  

Menu Bar 

The menu bar contains commands for creating, saving, and modifying models, and 

for setting your Pro/ENGINEER environment and configuration options.  

You can customize the menu bar by adding, removing, copying, or moving 

commands, or by adding icons to or removing them from the menu items.  

Note: Commands not appropriate to the active window are unavailable or not 

visible.  

Toolchests 

The toolchests, at the top, right, and left of the Pro/ENGINEER window, can contain 

toolbars, buttons, and menus. You can customize the content and location of the 

toolchests using the Customize dialog box. 
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Information Areas 

Each Pro/ENGINEER window has a message area and a status bar. In addition, 

screen tips appear when you pass the pointer over menu names, menu commands, 

toolbar buttons, and certain dialog box items. 

Dashboard 

The dashboard contains a message area in which one-line messages related to work 

in a window are displayed. Use the standard scroll bars in the message area to 

review past messages. 

Status Bar 

When applicable, the status bar displays the following information: 

• Warning and error shortcuts related to Tools > Console  

• Number of items selected in the current model  

• Available selection filters 

• Model regeneration status, , which indicates that the model must be 

regenerated, or , which indicates that current processes have been halted 

• Screen tips 

About the Menu Manager 

The Menu Manager is a series of cascading menus that you use to perform some 

tasks within Pro/ENGINEER. The Menu Manager menus change depending on the 

mode. Some of the Menu Manager menu options are duplicated in the menu bar 

menus. 

Customizing the Menu Manager 

You can customize the Menu Manager by creating a menu_def.pro file and storing it 

in your working directory.  

Note: If a menu default entry has already been defined for a particular menu in the 

loadpoint directory menu_def.pro file, any conflicting definitions in the local 

menu_def.pro file (in the working directory) are ignored. 

About the Dashboard 

The dashboard is a context-sensitive area at the bottom of the Pro/ENGINEER 

window that guides you through the modeling process. As you select geometry in the 

graphics window and set your preferences, the dashboard narrows your available 

options, so you make only targeted modeling decisions. The dashboard consists of 

the dialog bar, slide-up panels, message area, and the control area. 
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Dialog Bar 

You perform most of your modeling tasks in the graphics window and the dialog bar. 

When you activate a tool, the dialog bar displays commonly used options and 

collectors.  

Slide-up Panels 

To perform advanced modeling actions or retrieve comprehensive feature 

information, use the slide-up panels. Click one of the tabs above the dialog bar, and 

its slide-up panel opens. Because both the tabs and their corresponding slide-up 

panels are context sensitive, different tabs and panel elements are displayed, 

depending on the current modeling context. Default values are provided in some 

cases.  

To open another panel, click its tab. To close a panel, click its tab and the panel 

slides back into the dashboard.  

Message Area 

As you work with your model, Pro/ENGINEER confirms your actions and guides you 

through the modeling process with text messages in the message area below the 

dialog bar. The message area contains all messages for the current modeling 

session. To find an earlier message, scroll the message list or drag the sash to 

expand the message area.  

Text messages address two conditions:  

• System functions  

• Modeling actions 

Each message is preceded by an icon to indicate the category of the message: 

—Prompt 

—Informational 

—Warning 

—Error 

—Critical 

The message window continues to display messages even if you pause a tool and the 

dashboard is unavailable.  

Control Area 

The control area of the dashboard contains the following elements: 

—Pauses the current tool, temporarily returning you to the default system state 

in which you can make selections. Any features that you create while the original tool 
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is paused are placed in a Group in the Model Tree along with the original feature 

when completed. 

—Resumes a paused tool.  

—Activates Verify mode for the feature displayed in the graphics window. To 

stop Verify mode, click  again or click . The check box, when selected, 

activates dynamic preview, which you can use to view your changes to the model as 

you perform them. 

—Complete the tool with the current settings. 

—Cancels the current tool. 

To Change the Position of the Dashboard 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. Click the Options tab. 

3. Under Dashboard position, click Above graphics area or Below graphics 

area (the default). 

4. Save the new settings in the config.win using one of the following methods: 

o Select Automatically save to (selected by default), and then accept the 

default config.win file name. You can also enter a new file name or 

navigate to the config.win file in which you want to save the settings. 

o Click File > Save Settings. In the Save Toolbar Configuration File 

dialog box, you can accept the default file name and path, or you can type 

a new file name or navigate to the config.win file in which you want to 

save the new settings. Path names can contain up to 260 characters. 

5. Click OK to close the Customize dialog box and accept your changes. 

About Entering Data 

When you are prompted to enter data in the message area, a dialog box, or a slide-

up panel, you can either accept the default value or enter a new value. Complete the 

data entry in one of the following ways: 

• Press ENTER. 

• Click  or OK. 

• Middle-click. 

Note: You can usually cancel data entry operations by pressing ESC or clicking 

Cancel or . 
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Cutting and Pasting Text in Windows 

You can use the mouse or keyboard to cut, copy, and paste text from a system 

window, a Pro/ENGINEER window, or a message window. However, you cannot cut 

and paste either prompt text in the message area or online Help text. 

Entering Arithmetic Expressions 

When you are prompted for a numeric value, you can enter an arithmetic expression 

involving numbers, functions, operations, and parameter symbol names. For 

example: 

Enter value [2.53]: 2*((3/8)/7)+ceil(d5) 

The following basic arithmetic operators are supported: 

• + addition 

• - subtraction 

• / division 

• * multiplication 

• ( ) grouping, for example, d0=(d1-d2)*d3 

• ^ exponentiation 

Working with Fractions 

Dimension entry and display can be in decimal or fractional format. If you are 

working with fractions instead of decimal values, you must enter the number as an 

equation. For example, enter the value 1 1/8 as 1+1/8. This value appears as 1-1/8. 

You can create fractions automatically using configuration file options, or you can 

work in decimal format and convert specific dimensions to fractions.  

About Dialog Boxes 

Most dialog boxes support a set of related functions. For example, the view 

reorientation, zooming, panning, spinning, and spin-center functions are all available 

in the Orientation dialog box (View > Orientation > Reorient).  

Many dialog boxes are also dynamic, and options change as you make selections. For 

example, the Orientation dialog box changes depending on the selection under 

Type. 

As a rule, a function in the dialog box is available if:  

• The function is appropriate for the state of the window or object or for the 

product type (Part, Assembly, Sketcher, Layout, and so on). 

• The software required for using the function is installed. For example, if 

Pro/INTRALINK is installed, certain buttons on the File Open dialog box are 

available. 
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Performing Default Actions 

Most dialog boxes in Pro/ENGINEER have a default button, denoted by a black 

border. You can perform the default action quickly in three different ways: 

• Click the button. 

• Middle-click within the Pro/ENGINEER window. 

• Press ENTER. 

Using Accelerators and Mnemonics 

Accelerators and mnemonics are keyboard shortcuts to commands.  

Using Accelerators 

An accelerator is a key sequence for activating a menu command. To use an 

accelerator, press and hold the appropriate keys, such as CTRL or ALT, and then 

press the appropriate letter key. The key sequences for accelerators appear next to 

the commands on the menus. For example: 

CTRL+P Print 

CTRL+S Save 

CTRL+Z Undo 

CTRL+ALT+A Select All 

Using Mnemonics 

Mnemonics are letters that you use as shortcuts to traverse menus in the main menu 

bar. Mnemonics reduce mouse motion and provide a fast alternative if you prefer 

keyboard input.  

Mnemonics are indicated by an underlined letter in the menu name. For example, the 

mnemonic for File is F, and the mnemonic for Open is O. 

Press and hold ALT, press F. The File menu appears 

Press and hold ALT, press F, then O. The File Open dialog box opens.  

Shortcut Menus 

Pro/ENGINEER provides shortcut menus of frequently used commands appropriate to 

the current context. You can access a shortcut menu by right-clicking.  

Note: To open a shortcut menu in the graphics window, press the right mouse 

button for a short time. 

Shortcut menus are accessible in the following areas: 

• Graphics window 
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• Model Tree 

• Some dialog boxes with lists of items 

• Toolchests 

• Message area 

• Some status bar items 

• Any area where you can perform an object-action operation. 

Selection 

About Query and Preselection Highlighting 

You must select design items (datums or geometry) to be able to work with your 

model. This selection process usually begins with a query. You query design items to 

locate a specific item upon which to perform an action. As you move your pointer 

over the model and query, geometry and datums are highlighted and tooltips provide 

additional identification. This preselection highlighting enables you to accurately 

target the design item that you want to select. After you locate the item, you select 

it and begin designing. 

Query 

Query model geometry by placing your pointer over the model geometry and right-

click. With each right-click, Pro/ENGINEER cycles through each geometrical item that 

is located directly under the pointer from top (closest to the pointer) to bottom. The 

queried item name is displayed in the Status bar. You can continue to query until you 

have located the item that you want to select. Remember that querying is very 

helpful if another item is above the item that you want to select. 

Another way to query items is to use the Next and Previous shortcut menu 

commands or the Pick From List dialog box. The Pick From List dialog box 

contains a list of items that are located directly under the pointer, organized from top 

to bottom. Subassemblies are listed after the part-level components in the list. You 

can select the item from the Pick From List dialog box and begin designing your 

model.  

Note:  

• Pro/ENGINEER can display IDs of the items listed in the Pick From List dialog 

box for the queried model geometry or dimensions. Set the 

show_selected_item_id configuration option to yes to display these IDs (default 

is no). 

• Pro/ENGINEER can display a message in the message area that indicates each 

queried or selected geometry item. You must set the 

provide_pick_message_always configuration option to yes to display these 

messages (default is no). 
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Preselection Highlighting in Graphics Window 

As you move your pointer over an item or query an item, Pro/ENGINEER highlights 

the item. This type of highlighting is called preselection highlighting and provides a 

visual confirmation of the design item enabling you to accurately target the item that 

you want to select. As you move the pointer, Pro/ENGINEER highlights the top-most 

item located directly under the pointer. As you query, each item is highlighted from 

top (closest to the pointer) to bottom. 

Note: Preselection highlighting is enabled by default. If you disable it, you must use 

a different selection method.  

Preselection Highlighting in Model Tree and Layer Tree 

When preselection highlighting is enabled using Show > Preselection highlighting 

and you move your pointer over selectable Model Tree or Layer Tree items, that is, 

the tree nodes, then the tree nodes below the pointer appear underlined in the 

current text color indicating preselection highlighting of the nodes. The geometry 

corresponding to the selectable tree items below the pointer is displayed in the 

graphics window using preselection highlight presentation.   

When preselection highlighting is enabled by using both Show > Preselection 

highlighting and Edit > Select > Preferences and you move your pointer over 

selectable items in the graphics window, then the corresponding tree nodes appear 

underlined, indicating preselection highlighting of the nodes. 

A Note About ToolTips 

As you move the pointer over model geometry, a tooltip displays the name of the 

preselection highlighted or queried item in the Status Bar and in the graphics 

window. These Tooltips provide additional item identification. You can disable the 

graphic window tooltips by setting the enable_popup_help configuration option to no 

(default is yes). 

About Selection 

You must select a design item (datums or geometry) in order to work on your model. 

You can select an item before or after a feature tool is activated. To select an item, 

you place your pointer over the item in the graphics window. If another item is 

above it, you can query the item. After the item preselection highlights, click it. You 

can select multiple items by pressing the CTRL key as you click. Pro/ENGINEER 

builds a list of selected items or a "selection set" and indicates the number of items 

in the selection set in the Selected Items area located on the Status bar. For 

example, if you select three items, 3 selected is displayed in the Selected Items 

area. You can double-click the Selected Items area to open the Selected Items 

dialog box. This box contains the names of all items in the selection set. You can 

view the selection set and remove selected items.  

If you are selecting while working in a feature tool, each tool has specific selection 

requirements that must be met. These requirements are governed by filters and 

collectors. To make querying and selecting easier, Pro/ENGINEER provides filters that 

narrow the range of selectable items. These filters are located in the Filter box on the 
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Status bar. After you select items and open a feature tool, Pro/ENGINEER places the 

selected items in collectors. 

Note:  

• Preselection highlighting is enabled by default. If you disable it, you must use a 

different selection method. Refer to the topic under See Also for more information. 

• By default, when you select an item in the Model Tree or Layer Tree, geometry 

corresponding to the selected tree item is highlighted in the graphics window. 

You can disable this highlighting of geometry using Show > Highlight 

Geometry in the Model Tree or Layer Tree. 

Clearing a Selection 

As you select items, you may want to clear the selection of an item from the 

selection set, chain, or surface set. You can clear a selection in the following ways: 

Working outside of a tool 

• Holding down the CTRL key, click individual items to clear each one. For example, 

individual items in a surface set.  

Note: To clear the selection of the individual items from the ends of a chain, hold 

down the SHIFT key and click each item. To clear the selection of the entire 

chain, hold down the CTRL key and click the chain. 

• Remove the item using the Selected Items dialog box. 

• Clear the entire selection set, chain, or surface set by clicking in a vacant area in 

the graphics window. 

• Right-click the Selected Items area and click Clear on the shortcut menu to clear 

the entire selection set. 

Working inside of a tool 

• Clear a selected item or clear all items in the active collector either by using the 

Clear shortcut menu command from the graphics window, or the Remove or 

Remove All shortcut menu commands from within the collector itself. 

• Holding down the CTRL key, click individual items to clear each one from the 

collector. For example, individual items in a chain or surface set, or the entire 

chain or surface set. 

• Right-click the Selected Items area and click Clear on the shortcut menu to clear 

the selected items. 

Working with a Selection 

After you finish selecting, you can begin working on the selection set by doing any of 

the following: 

• Activate a feature tool by clicking a toolbar button enabling you to directly 

manipulate the item in the graphics window, or to use the Dashboard. Note that 

all selections inside a feature tool are governed by the requirement of that tool. 
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For example, you may only need to select one item to satisfy a Primary collector 

but multiple items for another collector. 

• Right-click and use the shortcut menu commands to perform an action on the 

selection set. 

• Use the menus on the Menu bar to perform an action on the selection set. 

Note: If you cancel a feature tool, Pro/ENGINEER restores the selection set that 

existed immediately before you opened the tool. This enables you to perform 

modeling actions on the selection set without having to recreate it. 

About Filters 

Pro/ENGINEER provides various filters to help you select items. These filters are 

located in the Filter box on the Status Bar. Each filter narrows the item types that 

you can select enabling you to easily locate the item. All filters are context-sensitive, 

so that only those filters that are valid for the geometrical context or that are 

required to meet feature tool requirements are available. Additionally, Pro/ENGINEER 

automatically selects the best filter according to the context. Remember that you can 

always explicitly change the filter by simply selecting another one from the Filter 

box. 

Smart Filter 

Pro/ENGINEER automatically selects the Smart filter, if it is available. The Smart 

filter enables you to select the most common types of items that are valid for the 

current geometrical context. This filter works on two levels: As you begin the 

selection process, the Smart filter allows you to select general, higher-level items, 

such as features or components. After you select the higher-level items, the Smart 

filter automatically narrows the selection scope enabling you to select more specific 

items, such as edges or faces. This entire process occurs automatically and results in 

less time explicitly changing filters and more time modeling in the graphics window.  

As with any other filter, simply select a different filter from the Filter box, if you do 

not want to use the Smart filter. 

Note: The Smart filter is not available if you disable preselection highlighting 

(enabled by default). 

About Collectors 

As you work with your model while in a feature tool, all selections are governed by 

the requirements of the tool. So, you must select a certain number and type of 

required items to create the feature. Pro/ENGINEER uses filters and collectors to 

guide you in making correct selections.  

After you select the items, they are collected as references (not the actual geometry) 

and placed in collectors. For example, you select a surface on your model as the 

primary placement reference for a hole and then activate the Hole tool. 

Pro/ENGINEER automatically opens the tool, collects the reference and places it the 

Primary placement collector. Now, you need to select secondary placement 
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references to satisfy the Secondary references collector (and to constrain the hole 

feature). At this time, you satisfied the basic hole requirements and you are free to 

close the tool and create the hole. However, you will want to finish designing the 

hole to your specifications. 

So, collectors function as storage bins for selected references that your feature tool 

requires. They also help you in making correct selections. 

Collector Types 

Pro/ENGINEER provides the following types of collectors: 

• Summary Collectors—Indicate that the required reference or references that 

you selected. Summary collectors are usually located on the dialog bar and 

always indicate the selection frequency and type. For example, you select 2 

surface sets, or two edges and a curve, and the Summary collector indicates 2 
Surface Sets, or 3 Selected. Remember that a Summary collector is always 

associated with its Detail collector, however not all feature tools have Summary 

collectors. 

• Detail Collectors—Contain detailed information about the required reference or 

references that you selected. Detail collectors are usually located on the slide-up 

panels and always contain detailed information such as feature name, type, and 

values. For example, you select a surface on your model as the primary 

placement reference for a hole. The Primary collector in the Placement slide-up 

panel contains Surf:F5(PROTRUSION). All feature tools have Detail collectors. 

Note: Collectors are only available after a feature tool activates. 

About Working with Collectors 

As you work in a feature tool, you must actively work with collectors. You can do the 

following: 

• Activate a collector—You activate a collector in order to work with it. You can 

click in a Detail collector to activate it or use a shortcut menu command. You can 

also activate a Summary collector by clicking in it. Remember that if you activate 

a Detail collector, the associated Summary collector (if available) also activates 

and vice versa. 

• Select new references—After you activate a collector, simply select new items 

to add to the existing ones or to replace them. 

• Change values, types, and other parameters—You can change reference 

values, type, and other parameters by working in the Detail collector. 

• Clear the active collector—You can clear all references from the active 

collector using the following methods: 

o While working in the graphics window, activate the collector and right-click. 

After the shortcut menu appears, select Clear. Pro/ENGINEER clears all 

references from the active collector. 
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o Simply, place your pointer in the collector and right-click. After the shortcut 

menu appears, select Remove All. Pro/ENGINEER removes all references 

from the collector. Note that multiple references must be present in the 

active collector to use Remove All. 

• Remove one reference from the active collector—You can remove one 

reference from the active collector using the following methods: 

o Press CTRL and click each selected item on the model. Pro/ENGINEER 

removes the associated reference from the active collector.  

o Place your pointer in the active Detail collector, select the item to remove 

and right-click. After the shortcut menu appears, select Remove. 

Remember that your pointer must be in the Detail collector before you 

right-click. 

o Report reference information—You can report detailed information for the 

selected reference. Simply select the reference from the active Detail collector 

and right-click. After the shortcut menu appears, select Information. 

Pro/ENGINEER opens the browser and displays reference information that can 

include feature element data and dimensions, layers, and parent and child 

feature data.  Remember that your pointer must be in the active Detail collector 

before you right-click. Note that you cannot report reference information about 

chains or surface sets. 

To Select Items 

This topic assumes that preselection highlighting is enabled (default setting). If you 

disable it, you must use a different selection method. Refer to About Disabling 

Preselection Highlighting under See Also for more information. 

1. Place your pointer directly over the item that you want to select and right-click. 

Pro/ENGINEER prehighlights each queried item that is directly under your pointer 

from top (closest to the pointer) to bottom. The queried item name displays in 

the Status bar and as a tooltip. 

2. After you locate the item, click it. The selected item highlights in the graphics 

window and in the Model Tree. Pro/ENGINEER builds a selection set and indicates 

1 Selected in the Selected Items area on the Status bar. 

3. If you want to add an additional item to the selection set, press CTRL and move 

the pointer over the item or use query the item, then click. Both selected items 

highlight in the graphics window and in the Model tree. The Selected Items area 

indicates 2 Selected. Repeat this step to add more items. 

4. If you want to select an existing Group feature, click an item contained in the 

Group feature, right-click and use Select Group from the shortcut menu. 

Pro/ENGINEER selects the Group feature and adds it to the selection set.  

5. If you want to remove an item from the selection set, place your pointer over the 

highlighted item and press CTRL+click. Pro/ENGINEER clears the item and 

removes it from the selection set. 



Pro/ENGINEER Fundamentals 

47 

6. With the selected items highlighted, right-click and use the shortcut menu 

commands or open a feature tool to perform an action on the selected items. 

Note:  

• You must press (and hold) CTRL to select multiple items. Otherwise, 

Pro/ENGINEER clears all selected items from the selection set and replaces them 

with the last selected item. 

• All selections inside a feature tool are governed by the requirement of that tool. 

For example, you may only need to select one item to satisfy one collector but 

multiple items for another collector. 

Tip:  

• Before you begin selecting items, make certain that the correct filter is selected. 

• You can always click a vacant area in the graphics window to clear the selection 

set. You can also use Clear from the shortcut menu. 

• If you are not in a feature tool and you select only one item, and the item surface 

(not the outline) highlights, click a vacant area in the graphics window to clear 

the selection. Then, start selecting again. 

• You can also view the selection set or remove items from the selection set by 

double-clicking the Selected Items indicator on the Status bar. After the 

Selected Items dialog box opens to display the selection set, simply select the 

items to remove and click Remove. 

• You can right-click the Selected Items area and click Clear on the shortcut menu 

to clear the entire selection set. 

• Pressing CTRL+double-click selects or removes an item and activates Edit 

enabling you to change dimension values and properties for the selected items. 

Selection Actions 

You can use various actions to select items (geometry and datums). The table below 

lists the main selection actions: 

Action Description 

Click Selects individual items to add to the 

selection set or tool collector. 

Double-click Activates the Edit mode enabling you to 

change dimension values or properties for 

the selected items. 

Note: For actions inside of a feature tool, 

refer to the documentation for the tool. 

CTRL+click (press and 

hold CTRL as you click) 

Selects additional items to be included in the 

same selection set or tool collector. 
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Action Description 

Clears a selected item and removes it from 

the selection set or from the tool collector. 

CTRL+double-click 

(press and hold CTRL as 

you double-click) 

Combines CTRL+click and Double-click in 

one action. 

Note: For actions inside of a feature tool, 

refer to the documentation for the tool. 

SHIFT+click (press and 

hold SHIFT as you click) 

After you select an edge or curve, activates 

the chain construction mode. 

After you select a solid surface or quilt, 

activates the surface set construction mode. 

Right-click Activates the shortcut menu. 

SHIFT+right-click 

(press and hold SHIFT as 

you right-click) 

Queries through possible chains based on the 

anchor that you selected. 

About Disabling Preselection Highlighting 

Preselection highlighting provides a visual confirmation of the design element 

enabling you to accurately target the element that you want to select. Pro/ENGINEER 

enables preselection highlighting by default. However, you can disable it, if 

necessary. 

Disabling Preselection Highlighting 

You disable preselection highlighting by clearing the Preselection highlighting 

check box in the Selection Preferences dialog box (Edit > Select > 

Preferences). Note that you can also set the prehighlight configuration option to 

no (default is yes).  

Selection Behavior 

If you disable preselection highlighting, the Pro/ENGINEER selection behavior 

changes. To select items, you must use the following selection method: 

• Pick—You select items directly from the model. You can activate the Pick mode 

by using the Pick command from the Edit menu (Edit > Select > Pick) or from 

the graphics window shortcut menu. Pro/ENGINEER selects this method by 

default if you disable preselection highlighting. 

• Query—You select items that are listed in the Pick From List dialog box. You 

can activate the Query mode by using the Query command from the Edit menu 

(Edit > Select > Query), or from the graphics window shortcut menu. 
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Remember that after you finish your selection using Query, Pro/ENGINEER 

returns to the Pick selection mode. 

Note: If you disable preselection highlighting. you cannot use the Smart filter. 

To Select with Preselection Highlighting Disabled 

After you disable preselection highlighting, you can use one of two following selection 

methods to select items. 

1. If you want to use the Pick selection method to select items, place your cursor in 

the graphics window, right-click and select Pick from the shortcut menu, or from 

the Edit menu (Edit > Select > Pick). You can now select items directly from 

the graphics window using the standard selection capabilities, such as pressing 

CTRL to select multiple items. Pro/ENGINEER builds a selection set and indicates 

the number of items in the set on the Status bar. Notice that you cannot query 

items by using the Pick selection method.  

Note: Pro/ENGINEER selects this method by default if preselection highlighting is 

disabled. 

2. If you want to use the Query selection method to select items, place your cursor 

in the graphics window, right-click and select Query from the shortcut menu, or 

from the Edit menu (Edit > Select > Query). Do the following: 

o Click the area on the model over which the item you want to select is 

located. The Pick From List dialog box appears listing all items that are 

directly under your pointer from top (closest to the pointer) to bottom. 

o Right-click to query the item. Pro/ENGINEER highlights the queried item in 

the graphics window and in the Pick From List dialog box. 

o Middle-click to select the item. Pro/ENGINEER builds a selection set and 

indicates 1 Selected  on the Status bar. The Pick From List dialog box 

also closes and the selected item highlights in the graphics window and on 

the Model Tree. Notice that you can also click OK from the Pick From List 

dialog box to select an item.  

o If you want to select additional items, right-click and select Query from the 

shortcut menu. Then, press CTRL and click the additional items from the 

Model Tree. Note that you cannot select additional items in the graphics 

window or in the Pick From List dialog box when using this selection 

method. 

o In the graphics window, right-click and use the shortcut menu commands 

to perform the preferred action on all selected items. 

Note: After you select an item, Pro/ENGINEER returns to the Pick selection 

method (the default method). You must select Query from the shortcut 

menu to continue using this method.  

Tip: After the Pick From List dialog box appears, you can move your 

pointer over a new location and click to change the items on the Pick From 

List dialog box. 
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3. Right-click and use the shortcut menu commands or open a feature tool to 

perform an action on the selected items. 

Note: If you disable preselection highlighting. you cannot use the Smart filter. 

Tip:  

• Before you begin selecting items, make certain that the correct filter is selected. 

• You can always click a vacant area in the graphics window to clear any selections. 

• You can also view the selection set or remove items from the selection set by 

double-clicking the Selected Items indicator on the Status bar. After the 

Selected Items dialog box opens to display the selection set, simply select the 

items to remove and click Remove. 

Chains and Surface Sets 

Chains 

About Chains 

Chains consist of multiple edges or curves that are related, for example, by a 

common vertex or by tangency. You select these related edges or curves and place 

them into a group or chain. Chains enable you to efficiently perform modeling actions 

on all of the selected edges or curves in that chain or on multiple chains at one time. 

You can construct chains and use them at any time (within a tool or before entering 

a tool) during your modeling session. Remember, anytime you want to construct a 

chain, you must first select a reference, and then press (and hold) SHIFT to activate 

the chain construction mode. Pro/ENGINEER provides ToolTips, messages, and labels 

that act as a visual aid to guide you through the chain construction process. 

To modify chains, you use the Chain dialog box. This dialog box contains a list of 

chains that you constructed using the active part and chain attributes and options. 

Chain Types 

You can create the following types of chains: 

Non-rule based 

• One-by-One Chain—Chain of individual edges, curves, or composite curves that 

you select. You can also use a One-by-One chain if you want to model additional 

edges or curves along with other chains that you constructed. You usually create 

a One-by-One chain if the elements that you need to select are not part of the 

same feature, such as a datum curve, or if the elements exist across multiple 

features. Note that some applications may place other conditions on the resulting 

chain, such as tangency.  

• Intent Chain—An intent chain is one that is defined and preserved by the event 

that created it rather than by the specific entities that it contains. For a simple 

extrusion with a section composed of entities forming a single closed loop, all the 



Pro/ENGINEER Fundamentals 

51 

edges generated by the section define an intent chain. If you add or remove 

entities from the loop, the intent chain is automatically updated as well as any 

feature that references it. 

For example, if you select the edges resulting from the intersection of two solid 

extrusions as an intent chain to create a round, then the intent chain and the 

round are automatically updated if you change the sections for the extrusions. 

Rule-based 

• Partial Loop Chain—Chain that begins at a start-point, follows an edge, and 

ends at the end-point of the edge or curve segment that you select (also known 

as a From-To chain). You can construct a curve, surface, or quilt boundary Partial 

Loop chains. 

• Tangent Chain—Chain defined by the selected item and the extent to which 

adjacent entities are tangent. 

• Complete Loop Chain—Chain that contains an entire loop of curves or edges 

that binds the curve, quilt, or solid surface to which it belongs, or binds a portion 

of it as defined by two curves or two edges. 

Note: Although points and vertices are considered to be chains by some 

applications, this is an exception. Most tools discard points and vertices when 

transferred along with chains into the primary collector. You cannot explicitly convert 

points and vertices outside of a feature tool into chains, nor can they be extended or 

modified in any way as chains. 

To Construct a Chain 

1. Select an edge or curve on your model to establish the anchor. Pro/ENGINEER 

highlights the selected edge or curve. 

2. Press the SHIFT key and move the pointer over to an adjacent segment. The 

preview of the one-by-one chain consisting of the anchor and the adjacent 

segment is displayed.  

3. Holding down the SHIFT key, right-click and do one of the following actions: 

• Click Pick From List on the shortcut menu. The Pick From List dialog box 

opens which contains all the possible chains that you can construct using the 

anchor and the adjacent segment. Select the desired chain from the list. The 

preview of the chain is displayed in the graphics window. Click OK to accept the 

selected chain and close the Pick From List dialog box. 

• Click Next or Previous on the shortcut menu to preview the next or previous 

chain available for selection without opening the Pick From List dialog box. Click 

to accept the selected chain. 

• Right-click to query all possible chains associated with the anchor. Valid edges 

and curves for each possible chain are highlighted and a ToolTip identifies the 

chain type, for example Tangent, Surface Loop, or One-by-One. Note that the 

pointer must be near the selection and not over a handle to be able to query 

possible chains. If you are constructing a From-To chain, place the pointer over 
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the edge or curve where the chain will terminate and right-click to query through 

the possible chains until you locate the From-To chain. 

Click the highlighted item associated with the chain type that you want to create. 

Pro/ENGINEER constructs the chain and highlights it.  

Note: If you are working with a tool closed, the Selected Items area indicates the 

selection and the Selected Items dialog box contains the chain. If you construct 

a chain from inside a tool, the active collector contains the chain and the Chain 

label is displayed on the model. 

4. If you are constructing a One-by-One chain, holding down the SHIFT key, click on 

the anchor again, and select additional edges or curves to include in the chain. 

Pro/ENGINEER appends and highlights the chain. Alternatively, holding down the 

SHIFT key, move the pointer over to an adjacent segment. The one-by-one chain 

consisting of the anchor and the adjacent segment are pre-highlighted. Click to 

accept the one-by-one chain. Select other segments to add to the one-by-one 

chain. 

5. If you want to construct additional chains during the same workflow, release 

SHIFT, hold down the  CTRL key and click an edge or curve on your model to 

select an anchor for the new chain. Release CTRL repeat step 2 through step 5. 

6. Open a feature tool or continue working in a tool to use the chain to create a 

feature. 

Tip: 

• You can remove an entire chain from the selection set by holding down the CTRL 

key and clicking the chain to remove it. 

• After you close a tool, Pro/ENGINEER restores the selection set that you 

constructed before opening the tool. You can continue to use your chains in other 

tools, without having to reconstruct them. 

• When you construct a Partial Loop chain, that is, a From-To chain using direct 

selection in the graphics window, Pro/ENGINEER remembers the first selected 

edge or curve as the anchor reference and the second selection as the extent 

reference. If the extent reference is a one-sided edge and is the same as the 

anchor, then when you query this edge, Surface loop from to appears once in 

every query cycle. If the extent reference is a two-sided edge and is the same as 

the anchor, then when you query this edge, Surface loop from to appears twice 

in every query cycle.  

• You can use a continuous intent edge to construct a One-by-one chain. 

• To exclude a continuous intent edge or a composite curve located at the end of a 

chain, query the edge or curve and select it. 

To Modify Chain Types and References 

Note: This topic discusses chain modification while working inside of a tool and using 

the Chain dialog box. If you want to modify a chain while working outside of a tool, 

you can use the SHIFT key to clear the selection of individual items from the ends of 
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a chain or use the CTRL key to remove an entire chain from the selection set. Refer 

to About Selection under See Also for more information about clearing a selection. 

1. Construct a chain and open the tool in which to work with the chain, or select a 

feature that contains an existing chain that you want to modify, right-click, and 

select Edit Definition from the shortcut menu. 

2. Locate the Detail collector that contains the chain that you want to modify. Detail 

collectors are located on the slide-up panel. Note that you cannot use the 

Summary collector (located on the dialog bar) to modify a chain. 

3. Click Details. Pro/ENGINEER pauses the tool, opens the Chain dialog box, and 

displays the attributes for the chain. 

4. If the slide-up panel Detail collector contains more than one chain, select the 

chain to modify from the chain list in the Chain dialog box. The chain attributes 

are displayed. 

5. Click the References tab to modify the chain type and references. 

6. Click Standard to change the selected chain to a One-by-One chain or modify 

this chain type. The References tab contains the following option. 

References collector—Contains the references for the selected chain. 

References consist of one or more adjacent edges or curves, or a single-piece 

Intent chain. To modify a reference, click the reference to activate the collector 

and then select a new reference from the model, select additional references, or 

remove the reference. Notice that you can also use the References shortcut 

menu command from inside the graphics window to activate this collector. 

Note: 

o All references in the collector are ordered according to the internal direction 

of the chain with the start point at the top. 

o You can remove references only at the top and bottom of the list. 

Additionally, if the collector contains only one reference, this reference 

cannot be removed. However, you can select another reference to replace 

it. 

7. Click Rule-based to change the selected chain to a Tangent, Partial Loop (From-

To), or Complete Loop chain, or to modify these chain types. The References 

tab now contains the following: 

Anchor collector—Contains the anchor reference for the selected chain. Anchor 

references consist of an edge or a curve. To modify the anchor, click the 

reference to activate the collector and select a new anchor reference from the 

model. Notice that you can also use the Anchor shortcut menu command from 

inside the graphics window to activate this collector. 

Note: You can only replace the anchor reference, you cannot remove it. 

Rule—Displays the following chain types enabling you to modify them: 
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o Tangent—Constructs a tangent chain by using all edges that are tangent to 

their neighboring edges and tangent to the anchor, if possible. Note that if 

an anchor reference is used it must be an edge.  

o Partial loop—Constructs a Partial Loop (From-To) chain by using all loop 

reference items (curves or edges that partially bind the quilt or solid surface 

to which it belongs) located between the anchor (start-point) and the 

extent (end-point) references. The Extent Reference collector and the 

Flip button appear. Note that you must select an anchor to use the Partial 

Loop option. 

o Complete loop—Constructs a Complete Loop chain by using an entire loop 

of reference items (curves or edges that completely bind the curve, quilt, or 

solid surface to which it belongs). The Loop Reference collector appears. 

Note that you must select an anchor to use the Complete loop option. 

Extent Reference collector—Contains the extent (end-point) reference for a 

Partial Loop chain. Extent references consist of an edge or a curve that can 

belong to a valid loop reference (solid surface, quilt, or curve). To modify the 

chain, click the reference to activate the collector and then select a different 

extent reference from the model. Notice that you can also use the Extent 

Reference shortcut menu command from inside the graphics window to activate 

this collector. 

Note: You must select the Partial Loop chain type to use this collector. 

Range—Displays the Flip button. The Flip button changes a portion of the loop 

reference in a Partial Loop (From-To) chain. Note that you must select the 

Partial Loop chain type, and more than one Partial Loop chain must be formed 

by the selected anchor, extent, or loop reference in order to use this button. 

Loop Reference collector—Contains the loop reference for the Complete Loop 

chain. Consists of a quilt or a solid surface loop reference. To define a new loop 

range, click the reference to activate the collector and then select a new loop 

reference from the model. Notice that you can also use the Loop Reference 

shortcut menu command from inside the graphics window to activate this 

collector. 

8. Click OK. Pro/ENGINEER saves the changes, closes the Chain dialog box, and 

resumes the tool. 

Tip: 

• You can construct a chain by clicking Add in the Chain dialog box and selecting 

chain references from the model. 

• To remove a chain from the Chain list, select the chain and click Remove in the 

Chain dialog box. 

• Remember that you can hold down the CTRL key and select a reference to either 

add an additional reference or to clear a selected reference. 

• To clear references in the active collector, click Remove or Remove All on the 

shortcut menu that appears when you right-click in the collector. Alternatively, 
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click Clear on the shortcut menu that appears when you right-click in the 

graphics window. 

• To easily locate references in the Chain dialog box, place your pointer over the 

reference in a collector. Pro/ENGINEER dynamically highlights the reference on 

the model. 

• Notice that as you modify a chain in the Chain dialog box, Pro/ENGINEER 

dynamically displays the changes in the graphics window. 

• When the Chain dialog box is open, you can perform Undo or Redo operations if 

the tool or feature supports Undo or Redo operations. 

To Trim or Extend a Chain 

Note:  

• This topic discusses chain modification while working inside of a tool and using 

the Chain dialog box. If you want to modify a chain while working outside of a 

tool, you can use the SHIFT key to clear the selection of individual items from the 

ends of a chain or use the CTRL key to remove an entire chain from the selection 

set. Refer to About Selection under See Also for more information about clearing 

a selection. 

• You can trim or extend open-ended chains (One-by-One, Tangent, and Partial 

Loop). 

• You can trim closed-loop chains but you cannot extend them. 

1. Construct the chain and open the tool in which to work with the chain, or select a 

feature that contains an existing chain that you want to modify and click Edit 

Definition. 

2. Locate the Detail collector that contains the chain that you want to modify. Detail 

collectors are located on the slide-up panel. Note that you cannot use the 

Summary collector (located on the dialog bar) to modify a chain. 

3. Click Details. Pro/ENGINEER pauses the tool, opens the Chain dialog box, and 

displays the attributes for the chain. 

4. If the slide-up panel Detail collector contains more than one chain, select the 

chain to modify from the chain list in the Chain dialog box. The chain attributes 

are displayed. 

5. Click the Options tab. If you have selected a closed-loop chain, then the Start 

Point check box appears selected by default.  

6. For closed-loop chains, if required, modify the start point using the Start Point 

collector and the Flip button. Clear the Start Point check box. The options under 

Length Adjustment become available. 

7. To trim or extend End 1 or End 2 of a chain, use one of the following options 

under Length Adjustment: 
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o Value—Trim or extend a chain using a value. Type a distance value and 

press ENTER, or select a most recently used value from the list. Note that 

negative values trim a chain. You can also drag the handle on your model 

to adjust the value. To add a relation to a feature for the extend values of 

chain ends when creating or redefining a feature, perform the following 

steps:  

a. Type an expression as the value of for a length adjustment. For 

example, d1*0.5.  

b. Press ENTER. If the expression returns a positive value, then 

Pro/ENGINEER prompts you for confirmation about whether you want to 

add the expression as a relation to the feature.  

c. Click Yes to create the relation in the feature. This relation controls 

the extend value. The Length Adjustment options list becomes read-only 

and displays the value derived from the relation as a read-only value.  

Note: After you have created the feature, you can modify the relation using 

the Relations dialog box that opens when you click Tools > Relations. 

o Trim at Reference—Trim a chain using a reference. Valid references 

consist of items that intersect the chain (surfaces, planes, curves, edges, 

axes, and so forth), or datum points or vertices that lie on the chain. This 

option activates the Trim at Reference collector enabling you to select a 

reference up to which the chain is trimmed. Notice that you can also use 

the Trim at Reference shortcut menu command from inside the graphics 

window to activate this collector. 

o Extend to Reference—Extends a chain using a reference. Valid references 

consist of items that intersect the chain (surfaces, planes, curves, edges, 

datum points, and so forth). This option activates the Extend to Reference 

collector enabling you to select a reference up to which the chain is 

extended. Notice that you can also use the Extend to Reference shortcut 

menu command from inside the graphics window to activate this collector. 

8. To trim a closed-loop chain, click Excluded and select an edge or curve from the 

start point of the chain. 

9. Click OK. Pro/ENGINEER saves the changes, closes the Chain dialog box, and 

resumes the tool. 

Tip: 

• Notice that as you modify a chain in the Chain dialog box, Pro/ENGINEER 

dynamically displays the changes in the graphics window. 

• To clear references in the active collector, click Remove or Remove All on the 

shortcut menu that appears when you right-click in the collector. Alternatively, 

click Clear on the shortcut menu that appears when you right-click in the 

graphics window. 

• To easily locate references in the Chain dialog box, place your pointer over the 

reference in a collector. Pro/ENGINEER dynamically highlights the reference on 

the model. 
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To Add Relations for Extend Values of Chain Ends  

1. To add a relation to a feature for extend values of chain ends when you create or 

redefine a feature using the graphics area, right-click the feature on the Model Tree 

and click Edit on the shortcut menu.  

2. Double-click the dimension value in the graphics area and specify the length 

adjustment value as an expression. For example, d1*0.5. 

3. Press ENTER. If the expression returns a positive value, then Pro/ENGINEER 

prompts you for confirmation about whether you want to add the expression as a 

relation to the feature.  

4. Click Yes to create the relation in a feature. Pro/ENGINEER derives the length 

adjustment value from the relation and displays it as a read-only value in orange. 

The relation controls the length adjustment value of the chain.  

Note: You can also add a relation to a feature for extend values of chain ends using 

the Chain dialog box when creating or redefining a feature. 

 

About Validating Chains Dynamically 

When you create or edit chains Pro/ENGINEER dynamically validates the chain. If the 

chain is valid the Dynamic validation box is automatically selected. When dynamic 

validation is enabled, adding new references to the active collector or removing 

references from the active collector does not make the active chain invalid. Note that 

you can disable dynamic validation at any time. 

If the chain is invalid the Dynamic validation box is automatically cleared. When 

dynamic validation is disabled, you can add new references to the active collector or 

remove references from the active collector without restrictions. However, this may 

make the active chain invalid. If the chain becomes invalid then the Dynamic 

validation box becomes unavailable. 

To Append or Exclude Items from a Chain 

Note:  

• This topic discusses chain modification while working inside of a tool and using 

the Chain dialog box. If you want to modify a chain while working outside of a 

tool, you can use the SHIFT key to clear the selection of individual items from the 

ends of a chain or use the CTRL key to remove an entire chain from the selection 

set. Refer to About Selection under See Also for more information about clearing 

a selection. 

• You can append items or exclude items in rule-based chains. However, all tools 

may not support the appending and excluding of items. 

1. Construct the chain and open the tool in which to work with the chain, or select a 

feature that contains an existing chain that you want to modify and click Edit 

Definition. 
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2. Locate the Detail collector that contains the chain that you want to modify. Detail 

collectors are located on the slide-up panel. Note that you cannot use the 

Summary collector (located on the dialog bar) to modify a chain. 

3. Click Details. Pro/ENGINEER pauses the tool, opens the Chain dialog box, and 

displays the attributes for the chain. 

4. If the slide-up panel Detail collector contains more than one chain, select the 

chain to modify from the chain list in the Chain dialog box. The chain attributes 

are displayed. 

5. Click the Options tab. 

6. Click in the Appended or Excluded collector to append items or exclude items, 

respectively. Clicking the collector activates the collector. Notice that you can 

also use the Appended Items or Excluded Items shortcut menu command 

from inside the graphics window to activate this collector. 

7. Hold down the CTRL key and from the graphics window, select one or more edges 

or curves from your model to append to or remove from the chain. The 

Appended collector does not allow you to select an excluded edge or curve. 

Similarly, the Excluded collector does not allow you to select an appended edge 

or curve. 

Note:  

o Pro/ENGINEER dynamically validates the chain you are creating or editing. 

If the chain is valid the Dynamic validation box is automatically selected. 

When dynamic validation is enabled, adding new references to the active 

collector or removing references from the active collector does not make 

the active chain invalid.  

o If the chain is invalid the Dynamic validation box is automatically cleared. 

When dynamic validation is disabled, you can add new references to the 

active collector or remove references from the active collector without 

restrictions. However, this may make the active chain invalid. If the chain 

becomes invalid then the Dynamic validation box becomes unavailable. 

o You can disable dynamic validation at any time.  

8. Click OK. Pro/ENGINEER saves the changes, closes the Chain dialog box, and 

resumes the tool. 

Tip: 

• Notice that as you modify a chain in the Chain dialog box, Pro/ENGINEER 

dynamically displays the changes in the graphics window. 

• To clear references in the active collector, click Remove or Remove All on the 

shortcut menu that appears when you right-click in the collector. Alternatively, 

click Clear on the shortcut menu that appears when you right-click in the 

graphics window. 
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• To easily locate references in the Chain dialog box, place your pointer over the 

reference in a collector. Pro/ENGINEER dynamically highlights the reference on 

the model. 

To Modify the Start Point or Direction of a Chain 

Note: This topic discusses chain modification while working inside of a tool and using 

the Chain dialog box. If you want to modify a chain while working outside of a tool, 

you can use the SHIFT key to clear the selection of individual items from the ends of 

a chain or use the CTRL key to remove an entire chain from the selection set. Refer 

to About Selection under See Also for more information about clearing a selection. 

1. Construct the chain and open the tool in which to work with the chain, or select a 

feature that contains an existing chain that you want to modify and click Edit 

Definition. 

2. Locate the Detail collector that contains the chain that you want to modify. Detail 

collectors are located on the slide-up panel. Note that you cannot use the 

Summary collector (located on the dialog bar) to modify a chain. 

3. Click Details. Pro/ENGINEER pauses the tool, opens the Chain dialog box, and 

displays the attributes for the chain. 

4. If the slide-up panel Detail collector contains more than one chain, select the 

chain to modify from the chain list in the Chain dialog box. The chain attributes 

are displayed. 

5. Click the Options tab. 

6. To change the start point and direction of an open-ended chain (One-by-One, 

Tangent, and Partial Loop), click Flip. Pro/ENGINEER reverses the chain start 

point and direction. Skip to step 9. 

7. To change the chain start point location of a closed-loop chain (One-by-One or 

Complete Loop), click the Start Point collector. After the collector is activated, 

select any vertex from the chain on your model as the new start point location. 

Notice that you can also use the Start Point shortcut menu command from 

inside the graphics window to activate this collector. 

8. To change the chain direction of a closed-loop chain, click Flip. Pro/ENGINEER 

reverses the chain direction. 

9. Click OK. Pro/ENGINEER saves the changes, closes the Chain dialog box, and 

resumes the tool. 

Tip: 

• Notice that as you modify a chain in the Chain dialog box, Pro/ENGINEER 

dynamically displays the changes in the graphics window. 

• To clear references in the active collector, click Remove or Remove All on the 

shortcut menu that appears when you right-click in the collector. Alternatively, 

click Clear on the shortcut menu that appears when you right-click in the 

graphics window. 
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• To easily locate references in the Chain dialog box, place your pointer over the 

reference in a collector. Pro/ENGINEER dynamically highlights the reference on 

the model. 

• To remove the Start point handle, right-click the handle and click Remove on the 

shortcut menu. The End point handle appears. Similarly, to remove the End point 

handle, right-click the handle and click Remove on the shortcut menu. The Start 

point handle appears. 

Example: Intent Chains 

1. The following figure shows an intent chain. All edges of an intent chain can be 

selected in a single click. 

 

1 Intent chain 

2. In the following figure the edges of the protrusion are rounded using the intent 

chain. 

 

3. In the following figure the geometry has changed, but the intent, that is, a round 

about the bottom, has not changed. The intent chain and the round are updated 

automatically. 
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Example: Tangent Chain 

In the following example, an edge tangent to the anchor is selected resulting in a 

tangent chain. 

 

Surface Sets 

About Surface Sets 

Surface sets consist of multiple surfaces that you select and place into a group. This 

group or surface set enables you to efficiently perform modeling actions on the 

selected surfaces at one time. You can select surfaces and use surface sets at any 

time (within a tool, or before entering a tool) during your modeling session. 

Remember that when you want to construct a surface set, you must first select a 

reference and then press (and hold) the SHIFT key to activate the surface set 

construction mode. 

Note: When working with an assembly inside a tool, you can select surface sets from 

the same model only.  

To modify surface sets, you use the Surface Sets dialog box. This dialog box 

contains a list of surface sets that you constructed using the active part, the number 

of surfaces in each surface set, attributes for each surface set, and excluded 



Pro/ENGINEER Fundamentals – Help Topic Collection 

62 

surfaces. Pro/ENGINEER provides ToolTips, messages, and labels that act as a visual 

aid guiding you through the surface set construction process. 

When using a dashboard tool or a tool that uses the Menu Manager, you can 

dynamically preview the surface set geometry after every action. To disable dynamic 

preview, clear the Dynamic preview checkbox in the Surface Sets dialog box.  

Note: When using a dashboard tool, the state of the checkbox in  controls the 

initial setting of the Dynamic preview checkbox in the Surface Sets dialog box. 

For example, if you change  to  before opening the Surface Sets dialog 

box, then the Dynamic preview checkbox appears as not selected when you 

subsequently open the Surface Sets dialog box. 

Surface Set Types 

You can construct the following types of surface sets: 

Non rule-based 

• Individual Surface Set—Contains individual solid surfaces or quilts that you 

select. You can also use a Individual surface set if you want to model additional 

surfaces along with other surface sets that you constructed. Note that if you want 

to exclude surfaces from a Individual surface set, you must remove the surface 

from the set. You cannot add them to the Excluded surface set. 

• Intent Surface Set—Contains intent surfaces. You can add intent surfaces to 

the Excluded surface set or use the intent surfaces as bounding surfaces in Seed 

and Boundary Surface set. 

• Excluded Surface Set—Contains all surfaces that you excluded from one or 

more surface sets. You construct the excluded surface set when you do not want 

to perform a modeling action on one or more individual surfaces that belong to a 

surface set. Note that you cannot add unwanted surfaces from a Individual 

surface set to an Excluded surface set.  

Rule-based 

• All Solid Surface Set—Contains all solid surfaces of the active part. 

• Quilt Surface Set—Contains quilt surfaces that you selected from the active 

part. 

• Loop Surface Set—Contains two-sided edges that form a loop around a surface. 

• Seed and Boundary Surface Set—Contains all surfaces between and including 

the selected seed and boundary surfaces. 

Note: Most tools require that all selected surfaces must belong to the same solid 

part geometry or quilt. 

To Construct an Individual Surface Set 

An Individual surface set is simply a selection set containing of one or more solid or 

quilt surfaces. 
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1. Select a surface on your model. Pro/ENGINEER highlights the selected surface. 

Notice that if you are working outside of a tool, the Selected Items area indicates 

the selection and the Selected Items dialog box contains the surface references. 

However, if you construct a Individual surface set from inside a tool, the active 

collector contains the surface set and the Individual Surfaces label displays on 

the model. 

2. If you want to add additional surfaces to the selection set, press CTRL and select 

them. Note that most tools require that all selected surfaces for the surface set 

belong to the same solid part geometry or quilt. 

3. Open a feature tool or continue working in a feature tool to use the surface set to 

create a feature. 

To Construct an All Solid Surface Set 

1. Select a solid surface on your model. Pro/ENGINEER highlights the selected 

surface. 

2. Right-click and select Solid Surfaces on the shortcut menu. Pro/ENGINEER 

constructs the surface set and adds all solid surfaces to the set. Note that if you 

are working outside of a tool, the Selected Items area indicates the selection and 

the Selected Items dialog box contains All Solid Surfaces. However, if you 

construct a surface set from inside a tool, the active collector contains the surface 

set and the All Solid Surfaces label is displayed on the model. 

3. Open a feature tool or continue working in a feature tool to use the surface set to 

create a feature. 

Note: 

• When working in a tool, if the surface sets collector or if surface sets and the 

Anchor collector are empty, then the Part filter is available. You can use the Part 

filter to select a part from the Model Tree or graphics area. You can also use the 

Part filter to select the components from the Layer Tree, irrespective of the layer 

status. 

• When working in a tool, if the surface sets and the Anchor collector are empty, 

then the Part filter is available. To construct an All Solid surface set select the 

Part filter and then select a part with solid surfaces from the graphics area or the 

Model Tree. When you select a part, by default, the Anchor collector displays the 

first solid surface in the part and continues to remain active, the All solid 

surfaces option is selected, and the Part filter becomes unavailable.  

Holding down the CTRL key and selecting the anchor surface clears the selection 

of the All Solid surface set. 

• When working in a tool, if the surface sets collector is empty, then the Part filter 

is available. To construct an All Solid surface set select the Part filter and then 

select a part that has solid surfaces from the graphics area or the Model Tree. 
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To Construct a Quilt Surface Set 

Note:  

• The active part must contain one or more quilt to construct a Quilt surface set. 

• If you constructing a Quilt surface set while working in a tool, activate the 

surfaces collector and follow step 2. through step 4.  

1. Select a feature from the model. Pro/ENGINEER highlights the feature. 

2. Query each feature and locate a quilt. Notice that you can also use the Quilts 

filter to easily locate quilts. 

3. Select a quilt. Pro/ENGINEER adds the selected quilt surface to the selection set. 

If you are working outside of a tool, the Selected Items area indicates the 

selection and the Selected Items dialog box contains the quilt reference. If you 

are working from inside a tool, the active collector contains the Quilt surface set 

and the Quilt Surfaces label appears on the model. 

4. If you want to add additional quilts to the selection set, press CTRL and repeat 

step 1. through step 3. Note that most tools require that the selected surfaces 

belong to the same solid part geometry or quilt. 

5. Open a feature tool. Pro/ENGINEER constructs the Quilt surface set, and the 

surfaces collector contains the Quilt surface set. The Quilt Surfaces label 

appears on the model. 

Tip: You can place your pointer over an item and right-click, or use Next and 

Previous from the shortcut menu to query each feature. You can also use the Pick 

From List to select features. 

To Construct a Loop Surface Set 

1. Select a surface on your model to establish the anchor. Pro/ENGINEER highlights 

the selected surface. Note that most tools require that the surface belongs to the 

same solid part geometry or quilt. 

2. Press SHIFT and move your pointer over the boundary of the selected surface. 

Valid surfaces highlight and a ToolTip displays each surface name. 

3. Select a two-sided edge that belongs to the anchor surface to complete the Loop 

Surface boundary. Pro/ENGINEER constructs and highlights the Loop surface set. 

Notice that if you are working outside of a tool, the Selected Items area indicates 

the selection and the Selected Items dialog box contains the Loop Surfaces. 

However, if you construct a surface set from inside a tool, the active collector 

contains the surface set and the Loop Surfaces label displays on the model. 

4. If you want to construct an additional Loop surface set during the same workflow, 

release SHIFT. Then, press CTRL and click a surface on your model to establish 

an anchor for the new surface set. Release CTRL and repeat step 2 through step 

4. 

5. Open a feature tool or continue working in a feature tool to use the surface set to 

create a feature. 
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Tip:  

• You can use Next, Previous, or Pick from List from the shortcut menu to 

select edges. 

• To open the Selected Items dialog box, simply double-click the Status area next 

to the Filter box.  

To Modify a Loop Surface Set 

You must be inside a tool to modify Loop Surface sets. 

1. In the graphics window, place your pointer over a Loop Surfaces label and right-

click. 

2. Click Activate Set from the shortcut menu .  

3. Press SHIFT and move your pointer over the boundary of the selected surface. 

Valid edges and surfaces highlight. A ToolTip displays the names of valid edges. 

4. Select the required edge to change the loop surface and complete the Loop 

Surface set. Pro/ENGINEER highlights the Loop Surface set. 

Note: A Loop Surface set closes if a new set is added, the tool is closed, or if you 

activate another collector inside of a tool. 

Tip:  

• To remove a Loop Surface set, right-click on the label and click Remove Set. 

• You cannot modify the anchor surface of a Loop surface set. 

• You can use Next, Previous, or Pick from List from the shortcut menu to 

select edges. 

• Inside a tool the selected items are not available for surface collection. 

To Construct an Intent Surface Set 

An Intent surface set is simply a selection set containing one or more intent surfaces. 

Note: If you constructing an Intent surface set while working in a tool, activate the 

surfaces collector and follow step 2. through step 4. 

1. Select a feature from the model. Pro/ENGINEER highlights the feature. 

2. Query each feature and locate an intent surface. 

3. Select an intent surface. Pro/ENGINEER adds the selected intent surface to the 

selection set. If you are working outside of a tool, the Selected Items area 

indicates the selection and the Selected Items dialog box contains the intent 

surface reference. If you are working from inside of a tool, the active collector 

contains the Intent surface set and the Intent Surfaces label appears on the 

model. 
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4. If you want to add additional intent surfaces to the selection set, press CTRL and 

repeat step 1. through step 3. Note that most tools require that the selected 

surfaces belong to the same solid part geometry or quilt. 

5. Open a feature tool. Pro/ENGINEER constructs the Intent surface set, and the 

surfaces collector contains the Intent surface set. The Intent Surfaces label 

appears on the model. 

Tip:  

• If you are working in a tool, you can also use the Intent Surface filter to easily 

locate intent surfaces. 

• You can place your pointer over an item and right-click, or use Next and 

Previous from the shortcut menu to query each feature. You can also use the 

Pick From List to select features. 

To Construct a Seed and Boundary Surface Set 

1. Select a surface on your model to establish the surface anchor (seed) surface. 

Pro/ENGINEER highlights the selected surface. 

2. Hold down the SHIFT key and move your pointer over the model. Valid surfaces 

highlight and a ToolTip displays the surface name. 

3. Select a surface that belongs to the same solid part geometry or quilt as the 

anchor surface. This establishes the boundary surface. Pro/ENGINEER constructs 

and highlights the Seed and Boundary surface set. Notice that if you are working 

outside of a tool, the Selected Items area indicates the selection and the 

Selected Items dialog box contains Seed and Boundary Surfaces. However, if 

you construct a surface set from inside a tool, the active collector contains the 

surface set and the Seed and Boundary Surfaces label displays on the model. 

Note: You can also use a Loop surface set as a boundary for constructing a Seed 

and Boundary surface set. To construct a Loop surface set and use it as a 

boundary for constructing the Seed and Boundary surface set, hold down the 

SHIFT key and select a two-sided edge that belongs to the selected boundary 

surface to complete the Loop surface boundary. 

4. Release SHIFT. The Seed and Boundary surface set highlights. This set includes 

the seed surface and all the surfaces between the seed surface and the boundary 

surfaces but not the boundary surfaces. Notice that boundary surface is not 

highlighted. 

5. If you want to include additional boundary surfaces to the set during the same 

workflow, repeat step 2 through step 4. Note that most tools require that the 

surfaces belong to the same solid part geometry or quilt. 

6. If you want to construct an additional Loop surface set during the same workflow, 

release SHIFT. Then, press CTRL and click a surface on your model to establish 

an anchor for the new surface set. Release CTRL and repeat step 2. through step 

4. 
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7. Open a feature tool or continue working in a feature tool to use the surface set to 

create a feature. 

Tip: 

• You can use Next, Previous, or Pick from List from the shortcut menu to 

select edges. 

• To open the Selected Items dialog box, simply double-click the Status area next 

to the Filter box. 

• In Seed and Boundary surface sets you can use Intent surfaces as bounding 

surfaces. 

Example: Constructing a Seed and Boundary Surface Set 

This example shows how to construct a Seed and Boundary surface set using a Loop 

surface set as a boundary. 

Select a seed surface on the model to establish the surface anchor (seed) surface. 

Pro/ENGINEER highlights the selected surface as shown below. 

 

Hold down the SHIFT key and move the pointer over the model. Valid surfaces are 

highlighted and a ToolTip displays the surface name. Select a boundary surface as 

shown below. 
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Hold down the SHIFT key and move the pointer over the desired Loop edge of the 

selected boundary. The Loop surface is highlighted as shown below. 

 

Select the Loop edge that belongs to the selected boundary surface to complete the 

Loop surface boundary. The Loop surface set is highlighted as shown below. 
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Release the SHIFT key. The Seed and Boundary surface set is created as shown 

below. 

 

To Modify a Seed and Boundary Surface Set 

You must be inside a tool to modify Seed and Boundary Surface sets. 
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1. In the graphics window, place your pointer over the Seed and Boundary 
Surfaces label and right-click. 

2. Click Activate Set from the shortcut menu. 

3. Press SHIFT and select the required boundary surface or surfaces to add or 

remove them from the Seed and Boundary Surface set. Pro/ENGINEER highlights 

the seed and boundary surfaces along with the valid surfaces. A ToolTip displays 

the names of valid surfaces. 

Note: 

• You cannot modify the anchor surface of a Seed and Boundary surface set. 

• A Seed and Boundary surface set closes if a new set is added, the tool is closed, 

or if you activate another collector inside of a tool. 

Tip:  

• To remove a boundary surface from the set, right-click on the label and click 

Remove Set. 

• You can use Next, Previous, or Pick from List from the shortcut menu to 

select edges. 

• Inside a tool the selected items are not available for surface collection. 

To Exclude Surfaces from Surface Sets 

You can use this procedure to exclude surfaces either before opening a tool or while 

you are working in a tool. 

1. Construct one or more surface sets using the active part. Pro/ENGINEER 

highlights the surfaces. 

2. Press CTRL and select one or more highlighted surfaces that you want to exclude 

from perform a modeling action. Pro/ENGINEER constructs the Excluded surface 

set and adds the excluded surfaces to it. Notice that the Selected Items area 

indicates the selection and the Selected Items dialog box contains Excluded 
Surfaces. 

3. Open a feature tool if one is not already open, and use the surface sets to create 

a feature. Notice that in a tool, the active collector contains the Excluded surface 

set and the Excluded Surfaces label appears on the model. 

Tip: You can use Next, Previous, or Pick from List from the shortcut menu to 

select edges. 

To Modify Rule-based Surface Sets 

Note: This topic discusses surface set modification while working inside of a tool and 

using the Surface Sets dialog box. If you want to modify a surface set while 

working outside of a tool, you can use the CTRL key to include individual surfaces in 

the set. You can also clear the entire surface set from the selection set. Refer to 

About Selection under See Also for more information about clearing a selection. 
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1. If you are working in a tool that uses the Menu Manager and not the dashboard, 

construct the surface set and open a tool. Place your pointer over a surface set 

label in the graphics window, right-click, and select Surface Sets on the shortcut 

menu. The Surface Sets dialog box opens. Skip to step 5. 

2. If you are working in a dashboard tool, construct a surface set and open a tool in 

which to work with the surface set, or select a feature that contains an existing 

surface set that you want to modify, right-click, and select Edit Definition on 

the shortcut menu. 

3. Locate the Detail collector that contains the surface set that you want to modify. 

Detail collectors are located on the slide-up panel. Note that you cannot use the 

Summary collector (located on the dialog bar) to modify a surface set. 

4. Click Details. Pro/ENGINEER pauses the tool and opens the Surface Sets dialog 

box. This dialog box contains a list of surface sets that were constructed using 

the active part, and their attributes. Notice that the surface set list contains set 

type and the number of surfaces contained in each set. 

5. Do one of the following from the Surface Sets list:  

o Click Neighbor Surfaces to modify a Loop surface set. The Anchor and 

Loop Edge collectors appear. 

o Click Bounded Set to modify a Seed and Boundary surface set. The 

Anchor and Bounding Surfaces collectors appear if individual surfaces 

determine the boundary. The Anchor, Boundary loop anchor, and 

Boundary loop edge collectors appear if Loop surfaces determine the 

boundary. 

o Click All Solid Surfaces to modify a Solid surface set. The Anchor 

collector appears. 

o Click Quilt Surfaces to modify a Quilt surface set. The Anchor collector 

appears. 

6. After you select a surface set from the list, the following options appear based on 

the surface set that you selected: 

o Anchor collector—Contains the anchor reference for the selected surface 

set. The anchor reference consists of a solid surface or quilt that belongs to 

the same solid part geometry or quilt. 

To modify the anchor reference, click the reference to activate the collector 

and select a different anchor from the model. Notice that you can also use 

the Anchor shortcut menu command from inside the graphics window to 

activate this collector. 

Note: You can only replace the anchor reference, you cannot remove it. 

o Rule—Displays the following rule-based surface set types enabling you to 

modify the selected surface set: 
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Loop surfaces—Constructs a Loop surface set by using all edges that form 

a loop around an anchor surface. Note that the anchor reference cannot be 

a quilt or an intent surface if you want to use this option. 

Seed and boundary surfaces—Constructs a Seed and Boundary surface 

set by using all surfaces between the seed surface and the bounding 

surfaces, including the seed surface and excluding the bounding surfaces. 

Displays the Boundary options and the Include bounding surfaces 

check box. Note that to use Seed and boundary surfaces option, the 

anchor reference cannot be a quilt or an intent surface.  

All solid surfaces—Constructs an All Solid surface set by using all solid 

surfaces in the active part. The Reference collector appears and contains 

the surface reference. 

o Boundary—Displays the type of boundary used to construct the Seed and 

Boundary Surface set. 

Individual Surfaces—Constructs a Seed and Boundary Surface set with 

individual surfaces as the bounding surfaces. Activates the Bounding 

Surfaces collector.  

Loop Surfaces—Constructs a Seed and boundary Surface set with a Loop 

surface set as the bounding surface.  Activates the Boundary loop anchor 

collector. 

o Loop Edge collector—Contains an edge that forms a loop around a 

surface. This edge reference determines the neighboring surfaces for a Loop 

surface set. A loop edge reference consists of a two-sided edge that belongs 

to the anchor reference surface. 

To modify a loop edge reference, click a loop edge reference to activate the 

collector and select a different edge from the model. This new reference 

replaces the existing loop edge reference. Notice that you can also use the 

Loop Edge shortcut menu command from inside the graphics window to 

activate this collector. 

Note: You must select the Neighboring surfaces only rule-based surface 

set type to use this collector. 

o Bounding Surfaces collector—Contains one or more bounding surface 

references that determine the boundary for the Seed and Boundary surface 

set. A bounding surface reference consists of a solid surface or quilt that 

belongs to the same solid part geometry or quilt. You can use intent 

surfaces as bounding surfaces. 

To modify a bounding surface reference, click the reference to activate the 

collector and either select a different surface from the model, hold down the 

CTRL key and select additional references, or remove a reference. Notice 

that you can also use the Bounding Surfaces shortcut menu command 

within the graphics window to activate this collector. 

Note: 

Surfaces removed from the Individual surface set are not considered 
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excluded surfaces. 

You must select the Seed and boundary surfaces rule-based surface set 

type to use this collector. 

o Boundary loop anchor collector—Contains a surface reference that is an 

anchor for the Loop surface set. The Loop surface set determines the 

boundary for the Seed and Boundary surface set. The anchor surface 

reference consists of a solid surface or quilt that belongs to the same solid 

part geometry or quilt and acts as the anchor surface for the Loop surface 

set. 

To modify an anchor surface reference, click inside the collector to activate 

it and either select a different surface reference from the model or remove 

the surface reference. You can remove the surface reference by clicking 

Clear on the shortcut menu in the graphics window or by clicking Remove 

on the shortcut menu that appears when you right-click in the collector. 

You can also use the Boundary loop anchor command on the shortcut 

menu within the graphics window to activate this collector. 

o Boundary loop edge collector—Contains an edge reference for the Loop 

surface set. The Loop surface set acts as a boundary for the Seed and 

Boundary surface set. This edge reference determines the neighboring 

surfaces for a Loop surface set. A loop edge reference consists of a two-

sided edge that belongs to the anchor reference surface. 

To modify the edge reference, click inside the collector to activate it and 

either select a different edge reference from the model or remove the edge 

reference. You can remove the edge reference by clicking Clear on the 

shortcut menu in the graphics window or by clicking Remove on the 

shortcut menu that appears when you right-click in the collector. You can 

also use the Boundary loop edge command on the shortcut menu within 

the graphics window to activate this collector. 

o Reference collector—Contains the surface references for the Solid surface 

set. Note that this reference is only displayed and can only be modified by 

changing the anchor reference. 

o Include bounding surfaces check box—Includes the bounding surfaces 

in a Seed and Boundary surface set. 

7. Click OK. Pro/ENGINEER saves the changes, closes the Surface Sets dialog box, 

and resumes the tool. 

Tip: 

• You can always construct a new rule-based surface set by clicking Add and 

selecting the surface references from the model. 

• To remove a surface set from the Surface Set list, select the surface set and click 

Remove. Note that Individual Surfaces and Excluded Surfaces cannot be 

removed. 
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• You can also remove a surface set from the graphics window by placing your 

pointer over the surface set label, right-click, and use Remove Set from the 

shortcut menu. 

• To clear references in the active collector, click Remove or Remove All on the 

shortcut menu that appears when you right-click in the collector. Alternatively, 

click Clear on the shortcut menu that appears when you right-click in the 

graphics window. 

• Remember that you can hold down the CTRL key and select a reference to either 

add an additional reference or to clear a selected reference. 

• To easily locate a references in the Surface Sets dialog box, place your pointer 

over the reference in a collector. Pro/ENGINEER dynamically highlights the 

reference on the model. 

• Notice that as you modify a surface set in the Surface Sets dialog box, 

Pro/ENGINEER dynamically displays the changes in the graphics window. 

• When the Surface Sets dialog box is open, you can perform Undo or Redo 

operations if the tool or feature supports Undo or Redo operations. 

To Modify Non Rule-based Surface Sets 

Note: This topic discusses surface set modification while working inside of a tool and 

using the Surface Sets dialog box. If you want to modify a surface set while 

working outside of a tool, you can use the CTRL key to include individual surfaces in 

the set. You can also clear the entire surface set from the selection set. Refer to 

About Selection under See Also for more information about clearing a selection. 

1. If you are working in a tool that uses the Menu Manager and not the dashboard, 

construct the surface set and open a tool. Place your pointer over a surface set 

label in the graphics window, right-click, and select Surface Sets from the 

shortcut menu. The Surface Sets dialog box opens. Skip to step 5. 

2. If you are working in a dashboard tool, construct a surface set and open a tool in 

which to work with the surface set, or select a feature that contains an existing 

surface set that you want to modify, right-click, and select Edit Definition from 

the shortcut menu. 

3. Locate the Detail collector that contains the surface set that you want to modify. 

Detail collectors are located on the slide-up panel. Note that you cannot use the 

Summary collector (located on the dialog bar) to modify a surface set. 

4. Click Details. Pro/ENGINEER pauses the tool and opens the Surface Set dialog 

box. This dialog box contains a list of surface sets that were constructed using 

the active part, and their attributes. Notice that the surface set list contains set 

type and the number of surfaces contained in each set. 

5. Do one of the following from the Surface Sets list:  

o Click Individual Surfaces to modify the Individual surface set. The 

Included Surfaces collector appears. 
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o Click Intent Surfaces to modify an Intent surface set. The Anchor 

collector appears. 

o Click Excluded Surfaces to modify the Excluded surface set. The 

Excluded Surfaces collector appears.  

6. After you select a surface set from the list, the following options appear based on 

the surface set that you selected: 

o Included Surfaces collector—Contains one or more surface references 

that you selected. Individual surfaces references consists of a solid surface 

or quilt that belongs to the same solid part geometry or quilt.  

To modify a reference, click the reference to activate the collector and then 

either select a different surface from the model, press CTRL and select 

additional references, or remove a reference. Notice that you can also use 

the Included Surfaces shortcut menu command from inside the graphics 

window to activate the Included Surfaces collector. 

Note: Surfaces removed from the Individual surface set are not added to 

the Excluded surface set. These surfaces are removed only from their 

respective surface set. 

o Anchor collector—Contains the anchor reference for the selected surface 

set. The anchor reference consists of a solid surface or quilt that belongs to 

the same solid part geometry or quilt.  

To modify the anchor reference, click the reference to activate the collector 

and select a different anchor from the model. Notice that you can also use 

the Anchor shortcut menu command from inside the graphics window to 

activate this collector. 

Note: You can only replace the anchor reference, you cannot remove it. 

o Excluded Surfaces collector—Contains one or more excluded surfaces that 

you selected.  

To modify a reference, click the reference to activate the collector and then 

either select a different reference from the model, press CTRL and select 

additional references, or remove a reference. Notice that you can also use 

the Excluded Surfaces shortcut menu command from inside the graphics 

window to activate the Excluded Surfaces collector. 

Note: 

Surfaces removed from the Excluded Surfaces collector return to their 

respective surface set. 

Surfaces removed from the Individual surface set are not add to the 

Excluded surface set. These surfaces are removed only from their 

respective surface set. 

7. Click OK. Pro/ENGINEER saves the changes, closes the Surface Sets dialog box, 

and resumes the tool 

Tip: 

• You can always construct a new rule-based surface set by clicking Add and 

selecting the surface references from the model. 
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• To remove a surface set from the Surface Set list, select the surface set and click 

Remove. Note that Individual Surfaces and Excluded Surfaces cannot be 

removed. 

• You can also remove a surface set from the graphics window by placing your 

pointer over the surface set label, right-click, and use Remove Set from the 

shortcut menu. 

• To clear references in the active collector click Remove or Remove All on the 

shortcut menu that appears when you right-click in the collector. Alternatively, 

click Clear on the shortcut menu that appears when you right-click in the 

graphics window. 

• Remember that you can press CTRL and select a reference to either add an 

additional reference or to clear a selected reference. 

• To easily locate a reference in the Surface Sets dialog box, place your cursor 

over the reference in a collector. Pro/ENGINEER dynamically highlights the 

reference on the model. 

• Notice that as you modify a surface set in the Surface Sets dialog box, 

Pro/ENGINEER dynamically displays the changes in the graphics window. 

Drag and Drop 

About Drag and Drop 

Pro/ENGINEER lets you move files from browsers, other Pro/ENGINEER sessions and 

from Windchill Solutions to the Pro/ENGINEER graphics window and the Model Tree. 

When a file is dragged to an acceptable target, the pointer changes indicating the 

object can be placed there.  

Links can also be dragged from browsers and Pro/ENGINEER navigators, and 

dropped in the embedded Web browser. 

Graphics Window 

Pro/ENGINEER files can be dropped in the graphics window from the embedded Web 

browser, a standalone browser or a file manager. Note that the Internet Explorer 

browser must be version 5.5 and later. The Netscape Navigator browser must be 

version 6.0 and later. 

When you activate the Folder Navigator, you can drag a Pro/ENGINEER component 

from the embedded Web browser and drop it in the graphics window. The component 

opens in a separate window unless you drop it on an active assembly. 

By default, when you drop a component on an assembly, Pro/ENGINEER attempts to 

automatically place it. If the component cannot be assembled automatically, the 

Component Placement dialog box opens to allow you to select references and 

constrain the part in the assembly. If you want to choose whether to assemble the 

component or open it in a new window, set the configuration option 

autoplace_single_component to no. When set to no, the Confirm Retrieval dialog 

box opens displaying the choice to open the component in a separate window or to 
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add it to the assembly. Refer to the help in Assembly for more information on placing 

components in assemblies. 

You can drag a .zip file to the graphics window. The File Open dialog box opens 

and displays the files contained in the .zip . Click a Pro/ENGINEER file in the File 

Open dialog box to open it. 

Model Tree 

You can drag and drop components onto the Model Tree. If you have an assembly 

open, the dropped component is unplaced. To place the component, click Edit 

Definition from the Model Tree shortcut menu 

Search Navigator 

If you are connected to a Windchill server, files are listed in the embedded Web 

browser. You can drag a file from the Number window in the Search navigator to the 

graphics window. The details page for that object open in the embedded Web 

browser. You can then drag a part or assembly from the browser to the graphics 

window. 

Tool Pausing 

About Tool Pausing 

When creating features, you may need to work in a tool that does not use the 

dashboard. Use  on the dashboard to suspend your current workflow and open 

another tool. When the current tool is paused, it becomes inactive,and you are 

temporarily returned to the default system state, in which you can select objects that 

satisfy other tool requirements. You can pause a tool explicitly or automatically. 

To resume a paused tool, click . 

To Pause a Tool 

You can pause a tool either explicitly or automatically.  

To Pause Explicitly 

1. Click . The dashboard is now unavailable.  

2. Open and use the tool for which you paused the original tool. 

3. Click  to return to the tool.  

To Pause Automatically 

1. Select an asynchronous tool from the toolbar. The current tool is now 

unavailable, and the Datum creation tool interface automatically opens.  
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2. Click  when you complete or cancel the Datum tool to resume the paused 

tool.  

Working with Handles 

About Handles 

Handles are graphical objects that you use to manipulate data in the graphics 

window. You can snap handles to existing geometric references or to user-defined 

grid increments. Changes to the geometry are displayed dynamically in the graphics 

window.  

You can move a drag handle along a 2D or 3D trajectory.  

Duplicating a Handle 

In the Round, Draft, Extend, Offset Curve, and Datum Point feature-creation and 

Datum Point Offset Csys tools, you can widen your ability to manipulate geometry by 

duplicating a handle. By duplicating the handle, you change the feature type from 

constant to variable or another radius or point is added. 

You can change the handle behavior by moving the dragger and pressing SHIFT or 

CTRL. 

• SHIFT—Activates the Snap mechanism, if available. 

• CTRL—Activates the Duplicate mechanism, if available. 

To Duplicate a Handle 

You can duplicate a handle when creating a Round, Draft, Extend, Offset curve, or 

Datum Point feature. 

1. When creating the feature, right-click a handle to access the shortcut menu. 

2. Click Add Radius (Round), Add Angle (Draft), Add (Extend and Offset curve), 

or Duplicate (Datum Point). The handle is duplicated. You can then drag the 

handle to place it. 

Snapping a Handle 

You can snap a handle to reference geometry, such as a datum plane, an edge, a 

point or vertex, or a surface. 

To Snap a Handle 

1. As you drag the drag handle toward the reference geometry to which you want to 

snap the handle, the drag handle appears as a black square, as shown in the 

next figure: 
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1 Drag handle 

2 Reference datum plane 

2. While dragging the drag handle, press and hold SHIFT. The drag handle 

appears as a black square containing a white circle, as shown in the next figure: 

 

3. Move the pointer over the reference geometry. The reference geometry is 

highlighted. 

4. Release the mouse button and SHIFT. The reference geometry is selected. The 

handle is snapped and appears as a white square containing a black circle, as 

shown in the next figure: 
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To Unsnap a Handle 

1. Press SHIFT and move the pointer over the snapped handle. The reference 

geometry is highlighted and the drag handle appears as a black square 

containing a white circle, as shown in the following figure: 

 

2. Drag the drag handle off of the reference geometry. 

3. Release the mouse button and SHIFT. The handle is now unsnapped from 

reference geometry. 
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Using Verify Mode 

About Verify Mode 

Using Verify mode, you can determine whether a feature that you have defined can 

be created in Pro/ENGINEER. When you enter Verify mode, Pro/ENGINEER 

regenerates the feature in the graphics window according to the dimensions, 

references, and settings that you have defined. While you are in Verify mode, you 

cannot edit the feature or cancel feature creation.  

If Pro/ENGINEER cannot regenerate the defined feature according to the current 

dimensions, references, and settings, you can exit Verify mode and change the 

feature definition or enter Fix Model mode to adjust other aspects of the model. 

If Pro/ENGINEER can regenerate the defined feature, the resulting model, including 

the feature being created, is displayed. Exit Verify mode and either accept the 

feature or continue defining it. 

While in Verify mode, you can activate the following commands from the Analysis 

menu: 

• Measure 

• Model Analysis 

To Use the Verify Mode 

1. Click  to enter Verify mode. The regenerated feature appears in the 

graphics window. 

2. To exit Verify mode, click one of the following items: 

o Click  to toggle off Verify mode. 

o Click  or Exit Verify from the shortcut menu to resume the previous 

tool. 

o Middle-click or click  to accept the feature 

Pro/ENGINEER Menus 

The File Menu 

Working with Pro/ENGINEER Files 

About Pro/ENGINEER Files 

The following requirements apply when creating and performing operations on 

Pro/ENGINEER files: 
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• File names have a 31 character limit. You cannot create or retrieve an object with 

more than a 31 character file name. 

• You cannot use brackets, such as [ ], { }, or ( ), spaces and punctuation marks 

(.?!;) in file names.  

• File names can contain hyphens and underscores, however, the first character in 

a file name cannot be a hyphen. 

• Use only alphanumeric characters (see hyphen and underscore exception in 

previous bullet) in file names. Object files containing non-alphanumeric 

characters (such as @, #, and %) in their names do not display in, and are not 

retrievable from dialog boxes. You cannot save new object files with 

nonalphanumeric characters in their names. 

• Use only lowercase characters for file names. An object or file on disk always 

saves with the name in lowercase. 

• Directory paths can use special characters, such as tilde ( ~ ) and two periods ( .. 

) to specify relative paths. It is better, however, to always show the absolute 

path names (from the root) to avoid problems if you change working directories 

or use the same configuration file in another startup directory. 

• A directory path can contain up to 260 characters. 

File Format 

Saving an object to disk creates a file with the following format: 

object_name.object_type.version_number 

For example, if you create and then save the part bracket, the filename for the part 

is bracket.prt.1. 

About File Types 

The majority of Pro/ENGINEER files are object files that store information about an 

object. Other files created in Pro/ENGINEER are object-dependent, temporary files 

that contain information that may have been output by you, or created as a quick 

way to retrieve data without regenerating the object, such as the .ptd file for Family 

Tables. 

You can remove temporary files from the system (identified with an asterisk in the 

following table), but you must never delete object files. 

In the following table of file-naming conventions, words like sectionname, partname, 

and filename indicate the name you enter at the prompt for sections, parts and data 

files, or the active object used to create the file (for example, partname.inf). 

File Name Description 

Asm####.asm Default assembly name. 

Assemblyname.asm Assembly with name entered by you. 
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File Name Description 

Assemblyname.als Assembly, Program design file. 

Assemblyname.bom* Bill of Materials file. 

Assemblyname.inf* File created when you choose Info > 

Assembly. 

Assemblyname.ref* File created when you are saving an 

assembly by using File > Save a Copy. 

It lists the components that you selected 

for renaming. 

Assemblyname.ptd* Family Table file for assembly. 

Assemblyname.tst* Records results of Verify operation on 

instances of assemblyname. 

Assemblyinstancename.xas Instance accelerator file for assembly 

instance. 

Assemblyname_a.wrl VRML export file for an assembly. 

Color.map Color palette of user-defined colors. 

Componentname.memb* File created when you choose Info > 

Component. 

Config.pro Configuration options file. 

Curv#.dat* Data file containing curvature 

information for curve, where # is curve 

internal ID. 

Dgm####.dgm 2D schematic diagram with default 

name. 

Diagramname.dgm 2D schematic diagram created with 

name entered by you. 

Datafile.ers* Summary of drawing setup file errors 

generated upon reading a setup file with 

errors. 

Dimdiff.info* Tabulation of dimension and feature 

differences between two parts, or two 

versions of the same part. Created when 

you choose Analysis > Part 

Comparison. 

Directoryname.idx Instance index file for directory 
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File Name Description 

directoryname. 

Drw####.drw Drawing with default drawing name. 

Drawingname.drw Drawing with name entered by you. 

Feature.lst* File created when you choose Info > 

Feature List. 

Feature.inf* File created when you choose Info > 

Feature. 

Filename_amp.dat* Assigned mass properties file. 

Filename.cbl Cable parameters file. 

Filename.con Connector parameters file. 

Filename.dat* Data files created for editing, such as 

relations data. 

Filename.dtl Setup file used by drawings, formats, 

and layouts. 

Filename.gph User-defined feature with name entered 

by you. 

Filename.ibl File containing data for creating a blend 

feature. 

Filename.inf* Information files created using the Info 

menu. 

Filename.lgh File containing lights data. 

Filename.ncl* File containing manufacturing CL data. 

Filename.pts File containing spline points coordinate 

data with name entered by you. 

Filename.scl File containing definitions for system 

colors. 

Filename.shd* Shaded view file. 

Filename.sym Symbol file storing geometry of drawing 

symbol. 

Filename.tph* File containing manufacturing toolpath 

information for model filename. 
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File Name Description 

Formatname.frm Format used by drawings and layouts. 

Iges_stats.dat* A summary of processing an IGES file. 

Lay####.lay Layout with default layout name. 

Layoutname.lay Layout with name entered by you. 

Machinename.mac File containing data for a manufacturing 

machine. 

Manufacturename.mfg Manufacturing object with name entered 

by you. 

Markupname.mrk Drawing markup file. Created in Markup 

mode. 

Menu_def.pro Default menu options file. 

Modelname.wrl File created when you export a model to 

the VRML format. 

Param.inf* File created when you choose Info > 

Relations and Parameters. 

Partinstancename.xpr Instant accelerator file for part instance. 

Partname.bde File that lists the elements that exceed 

the aspect ratio bound of a meshed 

object. 

Partname.bdi File that lists the elements that have a 

Jacobian distortion index lower than 

preset bound for a meshed object. 

Partname.bdm File that lists the elements that have mid 

ratios higher than a preset bound for a 

meshed part. 

Partname.ger* Geometry misalignment data. 

Partname.pls Part, Program design file. 

Partname.prt Part with name entered by you. 

Partname.m_p* Part mass properties file. 

Partname.ptd* Family Table file for part. 

Partname.tst* Records results of Verify operation on 

instances of partname. 
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File Name Description 

Partname_p.wrl VRML export file for part. 

Partname_pr#.wrl VRML resolution file for part. 

prt####.prt Part with default part name. 

Rels.inf* Relations info file created when you 

choose Info > Relations and 

Parameters. 

Reviewref.info* File created when reviewing feature 

references during a regeneration failure. 

s2d####.sec Sketch with default sketch name. 

Sectionname.sec Sketch with name entered by you. 

Spline.pts Default name for file containing spline 

points coordinate data. 

Toolname.tpm File containing data for a manufacturing 

tool. 

Training_file.txa Training file. 

Trail.txt* Default name for trail file. 

Xsectionname.m_p* Cross-section mass properties file. 

Creating Files 

About Creating New Files 

You create models by building features. To create features, you must first begin a 

new part. You can create a new sketch, part, assembly, manufacturing model, 

drawing, format, report, diagram, layout, markup, or interchange file in 

Pro/ENGINEER using the New and New File Options dialog boxes. 

When creating a new object, a template is automatically supplied for any object type 

supported by a template. You can accept the default template, select another, or 

browse to a file you want to use as a template.  

To Create a New File 

1. Click  or click File > New. The New dialog box opens. 

2. Select the type of file to create. If Sub-types are available, they are listed. 
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Note: If you click through the file types, you can see the default name for each 

file type in the Name box. The default prefix indicates the file type.  For example 

part prt0001, saves as file prt0001.prt, and assembly mfg0001 saves as file 

mfg0001.mfg. 

3. Select a Sub-type, if available. 

4. In the Name box, type a name for your file or use the default name. If you 

accept the default template or if Use default template is not available, go to 

step 10. To use another template go to step 5. 

5. Clear Use default template and click OK. The New File Options dialog box 

opens.  

Note:  

o If an object type is not supported by a template, then Use default 

template is unavailable.  

o To see the New File Options dialog box by default for template-supported 

types, set the configuration option force_new_file_options_dialog to 

Yes.  

6. Type the name of the template file, select a template file, or browse to a file and 

then select it as a template file. For each template two files are provided, one in 

metric (mmns) and one in nonmetric (inbls). 

7. Assign parameter values or change parameter values, if required. All standard 

part and assembly templates contain DESCRIPTION and MODELED BY 

parameters, which are automatically passed into Pro/INTRALINK and Pro/PDM. 

8. Select Copy Associated Drawings to create a drawing of a new part 

automatically when you select a template containing a drawing with the same 

name. For example, if you select the template inlbs_part_solid.prt, and the 

template directory contains a corresponding drawing template 

inlbs_part_solid.drw, select Copy associated drawings to automatically 

create a drawing with the same name. 

Note: Copy associated drawings is cleared by default. Use the configuration 

option rename_drawing_with_object to reset the default value. 

9. Click OK. The Pro/ENGINEER graphics window opens and the object appears. 

Note: In some cases another dialog box may open and require input before the 

Pro/ENGINEER graphics window opens. 

To Copy into an Empty Part or Assembly 

Use Copy From to import a part or assembly, including the geometry and features, 

into the active, empty, part or assembly. You can copy a part, only into a part, and 

an assembly, only into an assembly. The target part or assembly must not have a 

default template.  

1. Click File > New. The New dialog box opens. 
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2. Clear Use default template. 

3. Select Part and click OK. The New File Options dialog box opens. 

4. In the Template section of the dialog box, select Empty and click OK. The 

Pro/ENGINEER window is displayed. A part appears in the Model Tree. 

5. Click File > Copy From. The Choose Template dialog box opens. 

6. Select the part that you want to copy and click Open. The part is displayed in the 

Pro/ENGINEER graphics window. The message All existing parameters and 
layer information will be lost when the component is filled appears. 

This message refers to the parameters and layer information in the target 

(empty) part.   

Note: When using the Copy From command: 

• The part you are copying from cannot have external dependencies, such as a 

Merge feature. 

• The assembly you are copying from cannot have external dependencies, such as 

components. 

• No family table information is copied. 

Object Templates 

You can use Pro/ENGINEER object templates to customize the default content of 

newly created objects. Object templates belong to one of two categories: model 

templates and drawing templates. Model templates are standard Pro/ENGINEER 

models that contain predefined features, layers, parameters, named views, and 

other attributes. Drawing templates are special drawing files that contain instructions 

to create drawing items, including views, tables, formats, symbols, snap lines, notes, 

parametric notes, and dimensions.  

PTC-provided model templates include default datum planes, named views, default 

layers, default parameters, and default units. The PTC standard drawing templates 

include three orthogonal views and can be further customized. 

The following Pro/ENGINEER object types support the use of templates: 

• Solid parts 

• Sheetmetal parts 

• Bulk parts 

• Design assemblies 

• Mold manufacturing objects 

• Cast manufacturing objects 

• Drawings 
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Configuration Options for Object Templates 

To control object template display and storage, use the following configuration 

options. 

• start_model_dir—Specifies the directory in which to store templates. 

• force_new_file_options_dialog—Forces automatic display of the New File 

Options dialog box 

• template_solidpart,template_sheetmetalpart,template_designasm,templat
e_mfgcast, template_mfgmold, template_drawing—Specifies the model file to 

use as the default template. 

Opening Files 

About Opening Files 

You can open files across platforms, retrieve files from other directories, and retrieve 

earlier versions of a file. In addition, you can use wildcards to retrieve objects and to 

perform procedures to save time when retrieving graphics. To open a recently saved 

file, click its name at the bottom of the File menu. 

You can retrieve files of all types from the current session (in memory) and from disk 

using the File Open dialog box (File > Open). You use this dialog box to: 

• Navigate your disk and directory structure. 

• Filter displayed file types. 

• Preview Pro/ENGINEER files. 

• Select and open a file. 

• Import files into Pro/ENGINEER. 

• Create or select simplified representations of files. 

To Open a File 

$$$ProCmdModelOpen@CMD,ProCmdRecentFileOpen@CMD,file_open@DLG,file_open

@In_Session,file_open@desktop_pb,file_open@mydocs_pb,file_open@workingdir_pb

,file_open@network,file_open@System 

Formats_shortcut,file_open@view_favorites$$$ 

1. Click File and select one of the files at the bottom of the File menu. The four 

most recent files that you opened are listed. To open a file not on this list, go to 

step 2. 

Note: When you create a file, you must save it before it appears in the most 

recent list on the File menu. 

2. Click  or File > Open. The File Open dialog box opens. The directory in the 

address bar defaults to one of the following items: 
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o My Documents (Windows platforms only) if you have not set a working 

directory or previously saved an object to another directory in your current 

Pro/ENGINEER session. 

o The working directory that you set for your current session. 

o The directory you last accessed to open, save, save a copy, or back up your 

file. 

o The directory set with the file_open_default_folder configuration option. 

o The directory you set using Tools > Address Default in the File Open 

dialog box. This setting applies to the current session only and overrides 

the file_open_default_folder configuration option for the current 

session. 

3. Locate the file to open in the default directory or select a different directory using 

a method below: 

o Click a folder under Common Folders. 

o Click any directory in the address bar and then select another directory or a 

file. The path in the address bar changes as you select directories. 

o Click  to toggle the address bar to display a directory path that you can 

edit directly. 

o Click Folder Tree and select a folder to browse. To add a folder to the list 

of common folders select the folder, right-click, and choose Add to 

Common Folders from the shortcut menu.  

Note: 

o To narrow your search, select a file type from the Type box and a subtype 

from the Sub-type box. Only selected types are listed in the directory.  

o To quickly locate a file, type the file name into the Search box. The files in 

the current directory are filtered according to the typed text.  

o To change the view, organize, or perform other actions in the directory, 

click View, Organize, or Tools. You can also right-click a file in the 

directory and use the shortcut menu. 

4. To open the file, double-click it or click Open. The object appears in the graphics 

window. 

Note: To select a simplified representation of the object, select the object, click 

Open Rep, select a type of representation from the Open Rep dialog box, and 

click OK. 

Transferring Files Using FTP 

Pro/ENGINEER object files are saved in a binary format. This format can be 

transferred to and used on other hardware platforms. The files are guaranteed to be 

compatible with new Pro/ENGINEER software revisions. 
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If you use FTP (File Transfer Protocol) to transfer files, make sure that you set your 

FTP environment to transfer binary file types, and not ASCII files. When performing a 

file transfer using FTP, be aware that the Pro/ENGINEER file header may appear to 

be ASCII, but the file is actually in binary format.  

Retrieving an Earlier Version of a File 

Although Pro/ENGINEER automatically retrieves the latest saved version of an object, 

you can retrieve any previous version by entering the full file name with extension 

and version number (for example, bracket.prt.5). 

If you do not know the specific version number, you can enter a number relative to 

the latest version. For example, to retrieve a part from two versions ago enter 

partname.prt.-2. 

Note: 

• As a delimiter for the version number, use a period (.).  

• If an object is in the current session (in memory), Pro/ENGINEER ignores any 

version number you add when you are retrieving it. 

• If you retrieve a file from a non-working directory, rename the file and then save 

it, the renamed file is saved to the directory from which it was originally 

retrieved. It is not saved in the current working directory. 

You can also retrieve another version of a part already in memory as long as you 

give the part a new name. The part is retrieved into a subwindow under the new 

name. 

Retrieving Files Across Platforms 

To successfully retrieve Pro/ENGINEER files created on a UNIX system and 

transferred to a Windows system, the files must be transferred using a binary 

method. However, files transferred without using a binary method can be corrected. 

If during file retrieval Pro/ENGINEER determines a correction is required,a dialog box 

opens giving you the opportunity to correct the error. 

You can choose to cancel the retrieval process and correct no files or you can 

continue the file retrieval process, allowing Pro/ENGINEER to correct and retrieve the 

required files. If you choose to make the correction, all subsequent corrections in the 

current Pro/ENGINEER session are made without prompting. Other files that depend 

on the file being retrieved (such as part files for an assembly) are automatically 

corrected and retrieved.  

Note: 

• The correction process increases the total retrieval time for the Pro/ENGINEER 

model and may decrease the amount of available temporary swap space on your 

system. 

• You may not be able correct the error when retrieving a document. 
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Using the Command Line Utility 

You can use the command line utility dos_to_binary to correct files individually or to 

correct all files in a specified directory. The syntax for this utility is dos_to_binary 
[-inf] [-r] file.prt.1, where file.prt.1 is the name of the file to be 

corrected. If a file version is not specified, the latest version is used.  

Multiple files can be corrected by specifying each file name and separating each one 

with a space. If you specify a directory name, using the -r option, all files in that 

directory will be corrected. 

When the command line utility is used, the specified files are checked to determine if 

correction is necessary. If correction is necessary, the file is corrected and saved as 

an incremented revision. For example, if sphere.prt.2 is corrected, the corrected 

file is named sphere.prt.3. 

Note: The file is not marked as being modified for Pro/PDM or Pro/INTRALINK. 

Retrieving Objects Using Wildcards 

When you are retrieving objects, you can enter wildcard characters for object names, 

their extensions, and directory names. You cannot use wildcards in place of version 

numbers. 

The match syntax is 

• An asterisk (*) can replace any number of characters. 

• A question mark (?) can replace any one character. When the question mark is 

entered alone, you get the complete listing of the appropriate objects in the 

directory. 

• If you retrieve a file from a non-working directory, rename the file and then save 

it, the renamed file is saved to the directory from which it was originally 

retrieved. It is not saved in the current working directory. 

Simplified Representations 

Simplified representations improve regeneration, retrieval, and display time and let 

you tailor your work environment to include only the information of current interest 

to you.  

For example, you can remove a subassembly that you are not working on from an 

assembly.  

You can simplify the geometry of a part by excluding some of its features or by 

defining a specific work region. In drawings, you can create views of simplified 

representations. 

To Open a File Containing a Family Table (Instances) 

1. Click  or File > Open. 

2. Select the file containing the Family Table. The Select Instance dialog box 

opens. 
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3. Do one of the following:  

o Click the Name tab and select the generic. 

o Click the Name tab and select an instance. 

o Click the By Parameter tab, and select the desired parameter and value. 

All instances containing the specified parameter and value appear in the 

Name list. Select the instance you want to open. 

About Previewing Files 

Use Preview in the File Open (File > Open) dialog box to preview parts, drawings, 

and assemblies before opening them or to search for a file if you do not know the file 

name. Previewing while browsing is convenient when you must open a 

Pro/ENGINEER object file to incorporate into a design, for example, or when you 

must specify a component to assemble.  

Note:  

• Previewing is available for files saved in a version of Pro/ENGINEER that supports 

previewing.   

• Objects appear in the Preview window as they were saved. For example, if the 

layer for datum curves was blanked when the file was saved, that layer is 

blanked in the preview.  

To Preview Files 

1. Click  or File > Open. The File Open dialog box opens. 

2. Select the file from the file list or type the file name in the File name box. 

3. Click Preview. The object appears in the preview area. 

4. To change the preview configuration, right-click, and choose your preferred 

settings from the shortcut menu: 

Display style: 

o Shaded (default) 

o No Hidden 

o Hidden Line 

o Wireframe 

Projection style: 

o Orthographic (default) 

o Perspective 

Frame rate: 

o Frames per second 
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View type: 

o Dynamic 

o Anchored 

o Delayed 

o Velocity 

o Fly Throug 

o Standard (default) 

5. To return to the default preview orientation, right-click, and choose Refit from 

the shortcut menu. 

Previewing Assemblies 

When you preview assemblies you can focus on individual assembly components. 

Click an assembly component in the preview area to get a preview of that component 

only.  

For optimal assembly preview performance, set the save_model_display 

configuration option to shading_lod. 

Previewing Drawings 

To preview a drawing the drawing must be saved with the 

save_drawing_picture_file configuration option set to embed, export, or both. By 

default, the first sheet of the drawing appears in the preview area. You can pan and 

zoom the previewed drawing as you would in the Graphics window. To change 

sheets, right click and choose a sheet from the shortcut menu. 

About Searching For and Retrieving Models 

From Pro/ENGINEER you can open a model from another directory by specifying a 

directory path when you enter the model name. If you do not specify the directory, 

Pro/Engineer searches for the model in the following areas in the order shown: 

1. Directory appearing in the Look In box in the File Open (File > Open) dialog 

box 

2. Pro/ENGINEER session 

3. Active workspace or commonspace 

4. Current Working Directory 

5. Search Paths 

About the Search Path and search.pro 

During model retrieval, Pro/ENGINEER searches for and then retrieves submodels 

from the following areas in the order shown: 
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1. Pro/ENGINEER session 

2. Directory in which the top model is being retrieved 

3. Active workspace or commonspace 

4. Current Working Directory 

5. Other search paths and directories such as: 

o Specific Directories—Set the configuration option search_path and 

Pro/ENGINEER searches in the directories as specified. 

o search.pro file—Set the configuration option search_path_file and 

Pro/ENGINEER searches in the search.pro file. 

o Libraries—Set the configuration option pro_library_dir to set the default 

directory for Pro/ENGINEER libraries, or for libraries you have built. 

o Drawing Format Library—Set the configuration option pro_format_dir 

to set the default directory for the drawing format library. 

If the assembly components or drawing models are not in any of the above areas, 

you must retrieve them before retrieving the assembly or drawing. 

Adding Search Paths to Pro/ENGINEER 

If you want Pro/ENGINEER to search additional paths besides the working directory, 

such as a server, you can add paths using one of the following methods: 

• Within a Pro/ENGINEER session, specify additional directory paths with the 

configuration option search_path.  

• Type the paths directly into the search.pro file and set the configuration file 

option search_path_file. search.pro is an editable text configuration file that 

contains relative and absolute paths to search for models. You may specify either 

the full path name for the file or just the full path name of the directory 

containing the file. You can search for models on registered Windchill server 

cabinets and workspace, and other sites and servers. 

Directory path names can be relative or absolute. A path name can contain up to 260 

characters. When you specify a relative path name, you can use special characters, 

such as ".." in UNIX and Windows (NT, 95, 98, and 2000). 

Relative pathnames are initially resolved relative to the startup directory. If you 

subsequently reload the configuration file, the system reevaluates the relative 

pathnames relative to the current (working) directory and appends the new 

directories (if any) to the search path (the previous path remains in place). It is 

better to always specify the full pathnames (from root) so as to avoid problems if 

you change working directories or use the same configuration file in another startup 

directory. 

In Windows NT/95/98/2000 systems, specify the drive at the beginning of the path 

to avoid problems if you change your working directory to a directory in another 

drive. 
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It is possible for each configuration file read in at startup to call out its own search 

path directories or search.pro file. As Pro/ENGINEER processes the first 

configuration file, it loads any specified search_path directories and the contents of 

the specified search.pro file (if any) into its search path. As it processes subsequent 

configuration files, it likewise appends any specified directories to the search path. If 

a particular directory is specified more than once, it appears more than once in the 

search path. All search-path directories are listed and processed in the order in which 

they were read. 

If an object can be found in more than one search path directory, the system 

retrieves the first one it finds, regardless of which object is the most recent. 

Note: Search paths can be disabled by inserting a ! character in front of the 

appropriate line or lines in the search.pro file. 

The primary server is always included in the search path without being specified in 

the config.pro file. 

To Load a search.pro File 

Pro/ENGINEER does not automatically read the search.pro file at startup. You must 

load the search.pro file if you want Pro/ENGINEER to read it. 

1. Click Tools > Options. The Options dialog box opens. 

2. In the Options box, type the configuration option search_path_file. For a 

value, specify either the full path name for the file or the full path name of the 

directory containing the file.  

You must enclose in quotation marks any search path with a separator character 

(space, comma, or semicolon) in a directory name, for example: 

o Windows: search_path_file "C:\Program Files\proe2001\models" 

o UNIX: search_path_file 
"/home/user/smith/odd,dir;name/search.pro" 

Note: For Windows NT, omit the last backslash (\) from the path, or enclose the 

path in quotation marks, or add a trailing space after the backslash. 

3. Click Apply. Pro/ENGINEER reads the search.pro file automatically. 

When you load a search.pro file, Pro/ENGINEER appends the contents of the 

search.pro file to the search path. Pro/ENGINEER reads any paths that you 

added and ignores any paths that you commented out. 

To Edit a search.pro File 

1. Open the search.pro file from within a text editor such as Notepad or Microsoft 

Word. 

2. Add or delete search paths, or designate lines that contain search paths as 

comment lines only, as desired. 
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3. Save the file. When you save it, you can either accept the default name 

search.pro or assign a new name to the file. 

Note: 

• Only one directory path (search path) is allowed per line. 

• You can insert comments into the file. Simply precede the line with a ! and 

Pro/ENGINEER interprets the line as a comment and ignores it. Comment lines 

must begin with ! They may be interspersed throughout the file. 

• You can specify that certain paths in the file not be read at startup, by 

designating the lines containing the search paths as comments only. 

Pro/ENGINEER ignores the comment lines. 

• Lines may also be blank, except for the first line. 

• You must enclose in quotation marks any search path with a separator character 

(space, comma, or semicolon) in a directory name, for example: 

o Windows: "C:\Program Files\proe2001\models" 

o UNIX: "/home/user/smith/odd,dir;name/search.pro" 

Note: For Windows NT, omit the last backslash (\) from the path, or enclose the 

path in quotation marks, or add a trailing space after the backslash. 

• When you are defining a search path in the Windows NT operating system, you 

must precede the delimiting backslash character with another formatting 

character. 

• Directory path names can be relative or absolute and can include special 

characters such as ".." in UNIX, to specify a relative path. However, it is better to 

always include the absolute path names (that is, from root) to avoid problems if 

you change working directories or if you use the same configuration file in 

another startup directory. 

• Search paths may also include previously defined environment variables. This is 

done by preceding the variable with $ in the search path definition in UNIX, or 

enclosing it between % characters in Windows NT/95/98/2000. For example, the 

environment variable OBJ_TYPE can be used as follows: 

(UNIX)/partlib/$OBJ_TYPE/objects 

(Windows NT/95/98/2000)D:\partlib\%OBJ_TYPE%\objects 

• You can create multiple search.pro files and store them in different directories. 

However, you may instead want to use the same search.pro files for all your 

projects, and simply comment out the paths in the file that you do not want 

Pro/ENGINEER to read for certain sessions. 

To Temporarily Disable a Search Path 

In Pro/ENGINEER, you can temporarily prevent one or more paths from being read at 

startup. 
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1. Open the search.pro file from within a text editor such as Notepad or Microsoft 

Word. 

2. Comment out the lines that contain the paths you want to suppress. To comment 

out a line, place a ! character at the beginning of the line. 

To re-enable the path, delete the ! character from the line that contains the path 

you want to re-enable. Pro/ENGINEER reads the path at startup. 

Example: Adding Search Paths 

For maximum clarity, you should specify only one directory path name in the Value 

field in the Options dialog box. You can set the option any number of times in the 

configuration file. You can also set the configuration option search_path_file to a 

file that contains multiple search paths.   

The two directories shown in the following example are added by setting the 

configuration option twice.  

search_path /components/washers 

search_path wtpub://<alias> where <alias> is the name you specify in the site 

registry dialog.box. 

Separator Characters and Search Paths 

You must enclose in quotation marks any search path with a separator character 

(space,comma, or semicolon) in a directory name, for example: 

• Windows: search_path "C:\Program Files\proe2001\models" 

• UNIX: search_path "/home/user/smith/odd,dir;name" 

Note: For Windows NT, omit the last backslash (\) from the path, or enclose the 

path in quotation marks, or add a trailing space after the backslash. 

Using More Than One Path 

The system permits you to enter several path names on a single line, separated by 

commas, or semicolons. You must use the same delimiter within the same line to 

separate path names. For instance, you cannot use a space and a comma in the 

same line. If you wanted to include the directories /components/washers and 

wtpub://windchill_server but you wanted to set the search_path option only 

once, you would add the two directories at the same time in the Value field, as 

shown in the following example: 

search_path /components/washers, wtpub://windchill_server 

Note: Make sure you separate the directory paths with spaces, semicolons, or 

commas. 
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Selecting the Working Directory 

To Select a Working Directory 

Your working directory is an area you designate to store Pro/ENGINEER files. 

Typically, the default working directory is directory in which you start Pro/ENGINEER. 

To select a different working directory for your current Pro/ENGINEER session, use 

one of the following procedures. 

To Select a Working Directory from the Folder Navigator 

1. Click . (You may need to click  first to see the Folder Navigator.) The 

Folder Navigator appears. 

2. Select the directory you want to set as your working directory and right-click. A 

shortcut menu appears. 

3. Click Set Working Directory. A message confirms the working directory is 

changed. 

To Select a Working Directory from the File Menu 

1. Click File > Set Working Directory. The Select Working Directory dialog box 

opens. 

2. Browse to the directory you want to set as the new working directory. A folder 

followed by a period ( ) is displayed indicating the location of the working 

directory. 

3. Click OK to set as the current working directory. 

Note:  

• The new working directory setting is not saved when you exit Pro/ENGINEER. 

• If you retrieve a file from a directory other than your working directory and then 

save the file, the file saves to the directory from which is was retrieved. If you 

save a copy and rename the file, the copy saves to the current working directory. 

• You can access the working directory from the File Open, Save Object, Save a 

Copy, and Backup dialog boxes by clicking . 

Mirroring Parts 

To Mirror a Part 

When you mirror a part, the new part is a mirror image of the original part and can 

be independent of or dependent on the original part. 

1. Open a part. 

2. Click File > Mirror Part. The Mirror Part dialog box opens  
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3. Select one of the following combinations of options and then follow the 

appropriate steps. 

Click Mirror Geometry Only and clear the Geometry Dependent check box. 

a. Accept the default New Name or type a new name. 

b. Click OK. A new window opens with the mirrored part. No features 

from the original part appear and the only feature in the Model Tree is 

Mirrored Merge. You can select the Mirrored Merge feature and right-

click to select options such as Open Base (opens the original part from 

which this part was copied) or Edit Definition. If you change the geometry 

in the original part, it does not change in the mirrored part. 

Click Mirror Geometry Only and click the Geometry Dependent check box. 

a. Accept the default New Name or type a new name. 

b. Click OK. A new window opens with the mirrored part. No features 

from the original part appear. The only feature in the model tree is a 

Mirrored Merge feature. You can select the Mirrored Merge feature and 

right-click to select options such as Open Base (opens the original part 

from which this part was copied) or Edit Definition. If you change feature 

dimensions, for example, in the original part, the changes are propagated 

to the mirrored part. If you make changes in the mirrored part, they are 

propagated to the original part. 

Click Mirror Include all Feature data. The Geometry Dependent checkbox is 

not available. 

a. Accept the default New Name or type a new name. 

b. Click OK. A new window opens with the mirrored part. Features in the 

original part are propagated to the mirrored part and a Mirrored Merge 

feature is added as the last feature in the Model Tree. The original and 

mirrored part are independent of each other. Changes in one do not affect 

the other. 

Deleting Files 

About Deleting Files 

Erasing Objects in Memory 

An object is a file you create using a Pro/ENGINEER.  

Every time you save an object, you create a new version of the object and write it to 

the disk. Pro/ENGINEER numbers each version of an object storage file consecutively 

(for example, box.sec.1, box.sec.2, box.sec.3). 

When you close a window using the Close Window command, the object is no 

longer displayed but it remains in memory during the current session. Erasing an 

object removes it from memory but not from disk. 



Pro/ENGINEER Fundamentals 

101 

Note: 

• You cannot erase objects while assemblies or drawings that are referencing them 

are still active. 

• Erasing an object does not necessarily erase from memory those objects to which 

it refers (for example, erasing an assembly does not necessarily erase its 

components). 

Deleting Objects 

Every time you save an object, you create a new version of the object in memory, 

and write the previous version to disk. Pro/ENGINEER numbers each version of an 

object storage file consecutively (for example, box.sec.1, box.sec.2, box.sec.3). 

You can use the Delete command to free up disk space and remove old, 

unnecessary versions of objects: 

You can quickly purge Pro/ENGINEER files on disk (any files with version numbers) 

from an operating system window using the purge script, which is loaded by 

Pro/ENGINEER at installation. 

To use the purge script, type purge string, where string is a filter to match for 

files. 

If you do not include a string, the systems purges all but the latest version of 

assembly files, part files, datum curve files, and so on. If you do include a string, the 

system purges only those files that match the string. The string can contain 

wildcards: (*) matches any number of characters, (?) matches a single character. To 

prevent wildcard interpretation in UNIX, use a backslash in front of (*) and (?). 

To Erase the Current Object from Memory 

To erase the top-level object and selected sub-components displayed in the active 

window: 

1. Click File > Erase > Current. 

2. Click Yes. If you are working in a part, the part is erased from the graphics 

window. If you are working in an assembly, manufacturing model, or drawing, 

the Erase dialog box opens.  

3. Select the Associated Objects (objects reference by the current object) that 

you also want to erase from memory. 

4. Click OK.  

Note: 

Click Tools > Customize Screen to add the following to the toolbar: 

• —Erase Current 

• —Erase Not Displayed 
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To Erase Undisplayed Objects from Memory 

Use the Erase Not Displayed dialog box to erase all objects from the current 

session, except for objects that are currently displayed and any objects referenced 

by the displayed objects. For example, if an assembly instance is displayed, the 

generic of an instance and its components are not erased. 

1. Click File > Erase > Not Displayed. The Erase Not Displayed dialog box 

opens. 

2. Click OK. If you have set the configuration option prompt_on_erase_not_disp to 

yes , you are prompted to save each object before it is erased. 

Notes:  

• Click Tools > Customize Screen to add the following to the toolbar: 

o —Erase Current 

o —Erase Not Displayed 

o Set the configuration file option prompt_on_erase_not_disp to yes to display a 

prompt for each modified, unsaved object, allowing you to save the object before 

it is erased. When set to no (the default), Pro/ENGINEER immediately erases all 

undisplayed objects.  

To Delete Old Versions of a File 

Every time you save an object, you create a new version of the object in memory, 

and write the previous version to disk. Pro/ENGINEER numbers each version of an 

object storage file consecutively (for example, box.sec.1, box.sec.2, box.sec.3). 

Follow the steps below to delete all versions of an object except the most current 

version (the version with the highest version number). 

1. Click File > Delete > Old Versions. A confirmation prompt appears. 

2. Click  to delete older versions of the current object, or type the name of a 

different object and click . 

Note: You cannot delete a part or subassembly that has been used in an assembly 

or drawing during the current working session until the assembly or drawing is 

deleted. 

To Delete All Versions of a File 

To delete all versions of the current object: 

1. Click File > Delete > All Versions. A Delete All Confirm message appears. 

2. Click Yes to delete all versions of the current object. 
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Note:  

• You cannot delete a part or subassembly that has been used in an assembly or 

drawing during the current working session until the assembly or drawing is 

deleted. 

• If the object is an instance, neither the instance nor the generic is deleted. If an 

object is a generic and you select it for deletion, only the generic is deleted. 

Saving, Exporting, Renaming, and Backing Up Files 

About Saving Files 

You can save Pro/ENGINEER files using Save or Save a Copy commands. From the 

Save a Copy dialog box you can also export Pro/ENGINEER files to different formats, 

and to save files as images.  

Pro/ENGINEER saves only changed objects, except in the following cases: 

• An object selected for saving is not found in the destination directory 

• The configuration file option save_objects is set to all 

• The configuration file option save_objects is set to changed_and_specified and 

the current object is the top object in an assembly  

• A change is made to a dependent object and the configuration file option 

propagate_change_to_parents is set to yes. 

Saving an object on the disk creates a file with the format 

object_name.object_type.version_number. For example, if you create a part with 

the name bracket, it initially saves to the file name bracket.prt.1. Saving the same 

part again results in file name bracket.prt.2.  

If you retrieve an object using a relative path specification (for example, 

../partname), the same path specification is used to save it in its original directory. 

So if you change your working directory between retrieving and storing, the object 

could be saved in a wrong directory. Be careful when you use relative path names. 

Note: Path names can contain up to 260 characters. 

To Save a File 

1. Click  or File > Save.  The Save Object dialog box opens.   

o If you previously saved there are no options available in the Save Object 

dialog to change directories. Click OK to complete the save. 

o If you have not previously saved the object, go to Step 2. 

2. The directory in the Look In box defaults to one of the following: 
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o My Documents (Windows platforms only) if you have not set a working 

directory or previously saved an object to another directory in your current 

Pro/ENGINEER session. 

o The Working Directory you set for your current session. 

o The directory you last accessed to open, save, save a copy, or back up your 

file.  

3. Accept the default directory or browse to a new directory.  

Note: You can access the working directory by clicking . 

4. In the Model Name box, the name of the active model appears. To select a 

different model click . 

5. Click OK to save to the directory displayed in the Look In box or select a 

sub-directory and then click OK. The Pro/ENGINEER graphics area is displayed. 

Note: 

• Objects are stored in their original directories unless you set the configuration 

option override_store_back to yes.  

• If you do not want your file to save to the last accessed directory, set the 

configuration option file_open_default_folder. Use this configuration option to 

specify the directory from which you want to open, save, save a copy, or backup 

files.  

• If you do not have write permission to the original directory and have 

override_store_back set to no, set the configuration option 

save_object_in_current to yes to store the objects in the current directory.  

• By default, Pro/ENGINEER saves the model on which a drawing is based only 

when changes have been made to it. You can use the configuration file option 

save_modified_draw_models_only to save the model every time the drawing is 

saved.  

• To save disk space, compress file output by setting the configuration option 

compress_output_files to yes. Compressed files take longer to read and write, 

but are one-half to one-third the size of uncompressed files. They are also fully 

compatible across platforms. 

To Save a Copy of a File 

1. Click File > Save a Copy. The Save a Copy dialog box opens. The directory in 

the Look In box defaults to one of the following: 

o My Documents (Windows platforms only) if you have not set a working 

directory or previously saved an object to another directory in your current 

Pro/ENGINEER session. 

o The Working Directory you set for your current session. 
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o The directory you last accessed to open, save, save a copy, or back up your 

file.  

2. Accept the default directory or browse to a new directory.  

Note: You can access the working directory by clicking . 

3. In the Model Name box, the name of the active model appears. To select a 

different model click . 

4. In the New Name box, type the new file name.  

Note: An error message appears if you type the name of a model currently in 

session. 

5. Click OK to save to the directory displayed in the Look In box or select a sub-

directory and then click OK. The Pro/ENGINEER graphics area is displayed. 

Note:  

• To save a file to a different disk or directory using the same file name, use File > 

Backup. 

• If you do not want your file to save to the last accessed directory, set the 

configuration option file_open_default_folder. Use this configuration option to 

specify the directory from which you want to open, save, save a copy, or backup 

files.  

To Rename a File 

1. Click File > Rename. The Rename dialog box opens and the current model 

name appears in the Model box.   

2. To select a different model click . 

3. In the New Name box, type the new file name. 

4. Click either Rename in session or Rename on disk and in session. 

Note: Problems result if you rename a file on disk and then retrieve a model (not 

in session) that depends on the previous file name. For example, a part cannot 

be found for an assembly. 

5. Click OK.  

Note: 

• If you retrieve an object from a non-working directory, rename and save the 

object, it saves to the original directory from which it was retrieved and not in 

the current working directory. 

• You cannot save or rename a file using the original file name, even if you save 

the file in a different directory. 
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• To add  (Rename) to your toolbar, click Tools > Customize Screen. 

To Back Up a File 

To make a backup copy of an object file that is in memory: 

1. Click File > Backup. The Backup dialog box opens. The directory in the Look In 

box defaults to one of the following: 

o My Documents (Windows platforms only) if you have not set a working 

directory or previously saved an object to another directory in your current 

Pro/ENGINEER session. 

o The Working Directory you set for your current session. 

o The directory you last accessed to open, save, save a copy, or back up your 

file.  

2. Accept the default directory or browse to a new directory for which you have 

write access.  

Note: You can access the working directory by clicking . 

3. In the Model Name box the name of the active model appears. To select a 

different model click . 

4. Click OK to backup to the directory displayed in the Look In box or select a sub-

directory and then click OK. The Pro/ENGINEER graphics window is displayed. 

Note: 

o Versions of the backed up object are reset in the backup directory. 

o If you back up an assembly, drawing, or manufacturing object, 

Pro/ENGINEER saves all dependent files in the specified directory. 

o If an assembly has related interchange groups, those groups are not saved 

in the backup directory when you back up the assembly. 

o If you make changes to a model after backing it up and then save the 

model, the changes are always saved in the backup directory. 

Printing and Plotting Files 

About Printing and Plotting 

You can print files in the following ways: 

• From the File menu you can print with the following options: scaling, clipping, 

displaying the plot on the screen, or sending the plot directly to the printer. You 

can also print shaded images from this menu. You can create plot files of the 

current object (sketch, part, drawing, assembly, or layout) and send them to the 



Pro/ENGINEER Fundamentals 

107 

print queue of a plotter. The plotting interface to HPGL and PostScript formats is 

standard. 

• Use the Pro/BATCH utility to create a command file of print or plot files without 

having to choose from the interactive menus. The command file contains a list of 

objects to plot. For example, you can submit the job at the end of a workday, 

and the plot files are created and plotted offline. 

Notes for plotting: 

o Hidden lines appear as gray for a screen plot, but as dashed lines on paper.  

o You cannot plot when the option Use Fast HLR is checked in the 

Environment dialog box. 

o When Pro/ENGINEER plots the system line fonts, it scales them to the size 

of a sheet. It does not scale the user-defined line fonts, which do not plot 

as defined. 

You can use the configuration file option use_software_linefonts to make 

sure that the plotter plots a user-defined font exactly as it appears in 

Pro/ENGINEER.  

o With the CROSS SEC menu active, you can plot a cross section from Part 

or Assembly mode. 

o You can write plot files in Calcomp, Gerber, HPGL2, and Versatec format if 

you have the Pro/PLOT module. Pro/PLOT is part of the Foundation II 

license. 

o For the HPGL2 driver to print a screen capture of OLE objects, the printer 

must support the HP RTL extension. 

Configuring the Printer 

You can configure your printer using the Printer Configuration dialog box, 

available from the Print dialog box. If you are printing a shaded image, the Shaded 

Image Configuration dialog box opens instead of the Printer Configuration 

dialog box.  

To Print an Object: Basic Procedure 

1. Click File > Print. The Print dialog box opens. 

2. Click . A shortcut menus appears. 

3. Select another printer or add a new printer. The selected printer type is saved for 

the current session only. 

4. Click Configure. The Printer Configuration dialog box opens. 

Note: If you are printing a shaded model, the Shaded Image Configuration 

dialog box opens instead. For more information about printing a shaded image, 

refer to the topic To Print a Shaded Model. 
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5. Use the Printer Configuration dialog box to configure the printer page, to 

format and scale the model for printing, and to set other printer options, as 

necessary.   

6. Click OK. 

7. In the Print dialog box, set other print options as necessary. 

o If you select To file, complete the dialog box to specify the contents and 

structure of the plot files. 

o If you select To printer, specify the sheets (if available), quantity, and 

command for the print. 

8. Click OK. 

Note:  

• Shaded plots cannot be generated using the MS Printer Manager. 

• In the Plotter Command box you can type an operating system command for 

plotting (obtain this from your system administrator or the operating system 

guide for your workstation), or use the default command. 

Printer Configuration Dialog Box 

This topic shows you how to configure the printer page, format and scale a model for 

printing, and set other printer options when printing all objects except a shaded 3D 

model.  

The Printer Configuration dialog box opens when you click Configure in the Print 

dialog box (File > Print). It contains the following tabs: 

• Page tab—Provides options for configuring the printer page, such as paper size, 

height, width, and units (inches or millimeters). 

• Model tab—Provides options for formatting and scaling the model for printing. 

• Printer tab—Provides other printing options that you can set, such as: 

o Setting pen speed 

o Specifying whether a paper cutter is installed 

o Selecting the plotter initialization type 

o Selecting the paper type 

Configuring the Printer Page: The Page Tab 

The Page tab allows you to configure the printer page and provides the following 

options: 
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Option Action 

Size list Allows you to choose a paper size from the 

following available sizes: A (default size), 

B, C, D, E, F, A0, A1, A2, A3, A4, and 

Variable. 

Height Allows you to specify a paper height for 

variable size (default is 8.5 inches). 

Width Allows you to specify a paper width for 

variable width (default is 11 inches). 

Offset X Allows you to specify a horizontal printer 

offset. 

Offset Y Allows you to specify a vertical printer 

offset. 

Label Include Allows you to Indicate whether or not to 

print a label (the default setting is no 

label). 

Height Allows you to specify the height of the label 

(the default height is .125 inches). 

Units Inches or 

Millimeters 

Allows you to specify units as inches or 

millimeters (default is inches). 

Formatting and Scaling a Model for Printing: The Model Tab 

The Model tab provides the following options for formatting and scaling the model: 

Command Action 

Plot list Choose type of plotter (see list and descriptions in the 

following section entitled Plot Types). 

Plot Scale Specify scale of plotter (default is 1). 

Segmented If applicable, choose segmented plotting. 

With Format If applicable, choose plotting with formatting. 

Layers All 

Visible 

Print all visible layers. 

By ID Print specified layer. 

Layers By ID 

field 

Type ID of layer to be printed. 
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Command Action 

Quality list Choose interface quality for checking of overlapping 

lines. The options are No line check, No overlap 

check, Simple overlap check, and Complex overlap 

check (default is Complex overlap check). 

Note: Imported geometry cannot be scaled. 

Plot Types 

The options on the plot list are as follows: 

• Full Plot—Creates a plot of an entire object (the object plots as if you chose 

View > Pan/Zoom > Refit. 

• Clipped—Creates a clipped plot. Define the boundaries by drawing a box around 

the area to plot. This area appears on paper in its normal location relative to the 

lower left corner. 

• Based on Zoom (default)—Creates a scaled, clipped plot. The scaling and 

clipping are based on paper size and the zoom setting in the graphics window. 

• Paper Outline (available in 2D mode only)—Creates a plot of a specific area 

within a drawing on a specified paper size. For example, if you have a large 

drawing, such as size A0, and you want to plot an A4 area of the drawing, you 

can use this option. 

• Plot Area—Creates a plot by shifting the area inside the clip box to the lower left 

corner of the paper and scaling the clipped area to match the user-specified 

scale. Zoom and pan screen factors and scale in the model size are also factored 

into the plot area. Thus, if the scale=1, the geometry is not necessarily printed to 

scale. 

• Model Size—Scales the plot to a specified model scale. For example, if you enter 

.25, the system creates a plot of the model to ¼ scale. This choice is valid only 

for 3D objects. 

Note: Clipped and Plot Area are affected when you change both the sheet size and 

the scale factor. Plots are not to scale if you change the sheet size on the Page 

tabbed page. When either of these have been specified, after you click OK to close 

the Print dialog box, the system asks you to specify the corners of the area to be 

plotted. Place the cursor at one corner and drag the cursor to the diagonally opposite 

corner of the area to be plotted. 

Setting Other Printer Options: The Printer Tab 

The Printer tab provides the following options: 

Command or Option Action 

Pen Table File check box Use a default pen mapping table. 
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Command or Option Action 

Pen Table File field Type the name of the table. 

Velocity If applicable, specify speed of pen 

(centimeters per second). 

Cutter Installed Specify whether or not a paper cutter is 

installed. 

Handshake Xon/Xoff or 

Hardware 

Select the type of plotter initialization. 

Sheet Type Sheet or Roll If applicable, select the paper type. 

Rotation Specify rotation of image (0 or 90 

degrees). 

To Print a Shaded Model 

Printing a model that is shaded is different from printing a model that is set to 

display in Wireframe, Hidden Line, or No Hidden. With shaded models, you 

specify model scaling and formatting using the Shaded Image Configuration 

dialog box. 

1. Click File > Print. The Print dialog box opens. 

2. Click  to select a printer or to add a new printer. The selected printer type is 

saved for the current session only.  

3. Click Configure to specify model scaling and formatting for printing. The 

Shaded Image Configuration dialog box opens. 

4. Set model scaling and formatting as desired, using the following options in the 

Shaded Image Configuration dialog box. 

Command Action 

Size Specify a standard size or a custom size by selecting 

from the list. 

Height Specify custom height dimensions (if you select 

Variable in the Size list as a paper size). 

Width Specify custom width dimensions (if you select 

Variable in the Size list as a paper size). 

Top Margin Specify custom top margin dimensions (if you select 

Variable in the Size list as a paper size). 

Left Margin Specify custom left margin dimensions (if you select 
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Command Action 

Variable in the Size list as a paper size). 

Units Set the variable plot size to inches or millimeters. 

DPI Specify the resolution of the output from the list. 

Choose from 100 dpi, 200 dpi, 300 dpi, 400 dpi, 500 

dpi, or 600 dpi. 

Image Depth Specify the image depth for the print. Choose from 8 

bit index or 24 Bit RGB. 

To Print an Object to a File 

1. Click File > Print. The Print dialog box opens. 

2. Under Destination, select a printer, and then select To file. 

3. Click OK. The Print to File dialog box opens. 

4. Select one of the following: 

o Create Single File—Creates a single .plt file that contains all print 

information 

o Create Separate Files—Creates separate .plt files. Use this option if the 

plot will be on more than one page, such as if you print a drawing with 

multiple sheets, or if the plot is too large to fit on the specified paper size. 

In the former case, each drawing sheet is printed on a separate sheet of 

paper and saved to a separate .plt file. In the latter case, different parts 

of the plot are printed on different sheets of paper and saved to separate 

.plt files. The system uses the specified file name and appends numbers to 

each file name (such as drawing.plt, drawing1.plt, and so on). 

o Append to File—Appends the new plot to an existing .plt file. Typically, 

the .plt file is erased and recreated with the new plot information. 

5. Under Name, accept the default file name or type a new name for the output file. 

Use the Browse button to search the directory structure to choose the location 

for the output file. This overwrites any default location. If you do not set the 

directory, the system stores the plot file in the current working directory and 

adds the .plt extension to the file name. If you want the extension of the plot 

file to depend on the plotter type, set the configuration file option plot_names to 

yes. 

o If you choose Append to File in the preceding step, click Browse to open 

the Save dialog box and select an existing .plt file to contain the 

additional .plt information for the active file. 

o If you choose Create Separate Files, the system creates a separate file 

for each print page in cases where the plot information is too big to fit on 

one page. The system appends a number to each file in order to create 
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separate files. In cases where you want to print a multisheet drawing file, 

the system places each drawing sheet in a separate plot file and appends 

the sheet number to each plot file name. 

6. Click OK. The system saves the .plt file and displays a message that the file has 

been created. 

Note: OLE objects are printed only as screen captures. 

To Print Part of a Drawing 

1. Click File > Print. The Print dialog box opens. 

2. Click Configure. The Printer Configuration dialog box opens. 

3. Click the Model tab. 

4. Under Plot, open the Plot drop-down list box and select Paper Outline. 

5. Click OK in the Printer Configuration dialog box, and then click OK in the Print 

dialog box. The Paper Outline Size Selection dialog box opens, and a movable 

rectangle appears in the Graphics window. By default, the rectangle is white; its 

color depends on whether you have created a user-defined color scheme in 

Pro/ENGINEER. 

6. To define the area you want to print, click anywhere inside the rectangle and 

drag it to the desired position on the drawing. 

7. You can change the size of the rectangle by choosing a paper size under Size. (If 

you choose Variable, specify a height and width in the Height and Width boxes, 

then specify a unit of size.) 

8. Click OK. The Paper Outline Size Selection dialog box closes, and the Print 

dialog box opens. 

9. Click OK to print. 

Segmented and PostScript Plots 

Example 1: Segmented Plots 

When you want to plot a drawing full size but your plotter can only handle smaller 

paper sizes, select the Segmented check box in the Model page of the Printer 

Configuration dialog box. Pro/ENGINEER plots the drawing full size, but in 

segments that are compatible with the selected paper size. The following illustration 

shows how each segment is plotted with a border marking the cut-lines, tick marks 

indicating alignment, and row/column designators showing how to assemble the full-

size plot. HP7475a and HP7440A plotters do not support segmented plots. 

When specifying paper size, keep in mind that the segmented plot size is smaller 

than the actual paper size because of the border alignment marks. 

The following diagram shows a C-size drawing. 
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Note: Segmented plots are available only when plotting 2-D. It is not available in 

3-D mode. 

 

Example 2: PostScript Plots 

You can generate PostScript plots for any plotter or laser printer that can handle 

PostScript data. You can also use them in documents created by electronic publishing 
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systems that can incorporate the PostScript data. The PostScript output format is 2.0 

compliant (the bounding box directive is included). You might have to rotate 

PostScript plots to plot them correctly, as is shown in the following illustration. 

 

The diagram on the left is a default PostScript plot. The diagram on the right is a 

PostScript plot after rotating. 

1. Paper 

2. Drawing 

3. Paper feed 

4. Paper 

5. Drawing 

To Change Plotting Pen Attributes 

You can change the attributes and assign your own line font, thickness, or color to a 
pen using the table.pnt file. Any attribute that you specify overwrites the default 

instructions.  

The format for an entry in the table.pnt file is as follows: 

pen # pattern values units; thickness value units; color values; 
<color_name>; 

Note: For each pen definition, the pen number (pen #) must be the first entry and 

the color name (color_name) the last entry. Other attributes can be in any order. 

• pattern—Specifies plotted line font definition drawn according to defined values 

in the given units. Values are created in the following order: first line segment 

length, first space length, second line segment length, second space length, and 

so on. For example: pen 3 pattern .1 .05 .025.05. 

• thickness—Specifies plotted line thickness in the given units. 

• color—Specifies color used for plotting; defines color using proportions of red, 

green, and blue on a scale 0 to 1. Works only on color plotters. 

• <color_name>—Corresponds to the default Pro/ENGINEER color that the system 

assigns to a particular entity type (to access the default system colors, click View 
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> Display Settings > System Colors, and then, in the System Colors dialog box, 

click Scheme > Default. 

Note: When changing attributes for pen plotting, consider the following: 

• All units must be set in inches (IN) or centimeters (CM). Using millimeters (MM) 

results in a syntax error. 

• It is possible to assign more than one color to the same pen in the table.pnt 

file. 

• Separate multiple color names by spaces or commas. 

• Separate attributes by semicolons.  

• Include any or all attributes for each pen.  

• Attributes that were not included in the table.pnt file appear unchanged, as in 

normal plotting.  

Assigning Colors to Another Pen 

The table.pnt file enables you to reassign Pro/ENGINEER colors to another pen to 

overwrite the default mapping. The following table shows the default correspondence 

between the name of the system color and how it actually appears on the screen.  

Note: All colors can be toggled by using the Use Pre-Wildfire Scheme tab in the 

System Colors dialog box (View > Display Settings > System Colors). 

Color Correspondence Table 

COLOR_NAME Visible Color 

attention_color dark green 

letter_color yellow 

highlite_color dark red 

drawing_color white 

half_tone_color gray 

magenta_color purple 

edge_highlite_color green 

dimmed_color dark gray 

section_color blue 

presel_highlight_color cyan 

datum_color brown 
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COLOR_NAME Visible Color 

quilt_color magenta 

selected_color red 

secondary_selected_color orange 

preview_geom_color yellow 

secondary_preview_color pale yellow 

If you change a default color using the System Colors dialog box, the 

Pro/ENGINEER maintains the color_name that corresponds to entities that had their 

color changed. However, if you reassign an entity to another line style, this changes 

the associated color_name and Pro/ENGINEER plots the entity as defined for that 

color name. 

Note: Pro/ENGINEER plots entities by their assigned colors. User-defined colors 

always map to Pen 1. If Pen 1 has a default pattern, thickness, and so on, the 

system reflects this default in the plot. 

Example: table.pnt File 

Note: For each pen definition, the pen number (pen #) must be the first entry and 

the color name (color_name) the last entry. Other attributes can be in any order. 

The following is a sample table.pnt file: 

pen 1 color 0.0 0.0 0.7; highlite_color 

pen 2 thickness .5 cm; letter_color 

pen 5 pattern 1.0 0.1 0.5 .01 in; color 1.0 0.0 1.0; drawing_color 

When creating a table.pnt file, you can: 

• Use units in inches (in) or centimeters (cm), and mix them in font definitions; for 

example, you can specify a font pattern in inches and thickness in centimeters. 

• Use the backslash (\) at the end of a line to continue the entry on the next line. 

• Use an exclamation point (!) at the beginning of a line in the file to make it a 

comment. 

The following is another example of a table.pnt file: 

!Exclamation points denote comment lines in the file 

! 

!Change yellow entities to plot w/ pen 1 

pen 1 thickness 0.1 cm; letter_color 

! 

Change hidden lines to plot w/ pen 2 
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pen 2 pattern 0.1, 0.1 in; thickness 0.1 cm; half_tone_color 

!change geometry lines to pen 3 

pen 3 drawing_color 

! 

Green sheetmetal lines to pen 5 

pen 5 thickness 0.1 in; attention_color 

Specifying a Default Pen Mapping Table 

Pro/ENGINEER uses the default pen mapping table file unless another pen mapping 

file exists and Pro/ENGINEER is configured to use it. The default pen table file 

location is <loadpoint>/text/table.pnt. To use other pen tables, you must 

specify them as full path names in a plotter configuration file (.pcf) or in the 

config.pro file, or they must be in the current directory.  

To specify the default pen mapping, remove any reference to pen table files from the 

config.pro and plotter configuration files (.pcf), and remove any file named 

table.pnt from all working directories. 

When you specify a Pro/ENGINEER entity for plotting, the system assigns it a pen 

based on the default system color corresponding to this entity type. When it plots 

entities, it uses the line width and line font associated with a particular color. For 

example, the system uses pen #1 to plot all entities that appear in Pro/ENGINEER 

using the Geometry index (white by default) and have the same line width and 

thickness. 

If your plotter supports eight plotter pens, and you want to use them for plotting, set 

the configuration file option use_8_plotter_pens to yes. The following table 

illustrates the default pen mapping that occurs. A plotter that supports four pens 

uses the first four pens listed in the table. 

Pen Number System Color Mapping 

1 Geometry (white) 

Curve (dark blue) 

Manufacturing 

Volume (purple) 

Quilt (magenta) 

Datum (brown) 

Preselection 

Highlight (cyan) 

Preview Geometry 

(yellow) 

Secondary Preview 

Geometry (pale 

Visible geometry (plot as solid 

lines, except where noted): 

Cross-section cutting plane lines: 

plot as phantom lines 

Cross-section cutting plane arrows 

and text 

Drawing format and boundary 

Tag text  

Centerline line font with white color 

Brown portion of datum planes 
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Pen Number System Color Mapping 

yellow) 

2 Letter (yellow) All items plot as solid lines (except 

where noted): 

Dimension lines 

Leaders 

Axes and centerlines: plot as 

centerlines 

Geometric tolerance lines 

All text (except cross-section text) 

Balloon notes 

Cross-hatching 

Centerline line font with yellow 

color 

3 Hidden Line (gray) Hidden lines: plot as dashed lines, 

phantom font 

4 Highlight-Primary 

(dark red) 

Selected (red) 

Secondary Selected 

(orange) 

All items plot as solid lines: 

Spline surface grid (does not plot in 

drawings) 

5 Sheet Metal (dark 

green) 

Sheet metal color entities 

6 Sketched Curve 

(blue) 

Sketcher section entities 

7 Highlight- 

Secondary (dark 

gray) 

Toggled sections, grayed 

dimensions and text, dimmed 

tangent edges 



Pro/ENGINEER Fundamentals – Help Topic Collection 

120 

Pen Number System Color Mapping 

Dark gray portion of datum planes 

8 Highlight-Edge 

(green) 

Spline surface grid 

Plotter Configuration Files 

You can save or modify a .pcf file with the name of the text in the Destination box 

in the Print dialog box or create from a file. 

When Pro/ENGINEER is installed, plotter configuration file options are available in 

addition to those that you define within the plotter configuration file directory.  

You can also use a plotter configuration file (filename.pcf) in interactive and batch 

plotting to preset some or all of the plotting options. Pro/ENGINEER displays the 

name of your .pcf file without the extension in the list available from the button to 

the right of the Destination box in the Print dialog box. If your .pcf file has the 

option button_name defined, this string appears in the list. 

When creating plotter configuration files, keep in mind the following requirements: 

• You can maintain a plotter configuration file locally, or place it in another 

location. If you place it somewhere else, you must indicate its location by setting 

the config.pro configuration file option pro_plot_config_dir. 

• You must enter the contents and the name of the plotter configuration file in 

lowercase characters. 

• The plotter option is mandatory. 

• All numeric arguments for the plotter configuration options are mandatory. 

The following sample shows a plotter configuration file: 

plotter postscript 

plotter_command plot 

plot_names yes 

rotate_plotting no 

paper_size e 

plot_segmented yes 

plot_scale model 2 

In the preceding example, the .pcf file instructs the system to print any size 

drawing to an E-size Postscript printer. Notice that the configuration file is set up to 

generate a segmented plot.  
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Plotter Configuration Options 

The following is a list of plotter configuration options. The default values are in italic. 

Note: These options are not the same as Pro/ENGINEER configuration file options. 

allow_file_naming 

yes, no  

yes—Enters the name of the plot file. 

no—Uses the name of the object as the default name for the plot file. 

button_name  

string 

Adds the specified name to the selection list. Otherwise, the name of the plotter 

configuration file is used. 

button_help  

string 

Provides one-line help for an item specified by the button_name option. 

create_separate_files  

yes, no  

Defines the default in the Print to File dialog box. 

yes—Creates separate files by default. 

no—Creates a single file by default. 

delete_after_plotting  

yes, no  

yes—Deletes the plot file from the directory after it plots successfully. 

interface_quality  

0, 1, 2, 3  

Defines the amount of checking for overlapping lines in a plot or 2D export file, such 

as IGES, before making a file. 

0—Collects lines of the same pen color but does not check for overlapping lines. 

1—Collects lines of the same pen color for plotting but does not check for 

overlapping lines. 

2—Collects lines of the same pen color for plotting and partially checks edges with 

two vertices. 

3—Completely checks all edges against each other, regardless of the number of 

vertices, font, or color. Collects lines of the same pen color for plotting. 

paper_size  

paper size, <variable> X Y units 
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Specifies particular paper size to which to plot (for example, A1). You can specify a 

custom size by entering a variable, followed by the paper dimensions and units. 

paper_size_allowed  

List of possible paper sizes 

Specifies all of the paper sizes (separated by spaces) you can use for your plotter 

model, for example, a b c. This limits sizes in the Size list to only those in your list. 

pen_slew  

no_slew, value 

Sets the plotter pen speed along both the x-axis and the y-axis, where the value can 

be from 0.1 to 100. 

pen_table_file  

path and file name 

Specifies a default pen mapping table that supersedes other pen mapping 

information. Paths can contain up to 260 characters. 

plot_area  

yes x1 y1 x2 y2, no  

Sets the Plot Area button in the Plot list of the Shaded Image Configuration dialog 

box as the default. 

plot_access  

create, append, default 

Creates a new plot file, or appends the new data to another plot file. 

plot_clip  

yes x1 y1 x2 y2, no, default 

yes—Plots a portion of the drawing. The x- and y-coordinates are mandatory. They 

are normalized values from 0.0 to 1.0 (0,0 corresponds to the lower-left corner of 

the plot) that indicate which portion of the window to plot. For example, to clip half 

of the window in the center of the screen, set plot_clip yes 0.25 0.25 0.75 
0.75. 

plot_destination 

file, printer, and file_and_printer 

Directs plotting to write to a file, plot to a printer, or to write and plot. You can also 

specify this destination in the Print dialog box (File > Print) by clicking or clearing 

the To file and To printer check boxes. 

plot_drawing_format  

yes, no, default 

no—Generates a plot without format. 

plot_file_dir  
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directory name 

Specifies the directory to which plot files are written. Use the full path name, for 

example, /home/users/plotfiles. Paths can contain up to 260 characters. 

plot_label  

yes, no, default 

yes—Generates the plot with a label.  

plot_label_height  

<value> in, <value> cm 

Sets the height of the plot labels. Enter a numeric value for this option, followed by 

the units in inches (in) or centimeters (cm). 

plot_layer  

current, by_layer #, default 

by_layer—Specifies a layer of the drawing to plot where # is the layer ID number. 

plot_linestyle_scale  

any positive number, 1.0  

Specifies the scaling factor for the hidden line font in your plot. Enter any positive 

number, such as 2.0, as a value for this option. 

plot_names  

yes, no 

yes—Adds descriptive extensions to plot files when it creates them. The extensions 

are: 

• hp—Hewlett-Packard plotters 

• hp2—Hewlett-Packard hpgl2 plotters 

• cal—Calcomp plotters 

• ver—Versatec plotters 

• ger—Gerber photoplotters 

• ps—PostScript plotters (including color) 

no—Adds the extension .plt to all plot files. 

Note: Pro/BATCH does not support this option. 

plot_roll_media  

yes, no 

yes—Uses roll paper for the media type. 

no—Uses the  default setting of the particular printer for media type. 

plot_scale  
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fit_paper, model #, plot #, default  

Specifies a scale factor for scaling a model or drawing for plotting, where # is the 

scale value from 0.01 to 100.0.  

plot_segmented  

yes, no, default  

yes—Generates a segmented plot. 

plot_sheets  

current, range <low value> <high value>, default, all  

Specifies sheets to plot. To indicate a range of sheets, set this option to range, 

followed by the low and high values for the range, such as plot_sheets range 2 3. 

plot_translate  

<value>, <x value> <y value>, <x value> <y value> <units> 

Sets the offset of the plot from its origin. Enter only the x-offset value or both the x-

offset and y-offset values. You can only specify units (such as mm) when you have 

given the offset in both directions. For example: 

plot_translate .25 

or 

plot_translate .25 .35 for offsetting 0.25 in the x direction and 0.35 in the y 

direction. 

Note: When a single value is given, it is used for both x and y. 

plot_to_scale_full_window  

yes, no  

Scales the output plot file to the full size of the screen window. 

plot_with_panzoom  

yes, no  

yes—Bases plot on zoom. 

no—Plots full plot. 

plotter_command  

command, windows_print_manager <plotter or printer name> 

Specifies the command for to use when sending a plot to the printer. 

• In UNIX, specify a plotter command as: 

plotter_command lp -d <plotter_name> 

or  

plotter_command lpr -P <plotter_name> 
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• In Windows specify the plotter command as: 

plotter_command windows_print_manager <plotter or printer name>. 

plotter_handshake  

hardware, software  

Sets the type of plotter handshake initialization sequence, generated in the plotter 

files. For each mode, you must set the data port of the host computer appropriately: 

• Software handshake mode is Xon/Xoff. 

• Hardware handshake mode requires hardware control. 

Note: Consult your system administrator for more information on handshaking. 

plotter  

<plotter name>  

Sets the default plotter when making plot files. This option is mandatory. 

rotate_plotting  

yes, no  

yes—Rotates a PostScript plot 90 counterclockwise when plotting (portrait). The 

horizontal on the screen corresponds to the short edge of the paper. 

no—Does not rotate a PostScript plot. Plotting of parts and assemblies assumes a 

landscape format. The horizontal on the screen corresponds to the long edge of the 

paper. 

Note: This does not affect shaded PostScript output. 

Plotting Views Directly 

About Directly Plotting 3D Views 

While using the Standard application (Part or Assembly), use the Quick Print 

command (File > Quick Print) to directly plot views for the active model, without 

manually creating a drawing.  

By specifying one of the following layouts and a printer configuration file, you can 

create the plot: 

• Manual Layout—Specifies the number of views per sheet, named views and a 

scale for each named view, and a display style for each view.  

• Projection Layout—Selects the projection layout based on a named view.  

• Drawing Template—Uses a template to define all aspects of the layout, except 

for the printer configuration. 

The plot reflects the layer settings, simplified representation state, explode state, 

and zone clipping for the current model, and appears as if a drawing were created 
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and plotted. The file used to create the plot is automatically erased from your 

Pro/ENGINEER session. 

Note:  

• In Part, Quick Print is not available for simplified representations. 

• In Assemby, Quick Print is available for geometry and graphics representations 

but not for symbolic representations. 

Configuring for Direct Plotting 

Use the following configuration options when you set up for direct plotting: 

• quick_print_plotter_config_file—Specifies the path for the default plotter 

configuration file (.pcf) when using the Quick Print command.  

If plotter is set to ms_print_mgr, no other options are necessary. If it isn't set to 

ms_print_mgr, adding to the plotter configuration file the values for 

plot_file_dir and plotter_command is recommended.  

If you do not set quick_print_plotter_config_file, it defaults to 

<Pro/E_loadpoint>/text/plot_config/postscript.pcf on UNIX and <Pro/E 
loadpoint>/text/plot_config/ms_print_mgr.pcf on Windows. 

Note: The .pcf defined in the Quick Print dialog box overrides the configuration 

option setting. 

• quick_print_drawing_template—Specifies the path for the default drawing 

template file when using the Quick Print command with Drawing Template 

selected as your View Layout definition.   

Some settings in the Quick Print dialog box may conflict with settings in the plotter 

configuration file. For example, plotter configuration file settings for plot_access 

and allow_file_naming may be overwritten by settings in Quick Print. 

Some settings in the plotter configuration file are ignored by Quick Print because 

they do not apply to Quick Print. Settings in the plotter configuration file that are 

ignored by Quick Print include paper_size and paper_size_allowed. Plotter 

configuration options that work with Quick Print include plot_label, plot_sheets, 

plot_file_dir, and plot_segmented. 

To Directly Plot a 3D View 

To use a default plotter configuration or drawing template (when Drawing 

Template is selected for a view layout), set the configuration options 

quick_print_plotter_config_file and quick_print_drawing_template before 

you use the Quick Print command. Setting this configuration options eliminates the 

need to type a path or browse to these files from the Quick Print dialog box. 

1. Open a part or assembly and click File > Quick Print. The Quick Print dialog 

box opens. 

Note: The Quick Print command is available while using the Standard (Part 

and Assembly) application only. 
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2. Click a View Layout Definition. 

o Projection Layout—Selects the projection layout based on a named main 

view.  

o Manual Layout—Specifies the number of views, view layout, view scale, 

and view display style. 

o Drawing Template—Specifies a drawing template so you do not need to 

specify view name, view scale, and display style for each view. 

3. Depending on your View Layout Definition selection, click the appropriate 

procedure below: 

o To Plot Using a Projection  

o To Plot Using a Manual Layout  

o To Plot Using a Drawing  

To Plot Using a Projection Layout View 

After you click File > Quick Print, the Quick Print dialog box opens. Follow the 

procedure below when you select Projection Layout as your View Layout 

Definition. 

1. In the Plot Config File box, type the path to your plotter configuration .pcf file 

or click Browse and select the file. 

Note: If you have set the configuration option 

quick_print_plotter_config_file, the path to the plotter configuration file is 

automatically defined. You can override the configuration option by typing a path 

to or browsing to another .pcf file. 

2. Click Portrait or Landscape to specify the orientation of the sheet, and click the 

Standard Sizes box to select the size of the sheet. 

3. To use the same view scale and display style for all views, click the Use View 

Scale for all views and Use Display Style for all views check boxes. Note the 

View Scale and Display Style defaults for the Main View are listed in the 

Views area of the dialog box. 

Note: To assign unique view scales and display styles, clear these check boxes. 

4. Click the Saved View Name box for the Main view and select another name, or 

keep the default Standard Orientation name. 

5. Click in the View Scale and Display Style boxes to select a new values or style, 

or accept the defaults for the Main view. 

6. In the View Layout area click the projection views you want. Projection views 

determine view layout and positioning. 

Note: Projection views are the unlabeled boxes in the View Layout area. 
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7. Click a general view if needed. Each general view is listed in the Views area of 

the dialog box.  

o If you selected Use View Scale for all views or Use Display Style for 

all views, the values for View Scale and Display Style initially default to 

the values for Main. If you change a value for View Scale or Display 

Value for the Main View or any general view, then that value changes for 

all views listed. 

o If you cleared Use View Scale for all views and Use Display Style for 

all views check boxes, then you can make changes for Main or any 

general views, without affecting other values.  

8. Click OK to plot the part or assembly. 

Note:  

o If the plotter configuration file cannot be found, is missing required values, 

or is generating plotter errors, then an error dialog box opens after you 

click OK. Depending on the error, you can redirect to the correct plotter 

configuration file or edit the plotter configuration file from the dialog box.  

o If you have defined a model grid, and you are plotting a Project Layout 

View or Manual Layout View, the model grid is automatically plotted for 

all views with the correct orientation. For information on defining a model 

grid, see Detailed Drawings help. 

To Plot Using a Manual Layout View 

After you click File > Quick Print, the Quick Print dialog box opens. Follow the 

procedure below when you select Manual Layout as your View Layout Definition. 

1. In the Plot Config File box, type the path to your plotter configuration .pcf file 

or click Browse and select the file. 

Note: If you have set the configuration option 

quick_print_plotter_config_file, the path to the plotter configuration file is 

automatically defined. You can override the configuration option by typing a path 

to or browsing to another .pcf file. 

2. Click Portrait or Landscape to specify the orientation of the sheet and click the 

Standard Sizes box to select the size of the sheet. 

3. In the Number of Views box, select the number of views (maximum 4). 

o Available configurations for the number of views you select appear in the 

View Layout area.  

o An entry for each view appears in the Views area. 

o If you select more than one view, the Use View Scale for all views and 

Use Display Style for all views check boxes become available. 

4. Click the View Layout that you want. For example, you can select from the 

following layouts when you select 3 views. 
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5. If you select to have more than one view, and you want to use the same view 

scale and display style for all views, click the Use View Scale for all views and 

Use Display Style for all views check boxes.  

Note: To assign unique view scales and display styles, clear these check boxes. 

6. For each view listed in the Views area:  

o Click the Saved View Name box and select another name, or keep the 

default Standard Orientation name. 

o Click the View Scale and Display Style boxes to select a new values or 

style, or accept the defaults. 

If you selected Use View Scale for all views or Use Display Style for all 

views and you change a value for View Scale or Display Style for view, 

then that value changes for all views listed. 

If you cleared Use View Scale for all views and Use Display Style for 

all views check boxes, then you can make changes for a view, without 

affecting values for other listed views..   

7. Click OK to plot the part or assembly. 

Note:  

• If the plotter configuration file cannot be found, is missing required values, or is 

generating plotter errors, then an error dialog box opens after you click OK. 

Depending on the error, you can redirect to the correct plotter configuration file 

or edit the plotter configuration file, from the dialog box. 

• If you have defined a model grid, and you are plotting a Project Layout View or 

Manual Layout View, the model grid is automatically plotted for all views with 

the correct orientation. For information on defining a model grid, see Detailed 

Drawings help. 

To Plot Using a Drawing Template View 

After you click File > Quick Print, the Quick Print dialog box opens. Follow the 

procedure below when you select Drawing Template as your View Layout 

Definition. 

1. In the Drawing Template box, type the path to your drawing template (.drw) 

file or click Browse and select the file.  
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Note:  

o If you have set the configuration option quick_print_drawing_template 

this is automatically defined for you. You can overwrite the configuration 

option by typing a path to or browsing to another .drw file. 

o For more information on Drawing Template, see About Drawing Templates 

in Detailined Drawings. 

2. In the Plot Config File box, type the path to your plotter configuration (.pcf) 

file or click Browse and select the file. 

Note: If you have set the configuration option 

quick_print_plotter_config_file, the path to the plotter configuration file is 

automatically defined for you. You can overwrite the configuration option by 

typing a path to or browsing to another .pcf file. 

3. Click OK to plot the part or assembly. 

Note:  

o The Quick Print command plots only what is on the screen. Settings in the 

drawing template that are in conflict with the current model are ignored.  

o If the plotter configuration file cannot be found, is missing required values, 

or is generating plotter errors,then an error dialog box opens after you click 

OK. Depending on the error, you can redirect to the correct plotter 

configuration file or edit the plotter configuration file, from the dialog box. 

Exiting Pro/ENGINEER 

To Exit Pro/ENGINEER 

1. Click File > Exit. A Confirmation message appears. 

2. Click Yes. 

Note: 

• Set the configuration option allow_confirm_window to no to prevent the 

CONFIRMATION dialog box from opening. 

• Set the configuration option prompt_on_exit to yes.so you are prompted to 

save your files before you exit Pro/ENGINEER. 

The Edit Menu 

About the Edit Menu 

Use the commands on the Edit menu to perform a wide variety of editing operations. 

Depending on the application in which you are working, different commands may 

become available. For example, some commands are not available in the Standard 

part and assembly modes but are available in the Standard drawing mode. You can 
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also access many of the same editing commands from shortcut menus that are 

available when selecting items in the model tree or in the graphics window. 

Edit menu commands in the Standard part mode include the following: 

• Pro/ENGINEER editing features, Mirror, Fill, Intersect, Merge, Pattern, 

Project, Wrap, Trim, Extend, Offset, Thicken, and Solidify 

• Regenerate—Regenerates the model. 

• Undo—Removes the last operation in the current session and restores the model 

to the existing state before that operation. 

• Redo—Redoes the last operation you performed. 

• Copy—Copies the selected object to the clipboard. 

• Paste—Pastes the object from the clipboard 

• Paste Special—Pastes the object from the clipboard dependently. 

• Flip Normal—Flips the normal of a surface or quilt. 

• Suppress—Suppresses the selected features. 

• Resume—Resumes the selected suppressed features. 

• Delete—Deletes the selected features, 

• Properties—Opens the Dimension Properties dialog box after you select one 

or more dimensions. 

• Setup—Activates the PART SETUP menu from which you can define items such 

as material, units, accuracy, and mass properties. 

• References—Activates the REROUTE REFS menu from which you can Reroute 

the references of the selected item. 

• Definition—Opens the dashboard so that you can redefine the selected feature. 

• Pattern Table—Opens the Tables dialog box from which you can modify the 

table pattern  

• Scale Model—Prompts you to enter a scale for the dimension of the active 

model. 

• Feature Operations—Activates the FEAT menu, from which you can access 

commands to manipulate features. 

• Select > Preferences—Opens the Selection Preferences dialog box from 

which you to set the selection behavior preferences for selectable items in the 

Graphics window. You can also turn preselection highlighting on or off.  

• Select > Deselect All—Deselects all selected items. 

• Find—Opens the Search Tool dialog box from which you can search for, filter 

and select model items. 

• Hyperlink—Adds, removes, or edits a hyperlink to the selected text. 
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• Read Only—Activates the R-ONLY FEAT menu from which you can designate a 

feature as read only. 

About Undoing and Redoing Actions 

The Undo and Redo commands are available for many actions in Pro/ENGINEER. 

When working in a feature tool, you can undo and redo actions performed during the 

feature definition session. After you create a feature, save changes, and close the 

tool, you can undo the feature as one item. For example, when working in the 

Pro/ENGINEER graphics window, you can undo dimensions as many times as you 

change them. Specific Undo and Redo commands appear in the Edit menu and as 

tool tips, so you can confirm the desired action. The general_undo_stack_limit 

configuration option controls the number of times you can undo or redo actions. The 

default and maximum is 50. 

Note: The undo and redo functionality requires additional memory allocation and 

may result in some change in performance. 

What Actions Support Undo and Redo? 

The undo and redo functionality is supported for actions that you perform while 

working in Standard part, Sheetmetal, Assembly, Welding, Sketcher, and Drawing 

modes. 

Undo and redo actions are session- and window-based. The actions are sequentially 

stacked in memory. You can undo and redo most of the operations performed on a 

model. These include key feature operations such as: 

• Creating and deleting 

• Redefining (excluding redefinition of inheritance or features from a copy by 

reference) 

• Suppressing and resuming 

• Creating and deleting patterns 

• Grouping and ungrouping 

• Rerouting (excluding replace reference) 

• Reordering 

• Editing 

• Creating and changing relations and parameters 

• Family tables, visible or invisible instances of a family table in a session 

• Data Sharing Features 

• Interface features and Facet features 

• Simplified Representations (You can undo operations performed in simplified 

representation but not the operations of creating or modifying simplified 

representations). 
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How to Use the Undo and Redo Commands 

• Click  to undo or  to redo. 

• Use the Undo and Redo commands on the Edit menu. 

• Press CTRL+Z to undo or CTRL+Y to redo. 

Undo and Redo Command Considerations 

For actions that cannot be undone, one of the following occurs: 

• You can undo prior actions for commands such as Edit > Regenerate. For 

example, you cannot undo Edit > Regenerate, but you can undo actions prior to 

Edit > Regenerate until the stack is not cleared. 

• Some commands clear the Undo/Redo stack, in which case you cannot perform 

an undo operation. For example, clicking File > Erase > Current > Yes clears 

the stack. 

• You cannot undo actions prior to commands such as Insert > Independent 

Geometry. However, you can undo the Insert > Independent Geometry 

command. 

• When you activate a part in assembly mode and modify the part, you can undo 

only those changes that are made to the part. However, you cannot undo the 

action of activating the part. 

Note: 

• Within Sketcher, the sketcher_undo_stack_limit configuration option controls 

the number of times you can undo or redo operations. The default is 200 and the 

maximum is 500. 

• In the Style tool, you can perform any number of undo or redo operations. 

• When fixing a model, you can only use Undo Changes on the Fix Model menu. 

General undo and redo functionality is not available. The Undo/Redo stack is 

cleared when you fix the model using Fix Model > Undo Changes. 

To Select Locations in the Graphics Window Using the Keyboard 

If you do not want to or are not able to use the mouse, you can use the keyboard to 

select objects and specify locations in the graphics window. 

1. Set the configuration option kbd_selection to yes.  

Note: Click Tools > Options to set a configuration option. 

2. Click Edit > Select > By Keyboard. The Select Location dialog box opens and 

 (crosshairs) is displayed in the Graphics window. Use  to select objects and 

specify locations in the graphics window. To navigate through the Select 

Location dialog box press TAB or SHIFT+TAB. 

Note: The color of the crosshairs varies. 
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3. In the Horizontal Position box, type the relative horizontal location of where 

you want  in the Graphics window. The crosshairs move to the specified 

horizontal position. 

4. In the Vertical Position box,  type the relative vertical location of where you 

want  in the Graphics window. The crosshairs move to the specified vertical 

position. 

5. Repeat Steps 2 and 3 until  is in the position you want or select one of the 

position boxes and use the UP ARROW or the DOWN ARROW to change the value. 

The crosshairs move, changing position.  

6. To change the size of the box surrounding the crosshairs, type a new value 

between 1 and 500 in the Selection Size box. The default value is 7. The value 

corresponds to the distance between the center of the crosshairs and the sides of 

the box.  

Note: To change the default  Selection Size value, use the configuration option 

pick_aperture_radius. 

7. Do one of the following: 

o Click Select for left-click actions. All objects within the box surrounding the 

crosshairs are selected. 

Note: When working in a sketch or a drawing, only the entity closest to the 

crosshair intersection is selected. 

o Click Middle for middle-click actions. 

o Click Menu for right-click actions. 

The View Menu 

About the View Menu 

The View menu provides options for controlling model and performance display. It 

includes options for setting model orientation, selecting the View Manager, model 

setup such as lighting and perspective, and setting system and entity colors. Using 

View > Visibility >  Unhide All, you can show all objects in the main window. 

About Orient Mode 

Orient Mode (View > Orientation > Orient Mode) gives you more viewing 

capability than the standard spin, pan, zoom. With Orient Mode enabled, you can 

reorient the view with respect to specific geometry and change the style of view 

reorientation such as Dynamic, Anchored, Delayed, Velocity, or Fly Through. 

Orientation Center 

The Orientation Center is displayed by a graphical object that, when clicked with the 

middle-mouse button, reorients the model in various ways. As you spin, pan, or 
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zoom, the Orientation Center is visible. The Orientation Center is locked at the Spin 

Center but can be set anywhere in the graphics window when the Spin Center is 

disabled. 

Spin and Pan Constraint 

You can constrain spin and pan with respect to a derived vector when the Spin 

Center is disabled. The vector is derived by placing the Orientation Center on an 

edge or surface, combined with a drag action; or, if it is already on an edge or a 

surface, by initiating a drag action on the Orientation Center. 

The constraining vector is derived from the object or geometry beneath the 

Orientation Center, and is either linear to an edge or curve, or normal to a solid face 

or surface. 

Note: You cannot select items when Orient Mode is enabled. 

View Type Menu 

When Orient Mode is enabled, you can select the following viewing styles from the 

View Type menu (View > Orientation > Orient Type): 

• Dynamic (default)—The Orientation Center is displayed as . Orientation is 

updated as the pointer moves. The model spins freely about the Orientation 

Center. 

• Anchored—The Orientation Center is displayed as . The orientation is 

updated as the pointer moves. Model rotation is controlled by the direction and 

distance the pointer is moved from its initial position. The Orientation Center 

changes color at each 90-degree interval. When the pointer returns to the 

original mouse-down position, the view is reset to where it started. 

• Delayed—The Orientation Center is displayed as . The orientation is not 

updated as the pointer moves. When the middle mouse button is released, the 

pointer model orientation updates.  

• Velocity—Orientation Center is displayed as . The orientation is updated as 

the pointer moves. The velocity (speed and direction), is the rate of manipulation 

and is affected by the distance the pointer is moved from its initial position.  

• Fly Through—The orientation and position of the model is controlled with flight 

simulator-like interactions. This option is only available if you are using 

 Perspective display (View > Model Setup > Perspective). When the 

Perspective dialog box is opened, the viewer perspective is displayed by . 

Note: You can set the viewing style to dynamic or anchored using the 

orientation_style configuration option. This is irrespective of whether the Orient 

mode is enabled or disabled, that is, you are outside Orient mode or in the Orient 

mode, respectively. When Orient mode is enabled, you may change the viewing style 

as required. 
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Orient Mode Shortcuts 

You can right-click in the graphics area to open the shortcut menu: 

• Show/Hide Spin Center 

• Dynamic 

• Anchored 

• Delayed 

• Velocity 

• Fly Through 

• Exit Orient Mode 

About View Operations 

Using the View menu, you can adjust the model view, orient the view, hide and 

show entities, create and use advanced views, and set various model display options. 

The following list includes some of the View operations you can perform. 

• Orient the model view in the following ways, using the Orientation (View > 

Orientation > Reorient) dialog box: 

o Set the Orientation Center 

o Spin, pan, zoom, and turn models and drawings 

o Spin and pan about edges 

o Display the default orientation 

o Revert to the previously displayed orientation 

o Change the position or size of the model view 

o Change the orientation (including changing the view angle in a drawing) 

o Create new orientations 

• Temporarily shade a model by using cosmetic shading 

• Show, dim, or remove hidden lines 

• Explode or Unexplode an assembly view 

• Repaint the Pro/ENGINEER graphics window 

• Refit the model to the Pro/ENGINEER window after zooming in or out on the 

model 

• Update drawings of model geometry 

• Hide and show entities, and hide or show items during spin or animation 

• Use advanced views 
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• Add perspective to the model view 

About Activating the Orient Mode 

You can activate the Orient Mode by using one of the following methods: 

• Click . 

• Click View > Orientation > Orient Mode. 

• Press SHIFT+CTRL+click the middle mouse button while the pointer is in the 

graphics window. 

After the Orient Mode is enabled, View Type is enabled in the Orientation menu, 

and the Orientation Center and model center display in the graphics window. 

About Disabling the Orientation Center 

You can disable the orientation center by clearing the Orientation center check box 

in the Model Display dialog box that opens when you click View > Display 

Settings > Model Display. To disable the orientation center during spin, pan, or 

zoom operations, set the spin_with_orientation_center configuration option to no 

(default is yes). 

You cannot disable the orientation center when you are in the Orient mode. 

Adjusting the Model View 

About Dynamic Viewing 

Pro/ENGINEER dynamically displays the model as you reorient your view. For 

example, as you spin, pan, zoom or turn an item, you see it change as you move the 

mouse.  

View Behavior 

Spin, Pan, Zoom and Turn are all achieved by clicking the middle mouse button, and 

except for Spin, in combination with either the SHIFT or CTRL key. 

Three-button Mouse 

Spin Press and hold the middle mouse button + move the 

mouse 

Pan Press and hold the middle mouse button + SHIFT + 

move the mouse 

Zoom Press and hold the middle mouse button + CTRL + 

move the mouse vertically 

Turn Press and hold the middle mouse button + CTRL + 
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move mouse horozontally 

Wheel Mouse 

Zoom Place pointer over focused geometry area + spin mouse 

wheel. 

About Handles 

Handles are graphical objects that are used to manipulate geometry during creation 

or redefinition in realtime. Using your mouse, drag the handles to resize, reorient, or 

move feature geometry. Snap handles to existing geometric references or to user-

defined grid increments. Your changes display dynamically in the graphics window.  

Handle display changes at specified intervals to acknowledge your actions, and are 

used in conjunction with the left mouse button, SHIFT and CTRL. 

To Cosmetically Shade a Model 

Use this procedure to apply temporary shading to an image without affecting the 

saved view of the model, and without canceling the view choice for the current 

session. The shading is removed when you repaint the view. 

Do one of the following: 

• Click View > Shade  

• Press ALT+V then S 

Note: Do not use this procedure to shade the model view permanently (so that it 

remains shaded even when reoriented). Instead, click the Shading button. 

To Display the Default Orientation 

When you first create a model, it appears in a default view orientation, such as 

isometric or trimetric. When you open a model, it is retrieved in the orientation in 

which it was last saved. You can change the default orientation by using the 

Orientation dialog box (View > Orientation > Reorient) or the configuration 

option orientation. 

To display the model in the standard orientation, do one of the following: 

• Click View > Orientation > Standard Orientation 

• Click . The Saved Views list opens. 

• Click Default. The model reorients to the default view. 

To Refit the Model to the Window 

Use this procedure to refit the model to the screen so that you can view the entire 

model. A refitted model fills 80 percent of the screen. 
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Do one of the following: 

• Click View > Orientation > Refit. 

• Click the Refit button  on the Pro/ENGINEER toolbar. 

To Revert to the Previously Displayed Orientation 

Do one of the following at any time to resume the previously displayed view: 

• Click View > Orientation > Previous. 

• From the toolbar, click . (Use Customize Screen from the Tools menu to 

place buttons on the toolbar.) 

To Repaint the Window 

You can repaint a view to remove all temporarily displayed information. Repainting 

redraws the screen but does not regenerate the model. 

Do one of the following: 

• Click View > Repaint 

• Click   

• Press ALT + V then R 

• Press CTRL + R 

To Disable Highlighting of Selected Model Tree Items 

Pro/ENGINEER highlights all selected Model Tree items in the graphics window by 

default. If you do not want to highlight selected Model Tree items, you can disable 

this highlighting by clicking Show > Highlight Model from the Model Tree. The 

check mark clears to indicate that Highlight Model has been disabled. All items that 

you select in the Model Tree will not be highlighted in the graphics window. 

To Update a Drawing of Model Geometry 

To update a drawing after making changes to its source model, regenerate the view. 

Regenerating a drawing view is not object-action oriented; you must choose the 

command first, and then select the view. 

Do one of the following: 

• In Drawing mode, click View > Update > Drawing View. 

• Select one or more drawing views. 

• Set the configuration file option auto_regen_views to yes. 
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Orienting the Model View 

About Orienting the Model View 

A model appears in a default view orientation when it is first created and any time it 

is retrieved (provided it was saved in default orientation). You can change the default 

orientation of your model or create new orientations using the Orientation dialog 

box (View > Orientation > Reorient). Using this box, you can do the following: 

• Orient the view dynamically by using the slider bars to spin, pan, zoom, and turn 

the model. You can also use the mouse in the graphics area to spin, pan, zoom, 

and turn the model. 

• Orient the view by reference (default setting). 

• Set a different spin center in the model. The default spin center is the model 

center. You can set the screen center, a specified point or vertex, a specified 

edge or axis, or a coordinate axis as the new spin center. 

By default, the Spin Center symbol is present on the model at all times. This can 

be set using the configuration file option spin_center_display. The symbol is 

similar to that for a Coordinate System, except for the following: 

o The three axes of the spin center are, by default, in three different colors—

x-axis red, y-axis green and z-axis cyan, whereas all three axes of a 

coordinate system are yellow. 

o A small solid ball is positioned at the tip of each axis of the spin center. 

As you spin the model, the spin center rotates synchronously with the movement 

of the mouse. In addition, the balls at the ends of the axes grow larger as they 

move towards you (out from the screen) and smaller as they move away from 

you (into the screen). You can determine the relative orientation of the model at 

any time by inspecting the axes of the spin center. 

• Choose a saved view orientation. 

• Fit the model to the screen. 

• Select a new screen center. 

• Create a user-defined view orientation by specifying the reference axes and 

angles to rotate the model around each axis. 

You can also use the Orientation dialog box to orient a draft view. In this case, the 

dialog box provides some different options for orienting a selected draft view. 

About Saved Views 

Saving a view saves the orientation of the view relative to the screen and any pan 

and zoom orientation associated with the view. 

When you save views, the display is based on the default orientation of the model. If 

you change the default orientation of the model (for example, from isometric to 

trimetric), the orientation of saved views changes along with it. 
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If they are recalled with some of their view orientation references missing, saved 

views retain their orientation but do not retain the history of how that orientation 

was achieved. 

Note: Views created within instances of a generic model cannot be saved; only views 

created for the generic can be saved. 

Orientation Dialog Box 

A model appears in a default view orientation when it is first created and any time it 

is retrieved. You can change the default orientation of your model or create new 

orientations using the Orientation dialog box. 

In Drawing mode, you can also change the orientation of draft views by using the 

Orientation dialog box. 

To open the Orientation dialog box, do one of the following: 

• Click View > Orientation > Reorient. The Orientation dialog box opens with 

Orient by Reference selected under Type. 

• In Drawing mode, right-click on the drawing view. Select Reorient. The 

Orientation dialog box opens. If the selected view contains child views, you will 

be prompted to continue. Click Yes to continue.  

The following orientation types are available: 

• Angles (available only for Drawings)—Lets you orient a drawing view by 

specifying an angle reference (Normal, Vertical, Horizontal, or Edge/Axis) and an 

angle value. All angles that you specify are listed in the Reference area. 

• Dynamic Orient—Lets you orient the view dynamically by using the settings for 

panning, zooming, and spinning. Available for 3-D models only. 

• Orient by Reference—In Part, Assembly, or Drawing mode, lets you select 

references by which to orient the model or drawing view. In Part or Assembly 

mode, you can select multiple surfaces as orientation references. The options are 

Front, Back, Top, Bottom, Left, Right, Vertical Axis, and Horizontal Axis. 

• Preferences—This area contains different choices depending on whether you are 

in Part or Assembly mode, or in Drawing mode. 

o It lets you define the spin center for 3D models (Part and Assembly 

modes). 

o It lets you change the default orientation for parts, assemblies and 

drawings. The default view is Trimetric. You can set the view orientation to 

Isometric or User Defined. In a user-defined orientation, you specify 

angles to rotate the model around the X and Y axes. 

o It lets you set the view origin for a specified drawing view as either the 

default origin or a user-defined (custom) origin. To do so, you select a 

reference object within the specified drawing view. 

• Saved Views—In Part, Assembly, or Drawing mode, lets you name or save a 

view, or retrieve a previously saved view. 
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• Undo—In Part, Assembly, or Drawing mode, lets you undo the changes you made 

in the Orientation dialog box and returns you to the most current view state in 

the model or drawing. 

Tip: Orienting a View by Reference 

You can orient your model by selecting multiple surfaces to use as references in 

orientation. These references can be Front or Back (parallel to the screen), Top or 

Bottom (normal to the screen facing up or down), and Left or Right (normal to the 

screen and facing left or right). The model automatically reorients itself after the 

second surface has been selected.  

If two different parallel surfaces are selected before a normal surface is selected, the 

second selection overrides the first. You can also orient your model by selecting a 

single horizontal or vertical axis for orientation. 

Tip: Shortcut for Display of Saved Views 

To display a model or drawing in one of the saved view orientations, do one of the 

following: 

• Click View > View Manager. This invokes the View Manager dialog box. 

Select a view from the list, then click Set. In the graphics window, the model 

orients to the selected saved view. 

• Click the Saved View List toolbar button. A small selection box opens, listing all 

saved views. Select the name of the desired saved view. The model reorients to 

the selected view. 

Note: Views created for instances of a generic model cannot be saved; only the 

views created for the generic can be saved. 

Tip: Shortcuts for Changing the Model View 

You can use the following toolbar buttons to adjust the model view: 

• —Zooms in 

• —Zooms out 

• —Refits the object to the window 

• —Spins the object around the spin center 

• —Enters Viewing mode 

• —Displays the saved view list 

• —Reorients the view 
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You can also spin, pan, zoom, and turn with the mouse, by doing the following: 

• Spin—Hold down the middle mouse button and drag the mouse. 

• Pan—Hold down SHIFT, the middle mouse button, and drag the mouse. 

• Zoom—Hold down CTRL, the middle mouse button, and drag the mouse 

vertically. 

• Turn—Hold down CTRL, the middle mouse button, and drag the mouse 

horozontally. 

About Using Zoom on the Model 

You can zoom in on a part or assembly to define the individual features that are 

necessary for the part or assembly that you are creating. You zoom in on target 

geometry by framing the target geometry in a zoom box. The following illustrates 

how to zoom in using the zoom box: 

Zoom in 

 

1 Target geometry 

2 Zoom box start point 

3 Zoom box end point 

4 Zoom box 

You can zoom out on a part of assembly to gain a wider perspective of the 

geometrical context. This perspective helps you better understand how the individual 

features that you created for the part fit into the overall model design. The following 

illustrates various zoom out states: 

Zoom out 
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To Zoom on the Model View 

1. If you want to zoom out on the model, skip to step 6. 

2. To zoom in on the model, place the pointer above and to the left or right of the 

target geometry in the graphics window. This area is the zoom box start point. 

3. Press CTRL and middle-click. The pointer changes to . Note that you hold the 

CTRL key but release the middle mouse button. 

4. Drag the mouse diagonally over the target geometry and center the geometry in 

the zoom box. As you drag, the zoom box is created. 

5. Middle-click to define the zoom box end point. The end point is diagonally 

opposite of the start point. Pro/ENGINEER immediately zooms in on the target 

geometry. Note that to cancel zoom in, simply release the CTRL key. 

6. If you want to zoom out on the model, click  or use the scroll wheel on your 

mouse. 

Tip: 

• You can also click  to create the zoom box. 

• You can manually zoom in or zoom out on target geometry by using the scroll 

wheel on the mouse. If you do not have a scroll wheel,  place your pointer over 

the target geometry. Then press and hold the CTRL key and the middle mouse 

button, and drag up and down (left and right spins the model). 
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• If you want to manually zoom in or zoom out using the Zoom slider or by typing 

a zoom value, click . On the Orientation dialog box, select Dynamic orient 

from the Type box and use the Zoom slider. Note that negative values zoom 

out. 

• If you need to refit the model to the screen, simply click . 

To Change the Position or Size of the Model View 

You can adjust the angle of spin, size, or centering of an object in the active window, 

using the View menu and various options in the Orientation dialog box. 

1. Click View > Orientation > Reorient. The Orientation dialog box opens with 

the Type set to Orient by Reference. 

You may do any of the following to change size or position of your model view: 

• From the Type box, select Dynamic Orient to adjust Pan, Zoom and Spin 

settings. 

• Click Refit to redisplay the entire model in the window. 

• To select a new centerpoint, click Center, then select a new centerpoint in the 

graphics window. The model adjusts its position to the new centerpoint. 

• Under Options > Spin, do one of the following: 

o Click the Spin Center button ( ) to spin the object around its spin 

center. Move the X ( ), Y ( ), or Z 

( ) sliders, enter adjustment values, or click the up or down 

arrows to adjust the spin around the X, Y, or Z axes. 

o Click the Screen Center button ( ) to spin the object around the 

screen horizontal, screen vertical, or normal-to-screen axis. Move the H 

( ), V ( ), or C ( ) sliders, 

enter adjustment values, or click the up or down arrows to adjust the spin 

around the horizontal (X), vertical (Y), or center (Z) axes.  

• Click the Dynamic update check box to enable or disable viewing the view 

change as you make adjustments. 

2. Click OK to accept the orientation changes and close the Orientation dialog box, 

Undo to undo your orientation changes and start over, or Cancel to close the 

dialog box without saving the changes. 
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To Change the View Angle in a Drawing 

When you add a new general view in a drawing, the Drawing View dialog box 

opens automatically. To change the angles in a drawing view with respect to the 

normal, the horizontal, the vertical, or a specified edge or axis: 

1. Select a general view to reorient. 

Note: Reorienting a view reorients its children views accordingly. 

2. Right-click on the selected view and click Properties. The Drawing View dialog 

box opens. 

o By default, the View Type category is selected. 

o The name of the selected view appears in the View name box. 

o The type of view appears as General in the Type box.  

3. Click Angles under View Orientation. When asked for confirmation, click Yes. 

Note: Modifying the view orientation also affects the orientation of the 

highlighted children views. The children views may be on different sheets. 

4. Select the type of reference that you want to specify from the Rotation 

reference list. 

o Normal—Rotates the model around an axis through the view origin and 

normal to the drawing sheet. 

o Vertical—Rotates the model around an axis through the view origin and 

vertical to the drawing sheet.  

o Horizontal—Rotates the model around an axis through the view origin and 

horizontal to the drawing sheet.   

o Edge/Axis—Rotates the model around an axis through the view origin and 

according to the designated angle to the drawing sheet. 

Note: If you have selected Edge/Axis, the SELECT dialog box opens. Select an 

appropriate edge or axis reference on the previewed drawing view. The selected 

reference is highlighted and is listed in the box adjacent to the Rotation 

reference box. 

5. In the Angle value box, type the angular value by which you want to offset the 

orientation. 

6. If required, specify multiple references by using the Add and Remove buttons. 

7. Click Apply to display the model in its default view. 

To Name, Retrieve, Save, or Delete a View 

1. Click the Reorient View toolbar button. The Orientation dialog box opens. 

2. Click the Saved Views bar. The Saved Views dialog box opens. 

3. Select a view or type a name for the current view. 
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4. Select one of the following: 

Save—Type a name for the current view in the Name box (the name can be up 

to 80 characters long), and click Close to save the current view. 

Set—Select a name from the list and click Set (or double-click the name) to 

display the selected view. 

Delete—Select a name from the list and click Delete (or double-click the name) 

to delete the selected view. The current view remains unchanged when a saved 

view is deleted. 

Close—Click to close the Saved Views dialog box. 

Note: To view the list of saved views, click the Saved view list button on the 

Pro/ENGINEER toolbar.  

To Save a View Using the View Manager 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Orient. 

3. Click New. A default name appears for your view. Change the view name or 

press ENTER to accept the default name. 

4. Right-click the new view name and click Redefine on the shortcut menu. The 

Orientation dialog box opens. 

5. Orient the model by references or position the model to the desired view using 

the spin, pan, and zoom commands.  

Note : 

o The active orientation is marked with a red arrow. 

o A plus sign after the view name of the active orientation indicates that the 

orientation has changed. 

6. Click Edit > Save in the View Manager or click Save on the shortcut menu that 

opens when you right-click the view name. The Save Display Elements dialog 

box opens. 

Note: You cannot save the changes to the Standard orientation. 

7. Select the name of the view from the list or type a new name. 

8. Click OK in the Save Display Elements dialog box. 

You can use the Remove, Rename, or Copy commands on the shortcut menu that 

appears when you right-click a view to remove, rename, or copy a view, 

respectively. 
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To Set the Spin Center for an Object 

The default orientation for an object is set to trimetric but can be modified to be 

isometric or user-defined. The default spin center of a model is the model center. 

Use the following procedure to modify it to be any point on the screen. 

Note: You cannot set the spin center for an object in the Drawing mode. 

1. Click View > Orientation > Reorient. 

2. From the Type list in the Orientation dialog box, choose Preferences. 

3. From the Spin Center option buttons in the Options section, select one of the 

following: 

Model center 

Screen center 

Point or vertex—Select a point or vertex on the object. 

Edge or axis—Select an edge or axis on the object. 

Coordinate system—Select a coordinate system on the object. 

4. Under Default Orientation, select the type of default orientation you want to 

create (Isometric, Trimetric, or User Defined), and set the angular position of 

the user-defined default orientation in the X and Y directions. 

5. To name, set, save, or delete the view, click the arrow triangle to the left of the 

Saved Views section, and use one of the following: 

Save—Type a name for the current view in the Name text box and click Save to 

save the current view. 

Set—Select a name from the list and click Set to display the selected view. 

Delete—Select a name from the list and click Delete to delete the selected view. 

6. Click OK to accept the orientation changes and remove the dialog box, Undo to 

undo your orientation changes and start over, or Cancel to abort spin center 

changes and remove the dialog box. 

You can also set orientation using the configuration file option orientation.  

Model Display Options 

About Setting Model Display Options 

The flexibility in setting the model display makes it easy for you to visualize your 

model. For example, you can specify whether to show or hide items or set model 

appearance options (wireframe, hidden lines, shaded, displayed, or removed). Click 

View > Display Settings > Model Display to open the Model Display dialog box. 

Use the Display Style area in the General tab to: 
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• Change the default display style Shading to Wireframe, or specify whether and 

how hidden lines are displayed. 

• Toggle the model color display on or off. 

• Enable Trace Sketch display. 

• Change the display of dimension tolerances for the current Pro/ENGINEER 

session. The dimension tolerances are displayed on the bottom right side of the 

graphics window. 

• Show or hide reference designators. 

• Display cable portions that are inside cabling components. 

• Show or hide datums, surface mesh, silhouette edges, or the Orientation Center 

while reorienting or animating using Display while reorienting. 

• Enable animation by time and frames while reorienting using Animation while 

reorienting. 

Use the Edge/Line tab to: 

• Change the quality and detail of edges and lines.  

• Set the display style of cables to thick or centerline using Cable Display. 

Use the Shade tab to: 

• Change the quality and detail of shaded areas. 

• Set textures, transparency (stippled or blended), and realtime rendering using 

Enable. 

• Set reflection and shadows using Realtime Rendering. 

Setting Model Display Options 

You can specify how you want your model to appear on the screen. The default 

display method is Shading, which allows for efficient visual comprehension of the 

model. Hidden lines are shown as light grey lines in Wireframe display. To set model 

display style, you can use the Model Display dialog box (View > Display Settings 

> Model Display), or you can use the following toolbar buttons. 

 
Wireframe—Hidden lines are visible as regular, white lines. 

 
Hidden Line—Hidden lines are displayed in grey. 

 
No Hidden Line—Hidden lines are removed. 

 
Shading—Default setting. Shades the model. Hidden lines are 

not visible. The shading adapts to changes in model orientation. 

You can use this display method to view the contours of a 

surface or to print a copy of the model. 
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To Show Cables as Thick or Centerline 

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. Under Display on the General tabbed page, select or clear: 

o Reference designators—To change the display of reference designators 

of cabling connectors and ECAD components.  

o Internal cable portions—To change the display of cable portions that are 

inside cabling components. 

3. Under Cable Display on the Edge/Line tabbed page, select or clear: 

o Thick—To display cables with 3-D thickness to show shading. 

o Centerline—To display the cable centerline with location points shown in 

green. 

4. Click OK to save the changes and remove the dialog box, or Apply to save 

the changes and leave the dialog box displayed. 

To Show or Hide Items During Spinning or Animation 

To change the colors, spinning, or animation display of your model:  

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. In the General tab, under Display, select Colors to display colors. This can also 

be set using the configuration file option color. 

Note: You can also use the Colors on/off button ( ) on the toolbar to switch 

the display of colors. Use Customize Screen from the Tools menu to place 

buttons on the toolbar. 

3. Under Display while reorienting, select: 

o Datums—To display datum features during the dynamic spinning of the 

model. This checkbox is cleared by default. Note that you can also set the 
configuration option spin_with_part_entities to yes (default is no). 

o Surface mesh—To display surface mesh during the dynamic spinning of 

the model. This checkbox is checked by default.  

o Silhouette edges—To display silhouette edges during dynamic spinning of 

the model. This checkbox is cleared by default. Note that you can also set 
the configuration option spin_with_silhouettes to yes (default is no). 

o Orientation center—To display the Orientation Center during dynamic 

spinning of the model. This checkbox is checked by default. Note that you 
can also set the configuration option spin_with_orientation_center set 
to yes (default is yes). 

4. Under Animation while reorienting, select: 



Pro/ENGINEER Fundamentals 

151 

o Enable—Enable functionality. 

o Maximum seconds—Set the maximum number of seconds spent 

animating between views. 

o Minimum frames—Set the minimum number of displays for animation 

between views. 

To Switch Between Shaded and Wireframe Display 

Click one of the following toolbar buttons: 

• Wireframe — Hidden lines are displayed as regular lines. 

• Shading — The model is shaded according to the view orientation. Hidden 

lines are not visible in shaded view display. 

or 

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. In the General tab, under Display Style, select Wireframe or Shading. 

3. Click Apply to save the change and leave the dialog box open, or click OK to 

save the change and close the dialog box. 

To Show or Remove Hidden Lines 

Click one of the following toolbar buttons: 

• Hidden Line — Hidden lines are displayed in gray. The toolbar button shows 

dotted lines for clarity. 

• No Hidden — Hidden lines are removed. 

or 

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. Click the General tab. Under Display Style, select Hidden Line or No Hidden 

Line. 

3. Click Apply to save the change and leave the dialog box open, or click OK to 

save the change and close the dialog box. 

Tip: When Hidden Line Removal is Not Correct 

Hidden line display may not always work as you expect. Keep the following in mind: 



Pro/ENGINEER Fundamentals – Help Topic Collection 

152 

• Assembly components that physically intersect may not have correct display on 

one or both components. If this occurs it is an indication of incorrect component 

placement. 

• Curves and cosmetic features that intersect a part in the middle of a surface, i.e., 

where half the curve is visible and half not, might have incorrect display for the 

whole line. The display is correct if, in the current view, the curve crosses an 

edge at the surface boundary. 

To Change the Appearance of Edges and Lines 

1. Click View > Display Settings > Model Display. 

2. Click the Edge/Line tab of the Model Display dialog box. 

3. Under Edge Quality, select the quality of display you want (Medium, Low, 

High, or Very High). This can also be set using the configuration file option 

edge_display_quality.  

4. Under Tangent Edges, select the style for edges where two surfaces are tangent 

(Solid, No Display, Phantom, Centerline, or Dimmed). This can also be set 

using the configuration file option tangent_edge_display. 

Note: You can also use the tangent edge style toolbar buttons 

 to change tangent edges display (use Tools > Customize 

Screen to place buttons on the toolbar). 

5. Under Options, select the display options from the following: 

o Silhouette edges—To display silhouette edges. 

Note: You can select only the following types of silhouette edges: Silhouettes of 

cylinders and cones, and silhouettes of torii with axes that are parallel or 

perpendicular to the screen. 

o Smooth lines—To display all nonvertical and nonhorizontal lines using 

anti-aliasing techniques. 

o Depthcue always—To display depthcue when the Visibilities dialog box is 

closed. This can also be set using the configuration file option 

depthcue_options. 

o Clip always—To display clipping when the Visibilities dialog box is closed. 

6. Under Cable Display, select from the following: 

o Thick—To display clipping when the Visibilities dialog box is closed. 

o Centerline—To display the cable centerline with location points shown in 

green. 
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Note: You can also use the Cable thick style and Cable centerline style 

toolbar buttons to change the cable display. Use Utilities > Customize 

Screen to place buttons on the toolbar. 

7. Under Cable HLR, select Full, None, or Partial to set the level at which hidden 

lines are removed in a cabling assembly. This can also be set using the 

configuration file option full_hlr_for_cables. 

To Change the Display of Tangent Edges 

Use this procedure to change the line style for edges created by two tangent 

surfaces. 

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. In the Tangent Edges list on the Edge/Line tabbed page, select one of the 

following styles: 

o Solid 

o No Display 

o Phantom 

o Centerline 

o Dimmed 

3. Click Apply to save the change and leave the dialog box open, or OK to save the 

change and close the dialog box. 

Tip: Shortcuts for Setting the Display of Tangent Edges 

• You can also use the tangent edge style toolbar buttons  to 

change tangent edges display (use Tools > Customize Screen to place buttons 

on the toolbar). 

• You can also set the tangent edge display using the configuration file option 

tangent_edge_display. 

To Control Shading Quality 

The quality of a shaded model is determined by the size of triangles used for shading 

on revolved and spline surfaces. The higher the quality, the smoother the curved 

surfaces appear when shaded. Planar surfaces always appear the same, so they are 

not affected by the shade quality. 

To change the quality and appearance of a shaded image: 

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 
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2. Click the Shade tab. 

3. Under Quality, click the up or down arrows to adjust the value to the number 

you want. The range is 0 to 10. The default value is 3. A setting of 10 takes the 

longest to generate. 

4. Under Shade, select any of the following shading features: 

o Surface features—To use shade surface features when shading the model. 

This can also be set using the configuration file option 

shade_surface_feat. 

o With datum curves—To display datum curves on the shaded model. This 

can also be set using the configuration file option shade_with. 

o With edges—To display edges darker than the adjacent surfaces. This can 

also be set using the configuration file option show_shaded_edges. 

o Small surfaces—To shade very small surfaces. 

o Manufacturing reference model—To shade manufacturing reference 

models when shading the model. This can also be set using the 

configuration file option shade_mfg_ref_models. 

5. Under Enable, select any of the following: 

o Textures—To enable the display of textures on shaded models. 

o Transparency—To enable transparency for a model in the current window. 

There are two Transparency options: 

Blended—Default setting offers high-quality imaging with compromised 

performance in complex models. 

Stippled—Offers lower-quality imaging with faster performance in complex 

models. 

o Capped Clipping—To cap the plane that clips the shaded parts of a model. 

6. Click OK. 

To Hide or Unhide Datum Entities 

To turn the display of datum features on or off, do one of the following: 

• Click View > Visibility > Hide or View > Visibility > Unhide, or click its 

corresponding toolbar button. The GET SELECT menu appears. Use the Model 

Tree or the Graphics window to select the datum entities that you want to hide, 

and then click Done Sel. The selected datums are hidden. 

• Select a datum entity or entities that you want to hide, and then click View > 

Hide or View > Unhide. 

Note: In Pro/ENGINEER, the Display Curve Names button is not visible by 

default in any Pro/ENGINEER application except for Pro/SHIP. Use Tools > 

Customize Screen to place this button on the Pro/ENGINEER toolbar. 
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• Click View > Display Settings > Datum Display. The Datum Display dialog 

box opens.  

o Under Display, select the datum entities and entity names that you want 

to display. Some entities are selected by default, and you may want to clear 

the check boxes for the entities and entity names that you want to hide. 

o Use the Select All or Unselect All buttons to display or hide all datum 

entities at once. 

o Under Point Symbol, use the list box to select the type of symbol you 

want to use to designate a point. The options are Cross, Dot, Circle, 

Triangle, and Square. 

Tip: Datum Display Configuration Options 

You can change the datum and datum tag display by using any of the following the 

configuration file options: 

• display_planes 

• display_plane_tags 

• display_axes 

• display_axis_tags 

• display_coord_sys 

• display_coord_sys_tags 

• display_points 

• display_point_tags 

• spin_center_display 

• curve_tag_display 

Datum Display Dialog Box 

You use the Datum Display dialog box to specify the display status of individual 

datum entities independently from their names (tags). Click View > Display 

Settings > Datum Display to open the Datum Display dialog box. 

The following datum display options are available on the dialog box: 

• Planes—Displays datum planes and their names. This can also be set using the 

configuration file option display_planes. 

• Plane Tags—Displays datum plane names. This can also be set using the 

configuration option display_plane_tags. 

• Axes—Displays datum axes and their names. This can also be set using the 

configuration file option display_axes. 
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• Axis Tags—Displays datum axis names. This can also be set using the 

configuration option display_axis_tags. 

• Point Symbols—Displays datum points and their names. This can also be set 

using the configuration file option display_points. 

• Point Tags—Displays datum point names. This can also be set using the 

configuration file option display_point_tags. 

• Coordinate Systems—Displays coordinate systems and their names. This can 

also be set using the configuration file option display_coord_sys. 

• Coordinate System Tags—Displays coordinate system names. This can also be 

set using the configuration option display_coord_sys_tags. 

• Spin Center—Displays the spin center symbol. This can also be set using the 

configuration file option spin_center_display. 

• Curve Tags—Displays curve names. This can also be set using the configuration 

option curve_tag_display. 

• Section Tags—Displays the section tags.  

Use the Select All or Unselect All buttons to display or hide all datum entities at 

once. 

Under Point Symbol, you can specify the type of symbol you want to use to 

designate a point. The options are Cross, Dot, Circle, Triangle, and Square. 

To Improve Dynamic Display Quality 

You can reduce the amount of calculation that the system performs when 

dynamically orienting a shaded model by controlling the level of detail at which 

surfaces are displayed. The result is that the movements of the model appear 

smoother and better synchronized with the driving force. The effectiveness of using 

levels of detail (LODs) in a model is dependent on the configuration of your system. 

To control system performance: 

1. Click View > Display Settings > Performance. The View Performance 

dialog box opens. 

2. Under Hidden Line Removal, choose Fast HLR to enable hardware acceleration 

of dynamic spinning with hidden lines, datums, and axes. 

3. Under Spin Displays per Second, choose: 

o Enable—To attempt to guarantee the time it takes to draw a frame during 

spinning. 

o Frames Per Sec—To set the minimum number of displays per second 

during spinning. 

4. Under Level of Detail, choose: 
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o Enable—To use levels of detail in shaded models during dynamic 

orientation. This can also be set using the configuration file option 

lods_enabled. 

o Show detail %—To set the maximum level of detail that the system 

calculates. The range is from 0% through 100%. A setting of 100% (the 

default) represents no loss of detail. A setting of 0% represents almost a 

total loss of detail. 

To Display Process Components 

When working on a process plan, use this procedure to set display characteristics for 

process displays. 

1. Click View > Model Setup > Process Display. The Process Component 

Display dialog box opens. 

2. Using the list boxes under Settings, choose the display states you want for: 

o Previous Components (previously assembled components) 

o Current Components (components active in the current step) 

o Unused Components 

3. You can set the Process Display or Selection Display for previous, current, 

and unused process components to any of the following: 

o Current Environment 

o Phantom 

o Blank 

o Wireframe 

To Mesh a Part Surface 

To create a meshed surface in order to assess the validity of part geometry:  

1. Click View > Model Setup > Mesh Surface or from the toolbar, click the Mesh 

Surfaces button. (Use Customize Screen from the Tools menu to place the 

button on the toolbar.) The Mesh dialog box opens. 

2. Under Surface, in the list box, select the type of surface you want to mesh. The 

options are surface and quilt. 

3. Click the arrow button to display the GET SELECT menu to select the surface of 

quilt to mesh. 

4. Under Meshed Spacing, use 1st Direction to adjust the spacing between the 

mesh lines in the first direction and 2nd Direction to adjust the spacing between 

the mesh lines in the second direction.  

Surfaces remain meshed only until the view is repainted. Hidden lines are not 

removed when a part is meshed. 
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Example: Meshed Surface 

 

About Hiding Entities 

About Hiding Entities On the Fly 

Pro/ENGINEER allows you to hide and unhide selected model entities on the fly any 

time during the current Pro/ENGINEER session. Using the Hide or Unhide command, 

you can save valuable design time. 

• You do not have to assign the entities to a layer and then blank the entire layer. 

• You can hide and redisplay individual datum features, such as datum planes and 

datum axes, without having to hide or redisplay all of the datum features at 

once. 

• You can use the Model Tree search capability (Edit > Find) to select all items of 

a specified type (for example, all features of the same type in all components 

within an assembly) and then hide them using View > Visibility > Hide. 

The following types of items can be hidden on the fly: 

• Individual datum planes (as opposed to hiding or showing all datum planes at 

once) 

• Datum Axes 

• Features that contain axes, planes, and coordinate systems 

• Analysis features (points and coordinate systems) 

• Datum points (whole arrays) 

• Coordinate systems 

• Datum curves (whole curves, not individual curve segments) 

• Quilts (whole quilts, not individual surfaces) 
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• Assembly components 

You can also use the Hide and Unhide toolbar buttons, or choose the same 

commands from the shortcut menu when you right-click an item in the Model Tree or 

the Graphics area. Use Tools > Customize Screen to add these buttons to the 

toolbar. 

Hide—Hides the selected items. 

Unhide—Redisplays the selected items. 

Unhide All—Redisplays all hidden items that you have hidden. Unhide All does 

not redisplay items that were automatically hidden by Pro/ENGINEER, such as 

datums created on the fly or sketches for sketched entities. 

When you hide an item, Pro/ENGINEER removes the item from the graphics window. 

The hidden item remains in the Model Tree list, and its icon dims to reveal its hidden 

status. When you unhide an item, its icon returns to normal display (undimmed) and 

the item is redisplayed in the Graphics window.  

You can save or reset a layer display status as follows: 

Save Status—To save the current layer display status, click View > Visibility > 

Save Status.  

Note: Saving the object does not save the current layer display status. To save the 

current layer display status when saving the object, you must use View > Visibility 

> Save Status and then save the object. 

Reset Status—If you change the layer display status after you have saved a status, 

click View > Visibility > Reset Status to revert to the last saved layer display 

status. 

To Hide an Entity On the Fly 

Note: Hiding operations are object-action oriented only. You must select the item 

you want to hide or redisplay before you choose Hide or Unhide. 

1. In the Graphics window or the Model Tree, select and then right-click the item 

you want to hide. 

2. On the shortcut menu, click Hide. The selected item or items are blanked from 

the display. Their icons in the Model Tree are dimmed to reveal their hidden 

status. 

To Redisplay Hidden Entities 

Note: Hide and redisplay operations are object-action oriented only. You must select 

the item you want to hide or redisplay before you choose Hide or Unhide. 

1. In the Model Tree, select the hidden items that you want to redisplay. On the 

shortcut menu, click Unhide, or click the Unhide toolbar button. 

Note: The toolbar button is not present on the toolbar by default; you must add 

it using Tools > Customize Screen. 
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2. The selected entities are redisplayed in the Graphics window, and their icons are 

returned to normal display status (not dimmed) in the Model Tree. 

To Redisplay All Hidden Entities at Once 

Do one of the following: 

• Click View > Unhide All. 

• Click the Unhide All toolbar button. 

• Right-click the selected item and choose Unhide All from the displayed shortcut 

menu. 

All hidden (blanked) entities are redisplayed in the Graphics window. 

Using Advanced Views 

About Adding Perspective to a View 

Perspective creates a single-vanishing-point perspective view of a shaded or 

wireframe model. These views allow you to observe an object as the view location 

follows a curve, axis, cable, or edge through or around an object.  

To add perspective to a model view, you select a viewing path and then control the 

viewing position along the path in either direction. You can also rotate the 

perspective view in any direction, zoom the view in or out, and change the view 

angle at any point along the path. 

About Fly-Through and Walk-Through 

The fly-through and walk-through capabilities in Pro/ENGINEER enable you to view 

model geometry from different perspectives. 

Using fly-through or walk-through, you can do the following: 

• Move forward or backward, toward or away from the model. 

• Spin around so that model is in a different direction (up or down, or to the left or 

right). 

• Combine the preceding these movements to rotate around the model and view it 

from any perspective. 

Your view always moves (forward or backward) in the direction that you determine 

by using your mouse. Change the direction and the fly-though motion changes with 

respect to your direction. 

Fly-Through vs Walk-Through 

Fly-through provides a way to view model geometry in its entirety by using 

continuous motion. You navigate the model by using the eye target  and your 

mouse. You can fly-through the geometry to view the design as a whole. Seeing the 

larger context enables you to see how each feature or part fits into the design.  
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The Eye Target 

  

1. Eye target (not activated) 

2. Eye target (activated) 

3. Navigation handle 

Walk-through provides all of the moving capabilities of fly-through, except that you 

direct each movement increment using the sliders in the Perspective dialog box 

(View > Model Setup > Perspective). This provides greater navigational control 

enabling you to accurately view targeted geometry.  

You can also use both fly-through and walk-through to get a comprehensive view of 

your design. For example, you could use fly-through to view the model from a 

certain perspective, and then use walk-through to view smaller parts of the view or 

to turn corners while traveling around a model. 

Perspective Dialog Box 

The Perspective dialog box (View > Model Setup > Perspective), enables you to 

add perspective to a model view. This dialog box contains the following options: 

Under Type: 

• Fly Through—Activates fly-though. You use your mouse to navigate the model. 

• Walk Through—Activates walk-through. You use the sliders located under 

Options to navigate the model.  

• From To—Enables selection of two datum points or vertices that define the 

viewing path along the object. To use this perspective, select the features from 

the object using the SELECT dialog box. 

• Follow Path—Enables selection of an axis, edge, curve, or silhouette as the 

viewing path. For this perspective, select the features from the object using the 

SELECT dialog box. 

Note: All perspective view manipulation that is contained in the Perspective 

dialog box can also be done using the functionality available in View Mode and 

selecting the eye (viewer perspective) icon as the manipulation center. 

Under Options: 

• Dynamic Update—Controls whether or not the display dynamically changes as 

you adjust the settings in this dialog box. 

• Eye Dist—Moves the viewpoint along the selected path through the model. If the 

model is currently shaded and the path lies completely inside the model, nothing 

is visible on screen unless there are voids in the solid. 



Pro/ENGINEER Fundamentals – Help Topic Collection 

162 

• Rotate Eye—Sets the amount of display rotation around horizontal, vertical and 

center axes from -180 to +180 degrees. 

• Pan Eye—Sets the horizontal and vertical positioning of the display. 

• Zoom—Sets the percentage of magnification in the display from 0% to 100%. 

• View angle—Sets the angle of view from 0 to 45 degrees. 

• OK— Accepts all changes and closes the dialog box 

• Cancel—Cancels your changes and closes the dialog box 

• Reset—Restores the settings to their original (default) status and leaves the 

dialog box open so you can make additional changes 

To Add Perspective to the Model View 

1. Click View > Model Setup > Perspective. The Perspective dialog box opens. 

2. Under Type, select one of the following: 

o Fly Through 

o Walk Through 

o From To 

o Follow Path 

3. Under Options, select or clear the check box; or move sliders, click arrows, or 

enter values for the following: 

o Dynamic Update 

o Eye Dist 

o Rotate Eye 

o Pan Eye 

o Zoom 

o View Angle 

4. For From/To or Follow Path perspectives, select the items from the object 

using the SELECT dialog box. 

5. Click OK accept the settings or Cancel to remove the settings you made. Click 

Reset to restore the settings to their original (default) status. 

Change Depth Cue, or Clip Percentages 

To Change Depth Cue or Clip Percentages 

Use the following procedure to change depth cue and clip percentages for the model 

view: 
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1. Click View > Display Settings > Visibilities. The Visibilities dialog box 

opens. 

2. Adjust sliders or enter values for the following options: 

o Clip % — To change the placement of the clipping plane (a plane through a 

shaded model that lets you display only the portion of the model behind the 

plane). The range allowed is 0% to 100%, where 0% is the front of the 

model (nearest the screen). (To enable clipping plane display, choose View 

> Display Settings > Model Display and use the Shade tabbed page of 

the Model Display dialog box.) 

o Depth Cue % — To change the thickness of wireframe lines so that they 

appear darker as they extend into the screen (away from you) and lighter 

as they extend out from the screen (toward you). The range allowed is 0% 

to 100%. At 0%, all lines have maximum brightness; at 100%, all 

wireframe lines are blanked out. (To enable wireframe display, choose 

View > Display Settings > Model Display and use the General tabbed 

page of the Model Display dialog box.) 

To Fly Through a Model 

1. Click View > Model Setup > Perspective. The Perspective dialog box opens. 

2. Under Type, select Fly Through. 

3. In the graphics window, middle-click the eye target. Fly-through activates. 

4. Do one of the following: 

o Click the middle mouse button to move towards the object. To increase the 

speed, middle-click multiple times or hold the button down. Notice that if 

you are moving away from the object, clicking only the middle mouse 

button slows the reverse motion. 

o Press CTRL and middle-click to do the following: 

Decrease forward speed. Note that acceleration or deceleration must be re-

initiated after reaching zero-velocity. 

Move away from the object. To increase the reverse speed, press CTRL and 

middle-click multiple times or hold the button down. Notice that clicking 

only the middle mouse button slows the reverse motion.  

o Click to roll the object to the left. 

o Right-click to roll the object to the right. 

o Move the mouse and use the navigation handle to navigate the object . 

Notice that if the object is a zero velocity, this action repositions it. 

5. Double-click the middle mouse button to stop the fly-through. 

Note:  

• The Perspective dialog box must remain open to use fly-through. 
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• If you use the sliders in the Perspective dialog box after you selected Fly 

Through, Pro/ENGINEER changes to walk-through and the eye target closes. 

Simply, select Fly Through from the Types box. Fly-through activates and the 

eye target appears. 

To Walk Through a Model 

1. Click View > Model Setup > Perspective. The Perspective dialog box opens. 

Notice that Fly Through is selected by default. 

2. Under Type, select Walk Through. 

3. Under Options, use any of the following slides or type a value in the box and 

press ENTER: 

o Dynamic Update—This check box controls whether or not the display 

dynamically changes as you adjust the settings in this dialog box. 

o Eye Dist—Moves the viewpoint along the selected path through the model. 

If the model is currently shaded and the path lies completely inside the 

model, nothing is visible on screen unless there are voids in the solid. 

o Rotate Eye—Sets the amount of display rotation around horizontal, vertical 

and center axes in degrees. 

o Pan Eye—Sets the horizontal and vertical positioning of the display. 

o Zoom—Sets the percentage of magnification in the display. 

o View angle—Sets the angle of view in degrees. 

4. Click OK. The Perspective dialog box closes and walk-through session end. 

Cross Sections 

Creating Cross Sections 

About Part and Assembly Cross Sections 

You can use a cross section to see a cutout of a model along a particular direction. 

You can also use cross sections with the Info and Measure functions. If the model 

has changed since the cross section was created, the cross section is updated 

automatically. 

Use the View Manager to create the following types of cross sections: 

• Standard planar cross sections of parts or assemblies 

• Offset cross sections of parts or assemblies 

• Cross sections of a faceted model (.stl file) 

About Cross Sections and Quilts 
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With Technical Surfacing, you can create a cross section of a selected quilt or a cross 

section that intersects all model geometry including quilts. Depending on the 

geometry you want to intersect, you can create the following types of cross sections: 

• Model cross sections—You can create cross sections that intersect only the solid 

geometry in a model. 

• Model & Qlts cross sections—You can create cross sections that intersect solid 

geometry and all quilts in a model. The intersection curves are displayed in any 

three-dimensional view of the model and in any area cross-sectional drawing 

view. They do not appear in total cross-sectional drawing views. 

• Surf/Quilt cross sections—You can create cross sections that intersect a single 

quilt in a model to display its contour. Quilt cross sections can be created in Part 

and Assembly modes. 

• One Part cross sections—You can create cross sections that intersect only the 

selected part in an assembly.  

Restrictions for Using Cross Sections 

• Planar cross sections can be crosshatched or filled. Offset cross sections can only 

be cross-hatched. 

• Cross-hatching is not visible unless you have Detailed Drawings. If you have 

Detailed Drawings, the cross-hatching is visible even if you click the No Hidden 

toolbar button.  

• Cross sections do not show intersections with cosmetic features that are present 

in a model.  

To Create a Planar Cross Section 

You make a planar cross section through a model by aligning it with a datum plane 

or planar surface. 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Click New. A default name for the cross section appears. 

4. Press ENTER. The XSEC CREATE menu opens. 

5. To create a cross section through a single datum plane, click Planar > Single > 

Done. To create a cross section through all datum planes of a pattern, click 

Planar > Pattern > Done. The SELECT dialog box opens. 

6. Do one of the following: 

o Select a planar surface or datum plane to intersect the model. 

o If you are creating a cross section through all datum planes of a pattern, 

select any datum plane that belongs to the pattern.  

7. In the View Manager, click Display > Visibility to view the cross-section. 
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Example: Planar Cross Section 

In this example, a planar cross section is created along the datum plane DTM9. 

 

About an Offset Cross Section 

You create an offset cross section by extruding a section outline perpendicular to the 

sketching plane. This type of cross section is valuable for opening up the part to 

display several features with a single cross section. 

The following restrictions apply to an offset cross section: 

• The sketched section must be an open section. 

• Offset cross sections can be cross-hatched but not filled. 

• The first and last segments of the open section must be straight lines. The 

cutting plane arrows displayed in a drawing are perpendicular to these end 

segments. 

• In drawings, cross section edges always appear wherever the plane of the cross 

section is not parallel or perpendicular to the screen. 

• Circular and spline cross section geometry create non-modifiable horizontal 

cross-hatching (see the following example). 

Offset Cross Sections in a Drawing 
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1. Proper cross section 

2. Improper cross section 

To Create an Offset Cross Section 

To create an offset cross section, you must define an outline of the cut by sketching 

it in Sketcher. The outline is then projected perpendicular to the sketching plane. 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Click New. A default name for the cross section appears. 

4. Press ENTER. The XSEC CREATE menu opens. 

5. Click Offset > One Side or Both Sides > Done. The SELECT dialog box opens. 

6. Select the sketching plane and define the direction of viewing and sketch 

orientation. You are placed in Sketcher. 

7. Select reference entities to use for dimensioning. 

8. Sketch the section outline and click  to exit Sketcher.  

9. In the View Manager, click Display > Visibility to view the cross-section. 

Example: Offset Cross Section Created to One Side 

The following picture shows a cross section created to only one side of a sketching 

plane. 
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To Create Cross Sections Through Quilts 

Use the Model & Qlts option to create a cross section that intersects both solid 

geometry and quilts. Use the Surf/Quilt option to intersect a selected quilt. 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Click New. A default name for the cross section appears. 

4. Press ENTER. The XSEC OPTS menu opens. 

5. Select the type of a quilt cross section you wish to create, Model & Qlts or 

Surf/Quilt. 

6. Click Done. The SELECT dialog box opens. 

7. If you selected Surf/Quilt, select a quilt through which you want to create the 

cross section. 

8. Select the datum plane along which to create a section. 

9. In the View Manager, click Display > Visibility to view the cross section. 

Example: Model and Quilts Cross Sections 

This example shows a cross section created using the Model & Qlts option by 

intersecting both the solid and the surface geometry with the datum plane DTM1.  
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This example shows a cross section created using the Surf/Quilt option by 

intersecting the quilt with the datum plane DTM1. The bottom quilt was selected for 

sectioning. 

 

About Zonal Cross Sections 

Zonal cross sections are 3-dimensional cross sections created by defining zones. The 

zones contain the same functionality as normal zones. To make large models more 
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manageable, you can define specific regions called "zones" within a model. You can 

use zones to: 

• Organize a model. 

• Control view clipping. 

• Select components in an assembly for a simplified representation. 

• Create component display states. 

• Define envelope parts. 

Use the Xsec tab in the View Manager to create cross sections by defining zones. 

You can give each cross section a name and store it with the part or assembly. In 

addition, you can show cross-hatching and view clippings through zone boundaries 

which remains with the model. 

You can define a zone using planar references, for example datum planes or 

surfaces. These references can come from any level of the part or assembly. You can 

define the datum planes while you create a zone, or use existing datum planes or 

surfaces. You can use planar references to define a zone to include everything on 

one side of the reference. This side is a "half-space" of the datum plane. You can 

combine any number of half-spaces. However, if you use more than 6 half spaces, 

view clipping is not available. 

You can also define a zone by specifying offset distances from a coordinate system. 

Additionally, in Assembly, you can define a zone by using closed assembly feature 

surfaces, or by specifying a distance from an entity.  

When you create a zonal cross section, Pro/ENGINEER places it in the Regeneration 

Footer of the Model Tree. However, if you create datum planes while creating a zonal 

cross section, then Pro/ENGINEER groups the zonal cross section along with the 

datum planes. This group is directly placed in the Model Tree as a feature and not in 

the Regeneration Footer. If you want to move the zonal cross section to the 

Regeneration Footer, you must first ungroup the zonal cross section and the datum 

planes that were grouped earlier, and then drag the zonal cross section to the 

regeneration footer.  

Note: You can move a zonal cross section to the Regeneration footer but you cannot 

move it outside the Regeneration footer. 

Pro/ENGINEER includes components in zones as follows: 

• If a component lies in more than one zone, Pro/ENGINEER includes it in both 

zones. 

• If a zone intersects a component’s bounding box, Pro/ENGINEER includes it in 

that zone. 

To Create a Zonal Cross Section Using Planar References 

1. Click  or View > View Manager or View > Zone. The View Manager 

dialog box opens. 
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Note: If you have clicked View > Zone proceed to step 4. 

2. Click the Xsec tab. 

3. Click New. A default cross section name appears in the Names section of the 

View Manager dialog box.  

4. Accept the default cross section name or type a new name and then press 

ENTER. The XSEC OPTS menu appears. 

5. Click Zone. The Zone dialog box opens. 

6. To select components on one side of a plane using planar references, select Half-

Space from the list located below the Reference list area. Half-Space is the 

default option. 

7. Select a planar reference, for example a datum plane or a surface, for defining 

the zone. These references can come from any level of the part or assembly. 

o The planar reference name appears in the text box next to the selection 

arrow.  

o Nine arrows appear in the graphics window, indicating which side of the 

datum is used to define the zone. You can flip the direction of the arrows 

using the flip button located below the reference list. 

8. To select additional references, click  and select the required reference. 

Note:  

o You can add any number of planar references. However, for view clipping, 

define a zone using a maximum of six planar references. 

o In Assembly, if you change the reference type after specifying some 

references, those references are no longer displayed. If you switch back to 

the earlier reference type, the references appear again. 

o Click  to remove a reference at any time. 

9. If you specify more than one reference, click AND or OR.  

Note: When you select more than one reference, they have logical AND and OR 

and capabilities. Pro/ENGINEER uses parentheses to maintain an order of 

operations. You cannot change the position of the parentheses. The OR 

operations are always grouped within parentheses while the AND operation 

separates operations into new parentheses. 

10. Click  to preview all the selected references at the same time. 

Note: To see a highlighted reference in the Graphics area, select the reference in 

the References list area. You can select only one reference at a time.  

11. Click  to close the Zone dialog box.  
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o The name of the new zonal cross section is displayed in the View 

Manager. 

o The zonal cross section is added to the Regeneration Footer in the Model 

Tree.  

12. To preview defined zones, click Display in the View Manager and click one 

of the following: 

o Zone Refs—To preview zone references 

o Zone Comps—To preview zone components 

o Zone Only—To preview zone only 

13. To show the cross-hatching permanently, in the View Manager, click 

Display > Visibility or right-click on the cross section name and select 

Visibility from the shortcut menu.  

14. To make the cross section hatching or zone geometry or both visible in the 

model, select Xhatching or Show Region Boundary or both and click OK.  

Working with Cross Sections 

About Cross Section Operations 

You can perform the following operations on a cross section: 

• Display or blank a cross section 

• Show a clipped model using a cross section 

• Rename a cross section 

• Copy a cross section from another model 

• Add a description to a cross section 

• Remove a cross section 

• Include or exclude assembly members from a cross section 

• Modify section dimensions for offset cross sections 

• Redefine the section attributes, geometry, and dimensioning scheme 

• Change a cross section color and cross-hatching 

• Switch between filled and hatched cross sections 

To Display a Cross Section 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Under Names, click the cross section that you want to display. 
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3. Click Display > Xhatching. The cross section hatching is visible in the model. 

However, upon selection of another cross section the cross-hatching is not 

visible.  

4. To display the cross-hatching permanently, click Display > Visibility.  

Note: To view zone geometry in a zonal cross section, click Display > Show 

Region Boundary. 

About View Clipping 

You can perform view clipping using the View Manager. You can clip models 

through cross sections. You can create drawing views from clipped views. 

The following are some guidelines for view clipping: 

• You can define multiple cross sections. However, you can view clip a model using 

only one cross section at a time. 

• You can use a maximum of six planar boundaries to define zones to view clip 

them. 

• You cannot use cross-section view clipping and model view clipping 

simultaneously. 

• You can save the model in the view clipped state by setting the 

save_clipped_view configuration option to yes. On subsequent retrieval of the 

model, Pro/ENGINEER sets the saved clipping state to active, and the model is 

displayed in the clipped state. 

Note: You need the save_clipped_view configuration option only at the time the 

model is saved. Retrieval of the model depends on how the model was saved; 

retrieval is completely independent of the configuration option. 

To Clip a Model Using a Cross Section 

You can display a clipped model using a cross section. 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Right-click the name of the cross section to clip. The shortcut menu appears. 

4. Click Set Active. The model is clipped. 

Note: You can click Display > Flip to change the direction of clipping on the 

model. 

To Rename a Cross Section 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 
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3. Under Names, click the cross section that you want to rename. 

4. Click Edit > Rename. 

5. In the name cell, type a new name. 

6. Press ENTER. 

To Copy a Cross Section 

Use the Copy command from the Edit menu in the View Manager to copy a cross 

section from another model. The model from which the cross section is copied must 

be of the same type as the model in which the new cross section is being created 

(part or assembly). 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Click Edit > Copy. 

4. Under the Names column, type a name for the new cross section and press 

ENTER. The Open dialog box opens.  

5. In the Open dialog box, select the reference model that contains the cross 

section you want to copy. The reference model can be the same as the current 

model.  

6. The reference model appears in a secondary window. The XSEC NAMES menu 

lists the cross sections that are present in the reference model. Select the cross 

section that you want to copy. The references for the selected cross section are 

highlighted in green on the reference model.  

7. For each highlighted reference, click a corresponding reference on the current 

model. The cross section is copied to the current model and displayed.  

Note: You can also copy or group features that reference a cross section, for 

example, datum curves created with the UseXsec command. 

To Remove a Cross Section 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under the Names column, click the cross section that you want to remove. 

4. Click Edit > Remove. 

5. Confirm by pressing OK at the system prompt. 

To Modify Section Dimensions 

You can change the dimensions of an offset cross sections. 
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1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under the Names column, click the cross section you want to modify. 

4. Click Edit > Redefine. The XSEC MODIFY menu appears.  

5. Click XSEC MODIFY > Dim Values. The cross section dimensions appear. 

6. Modify the dimensions as needed. Click OK from the SELECT menu. The part is 

automatically regenerated. 

7. Click Done/Return. 

To Redefine an Offset Cross Section 

You can redefine an existing offset cross section to change the section attributes, 

section geometry, and dimensioning scheme. 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. In the Names column, select the existing offset cross section that you want to 

redefine. 

4. Click Edit > Redefine. 

5. Click XSEC MODIFY > Redefine. From the REDEFINE menu, select options to 

modify: 

o Attributes—Redefine the attributes of the feature. 

o Direction—Redefine the direction of feature creation. 

o Section—In Sketcher, modify the sketch of the cross section. You can add, 

delete, or modify sketcher entities and dimensions.  

o Scheme—Add or delete dimensions in Sketcher. 

6. Click Done. 

Modifying Cross Sections 

About Modifying Cross-Hatching 

The default line style for cross sections is leader style. When you quit the View 

Manager, the cross section is displayed in yellow. You can modify the cross-hatching 

in planar and offset cross sections. 

Cross-hatch cosmetics are independent of orientation. Your spacing specifications are 

stored in model coordinates, while angles are measured from the horizontal of the 

current view. The latter is designed to retain the same angle of cross hatching when 

the model is retrieved in a drawing cross-sectional view. 
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Note: Modifying the cross-hatching in Part or Assembly mode does not update any 

existing drawing views.  

Standard Cross-Hatch Patterns 

Note: Nine standard crosshatch patterns are included with Detailed Drawings (see 

the following figure). 

 

1. Aluminum 

2. Copper 

3. Electric 

4. Glass 

5. Iron 

6. Plastic 

7. Steel 
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8. Titanium 

9. Zinc 

To Display a Cross Section as Hatched or Filled 

After you defined a planar cross section, you can display it as hatched or filled.  

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under the Names column, click the cross section that you want to change. 

4. Click Edit > Redefine.  

5. Click XSEC MODIFY > Hatching. 

6. From the MOD XHATCH menu, select one of these options: 

o Hatch (default)—Create a hatched cross section. To see the current color 

and line definitions, click  Line Style from the MOD XHATCH menu.  

o Fill—Fill the cross section in a solid color.  

7. When finished, click MODIFY XHATCH > Done. 

To Change the Fill Color 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under the Names column, click the cross section that you want to change. 

4. Click Edit > Redefine. 

5. Click XSEC MODIFY > Hatching. 

6. From the MOD XHATCH menu, click  Fill and then Line Style. The Color dialog 

box opens. 

7. Select a color or create one. 

8. Click OK. Pro/ENGINEER updates the color in the cross section and closes the 

dialog box.  

To Modify Hatch Spacing 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under there Names column, click the cross section that you want to change. 

4. Click Edit > Redefine.  
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5. Click XSEC MODIFY > Hatching > Spacing. The MODIFY MODE menu 

appears.  

6. Specify if you want to change an individual or all pattern lines: 

o Individual—Apply the change in hatch spacing to an individual pattern 

line. 

o Overall—If hatching has multiple line patterns, apply the change in hatch 

spacing to all line patterns. 

Note: In most cases, there is only one pattern. Therefore, choosing Individual 

or Overall gives the same result. 

7. Define the spacing using one of these options: 

o Half—Change spacing to one half of the current spacing by creating more 

hatch lines. 

o Double—Change spacing to double the current spacing by decreasing the 

number of hatch lines. 

o Value—Enter a value for the spacing. The system calculates the number of 

hatch lines based on the spacing value. 

8. When finished, click MODIFY XHATCH > Done. 

Note: You can set the default spacing and angle of cross-hatching in newly 

created planar and offset cross sections by adding parameters. Click the topic To 

Set the Default Spacing and Angle under See Also. 

To Modify the Hatch Angle 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under there Names column, click the cross section that you want to change. 

4. Click Edit > Redefine.  

5. Click XSEC MODIFY > Hatching > Angle.  

6. Specify if you want to change an individual or all pattern lines: 

o Individual—Apply the change in hatch angle to an individual pattern line. 

o Overall—If hatching has multiple line patterns, apply the change in hatch 

angle to all line patterns. 

Note: In most cases, there is only one pattern. Therefore, choosing Individual 

or Overall gives the same result. 

7. Select the angle from the MODIFY MODE menu.  

8. When finished, click MOD XHATCH > Done. 
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Note: You can set the default spacing and angle of cross-hatching in newly 

created planar and offset cross sections by adding parameters. Click the topic To 

Set the Default Spacing and Angle under See Also. 

To Set the Default Spacing and Angle 

You can set the default spacing and angle of cross-hatching for new planar and offset 

cross sections. To do that, add the following model parameters using Tools > 

Parameters: 

• default_xhatch_angle with a value for the angle between –360 and 360 

degrees. 

• default_xhatch_spacing with a positive value for the spacing. 

Consider the following information for setting the defaults for spacing and angle: 

• If you modify the spacing and angle manually after setting the hatching using 

these parameters, the change overrides the parameter values. 

• Changing the parameter values for angle and spacing only affects new cross 

sections—not previously created ones that have the parameters associated with 

them. 

• These parameters do not affect different material styles for cross-hatching. They 

affect only the default style. 

• If you enter an invalid value for a parameter, the system uses the default. 

To Modify Hatch Line Style 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under there Names column, click the cross section that you want to change. 

4. Click Edit > Redefine.  

5. Click XSEC MODIFY > Hatching > Spacing. 

6. Click MOD XHATCH > Line Style. The Line Style dialog box opens. 

7. Select a new line style and click Apply. The line style in the section is updated.  

8. To change the line color, click the color box. The Color dialog box opens.  

9. Select a new color and click OK. The Color dialog box closes, and the new color 

choice appears in the Line Style dialog box.  

10. Click Apply, then Close.  

11. To update the display, click MOD XHATCH > Fill > Hatch. 
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Line Style Dialog Box 

Use the options in the Line Style dialog box to modify line styles: 

Style—Use to set the line style name by selecting from a list of existing line style 

names. 

Existing Line—Use Select Line to copy the line style of an existing line. 

Line Font—Use to set a line font by selecting from a list of all available line fonts.  

Color—Use to set the color of selected lines using the Color dialog box. 

Click Apply to apply the line style or Cancel to close the dialog box without making 

changes. If you click Reset, the line style resets to the previous values. 

To Modify the Offset of Parallel Cross-Hatching 

Use the Offset command to change the offset of the second line for the parallel type 

of cross-hatching. 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under there Names column, click the cross section that you want to change. 

4. Click Edit > Redefine.  

5. Click XSEC MODIFY > Hatching > Offset.  

6. Type a value for the offset in drawing units and press ENTER.  

7. When finished, click MOD XHATCH > Done. 

To Save a Cross-Hatch Pattern 

You can save and later retrieve a cross-hatch pattern. The configuration file option 

pro_crosshatch_dir specifies the path to the default directory where the patterns 

are saved. When you choose the Retrieve command from the MOD XHATCH menu, 

Pro/ENGINEER searches the default directory. 

To save a pattern: 

1. Click  or View > View Manager. The View Manager dialog box opens. 

2. Click Xsec. 

3. Under there Names column, click the cross section that you want to save. 

4. Click Edit > Redefine. 

5. Click XSEC MODIFY > Hatching. 

6. Click MOD XHATCH > Save. 

7. Type the name of the crosshatch pattern and press ENTER. The crosshatch 

pattern is stored to file with the  extension .xch in the current directory. 
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To retrieve a pattern: 

1. Click MOD XHATCH > Retrieve. The Open dialog box opens, containing the 

names of cross-hatch patterns in the current directory, all crosshatch patterns in 

the default cross-hatch directory, and the standard cross-hatch patterns.  

2. Select a cross-hatch pattern from the list and click Open. The selected 

crosshatch pattern places the current cross-hatching in the view. 

3. To update the color, click Fill.  

System Colors 

About System Colors 

Pro/ENGINEER provides default system colors enabling you to easily identify model 

geometry, datums, and other important display elements. These default system 

colors are displayed in the System Colors dialog box (View > Display Settings > 

System Colors) under the Graphics tab. The User Interface, Datum and 

Geometry tabs enable you to further assign system colors to these elements.  

Customizing System Colors 

You can customize the default system colors by making the following changes: 

• Define, save, and open color schemes 

• Store a color scheme so you can reuse it 

• Open a previously used color scheme 

• Customize colors used in the user interface 

• Change your entire color scheme to a predefined color scheme (such as black on 

white) 

• Change the top or bottom background colors 

• Redefine basic colors used in models 

• Assign colors to be used by a geometry or datum entity 

You can turn on and off Blended Background (gray and dark gray) by clicking the 

Blended Background check box under the Graphics tab. You can set the blended 

background from the Blended Color dialog box (click the Edit button under the 

Graphics tab). 

Modifying System Colors Using Configuration Options 

In addition to using the System Colors dialog box (accessed by clicking View > 

Display Settings > System Colors), you can modify each of the following colors 

by using the config.pro file. Refer to the topics under Configuring Pro/ENGINEER 

Fundamentals for more information.  
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User Interface Tab 

Set colors for text, editable, and selected area, and background. Click the color to 

open the 16-color standard Windows palette. Click Other to customize and Cancel 

to close the color palette.  

Datum Tab 

Set colors for datum planes, axes, points, and coordinate systems. To change the 

default datum colors, you click the color to display the 13 default color settings, then 

click on the desired color. 

Geometry Tab 

Set colors for References, Sheet Metal Surface, Spine Surface Mesh, Cable, Quilt 

Edge, Mold and Cast Surfaces, and the ECAD Area. To change the default geometry 

colors, you click the color to display the 13 default color settings, and select the 

desired new color. 

File Menu 

Using the File menu, you can open an existing color scheme or save your current 

scheme. 

Open—Allows you to restore a previously used color scheme by reading in a system 

colors (.scl) file. 

Save—Allows you to save the current system colors in a .scl file for future use. 

Scheme Menu 

A color scheme affects system colors. The default color scheme is a light to dark grey 

gradient background. You change the color scheme by using the Scheme menu. 

Pro/ENGINEER provides the following color schemes: 

• Black on White—Displays black entities shown on a white background. 

• White on Black—Displays white entities shown on a black background. 

• White on Green—Displays white entities shown on a dark green background. 

• Initial—Resets the color scheme to the one defined by the configuration file 

settings.  

• Default—Resets the color scheme to the default Pro/ENGINEER Wildfire color 

scheme (light to dark grey gradient background). 

• Use Pre-Wildfire Scheme—Resets the color scheme to the 2001 release of 

Pro/ENGINEER (blue to black gradient background). 

To Open an Existing Color Scheme 

1. Click View > Display Settings > System Colors. The System Colors dialog 

box opens. 
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2. Click File > Open. 

3. In the Open dialog box, browse to the color scheme .scl file that you want to 

use. 

4. Click OK. Pro/ENGINEER sets the display using the color scheme. 

To Redefine a System Color 

1. Click View > Display Settings > System Colors. The System Colors dialog 

box opens. 

2. Click the tab related to the colors that you want to change. Pro/ENGINEER 

provides the following tabs: 

o Graphics—Displays the default system colors for the graphical elements. 

o User Interface—Sets the colors for text, editable and selected areas, and 

the background.  

o Datum—Sets the colors for datum planes, axes, points, and coordinate 

systems.  

o Geometry—Sets the colors for references, sheet metal surfaces, spine 

surface mesh, cables, quilt edges, and the ECAD area. 

3. Click the button to the left of the check box for the system color you want to 

redefine. 

4. In the Color Editor dialog box, you can adjust the RGB or HSV controls to 

create the color that you want. For example, to set Background to white, move 

the R, G, and B slider handles all the way to the right. To set Background to 

black, move the slider handles all the way to the left.  

5. When you redefine a color, the check box for that color turns black to indicate a 

color change. Click the check box to reset the entity color back to the original 

color. Click it again to reset the color to the new color. 

6. When you finish editing the chosen color, click OK in the Color Editor dialog 

box. 

7. Repeat step 2. through step 4. to change other system colors. 

8. Click OK in the System Colors dialog box. 

To Define a Custom Background Color 

1. Click View > Display Settings > System Colors. The System Colors dialog 

box opens. 

2. Click the Graphics tab and then click the Blended Background check box to 

turn on or off the Blended Background. 

3. Click Edit. The Blended Color dialog box opens. 

4. To change the top or bottom background color, select the appropriate check box. 
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5. Click the color sample button to the left of the check box. The Color Editor 

dialog box opens. 

6. Specify a new color. The color sample button changes to the new color. The new 

background color gradations that you selected appear in the preview window. 

Note: If you want to have the backgrounds of windows with 3D objects 

automatically update as you change background colors, make sure that 

Dynamically update model window is selected. This is the default option. 

7. Click OK. The Color Editor dialog box closes. 

8. Click OK in the System Colors dialog box. 

To Save the Current Color Scheme 

1. Click View > Display Settings > System Colors. 

2. In the System Colors dialog box, click File > Save. 

3. Use the Save dialog box to name and save your current color scheme as a file. 

The file names for color schemes contain the extension .scl. 

Note: To have those colors in place for the next session, this file must be pointed 

to the setting in the configuration option system_colors_file. 

Tip: Modifying System Colors Using the Configuration File 

In addition to using the System Colors dialog box (accessed by clicking View > 

Display Settings > System Colors), you can modify each of the following colors 

by using the config.pro file. The options are: 

• system_letter_color (corresponds to the Letter option in the System Colors 

dialog box) 

• system_highlight_color (corresponds to the Highlight - Primary option in 

the System Colors dialog box) 

• system_colors_file (Alternatively, you can create a separate file with all of 

these values specified and use this option to specify the file location.) 

• system_background_color (corresponds to the Background option in the 

System Colors dialog box) 

• system_hidden_color (corresponds to the Hidden Line option in the System 

Colors dialog box) 

• system_edge_high_color (corresponds to the Highlight - Edge option in the 

System Colors dialog box) 

• system_dimmed_menu_color (corresponds to the Highlight - Secondary option 

in the System Colors dialog box) 

• system_volume_color (corresponds to the Manufacturing Volume option in 

the System Colors dialog box) 
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• system_section_color (corresponds to the Sketched Curve option in the 

System Colors dialog box) 

• system_sheetmetal_color (corresponds to the Sheet Metal option in the 

System Colors dialog box) 

• system_curves_color (corresponds to the Curves option in the System Colors 

dialog box) 

• system_geometry_color (corresponds to the Geometry option in the System 

Colors dialog box) 

• system_colors_file (specifies a location for a separate file containing color 

values) 

A keyword must be followed by three decimal values in the range from 0 through 

100, which specifies the percentages of red, green, and blue (in that order) in the 

resulting color. These values are identical to those you see in the R, G, and B fields 

in the Color Editor dialog box (accessed by clicking a color button in the System 

Colors dialog box). 

System Colors 

Pro/ENGINEER provides system colors enabling you to easily identify model 

geometry, datums, and other important display elements. The following tables list 

the default system colors and their corresponding RGB (Red Green Blue) values. 

 Note that these default system colors are listed in the System Colors dialog box 

(View > Display Settings > System Colors) on the Graphics tab. 

Sample Color 

Name 

RGB Values 

(R,G,B) 

Description 

 White 255,255,255 Identifies geometry. 

 Gray 150,148,138 Identifies hidden lines. 

 Blue 52,160,239 Identifies sketches. 

 Dark 

blue 

60,56,255 Identifies curves. 

 Magenta 237,64,199 Identifies quilts. 

 Purple 129,0,174 Identifies mill volumes in 

manufacturing, and mold 

volumes in molding and casting. 

 Green 19,140,46 Identifies the driving surface of 

sheet metal parts. 

 Brown 170,118,56 Identifies datum planes, axes, 

points, and coordinate systems. 
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Sample Color 

Name 

RGB Values 

(R,G,B) 

Description 

 Yellow 255,255,0 Identifies text. 

 Dark red 148,0,41 Identifies (primary) highlighted 

items. 

 Dark 

gray 

94,93,89 Identifies (secondary) highlighted 

items such as weak dimensions 

and non-current subsections. 

 Green 55,255,38 Identifies highlighted references. 

The following table lists the default system colors that Pro/ENGINEER reserves for 

feedback during selection, and during current tool usage: 

Sample Color 

Name 

RGB Values 

(R,G,B) 

Description 

 Cyan 0,255,255 Identifies the preselected item. 

 Red 255,0,51 Identifies selected items. 

 Orange 255,138,0 

 

Identifies secondary selected 

items. 

 

 Yellow 255,255,0 Identifies previewed results of 

the current activity. 

 Pale 

yellow 

252,255,198 Identifies secondary previewed 

results of the current activity. 

 

The following table lists the default system colors that Pro/ENGINEER uses for 

displaying the geometry area background: 

Sample Color 

Name 

RGB Values 

(R,G,B) 

Description 

 Black 51,50,46 Identifies the background color 

used in windows that display 2D 

geometry, and the non-blended 

background color used in 

windows that display 3D 

geometry.  

Note: You must clear the 

Blended Background check box 

in the System Colors dialog box 
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Sample Color 

Name 

RGB Values 

(R,G,B) 

Description 

(Graphics tab) to display this 

color in windows that display 3D 

geometry.  

 Gray 158,155,145 Identifies the top portion of the 

graphics window blended 

background in windows that 

display 3D geometry. 

Note: You must click Edit on the 

System Colors dialog box 

(Graphics tab) to modify this 

color. 

 Light 

gray 

227,225,213 Identifies the bottom portion of 

the graphics window blended 

background in windows that 

display 3D geometry. 

Note: You must click Edit on the 

System Colors dialog box 

(Graphics tab) to modify this 

color. 

Using Model Colors in Drawings 

You can set the system to use the original model colors in all associated drawings. 

Keep in mind: 

• Views that are displayed in the original model colors are plotted (printed) as 

such. 

• Changing the color of individual geometry does not change the colors in views 

that display the original model colors. 

• If you change model colors in the associated model, the new model colors are 

updated automatically in the drawing, if you set the drawing views to use model 

colors. 

• Hidden lines in drawing views always appear in the standard hidden line color in 

the model. 

• Any assigned process assembly colors always supercede the setting for using 

model colors or assigned drawing colors in the drawing. 

In Drawing mode, set the system to use model colors in drawings by using the 

Model Colors option in the VIEW DISP menu (accessed when you select a drawing, 

click Edit > Properties > View Disp).  
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The Insert Menu 

About the Insert Menu 

Options for creating datum feature types such as holes, rounds, datums, points, 

axes, and planes, and for creating other features, such as holes, shells, ribs, drafts, 

chamfers, cuts, cosmetic features, and more. You can also create advanced features 

such as pipes, toroidal bends, and patches. Also includes options for appending data 

from external files to the current model. Additional options include working with 

shared data, and advanced blends. 

About Datum Feature Creation 

You can create all datum feature types, including points, axes, planes, coordinate 

systems, curves, graphs, and analyses, by clicking Insert > Model Datum. 

During feature creation, model investigation, component assembly, and other 

operations, you are required to select one or more datum points, axes, planes, 

and/or coordinate systems, but in many cases the desired datum does not exist. It is 

unnecessary to abort your current operation in order to navigate the Feature menus 

and create the desired datum feature. 

You can create datum points, axes, planes (including offset planes), curves, ribbons 

and coordinate systems at any time using Insert > Datum. You can create these 

features even during the creation of another feature, and then use them as 

references of that feature. At any point in feature creation, measurement, or 

analysis, if a datum feature is needed, you can create it. 

This applies even for nested datum features, such as a condition where a point, axis, 

and plane must be created simply to get a reference for an offset make datum. 

Note: Datum features, like other features, may have names that are identical to 

individual entity names. For example, a datum axis feature may contain an axis 

entity. In the former case, an axis is a type of feature, and in the latter case, it is a 

type of entity. Likewise, a datum point feature may contain many datum point 

entities. 

For more information about and procedures for creating datum features, see the 

topics under Part Modeling in the Pro/HELP Table of Contents. 

About the Style Function 

The Insert menu contains the Style option, which inserts the Styling menu in the 

menu bar. Styling is an intuitive and interactive design environment for the creation 

of freeform curves and surfaces embedded in the Pro/ENGINEER parametric 

environment. The super-features are created at part level and allow you to model 

curves and surfaces with as many or as few constraints as you like. The four-view 

layout allows you to work simultaneously in multiple views, and the unique softpoint 

technology results in lighter and more flexible curves. The editing controls allow for 

quick, intuitive and dynamic interaction with models. 
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The Analysis Menu 

About the Analysis Menu 

Use these commands to display information about the models and modify the options 

for analyzing model parameters. Options exist for  

• Comparing the features or geometric differences between two parts 

• Performing model, curve, surface, Mechanica, Excel, or user-defined analyses 

• Performing sensitivity analyses 

• Feasibility or optimization studies, or creating a multi-objective design study 

• Comparing a sheet to an existing picture and display the results in the Drawing 

mode 

You can perform the following types of analysis on a model: 

• Model—Analyzes the model properties 

• Measure—Measures model geometry, such as lengths, angles, areas, and so on 

• Geometry—Analyzes surface properties and curves 

These analysis tools are used in applications such as solid modeling, surface 

modeling, and behavioral modeling. 

About a Saved Analysis 

You can save an analysis with the model. The saved analysis is displayed in the 

Pro/ENGINEER graphics window until you explicitly hide or delete it using the Saved 

Analysis dialog box.  

You can open a saved analysis by clicking Analysis > Saved Analysis. Use the 

Saved Analysis dialog box to perform the following operations: 

• Hide or unhide a saved analysis. 

• Redefine a selected analysis. 

• Use the filter to select the type of analysis that you want to view. 

• Delete a saved analysis. 

You can also create an analysis feature from a saved analysis. However, you can 

redefine a saved analysis only for the Geometry type of analysis. 

To Create an Analysis Feature From a Saved Analysis 

1. Click Analysis > Saved Analysis to open a saved analysis. The Saved Analysis 

dialog box opens. 

Note: Using the Saved Analysis dialog box, you can redefine a saved analysis 

only for the Geometry type of analysis. 
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2. Click  in the Saved Analysis dialog box. 

3. Specify a name for the new feature you want to create, in the text area displayed 

on the dashboard. 

4. Click . An analysis feature with the specified name is created on the Model 

tree. 

Analyzing Model Properties 

About Model Analysis 

Use Analysis > Model and select the appropriate type of analysis to analyze the 

model properties. 

You can perform the following types of model analysis: 

• Mass Properties—Computes mass properties for a part, assembly, or drawing. 

The Assembly Mass Properties type of analysis is available in Assembly mode and 

assembly drawing while the Model Mass Properties type is available in Part and 

Drawing modes. 

• X-Section Mass Properties—Computes the mass properties for a cross section. 

• One-Sided Volume—Computes the volume of a model on one side of a 

designated plane. The One-Sided Volume type of analysis is available in Part and 

Drawing modes. 

• Pairs Clearance—Computes the clearance distance or interference between two 

objects or entities (any combination of subassemblies, parts, surfaces, cables, or 

entities) in a model. The Pairs Clearance type of analysis is available in Part, 

Assembly, Piping, and Drawing modes. 

Note: Exploded views in Assembly are cosmetic and have no effect on clearance 

computations. 

• Global Clearance—Computes the clearance between each part or subassembly 

of a model. The Global Clearance type of analysis is available in Assembly, Piping, 

and Drawing modes. 

Note: Exploded views in Assembly are cosmetic and have no effect on clearance 

computations. 

• Volume Interference—Verifies that the selected closed quilt has nothing 

interfering with it. The Volume Interference type of analysis is available in 

Assembly and Drawing modes. 

Volume interference checking is used in ECAD to ensure that keepin or keepout 

areas have not been violated. 
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• Global Interference—Displays information (in a drawing or assembly) about 

interference between each part or subassembly in a model. The Global 

Interference type of analysis is available in Assembly and Drawing modes. 

• Short Edge—Computes the length of the shortest edge in a selected part or 

component and also determines how many edges in the model are shorter than 

the specified length. The Short Edge Type analysis is available in Part and 

Assembly modes. 

• Edge Type—Determines the type of geometry used to create the selected edge. 

The Edge Type analysis is available in Part, Assembly, and Drawing modes. 

• Thickness—Checks whether the thickness of a part is greater than a maximum 

value or less than a minimum value or both and calculates the area for thickness 

check. The Thickness type of analysis is available in Part and Assembly modes. 

Note: For clearance and interference checks, the accuracy of the calculation is 

determined by part accuracy. The accuracy of a clearance measurement or 

interference volume is controlled by the measure_sig_figures configuration option.  

If the selected objects do not interfere, the minimum clearance appears graphically 

as a red line. A small red circle with a crosshair appears at each end of the line to 

identify the location at which the clearance is being measured. The clearance value 

appears in the message window. If there is an interference between the selected 

objects, Pro/ENGINEER highlights the volume of interference and the curve or point 

of intersection in the graphics window, as appropriate for the selected items. 

Exploded views are only cosmetic and have no effect on clearance computations. The 

displayed results in such cases correspond to an unexploded model. 

Note: Adding a feature or creating a saved analysis is not possible in the Drawing 

mode. 

About Computing Mass Properties 

You can set the default mass units for all new parts and assemblies that you create 

using the pro_unit_mass configuration option.  

Mass properties for a part or assembly is calculated using system parameters within 

a relation. However, mass properties are not automatically updated when the model 

changes. You must recalculate the mass properties to see the effect of model 

changes. 

Note: In Welding assemblies, you can include or exclude welds from the mass 

properties calculation. Mass property calculations for light welds are approximate, 

unless you specify weld section references. Set the add_weld_mp configuration option 

to yes to include welds in the mass properties calculation. The default is no. 

If dimension bounds have been set, mass property calculations are based on 

hypothetical dimension values. 

If features are suppressed, the mass properties are calculated as if the features did 

not exist. If a part has been simplified for assembly purposes and contains many 

suppressed features, mass properties may be assigned to the part so that those 

values are used in calculating mass properties of an assembly. 
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If parts on layers have been blanked from the current view, they are still used to 

calculate the mass properties of an assembly. Blanking items only affects the display 

of the object, not its composition. 

The computed mass properties for a part or assembly include: 

• Volume—Total volume of the model 

• Surface area—Total surface area of the model 

• Density—For part mass properties, the specified part density is listed here. 

For assembly mass properties, the average density of its components is listed. 

The average density is calculated as the total mass divided by the total volume: 

Average density=(total mass of assembly)/(total volume of assembly) 

The density of each individual part is used in the calculation of the mass 

properties. 

• Mass—Total mass of the model 

• Center of gravity—Location of the center of gravity with respect to a specified 

coordinate system. The center of gravity and coordinate system are displayed 

graphically on the model. 

• Inertia tensor at the specified coordinate system origin and axes. The values are 

computed as follows: 

 

-and so forth. 

 

-and so forth 

-where ρ = specified part density. 

• Inertia tensor at the center of gravity and oriented along the specified coordinate 

system axes 

• Principal moments of inertia—Moments of inertia at the center of gravity with 

respect to the principal axes 

 

The principal coordinate axes, which define a new coordinate system, are labeled 

1, 2, 3 instead of x, y, z. In the preceding equation, y is the coordinate along the 

principal axis 2 and z is the coordinate along the principal axis 3. 
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• Rotation matrix and rotation angles—Rotation from the coordinate axes to the 

principal axes in matrix and angular form. Rotation matrix is computed as 

follows: 

 

-where ϕ is the rotation angle about the 1 axis, θ is the rotation angle about the 2 

axis, and ψ is the rotation angle about the 3 axis. 

Rotation Angles 

 

• Radii of gyration—The radii of gyration at the center of gravity with respect to the 

principal axes 

• For an assembly, a summary of the mass properties of its components 

To Analyze Mass Properties 

1. Click Analysis > Model > Mass Properties. The Mass Properties dialog box 

opens. Quick is the default analysis type. 

2. Click in the CSYS collector if it is not active by default and select a reference 

coordinate system. The name of the selected coordinate system is displayed in 

the collector. You can click the Use Default check box to select and use the 

default coordinate system. 

The result of the analysis is displayed in the result area at the bottom of the 

Mass Properties dialog box. You can view the report of the analysis in the 

Information Window by clicking . 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new coordinate 

system in the collector to create a new analysis. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save or create an analysis feature, perform the following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Mass Properties dialog box.  
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c. Select Saved to save the analysis with the model, and dynamically 

update the analysis while modeling or select Feature to create advanced 

features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to create or change feature options of the 

current analysis, if required. You can access the feature options such as 

parameters or datum features only when you select a feature type of 

analysis. 

5. Optionally, to customize or edit your analysis, perform the following steps:  

a. Specify the material density in the Density box or select a density 

value from the list of most recently used values in the Density box. The 

density value is saved with the model. The default material density is 1. 

Note: If a material file is already applied to the model, you cannot specify 

the material density. 

b. Change the relative accuracy or accept the default accuracy value, 

0.000010, in the Accuracy box. You can also select an accuracy value from 

the list of most recently used values in the Accuracy box. Part accuracy 

must not be less than 1/100th of the mass property accuracy. 

6. Click  to compute the analysis. A coordinate system is displayed at the 

center of gravity in the Pro/ENGINEER graphics window. 

To Compute the Mass Properties for a Cross Section 

Note: Cross-section mass properties are available only for planar x-sections. 

1. Click Analysis > Model > X-Section Mass Properties. The Cross Section 

Properties dialog box opens. Quick is the default analysis type. 

2. Select a cross section name for which you want to compute the mass properties 

in the Name list. 

Note: The Name list is available only if you have a cross section in the model. 

3. Click in the Plane collector if it is not active by default and select a reference 

datum plane. The name of the selected plane is displayed in the collector. 

4. Click in the CSYS collector and select a coordinate system. The name of the 

selected coordinate system is displayed in the collector. You can click the Use 

Default check box to select and use the default coordinate system.  

The result of the analysis is displayed in the result area at the bottom of the 

Cross Section Properties dialog box. You can view the report of the analysis in 

the Information Window by clicking . 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new plane and 

coordinate system in the collector to create a new analysis. 
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5. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

6. Optionally, to save or create an analysis feature, perform the following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Cross Section Properties dialog box. 

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

advanced features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to create or change feature options of the 

current analysis, if required. You can access the feature options such as 

parameters or datum features only when you select a feature type of 

analysis. 

7. Optionally, to customize or edit your analysis, change the relative accuracy or 

accept the default accuracy value, 0.000010, in the Accuracy box. You can also 

select an accuracy value from the list of most recently used values in the 

Accuracy box. 

8. Click  to compute the analysis. A coordinate system is displayed at the 

center of gravity of x-section in the Pro/ENGINEER graphics window. 

List of Computed Mass Properties for a Cross Section 

The computed mass properties for a cross section include the following: 

• Volume—Volume of the cross section. 

• Surface Area—Area of the cross section. 

• Density—Density of the mass of a cross section. 

• Mass—Total Mass of the cross section. 

• Center of gravity—Location of the center of gravity with respect to a specified 

coordinate system. The center of gravity and coordinate system are displayed 

graphically on the model. 

• Inertia tensor at the specified coordinate system origin and axes. 

• Inertia tensor at the center of gravity and oriented along the specified coordinate 

system axes. 

• Principal moments of inertia—Moments of inertia at the center of gravity with 

respect to the principal axes. 
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• The principal coordinate axes are labeled 1 and 2 instead of x and y. In the 

preceding equations, x is the coordinate along principal axis 1 and y is the 

coordinate along principal axis 2. 

• Polar moment of inertia—Cross-sectional polar moment of inertia at the center of 

gravity. 

 

• Rotation matrix and rotation angle—Rotation around the z-axis from the 

coordinate axes to the principal axes, in matrix and angular form. 

• Radii of gyration—The radii of gyration at the center of gravity with respect to the 

principal axes. 

• Section moduli and the corresponding points—Calculated for each principal axis 

(for example, 1-axis, 2-axis) by dividing the area moment of inertia with respect 

to the chosen axis by the distance to the point or points of the cross section that 

are farthest from the chosen axis. These points have the lowest (most negative) 

and highest (most positive) coordinate values along the orthogonal principal axis 

in the cross section plane. 

 Note: Cross section mass properties are not available for offset cross sections. 

To Calculate the Volume of One Side of a Model 

1. Click Analysis > Model > One-Sided Volume. The One Sided Volume dialog 

box opens. Quick is the default analysis type. 

2. Click in the Plane collector if it is not active by default and select a reference 

datum plane. The name of the selected plane is displayed in the collector. 

The result of the analysis is displayed in the result area at the bottom of the One 

Sided Volume dialog box. An arrow in the graphic window indicates the side for 

which the volume is calculated. You can flip the arrow to change the direction by 

clicking on the arrow in the graphic window. You can view the report of the 

analysis in the Information Window by clicking . 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new plane in the 

Plane collector to create a new analysis. 
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3. Click  to complete the analysis or  to cancel the analysis. 

 Alternatively, click  to start a new analysis. 

4. Optionally, to save or create an analysis feature, perform the following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

One Sided Volume dialog box.  

c. Select Saved to save the analysis with the model, and dynamically 

update the analysis while modeling or select Feature to create advanced 

features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to create or change feature options of the 

current analysis, if required. You can access the feature options such as 

parameters only when you select a feature type of analysis. 

5. Optionally, to customize or edit your analysis, change the relative accuracy or 

accept the default accuracy value, 0.000010, in the Accuracy box. You can also 

select an accuracy value from the list of most recently used values in the 

Accuracy box.  

6. Click  to compute the analysis. 

To Calculate Clearance Between Two Entities 

1. Select any two curves, edges, datum points, surfaces, pipe segments in Assembly 

mode, cable segments in Assembly mode, cables in Assembly mode, parts in 

Assembly mode, or components in Assembly mode. 

2. Click Analysis > Model > Pairs Clearance. The Pairs Clearance dialog box 

opens. Quick is the default analysis type. 

3. Click  to complete the analysis or  to cancel the analysis. 

 Alternatively, click  to start a new analysis. 

4. Optionally, to save or create an analysis feature, perform the following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Pairs Clearance dialog box.  

c. Select Saved to save the analysis with the model, and dynamically 

update the analysis while modeling or select Feature to create advanced 

features. 

d. If required, rename the analysis in the box adjacent to the list. 
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e. Click the Feature tab to create or change feature options of the 

current analysis, if required. You can access the feature options such as 

parameters or datum features only when you select a feature type of 

analysis. 

5. Optionally, to customize or edit your analysis, perform the following steps: 

a. Click in the From collector and select the required entity. The name of 

the selected entity is displayed in the From collector. If the From entity is 

a surface, Whole surface and Near pick options are activated to select 

the Geometry from which you want to calculate the clearance . Whole 

surface is selected by default. If you click Near pick, you can select only a 

surface in the To collector.  

Note: In the Assembly and Drawing mode, you can also select quilts or facets of 

the selected part, subassembly, surface, or cable in the From and To collectors 

to compute the clearance. 

b. Click in the To collector and select the required entity. The name of 

the selected entity is displayed in the To collector. 

6. Select a reference plane, coordinate system, surface, axis, edge, curve, or datum 

plane in the Projection Reference collector. The projected clearance and actual 

clearance are displayed in the result area at the bottom of the Pairs Clearance 

dialog box. 

7. If required, click  to view the projected clearance and actual clearance report 

in the Information Window. 

Note: If you select a coordinate system to project the direction in the Pairs 

Clearance dialog box, you can select the required coordinate system in the 

Pro/ENGINEER graphics window. Projected clearance is displayed for the x-, y-, 

and z- directions. 

8. Click  to compute the analysis. The clearance between the two entities is 

displayed in the result area at the bottom of the Pairs Clearance dialog box. 

To Display Global Clearance Information 

1. Click Analysis > Model > Global  Clearance. The Global Clearance dialog 

box opens. Quick is the default analysis type. 

2. Select Parts only or Sub-assembly only as a Setup value, to calculate the 

global clearance between parts or assemblies. 

3. Click the Include Harness check box if harnesses are present in the assembly. 

4. Specify the clearance value in the Clearance box . You can also select the 

clearance value from the list of most recently used values in the Clearance box. 



Pro/ENGINEER Fundamentals 

199 

5. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

6. Optionally, select Saved in the list at the bottom of the Global Clearance dialog 

box to save the analysis with the model, and dynamically update the analysis 

while modeling. 

7. If required, rename the analysis in the box adjacent to the list. 

8. Click  to compute the analysis. The result of the analysis is highlighted in 

the Pro/ENGINEER graphics window. 

Pairs of components within the specified clearance value are displayed in the 

result area at the bottom of the Global Clearance dialog box. You can view the 

report of the analysis in the Information Window by clicking . 

9. Click Show All to highlight the result of the analysis in the Pro/ENGINEER 

graphics window or Clear to clear the clearance items and the result of analysis. 

To Display Closed Quilt Volume Interference 

1. Click Analysis > Model >  Volume Interference. The Volume Interference 

dialog box opens. Quick is the default analysis type. 

2. click in the Quilt collector if it is not active by default and select the required 

quilt. The name of the selected quilt is displayed in the Quilt collector. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, select Saved in the list at the bottom of the Volume Interference 

dialog box to save the analysis with the model, and dynamically update the 

analysis while modeling. 

5. If required, rename the analysis in the box adjacent to the list. 

6. Click  to compute the analysis. The parts that interfere with the selected 

quilt and the area of interference are highlighted in the Pro/ENGINEER graphics 

window. 

A list of parts that interfere with the quilt is displayed in the result area at the 

bottom of the Volume Interference dialog box. You can view the report of the 

analysis in the Information Window by clicking . 

7. Click Show All to display the result of the analysis in the Pro/ENGINEER graphics 

window or Clear to clear the collector and the result of analysis. 
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To Display Global Interference Information 

1. Click Analysis > Model > Global Interference. The Global Interference 

dialog box opens. Quick is the default analysis type. 

2. Select Parts only or Sub-assembly only as a Setup value to compute the 

interference for parts or subassemblies. 

3. Click Include Quilts to include surface quilts in the computation. 

4. Click Include Facets to include facets in the computation. 

5. Select a value for Compute. Click Exact to obtain a complete and detailed 

computation or Quick to perform a quick check. Quick lists any pair of parts or 

subassemblies that interfere. Exact also highlights the volume of interference. 

6. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

7. Optionally, to save or create an analysis feature, perform the following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Global Interference dialog box.  

c. Select Saved to save the analysis with the model, and dynamically 

update the analysis while modeling or select Feature to create advanced 

features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to create or change feature options of the 

current analysis, if required. You can access the feature options such as 

parameters only when you select a feature type of analysis. 

8. Click Show All to display the result of the analysis in the Pro/ENGINEER graphics 

window. 

Alternatively, click Show All and then Clear to graphically view the result one by 

one. If you select Quick to perform a quick check, click Verify to verify the 

result in exact conditions and display the interference volume. 

9. Click  to compute the analysis. Pairs of components that interfere are 

highlighted in the Pro/ENGINEER graphics window and displayed in the result 

area at the bottom of the Global Interference dialog box. You can view the 

report of the analysis in the Information Window by clicking . 

To Compare Edge Lengths 

1. Click Analysis > Model > Short Edge. The Short Edge dialog box opens. 

Quick is the default analysis type. 
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2. Click in the Part collector and select a part for analysis. 

Note: The  Part collector is available only in the Assembly mode. 

3. Select a Quick or Saved type of analysis. Quick is the default. Click Saved to 

save the analysis with the model, and to display and dynamically update the 

analysis while modeling. 

4. For a saved type of analysis, accept the default name for the current analysis or 

rename the analysis if required. 

5. The length of the shortest edge in a selected part or component is displayed in 

the Length box. In the Length box, type a new length or use the default length. 

The number of edges that are shorter than the specified length is displayed in the 

result area at the bottom of the Short Edge dialog box. You can view the report 

of the analysis in the Information Window by clicking . 

6. Click  to compute the analysis. The result of the analysis is highlighted in 

the Pro/ENGINEER graphics window. 

7. Click  to start a new analysis, if required. 

8. Click  to complete the analysis or  to cancel the analysis. 

To Display Edge Type Information 

1. Click Analysis > Model > Edge Type. The Edge Type dialog box opens. Quick 

is the default analysis type. 

2. Click in the Edge collector and select an edge for analysis. The name of the 

selected edge is displayed in the Edge collector. 

The result of the analysis is displayed in the result area at the bottom of the 

Edge Type dialog box.  

3. Optionally, Select Saved type of analysis to save the analysis with the model, 

and dynamically update the analysis while modeling. 

4. If required, rename the analysis. 

5. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

To Check the Thickness of a Part 

1. Select a plane in the part to check the thickness of the part. 

2. Click Analysis > Model > Thickness. The Thickness dialog box opens. Quick 

is the default analysis type. 
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3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis, perform the following steps: 

a. Select Saved from the list at the bottom of the Thickness dialog box 

to save the analysis with the model, and to displays and dynamically 

updates the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 

5. Optionally, to customize or edit your analysis, perform the following steps: 

a. Click in the Planes collector and select a plane. The name of the 

selected plane is displayed in the Planes collector.  

Note: If you select a plane, From Slices, To Slices, Direction, Use 

number of slices, and Offset become unavailable. 

b. If you do not select a plane, select the start and end points to insert 

the number of slices between the points in the model. Click in the From 

Slices collector and select a vertex as the start point. Similarly, click in the 

To Slices collector and select a vertex as the end point. The names of the 

selected start and end points appear in the From and To collector, 

respectively.  

c. Click in the Direction collector and select a surface, curve, edge, axis, 

or coordinate system. An arrow in the graphic window indicates the surface, 

curve, edge, axis, or coordinate system for which the thickness is 

calculated. 

d. Click the Use number of slices check box to specify the number of 

slices or use the default value. 

e. Click the Offset check box and change the offset value if necessary. 

f. Specify the maximum and minimum thickness values in the Max and 

Min boxes, respectively. You can also select maximum and minimum 

values from the list of most recently used values in the Max and Min 

boxes. 

6. Click  to compute the analysis. The result of the analysis is highlighted in 

the Pro/ENGINEER graphics window. 

The Results box displays the names of parts that have a thickness greater than 

the specified maximum value or less than the minimum value or both and also 

displays the area selected for the thickness check. You can view the report of the 

analysis in an Information Window. 

When the thickness check is complete, the cross-section is highlighted as follows: 

o Yellow—Thickness is between the specified maximum and minimum 

values. 
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o Red border—Thickness exceeds the specified maximum value. 

o Blue border—Thickness is below the specified minimum value. 

7. Click Show All to highlight the result in the Pro/ENGINEER graphics window or 

click Clear to clear the results. 

Example: Thickness Check 

Thickness Check Using a Plane 

 

1. Regions within the cross section that violate the maximum thickness are 

highlighted in red. 

2. The cross section of the model displays cross-hatching in yellow. 

Thickness Check Using Slices 

 



Pro/ENGINEER Fundamentals – Help Topic Collection 

204 

1. The cross section of the model displays cross-hatching in yellow. 

2. Regions within the cross section that violate the maximum thickness are 

highlighted in red. 

Performing Measure Operations 

About Measuring a Model Geometry 

Using the measure analysis, you can measure model geometry with one of the 

following commands: 

• Distance—Measures the distance between two entities. 

• Length—Measures the length of the curve or edge. 

• Angle—Measures the angle between two entities. 

• Area—Measures the area of the selected surface, quilt, facets, or an entire 

model. 

• Diameter—Measures the diameter of the surface. 

• Transform—Displays a note pointing to the second coordinate system. 

Note: In Assembly mode, all measurements are based on the unexploded 

assembly distances. Exploding an assembly affects only the view of the assembly 

components. 

Types of Geometry 

Geometry Type Description 

Length Measures the length of the selected edge or 

curve, or chain of curves or edges. 

Distance Measures distances with respect to a basic entity 

(From). After you have selected the basic entity, 

you can measure as many distances from it as 

you like by selecting various other entities (To). 

Calculates all the distances with respect to the 

first entity until you restart the measuring 

process by selecting a new basic entity. 

Angle Measures the angle between two entities. The 

entities can be axes, planar curves, planar 

nonlinear edges, planar faces, or datum planes. 

Area Measures the area of any surface on the part or 

the area of a quilt or the area of a selected 

surface. 
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Geometry Type Description 

Diameter Measures the diameter of any part surface that 

you have created by revolving a sketched entity 

or extruding an arc or a circle. 

Transform Generates a transformation file containing the 

transformation matrix values between two 

coordinate systems. This information is in a 

format that is required to create other coordinate 

systems using the From File option available in 

the Offset type list of the COORDINATE 

SYSTEM dialog box. 

 

To Measure a Distance in an Object 

1. Click Analysis > Measure > Distance. The Distance dialog box opens. Quick 

is the default analysis type. 

2. Click in the From collector if it is not active by default and select an entity. This 

entity can be a vertex, datum point, scan point, coordinate system, edge or 

curve, scan curve, scan curve location, axis, curve feature, surface, quilt, facet 

vertex, facet edge, face location, curve location, edge location, pipe segment (in 

assembly mode), cable segment (in assembly mode), part (in assembly mode), 

or a component (in assembly mode). 

3. Click in the To collector and select a second entity. This entity can be any entity 

listed for the first entity. 

The distance between the two selected entities is calculated and displayed in the 

result area at the bottom of the Distance dialog box and in the Pro/ENGINEER 

graphics window. A leader points to the entity displaying the computed distance. 

4. Click  to complete the analysis or  to cancel the analysis. 

 Alternatively, click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Distance dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

advanced features. 

d. If required, rename the analysis in the box adjacent to the list. 
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e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

6. Optionally, to customize or edit your analysis, select the required entities in the 

From and the To collector.  

o If you select a plane as either the From or To entity, then the Use As 

Plane check box becomes available and is selected by default. Use As 

Plane allows you to measure the distance between the two entities normal 

to the plane. 

o If you select a curve or edge that appears like an arc or circle as the From 

or To entity, the Use Center check box becomes available and is selected 

by default. Use Center allows you to measure the distance between the 

center of the selected curves or edges that appear like an arc or circle. 

Clear this check box if you want to use the edge or circle and not the center 

of the circle or arc of the From or To entity. 

o If you select a surface that appears like a cylindrical surface or a true 

cylindrical surface as the From or To entity, the Use Center Axis check box 

becomes available and is selected by default. Use Center Axis uses the 

center axis of the surface to measure the distance between the two entities. 

Note: You can switch between the From and To entities or collectors by right-

clicking in the Pro/ENGINEER graphics window and using the shortcut menu. 

7. Click the View Plane check box to view the projected distance and the actual 

distance between the two entities in the graphics window. If you clear the View 

Plane check box, then the Projection Direction collector is activated. 

8. Select a reference plane, surface, axis, edge, curve, coordinate system, pipe 

segment (in assembly mode), or cable segment (in assembly mode) to project 

the distance in the Projection Direction collector. The projected distance and 

actual distance are displayed in the result area at the bottom of the Distance 

box. 

Note: If you select a coordinate system in the Projection Direction collector, 

then CSYS becomes available and you can select the required coordinate system, 

that is, one of Cartesian, Cylindrical, or Spherical. 

9. Update is selected by default. You can see the effects of your selections as you 

make them. Clear the Update check box to select or adjust multiple analysis 

options, and click  to view the result of the analysis. 

Tip: Measuring the Distance From an IBL Curve to Another Feature 

If a feature such as a curve consists of multiple datum curves and you measure the 

distance between the curve and another entity such as an axis, then if you select a 

specific curve segment to measure the distance from, Pro/ENGINEER calculates the 

shortest distance between that segment and the feature. 
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When you create multiple curve segments with an IBL file and measure the length of 

these segments using Analysis > Measure > Length, Pro/ENGINEER calculates the 

shortest distance between the entire IBL curve and the axis, and not from the 

individual segment. 

If you do not want Pro/ENGINEER to include the entire IBL curve in the 

measurement of the distance between the IBL curve and the axis, then you can 

create a composite curve on one of the segments and measure the distance from the 

composite curve. For information on creating a composite curve, refer to the 

Pro/ENGINEER help topics on creating datum curves. 

To Measure an Angle in an Object 

1. Click Analysis > Measure > Angle. The Angle dialog box opens. Quick is the 

default analysis type.  

2. Click in the From collector if it is not active by default and select a curve, edge, 

axis, surface, facet edge, or pipe segment (in assembly mode). 

3. Click in the To collector and select an entity. This entity can be any entity listed 

for the first entity. 

The angle between the two selected entities is calculated and displayed in the 

result area at the bottom of the Angle dialog box. The direction of the angle is 

determined by the right hand rule and is displayed as an arrow in the 

Pro/ENGINEER graphics window. A leader points to the angle displaying the 

computed angle in degrees. Clicking the arrow flips the direction of the entities 

and the angle is recomputed.  

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Angle dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

advanced features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis 

6. Optionally, to customize or edit your analysis, click in the Direction collector and 

select a reference plane or surface, curve, edge, axis, facet edge, pipe segment 
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(in assembly mode), or cable segment (in assembly mode) to project the angle in 

the Direction collector.  

7. Select the range for plotting that is, one of 0-360 and +/-180 and adjust the 

scale of the plot using the thumbwheel or specify the required scale in the Scale 

box. 

Example: Measuring Distances and Angles 

Measuring the Minimum Distance between Two Curves  

 

1. First entity (curve) 

2. Second entity (curve) 

3. Minimum distance 

Measuring the Minimum Distance between Two Linear Entities 

 

1. First entity 

2. Minimum distance 

3. Second entity 

Measuring the Angle between a Plane and a Line 
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1. Planar curve 

2. The smaller angle between DTM1 and DTM2 is the angle between DTM1 and the 

curve. 

To Measure a Curve Length 

1. Click Analysis > Measure > Length. The Length dialog box opens. Quick is 

the default analysis type.  

2. Click in the Curve collector if it is not active by default and select a curve, edge, 

chain, facet edge, feature, or pipe segment (in assembly mode). The name of the 

selected entity is displayed in the Curve collector. 

The length of the selected curve or edge is displayed in the result area at the 

bottom of the Length dialog box and in the Pro/ENGINEER graphics window. A 

leader points to the curve or edge displaying the computed curve length. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Length dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

advanced features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 
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5. Optionally, to customize or edit your analysis, click Detail under the Curve 

collector and select the required chain type in the Chain dialog box that opens. 

You can select standard or rule-based curves in the References collector in the 

Chain dialog box. 

To Measure the Area of an Object 

1. Click Analysis > Measure > Area. The Area dialog box opens. Quick is the 

default analysis type. 

2. Click in the Geometry collector if it is not active by default and select an entity 

such as a surface, quilt, facets, or a component. The name of the selected entity 

is displayed in the Geometry collector. 

The area for the selected entity is displayed in the result area at the bottom of 

the Area dialog box and in the Pro/ENGINEER graphics window. A leader points 

to the surface displaying the computed area. 

Note: The calculated area has a marginal error of about 0.15%. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Area dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

advanced features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

5. Optionally, to customize or edit your analysis, click in the Direction collector and 

select a reference plane or surface, axis, edge, curve, pipe segment (in assembly 

mode), or cable segment (in assembly mode) to project the area. 

To Measure a Diameter in an Object 

1. Click Analysis > Measure > Diameter. The Diameter dialog box opens. Quick 

is the default analysis type. 

2.  Click in the Surface collector if it is not active by default and select a surface for 

diameter measurement. The name of the selected surface is displayed in the 

Surface collector. 
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The diameter for the selected surface is displayed in the result area at the bottom 

of the Diameter dialog box and in the Pro/ENGINEER graphics window. A leader 

points to the diameter displaying the computed diameter. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Diameter dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

advanced features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

5. Optionally, to customize or edit your analysis, click in the Point collector and 

select a point such as datum point, face location, curve location, cable or edge 

location at which the diameter must be measured. 

To Generate a Transformation File 

1. Click Analysis > Measure > Transform. The Transform dialog box opens. 

Quick is the default analysis type. 

2. Click in the From collector and select the first coordinate system.  

3. Click in the To collector and select the second coordinate system. 

A transformation matrix between two coordinate systems in an object is 

displayed in the result area at the bottom of the Transform dialog box and as a 

note pointing to the second coordinate system in the Pro/ENGINEER graphics 

window. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis, perform the following steps: 

a. Select Saved from the list at the bottom of the Transform dialog box 

to save the analysis with the model, and to display and dynamically update 

the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 
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To Measure Draft Entities in Drawings 

1. Open the required drawing. 

2. Click Analysis > Measure Draft Entities. The Draft Measure dialog box and 

the SELECT dialog box open. 

3. Under Type, select the type of draft to measure. 

4. Under From and To, select the first and second entity, respectively. 

Note: To display the SELECT dialog box again, click . 

5. If you select an angle, you can select Use horizontal to calculate the angle, 

instead of selecting a second entity. 

6. Click Compute. The result appears in the Results box. The displayed result 

includes the angle, distance, intersection point, and tangent point. 

7. Click Compute to perform another analysis and Info to display the results in an 

Information Window. 

8. To create a new analysis feature that uses the current analysis definition, click 

Add Feature. You are prompted to specify a name for the analysis feature or use 

the default name. 

9. Press ENTER to save the analysis feature. 

10. Click Close to close the Draft Measure dialog box. 

For more information on obtaining drawing information, refer to the topics on 

drawings in the Detailed Drawings module of the Pro/ENGINEER Help Center. 

Analyzing Curves 

About Analysis Types 

When performing analysis, you can select one of the following analysis types: 

• Quick—Displays the results of your selections at real time as you make them. 

Quick is the default. 

• Saved—Saves the analysis with the model. Saved dynamically updates the 

analysis results as you change the geometry. The saved analysis is displayed in 

the Pro/ENGINEER graphics window until you explicitly hide or delete it using the 

Saved Analysis dialog box. 

Note: Use Analysis > Saved Analysis to access a saved analysis. 

• Feature—You can create a new feature from the current analysis of the selected 

point, radius, curvature, dihedral angle, offset, and deviation or their modified 

measurement. The new feature name is displayed in the model tree. Parameters 

and datums can be created for analysis features. Analysis features are used in 

BMX and other applications. 
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Note: Only some analysis types support feature creation. 

Using Any Analysis Dialog Box 

A separate dialog box opens for each type of analysis. These dialog boxes allow you 

to select the type of analysis, references, and set the options. The analysis controls 

are organized into the following tabbed pages: 

• Analysis—You can select entities as references for the analysis. While all 

analyses have at least one selection set for references, some have additional 

selection sets such as a coordinate system, datum plane, datum axis, and so on 

depending on the type of analysis you select. You can define an analysis with 

options such as plot type, quality, and scale. 

You can also select a Quick, Saved, or Feature type of analysis. Quick allows 

you to create a temporary analysis. Saved allows you to create a permanent 

analysis which is saved with the model while Feature allows to create a new 

feature for an analysis. 

Note: Feature is available only for those analysis types that supports feature 

creation. 

The result of the analysis is displayed in the result area at the bottom of the 

dialog box that opens depending on the type of analysis you select. Wherever 

applicable, you can also click  to display the result of the analysis graphically, 

in the Graphtool window. The values of the parameters are also included in the 

analysis for the selected curve or edge. 

Click  to view the result in an INFORMATION WINDOW.  

• Feature—To regenerate the analysis feature, set the regeneration state to one of 

the following: 

o Always—Always regenerates the analysis feature during the model 

regeneration. 

o Read Only—Excludes the analysis feature from the model regeneration. 

o Only Design Study—Regenerates the analysis feature only when it is used 

by a design study. 

You can create datums and parameters as a part of the feature. You can rename 

the parameter or datums of the selected entities, or accept the default name. 

Feature allows you to display datums for the current analysis. 

Note: If you click  to start a new analysis, the result of the previous analysis in 

the result area at the bottom of the dialog box is cleared. On selecting a new entity, 

the result of the new analysis is displayed in the result area. 
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Setting Plotting Resolution 

You can improve the resolution of plotting using one of the following sampling types. 

These sampling types are available in the dialog box that opens for analyzing an 

offset curve, offset surface, cross sections of a surface, shaded curvature of a 

surface, shadow, curvature of a curve or edge, curvature of surface, slope of a 

surface, dihedral angle for an edge or curve, and draft check analysis. 

• Quality—The quality of the plot is based on the number of sample points. 

Pro/ENGINEER performs the analysis for the number of samples that you specify 

as a value for Quality. Specify a higher value for Quality when you want the 

quality of the plot to be high. The percentage quality of the plot ranges from 0 

through 100. Quality is the default. 

Note: Specifying a higher value for Quality may increase the time taken for the 

analysis. 

• Number—Indicates the number of samples on the curve or surface for which you 

are performing the analysis. The number of samples must always be greater than 

1. A higher number of samples uses more sampling points, which in turn 

improves the accuracy of the analysis. 

• Step—The distance between two sample points that you have specified for 

performing the analysis. This value increments the distance between the sample 

points by one step. This value must always be greater than 0.001. A lesser step 

value increases the accuracy of the plot. 

You can change these values using the thumbwheel or the slider. 

About Analyzing Curves 

Curve analysis followed by surface analysis are used for surface modeling. Curve 

analysis checks the quality of curves or the continuity between curves before the 

surfaces are built from them. This analysis helps to ensure that the resultant 

surfaces are of good quality. 

Use Analysis > Geometry and select one of the following analysis types to perform 

a curve analysis: 

• Point—Evaluates a normal curvature vector at a datum point or a specified point 

on a curve or edge. Displays the curvature, normal, tangent, and radius at the 

selected point on the curve or edge. You can also specify a coordinate system. 

• Radius—Evaluates and displays the minimum radius for a curve or edge at the 

selected point. The radius is equal to 1/curvature. 

• Curvature—Evaluates and displays the curvature of curves or edges. 

Mathematically, the curvature is equal to 1/radius. 

• Offset—Evaluates and displays an offset for a selected set of curves or edges. 

You must also select a reference plane to display the offset. 

• Deviation—Evaluates and displays the deviation from a curve or edge to a 

datum point, curve, or datum point array. 
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To Display Information About a Point on a Curve or Edge 

1. Click Analysis > Geometry > Point. The Point dialog box opens. Quick is the 

default analysis type. 

2. Click in the Point collector and select a datum point or point on a curve or edge 

of the object for analysis. The name of the selected datum point or point on curve 

or edge is displayed in the Point collector and the corresponding reference 

coordinate system is selected in the CSYS collector. 

The normal vector for each newly selected entity is computed and is displayed in 

the result area at the bottom of the Point dialog box. The direction of the vector 

is determined by the right hand rule and is displayed as an arrow for the tangent 

vector, normal vector, and the radius in the Pro/ENGINEER graphics window. A 

point analysis reports the point, curvature, normal, tangent, dihedral edge point, 

and radius at the selected point. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select a point or 

coordinate system in the collector. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Point dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 

d. If required, rename the analysis in the box adjacent to the list. 

Note: A point analysis reports the point, normal, minimum curvature, and 

maximum curvature at the selected point in the result area at the bottom of 

the Point dialog box. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

5. Optionally, to customize or edit your analysis, adjust the scale in the Scale box 

using the thumbwheel or type the value in the Scale box. You can also adjust the 

scale graphically using the handle on the point. 

Point Information on the Edge or Curve 

A normal to the surface at a selected point is a normal curvature vector. Principal 

curvature vectors are determined as follows: for every plane that contains the 
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normal vector, there is a curve of intersection of this plane with the surface. 

Pro/ENGINEER evaluates all the intersection curves to determine the maximum and 

minimum curvature value. 

There can be only one curvature value if it is the same for all planes. The curvature 

values are called the principal curvatures of the surface at the specified point. 

Curvatures can be positive or negative. If the curve turns in the direction away from 

the normal, it is indicated by a negative sign. The intersection of planes that contain 

the principal curvatures with the tangent plane defines the principal directions. 

 

To Display Minimum Radius of a Curve or Edge 

1. Click Analysis > Geometry > Radius. The Radius dialog box opens. Quick is 

the default analysis type. 

2. Click in the Geometry collector and select one or more curves or edges on the 

object for the analysis. The name of the selected curve or edge is displayed in the 

Geometry collector. 

The minimum radius value for the selected curve or edge is computed and 

displayed in the result area at the bottom of the  Radius dialog box. A vector is 

displayed with the minimum radius value for the selected curve or edge in the 

Pro/ENGINEER graphics window. 

Note:To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new entities in 

the collector to create a new analysis. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 
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a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Radius dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

5. Optionally, to customize or edit your analysis, perform the following steps: 

a. Select one of the following types of plot in the Plot list: 

o Inside & Outside—Displays both the inside and outside minimum radius of 

the selected curve or edge. 

o Inside—Displays the inside minimum radius of the selected curve or edge. 

o Outside—Displays the outside minimum radius of the selected curve or 

edge. 

b. Adjust the scale of plot using the thumbwheel or type a value in the 

Scale box. You can also adjust the scale graphically using the handle on 

the entity. 

To Display the Curvature of a Curve or Edge 

1. Click Analysis > Geometry > Curvature. The Curvature dialog box opens. 

Quick is the default analysis type. 

2. Click in the Geometry collector and select one or more curves or edges for the 

analysis. The name of the selected entity is displayed in the Geometry collector. 

The minimum and maximum curvature of the selected curve or edge is 

computed. The result is displayed in the result area at the bottom of the 

Curvature dialog box. A curvature plot for the selected curve or edge is 

displayed in the Pro/ENGINEER graphics window.  

Note:To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new entities in 

the collector to create a new analysis. 

3. Click  to complete the analysis or  to cancel the analysis. 

 Alternatively, click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps. 

a. Click the Analysis tab if it is not selected by default. 
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b. Select the desired analysis types from the list at the bottom of the 

Curvature dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 

d. If required, rename the analysis in the box adjacent to the list. 

d. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

5. Optionally, click  to display the analysis result in a separate window. The 

Graphtool window opens and the result of the analysis with the parameter 

values for the selected curve is graphically represented in the Graphtool 

window. 

6. Optionally, to customize or edit your analysis, perform the following steps: 

a. Select Curvature, Radius, or Tangent type of plot in the Plot box. 

Curvature is the default. 

o Curvature—Evaluates and plots the curvature along the selected curves or 

edges. For a single surface, evaluates and plots the curvature of surface in 

both the directions as isolines. 

o Radius—Evaluates and plots the radius along the selected curves and 

edges. 

o Tangent—Evaluates and plots the tangents along the selected curves and 

edges. 

Note: You cannot create a new feature for analysis with a Tangent plot. 

b. Select the Quality, Number, or Step type of sampling in the Sample box. 

Quality is the default. Adjust the sample values using the thumbwheel or 

slider. 

Note: The number of samples must be greater than 1 and the incremental 

value for the step must be greater than 0.001 in model units. 

c. Adjust the scale of plot using the thumbwheel or type a value in the Scale 

box. You can also adjust the scale graphically using the handle on the curve 

or edge. 

d. Select the required plotting style. 

e. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. 
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Example: Curvature of a Curve or Edge 

The following example shows the curvature (1/radius), including the minimum and 

maximum curvature values for the selected edge or curve on an object. 

 

To Display an Offset Curve 

1. Click Analysis > Geometry > Offset. The Offset dialog box opens. Quick is 

the default analysis type. 

2. Click in the Geometry collector and select a curve or a set of curves that you 

want to offset. The name of the selected curve or curves are displayed in the 

Geometry collector. 

3. Click in the  Plane collector and select a reference plane for the offset. The name 

of the selected reference plane is displayed in the Plane collector. 

The selected curves are offset using the default offset distance and displayed in 

the Pro/ENGINEER graphics window.  

Note:To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new curve or 

plane in the collector to create a new analysis. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis, perform the following steps: 

a. Select Saved from the list at the bottom of the Offset dialog box to 

save the analysis with the model, and to display and dynamically update 

the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 

6. Optionally, to customize or edit your analysis, perform the following steps: 

a. Specify the offset distance in the Offset box. The default offset 

distance is 0.0. You can graphically drag the handle to adjust the offset 

distance or change the value directly in the Pro/ENGINEER graphics 

window.  
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b. Select the Quality, Number, or Step type of sampling in the Sample 

box. Quality is the default. Adjust the sample values using the slider or 

thumbwheel.  

c. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. 

Example: Offset Curve 

The following example shows an offset for the selected edge or curve on an object. 

 

To Display Deviation of a Curve or Edge 

1. Click Analysis > Geometry > Deviation. The Deviation dialog box opens. 

Quick is the default analysis type.  

2. Click in the From collector and select a curve or edge. The name of the selected 

curve or edge is displayed in the From collector. 

3. Click in the To collector and select a datum point, scan curve, or datum point 

array for which you want to measure the deviation in the To collector.  

The minimum and maximum deviation is computed and displayed in the result 

area at the bottom of the Deviation dialog box, and the Pro/ENGINEER graphics 

window. The deviation plot is displayed with green and red lines where green 

denotes deviation within tolerance and red denotes deviation beyond tolerance. 

Note:To clear the contents of the  From and To collectors, right-click in the 

collectors and click Remove on the shortcut menu. You can then continue to 

select the From and To entities in the collectors. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 
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b. Select the desired analysis types from the list at the bottom of the 

Deviation dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

advanced features. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

6. Optionally, to customize or edit your analysis, perform the following steps: 

a. Adjust the scale of plot using the thumbwheel or type the required 

scale value in the Scale box. You can also adjust the scale graphically using 

the handle on the entity.  

b. Adjust the threshold value using the thumbwheel or type the required 

threshold value in the Threshold box. You can change the threshold value 

graphically by changing the value directly in the Pro/ENGINEER graphics 

window. 

c. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. 

Analyzing Surfaces 

About Analyzing Surfaces 

Curve and surface analysis is used for surface modeling. A surface analysis is 

performed after curve analysis to check the quality of the surface. Along with the 

connections that it shares with its adjacent surfaces, a surface needs to be of high 

quality. This analysis also checks if the surface can be offset by the specified 

thickness value. 

Surface analysis is an iterative process. After modifying or finalizing a shape, you can 

determine the suitability of the surface model for thickening and production. You can 

analyze surface properties in both Part and Assembly mode. 

Use Analysis > Geometry and select one of the following options to perform a 

surface analysis: 

• Dihedral Angle—Displays the angle between the normals of two surfaces that 

share an edge. This is an useful check for continuity during the evaluation of 

neighboring surfaces. 

• Point—Evaluates a normal curvature vector at a datum point or a specified point 

on the surface. Analyzes and reports the curvature, normal, tangent, dihedral 

edge point, and radius at the selected point on the curve or edge. You can also 

specify a coordinate system. 
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• Radius—Displays the minimum radii for a surface. The radius is equal to 

1/curvature. 

• Curvature—Evaluates and displays the curvature of surface. Mathematically, the 

curvature is equal to 1/radius. 

• Offset—Displays an offset for a selected set of surfaces. 

• Deviation—Displays the deviation from a surface or datum plane to a datum 

point, curve, or datum point array to which you want to measure the deviation. 

• Sections—Evaluates surface continuity, especially across shared boundaries. 

• Shaded  Curvature—Evaluates and displays the smallest and largest normal 

curvature for every point on a surface. Color values are assigned in ranges to 

show curvature. Values towards the red and blue ends of the spectrum indicate 

maximum and minimum curvatures, respectively. 

• Draft—Analyzes a part design to determine if a draft is necessary for the part to 

be used in a mold. Displays a color plot of the draft. 

• Slope—Displays, in color, the slope of a surface relative to a reference plane, 

coordinate system, curve, edge, or datum axis on a part. 

• Reflection—Displays curves that represent the reflection due to linear sources of 

light on a surface when viewed from the specified direction. The reflection 

analysis is a shaded analysis. To view changes in the reflection, spin the model 

and observe the dynamic changes in the display. 

• Shadow—Displays a color plot of the shadow area cast by a surface or model on 

another surface with reference to a datum plane, coordinate system, curve, edge, 

or axis. 

To Display Information About a Point on a Surface 

1. Click Analysis > Geometry > Point. The Point dialog box opens. Quick is the 

default analysis type. 

2. Click in the Point collector and select a datum point or point on a surface of the 

object for analysis. The name of the selected entity is displayed in the Point 

collector and the corresponding reference coordinate system is selected in the 

CSYS collector. 

The normal vector for each newly selected entity is computed and is displayed in 

the result area at the bottom of the Point dialog box. The direction of the vector 

is determined by the right hand rule and is displayed as an arrow for the tangent 

vector, normal vector, and the radius in the Pro/ENGINEER graphics window. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select a point or 

coordinate system in the collector. 
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3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Point dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 

d. If required, rename the analysis in the box adjacent to the list. 

Note: A point analysis reports the point, normal, minimum curvature, and 

maximum curvature at the selected point in the result area at the bottom of 

the Point dialog box. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a Feature type of analysis. 

5. Optionally, to customize or edit your analysis, adjust the scale using the 

thumbwheel or type the value in the Scale box. You can also adjust the scale 

graphically using the handle on the point. 

To Display Surface Radii 

1. Click Analysis > Geometry > Radius. The Radius dialog box opens. Quick is 

the default analysis type. 

2. Click in the Geometry collector and select one or more surfaces or quilts on the 

object for analysis. The name of the selected entity is displayed in the Geometry 

collector. 

The minimum inside radius and minimum outside radius for the selected surface 

is computed and their values are displayed in the result area at the bottom of the 

Radius dialog box. Vectors with the minimum inside radius and minimum outside 

radius value for the selected surface are also displayed in the Pro/ENGINEER 

graphics window. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select one or more 

surfaces or quilts in the collector. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 
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4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Radius dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a Feature type of analysis. 

5. Optionally, to customize or edit your analysis, perform the following steps: 

a. Select one of the following types of plot in the Plot list. 

o Inside & Outside—Displays both the inside and outside minimum radius of 

the selected surface. 

o Inside—Displays the inside minimum radius of the selected surface. 

o Outside—Displays the outside minimum radius of the selected surface 

b. Adjust the scale of plot using the thumbwheel or type a value in the 

Scale box. You can also adjust the scale graphically using the handle on 

the plot. 

To Display the Curvature of a Surface 

1. Click Analysis > Geometry > Curvature. The Curvature dialog box opens. 

Quick is the default analysis type. 

2. Click in the Geometry collector and select one or more surfaces or quilts on the 

object for analysis. The name of the selected entity is displayed in the Geometry 

collector. 

The minimum and maximum curvature of the selected surface is computed and 

displayed in the result area at the bottom of the Curvature dialog box. A 

curvature plot for the surface is displayed in the Pro/ENGINEER graphics window. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select the reference 

geometry or coordinate system in the collector.  

3. Select Spacing in the Sample box and specify spacing between the mesh 

lines in the first and second direction. Alternately, click Number in the Sample 

box and specify the number of mesh lines in the first and second direction. 
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4. Click  to complete the analysis or  to cancel the analysis. 

Alternatively, click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Select the desired analysis types from the list at the bottom of the 

Curvature dialog box.  

b. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling. You can select Feature to 

create analysis feature. 

c. If required, rename the analysis in the box adjacent to the list. 

6. Optionally, to customize or edit your analysis, perform the following steps: 

a. Click in the CSYS collector and select a reference coordinate system. 

b. Select a Curvature or Normal type of plot in the Plot box. 

Curvature is the default. 

o Curvature—Evaluates and plots the curvature along the selected curves or 

edges. For a single surface, evaluates and plots the curvature of surface in 

both the directions as isolines. 

o Normal—Evaluates a single surface and plots the normals to surface in 

both the directions as isolines. 

c. Select the Quality, Number, or Step type of sampling in the Sample 

box to plot the curvature in the first direction. Quality is the default. Adjust 

the sample values using the slider. 

Note: The number of samples must be greater than 1 and the incremental 

value for the step must be greater than 0.001 in model units. 

d. Adjust the sample values for the 2nd Quality, 2nd Number, or 2nd 

Step type of sample plot and the scale in the second direction. These 

options are available based on the values selected in the Sample box. 

e. Adjust the scale of plot using the thumbwheel or type a value in the 

Scale box. You can also adjust the scale graphically using the handle on 

the curve or edge. 

f. Select the required plotting style. 

Note: You cannot specify a plotting style for the Normal type of plot. 

g. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. 
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Example: Curvature of a Surface 

The following example shows curvature plot for the selected surface. 

 

To Display Cross Sections of a Surface 

1. Click Analysis > Geometry > Sections. The Sections dialog boxopens. Quick 

is the default analysis type. 

2. Click in the Geometry collector and select a one or more surfaces, quilts, parts, 

or all model surfaces on which you want to perform a surface analysis. If you 

select a part, all solid surfaces in the part are analyzed. The name of the selected 

entities are displayed in the Geometry collector. 

3. Click in the Direction collector and select a reference plane, coordinate system, 

a straight curve, edge, axis, or multiple planes to indicate the direction of 

sections. You can flip the reference to reverse the direction indicated by the 

arrow on the model. 

The sections are computed for the Cross type of sections by default and 

displayed in the Pro/ENGINEER graphics window. The minimum and maximum 

curvature values for cross sections are displayed in the result area at the bottom 

of the Sections dialog box. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select the surfaces or 

direction references. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Select Saved from the list at the bottom of the Sections dialog box to 

save the analysis with the model, and to display and dynamically update 
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the analysis while modeling. You can select Feature to create analysis 

feature. 

b. If required, rename the analysis in the box adjacent to the list. 

6. Optionally, click  to display the analysis result in a separate window. The 

Graphtool window opens and the result of the analysis with the parameter 

values for the selected surface is graphically represented in the Graphtool 

window. 

Note: You can view parameter values only for the Curvature and Radius type 

of plots. 

7. Optionally, to customize or edit your analysis, perform the following steps: 

a. Select Cross as the section type in the Sections box if it is not selected by 

default. 

b. Select Number or Span as the sampling type in the Sample box. 

c. If you select Number, then specify the number of sections in the Number 

box. The default value is 3. 

Specify the distance between the cross sections in the Spacing box. The 

spacing value is displayed in the Pro/ENGINEER graphics window. 

In the Start box, specify the start position of the sections with respect to 

the reference plane. The start and end locations of the sections are 

displayed as two straight lines at right angles, spanning the selection set. 

The start position of the sections with respect to the reference plane is 

displayed in the Pro/ENGINEER graphics window. 

Note: The start position of the section and the spacing values can be 

negative. 

You can graphically drag the start and end handles to adjust the spacing 

between sections. Drag any handle to move all sections. Drag the start or 

end handles and hold down the ALT key to increase or decrease the number 

of sections. 

d. If you select Span, you can cut sections across all selected geometry 

at a distance specified in the Spacing box. The number of sections is 

computed and the sections are equally spaced by the value specified in the 

Spacing box. 

e. Select the plot type for cross sections in the Plot box. You can select a 

Curvature, Radius, Tangent, or Position type of plot. The cross sections 

on the selected surface or quilt are displayed in the Pro/ENGINEER graphics 

window based on the plot type you select. 

Curvature—Evaluates and plots the curvature of the surface in both the 

directions as isolines for surfaces or quilts. 

Radius—Evaluates and plots the radius along the selected surfaces. 

Tangent—Evaluates and plots the tangents along the selected surfaces. 
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Position—Evaluates surface continuity across shared boundaries and 

displays section curves for the selected surface. 

Note: Feature is not available for Tangent and Position types of plot. 

f. Select the Quality, Number, or Step type of sampling in the Sample 

box. Quality is selected by default. Adjust the sample values using the 

slider. 

f. Adjust the scale of the plot by using the thumbwheel or type a value in 

the Scale box. You can also adjust the scale graphically by using the 

handle on the plot. 

g. Select the required plotting style. 

h. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and then 

click  to view the result of the analysis. 

Example: Section Curvature for a Surface 

The following example shows the cross sections on the selected surface for Curvature 

type of plot. 

 

To Display Highlight Sections of a Surface 

1. Click Analysis > Geometry > Sections. The Sections dialog box opens. Quick 

is the default analysis type. 

2. Click in the Geometry collector and select a surfaces, quilts, parts, or all model 

surfaces on which you want to perform a surface analysis. If you select a part, all 

solid surfaces in the part are analyzed. The name of the selected entities are 

displayed in the Geometry collector. 
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3. Click in the Direction collector and select a reference plane, coordinate system, 

a straight curve, edge, axis, or multiple planes to indicate the direction of 

sections. The reference direction is indicated by an arrow on the model. You can 

flip the reference to reverse the direction indicated by the arrow on the model. 

4. Select Highlight as the section type in the Sections box to provide information 

about surface connections. 

Note: A highlight section is created where the surface normal is at a specific 

angle with respect to a horizontal line, that is, at the zero coordinate. 

5. Specify the distance between the highlight curves in the Spacing box. The 

curves are highlighted on the surface and the spacing value is displayed in the 

Pro/ENGINEER graphics window. By default, the spacing is 10. You can change 

the spacing graphically by changing the value directly in the Pro/ENGINEER 

graphics window. 

6. Update is selected by default. You can see the effects of your selections or 

changes on the analysis plot as you make them. Clear the Update check box to 

select or adjust multiple analysis options, and then click  to view the result 

of the analysis. 

7. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

For surfaces with tangent continuity, the highlight sections between surfaces are 

displayed with sharp corners. However, for surfaces that have curvature 

continuity, the highlight sections between surfaces are displayed as smooth 

curves. 

8. Optionally, to save an analysis, perform the following steps: 

a. Select Saved from the list at the bottom of the Sections dialog box to 

save the analysis with the model, and to display and dynamically update 

the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 

Example: Highlight Sections of a Surface 

The following example shows highlight sections on the selected surface. 
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To Display the Dihedral Angle for an Edge or Curve 

Note: A dihedral angle is an angle between the normals of the two surfaces that 

share an edge. 

1. Click Analysis > Geometry > Dihedral Angle. The Dihedral Angle dialog box 

opens. Quick is the default analysis type. The Analysis tab is selected by 

default. 

2. Click in the Edge collector and select an edge, point, or datum point on an edge 

for dihedral angle analysis. The name of the selected entities are displayed in the 

Edge collector.  

The minimum and maximum dihedral angles are displayed in the result area at 

the bottom of the Dihedral Angle dialog box and an angle plot is displayed in 

the Pro/ENGINEER graphics window. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select a new edge to 

create a new analysis. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Dihedral Angle dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 
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d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a feature type of analysis. 

5. Click  to display the analysis result in a separate window. The Graphtool 

window opens and the result of analysis with the parameter values for the 

selected curve or edge is represented graphically in the Graphtool window. 

6. Optionally, to customize or edit your analysis, perform the following steps: 

a. Select the Quality, Number, or Step type of sampling in the Sample 

box. Quality is selected by default. Adjust the sample values using the 

slider or thumbwheel. 

b. Adjust the scale of plot using the thumbwheel. The selected value is 

displayed in the Scale box. You can also adjust the scale graphically using 

the handle on the curve or edge of a surface. 

c. Select the required plotting style. 

d. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. 

Example: Dihedral Angle for an Edge or Curve 

The following example displays a plot of angles between the normals of two adjoining 

surfaces that share a common edge: 
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To Display an Offset Surface 

1. Click Analysis > Geometry > Offset. The Offset dialog box opens. Quick is 

the default analysis type. 

2. Click in the Geometry collector and select one or more surfaces or quilts that 

you want to offset. The name of the selected entity is displayed in the Geometry 

collector. The name of the corresponding plane is automatically displayed in the 

Plane collector. 

The selected surfaces or quilts are offset using the default offset distance, mesh, 

plot type, and displayed in the Pro/ENGINEER graphics window. You can continue 

to select other surfaces or quilts. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new surface or 

surfaces to create a new analysis. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis, perform the following steps: 

a. Select Saved from the list at the bottom of the Offset dialog box to 

save the analysis with the model, and to display and dynamically update 

the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 

5. Optionally, to customize or edit your analysis, perform the following steps:  

a. Specify the offset distance in the Offset box. You can graphically drag 

the handle to adjust the offset distance or change the value directly in the 

Pro/ENGINEER graphics window. 

b. If you have selected one or more surfaces in the Geometry collector, 

select Spacing in the Mesh box and specify spacing between the mesh 

lines in the first and second direction. Alternatively, click Number in the 

Sample box and specify the number of mesh lines in the first and second 

direction. 

Note: Mesh is available only if you select one or more surfaces in the 

Geometry collector. It is not available for edges or quilts. 

c. Select the Quality, Number, or Step type of sampling in the Sample box 

and adjust the sample values using the slider or thumbwheel. 

d. Adjust the sample values for the 2nd Quality, 2nd Number, or 2nd 

Step type of plot sample using the slider. These options are available based 

on the values selected in the Sample box. 

e. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to view the analysis for selected options, the compute 

option is available. 
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f. Select or adjust multiple analysis options, and click  to view the 

result of the analysis. 

To Display the Deviation of a Surface to Points 

1. Click Analysis > Geometry > Deviation. The Deviation dialog box opens. 

Quick is the default analysis type. The Analysis tab is selected by default. 

2. Click in the From collector and select a surface or a datum plane. The name of 

the selected surface or datum plane is displayed in the From collector. 

3. Click in the To collector and select a datum point, datum plane, datum curve, 

scan curve, or datum point array to which you want to measure the deviation. 

The name of the selected reference is displayed in the To collector. 

The minimum and maximum deviation is computed and displayed in the result 

area at the bottom of the Deviation dialog box, and the Pro/ENGINEER graphics 

window. The deviation plot is displayed with green and red sticks where green 

denotes deviation within tolerance and red denotes deviation beyond tolerance. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select the From and 

To entities in the collectors. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Deviation dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 

d. If required, rename the analysis in the box adjacent to the list. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a Feature type of analysis. 

6. Optionally, to customize or edit your analysis, perform the following steps: 

a. Adjust the scale of plot using the thumbwheel or type the required 

scale value in the Scale box. You can also adjust the scale graphically using 

the handle on the entity.  

b. Adjust the threshold value using the thumbwheel or type the required 

threshold value in the Threshold box. You can change the threshold value 
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graphically by typing the value directly in the Pro/ENGINEER graphics 

window. 

c. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and then 

click  to view the result of analysis. 

Example: Deviation of a Surface to Points 

The following example displays minimum and maximum deviation from the surface 

to the selected curve. 

 

To Display Shaded Curvature of a Surface 

1. Click Analysis > Geometry > Shaded Curvature. The Shaded Curvature 

dialog box opens. Quick is the default analysis type. The Analysis tab is 

selected by default. 

2. Click in the Surface collector and select one or more surfaces, quilts, solid 

geometry, or facets on which to perform the surface analysis. If you select a solid 

geometry, all solid surfaces in the part are analyzed. The selected entity is 

displayed in the Surface collector and the Color Scale dialog box opens.  

3. Click in the Plane collector and select a reference plane. You can select a 

reference plane only for a Section type of plot.  

The minimum and maximum shaded curvature values for each newly selected 

entity are displayed in the result area at the bottom of the Shaded Curvature 

dialog box. A shaded plot for the selected surface is displayed in the 

Pro/ENGINEER graphics window. 
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Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new surfaces in 

the Surface collector to create a new analysis. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Radius dialog box.  

c. Select Saved to save the analysis with the model, and to display and 

dynamically update the analysis while modeling or select Feature to create 

analysis feature. 

Note: You cannot create an analysis feature for the Maximum type of plot. 

c. If required, rename the analysis in the box adjacent to the list. 

d. Click the Feature tab in the Shaded Curvature dialog box to change 

the feature options of the current analysis, if required. You can access the 

feature options only when you select a Feature type of analysis. 

6. Optionally, to customize your color plot, click one of the following types of color 

plots in the Color Scale dialog box: 

—A rainbow type of color plot is displayed for the selected surface or 

surfaces. 

—A gradient type of color plot is displayed for the selected surface or 

surfaces. 

—A two-color type of color plot is displayed for the selected surface or 

surfaces. 

7. Select one of the following types of styles for the selected surface or surfaces: 

—Displays the color plot with a linear scale. 

—Displays the color plot with a logarithmic scale. 

Note: These styles are not available for the two-color type of color plot and when 

the Gaussian Curvature plot show positive and negative results. 

The Continuous check box is selected by default.  
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8. Modify the number of colors for a linear or logarithmic type of plotting style. For a 

gradient type of color plot, you can also modify the minimum and maximum 

values for color gradation. 

If you clear the Continuous check box, you can specify the number of colors for 

the color scale in the Number box and change the base value of the logarithm 

for a logarithmic scale used for the analysis. 

Note: Continuous is not available for the two-color type of color plot. 

9. If required, click Default in the Color Scale dialog box to restore the default 

values of the plot. 

10. Optionally, to customize or edit your analysis, perform the following steps: 

a. Select one of the following types of plots in the Plot box: 

Gaussian—Evaluates the curvature of a surface. Shaded curvature is the 

product of the smallest and largest normal curvatures for every point on a 

surface. 

Maximum—Shows the largest normal curvature at every point on the 

surface. 

Mean—Evaluates the continuity between surfaces. 

Section—Displays the curvature of cross-sectional cuts parallel to a 

reference plane. 

The following types of plots are available only when you are in the Reverse 

Engineering feature environment: 

Compare Surfaces—Displays the minimum and maximum deviation 

between the surface and facet vertices. 

Third derivative—Displays the percentage change in the curvature by 

using the shaded plot. 

b. Select the Quality, Number, or Step as the sampling type in the 

Sample box. Quality is selected by default. Adjust the sample values using 

the slider or thumbwheel. 

c. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. A shaded plot for the selected 

surface or surfaces is displayed in the Pro/ENGINEER graphics window. 

Example: Shaded Curvature of a Surface 

Surface analysis assigns color values in ranges to show curvature. Values toward the 

red end of the spectrum indicate maximum curvature or slope. Minimum curvature 

values are shown toward the blue end of the spectrum. 
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A Shaded curvature is the product of the smallest and largest normal curvatures for 

every point on a surface. 

 

To Perform a Draft Check on a Part 

1. Click Analysis > Geometry > Draft. The Draft dialog box opens. Quick is the 

default analysis type.  

2. Click in the Surface collector and select one or more surfaces, quilts, solid 

geometry, or facets on which you want to perform an analysis. The selected 

entity is displayed in the Surface collector. 

3. Click  in the Direction collector and select a reference plane, coordinate system, 

curve, edge, or axis to specify the pull direction. The Color Scale dialog box 

opens. You can flip the reference to reverse the direction indicated by the arrow 

on the model.  

The draft is computed and displayed in the result area at the bottom of the Draft 

dialog box. A shaded plot for the selected surface is displayed in the 

Pro/ENGINEER graphics window. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select a required 

surface, model, or reference in the collector. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 
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5. Optionally, to save the analysis, perform the following steps: 

a. Select Saved from the list at the bottom of the Draft dialog box to 

save the analysis with the model, and to display and dynamically update 

the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 

6. Optionally, to customize your color plot, click one of the following in the Color 

Scale dialog box: 

—A rainbow type of color plot is displayed for the selected surface or 

surfaces. 

—A gradient type of color plot is displayed for the selected surface or 

surfaces. 

—A two-color type of color plot is displayed for the selected surface or 

surfaces. 

7. Click the Continuous check box to customize the color plot by modifying the 

number of colors for a linear or logarithmic type of plotting style. If you click this 

check box, then for the gradient type of color plot, you can also modify the 

minimum and maximum values for color gradation. 

If you clear this check box, you can specify the number of colors for the color 

scale in the Number box. Additionally, for a gradient type of color plot, you can 

also modify the minimum and maximum values for color gradation. 

Note: Continuous is not available for the two-color type of color plot. 

For a gradient type of color plot: 

o The color plot is displayed in the Pro/ENGINEER window using the minimum 

and maximum display angles which by default is three times the specified 

draft angle value. 

o Geometry areas outside the maximum display angle are displayed in the 

color shown in the swatch for the maximum color gradation. 

o Geometry areas outside the minimum display angle are displayed in the 

color shown in the swatch for the minimum color gradation. 

o The insufficient draft geometry areas are displayed in the color shown in 

the undercut color swatch. 

o You can customize the minimum, maximum, and undercut color swatches 

using the Color Editor that opens when you click on the color swatches. 

8. If required, click Default in the Color Scale dialog box to restore the default 

values of the plot. 

9. Optionally, to customize or edit your analysis, perform the following steps: 
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a. If required, select the draft direction by clicking  for one direction 

or  both direction and specify a value for the draft angle in the Draft 

box. You can change the draft angle graphically by typing the value directly 

in the Pro/ENGINEER graphics window. 

b. Select the Quality, Number, or Step as the sampling type in the 

Sample box. Quality is selected by default. Adjust the sample values using 

the slider. 

b. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. 

Example: Draft Check on a Part 

The following example illustrates a draft gradient for both sides where the draft angle 

is 6 degrees and the upper and lower angles are 18 degrees, respectively. The upper 

and lower color is set to the default, that is, blue and red, respectively. In the 

shaded analysis, the red color indicates an adequate draft for the lower half of the 

mold while blue indicates an adequate draft for the upper half of the mold. White 

indicates the areas of the mold that have an inadequate amount of draft, while the 

graded colors indicate areas that are within the draft limit. 
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To Display the Slope of a Surface 

1. Click Analysis > Geometry > Slope. The Slope dialog box opens. Quick is the 

default analysis type.  

2. Click in the Surface collector and select one or more surfaces, quilts, solid 

geometry, or facets on which to perform surface analysis. The selected surface, 

quilt, or part is displayed in the Surface collector. 

3. Click in the Direction collector and select a reference plane, coordinate system, 

straight curve, edge, or axis. The Color Scale dialog box opens. You can flip the 

reference to reverse the direction indicated by the arrow on the model.  

The slope is computed and the minimum and maximum slope values for each 

newly selected surface appear in the result area at the bottom of the Slope 

dialog box. A shaded plot for the selected surface is displayed in the 

Pro/ENGINEER graphics window. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select a required 

surface, model, or reference in the collector. 

4. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

5. Optionally, to save the analysis or create an analysis feature, perform the 

following steps: 

a. Click the Analysis tab if it is not selected by default. 

b. Select the desired analysis types from the list at the bottom of the 

Slope dialog box .  

c. Select Saved to display and dynamically update the analysis while 

modeling or click Feature to create analysis feature. 

d. If required, rename the analysis. 

e. Click the Feature tab to change feature options of the current 

analysis, if required. You can access the feature options only when you 

select a Feature type of analysis. 

6. Optionally, to customize your color plot, click one of the following types of color 

plots in the Color Scale dialog box: 

—A rainbow type of color plot is displayed for the selected surface or 

surfaces. 

—A gradient type of color plot is displayed for the selected surface or 

surfaces. 
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—A two-color type of color plot is displayed for the selected surface or 

surfaces. 

7. Select one of the following types of styles for the selected surface or surfaces: 

—Displays the color plot with a linear scale. 

—Displays the color plot with a logarithmic scale. 

Note: These plotting styles are not available for the two-color type of color plot. 

8. Click the Continuous check box  in the Color Scale dialog box to customize the 

color plot by modifying the number of colors for a linear or logarithmic type of 

plotting style. If you click this check box, then for the gradient type of color plot, 

you can also modify the minimum and maximum values for color gradation. 

If you clear this check box, you can specify the number of colors for the color 

scale in the Number box and change the base value of the logarithm for a 

logarithmic scale used for analysis. Additionally, for the gradient type of color plot 

you can also modify the minimum and maximum values for color gradation. 

Note: Continuous is not available for the two-color type of color plot. 

9. If required, click Default in the Color Scale dialog box to restore the default 

values of the plot. 

10. Optionally, to customize or edit your analysis, perform the following steps: 

a. Select the Quality, Number, or Step as the sampling type in the 

Sample list. Quality is selected by default. Adjust the sample values using 

the slider. 

b. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of the analysis. 

Example: Slope of a Surface Relative to a Reference Plane 

The following example displays the color plot of the surface relative to a reference 

plane. Values toward the red end of the spectrum indicate maximum curvature or 

slope. Minimum curvature values are shown toward the blue end of the spectrum. 
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To Display Curve Reflection  

1. Select one or more surfaces, quilts, solid geometry, or facets on which to perform 

surface analysis. 

Note: Reflection curve analysis for the earlier versions is not supported. You 

must create a new reflection analyses for any old reflection curve analyses that 

needs to be edited. 

2. Click Analysis > Geometry > Reflection. The Reflection dialog box opens. 

Quick is the default analysis type. 

The reflection is computed and a shaded plot for the selected surface is displayed 

in the Pro/ENGINEER graphics window. The result of reflection analysis is visible 

only in the OpenGL graphics mode. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select new surfaces, 

quilts, or parts to create a new analysis. 

3. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

4. Optionally, to save the analysis, perform the following steps: 
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a. Select Saved from the list at the bottom of the Reflection dialog box 

to save the analysis with the model, and to display and dynamically update 

the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 

5. Optionally, to customize or edit your analysis, perform the following steps: 

a. Specify the number of lights in the Lights box. The default value is 8. 

b. Adjust the angle of lights in the Angle slider. The default is 90 

degrees. 

c. Adjust the spacing between the linear source of light in the Spacing 

box, and the width in the Width box, as required. The default values are 10 

and 5, respectively. 

d. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to select or adjust multiple analysis options, and click 

 to view the result of analysis. 

Note: If you edit the definition of one saved type of reflection analysis, the 

definitions of the other existing saved type of reflection analyses also change. 

Example: Curve Reflection 

The following example shows reflection curves that represent the reflection from 

linear sources of light on a surface when viewed from a particular direction. 

 

To Display Shadows 

1. Click Analysis > Geometry > Shadow. The Shadow dialog box opens. Quick 

is the default analysis type. 

2. Select the desired analysis types from the list at the bottom of the Shadow 

dialog box.  
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3. Click in the Surface collector and select one or more surfaces, quilts, or solid 

geometry on which you want to perform the analysis. The selected entity is 

displayed in the Surface collector. 

4. Click in the Model collector and select surfaces, quilts, or solid geometry. The 

selected entity is displayed in the Model collector. 

5. Click in the Direction collector and select a reference plane, coordinate system, 

straight curve, edge, or axis. You can flip the reference to reverse the direction 

indicated by the arrow on the model. 

The shadow is computed and a shaded plot is displayed in the Pro/ENGINEER 

graphics window. The shadow area and ratio values for the selected entity appear 

in the Results box. 

Note: To clear the contents of the collector, right-click in the collector and click 

Remove on the shortcut menu. You can then continue to select a required 

surface, model, or reference in the collector. 

6. Click  to complete the analysis or  to cancel the analysis. Alternatively, 

click  to start a new analysis. 

7. Optionally, to save the analysis, perform the following steps: 

a. Select Saved from the list at the bottom of the Shadow dialog box to 

save the analysis with the model, and to display and dynamically update 

the analysis while modeling. 

b. If required, rename the analysis in the box adjacent to the list. 

8. To customize or edit your analysis, perform the following steps: 

a. Select the Quality, Number, or Step type of sampling in the Sample 

box. Quality is selected by default. Adjust the sample values using the 

slider.  

b. Update is selected by default. You can see the effects of your 

selections or changes on the analysis plot as you make them. Clear the 

Update check box to view the analysis for selected options, the compute 

option is available. 

c.  Select or adjust multiple analysis options, and click  to view the 

result of the analysis. 

Comparing Part or Assembly Files 

About Part Comparison 

In Part mode, you can compare two part files or two different versions of a part file, 

and obtain a graphical report on the differences between the two parts or versions. 

You can perform a feature comparison or a geometric comparison: 
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• To compare the features of two parts, use Analysis > Compare Part > By 

Feature. 

• To measure the geometric deviation of one part from another part, use Analysis 

> Compare Part > By Geometry. 

Note: You can compare the features of two parts in the Part mode or two 

components in the Assembly, Cabling, Piping , or Welding modes. 

Comparing the Features of Two Parts 

You can compare the features of two parts or two versions of the same part. For 

example, if you have two part files that contain the same basic part with the same 

basic features, but the dimensions of the features differ, you can use part 

comparison to analyze the difference in size between the two parts. A list of features 

that have been modified, along with any features that exist in only one of the part 

files, is displayed in the Part Comparison dialog box. Pro/ENGINEER also displays 

an overlay of the second part on the first part and highlights the feature being 

compared. The default highlight color is red. 

Comparing the Geometry of Two Parts 

You can measure the geometric deviation between one part and another part. 

Pro/ENGINEER performs an analysis that generates a point cloud of the first part, 

and then overlays it on and aligns it to the second part. Then Pro/ENGINEER 

generates a shaded color display of the deviation between the two parts and displays 

it in the graphics window. 

To perform the geometric comparison, click Analysis > Compare Part > By 

Geometry. The Diff Geom dialog box opens. In the Diff Geom dialog box, you can 

control the point density (how far apart the points in the point cloud will be) by 

typing in a measurement spacing value. The unit of measurement in this box is 

always the same as the default or user-defined part measurement unit. You can also 

control the tolerance values for the display. That is, you can choose to display only 

the deviations between the parts that occur above a specific value. For example, if 

you are interested in a deviation range of 1.0 millimeter or more, Pro/ENGINEER 

displays deviations of more than 1.0 millimeter and eliminates deviations of lesser 

values from the display. 

Note: You can choose to export the difference report displayed in the Pro/ENGINEER 

browser by clicking Export Report on the HTML report page. By default, the 

exported file is saved in the current working directory in the Comma Separated Value 

(CSV) format as <model_name>_CMPR0.csv and <model_name>_CMPR0.csv.1. Set the 

export_report_format configuration option to rich_text to save the exported file 

in the rich text format as <model name>_CMPRO.txt and <model 
name>_CMPRO.txt.1. You can open these saved files in Microsoft Excel. 

The <model_name>_CMPR0.csv.1 and <model name>_CMPRO.txt.1 are version files. 

Whenever you export the same report again, new version files are created with 

incremented file names and the <model_name>_CMPR0.csv and <model 
name>_CMPRO.txt files are replaced by latest exported file. 
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To Compare the Features of Two Parts 

1. Open the first part. 

2. Click Analysis > Compare Part > By Feature. The Open dialog box opens and 

lists the part files in the working directory. 

3. Select the part file that you want Pro/ENGINEER to compare with the first part, 

and click Open. Pro/ENGINEER opens the second part and performs the 

comparison analysis. 

When the comparison is finished, a list of all the features in the second part that 

have been modified, along with the features that are present in the second part 

but missing in the first part are displayed in the Pro/ENGINEER browser. The 

graphics window displays a model with the second part overlaid on the first part 

and the differences are highlighted in red. 

4. If required, sort the difference report in ascending or descending order based on 

the contents of a column by clicking its column header. Clicking the column 

header again reverses the sort order. 

For User Defined Features and features that are a part of a group, the report 

displays the group name or the User Defined Feature name with the actual 

feature name in parentheses in the Item Name column. This enables you to sort 

the report for similar grouped features by group name and UDF name. For 

example, Group ABD(AE_1). 

In the Part Comparison dialog box, you have the following choices: 

Command Action 

 Select the next feature in the list and highlight the 

difference between the two features in the graphics 

window. 

 Select the previous feature in the list and highlight the 

difference between the two features in the graphics 

window. 

Info Display information about the selected feature in a 

separate Information window. 

Close Close the dialog box and quit the comparison operation. 

Note: Pro/ENGINEER does not automatically close the second part when you quit the 

comparison operation. You must close the window manually using File > Close 

Window. 

To Measure the Geometric Deviation between Two Parts 

1. Open the first part. 

2. Click Analysis > Compare Part > By Geometry. The Open dialog box opens 

and lists the part files in the working directory. 
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3. Select the second part file and click Open. The Geom Diff dialog box opens. 

4. In the Measurement Spacing box, enter the desired Measurement Spacing 

value. This value represents the distance between each point in the point cloud 

that Pro/ENGINEER generates from the first part. 

5. In the Tolerance box, enter the desired tolerance value. This value is equal to 

the maximum difference in the compared geometry of the two parts, in part 

units. Pro/ENGINEER displays deviations that are larger than the specified 

tolerance value upon comparison. 

6. To display only the areas that have changed from the first part to the second 

part, select Show only changed areas. 

7. Click Apply to begin the part comparison operation. The system compares the 

geometry of the parts and calculates the deviation of the geometry in the second 

part to the geometry of the current part. 

A shaded color display showing the differences between the second part and the 

current part is displayed in the Graphics window. The Color Range dialog box 

opens beside the color display, and displays a visual color chart containing the 

measurement definitions of each color. 

8. To perform additional comparisons of the same two parts, you can repeat steps 5 

through 8. 

9. To close the dialog box and exit the part comparison mode, click Close in the 

Geom Diff dialog box. 

To Compare the Components or Features of Two Assemblies 

1. Click Analysis > Compare Assembly by feature. The Comparison Options 

dialog box opens. 

2. Select one of the following options: 

o Retrieve sub models—Retrieves the submodel from the local library, 

renames it automatically, and displays the difference report in the 

Pro/ENGINEER browser window. 

o Display sub model differences—Displays a difference report between the 

two submodels in the Pro/ENGINEER browser window. Displays a difference 

report in the Pro/ENGINEER browser window for the two assemblies 

including the items that originated from the submodels. 

3. Select the assembly file that you want Pro/ENGINEER to compare with the first 

assembly, and click Open. Pro/ENGINEER opens the second part and performs 

the comparison analysis. 

When the comparison is complete, a list of all the features and submodels that 

have been modified in the assembly is displayed in the Pro/ENGINEER browser 

window. 
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Note: If assemblies to be compared are stored in different local directories, 

submodels of each assembly are retrieved separately and submodel differences are 

reported in the difference report. However, if the assemblies to be compared are 

located in the same local directory, the submodels will be identical in both the 

assemblies as Pro/ENGINEER does not retrieve a model that is already in session. In 

this case, submodel differences between the two assemblies are not reported. 

The Info Menu 

About the Info Menu 

In Pro/ENGINEER, you can display information about selected features, parts, or the 

entire model in the embedded browser. 

If information is displayed in text format, you can save the file with a different name 

and edit the file using the File, Edit, and View menus in the Information Window. 

You can retrieve and display information for the following: 

• Bill of Material 

• Feature 

• Component 

• Model 

• Reference Viewer 

• Parent/Child 

• Relations and Parameters 

• Feature List 

• Modification History 

• Model Size 

• Audit Trail 

• Session Info 

About the Info Menu 

About the Display of Information 

Using Info > Component, you can display component assembly information and 

information about its parents, children, relationships, and parameters. 

You can display revision information about the current model using Info > Audit 

Trail. Information about the system date and time can also be displayed in the 

Pro/ENGINEER message area. 
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To Display Component Assembly Information 

1. Click Info > Component. The Component Constraints and SELECT dialog 

boxes open. 

2. Select the component for which you want constraint information. The name of 

the component appears in the Component box. In addition, Type, CompRefs, 

Asm Refs, and Offset information is displayed, if applicable. 

3. Click OK in the SELECT dialog box. 

4. Click Apply on the Component Constraints dialog box. A report displays 

information about the component in the Pro/ENGINEER browser, by default. 

5. If required, sort the report in ascending or descending order based on the 

contents of a column by clicking its column header. Clicking the column header 

again reverses the sort order. 

Alternatively, you can view the component information in an Information Window, in 

a file named component-name.memb if the info_output_format configuration option 

is set to Text. 

If required, use the File, Edit, and View menus in the Information Window to save, 

edit, or search information. 

To Display the Model Revision History 

Click Info > Audit Trail. A report displays revision information in the Pro/ENGINEER 

browser. This information is also available in a file displayed in the message area. 

Each audit trail displays: 

• Item Type—Lists the type of item such as feature, parameter, layer, dimension, 

note, and so on. 

• Item Name—The name of the item. 

• Item Id—The ID of the item indicating location of the change. 

• Change Type—Selects the type of model change such as, Metadata, 

Geometry, Drawing, or Cosmetic. 

• Change Description—Changes associated with the object during the creation of 

the model. 

• Detailed Info—Any extra but important information in addition to the change 

description. 

• Time/Date—The date and time of the most recent modification to the object in 

the format mm/dd/yy hh:mm:ss. 

• Rev—The current revision of the object in its product database of origin. 

• Rel Level—The current release level of the object in its product database of 

origin. 

• User—The owner of the object in its product database. 
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• Actions—A list of actions that have been performed on the object, including 

fetching, storing, renaming, and copying. 

• Comment—Comments associated with the object during submission, approval, 

rejection, and so on. 

Note: The info_output_mode configuration option determines the means by which 

Pro/ENGINEER creates the audit trails. 

If required, sort the report in ascending or descending order based on the contents 

of a column by clicking its column header. Clicking the column header again reverses 

the sort order. 

To Display the Date and Time 

To display the date and time in the Pro/ENGINEER message area, click Info > 

Session Info > Date and Time. 

To Display a List of Messages in the Current Session 

Click Info > Session Info > Message Log. The Message Log dialog box opens 

showing a list of messages received in your current session. 

You can use the File, Edit, and View menus on the Information window to save the 

information in a file, edit the file, or view line numbers. 

Getting Part and Assembly Information 

About Displaying Part and Assembly Information 

In Pro/ENGINEER, you can display information about selected features, including 

entity layers and status, using Info > Feature. You can also display information 

about entire models using Info > Model. 

You can display feature information using an object-action workflow as follows: 

• Query the Info menu for feature information, then  

• Select the feature in the graphics window 

Note: You can also display feature or part information by right-clicking the 

feature name in the Model Tree and using the shortcut menu (Info > Feature or 

Info > Model). 

About Bill of Materials (BOM) 

The Bill of Material (BOM) lists all parts and part parameters in the current assembly 

or assembly drawing. The BOM also comprises a breakdown and a summary of the 

report. The Breakdown section lists what is contained in the current assembly or 

part. The Summary section lists the total quantity of each part included in the 

assembly, and is the list of all the parts needed to build the assembly from the part 

level. 

You can view a BOM in the following formats: 
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• BOM Text output format  

BOM HTML Output Format 

The default BOM HTML format provides hyperlinks to parts in the current assembly. 

It also provides hyperlinks that allow you to highlight, open, or see additional 

information about the parts in the assembly. 

Breakdown Section 

The HTML BOM Breakdown section lists information such as the quantity, type, name 

(hyperlink), and three actions (highlight, information, and open) about each member 

or submember of your assembly. 

• Quantity—Lists the number of components or drawings. 

• Type—Lists the type of the assembly component (part of subassembly). 

• Name—Lists the assembly component and is hyperlinked to that item. Clicking 

this hyperlink highlights the component in the graphics window. 

• Action—Includes the following three areas: 

o Highlight—Highlights the selected component in the assembly. 

o Information—Provides model information on the relevant component. 

o Open—Opens the component in another Pro/ENGINEER window. 

Note: If required, sort the report in ascending or descending order based on the 

contents of a column by clicking its column header. Clicking the column header again 

reverses the sort order. 

Summary Section 

The BOM HTML Summary section lists information such as the quantity, type, name, 

links, and three actions (highlight, information, and open) about each member or 

submember of your assembly. 

BOM Text Output Format 

The text formatted BOM Breakdown section lists the quantity, type, and name of 

each member and submember of the assembly. The Summary section lists the 

quantity, type and name for each part included in the assembly.  

BOM Configuration 

You can configure BOM output format with the bom_format configuration file option. 

You can set the info_output_format configuration option to text to specify text 

format for the BOM. 

To Create a BOM 

1. Click Info > Bill of Materials. The BOM dialog box opens. 

2. Under Select Model, select Top Level or Subassembly. 
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3. If you select Subassembly, use the SELECT menu to select the subassembly in 

the current window. 

4. Under Include, select or clear the Skeletons, Unplaced, and Designated 

Objects check boxes to indicate whether you want these to appear in the BOM. 

5. Click OK. The BOM appears in a report in the Pro/ENGINEER browser, by default.  

6. If required, sort the report in ascending or descending order based on the 

contents of a column by clicking its column header. Clicking the column header 

again reverses the sort order. 

Alternatively, you can view the BOM information in an Information Window if the 

info_output_format configuration option is set to Text. If required, use the File, 

Edit, and View menus in the Information Window to save, edit, or search 

information. 

To Define the BOM Format 

1. Using the system editor, create the BOM output format file. 

2. Add the following option to the configuration file: 

bom_format formatname.fmt 

3. In Pro/ENGINEER, add user-defined parameters to parts and assemblies using 

Tools > Relations > Parameters > Add Parameter. 

4. Click Info > Bill of Materials. The BOM appears in an INFORMATION WINDOW 

and is written to file. 

Note: Assembly members that are blanked on a layer or suppressed through 

assembly representation are listed in the BOM for the assembly as if they were 

displayed. 

BOM and Mass Properties Behavior 

In Skeleton Models 

When working with a skeleton model in an assembly, Pro/ENGINEER generates Bill of 

Materials (BOM) information and mass properties information that accurately reflects 

the design models and either the default or user-specified mass properties. However, 

the assembly BOM and assembly mass properties ignore skeleton models entirely 

when working on parts. 

In Master Representations 

To obtain the full BOM or the mass properties of the Master Representation while 

working with a simplified representation, you must switch to the Master 

Representation. Pro/ENGINEER includes included components in mass property 

calculations because they are in session. It does not include excluded components 

unless they are in session. Mass properties only reflect what is currently on the 

screen. 
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The BOM lists all components of assemblies that are in session. Unless the Master 

Representation is in session, the BOM is not accurate. Pro/PDM provides the full BOM 

without retrieval of objects. In Pro/REPORT, the BOM is available only when you 

retrieve an assembly as the Master Representation. 

For substituted objects, Pro/ENGINEER has access to the names of both the original 

object and the substituted object. The mass properties of the substituted component 

are available because the component is in session. If they have been assigned 

through Interchange mode, the mass properties of the original object are available in 

the substituted component. 

To Display Feature Information 

1. Click Info > Feature. The SELECT dialog box opens. 

2. Click the desired feature on the Model Tree or in the model. A feature information 

report is displayed in the Pro/ENGINEER browser. The report lists the feature 

name, parents, children, feature element data, section data, dimension, and 

generic section data. 

3. Right-click the BOM Report to add it to Favorites in the Pro/ENGINEER browser. 

Pro/ENGINEER saves the information in a file named feature.inf. 

4. If required, sort the report in ascending or descending order based on the 

contents of a column by clicking its column header. Clicking the column header 

again reverses the sort order. 

Alternatively, you can view the feature information in an Information Window if the 

info_output_format configuration option is set to Text. If required, you can save 

the file with a different name and edit the file using File, Edit, and View menus in 

the Information Window. 

To List Model Features 

Click Info > Feature List. A feature information report is displayed in the 

Pro/ENGINEER browser. The report lists the part name and features of this part. 

If required, sort the report in ascending or descending order based on the contents 

of a column by clicking its column header. Clicking the column header again reverses 

the sort order. 

For User Defined Features and features that are a part of a group, the report displays 

the group name or the User Defined Feature name with the actual feature name in 

parentheses in the Item Name column. This enables you to sort the report for similar 

grouped features by group name and UDF name. For example, Group ABD(AE_1). 

Alternatively, you can view the model information in an Information Window if the 

info_output_format configuration option is set to Text. You can save the file with a 

different name and edit the file using the File, Edit and View menus in the 

Information Window. 
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To Display Detailed Model Information 

1. Click Info > Model. If you are in Part mode, a feature information window opens 

in the Pro/ENGINEER browser and lists the part name and features of this part.  

2. If you are in Assembly mode, the Model Info dialog box opens. 

3. Under Select Model, click the option for which you want information that is one 

of Top Level, Subassembly, Part, or Skeleton. 

4. If the SELECT dialog box opens, select the subassembly, part, or skeleton that 

you want information about and click OK. 

5. Click Apply in the Model Info dialog box. A feature information report is 

displayed in the Pro/ENGINEER browser. 

6. If required, sort the report in ascending or descending order based on the 

contents of a column by clicking its column header. Clicking the column header 

again reverses the sort order. 

For User Defined Features and features that are a part of a group, the report 

displays the group name or the User Defined Feature name with the actual 

feature name in parentheses in the Item Name column. This enables you to sort 

the report for similar grouped features by group name and UDF name. For 

example, Group ABD(AE_1). 

Alternatively, you can view the model information in an Information Window if the 

info_output_format configuration option is set to Text. This feature information is 

saved to a file named part-name.inf.n, where part-name is the name of the model 

and n is the version number of the file. 

The information depends on what you have selected. 

Command Action 

Top Level View model information for the top-level assembly.  

Subassembly View model information for a particular 

subassembly.  

Part View the following model information for a part: 

Regular features 

Suppressed features 

Coordinate systems 

Cross sections 

Reference dimensions 

Incomplete features 

Parts are labeled if they are a generic or an 

instance. To use the Name option on a part, the 
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Command Action 

part must have been created or retrieved during 

the working session. 

Skeleton View model information for a skeleton. 

By default, only the names of the objects appear in the Model Info window. 

However, you can use the configuration file option display_full_object_path to 

display the full path name of the objects, along with their object-type and version-

number suffixes. 

To List All In-Session Models 

1. Click Info > Session Info > Object List. An INFORMATION WINDOW opens 

and displays a list of objects. 

2. In the INFORMATION WINDOW, you can use the following menus: 

o File—To save or close the list 

o Edit—To edit the list 

o View—To add line numbers to the list 

To Display Model Size 

1. Click Info > Model Size. If you are in Assembly mode, the SELECT dialog box 

opens. 

2. Select the model (component) that you want size information about and click OK. 

The length of the bounding box diagonal for the assembly appears in the Message 

window, and the bounding box appears in green around the selected model.  

If you are in Part mode, the length of the bounding box diagonal appears in the 

Message window and the bounding box appears in green around the selected 

model. 

Note: To remove the bounding box, repaint or rotate the model. 
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Getting Manufacturing Information 

About the Information Window 

Click Info in various dialog boxes to display information generated by various 

Pro/ENGINEER functions in an INFORMATION WINDOW. 

Sometimes you are prompted to specify whether you want to have information 

displayed in the window, written to a file, or both. At other times, the INFORMATION 

WINDOW opens as soon as you select a Pro/ENGINEER command that solicits 

information. 

Use the menus in the Information window as follows: 

• File—To save the contents of the window to a file 

• Edit—To edit the contents of the window 

• View—To display line numbers in the window 

To Get Cast Model Information 

1. Click Info > Cast. The CAST INF dialog box opens. 

2. Under Show Info About, select or clear: 

o BOM 

o Components 

o Cavity Layouts 

o Split Volumes 

o Created Volumes 

o Split 

o Last Volume 

3. Under Output Results, choose Screen, File or both and edit the file name if 

desired. 

4. Click Apply to display the data in an INFORMATION WINDOW, write the data to a 

file (named in the message area), or both, depending on your selections under 

Output Results. 

5. If desired, use the File, Edit, and View menus in the INFORMATION WINDOW to 

save, edit, or search, then close the Cast Information window. 

To Get Diagram Information 

1. Click Info > Wire List. An INFORMATION WINDOW appears and displays the 

following information: 

o File name for the diagram 
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o Cable/wire names 

o Conductor names 

o From and To component pin names 

o Spool Names 

2. If desired, use the File, Edit, and View menus in the INFORMATION WINDOW to 

save, edit, or search the information, and to close the component information 

window. 

To Get Sheetmetal Toolpath Information 

1. Click Info > Toolpath Display. 

2. Select Tool & Path, Tool, Path, or None. 

3. Click OK. The toolpath display is highlighted on the model. 

To Get Sheetmetal Design Information 

1. To show information in HTML format, ensure that the info_output_format 

configuration option is set to html. The default is html. 

2. Click Info > Model. The Sheetmetal part information is displayed in the 

Pro/ENGINEER browser with the following reports: 

o Used K and Y factors by Part  

o Bend Tables Associated with Part  

o Bends Containing Feature Bend Table  

o Bends Allowance 

o Bend Radii  

o Design Rules - Violations Check 

3. If the the info_output_format configuration option is set to Text, click Info > 

Sheetmetal. The Sheetmetal Info dialog box opens. 

a. Under Report, select Bend Report, Radii Report, or Design Check.  

Note: Design Check checks the part against designated rules and displays 

any violations. This check requires a rule table. 

b. Under Output Results to, select Screen, File, or both, and change the file 

name if desired. 

c. Click OK to generate the information display. 

To Get Harness and Cable Information 

1. Click Info > Cabling. 
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2. In the Cabling Information dialog box, select the Information Type: 

o Harness Items—To display a list of the harness items 

o Harness Wirelist—To display a list of the wires in the harness that shows 

the cable names, color, length, and From and To locations 

o Physical Routing—To display another dialog box with the following 

buttons: 

3. Select All, Individual, or Partial to indicate the amount of information you 

want. 

4. Click Apply to display the information in an INFORMATION WINDOW. For 

individual and partial selection of cables in harness, select the required cable 

from the HARNESSES menu. 

5. If required, use the File, Edit, and View menus in the INFORMATION WINDOW 

to save, edit, or search the information. 

To Get Mold Model Information 

1. Click Info > Mold. The MOLD INF dialog box opens. 

2. Under Show Info About, select or clear the following options: 

o BOM 

o Components 

o Cavity Layouts 

o Split Volumes 

o Created Volumes 

o Parting Surf 

o Split 

o Last Volume 

o Shrinkage 

3. Under Output Results, choose Screen or File or both, and edit the file name if 

desired. 

4. Click Apply to display the data in an INFORMATION WINDOW, write the data to a 

file (named in the message area), or both, depending on your selections under 

Output Results. 

5. If desired, use the File, Edit, and View menus in the INFORMATION 

WINDOW to save, edit, or search, then close the window. 

To Get Process Sequence Information 

1. Click Info > Process Sequence. 
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2. An INFORMATION WINDOW opens containing information about the process. 

To Get Process Setup Information 

1. Click Info > Process Step. The Select Step dialog box opens. 

2. Select the step about which you want to see information and click Info. An 

INFORMATION WINDOW opens containing the information. 

3. Click Close to close the dialog box. 

To Get Manufacturing Model Information 

To display information about the current, active manufacturing model, from the 

menu bar: 

1. Click Info > Manufacturing. The Manufacturing Info dialog box opens. 

2. Under Output Information for, select one of the following options: 

o Manufacturing Model—To display information in the INFORMATION 

WINDOW about the model including: 

Machining Sequence Report (Manufacturing Type, Stock, and Date) 

Fixture Setup Information 

Overall Machining Data 

Operation List 

o Operation—To display list of operations in the Operation List box 

o NC Sequence—To display a list of NC sequences from either the current 

operation or all operation 

o Mfg Geometry—To display a geometry list for a selected Geometry Type 

(Mill Window, Mill Surface, Mill Volume, or Turn Profile) in the 

Geometry List box 

o Route—To display a Route Sheet for the assembly in an INFORMATION 

WINDOW showing Seq. Machine and Sequence, Rmvd Vol, Set up Time, 

and Run Time 

3. In the Output Results To section of the Manufacturing Info dialog box, select 

Screen, File, or both and change the file name if desired. 

4. Click Apply to generate the information, if applicable. (If no features exist to 

support the selection, an informational message appears.) 

5. Click Filter to display the Manufacturing Information: Filters dialog box, 

which allows you to select or clear filters for information display. 

6. Click Close to remove the Manufacturing Info dialog box. 
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Investigating References 

About Reference Investigation 

Reference investigation allows you to investigate the relationships and dependencies 

between features and models, enabling increased management of design intent. You 

can perform reference investigation through the Reference Viewer dialog box when 

working on individual parts or assemblies. Use Info > Reference Viewer to access 

the Reference Viewer dialog box. By using filters in the Reference Viewer dialog 

box, you can customize the contents of the Reference Viewer dialog box to show 

only dependencies of interest. 

With the Reference Viewer you can: 

• Identify the features in a model that have external or local references. 

• Identify the features in a model that have a chain of dependencies from the 

feature to the referenced entity. 

• Reroute or redefine a feature to break the dependency, if any of the external or 

local references are not required. 

• Investigate regeneration failures by examining parent and child dependencies. 

• Obtain information about the models that have external or local references to a 

specified model and about their relation references. Using the relations reference 

type as a filter, you can investigate model and feature relations to identify local 

or external references, or both created by relations. 

• Identify references generated by relations and parameters. 

• Identify circular references. 

• Understand the relationships among various models, components, and features in 

an efficient and flexible manner. 

• Break dependencies between the specified model and its dependent model or 

between a Data Shearing Feature and its dependent model. 

The relationships are displayed graphically in the form of a tree and uses arrow 

shaped graph connection handles to present multiple dependencies in an easily 

viewable form. The graph area can display multiple levels of parents and children at 

one time, allowing you to see an entire assembly structure and all interdependencies 

among all the models. 

You can investigate the following types of references, or dependencies:  

• Regular references 

• Placement references 

• System references 

• Relations references, and  

• Component references. 
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Note: 

• If the Reference Viewer dialog box is open, you cannot modify an assembly. 

• If you close the Reference Viewer dialog box using File > Close and open it again 

in the same session, the previous reference information is retained and only 

changes to the assembly are updated.  

• If you choose a command from a Pro/ENGINEER menu while the Reference 

Viewer dialog box is open, the Reference Viewer dialog box automatically closes. 

However, without closing the Reference Viewer dialog box you can view the 

information for a feature or model by clicking Info on the shortcut menu that 

appears when you right click a feature on the Model tree. 

Feature References 

Feature references are the dependencies between different features in a design. 

They are created in the context of a single part, or in the context of an assembly. 

Feature dependencies can be local references or external references. Local 

references only reference geometry of the model in which they were created. 

External dependencies reference geometry outside the model in which they were 

created. 

For external references, the assembly in which the two components existed when the 

dependency was created is another important characteristic of the dependency. For 

example, an assembly cut intersecting the assembly components and using their 

geometry is a local reference in the context of this assembly. However, if an 

assembly feature of a subassembly component references geometry outside the 

subassembly, such as a top-level part component, then this type of reference is 

considered external for the subassembly. 

If a feature is set as current, all models that are referenced by this feature or that 

are referencing this feature appear in the Parent and Children trees. You can expand 

these models to show the features that participate in dependencies with the current 

feature. If a component is set as current, all parents and children of its features 

appear. 

Models with only placement dependencies do not expand to features, because their 

features do not participate in the dependency. Exceptions are feature relations using 

external parameters and merge references. 

Relations References 

Relations references consist of dimensions and parameters that are used in relations. 

The Relations references filter setting displays objects with dependencies resulting 

from relations. No information about local symbols or other information about 

relations is given here. The Reference Viewer dialog box only provides 

investigation of references created in relations and references that were created in 

Program to other objects. 

Relations references displays relations using parameters and dimensions from other 

models or features. For example, if the following symbols are used in the relations of 

a specified feature: 
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feat_param:FID_DTM1, surf_param:sid_surf1, model_param:5  

the feature DTM1, the surface surf1, and the model that corresponds to session id 5 

are displayed as parents of this feature when you use the Relations references 

setting as a filter. 

As with parameters, relations can belong to various objects: assemblies, skeletons, 

parts, features, and patterns. 

Because patterns can have relations (P52:2 = P6:9, for example), and accordingly, 

can now have parents, the Global Reference Viewer also shows patterns, as does the 

Model Tree. Both can be expanded to show their features. 

Because a relation can be maintained without the assembly, the full path for a 

relation appears in the following format: 

Relation d54:4 = d42:2 + 10 --> Cut id 496 --> 
A_WHITE_BRASS_CONNECTION.PRT --> 

A_CYL_END_TOP.PRT --> Protrusion id 323 --> Dimension d42:2 

Component References 

Component references are references used to place a component in an assembly. 

These references are created when components are placed relative to one another in 

an assembly. When you add a part to an assembly, the system creates a component 

feature in the assembly. This feature represents the part included in the 

subassembly, the part entities, and assembly entities used to place the part. 

External placement dependencies occur when some geometry that does not belong 

to the subassembly or its components is used in placing a component of a 

subassembly. When you investigate a component reference, you may find an 

external reference exists because the component belongs to one subassembly but 

has been assembled to a component that does not belong to the same subassembly. 

If such an external reference is used for placement, the design intent of the 

subassembly is unclear outside the context of the higher level assembly in which the 

reference was created. Also, the subassembly will always have an external 

dependency to this parent assembly, making it difficult to reuse in other designs. 

Local placement dependencies occur when placement uses geometry of components 

of the same subassembly (or their subcomponents). 

When you set a subassembly as current, the system first considers it as a component 

and checks whether its own placement in a higher level subassembly is using some 

external geometry (in the context of the higher level subassembly). Then, it checks 

components of the current subassembly (only its own components) to see if it is 

using some of them for placement geometry out of the current subassembly. 

External References 

When investigating dependencies in an assembly, features may exist that were 

created in the context of another assembly. Therefore, these external dependencies 

point to a component in another assembly. 
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In the case when the other assembly is in session, the corresponding parent (or 

child) component has a name of the assembly next to it in parentheses, for example, 

PARENT.PRT (OTHERASM). Setting such an object as current replaces the current 

assembly tree with a filtered tree of OTHERASM.ASM. You can investigate other 

dependencies in the context of this assembly. When you select a previous item from 

the first assembly tree, you restore the tree of your initial assembly. 

In the case when the other assembly is not in session, the system cannot determine 

which component inside this other assembly participates in an external dependency. 

It can only show the other assembly as the context of the dependency. You then see 

the following parent OTHERASM.ASM (you cannot show a child from another assembly 

that is not in session). If you select this parent and try to set it as current, the 

system tells you that you should retrieve the assembly first. If you confirm this, the 

Reference Viewer dialog box automatically retrieves it and shows its tree. The 

system behaves then as described above for an assembly that is in session. 

About Deleting References 

You can delete references in one of the following ways: 

• Using the Reference Viewer dialog box—You can delete a reference through the 

Reference Viewer dialog box only when Pro/ENGINEER identifies it as an 

additional reference that can be safely removed. You can access the Reference 

Viewer dialog box using the menu bar, menu manager, or the Model Tree.  

• Using the Edit Definition command—You can delete all references, including the 

references that cannot be deleted through the Reference Viewer, by clicking 

Edit Definition on the shortcut menu that appears when you right-click a 

feature on the Model Tree.  

To delete a reference through the Reference Viewer using the menu bar, click Info > 

Reference Viewer, right-click the reference in the Reference Viewer dialog box 

that opens, and click Delete Reference on the shortcut menu. 

If a feature fails for a missing reference, click Investigate > Show Ref on the 

RESOLVE FEAT menu that appears, right-click the reference in the Reference 

Viewer dialog box that opens, and click Delete Reference on the shortcut menu. 

To delete references through the Reference Viewer from the Model Tree, right-click 

the feature on the Model Tree and click Info > Reference Viewer.  Right-click the 

reference in the Reference Viewer dialog box that opens, and click Delete 

Reference on the shortcut menu. 

You can delete missing references only for features that have the following types of 

references: 

Feature Type Reference Type 

Round  Edge, Variable round point 

Chamfer Edge 
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Feature Type Reference Type 

Copy Geometry, Publish 

Geometry 

Edge, Surface, Datum Plane, Datum Axis, 

Datum Point, Coordinate System, Feature 

Annotation Features Annotation plane references, User 

references, Leader attachment references, 

Surface finish reference surfaces  

Thru-Point Datum 

Curve 

Reference point of a Thru-point datum curve 

Delete Reference is not available if: 

• Deletion of a reference changes the structure of the feature. For example, 

deleting an edge in a round changes the type of round. 

• You are deleting references for Thru-Point Datum Curve with Tweak option. 

• A reference belongs to a logical collection such as a tangent chain, intent chain, 

surface loop, surface boundary and so on and the anchor is not a part of selected 

references. 

• A reference belongs to a pattern feature, pattern instance, or leader. To delete 

references from a leader, suppress the pattern and delete references. 

• Reference belongs to restricted annotation elements or dependent annotation 

elements. However, you can delete annotation plane references from dependent 

annotation elements if these annotation elements belong to annotation element 

propagation feature or data sharing feature. 

The Applications Menu  

About the Applications Menu 

The Applications menu provides options for switching from one Pro/ENGINEER 

mode to another and to start-related applications. The modules available on the 

Applications menu vary depending on the current model type open and licenses 

you have. 

Applications include: 

Standard—Create parts, assemblies, drawings and more. Available when you launch 

Pro/ENGINEER. 

Cabling—Create a special cabling harness part within an assembly. 

Piping—Model complex 3-D piping systems based on either user-defined pipe data 

or project specifications.  

Welding—Model welds in assemblies. Generate report tables about weld parameters 

and show welding symbols in assembly drawings.  

Legacy—Import and update 3D data and 2D drawings in Pro/ENGINEER.  
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Sheetmetal—Facilitate the design of a sheet metal part. 

Scantools—Focus on reverse engineering. 

Mechanica—Simulate how a product will function in its intended environment 

enabling non-specialist design engineers to explore the mechanical performance of 

design alternatives without building prototypes.  

Mechanism—Make a mechanism move and analyze its motion.  

Animation—Animate mechanisms previously created in Mechanism Design or any 

assembly from Pro/ENGINEER.  

Plastic Advisor—Rapidly design high quality, manufacturable, injection-molded 

plastic parts without the need for expertise in plastics processing.  

Mold/Casting—Create mold/casting features such as Silhouette Curve, Draft Line, 

Draft, Tan Draft, Offset Area, 1 Sided Trim, Waterlines, and runners while in Part 

mode.  

Mold Layout—Automate mold design beyond just creating the core and cavity 

assembly.  

NC Post Processor—Start the PTC NC post-processor, G-POST. A post-processor is 

used to translate CL files generated by NC/Manufacturing into G/M codes for CNC 

machines.  

Template—Activate Template mode (drawings only), allowing you to define the 

attributes for new drawing templates.  

Conference—Start a conference. Share files and run a shared application in real 

time. 

The Tools Menu 

About the Tools Menu 

The Tools menu includes options for customizing the Pro/ENGINEER working 

environment, setting external reference control options, and viewing the model 

creation history using the Model Player. It also includes options for setting 

configuration options (config.pro), and trail or training file playback. You can also 

choose options for creating and modifying mapkeys, and for working with floating 

modules and auxiliary applications. 

Using the Environment Dialog Box 

About Environment Settings 

You can set various Pro/ENGINEER environment options using the Environment 

dialog box (Tools > Environment). When you make a change in the Environment 

dialog box, it takes effect only for the current session. When you start 

Pro/ENGINEER, the environment settings are defined by your configuration file, if 

any; otherwise, by the system configuration defaults. 
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The Environment dialog box has sections where you can set options for: 

Setting the Display 

The following table lists the options available under Display in the Environment 

dialog box. 

Command Action 

Dimension 

Tolerances 

Display model dimensions with tolerances. 

Datum Planes Display the datum planes and their names. Note 

that when you turn off the datum plane display by 

clearing the check box, this will not affect a datum 

plane that is set as a reference datum for geometric 

tolerances. 

Datum Axes Display the datum axes and their names. Note that 

in Drawing mode, when you turn the datum axis 

display off by clearing the check box, only the axis 

names are blanked. 

Point Symbols Display the datum points and their names.  

Coordinate 

Systems 

Display the coordinate systems and their names.  

Spin Center Display the spin center for the model.  

Notes as Names With the preceding 3D Notes option selected, 

select this box to display the names, and clear it to 

display note text. 

Reference 

Designators 

Make each assembly component designated as a 

connector in Cabling or imported as an ECAD 

component appear with its reference designator in 

3D assembly views. 

Thick Cables Display a cable with 3D thickness. It can be shaded. 

This option and Centerline Cables are mutually 

exclusive. 

Centerline Cables Display the centerline of a cable with location points 

shown in green. This option and Thick Cables are 

mutually exclusive. 

Internal Cable 

Portions 

Display cable portions that are hidden from view by 

other geometry. 

Colors Display the models in colors. 

Textures Display textures on shaded models. 
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Command Action 

Levels of Detail Make use of the levels of detail available in a 

shaded model during dynamic orientation (panning, 

zooming, and spinning).  

Setting the Default Actions 

The following table lists the options available under Default Actions. 

Command Action 

Ring Message 

Bell 

Ring bell (beep) after each prompt or system 

message. 

Save Display Save objects with their most recent screen display. 

This makes object retrieval in new sessions faster, 

because its graphics do not need to be recalculated. 

Make Regen 

Backup 

Make the system back up the current model or 

models to disk before every regeneration: when you 

explicitly choose Regenerate, as well as whenever 

you start a function that ends in an implicit 

regeneration. At the end of a successful 

regeneration, Pro/ENGINEER automatically deletes 

the backup files that it creates. 

Snap to Grid Make points you select on the screen snap to a grid. 

This is particularly useful in Sketcher. 

Highlight Erased 

Views 

Show a box and the view name in place of an erased 

drawing view. 

Keep Info 

Datums 

Control how the system treats datum planes, datum 

points, datum axes, and coordinate systems that 

you create on the fly under the Info functionality. If 

selected, the system includes them as features in 

the model. If cleared, the system erases them when 

you exit the Info functionality. 

Use 2D Sketcher Control the initial model orientation in Sketcher 

mode. If selected, the model is reoriented upon 

entering Sketcher to a 2-D orientation looking 

directly at the sketching plane. If cleared, the model 

orientation upon entering Sketcher is unchanged. 

Sketcher Intent 

Manager 

Use the Intent Manager when in Sketcher. 

Use Fast HLR Make possible the hardware acceleration of dynamic 

spinning with hidden lines, datums, and axes. 

Performance improvements vary among different 
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Command Action 

systems and displays. 

Lock View 

Movement 

Disallow the movement of drawing views with the 

mouse. 

You can also change Display Style, Standard Orient, and Tangent Edges settings 

using the Environment dialog box. 

To Change Pro/ENGINEER Environment Settings 

You can control many aspects of the environment in which Pro/ENGINEER runs with 

the Environment dialog box. 

To open the Environment dialog box, click Tools > Environment on the menu bar 

or click the appropriate icon in the toolbar.  

You can also change many settings by using toolbar buttons. Click Tools > 

Customize Screen to get more information and to place command buttons on the 

toolbar. 

Tip: Ways to Change Environment Settings 

You can change settings in several ways: 

• You can change many of the display settings on the Environment dialog box by 

using items on the View menu. 

• You can customize your toolbar to contain additional buttons for changing 

settings by using the Customize Screen command on the Tools menu. 

• You can change settings for every session by editing your config.pro file using 

the Options dialog box, accessed through the Options command on the Tools 

menu. 

• You can set up mapkeys as shortcuts for Pro/ENGINEER settings by using the 

Mapkeys command on the Tools menu, and then use the mapped keys to 

change settings. 

Working with Mapkey Macros 

About Mapkeys 

In Pro/ENGINEER, a mapkey is a keyboard macro that maps frequently used 

command sequences to certain keyboard keys or sets of keys. The mapkeys are 

saved in the configuration file mapkey, with each macro beginning on a new line. You 

can define a unique key or combination of keys which, when pressed, executes the 

mapkey macro (for example, F8). You can create a mapkey for virtually any task you 

perform frequently within Pro/ENGINEER. 

By adding custom mapkeys to your toolbar or menu bar, you can use mapkeys with 

a single mouse click or menu command and thus automate your workflow. If you are 
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a newer user, you can borrow mapkeys from coworkers and eliminate having to 

remember cryptic abbreviations. 

To create a mapkey, you can use the configuration file option mapkey, or, on the 

Pro/ENGINEER menu bar, click Tools > Mapkeys, then in the Mapkeys dialog box, 

you click New and record your mapkey in the Record Mapkey dialog box. 

Use the Mapkeys dialog box to: 

• Define new mapkeys 

• View, modify, and delete existing mapkeys 

• Execute a mapkey chosen from the list 

• Save the mapkeys to a configuration file 

The system records your mapkey as you step through the sequence of keystrokes or 

command executions to define it. After you define the mapkey, Pro/ENGINEER 

creates a corresponding icon and places it in the Customize dialog box under the 

Mapkeys category. To open the Customize dialog box, click Tools > Customize 

Screen. On the Toolbars tabbed page, select the Mapkeys category. You can then 

drag the visible mapkey icon onto the Pro/ENGINEER main toolbar. You can also 

create a label for the new mapkey. If you choose to add the newly created mapkey 

icon to the toolbar, the label appears on the button added to the toolbar. When you 

mouse over the button, the description appears next to the mouse pointer and in the 

message area. 

You can also nest one mapkey within another, so that one mapkey initiates another. 

To do so, you include the mapkey name in the sequence of commands of the 

mapkey you are defining. 

Mapkey operations include the ability to do the following actions: 

• Pause for user interaction. 

• Handle message window input more flexibly. 

• Run operating system scripts and commands. The Record Mapkey dialog box 

contains the OS Script tabbed page, whose options allow you to run OS 

commands instead of Pro/ENGINEER commands. 

When you define a mapkey, the system automatically records a pause when you 

make screen selections, so that you can make new selections while the mapkey is 

running. Also, you can record a pause at any place in the mapkey along with a user-

specified dialog prompt, which will appear at the corresponding point while the 

mapkey is running. 

Note: If you create a new mapkey that contains actions that open and make 

selections from dialog boxes, then when you run the mapkey, it does not pause for 

user input when it opens the dialog box. To set the mapkey to pause for user input 

when opening dialog boxes, you must select Pause for keyboard input on the 

Pro/E tab in the Record Mapkey dialog box before you create the new mapkey. 
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Mapkeys Dialog Box 

To open the Mapkeys dialog box, click Tools > Mapkeys. The following table 

defines each command on the dialog box. 

Command Action 

New Allows you to define a new mapkey. Opens the Record 

Mapkey dialog box. 

Modify Allows you to modify the selected mapkey. 

Run Allows you to run the selected mapkey. 

Delete Allows you to delete the selected mapkey. 

Save Allows you to save all mapkeys in the active file to a 

configuration file.  

Changed Allows you to save only the mapkeys changed in the 

current session to a configuration file. 

All Save all the mapkeys. 

 

To Define a Mapkey 

1. Click Tools > Mapkeys from the menu bar or click the appropriate icon on the 

toolbar (use Customize Screen on the Tools menu to place buttons on the 

toolbar). The Mapkeys dialog box opens. 

2. Click New. The Record Mapkey dialog box opens. 

3. Type the key sequence that is to be used to execute the mapkey in the Key 

Sequence text box. 

Note: To use a function key, precede its name with a dollar sign ($). For 

example, to map to F3, type $F3. 

4. Optional: Type the name and description of the mapkey in the appropriate 

text boxes. 

5. Click the Pro/E tab. Specify how the system must handle the prompts when 

running the mapkey by selecting one of the following options: 

o Record keyboard input—(default). Record the keyboard input when 

defining the mapkey and use it when running the macro. 

o Accept system defaults—Accept the system defaults when running the 

macro. 

o Pause for keyboard input—Pause for keyboard input in the message area 

in response to a prompt while running the macro. 
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Note: The Pause for keyboard input option waits for you to enter a value 

wherever an user input is required while recording the macro. 

6. Click Record and start recording the macro by selecting menu commands in 

the appropriate order. 

7. If you create a new mapkey that contains actions that open and make 

selections from dialog boxes, when you run the mapkey, Pro/ENGINEER does not 

pause for user input whenever the dialog box opens. To pause for user input into 

dialog boxes, click Pause in the Record Mapkey dialog box to indicate when to 

pause while recording the mapkey. The Resume Prompt dialog box opens. 

8. Type the prompt in the Resume Prompt dialog box. Then click Resume and 

proceed recording the mapkey. 

9. Click Stop when finished recording the macro. 

When you run the macro, the system pauses, displays the prompt you typed, and 

gives you the options to Resume recording the macro or to Cancel. 

The OS Script tab allows you to run an Operating System (OS) script through 

Pro/ENGINEER using a mapkey. This is beneficial because you can start this OS 

script without having to minimize your window or to place it in the background. 

An OS script is analogous to using aliases in UNIX. An example of an OS script is one 

that copies a configuration file that is commonly used from a directory on the hard 

disk to the working directory so that you can load the file into your session. 

Defining or Editing Mapkeys 

The following rules apply when you are creating mapkeys, editing mapkeys that you 

originally entered in the config.pro file or editing mapkeys that you created by 

using the Mapkeys dialog box (Tools > Mapkeys): 

• Precede each command with a crosshatch sign (#). 

• Use semicolons to separate commands or fields. 

• To use a function key as a mapkey, precede it with a dollar sign ($). For 

example, $F1. 

• If the first nonspace character in a field is not a crosshatch sign (#), the system 

interprets the rest of the field as keyboard input that you had entered in 

response to a prompt. However, if the current command does not request 

keyboard input, this data is ignored. 

• If there is no text in a field, the system interprets the field as a carriage return 

(<CR>). 

• The system ignores leading spaces. 

• The system treats a series of nonleading spaces as a single space, unless it is 

treating the field as an input field. 

• Entries are case insensitive. 
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• Keyboard input is case sensitive. 

• There is no practical limit to the length of a mapkey. Use the backslash character 

(\) as a continuation character. For example, you could define the macro "aa" as 

follows: 

mapkey aa #feature;#create;#protrusion; \ 

#revolve; #done; 

Nesting Mapkeys 

You can nest mapkeys so that one mapkey initiates another. 

Mapkey Execution 

Three important rules apply for executing mapkeys: 

• When you press the mapped key, if the first command is not on the screen, the 

system checks all the following commands in turn. When it finds one present, it 

executes the mapkey from the first found command. 

Therefore, it is advisable to build command sequences starting from the top-level 

menu where appropriate.  

Note: Sometimes a mapkey cannot be executed because a command specified in 

the mapkey is currently unavailable in the menus. 

• If some of the commands ask for an input from the keyboard (for example, the 

name of a part), the mapkey pauses. After you enter the data, the system 

continues executing the mapkey. 

• If one of the mapkey commands calls for you to select using the mouse (for 

example, selecting a sketching plane in the graphics window), the system stops 

the mapkey execution and exits the mapkey at that point. 

In this way, you are able to create object-independent mapkeys for long 

sequences of repeating choices, provided you do not have to select any 

geometry.  

Naming the Mapkeys 

If you have set the configuration option for keyboard command abbreviation to on, 

use caution when naming the mapkeys. For example, if you have mapped a 

character sequence "cc," Pro/ENGINEER picks the command ChangeWindow from the 

Main menu as soon as you press the first "c." Therefore, it is advisable to start the 

mapped sequences with a character that is not used in the command names: slash, 

bracket, exclamation point, and so forth. 

Native Language Support 

Mapkeys are supported both for native language versions (by default) and for the 

English language. If you have written or recorded your macros in English and do not 
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want to rewrite them in your native language, set the configuration file option 

native_kbd_macros to no. 

Example: Creating Nested Mapkeys 

You can nest mapkeys so that one mapkey initiates another. To nest a mapkey, 

include the mapkey name preceded by a percent sign (%) in the sequence of 

commands of the mapkey you are defining. 

The following is an example of an edited mapkey with a nested mapkey. The first line 

shows the mapkey to be nested, as illustrated in the second line. 

mapkey $F1 #VIEW;#PREVIOUS; 

mapkey $F2 %$F1;#VIEW;#REPAINT;  

Note: Nested mapkeys cannot be more than five levels deep. 

This method of calling existing mapkeys is different from the one the system uses 

when you create mapkeys using the Mapkeys dialog box (Tools > Mapkeys). 

About an Incremental Mapkey 

You can record an incremental mapkey by setting the relation_text_trail_output 

configuration option to yes and the relation_tool_mapkey_behavior configuration 

option to increment. You can record and run an incremental mapkey in the 

Relations dialog box only. 

Note: You cannot record an incremental mapkey if you have set the 

relation_text_trail_output configuration option to no even if the 

relation_tool_mapkey_behavior configuration option is set to increment. 

However, you can run a mapkey that was recorded earlier with the 

relation_text_trail_output configuration option set to yes regardless of this 

option’s setting when you run the mapkey. 

The incremental mapkey records the insertion point in the Relations dialog box. The 

incremental mapkey records only the newly added text or action performed at the 

insertion point. When you run the recorded mapkey, it performs the recorded 

operations starting at the recorded insertion point. It adds or removes text 

incrementally to the current text set in the text area. The incremental mapkey does 

not delete or replace the pre-existing text or relation sets if it is not defined to do so.  

With an incremental mapkey you can: 

• Add text and relation sets in the Relations dialog box by running the mapkey 

again at the required insertion point. You may add multiple lines of text at the 

same time.  

• Replace text with new text. You can select text and run the mapkey again to 

replace the selected text with the new text in the existing text set. 

• Delete a specific portion of the text from a relation set in the Relations dialog 

box. You can delete the number of characters before or after that current cursor 

position as recorded in the mapkey. 
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Customizing the User Interface 

To Add or Remove Toolbars 

Using the Toolbars tabbed page in the Customize dialog box, you can add entire 

toolbars to or remove them from the Pro/ENGINEER user interface. 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. Click the Toolbars tab. 

3. To remove a toolbar from the display, clear its check box. Click OK to close the 

dialog box. 

4. To add a toolbar, select a toolbar name, for example, Datum Display. 

5. Specify the position of the toolbar by selecting Top, Left, or Right in the position 

list (to the right of the toolbar name). 

The system moves all the buttons currently in the selected toolbar to their 

specified positions. For example, if you specify Right for the View toolbar, the 

system moves the Repaint, Zoom, and other buttons in the View toolbar to the 

right side of the window. 

6. To save the new settings in the config.win file, take one of the following actions 

in the Customize dialog box: 

Click the Automatically save to check box (selected by default). Then, either 

accept the default config.win file name, type a new file name, or navigate to 

the config.win file in which you want to save the settings. 

or 

Click File > Save Settings. In the Save Window Config Settings dialog box, 

you can accept the default file name and path, or you can type a new file name 

or navigate to the config.win file in which you want to save the new settings. 

Path names can contain up to 260 characters. 

7. Click OK to close the Customize dialog box and accept your changes. 

About Customizing the Pro/ENGINEER User Interface 

You can customize the Pro/ENGINEER user interface according to your needs or the 

needs of your group or company.  

Using the Customize dialog box (Tools > Customize Screen), you can customize 

the menu bar and toolbars. By default, all commands in addition to the ones 

available for the active session are also displayed in the Customize dialog box. You 

can add options to the Menu Manager by using the menu_def.pro file. 

Note: You can also change environment settings for Pro/ENGINEER using the 

Environment dialog box. 
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Creating Keyboard Macros, Buttons, and Button Images 

You can click the Mapkeys command on the Tools menu to: 

• Create keyboard macros, called Mapkeys, (copies of frequently used command 

sequences that are associated with defined keystrokes). 

• Define text labels for the buttons if they are added to a toolbar. The label is 

displayed in the toolbar when the user chooses to display text in the toolbar 

buttons. The label is also used when you add the mapkey to a menu using the 

Customize dialog box. Click Tools > Customize Screen to access this dialog 

box. 

• Enter descriptions of each macro that help you keep track of the defined macros. 

Customizing the Toolbars, Toolbar Buttons, and Message Area Location 

You can use the Customize Screen command on the Tools menu to: 

• Add, remove, and move toolbars and toolbar buttons. Many toolbar buttons are 

available in addition to those that appear initially. You can also create new 

toolbar buttons, including split toolbar buttons. 

• Create your own toolbar buttons and change the images on buttons. You can use 

the Customize dialog box to copy, delete, or edit button images. 

• Add, remove, and move mapkeys and top-level commands in menu bar menus. 

• Change the location of the message area. 

• Choose display settings for the Model Tree. 

• Save all window configuration settings in the config.win file. 

Moving, Copying, or Removing Toolbars, Toolbar Buttons, and Menu 
Commands 

You can change the position of a Pro/ENGINEER toolbar on the screen. You can drag 

a toolbar by its handle and place it in a docked position on the top, left, or right side 

of the main window. You cannot float a toolbar as a separate window. You can also 

move individual toolbar buttons to different positions on the same toolbar, or to 

other toolbars. You can then save the new toolbar positions as default settings in the 

config.win file. You can also move menu commands to different positions within the 

same menu or to other menus. You can remove toolbar buttons or menu commands 

from the user interface by dragging them off of the menu or toolbar area. 

You can also reset a button image to its original state and set the display of menu 

bar or toolbar commands as text only, image only, or text with image. You cannot 

modify the appearance of a Menu manager command. 

Editing the Configuration Files 

You can load and edit configuration files to set the look and feel of the Pro/ENGINEER 

window (using the config.win file) and to specify how you want Pro/ENGINEER to 

work in every session (using the config.pro file). To edit the config.pro file, click 
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Options on the Tools menu. To edit the config.win file, use Customize Screen on 

the Tools menu. 

Customizing the Menu Manager Options 

You can customize the Menu Manager. If a system default does not exist for a 

particular menu, you can set your own default using a menu_def.pro file. You can 

also add options and blank them to make them unavailable in the Menu Manager. 

Like the configuration files, this file is loaded during Pro/ENGINEER initialization. 

While loading, the system default directory is searched first, then the current 

working directory. If a menu default entry (menu_def.pro) is defined for a particular 

menu in the system, then any conflicting definitions in the local file are ignored. 

To Add a Mapkey to the Menu Bar or Toolbars 

You can add commands to toolbars or to the menus in the menu bar. The new button 

or command can be an existing Pro/ENGINEER command or a user-defined mapkey. 

1. Click Tools > Customize Screen. The Customize dialog box opens and the 

Commands tab is displayed by default. 

2. Select Mapkeys in the Categories list. 

3. Under Mapkeys, do one of the following tasks: 

o To add a mapkey, drag it to the desired location in the menu bar. 

o To remove a mapkey from the menu bar, drag it outside the menu bar. 

4. To save the new settings in the config.win file, choose of the following actions 

in the Customize dialog box: 

o Select Automatically save to (selected by default), and then accept the 

default config.win file name, type a new file name, or navigate to the 

config.win file in which you want to save the settings. 

o Click File > Save Settings. In the Save Window Config Settings dialog 

box, accept the default file name and path, or type a new file name, or 

navigate to the config.win file in which you want to save the new settings. 

Path names can contain up to 260 characters. 

5. Click OK. 

To Add a Split Button to a Toolbar 

A split button is a series of toolbar buttons that contain closely related commands 

and is stored in a group. Only the first command button in the series is visible. The 

button contains an arrow which, when clicked, displays the remaining command 

buttons. Rather than creating individual toolbar buttons for each command, you can 

create split buttons to save space or to group closely related commands. Using the 

following procedure, you first create a split button, and you then add commands to 

it. The split button displays only the first command in the series; the other 

commands appear when you click the arrow. 



Pro/ENGINEER Fundamentals 

277 

1. Click Tools > Customize Screen. The Customize dialog box opens and the 

Commands tab is displayed by default. 

2. Under Categories, select New Menu. 

3. Under Commands, click and drag the New Flyout button to the desired toolbar 

in the Pro/ENGINEER window. As you drag, an insert indicator previews the 

placement position of the button. You can insert the button anywhere in an 

existing toolbar, but you cannot insert the button inside of another split button or 

as a separate toolbar. Release the mouse button to place the New Flyout button 

in the indicated position. 

4. Assign commands, including mapkeys, to each new button as desired. To do so, 

take one of the following actions: 

Select a new category in the Categories tree, and then under Commands, click 

and drag the desired icon onto the button. 

or 

In the Pro/ENGINEER window, click and drag an existing menu item or toolbar 

button onto the compound button. 

Note: You must add a command to the button. If the button is empty, it is 

removed from the toolbar area when you exit the Customize dialog box. 

5. To save the new settings in the config.win file, click File > Save Settings. 

6. Click OK. 

To Change the Appearance of Menu Bar and Toolbar Commands 

1. Click Tools > Customize Screen. The Customize dialog box opens. The 

Commands tabbed page is displayed by default. 

Note: You can use the Customize dialog box to copy, delete, or edit button 

images. You can also reset a button image to its original state and set the display 

of menu bar or toolbar commands as text only, image only, or text with image. 

You cannot modify the appearance of a Menu Manager command. 

2. Under Categories, select Mapkeys.  

3. In the Mapkeys area, select a specific button and click Modify Selection. Select 

from the following options: 

o Delete—Delete the selected button. 

o Copy Button Image—Copy the image of the selected button to the 

clipboard. 

o Paste Button Image—Paste a copied button image on the selected 

button. 

o Reset Button Image—Reset the selected button to its original image. 
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o Choose Button Image—Open the Pick Mapkey Icon dialog box to 

choose from a set of created images. 

o Edit Button Image—Open the Button Editor dialog box to edit the pixels 

in the image on the selected button. 

o Text Only—Display text only on the selected button. 

o Image and Text—Display image and text on the selected button. 

o Image Only—Display the image only on the selected button (the default). 

You can also select a system-supplied command and click Modify Selection. In 

this case, the only available option is Copy Button Image. 

4. Click OK. 

To Move a Command from One Location to Another 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. In the Pro/ENGINEER window, click and drag a toolbar button or menu item to a 

different location within the same or different toolbar or menu. You can also 

move entire menus and toolbars from one location to another. If you move a 

command from one menu or toolbar to another, the command is copied to the 

new menu or toolbar and now exists on both toolbars or menus. 

To Rename a Menu Bar Menu 

1. Click Tools > Customize Screen. The Customize dialog box opens and the 

Commands tab is displayed by default. 

2. In the Pro/ENGINEER menu bar, right-click the menu you want to rename, and 

then choose Rename from the shortcut menu. 

3. In the Rename dialog box, type the new name for the menu. To place a 

mnemonic (shortcut key) in the new menu name, include an ampersand symbol 

(&) just before the letter you want to designate as the mnemonic. For example, if 

you want to rename the Edit menu to Modify, and you want to make the letter o 

a mnemonic, you would type M&odify. The new menu name would appear 

Modify on the menu bar, and pressing ALT+O would open the menu. 

4. Click OK. The menu is renamed. If you designated a mnemonic, the specified 

letter is underlined. You can press ALT+<the letter> to open the menu rather 

than using the mouse. 

Note: You cannot rename menu command, such as Exit on the File menu. 

To Remove Commands from the User Interface 

You can remove individual commands or entire toolbars or menus. 
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To Remove a Single Command 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. In the Pro/ENGINEER window, drag the toolbar button or menu command outside 

of the toolbar or menu bar. The button or command is removed. 

Note: When you remove a toolbar button, make sure you drag the button 

outside of the toolbar area. If you drag the toolbar button to another location 

within any toolbar, the button is relocated or copied rather than removed. 

To Remove an Entire Toolbar 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. Click the Toolbars tab, and then clear the check box next to the name of the 

toolbar you want to remove. The toolbar is removed from the Pro/ENGINEER 

window. 

3. Click OK. 

To Remove an Entire Menu from the Menu Bar 

1. Click Tools > Customize Screen. The Customize dialog box opens to the 

Commands tabbed page. 

2. In the menu bar, right-click the menu you want to remove, and then choose 

Delete from the shortcut menu. The menu is removed. 

3. Click OK. 

To Change the Position of the Message Area 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. Click the Options tab. 

3. Under Dashboard  position, click Above graphics area or Below graphics 

area. 

4. To save the new settings in the config.win file, do one of the following actions: 

o Select Automatically save to (selected by default), and then accept the 

default config.win file name, or enter a new file name, or navigate to the 

config.win file in which you want to save the settings. 

o Click File > Save Settings. In the Save Window Config Settings dialog 

box, you can accept the default file name and path, or you can type a new 

file name or navigate to the config.win file in which you want to save the 

new settings. Path names can contain up to 260 characters. 

5. Click OK. 

Note: The config.pro file option windows_scale lets you scale the Pro/ENGINEER 

windows using a coefficient. 
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Customize Dialog Box 

You can customize the user interface with the Customize dialog box. To open the 

Customize dialog box, click Tools > Customize Screen. 

You can use this dialog box to: 

• Load different window configuration settings by loading a different config.win 

file. 

• Specify the command buttons that appear in the window toolbars. 

• Add mapkeys and other commands to the menus and toolbars, move them from 

one location to another location, and remove them from the menus or toolbars. 

• Show or hide toolbar categories and customize the locations of toolbars on the 

screen. 

• Show commands for all categories using the All Commands option under the 

Categories section. 

• Specify whether the message area is located below or above the graphics window 

and whether icons appear next to their commands in the menu bar menus. 

• Control the location of the Model Tree and Navigation tabs. 

• Switch the display of icons in the top-level menus, using the Options > Menu 

display > Show icons command in the Customize dialog box. 

Note: You can save the settings you make in the Customize dialog box. All settings 

are saved in the config.win file. To save the settings, select Automatically save 

to (selected by default), and then accept the default file name, or enter a new file 

name, or navigate to the config.win file in which you want to save the settings. 

The following table lists the available commands in the Customize dialog box, along 

with a description of each command. 

Command Action 

File > Open 

Settings 

Opens the Open dialog box, from which you can load a 

different config.win file. 

File > Save 

Settings 

Opens the Save Window Config Settings dialog box, 

in which you can save your current windows 

configuration settings as a new, custom configuration 

file with a new file name. 

View > Show 

Mode 

Commands 

Only 

Lists all commands that are applicable to active model 

of the current session. 

Toolbars 

tabbed page 

Allows you to add, remove, or reposition the available 

Pro/ENGINEER toolbars 

Commands Allows you to add (and delete) new menus and custom 
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Command Action 

tabbed page commands (including mapkeys) to the user interface. 

Also allows you to edit the image and text on a toolbar 

button, delete commands from the menu bar menus or 

toolbars, and set the relative position of individual 

toolbar buttons. 

When you select a command name under Categories, 

its icon is displayed under Commands. The available 

commands are most helpful in the core modules, for 

example, Drawing, Sketcher, and Manufacturing. You 

can also place buttons that you have defined as 

mapkeys on the toolbar or on a menu bar menu. 

Navigation 

Tabs tabbed 

page 

Allows you to set placement and size of the Navigation 

tabs and the Model Tree, and show History by default. 

Browser 

tabbed page 

Allows you to set the width of the Pro/ENGINEER 

browser, expand and animate it upon opening or 

closing Pro/ENGINEER. 

Options 

tabbed page 

Allows you to customize the position of the dashboard, 

change the size of secondary windows, and customize 

the menu display. 

Automatically 

save to 

Allows you to save settings automatically, in the 

config.win (or custom named config.win) file of your 

choice, each time you make changes. The advantage of 

this option is that a config.win could be easily 

modified and saved automatically, then read 

automatically when Pro/ENGINEER is started at a later 

time. 

Customizing the Menu Manager 

About Customizing the Menu Manager 

Your system administrator may use a configuration file called menu_def.pro to 

customize the Menu Manager according to the needs of your workgroup. For 

example, the administrator may add options to the Menu Manager, blank (make 

unavailable) certain options, or set default option selections for the menus. The 

administrator would store the menu_def.pro file in the system default directory 

<loadpoint>/text, so that the identical Menu Manager configuration is loaded 

during initialization (startup) for all members of your workgroup. 

You too can customize the Menu Manager for your local Pro/ENGINEER session, by 

creating a menu_def.pro file and storing it locally in your working directory. The local 

settings will affect only your local session and not the sessions of others in your 
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workgroup. At startup, the system searches for all /menu_def.pro files. It searches 

in the same three directories in which it searches for other configuration files, and in 

the same order—the system default directory <loadpoint>/text, the home 

directory, and the current working directory. The system then customizes the Menu 

Manager according to the settings in all found menu_def.pro files. Note that any 

settings in the loadpoint menu_def.pro file supercede similar settings in the files 

located in the home and working directories. For instance, if the loadpoint directory 

menu_def.pro file contains a setting for making Feature the default selection on the 

PART menu, and your local menu_def.pro contains a setting for making the Set Up 

choice the default selection on the PART menu, Feature will be the default 

selection. 

• You can create a menu item and place it on the Menu Manager to implement a 

sequence of existing commands or a user-defined mapkey (macro). Adding menu 

options provides easy visual access to your keyboard macros or other existing 

commands; menu options are easier to remember and more likely to be used. 

You can also set up these menu items to access other commands or external 

software applications. 

Note: If you want to add an option to the menu bar menus or to the toolbars, 

use Tools > Customize, and then use the Customize dialog box. 

• You can set a Menu Manager menu option as the default choice when a particular 

menu is opened. For example, the default menu option on the FEAT CLASS 

menu is Solid, and it is selected (and highlighted) automatically when you 

choose PART > Feature > Create. 

To Create a menu_def.pro File 

1. Open the text editor of your choice (such as Microsoft Word or Notepad). 

2. Create a new file, and then add the desired commands to customize the Menu 

Manager. You can add options, blank existing options, and set a default selected 

menu option. 

3. Save the file to your working directory as a text file with the filename menu_def 

and the extension .pro. If you are working in an editor that does not allow you to 

use the .pro extension, use the extension .txt and rename the file using 

Windows Explorer or an equivalent application after the file is saved. 

The system loads your menu_def.pro settings each time you start 

Pro/ENGINEER. 

To Add an Option to the Menu Manager 

You add menu items to the Menu Manager by using a menu_def.pro file. To add an 

item, use the setbutton command. 

1. Open a new or existing menu_def.pro file. 

2. Edit the file by adding a line in one of the following formats: 

setbutton menuname menuitem "ActionDefinition" "ShortHelp" 
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or 

setbutton menuname menuitem "ActionDefinition" 

The elements of these definitions are as follows: 

• Menuname—Menu title. It is usually, but not always, the same as that shown in 

the title box at the top of a menu. To be absolutely sure of what the menuname is, 

enable the configuration file option button_name_in_help. As you place the 

cursor over a menu option, the associated menuname and menuitem is shown in 

the status bar. If the title consists of more than one word, substitute # for spaces 

in the menuname (for example, set#up for set up). 

• Menuitem—Name of the new menu option, as you want it to appear in the menu. 

If the option consists of more than one word, substitute # for spaces in the 

menuitem (for example, shade#obj for shade obj).  

• ActionDefinition—Sequence of menu picks, dialog-box picks and user input to 

be activated by the new option. The syntax for the ActionDefinition is the 

same as that for keyboard macros. When a setbutton definition does not fit in 

one line, type [\<CR>] (backslash carriage-return) and continue on the following 

line. The total length of a setbutton definition must be fewer than 250 

characters.  

• ShortHelp—Text string used as one-line help for the new menu option. If omitted 

(when the second format is used), the default string User defined action is 

used for one-line help.  

Referencing Mapkeys in menu_def.pro settings 

You can also reference mapkeys in a menu_def.pro line with the following syntax: 

%<mapkey name> 

For example, if you have your config.pro file contains the following mapkey 

definition: 

mapkey repaint ~ Activate `main_dlg_cur` `View.psh_view_repaint` 

you can reference your menu_def.pro button definition using the following syntax: 

@setbutton PART Update#Model %repaint 

where %repaint is the direct reference to the mapkey. 

Note: To add menu items to the menu bar or toolbars, use the Customize dialog 

box (Tools > Customize Screen). 

Rules for Adding Options to the Menu Manager 

• You cannot use setbutton to modify existing Pro/ENGINEER menu options (that 

is, menu items existing in the system menu files). 

• Make sure that the user-defined item name is unique among all items on the 

screen at any given moment, and that all commands referenced in 

ActionDefinition are accessible at the moment of action execution. For 



Pro/ENGINEER Fundamentals – Help Topic Collection 

284 

example, if you shade the object (see the example below) in Drawing mode, it 

will fail. 

• When you are using a user-defined menu option in another setbutton definition 

or a keyboard macro, remember to change the # characters, if any, back to 

spaces. 

• The maximum number of characters in menuitem permitted by the system is 19. 

You may want to use only 12 characters to fit in the standard Pro/ENGINEER 

menu, or modify your menu width.  

• You must enter menuitem and ShortHelp exactly as they appear on the screen. 

The elements for menuname are case insensitive. ActionDefinition is case 

insensitive except for keyboard input. 

Example: User-Defined Menu Manager Options 

The next three examples illustrate the proper syntax for adding options, blanking 

options, and setting default menu options in Menu Manager menus. 

Example 1: Adding Options 

The following example is part of an actual menu_def.pro file. It contains a setting for 

adding a button to the Menu Manager that cosmetically shades a model. 

@setbutton PART#SETUP COSMETIC#SHD \ 

"~ Activate `main_dlg_cur` `View.psh_view_shade`" "Temporarily Shade the 
Model." 

Example 2: Including Mapkeys 

The following example is from an actual menu_def.pro file. Note that the settings 

contain mapkeys in the definitions. The mapkeys are preceded by a % sign. 

 

Example 3: Setting Default Menu Manager Menu Options 
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This example illustrates two menu_def.pro settings for setting default menu 

selections in Menu Manager menus. A default menu selection is chosen and 

highlighted when its menu is opened. 

The first line sets the option Solid as the default selection on the FEAT CLASS menu 

(accessed when you click PART > Feature > Create). 

@setbutton FEAT#CLASS SOLID 

The following line illustrates the syntax you would use to set the option Protrusion 

as the default selection on the SOLID menu (accessed by clicking PART > Feature 

> Create > Solid). It contains a setting for one-line help. 

@setbutton #SOLID PROTRUSION;\ 

Create a protrusion. 

About Setting Default Menu Options in the Menu Manager 

You can set any Menu Manager menu command as the default choice for a menu. 

The specified menu command will be selected automatically whenever that menu is 

chosen. For example: 

The default menu option in the FEAT CLASS menu is Solid, and it is selected 

automatically when you choose PART > Feature > Create. You can change the 

default option to any option in the FEAT CLASS menu, such as Surface or 

Cosmetic. 

If there is no system default for a particular menu, you can set your own default.  

Examples 

In the drawing mode on selecting Table > Repeat Region, the TBL REGIONS is 

activated and Simple is selected by default. 

Rules for Setting Default Menu Manager Options 

When setting default Menu Manager menu options using menu_def.pro, be aware of 

the following points: 

• To avoid creating serious problems consider what result setting a certain menu 

default may produce. Always remember what menu items the file has set as 

defaults. For example, setting Create as the default choice for the Feature 

menu results in a continuous loop of feature creation, which can only be stopped 

by exiting the Pro/ENGINEER session.  

Setting a certain drawing size as the default for the DWG SIZE menu is another 

example of a dangerous choice. That drawing size is automatically selected 

whenever a drawing is created, and could easily lead to a drawing being 

completed on the wrong size sheet before the mistake is realized. 

• The system default directory <loadpoint>/text is searched first, then the 

current working directory. If a menu default entry has already been defined for a 

particular menu in menu_def.pro, any conflicting definitions in the local file are 

ignored. 
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• You cannot set menu defaults for compound menus. 

• Insert only one space between a menuname and the menuitem specified as its 

default. 

• The entries you make in the menu_def.pro file are case insensitive. 

• If during runtime a user-defined menu default is inaccessible, it is ignored at that 

moment. If the same menu name is used in the menu_def.pro file twice, the 

later entry overrides the earlier one. The system does not report any error 

messages for incorrect menu defaults. 

Tip: Controlling Automatic Loading of a menu_def.pro File 

The system looks for and loads a menu_def.pro file automatically at startup. To 

avoid automatic loading, you can do one of the following actions: 

• Create a menu_def.pro file only when you are certain that you will use it in the 

next Pro/ENGINEER session. Rename or remove the file when the session ends. 

• Keep the file in the working directory under a different file name. When you are 

about to begin a Pro/ENGINEER session during which the file is used, rename it 

to menu_def.pro. Rename or remove the file when the session ends. 

• Keep in mind that your company system administrator may already have created 

a menu_def.pro file. In this case it is stored in the loadpoint directory and its 

properties can only be modified by the system administrator. 

To Set a Default Menu Manager Menu Option 

1. Create or open an existing local menu_def.pro file. 

2. Add to the file a line in the following format: menuname menuitem  

where 

o menuname—Title as shown at the top of a menu. If the title consists of more 

than one word, spaces between the words must be changed to # (for 

example, the menuname for menu DIM PNT PNT would be entered as 

dim#pnt#pnt).  

o menuitem—Option in the menu menuname. If the option consists of more 

than one word, you must change spaces between the words to # (for 

example, enter the menuitem Edge Tangent as edge#tangent). 

Remember to include only one space between the menuname and the menuitem. 

The entries you make in the menu_def.pro file are case insensitive. 

3. Save the file. The new settings will take effect the next time you start 

Pro/ENGINEER. 

Note: Any settings in a menu_def.pro file created and stored in the loadpoint 

directory supercede your local menu_def.pro file settings. 
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Using Configuration Files 

About Configuration Files 

You can customize the look and feel of Pro/ENGINEER and the way in which 

Pro/ENGINEER runs by setting options in a configuration file. Pro/ENGINEER contains 

two important configuration files: config.pro and config.win. The config.pro file 

is a text file that stores all of the settings that define the way in which Pro/ENGINEER 

handles operations. The config.win file is a database file that stores window 

configuration settings, such as toolbar visibility settings and Model Tree location 

settings. Each setting in the configuration files is called a configuration option. 

Pro/ENGINEER provides default values for each option. You can set or change the 

configuration options. Some of the options you can set are: 

• Tolerance display formats 

• Calculation accuracy 

• The number of digits used in sketcher dimensions 

• Toolbar contents 

• Relative button order on a toolbar 

• Location and size of the Model Tree 

Note: Config.sup is a protected system configuration file. Your company system 

administrator uses this file to set configuration options that are used on a 

company-wide basis. Any values that are set in this file cannot be overridden by 

other (more local) config.pro files. 

About menu_def.pro 

The menu_def.pro file is a configuration file that controls the look and feel of the 

Menu Manager. Typically, your company system administrator would set up this file 

in order to customize the Menu Manager according to the needs of your workgroup. 

You can also create your own menu_def.pro file and further customize the Menu 

Manager locally. 

How Pro/ENGINEER Reads Configuration Files at Startup 

Pro/ENGINEER reads configuration files automatically from several areas. If a 

particular option is present in more than one configuration file, Pro/ENGINEER 

applies the most recently loaded/read setting. 

At startup, Pro/ENGINEER first reads in a protected system configuration file called 

config.sup. It then searches for and reads in configuration files (config.pro, 

config.win, menu_def.pro) from the following directories in the following order: 

1. loadpoint/text (loadpoint is the Pro/ENGINEER installation directory) − Your 

system administrator may have put configuration files in this location to support 

company standards for windows configuration settings, formats and libraries. Any 

user starting Pro/ENGINEER from this loadpoint uses the values in this file. 
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2. Login directory − This is the home directory for your login ID. Placing your 

configuration files here lets you start Pro/ENGINEER from any directory without 

having a copy of the files in each directory. 

3. Startup directory − This is your current or working directory when you start 

Pro/ENGINEER. 

Note: The local configuration files (config.pro, config.win, and menu_def.pro) 

in your startup directory are the last to be read; therefore, they override any 

conflicting configuration file option entries. The config.pro file does not, 

however, override any config.sup entries. 

You can create and store custom configuration files in your current working 

directory. These custom configuration files usually apply to specific projects. 

About config.pro Options 

Options in the config.pro file generally use the following format: 

config_option_name value 

Where config_option_name is the option that you want to set, and value 

determines the setting for that option. 

For example, the configuration file option prompt_on_exit tells Pro/ENGINEER 

whether to prompt you to save your working files when you click File > Exit. By 

default, Pro/ENGINEER exits without a prompt. To change this default behavior, you 

can add the following line to your configuration file: 

prompt_on_exit yes 

Pro/ENGINEER reads this configuration file option when it starts and subsequently 

prompts you to save any modified files before exiting. 

Setting config.pro Options 

Each configuration file option in config.pro contains a default value that is set by 

Pro/ENGINEER. If you do not change an option, Pro/ENGINEER uses the default 

value. 

There are two methods to change a config.pro option: 

• Click Tools > Options and use the Options dialog box. 

• Open the config.pro file from within a text editor such as Notepad or Microsoft 

Word, and add or change configuration options directly. 

In general, you should change config.pro file settings before you start a 

Pro/ENGINEER session. If you want to change the environment during a session, it is 

usually more convenient to use the Environment dialog box, accessed by clicking 

Tools > Environment. However, you can change some config.pro options only by 

editing the file directly, by using one of the two methods mentioned previously. 

You can save multiple versions of the config.pro file, with each file containing 

unique settings. This approach is useful if you want to use different configuration 

settings for different models, and you do not want to change multiple options for the 
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same config.pro file as needed. You save different versions by using the Options 

dialog box. 

Setting config.win Options 

You can make window configuration changes to Pro/ENGINEER only during an active 

session. You can make changes using only the Customize dialog box. Open the 

Customize dialog box by clicking Tools > Customize Screen. 

As with the config.pro, the config.win file uses a hierarchical approach to 

configuration file settings. First, it looks in the loadpoint/text and home directories, 

then at the local directory. The settings are reflected as it moves down the hierarchy. 

You can retain different window configurations by saving multiple versions of 

config.win and loading the desired configuration file during a session, rather than 

by changing a single config.win file every time your window configuration needs to 

change. 

To Save config.win Changes Automatically 

All changes in the Pro/ENGINEER user interface are saved in the config.win file 

located in your current working directory. 

1. Click Tools > Customize Screen. The Customize dialog opens. 

2. Select Automatically Save To if it is not already selected. 

3. In the Automatically Save To box, type the name of the custom config.win 

file in which you want to store the current settings, or accept the default file. 

4. Click OK to close the Customize dialog box and accept your changes. 

Note: If you want to see the full path of your current working directory, do the 

following: 

1. Start Pro/ENGINEER in an empty directory. 

2. Open the Customize dialog box (click Tools > Customize Screen). 

At the bottom of the Customize dialog box, the full path name of your current 

working directory is displayed. 

Note: Path names can contain up to 260 characters. 

To Load a config.win File 

Pro/ENGINEER loads the default config.win file at startup if it does not find any files 

named config.win. To load a file named other than config.win or located in one of 

the non-default search locations, you must load custom configuration files each time 

you start Pro/ENGINEER and open the project to which the configuration file(s) 

apply. Use the following procedure: 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. Click File > Open Settings. 
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3. In the Open dialog box, navigate to and select the windows configuration file you 

want to open. Then click Open. 

4. Click OK. The new config.win settings are loaded and visible. 

To Set config.pro Options 

1. Click Tools > Options. The Options dialog box opens. Settings from the most 

recently loaded config.pro file are displayed. The icon next to the option shows 

whether the edit is applied immediately, applied to the next instance of an object 

created, or applied to the next session. 

2. Locate the option you want to set. When you highlight an option in the list, it 

appears in the line labeled Option: in the lower part of the dialog box. 

3. In the Value text box, enter the new value. If the value entries are fixed, for 

example Yes or No, you can use the drop-down list at the bottom of the dialog to 

see what values are available. If the value requires an integer, type it in. If the 

value requires a path or file, type it in or use the Browse option to locate it. 

4. When you have edited the value, click Add/Change. The new value is applied in 

the options list window. The status icon for the affected line changes to show that 

an edit to the default has been made. 

5. When you have finished making edits to the config option values, click Apply, or 

OK. Changes that can be applied immediately appear in the user interface. 

Additionally, when you edit a value during the current session, a configuration file 

called current_session.pro is automatically created in the working directory. 

This file contains only the configuration options you changed with their new 

settings. If the file already existed, it is edited or appended with the new 

settings.  

Using the Options Dialog Box 

Use the Options dialog box to work with Pro/ENGINEER configuration files in the 

following ways: 

• Load a different configuration file (the default is config.pro). 

• Modify values for configuration options in Pro/Engineer configuration files, 

including config.pro files and other files such as drawing setup files (available in 

Drawing mode only). 

• Toggle the display of all configuration options and values, or display only those 

options that are off-default and loaded locally. 

• Determine the source configuration file for each configuration option displayed. 

• Save copies of configuration files with custom settings for current sessions. 

To access the Options dialog box, click Tools > Options. 

The Showing list box displays the last config.pro file read, and the left pane shows 

the cumulative off-default settings that have been read from any config.pro files 
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found in the search path while Pro/ENGINEER is loading. The value, status, and 

source are shown for each option. The status is either applied (solid dot) or 

conflicting values (crosshatched dot). Conflicting values means that two 

configuration files have differing values for the same option. In this case the system 

default setting is used until you reset the value for the current session. 

The source is defined as the configuration file and path that the option and value 

come from. You can use the list to show only the configuration options from each of 

the sources. 

When Current Session is displayed in the Showing box, uncheck the Show Only 

Options check box to show all options and values referenced during the current 

Pro/ENGINEER session. When the box is checked, only those options and values 

loaded from config.pro files are displayed. 

Application Effective Icons 

The icon to the left of each option indicates whether a change is applied immediately, 

or on the next startup. The lightning icon means immediate effect. The wand icon 

means the change is applied to the next object created. The screen icon means the 

change is applied in the next session. 

Editing Options and Values 

When you make edits to options or values, the edits are saved to the file currently 

displayed in the Showing menu when you click Apply. If Current Session is 

displayed, the changes are saved to a file named current_session.pro, which is 

automatically created in the current working directory. 

To edit a value, select it in the list window. The option appears in the Option: text 

field. The value appears in the Value: field. If the value is fixed, for example Yes or 

No, use the drop down list box to select from the choices for the option. If the value 

requires an integer, type it in.  

To reset a value to the system default, select the value and click Delete. When the 

option and value are deleted, the system returns to referencing the default values. 

Navigating the Options 

• Use the Sort list box to sort the options alphabetically or by category. 

• Use the Find button to open the Find Option dialog box and search for options 

using a text string and wildcard characters. For example, if you type 'ecad' in the 

Type keyword field, the dialog box lists all options using ecad in their strings. You 

can also use keywords and wildcard characters to search the descriptions. You 

can change values for the selected configuration options from within the Find 

Option dialog box. 

Note: You must still click Apply in the Options dialog box to save changes to the 

session. 
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To Search for a Configuration Option 

You can use the Find Option dialog box to search for configuration options by typing 

a keyword and wildcard characters. 

1. To open the Find Option dialog box, click the Find button in the Options dialog 

box. 

2. Under Type keyword, type a string that exists within the option you want to 

find. You can use wildcard characters to assist you in your search. For example: 

o If you type the letter a with no wildcard character, the search returns all of 

the configuration options that contain the letter a. This is the most 

convenient way to find all options that contain a certain word. 

o If you type the letter a and an asterisk a*, the system lists all of the 

configuration options that begin with the letter a. 

o If you type an asterisk and the letter a*, the system lists all of the 

configuration options that end with the letter a. 

3. Click Find Now to perform the search. 

Under Choose Option, the system lists all of the configuration options that 

contain the specified string (keyword). 

4. Select a configuration option under Choose Option. 

5. To set a value for the specified option, use the Set Value box. 

6. Click Add/Change to update the configuration option display, and then click 

Close to close the Find Option dialog box. 

7. In the Options dialog box, Click Apply to apply your changes. If you do not click 

Apply, your changes are lost. The system updates the setting in the 

configuration option. 

8. Click Close to close the Options dialog box. 

Working with Licenses 

About Pro/ENGINEER Licenses 

In Pro/ENGINEER, there are two types of licenses: 

• Locked Licenses—A locked license allows Pro/ENGINEER to run only on the 

machine for which the codes were generated. On UNIX systems, the DISPLAY 

setting of Pro/ENGINEER is also forced to the machine for which the codes were 

generated. With this type of license, a license server is not required. 

• Floating Licenses—A floating license allows Pro/ENGINEER to run on any 

machine on your network, provided a machine can communicate with the license 

server. The license server keeps track of how many licenses are checked out and 

will grant or deny licenses to clients based on license availability 
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To List, Get, or Release a Floating Module License 

To obtain the floating module licenses, click Tools > Floating Modules. The 

Floating Modules dialog box opens, and lists the floating modules. 

Command Action 

 

Select all the modules. 

 

Cancel the selection of all the modules. 

Using Auxiliary Applications 

About Auxiliary Applications 

The Auxiliary Applications command on the Tools menu is used to manage 

Pro/TOOLKIT and J-Link applications. It is an entry point for these external 

applications you create for use in Pro/ENGINEER. 

The Auxiliary Applications command opens the Auxiliary Applications dialog box. It 

allows you to 

• Search for registry files (.dat files) in order to register external applications. 

• List all available external applications. 

• Start, stop, or delete registered applications. 

For more information about Pro/TOOLKIT or J-Link, refer to the Pro/TOOLKIT and J-

Link online documentation. 

To Work with Auxiliary Applications 

To start, stop, list, register, or delete an auxiliary application: 

1. Click Tools > Auxiliary Applications. The Auxiliary Applications dialog box 

opens, listing the existing auxiliary applications and their status. 

2. Click one of the following: 

o Register—Retrieve a file by displaying the Register auxiliary application 

dialog box. 

o Start—Start a selected application 

o Stop—Stop a selected application. 

o Delete—Remove a selected application. 

o Info—Display information about any auxiliary applications in the 

Information window. 
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Using Pro/Web.Link 

About Pro/Web.Link 

Pro/Web.Link enables you to build custom Web-based applications that interact with 

Pro/ENGINEER through the Netscape Web browser. Pro/Web.Link extends the 

capabilities of this browser so it can recognize and execute JavaScript commands 

that communicate with a Pro/ENGINEER session. 

During a Pro/ENGINEER session, you set up the access control for Pro/Web.Link with 

the Pro/Web.Link Security dialog box (Tools > Pro/Web.Link > Set Access 

Permissions). 

To Set Access Permissions for Pro/Web.Link 

Pro/Web.Link links the World Wide Web to Pro/ENGINEER, enabling you to use the 

Web as a tool to automate and streamline parts of your engineering process. 

To set access permissions for Pro/Web.Link: 

1. Click Tools > Pro/Web.Link > Set Access Permissions. The Pro/Web.Link 

Security dialog box opens. 

2. Check any of the following actions you want the Web pages support: 

o Read from Pro/ENGINEER Session 

o Make changes in Pro/ENGINEER Session 

o Read from File System 

o Write to File System 

Prompt as needed for new permissions (if autoprompting is turned on and you 

call a function that requires a security level beyond the current settings).  

3. Click OK. 

To Remove a Pro/Web.Link License 

When you remove the ownership of unused Pro/Web.Link licenses (because of a 

program crash, power failure, and so on), click Tools > Pro/Web.Link > Release 

License. 

Working with Trail and Training Files 

About Trail and Training Files 

Trail Files 

A trail file is a record of all menu choices, dialog-box choices, selections, and 

keyboard entries for a particular working session. Trail files allow you to view the 
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record of activity so that you can reconstruct a previous working session or recover 

from an abrupt termination of a session. Trail files are editable text (.txt) files. 

When you run a trail file, the system replays the selections in the exact order in 

which they were originally made. 

Note: Before running a trail file, you must rename it. You cannot rename a trail file 

within Pro/ENGINEER. 

Training Files 

Training files are customized trail files that can be used to help train Pro/ENGINEER 

users. Unlike trail files, training files contain directives that provide the user with 

additional information to help guide them through sample exercises or operations in 

Pro/ENGINEER. These directives can include pauses and textual comments that are 

displayed in an INFORMATION WINDOW. Training files use the extension .txa. You 

can train yourself to use Pro/ENGINEER by creating training files. A training file is a 

trail file that contains information that guides you through a sample exercise or 

operation in Pro/ENGINEER. When you run a training file, the comments that you 

inserted are displayed in an INFORMATION WINDOW. 

Trainer Text Files 

The trainer text file contains the text that is displayed while you use the training file. 

Each training file can reference a single trainer text file. The training text file 

contains text blocks that are displayed in a text window during execution of a 

training file. The text blocks are used to describe what is happening in the system. 

They also provide clues for performing an operation and present data that may not 

appear graphically. 

The trainer text file is divided in sections. The format for each section is as follows: 

#begin number 

text 

#end 

In the trainer text file format, text is the text to be displayed on the screen at a 

particular point in the training file. 

To Run a Trail or Training File 

1. Rename the trail file before running it. 

Note: You cannot rename a trail file from within Pro/ENGINEER. On a Windows 

NT system, use Explorer, and on a UNIX system, use the terminal window to 

either move or copy the file to the new name. Assign the extension .txa to the 

training file. 

2. In Pro/ENGINEER, click Tools > Play Trail/Training File or click  in the 

toolbar (click Tools > Customize Screen to place buttons on the toolbar). The 

Open dialog box opens.  
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3. Select a trail or training file, and then click Open. 

To Create a Training File 

1. Open an existing trail file within an external text editor such as Microsoft Word, 

and then rename the file with the extension .txa. 

2. Open the new training (.txa) file within any text editing application, such as 

Microsoft Word or Notepad. 

3. Add directives to the file. 

4. Save the file when you are finished adding directives. 

To Pause a Training File During Execution 

To set a training file to pause after each line in the file, set the configuration option 

set_trail_single_step to yes. 

To set a training file to pause after only certain lines, include the following syntax in 

the directive of the line at which you want the file to pause: 

`PAUSE 

Directives for Creating Training Files and Trainer Text Files 

The following directives are available to create training files and trainer text files. The 

directives are listed in alphabetical order. 

Breakpoint Marker Name Text 

Cont At Menu Options Textwindow Hints 

Display Menu Nostop Typefile Unset Window Output 

File Pause User Input 

Graphics Resume Prompt User Menu Pick 

Graphics Stop Set Window Output User Pick 

Ignore Stop Typefile  

Note: You must include the open single quote ( ` ) preceding the directive. 

Breakpoint 

Syntax `breakpoint 

Description Stops the rapid execution of the training file 

and returns the trainee to single-stepping. 

Add this directive after the menu selection at 

which you want to break. 
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Cont At 

Syntax `cont_at <label_name> 

Description Causes the training file to skip all commands 

and statements until the specified label is 

found. Execution continues from that point 

on. The argument label_name can point to a 

label further ahead in the training file, but 

cannot point back. 

Example `cont_at get_out 

Transfers training file execution to the label 

get_out. 

See Also Marker Name 

Display Menu 

Syntax `display_menu menu_name 

Description Displays a menu that has already been 

defined with a `menu_options command. 

For the item selected, the action specified in 

the `menu_options command is performed. 

Example `display_menu choices 

Displays the menu named choices. It is 

assumed that the menu has already been 

defined with the `menu_options command. 

See Also Menu Options 

File 

Syntax `file name 

Description Specifies the trainer's text file to be used 

with the training file.  

Only one such file can be specified; 

subsequent `file commands have no 

effect. 

You must enter the full path name only if 

the text file is not in the same directory 

(path names can contain up to 260 

characters). If there is no path specified 

with the name, the system searches for the 
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file in the following directories, in order: 

• The current directory 

• The directory in which the training file 

resides 

• The training directory, if defined in the 

config.pro file with the TRAIN_PATH_FILE 

configuration option 

Example `file text.txt 

The file text.txt is associated with the 

training file. 

`file /usr/users/train/text.txt 

The file text.txt, located in the directory 

/usr/users/train, is associated with the 

training file. 

Graphics Resume 

Syntax `graphics_resume 

Description Restores the graphics mode after a 

`graphics_stop command. If the system 

does not encounter a previous 

`graphics_stop command, nothing 

happens. 

See Also Graphics Stop 

Graphics Stop 

Syntax `graphics_stop 

Description Stops putting new graphics on the screen. 

This command can be used to conceal a 

particular sequence of operations from the 

trainee. 

You can execute all the commands in the 

trail file between this directive and 

`graphics_resume, but they are not 

displayed on the screen. The geometry that 

is displayed in the main window is frozen at 

the point before the command preceding 

the `graphics_stop directive. The menus 

are not displayed. When the trail file 
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reaches the directive `graphics_resume, 

the system resumes normal geometry and 

menus are displayed. 

Example  

See Also Graphics Resume 

Ignore 

Syntax `ignore 

Description Can be used in other commands to replace 

an action or argument. If an action is 

replaced, the system does nothing. If an 

argument is replaced, the system uses a 

default value. 

Example `menu_options choices continue 
`ignore `ignore skip `cont_at 
dome_feature 

Marker Name 

Syntax `marker label_name 

Description Defines a label in the training file, which can 

then be referenced as a target for a jump. 

Example `marker get_out 

Defines a label called get_out in the 

training file. 

See Also Cont At 

Menu Options 

Syntax `menu_options menu_name item 1_name 
action1 {arg1} {item2_name action2 
{arg2}...} 

Description Allows you to define a menu to be displayed 

to the trainee when running the training file. 

The argument menu_name is the name by 

which the menu is identified. 

The menu can have any number of items. 

Each item definition must have an action 
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command and an argument, if necessary. 

You can use `ignore for both actions and 

arguments. 

The number of characters in menu_name and 

any of its items cannot exceed 20. 

Example `menu_options choices quit `cont_at 
get_out continue `ignore `ignore skip 
`cont_at dome_feature. 

See Also Marker Name 

Nostop Typefile 

Syntax `nostop_typefile 

Description Returns the control of the INFORMATION 

WINDOW display to Pro/ENGINEER after the 

``stop_typefile command. If no previous 

`stop_typefile command has been 

encountered, nothing happens. 

Example `nostop_typefile 

The INFORMATION WINDOW (other than 

the window with the trainer's text) scrolls 

quickly. 

See Also Stop Typefile 

Pause 

Syntax `pause line number 

Description Stops the execution of the training file until 

you click Resume to continue the execution 

of the training file again. 

Example `pause 74 

Prompt 

Syntax `prompt number 

Description Displays a prompt message in the Message 

Window. The number argument is the 

number of blocks in the trainer's text file. 
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Example `prompt 77 

Displays the first line of text block number 

77 in the associated text file in the Message 

Window. 

See Also File 

Text 

Set Window Output 

Syntax `set_window_output 

Description Restores regular training file operations for 

message output. 

See Also Unset Window Output 

Stop Typefile 

Syntax `stop_typfile 

Description Passes the control of the INFORMATION 

WINDOW display to the trainee, providing 

the ability to page back and forth, and so 

on. 

When the training file runs, Pro/ENGINEER 

information (such as the feature's 

information and mass properties 

calculations) is displayed in the 

INFORMATION WINDOW. If there are 

multiple pages in the messages in the 

INFORMATION WINDOW, they scroll by 

quickly, and there is no time to view them. 

This directive allows the trainee to control 

the display. 

This command does not affect the display of 

trainer's text. To switch this command off, 

use the `nostop_typefile command. 

See Also Nostop Typefile 

Text 

Syntax `text <number> 
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Description Specifies which block of the text file is to be 

displayed in the INFORMATION WINDOW at 

a specified interval when running the 

training file. Add this directive after the 

menu pick at which you want to break. 

Any text block can be displayed at any time, 

in any order. Repetitive block displays are 

also allowed. 

Example `text 44 

Displays text block number 44. 

Textwindow Hints 

Syntax `textwindow_hints {px py} {rows cols} 

Description Allows you to change the size and position of 

the INFORMATION WINDOW with the 

trainer's text. In the syntax, px and py 

represent horizontal and vertical positioning 

of the text window (its lower-left corner), 

with respect to the main window. The 

argument rows specifies the number of rows 

in the text window, and cols specifies the 

number of columns in the text window. 

You can omit any pair of parameters, in 

which case the system defaults are used. 

(To omit the first pair, replace it with two 

`ignore commands.) If any parameter is 

out of range, the system uses the default 

values. The table Command Parameters lists 

the system defaults and valid ranges for the 

parameters. 

Example `textwindow_hints 0.1 0.1 8 80 

The INFORMATION WINDOW size will be 8 

rows by 80 columns. Its origin will be offset 

at 0.1, 0.1 with respect to the main window. 

`textwindow_hints `ignore `ignore 30 
70 

In this example, only the window size is 

specified (30 rows by 70 columns). The 

INFORMATION WINDOW origin will be at the 

default location. 
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See Also Ignore 

Unset Window Output 

Syntax `unset_window_output 

Description Removes the Text INFORMATION WINDOW 

and diverts all message output to the 

Message window. 

See Also Set Window Output 

User Input 

Syntax `user_input keyboard_data {fail} 
{succ} {giveup} {retries} 

Description Forces the trainee to enter some keyboard 

data at some point while running the 

training file. 

The arguments are as follows: 

• keyboard_data—The keyboard data line 

duplicated from the training file. 

• fail—The message to be displayed if the 

user fails to enter the expected data. The 

format is that of a `text command. Only 

the first line of the specified text block is 

displayed. If you replace this argument 

with `ignore, the default message is 

displayed. 

• succ—The message to be displayed if the 

user succeeds in entering the expected 

data. The format is that of a `text 

command. Only the first line of the 

specified text block is displayed. If you 

replace this argument with `ignore, the 

default message is displayed. 

• giveup—The message to be displayed if 

the user fails the maximum allowed 

number of retries, which is specified by the 

argument retries. The format is that of a 

`text command. Only the first line of the 

specified text block is displayed. If you 

replace this argument with `ignore, the 

default message is displayed. 
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• retries—The maximum number of 

attempts allowed. If you do not specify 

this argument, or replace it with ignore, 

the system uses the default value (5). 

The `user_input command line is a 

duplicate, not a replacement, of an existing 

line with keyboard data in the training file. 

To compose this command, copy a 

keyboard data line, and add the 

`user_input command prefix. Place the 

command above the actual keyboard data 

line. 

Example `user_input 0.5 

0.5 

This example shows the basic `user_input 

command that uses the default message 

specifiers. The second line is the actual trail 

file line. 

``user_input 0.5 'text 67 `ignore 
`ignore 2 

0.5 

This example defines the failure message 

(as the first line of block number 67 in the 

associated text file), and allows two tries. 

The second line is the actual trail file line. 

See Also Ignore 

User Menu Pick 

User Pick 

User Menu Pick 

Syntax `user_menu_pick command {fail} {succ} 
{giveup} {retries} 

Description Forces the trainee to perform a menu pick at 

some point while running the training file. 

The arguments are as follows: 

• command—The menu command line 

duplicated from the training file. The # 

character is retained. 
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• fail—The message to be displayed if the 

user fails to make the expected menu pick. 

The format is that of a `text command. 

Only the first line of the specified text block 

is displayed. If you replace this argument 

with `ignore, the default message is 

displayed. 

• succ—The message to be displayed if the 

user succeeds in making the expected 

menu pick. The format is that of a `text 

command. Only the first line of the 

specified text block is displayed. If you 

replace this argument with `ignore, the 

default message is displayed. 

• giveup—The message to be displayed if 

the user fails the maximum allowed 

number of retries, which is specified by the 

next argument. The format is that of a 

`text command. Only the first line of the 

specified text block is displayed. If you 

replace this argument with `ignore, the 

default message is displayed. 

• retries—The maximum number of 

attempts allowed. If you do not specify this 

argument, or replace it with ignore, the 

system uses the default value (5). 

The `user_menu_pick command line is a 

duplicate, not a replacement, of an existing 

menu pick line in the training file. To compose 

this command, copy a menu pick line and add 

the command prefix `user_menu_pick. Place 

the command above the actual menu pick line. 

Note: This function is available for 

standard Pro/ENGINEER options only, not 

user-defined options (which are defined 

using the functions Menu Options and 

Display Menu). 

Example `user_menu_pick #DIMENSION 

#DIMENSION 

This example shows the basic 

`user_menu_pick command that uses all 

the default message specifiers. The second 

line is the actual trail file line. 
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`user_menu_pick #REGENERATE `ignore 
`text 78`ignore 3 #REGENERATE 

This example defines the success message 

(as the first line of block number 78 in the 

associated text file), and allows three 

retries. The second line is the actual trail file 

line. 

See Also Ignore 

User Input 

User Pick 

User Pick 

Syntax `user_pick x y b {fail} {succ} 
{giveup} {retries} 

Description Forces the trainee to perform a graphics pick 

at some point while running the training file. 

The arguments are as follows: 

• x, y, b—The XY coordinates and button 

code of a pick duplicated from the training 

file. 

• fail—The message to be displayed if the 

user fails to make the expected pick. The 

format is that of a `text command. Only 

the first line of the specified text block is 

displayed. If you replace this argument 

with `ignore, the default message is 

displayed. 

• succ—The message to be displayed if the 

user succeeds in making the expected pick. 

The format is that of a `text command. 

Only the first line of the specified text block 

is displayed. If you replace this argument 

with `ignore, the default message is 

displayed. 

• giveup—The message to be displayed if 

the user fails the maximum allowed 

number of retries, which is specified by the 

next argument. The format is that of a 

`text command. Only the first line of the 

specified text block is displayed. If you 

replace this argument with `ignore, the 
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default message is displayed. 

• retries—The maximum number of 

attempts allowed. If you do not specify this 

argument, or replace it with `ignore, the 

system uses the default value (5). 

The `user_pick command line is a 

duplicate, not a replacement, of an existing 

pick in the training file. To compose this 

command, copy a pick line, and add the 

`user_pick command prefix. Place the 

command above the actual pick line. 

Example `user_pick 0.427022 0.495110 L 
0.427022 0.495110 L 

This example shows the basic `user_pick 

command, with all the default message 

specifiers. The second line is the actual trail 

file line. 

`user_pick 0.427022 0.495110 L `text 
43 `ignore `ignore 15 0.427022 
0.495110 L 

This example defines the failure message 

(as the first line of block number 43 in the 

associated text file), and allows fifteen 

retries. The second line is the actual trail file 

line. 

See Also Ignore 

User Menu Pick 

 

Example: Sample Training File 

The following example of a training file contains five directives. The directives are 

displayed in red. The following key describes the function of each directive. 

KEY: 

• Lines 1 and 2 are the header. 

• The first directive is the name of the file with the trainer's text. 

• The second directive specifies the size of the text window. 

• The third directive displays the first portion of the file train1.txt. 

• The fourth directive stops the graphics display at that point. 
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• The fifth directive resumes the graphics display. 

!trail file version No. ### 

!Pro/ENGINEER TM Version ####### Copyright 1999-2002 by Parametric 
Technology Corporation All Rights Reserved. 

!Select a menu item. 

#PART 

`file train1.txt 

`textwindow_hints 0.1 0.1 8 80 

#RETRIEVE 

!Enter Part name? [-Quit-]: 

block 

#FEATURE 

#CREATE 

#CUT 

`text 1 

#DONE 

#THRU_ALL 

#DONE 

`graphics_stop 

!Select or create a SKETCHING PLANE. 

0.610000 0.435000 L 

@ sel view 0 

0.668082 0.000000 -=0.668077 -0.385709 0.771437 -0.385712 0.545486 
0.545477 0.545491 416.488903 412.228321 -354.564531 1.000000 

!Arrow shows direction of feature creation. 

Pick FLIP or OKAY 

#OKAY 

!Select or create horiz. or vertical REFERENCE for sketching plane. 

0.535000 0.150000 L 

@ sel view 0 

0.668082 0.000000 -0.668077 -0.385709 0.771437 -0.385712 0.545486 
0.545477 0.545491 416.488903 412.228321 -354.564531 1.000000 

!Confirm selection. 

#CREATE 

!Enter Section name?: 
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@ ok 

`graphics_resume 

0.480000 0.510000 L 0.490000 0.485000 M 0.480000 0.510000 M 0.510000 
0.435000 M 

#DIMENSION 0.525000 0.575000 L 

@ sel view 0 

0.000000 0.000000 -1.474721 0.000000 1.474721 0.000000 1.474721 0.000000 
0.000000 7s21.208185 90.062723 -405.548339 1.000000 

@ sel2d CIRCLE 0 4 0.525000 0.625000 M 

Distributed Computing Technology in Pro/ENGINEER 

About Distributed Computing Technology in Pro/ENGINEER 

Pro/ENGINEER uses distributed computing technology to augment your existing 

hardware so that it can perform computationally intensive tasks. 

Distributed computing technology is comprised of the following: 

• A session of Pro/ENGINEER (the controller) 

• Participating networked workstations 

• A daemon running on each participating workstation 

• One or more agents running on the workstations (Pro/ENGINEER sessions 

running as server processes) 

• A task (a collection of jobs) 

The following steps outline how distributing computing technology works: 

1. The controller communicates with the daemon on each remote workstation in 

order to begin an agent process. 

2. The agent process establishes a connection with the controller. 

3. The controller decides which agent receives the next job. The controller 

dispatches the jobs to the agents in order to most efficiently distribute the 

computing of the task. 

4. The daemon on each workstation enables data streaming between the controller 

and the agents, provides statistics, provides job execution feedback, reports 

workstation loads, and monitors workstations on the network. 

5. As each job is completed, the results are streamed to the controller. 

Interactions between the Controller and the Agent  

Distributed computing technology optimizes task distribution. The controller 

communicates with the daemon on each workstation and determines load averages. 
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Agent sessions are launched automatically, depending on load averages and the 

number of processors. These agents are started only once per distributed computing 

task, not once per job. 

Data communication is also optimized. Data (models, information, instructions) are 

efficiently streamed directly to each agent via the daemon. Files are not copied to 

workstations prior to executing a job. As subsequent jobs are dispatched to the same 

agent, only data that is different between the jobs is streamed. If the models 

involved are the same, they are not streamed again. 

To Specify Host Machines for Distributed Computing 

You can specify which host machines you want to use for distributed computing by 

selecting them from a master list configured by your system administrator. 

1. Click Tools > Distributed Computing. The Distributed Computing Hosts 

Selection dialog box opens and lists all host machines designated for distributed 

computing. Information is provided regarding the host name, the IP address, the 

hardware platform, the number of processors, and the CPU load for each 

workstation. 

2. Use the Distributed Computing Hosts Selection dialog box to do the 

following: 

o Configure the current Pro/ENGINEER session so that it uses all or a subset 

of the designated workstations. 

o Use Save to save the selected hosts in a file on disk. To load the files at a 

later time, use Load. 

o Change the selected host machines at any time during a session. 

o Use Refresh to recreate the list of host machines. The system removes any 

machines that are currently off the list. 

o Select a column heading, or use the Sort by box, to sort the host machine 

list. 

To interrupt or cancel a distributed computing task, click Stop. Participating agent 

workstations are made free within a few seconds so that they can be used by others 

who want to execute a distributed computing task. 

Distributed computing is suitable only for Multi-Objective Design studies. Distributed 

computing tasks automatically use the dialog box settings. When you begin 

executing a task, a progress dialog opens and displays the progress of the execution, 

statistics about how many jobs are being processed by agents on each of the 

participating workstations, and the status of each workstation. 

To Configure Workstations to Use with Distributed Computing 

Note: This procedure should be performed by your company System Administrator. 
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After installing Pro/ENGINEER release 2000i2 or later, your system administrator 

must configure workstations to use with distributed computing by performing the 

following tasks: 

1. From the available workstations at your company, choose one that can 

participate in distributed computing sessions. Any mix of UNIX and Windows 

workstations can be used. 

2. Execute the dcadsetup command script on each of the participating workstations. 

Running this script starts a daemon process that is required for distributed 

computing. No other setup task is required. 

3. To shut down the daemon process and thus disable a workstation from 

participating in distributed computing sessions, the dcadshutdown command 

script is available. 

4. Optionally, your system administrator may register the dcadsetup command 

within the boot script of a workstation to ensure that the workstation is always 

enabled after shutdown and restart procedures. 

Viewing Model Creation History 

About Viewing Model Creation History 

The Model Player option on the Tools menu lets you observe how a part is built. It 

aids in the diagnosis of bad features in a part by allowing you to view the creation 

history of a model. You can use this option at any time, or instead of regenerating a 

model after you modify it. The Model Player allows you to do the following: 

• Move backward or forward through the feature-creation history in the model to 

observe how the model was created. You can also start the model playback at 

any point in its creation history. 

• Regenerate each feature in sequence, starting from the specified feature, as the 

model moves forward. 

• Display each feature as it is regenerated or rolled forward. 

• Update (regenerate all the features in) the entire display when you reach the 

desired feature or when the playback process is complete. 

• In Manufacturing mode, recalculate CL data for each NC sequence during 

regeneration. 

• Obtain information about the current feature (the feature that was currently 

regenerated when you stopped the model playback process). You can show 

dimensions, obtain regular feature information, investigate geometry errors, and 

enter Fix Model mode. 

To View Model Creation History 

1. Click Tools > Model Player. The Model Player dialog box opens. 
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2. Select one of the following options for controlling feature regeneration and 

display: 

o Regenerate features 

o Display each feature 

3. Using the control buttons or the slider, select the point in the model creation 

history (that is, select the feature) at which you want to begin the regeneration 

process. To select a starting feature from the Graphics window or the Model Tree, 

click . You can also choose Feat # and type a feature number to specify a 

starting feature. Use  and  to choose a starting feature by stepping 

backward or forward through the playback operation one feature at a time. 

The feature you specify becomes the starting feature. The system suppresses all 

features that occur after it. 

4. To stop playback, click Stop. 

5. Click a command at the bottom of the Model Player to get information about 

the current feature (the feature that was currently regenerated when you 

stopped the model playback process). 

If a feature is one that intersects any other feature on the part, the system displays 

the geometry of the feature in red wireframe before intersection. 

Using the Model Player 

To open the Model Player dialog box, click Tools > Model Player. 

• Select one of the following commands for controlling feature regeneration and 

display: 

o Regenerate features—Regenerates each feature in sequence, starting 

from the specified feature, as the model moves forward. If this box is 

cleared, features will be rolled forward without regenerating. If you have 

made changes to the model without regenerating, the command is checked 

and unavailable. 

o Display each feature—Displays each feature in the Graphics window as it 

is being regenerated or rolled forward. Future features are not displayed 

until they are regenerated. If this box is cleared, the entire display is 

updated only when the desired feature is reached and the model playback 

is complete, or when you stop model playback. 

o Compute CL—(Available in Manufacturing mode only) When selected, the 

CL data is recalculated for each NC sequence during regeneration. If 

cleared, no CL data is calculated during regeneration. 

• Select one of the following commands to select the place (feature) in the model 

creation history at which to start the regeneration process: 
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—Moves immediately to the beginning of the model (suppresses all 

features). 

—Moves immediately to the end of the model (resume all features). Use 

 to step backward through the features one at a time. 

—Steps backward through the model one feature at a time and regenerates 

the preceding feature in the model. 

—Steps forward through the model one feature at a time and regenerates 

the next feature in the model. 

Slider Bar—Drags the slider handle to the first feature at which you want model 

playback to begin. The features are highlighted in the Graphics window as you 

move through their position with the slider handle. The feature number and type 

are displayed in the selection panel (such as #16 (CHAMFER)), and the feature 

number is displayed in the Feat # box. When you release the slider, the model 

immediately rolls or regenerates to that feature. 

—Lets you select a starting feature from the graphics window or the Model 

Tree. Opens the SELECT dialog box and SELECT FEAT menu. After you select a 

starting feature, its number and ID are displayed in the selection panel, and the 

feature number is displayed in the Feat # box. When you select a feature, the 

model immediately rolls or regenerates to that feature. 

Feat #—Lets you specify a starting feature by typing the feature number in the 

box. After you enter the feature number, the model immediately rolls or 

regenerates to that feature. Use  and  to step forward or backward 

through the playback one feature at a time. 

The feature you specify becomes the starting feature, and all features that occur 

after it are suppressed. 

• To stop playback, click the Stop button. 

• You can use the following commands to obtain information about the current 

feature (the feature that was currently regenerated when you stopped the model 

playback process): 

o Show Dims—Displays the dimensions of the current feature. 

o Feat Info—Provides regular feature information about the current feature 

in an Information window. 

o Geom Check—Investigates the geometry error for the current feature. This 

command is accessible only when the system encounters a geometry error. 

o Fix Model—Activates Resolve mode by forcing the current feature to abort 

regeneration. When you exit Resolve mode, Pro/ENGINEER returns to the 
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Model Player at the current feature. You can then continue to move 

backward or forward through the model. 

o Close—Closes the Model Player and enters Insert mode at the current 

feature (the last regenerated feature). You can choose this command 

anytime during the model playback. 

o Finish—Closes the Model Player and returns to the last feature in the 

model. Pro/ENGINEER restores all features. You can choose this command 

anytime during model playback. 

If a feature is one that intersects any other feature on the part, the system displays 

the geometry of the feature in red wireframe before intersection. 

Working with External Reference Control 

About External Reference Control 

Pro/ENGINEER provides reference control tools for specifying system behavior when 

you create external references among features in a design. You can specify the 

reference control settings in the External Reference Control dialog box that opens 

when you click any of the following: 

• Tools > Assembly Settings > Reference Control 

• Edit > Setup > PART SETUP > Ref Control, for a part in Part mode 

• Edit > Setup > ASSEM SETUP > Ref Control, for a subassembly within an 

assembly 

You can: 

• Specify global scope settings that apply to all components in the current session 

except objects that have an object-specific scope setting and objects that have a 

less restrictive object-specific scope control. 

• Specify object-specific scope settings for external references. 

To Set External Reference Control Scope Globally 

In Part or Assembly mode, you can define external reference control scope globally 

for the general Pro/ENGINEER environment. 

1. Click Tools > Assembly Settings > Reference Control. The External 

Reference Control dialog box opens. The Objects tab is selected by default. 

2. Under Components Allowed to be Referenced, select the appropriate option 

to create external references to any component, to components in the same 

subassembly, or to the skeleton of any high level subassembly. 

3. Click the Geometry tab. 

o Under Geometry to be Referenced, select the appropriate option to 

restrict reference selection of external references to only published 

geometry, for all models, or only for models with published geometry. 
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o Under Allowed Placement References, specify if you want to reference 

entire geometry with component constraints or only component interfaces 

as component constraints. 

4. Click the Selection tab. 

• Under Exclude from Selection Bin, select the required settings to include or 

exclude the forbidden references. 

• Under Colors of Forbidden References, specify the color settings as follows: 

o To highlight all prohibited components, select Change Color of Not 

Allowed for Backup, and then click the icon to the right of the text to 

open the Color Editor dialog box, in which you can set the highlight color. 

o To highlight all components from which local copies must be made, select 

Change Color of Allowed for Backup, and then click the icon to the right 

of the text to define the highlight color. 

o To disable the selection of out-of-scope references or invalid components, 

clear both the check boxes. 

Note: If there are object-specific settings in addition to the environmental setting 

for scope control, the system enforces the more restrictive setting for the object. 

To Set External Reference Control Scope for Specific Objects 

You can specify a particular scope setting and external reference-handling scheme 

for a specific object. The information is stored with the object and is in effect for 

each part or assembly file in which the object appears. 

Note: You can set external reference control scope both at model and component 

level. 

1. Use one of the following methods to control the reference scope and handling for 

a component. 

o To set the reference scope and handling for a part in Part mode, click Edit 

> Setup > PART SETUP > Ref Control. 

o To set the reference scope and handling for a subassembly within an 

assembly,click Edit > Setup > ASSEM SETUP > Ref Control and then 

select Inside Subassembly in the External Reference Control dialog 

box. 

o In the Model Tree, right-click to select Reference Control for a part, a part 

within an assembly, or a subassembly within an assembly. 

Each of these methods opens the External Reference Control dialog box. 

2. The Accessible tab is selected by default. If not, click the Accessible tab. 

Under Components Allowed to be Referenced, define the scope of 

components you want to be referenced by selecting one of the following: 
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o All—Allows you to create any external references to any other component. 

This setting is equivalent to having no scope control at all. 

o Inside Subassembly—Allows you to create external references only to 

components of the same subassembly. 

o Skeleton Model—Allows you to create external references to skeleton 

models only. 

o None—Allows no external references to be created. 

3. Click the Backup Forbidden References check box to create out-of-scope 

references. In this case, you can create an out-of-scope reference as an invisible 

local copy only. 

Else, clear Backup Forbidden References to prohibit the creation of external 

references that violate the scope. In this case, if creation of an out-of-scope 

reference is attempted, the action stops and a message identifying the part or 

model whose scope has been violated appears. 

4. Click the Shared tab. 

o Under Geometry Allowed for Referencing, if you want to restrict 

selection of external references to only published geometry, select 

Published Geometry. You can also specify whether you want to restrict 

selection for all models or only for models with published geometry. 

o Under Allowed Placement References, specify if you want to reference 

entire geometry with component constraints or only component interfaces 

as component constraints. 

Note: If there are object-specific settings as well as an environmental setting for 

scope control on an object, the system enforces the more restrictive setting for the 

object. 

The Window Menu 

About the Window Menu 

The Window menu contains commands for activating, opening, closing, and resizing 

Pro/ENGINEER windows. You can also switch between open windows by selecting the 

desired window at the bottom of the Window menu. 

Activating a Window 

To use all the Pro/ENGINEER features that are applicable to an object, you must 

activate the window containing the object. You can activate a window by doing one 

of the following: 

• Press CTRL+A. 

• Note: If a list is available, CTRL+A selects all items in the list. Otherwise, it 

activates the current window. 
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• Click Window > Activate. 

• Select an object from the list in the Window menu. 

In an active window: 

• The word "Active" appears on the title bar after the model name. 

• All applicable menu commands on that window become available. 

• If you minimize the active window, all windows are minimized. 

• The file name associated with the object is selected in the list of open windows on 

the Window menu. 

Opening a New Window 

You can create a Pro/ENGINEER window that contains the same object that is in the 

current window. You can then modify the model and rename it. 

In Part or Assembly Mode 

To create a new window in Part or Assembly mode, use Window > New. The object 

in your current Pro/ENGINEER window is also present in the new window. The new 

Pro/ENGINEER window becomes the active window.  

In Other Modes 

The procedure for creating a new window varies, depending on the module or mode 

you are in at the time. For module-specific procedures, refer to the Help topics on 

the specific module. 

Closing a Window 

You can remove a window from the screen and still retain its object in memory by 

doing one of the following: 

• Click Window > Close. 

• Click File > Close Window. 

If there was an object in that window, the object remains in memory throughout the 

session, or until you click File > Erase > Current. 

If only one Pro/ENGINEER window is open, the object is removed, and the window 

remains open. 

Resizing a Window 

You can resize a Pro/ENGINEER window using several methods: 

• Drag any side or corner of the window. 

• Click the maximize or minimize button on the title bar. 
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• Use the Pro/ENGINEER Maximize, Default Size, and Restore commands on the 

Window menu. 

To Open a System Window 

Click Window > Open System Window.  

You can open a system window (called a command prompt window, in Windows) 

directly from within Pro/ENGINEER. Use a command-line editor to edit a 

configuration file or to carry out other operating-system commands. You must exit 

the system window before you can continue using other Pro/ENGINEER functions. 

The Help Menu 

About the Help Menu 

Use the Help menu to access the Help Center home page, context-sensitive Help, 

release information, and customer service information. The following commands are 

available: 

Help Center—Opens the home page for the Pro/ENGINEER Help Center. From here 

you can navigate to any Help topic. Topics are arranged by functional area. You can 

search for information within a functional area or multiple functional areas. 

What’s This?—Enables context-sensitive Help mode. 

Menu Mapper—Opens the Menu Mapper, an interactive tool that facilitates learning 

of the improved menu structure of Pro/ENGINEER Wildfire. 

Online Resources—Opens the Online Resources page. 

What's New—Opens the What's New document that highlights the new 

functionality. 

Technical Support Info—Provides product information, including the release, 

license information, installation date, and customer support contact information. 

About Pro/ENGINEER—Displays Pro/ENGINEER copyright and release information. 

Context-Sensitive Help  

To Get Context-Sensitive Help 

1. Click Help > What's This? or . 

Note: In some cases, it may be easier to open the dialog box or menu first and 

then click Help > What's This?  

2. Click the icon, dialog box, dialog box option, or menu command for which you 

want help. Pro/ENGINEER displays Help for the item. 

Note: When you are working with the Menu Manager, you can also right-click an 

active command, and click GetHelp. 
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Working with the Model 

Model Tree 

About the Model Tree 

The Model Tree is a list of every feature in a part file including the datums and 

coordinate system. In a part file, the Model Tree shows the part file names and each 

feature in the part below it. In an assembly file, the Model Tree shows the assembly 

file names and the included part files beneath it. 

The model structure is displayed in a hierarchical (tree) format with the root object 

(the current part or assembly) at the top of its tree and the subordinate objects 

(parts or features) below. If you have multiple Pro/ENGINEER windows open, the 

Model Tree contents reflect the file in the current window. 

The Model Tree lists only the related feature- and part-level objects in a current file 

and does not list the entities such as edges, surfaces, curves, and so forth that 

comprise the features.  

Each Model Tree item contains an icon that reflects its object type, for example, 

hidden, assembly, part, feature, or datum plane (also a feature). The icon can also 

show the display or regeneration status for a feature, part, or assembly, for 

example, suppressed or unregenerated. 

By default, the Model Tree is located in the Pro/ENGINEER main window. Click  

on the toolbar to show or hide the Model Tree. Click Settings to customize the 

appearance of the Model Tree. 

You can save all of the information in the Model Tree as a text (.txt) file. 

Subsequently, you can print the file, import it into a text editor and format it for 

review, import it into Microsoft Excel, and apply scripts to it. You can add columns to 

the Model Tree that display selected information about the model. 

Selection in the Model Tree is object-action oriented; you select objects in the Model 

Tree without first specifying what you intend to do with them. You can select 

components, parts, or features using the Model Tree. You cannot select the individual 

geometry that makes up a feature (entities). To select an entity, you must select it 

in the graphics window. 

By default, the Model Tree displays each embedded datum as a feature subnode in 

the creation order that is the last created item is displayed first. For a feature, the 

display of embedded datums and other subnodes on the Model Tree is in the order of 

sketch, annotation, embedded datums, and transformed or patterned features. The 

patterned, mirrored, or moved features are automatically grouped when you embed 

datum features in them. They are displayed in the Model Tree with labels that 

include the tool names, such as Patterned Features, Mirrored Features, or Moved 

Features. The embedded datum features are displayed as sub-nodes of the group 

header, above all other group members. The asynchronous datums with their 

respective feature are displayed as a feature subnode on the Model Tree. In the 

Model Tree using the drag-and-drop technique, you can convert a stand alone datum 

to an embedded datum and vice versa. 
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About Manipulating the Order of Features on the Model Tree  

The Model Tree displays a hierarchical structure of all the features in a Model.  

In addition to selection, you can drag nodes on the Model Tree. Based on the 

context, you can drag nodes to subsequently perform different operations such as 

reordering features on the Model Tree, creating or manipulating groups, embedding 

datum features, activating the insertion mode, and so on. The context is determined 

by the node that you select for the drag-and-drop operation and the location where 

you want to place the dragged node. 

If the new location where you want to place the dragged feature is not valid, the 

pointer changes to . If the location where you want to place the dragged feature 

is a valid location, an internode indicator ( ) appears on the Model Tree. 

Note: Reordering existing features can change the order of features on the Model 

Tree and in turn, the geometry of the model. 

During the drag-and-drop operation, Pro/ENGINEER maintains the referential 

integrity. That is, you cannot place a child feature before its parent feature or a 

parent feature after its children. In order to maintain this referential integrity, 

Pro/ENGINEER dynamically handles the dependencies between the features. That is, 

the interfering parent or children in the sequence on the Model Tree are 

automatically selected and dragged with the dragged node, and the parent-child 

relationship is maintained. 

While performing a drag-and-drop operation on the Model Tree, Pro/ENGINEER 

highlights the selected members and their dependent members based on the relation 

or properties of the selected members. For example: 

• If you drag a feature over a collapsed group node and hold it there for a few 

seconds without placing it over the node, the group node expands automatically.  

• While dragging a feature over an expanded group node, the color of the group 

header changes to dark grey. This color indicates that you are placing the feature 

in the group. Similarly, the color of the group header changes to dark grey when 

you drag a member of that group to place it outside the group. 

• If you drag a feature over a collapsed group and the group contains a dependent 

feature of the feature you are moving, the color of the group header changes to 

light blue indicating that the dependent features will also be moved out of the 

group. For example, if you drag a parent feature over a collapsed group 

containing a child of that feature and place it outside the group, the child feature 

is placed with its parent outside the group. 

• If you drag a datum over other features on the Model Tree, the color of the 

datum header changes to light grey as soon as you move it over a feature in 

which you can embed the datum. However, while embedding, the feature number 

does not change and thus the order of regeneration of features may be different 

from the order in which the features appear on the Model tree. 

• When you drag a feature that is related to other features by one or more 

dependencies, the other dependent features are automatically selected on the 



Pro/ENGINEER Fundamentals 

321 

Model Tree. A  sign appears on the icons of the dependent features to indicate 

that those features were automatically selected.  

For example, when you drag a child feature (Extrude) above the parent 

feature (Datum), the parent feature is highlighted on the Model Tree and its 

icon changes to  to indicate that the feature was automatically selected. 

Similarly, when you drag a parent feature below its child, the child feature 

is automatically highlighted and its icon changes to a   

• If you select multiple items on the Model Tree to perform a drag-and-drop 

operation, a appears next to the pointer. 

• You cannot reorder some features, such as suppressed features or 3D notes. 

• If you try to place the insertion locator ( ) after a suppressed feature, it 

is automatically placed before the suppressed feature or any other suppressed 

features that exist before it. Additionally, if you try to place the insertion locator 

after a group whose last member is suppressed, Pro/ENGINEER activates the 

insert mode and places the insertion locator before the group. 

Note: The insertion locator on the Model Tree indicates where a feature will be 

inserted upon creation. 

Understanding Glyphs on the Model Tree 

The hierarchical structure of the Model Tree contains feature names and their 

corresponding icons. In addition to the feature icons on the Model Tree, 

Pro/ENGINEER uses glyphs to depict the different states of the features when you 

perform various operations on the features. A glyph, located next to the feature icon, 

is a modifier that Pro/ENGINEER uses to indicate whether a component is 

suppressed, not complete, frozen, and so on.  

Pro/ENGINEER uses different glyphs depending on whether you are working on a 

part, assembly, manufacturing model, drawing, format, report, diagram, layout, 

markup, and so on. 

The following table describes some of the glyphs on the Model Tree: 

Glyph Description 

 Indicates that the feature is currently being created or redefined.  

You create models by building features. To create features, you can 

create a new sketch, part, assembly, manufacturing model, 

drawing, format, report, diagram, layout, markup, or interchange 

file in Pro/ENGINEER using the New and New File Options dialog 

boxes. 

 Indicates that the feature is not fully defined (incomplete). 

You can suspend feature creation without losing data that you have 

already defined. This produces an incomplete feature, which you 

can complete later when the design intent is clear or the required 



Pro/ENGINEER Fundamentals – Help Topic Collection 

322 

Glyph Description 

references are available. A fully defined feature cannot be made 

incomplete. 

 Indicates that the feature has failed regeneration.  

Regeneration can fail for reasons such as bad geometry, broken 

parent-child relationships, and missing or invalid references. 

 Indicates that the feature is a packaged component. 

A packaged component is an assembly component that is not fully 

constrained. All moving assembly components are packaged. 

 Indicates that the feature is a child of a packaged component. 

When you place a component in an assembly by referencing a 

packaged parent, the newly placed component is called a child of 

the packaged component. The component is shown as Child of 

Packaged in the Model Tree Status column. 

 Indicates that you are duplicating and placing a component in an 

assembly by copying and pasting it.  

While placing the component, the placement references of the 

source component are maintained but the assembly references 

must be redefined. 

 Indicates that the feature is suppressed. 

Suppressing features is similar to removing them from the model 

temporarily. However, you can unsuppress (resume) the 

suppressed features at any time. You can suppress features in a 

model to simplify the model and reduce regeneration time. 

 Indicates that the component placement uses mechanism joints, 

and is not fully constrained. 

 Indicates that the feature is frozen. (Assembly Mode only) 

Freezing is similar to suppressing a feature. Freezing keeps the 

selected feature in its current location. You can freeze only the 

components of an assembly.  

 
Indicates that the feature is a child of a frozen feature. 

Children of suppressed components can be frozen in their original 

location until they can be regenerated successfully, either by 

resuming the parent, redefining the placement, or rerouting the 

child. 
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Basic Model Tree 

Model Tree Display 

About Searching in the Model Tree 

When you search for model properties or other information the results are 

highlighted in the Model Tree. To perform a search, you use the Search Tool dialog 

box, accessed from the Find command on the Edit menu.  

About Adding Information to the Model Tree 

You can add informational columns to the Model Tree window, such as columns 

containing parameters and values, assigned layers, or feature name for each item. 

You can use the cells in the columns to perform context-sensitive edits and deletions. 

The following types of information can be added: 

• Info—Use this option to add information, including Status, Feat #, Feat ID, Feat 

Type, Feat Name, Copied Refs, Model Size, Feat Subtype and Designate Name. 

• Model Params—Use this option to display any established parameters that 

affect an entire model. You can also define new model parameters using this 

option. 

• Database Params—Use this option to view local, Windchill and Pro/INTRALINK 

database parameters. 

• Feat Params—Use this option to create feature parameters in the Model Tree. 

You can also display the existing parameters by specifying the existing parameter 

name in the Name field. 

• Annotation Elem Params—Use this option to create annotation element 

parameters in the Model Tree. You can also display the existing parameters by 

specifying the existing parameter name in the Name field. 

• Simplified Reps—Use this option to view simplified representations in the 

current assembly. 

• Ext. Simp. Rep—Use this option to view external simplified representations in 

the current assembly. 

• Display Styles—Display Style, DEFAULT 

• Layer—Use this option to display layer status and name of each layer in the 

current model. 

• Note—Use this option to display information about notes, including Note ID, First 

Line, Note Display, any URL that has been assigned to the note, and Note Type. 

• Cable Info—Use this option to set and display default Cabling information such 

as Designation, Diameter, Logical From, Logical To, Physical From, Physical To 

and Length. 
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• Cabling Params—This option allows you to enter and display user-defined cable 

parameters. 

• ECAD Params—Use this option to display parameters specifically associated with 

ECAD parts and features. For more information on the specific parameters you 

can add, refer to the Help on ECAD. 

• Reference Control—Use this option to display the references that are set to 

your current model. You can also choose to display shared model references. 

• Mass Properties Params—Use this option to display the Mass Properties in your 

model. If no properties are assigned, you can type them into a drop-down list 

box. If more than one property is assigned, you can select from them a drop-

down list box. 

• Zones—(Assembly mode only) Use this option to display components inside the 

zone in the current assembly.  

You access the Model Tree Columns dialog box by clicking Settings > Tree 

Columns. 

To Add Columns to the Model Tree 

1. Click Settings > Tree Columns. The Model Tree Columns dialog box opens. 

2. In the Type list, select a type (such as Info, Layer, or Note) and a subtype 

(such as Feat # or Feat ID for the Info type, or Layer Names or Layer Status 

for the Layer type).  

3. Click  to add types to the Displayed list. The new parameter is added to the 

Displayed list. 

4. Click Apply > OK. The dialog box closes and the new parameter column is added 

to the Model Tree. The status of a feature (such as regenerated or failed) is 

indicated next to its icon. 

About Model Tree Operations 

You can perform the following operations using the Model Tree: 

• Rename files on the Model Tree 

o Click the icon next to the filename or double-click the name. A type box 

opens. 

o Type the new name in the type box provided. 

o Press Enter. 

• Select features, parts, or assemblies, and perform object-specific operations on 

them using the shortcut menu. 

Note: You cannot use the Model Tree to select individual geometry that is used 

to make a feature (entity). To select entities, you must use the graphics window. 
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• Filter the display by item type or status, for example, showing or hiding datum 

features, or showing or hiding suppressed features. 

• Open a part within an assembly file by right-clicking the part on the Model Tree. 

• Create or modify features and perform other operations such as deleting or 

redefining parts or features, rerouting parts or features, and so on, using the 

shortcut menu (accessed by right-clicking a part name). 

• Search the Model Tree for model properties or other feature information by 

clicking Edit > Find on the Pro/ENGINEER menu bar. 

• Show the display or regeneration status for a feature, part, or assembly, for 

example suppressed or unregenerated. 

Note: Each Model Tree item contains an icon that reflects its object type, for 

example, assembly, part, feature, or datum plane. The icon can also show display 

or regeneration status, for example, suppressed or unregenerated. 

About Selecting in the Model Tree 

You can use the Model Tree to select features or parts for editing. This is especially 

useful when the selected feature or part is not visible in the graphics window. You 

can also right-click the feature or part to open a shortcut menu, from which you can 

select object-specific commands relative to the selected object. 

You can also select features and parts in the Model Tree even when their selection is 

disabled in the graphics window.  

Note: You cannot select individual geometry (entities) in the Model Tree. The Model 

tree lists only features and not individual entities, as they are the components of 

features. 

The Model Tree Insertion Locator 

The Model Tree insertion locator, indicated on the Model Tree by Insert Here, 

indicates where features will be inserted upon creation. By default, its position is 

always after all items listed in the Model Tree. You may drag it higher or lower in the 

Model Tree to insert features between other features in the list. When you move the 

insertion locator, the model does not reorient irrespective of backward or forward 

movement of the insertion locator in the Model Tree. The graphical display of model 

in current view is displayed. 

After it is moved, you can return the insertion locator to its default location by 

positioning the pointer over it and selecting Cancel on the shortcut menu or by 

dragging the insertion locator to the bottom of the model tree. 

To Move the Model Tree Insertion Locator 

1. Position the pointer over Insert Here on the Model Tree. 

2. Press and hold the left mouse button and drag the pointer to the desired location. 

The insertion locator moves with the pointer. 
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3. Release the left mouse button. The insertion locator is in the new location and 

model orientation of the current view is retained. The model does not roll back to 

the new location. Pro/ENGINEER displays a message in the message area that 

indicates Insert mode has been activated. 

Use the following procedure to return the insertion locator to its default position: 

1. Position the pointer over Insert Here on the Model Tree. 

2. Right-click to open the shortcut menu. 

3. Select Cancel. The insertion locator returns to its default position. Pro/ENGINEER 

displays a message in the message area that indicates Insert mode has been 
cancelled. 

Alternatively, you can return the insertion locator to its default position by 

dragging the insertion locator to the bottom of the model tree. 

About Model Tree Status Display 

You can display the model status in the Model Tree by setting Tree Columns > Info 

> Status and Tree Columns > Database Params > Database Status. 

The status is displayed in the Model Tree column and describes the object state, for 

example, Regenerated. The database status describes whether the object is Editable 

or Read Only. 

When a PDM model is displayed, the Pro/ENGINEER title bar displays the part name, 

revision and its status for example, In Work. 

To Select Objects Using the Model Tree 

You can use the mouse or the keyboard to select objects on the Model Tree. 

Using the Mouse 

1. Click Show > Highlight Model in the Pro/ENGINEER navigator window to check 

the Highlight Model option. 

2. Click the name of a feature or part in the Model Tree. Pro/ENGINEER activates 

the window containing that feature or part and highlights the selected object in 

the graphics window.  

Note: Selections in the graphics area are cleared when items are selected using 

CTRL+Click in the Model Tree. 

You cannot use CTRL + A to select all items in the Model Tree. 

Using the Keyboard 

1. Click the Model Tree window to activate it. A dotted rectangle appears around the 

top-level Model Tree object.  

2. Press the arrow keys to move the rectangle to other Model Tree objects. 

3. Press the space bar once the rectangle is on the object you want to select. 
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To Change Model Tree Column Order 

1. Click Settings > Tree Columns. The Model Tree Columns dialog box opens. 

2. Under Displayed, select the column you want to reorder and click  to 

move the column to the left or right on the Model Tree. 

3. Click Apply > OK. The selected columns are moved to their newly specified 

positions in the Model Tree. 

To Change Model Tree Placement 

1. Click Tools > Customize Screen. The Customize dialog box opens. 

2. Click the Navigation Tabs tab.  

3. Select from the Placement list in the Model tree settings window. 

4. Select desired placement option. 

5. Click Apply settings > OK. 

To Display or Hide Items On the Model Tree 

To hide items, select the item or items on the Model Tree, right-click, and select 

Hide. The selected item or items are temporarily hidden in the graphics window and 

added to the Hidden Items layer. 

To display the hidden items, select the item that you want to display, right-click, and 

use one of the following methods: 

• On the Layer Tree, under Hidden Items, right-click and select Unhide. 

• On the Model Tree, right-click and select Unhide, or click View > Visibility > 

Unhide. 

You can also display or hide the Model Tree by using one of the following methods: 

• On the Model Tree, click the plus sign or minus sign to expand or collapse the 

Model Tree, respectively. 

• On the Layer Tree, click Show > Model Tree. 

To Expand or Collapse the Model Tree 

Click Show > Expand All, or Show > Collapse All. This expands or collapses all 

branches and displays only the highest, or parent part, assembly, or feature, in the 

Model Tree. To expand or collapse single branches, click the plus or minus sign in the 

tree node. 

To Remove Columns from the Model Tree 

1. On the Model Tree, click Settings > Tree Columns. The Model Tree Columns 

dialog box opens. 
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2. Under Displayed, select the column you want to remove and click . 

3. Repeat step 2 for each column you want removed from the Model Tree. 

4. Click Apply > OK.  

To Reorder Features in the Model Tree 

1. Select one or more features in the Model Tree. 

2. Drag the selected feature or features to a new location in the feature list. 

Note: Some features cannot be reordered, such as suppressed features or 3D notes. 

If you try to move a child part to a higher position than its parent part, the parent 

part moves with the child part in context, and the parent/child relationship is 

maintained. Also, if you move a parent part to another position, the children parts 

move with the parent part in context, so the parent/child relationship is maintained. 

To Show or Hide Items by Type on the Model Tree 

1. Click Settings > Tree Filters. The Model Tree Items dialog box opens. 

2. Under Display, click or clear the desired object state options.  

3. Under Feature Types, click a tab and click the feature types you want to 

display. You can click  to select all feature types to display, or   to hide 

all feature types. 

4. Click Apply > OK. 

About Suppressing Items in the Model Tree 

Suppressing a feature temporarily removes it from the model, both physically and 

visually. You can use the Hide command to visually remove a feature. However, if 

you want to remove temporarily remove a feature, for example, in order to try 

another one in its place. Suppressing and resuming features allow you to temporarily 

remove a single or group of features and restore them later. 

To Suppress and Resume Features 

1. Right-click the feature in the Model Tree. The shortcut menu appears. 

2.  Click Suppress. 

Note: If suppressed features are hidden in the Model Tree, click Settings > 

Tree Filters and select the Suppressed Objects checkbox. When supressed 

features are shown, you can select them and click Resume from the shortcut 

menu to return them to the model. 
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Model Tree Notes 

To Create a Model Note Using the Model Tree 

Use the following procedure to create a note in your model from the Model Tree: 

1. Right-click a feature or part in the Model Tree. A shortcut menu opens. 

2. Click Setup Note > Feature (or Assembly, Part, or Component in Assembly 

mode). The Note dialog box opens. 

3. Specify the name for the note in the Name field, or use the default. 

4. Type the note text in the Text field, or click Insert to insert text from a file or 

from another note. 

5. (Optional) Click Symbols to select from a gallery of symbols to add to the note. 

6. (Optional) Under Placement select one of the following for attaching the note to 

the displayed object: 

o Place—Places note on the model 

o Move Text—Moves the note text location 

o Mod Attach—Redefines the attachment point of the note with reference to 

an entity or surface 

o Move—Moves the leader in 360 degrees to change the location and size of 

the leader with reference to the attachment point. 

Optionally, you can also select Place Note Flat to Screen while creating a note 

so that the note text remains flat to screen. This allows you to read the note text 

even when the model is rotated in different directions. 

7. Click Place. The Select dialog box opens. 

8. Select a datum plane or symbol to which the new symbol will be parallel. The 

DIRECTION menu appears. 

9. Click Okay or middle-click to accept the direction for operation, or Flip to reverse 

the direction. The NOTE TYPES menu appears. 

10. Select the required note type or use the defaults. 

11. Click Done. The ATTACH TYPE menu appears. 

12. Select the required options or use the defaults. 

The Select dialog box opens. 

13. Click the required placement area in the main window to place the note. 

14. Click OK in the Select dialog box. 

15. Click Done in the ATTACH TYPE menu. 

16. Click on the graphics area to create the note and place it in the selected area. 
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17. Click OK in the Note dialog box. 

To Create a Note Hyperlink Using the Model Tree 

1. Click Hyperlink in the Note dialog box. The Edit Hyperlink dialog box opens. 

OR 

Right-click the note in the Model Tree to which you want to attach a URL. A 

shortcut menu appears. 

2. Click Add Link. The Edit Hyperlink dialog box opens. 

3. Enter a URL or Internal link in the text box and click OK. 

4. Select the required note in the Model Tree and right-click the note in the main 

window or Model Tree. A shortcut menu appears. 

5. Click Open URL. The Web site attached to the note opens in the Pro/ENGINEER 

browser. 

6. To add the address to your favorites, right-click the Web page and select Add to 

Favorites. 

Similarly, you can edit or remove hyperlinks from notes using the shortcut menus. 

You can also Move, Erase, or Delete the selected note. Use Text Style to change 

the text properties of the note. 

Saving Model Tree Information 

To Save Model Tree Information 

1. Click Settings > Save Model Tree. The Get Name dialog box opens. 

2. Accept the default file name treetool.txt, or type another name and click OK. 

The text file is created and saved in your working directory. 

Note: Pro/ENGINEER does not automatically save Model Tree information to a 

text file. To update the text file, you must perform this procedure. 

To Save Model Tree Settings 

You can save your Model Tree setup and apply it to other models. With more than 

one assembly, part or drawing open in your session, do the following: 

1. Click Settings > Apply Settings from Window in the Model Tree navigator. 

The Change Config Settings dialog box opens. 

2. Select the appropriate model from the list. 

3. Click Apply > OK. 

4. Click Settings > Save Settings File to save these settings to a file. The Save 

Model Tree Configuration dialog box opens. 
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5. Accept the default file name, that is, tree.cfg, or type a new name. 

6. Click Save. 

Advanced Model Tree 

Configuration 

To Save a Model Tree Configuration 

1. Click Settings > Save Settings File. The Save Model Tree Configuration 

dialog box opens. 

2. Accept the default file name tree.cfg, or type a new name. 

3. Click Save. 

To Retrieve a Saved Model Tree Configuration 

1. Click Settings > Open Settings File. The Load Model Tree Configuration 

dialog box opens. 

2. Click Open. If necessary, navigate to the directory where the desired 

configuration file resides, and then double-click the file name to open it, or select 

the file and click Open. 

To Load a Model Tree Configuration at Startup 

You can set the configuration file option mdl_tree_cfg_file to specify a Model Tree 

configuration file to be loaded at startup. 

1. Click Tools > Options. The Options dialog box opens. 

2. Under Option, type the configuration option mdl_tree_cfg_file. 

3. Under Value, enter the path and file name of the Model Tree configuration file 

(tree.cfg, or a user-defined name). 

The Model Tree configuration loads automatically the next time you start 

Pro/ENGINEER. 

Parameters 

To Remove a Parameter Subtype In the Model Tree 

You can use the following procedure to remove a parameter if you added a 

parameter column to the Model Tree. 

1. In the Model Tree, click Settings > Tree Columns. The Model Tree Columns 

dialog box opens. 

2. In the Displayed box, select the parameter you want to remove. 
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3. Click . The parameter is moved back under the Not Displayed box. 

4. Click Apply > OK. 

To Create Parameters Using Model Tree Columns 

1. Select an item in the Model Tree to which you want to apply the new parameter. 

2. Click Settings > Tree Columns. The Model Tree Columns dialog box opens. 

3. In the Type list, select one of Model Params, Database Params, Feat 

Params, Annotation Elem Params, ECAD Params, or Mass Properties 

Params type of parameters. 

4. To create a new parameter for the selected item, under Not Displayed, specify a 

name for the new parameter in the Name field. 

5. Click >> to add the new parameter to the Displayed list. 

6. Click Apply > OK. The dialog box closes and the new parameter column is added 

to the Model Tree. 

7. Click anywhere in the new parameter column opposite the selected item. If the 

parameter does not yet exist, the Parameter Properties dialog box opens.  

8. Select a parameter format (String, Real Number, Integer, or Yes No) and 

click OK. 

9. Type the required parameter value according to the parameter format that you 

have selected. For a real number variable, Pro/ENGINEER automatically 

completes the value to six decimal places. For a Yes No variable, Pro/ENGINEER 

automatically types a YES or NO. 

10. From the Units list, select the required unit for the parameter. 

11. Under Access, select the type of access, that is, full, limited, or locked that you 

want to give to the parameter. 

12. Click OK. The parameter for the selected feature or model is added to the Model 

Tree. 

Layers 

Layer Basics 

About the Layer Tree 

In the Layer Tree, you can manipulate layers, their items, and the display status. 

Use the View menu to control the display of layers.  

You can access the Layer Tree using the following methods: 
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• Click  or View > Layers to display the Layer Tree in the navigation window 

or in a separate dialog box. To view the layer tree in the Layers dialog box, set 

the floating_layer_tree configuration option to yes. If you set this option to 

the default of no, then the Layer Tree is displayed in the navigator window. 

• Click Show > Layer Tree in the Model Tree navigator window. The Layer 

command is available while you are working below the highest-level functional 

menu of any mode (Drawing mode, Assembly mode, Part mode, and so forth) so 

that you can manipulate the layer display status or layer membership as required 

without having to return to the Part, Assembly, or top-level menu. 

Note: The Layer Tree command is available only when floating_layer_tree 

configuration option is set to no. 

Use the shortcut buttons on the Layer Tree toolbar, right-click on items listed in the 

Layer Tree, or use the following drop-down menus to perform layer related 

functions: 

• Show—Display the Model Tree or items in different levels of layers, including 

nested and sub-model layers within your assembly. 

• Layer—Create new layers, set rules, or edit properties with the Layer Properties 

dialog box. In addition, you can propagate, delete, remove, cut, copy, and paste 

items or layers. 

• Settings—Add non-local items to layers being defined or sub-model layers. 

The following symbols appear in the Layer Tree to indicate the type of layer 

associated with items: 

 Hidden Items—Items temporarily hidden from the Model Tree. 

Simple layers—Items are manually added to the layer. 

Default layers—Created using the def_layer configuration option. 

Rules Layers—Layers defined primarily with rules. 

Nested Layer—Layer that primarily contains other layers 

Same Name Layer—Holds all same name layers of all components in the 

assembly. 

Using Hidden Items Layer 

When you manually hide items using the Model Tree or create asynchronous items, 

such items are automatically added to a layer called Hidden Items, if it already 

exists. If it does not exist, a new layer called Hidden Items is automatically created 

and the hidden items are added to it. This layer is always created at the top in the 

Layer Tree list. 

Note: You cannot change the name or properties of the Hidden Items layer, or 

copy other layers to this layer. 
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You can select any item in the Hidden Items layer and perform the Copy Item, 

Cut Item, or Paste Item operations using the shortcut menu to add or remove 

items from this layer. When you unhide items using Unhide All, all the manually 

hidden items that are listed under the Hidden Items layer are removed and 

displayed on the graphics screen. 

Note: The status of the Hidden Items layer is saved when you save the status of 

the other layers. But, you cannot delete the Hidden Items layer. 

About Layer Names 

Layers are identified by name. These names can be expressed in numeric or 

alphanumeric form, with a maximum of 31 characters. When layers are displayed in 

the tree, numeric layer names are sorted first and then alphanumeric names are 

sorted. Layer names in alphanumeric form are sorted alphabetically. 

About Selecting the Active Model in the Layer Tree 

You can select the active layer model from the: 

• Drop-down list 

• Model Tree 

• Graphic Window 

In Part mode, the active model is the part itself. You do not need to identify it before 

working with layers. 

In Assembly mode, you may select the active model before working with layers. 

In Assembly mode, if you are in the process of modifying a part, subassembly, or 

skeleton (that is, you have selected a sub-model and click Activate in the shortcut 

menu to set it as the active model), the Active Object is automatically set to the 

model being modified. 

To Create a New Layer 

You can create a new layer and then use the Layer Properties dialog box to edit 

the name and ID of the layer and add to or remove items from the layer. 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears.  

2. Click Layer > New Layer or right-click within the Layer Tree and use the 

shortcut menu. The Layer Properties dialog box opens. 

3. Type a name for the new layer, or accept the default name. The Layer ID field is 

empty. 

4. Select what you want to include or exclude in the layer using the graphics 

window, search tool, layer tree, or rules tab. 

5. Click Ok. The system creates a new layer with the specified name and adds the 

layer to the active object. As you add a layer, it is placed alphabetically in the 
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tree, and the tree scrolls vertically to the location of the layer that was added 

last. The Layer Properties dialog closes. 

6. Click Pause to temporarily suspend selection of items to the layer and perform 

other operations. Click Resume to continue adding or removing items to the 

layer. 

7. Click Cancel to close the dialog box. Changes to the layer properties dialog box 

are ignored. 

Note: A layer can be defined as a non-ruled layer if it exists in the top level model. 

Using a Template Layer Model 

To use predefined ruled layers, you must define a template model with the required 

ruled layers specified. This model is designated as the template layer model. To 

access the template layer model set the default_layer_model config option to 

<layer_model_name>. Where <layer_model_name> specifies the model name that 

would be used to define predefined ruled layers for all models (*.prt, *.asm, and 

*.drw) in session. You must specify the name of the default layer models without an 

extension. You can create template layer models for a part (*.prt), assembly 

(*.asm), and drawing (*.drw). For example, if the default_layer_model config 

option is set to DEF_LAYER_MODEL_NAME, then for a part, Pro/ENGINEER will search 

for def_layer_model_name.prt, and for an assembly, Pro/ENGINEER will search for 

def_layer_model_name.asm in the working directory, workspace, and template 

directory. 

If you create a new entity in a part, assembly, or drawing that matches the criteria 

of any of the predefined rules in a template layer model, a new layer is added to the 

current model automatically, and the new entity is added to that layer. However, if 

the template model is not available in the current session and if it is undesignated, 

then the ruled layers are no longer driven by the template layer model. 

When the template layer model is not available, then the existing ruled layers 

become non-ruled layers and do not collect any items or objects. Additionally, a layer 

driven from the template layer model (or default layer config) will have the option of 

making the layer independent of the default layer model. Models that already have 

layers before a default layer model is used will always have layers that are 

independent of the default layer model if rules are already defined for the previous 

layers. 

To Activate a Layer 

You can control the layer on which drawing items are placed by setting the layer as 

active. After the layer is activated, any drawing items created, shown, or pasted in 

the drawing are placed on the layer. If a layer is activated in a 3D model, all the 

newly created 3D elements are added to this layer. 

A layer remains active for the duration of the session until you deactivate it, change 

to another layer, or end the session. 

If you manually create a layer, you must manually activate it. You can manually 

activate a layer by doing the following: 
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1. On the Model Tree, click Show > Layer Tree. Any existing layers are listed. 

2. Right-click the layer that you want to activate and click Activate.  appears 

next to the activated layer. Any drawing items created, shown, or pasted in the 

drawing are placed on the active layer. The following table lists different states of 

the default and nested layers. 

Default Layers Nested Layers 

  Default layer is activated  Nested layer is activated 

 Default layer is isolated and 

activated 
 Nested layer with hidden 

components is activated 

 Default layer with hidden 

components is activated 
 Nested layer is isolated and 

activated 

Note:  

• You can automatically activate a default layer by creating it with the def_layer 

configuration option. If you set the def_layer configuration option to 

layer_all_detail_items, you can activate 2D elements. To activate 3D 

elements, set the def_layer configuration option to layer_3d_items. 

• If an active layer exists and you activate another layer, then the first active layer 

is deactivated. 

• If you activate a layer that has the same name as another layer, then each layer 

with that name is activated. 

• If the top-level drawing layer is Layer X and the part layer is also Layer X, then 

activating Layer X in the drawing activates Layer X in the part. However, Layer X 

in the drawing contains all detail items while Layer X in the part contains all 3D 

entities. 

• If you open a new model or drawing in the current Pro/ENGINEER session, then 

no layer is active for that new model or drawing. 

• If Drawing A has an active layer and you open Drawing B, then no layer is active 

in Drawing B. However, if you switch back to Drawing A, then the active layer is 

still displayed. 

• If you open a model in a new window, then no layer is active for that model. 

• If you switch to a model that did not have an active layer, then no layer is active 

for that model. 

• Pro/ENGINEER remembers the active layer status for the top-level model layer 

and any existing same name layers of submodels and retains the status in the 

active window. However, if you open a submodel in a new window, then no layer 

is active for that submodel. 

• If a submodel does not have a same name layer as that of the top-level model 

layer that is active, a new layer is created but not activated. The submodel does 

not have an active layer. 
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To Deactivate a Layer 

A layer remains active for the life of the session or until you deactivate it. You can 

deactivate layers in the following ways: 

• Delete the setting for the def_layer configuration option. 

• Rename the active layer. The layer is automatically deactivated.  

Deactivate the Layer Manually 

You can also deactivate the layer by doing the following: 

1. On the Model Tree, click Show > Layer Tree. All existing layers are listed. 

2. Right-click the layer you want to deactivate, and click Deactivate. The layer is 

deactivated. Any items created or shown after this point will not be automatically 

placed on the layer. 

Note: If the settings for the def_layer configuration option are changed for the 

layer that was activated manually, you cannot deactivate such layers. 

Managing Layers with the Same Name 

Items on layers with the same name are treated similarly. You can set the display of 

model layers to mirror the display of drawing layers with the same name. For 

example, if you blank the drawing layer datums, Pro/E also blanks all items on the 

datums layers for the model components.  

If the model is an assembly and you add a component with a layer of the same 

name, Pro/ENGINEER automatically sets the display of any items on a model layer 

named datums to be the same as the drawing layer. To keep one component datums 

layer from being affected, put the desired layer directly on another drawing layer.  

To set the display of layers with the same name, do one of the following: 

• On the Model Tree, click Settings > Drawing Layer Status, and select the 

second check box (Change display of model layers with the same names in 

drawing only) in the Layer Status Control dialog box. 

• Set the draw_layer_overrides_model drawing setup file option to yes. If you 

set this option to no (the default), Pro/ENGINEER ignores nondrawing layers 

when you set the display status of layers in the drawing model with the same 

name.  

With the exception of ruled layers, if you activate a layer that has the same name as 

another layer, each layer with that name is activated. For example, if the drawing 

and the drawing model have a layer named my_layer, activating one of these layers 

causes the other to be activated. Designated items supported in both modes (driven 

dimensions, surface finish symbols, and geometric tolerances) are placed on both 

layers, while unsupported items are only placed on the drawing layer.  

In an assembly, you cannot activate a layer that exists only in a submodel. However, 

if you activate the same name layer at the top level, all submodel layers are 

activated. 
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To Delete a Layer 

You can delete the selected layer or layers from their objects. 

1. Select one or more layers in the Layer Tree. 

2. Click Layer > Delete Layer or right-click the layer name and click Delete > 

Layer. The CONFIRMATION dialog box opens. 

3. Click Yes to delete the selected layer or layers or click No to cancel the 

deletion. 

To Copy an Item Between Layers 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree opens. 

2. Right-click the items to copy and click Copy Item. The item or items are copied 

to the clipboard. 

3. Select one or more existing layers or click New Layer to create a new layer.  

4. With all destination layers highlighted, click Layer > Paste (or use the right 

mouse button). The item or items are placed on the layers. 

To Copy All Items on a Layer 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree opens. 

2. Right-click the layer whose contents you want to copy. The shortcut menu 

appears. 

3. Click Select Items. 

4. Click Copy Item. The contents of the selected layer are copied to the clipboard. 

5. Select the layer on which you want to paste the copied items, or create a new 

layer by using Layer > New Layer. 

6. Click Layer > Paste. The items are copied onto the selected layer. 

To Set Properties for a Layer 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree opens. 

2. Click Layer > Layer Properties or right-click the layer name and click Layer 

Properties. The Layer Properties dialog box opens. 

3. The current layer name is displayed. You can select it and change the name.  

4. The current ID is displayed in the Layer ID box. You can change the ID. 

The following tabs allow you to set properties for layers: 
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• Contents 

• Rules 

• Notes  

Layer properties in the dialog box always correspond to the selected layer. The Layer 

Tree scrolls vertically so that the selected or expanded layer is always visible. If you 

select more than one layer, selection and properties step down the list, starting with 

the highest layer. 

Note:  If you want to change the names of all same name layers in a top level 

assembly, select the top level name node, and right-click Rename in the shortcut 

menu. This command is only available for name nodes.   

To Obtain Information about a Layer 

Right-click one or more layers in the Layer Tree and click Layer Info in the shortcut 

menu. An Information window opens, showing layer display status for each selected 

layer. 

The information reflects the current status of the Layer Tree even with respect to 

drawing setup file options such as ignore_model_layer_status. 

To Set a Layer Interface ID 

In the Layer Properties dialog box, you can set an interface layer ID. With this ID, 

a layer is recognized when you are exporting the file to a different format, such as 

IGES. 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears.  

2. Right-click one or more layers in the Layer Tree. The shortcut menu appears. 

3. Click Layer Properties. The Layer Properties dialog box opens. If more than 

one layer is selected, the Layer Properties dialog boxes open sequentially for 

each selected layer. 

4. Type a new interface ID for the selected layer or layers of the current object in 

Layer ID box. Enter an integer in the range of 1 through 99,999,999. 

5. Click OK to close the Layer Properties dialog box. 

To Remove a Layer Interface ID 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears. 

2. Select one or more layers in the Layer Tree. If more than one layer is selected, 

the Layer Properties dialog boxes opens sequentially for each selected layer. 

3. Remove the Layer ID from the box. 
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4. Click OK to close the Layer Properties dialog box. 

Layers Remove Item Commands 

You can use Layer > Remove Item and Layer > Remove All Items in the Layer 

Tree to remove a selected item or items from all layers, from all 3-D layers, or from 

all drawing layers. When you use these commands to remove items from a layer, the 

CONFIRMATION dialog box prompts you to confirm before the system removes the 

selected item or items. 

About Layer Display 

Use the Layer Tree to view layers in a part or assembly, view items assigned to a 

layer, and control how layers are displayed in the model. After you change the layer 

display status, click View > Visibility > Save Status to save your changes. If you 

make further changes to the display status after you save it, you can revert the 

display status to the saved status by clicking View > Visibility > Reset Status. 

Hiding and showing layers do not affect model geometry, because these functions 

only affect features that do not affect mass properties, such as datum planes, axes, 

and coordinate systems. You can select datum axes that are created with geometry 

to add to layers either graphically or using the search tool. 

You can set the display status of a layer to one of the following: 

• Shown Layers—(Default) Displays the selected layer. 

• Hidden Layers—Hides the selected layer. 

• Isolated Layers—Displays the selected layers and treats all non-isolated layers 

as hidden. 

• Layers Shown in Hidden Line—(Assembly and Manufacturing mode only) Hides 

the components in the hidden layers according to the environment settings for 

hidden-line display. Other items on those hidden layers are not affected. The 

rules are as follows: 

Environment Setting for Line 

Display 

Hidden Layer Component 

Display 

Wireframe Shown 

Hidden Line Hidden Line 

No Hidden Line Hidden 

Shading Shown 

In Assembly mode, if you set a specific layer or layers to Isolate, Pro/ENGINEER 

hides all components. In addition,  Pro/ENGINEER hides all other items that are 

assigned to any non-Isolate layer. 
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Note: In Assembly mode, if you have components on layers that you subsequently 

set to Hide,  Pro/ENGINEER hides all nongeometry items (datum planes, datum 

axes, feature axes) even if they are also on the displayed layers.  

In all other modes, if you set a specific layer or layers to Isolate,  Pro/ENGINEER 

also hides all other layers. However,  Pro/ENGINEER continues to display items that 

are not assigned to any layer.  

You can hide the following types of items in any modeling mode (such as Part, 

Assembly, or Manufacturing): 

• Datum features, such as planes, axes, curves, and points 

• Feature axes, such as the axes for holes on the layer 

• Cosmetic features 

• Quilts 

Note: Isolate has priority over Hide. Therefore, if a member is on two layers, one set 

to Isolate and the other set to Hide, the member is shown. However, if a feature 

consists of several entities (for example, datum curves), individual entities are not 

shown if the entire feature is in a layer that is set to Hide, even if the entities 

themselves are in layers that are set to Isolate. 

The only features on a layer that layer display operations affect are datum and 

surface features. Solid geometry is not affected. For example, in Part mode, if you 

put a hole on a layer and hide the layer, only the datum axis of the hole is hidden. 

You can hide the hole itself only by suppressing it directly or by suppressing its layer. 

The only exception to this rule is that, in an assembly solid, you can hide 

components. 

If you add a new member to an assembly, and a default layer for it does not exist, 

 Pro/ENGINEER does not automatically add it to an existing layer. If a layer in the 

assembly is already set to Isolate when the member is added, the new member is 

not shown until you either add it to a layer that is explicitly isolated and repaint the 

display or clear all the isolated layers. In the latter case, which is the recommended 

action, all the members of the assembly are shown. 

In Assembly, Show affects the level of the member and levels above it; Hidden 

affects the level of the member and levels below it. 

To Set Layer Display Status 

You can set the display status of layers using the Save Status command, by setting 

configuration file options, or by using the layer file.  

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears.  

2. Click Layer on the Layer Tree toolbar and select one of the following commands 

to set the display status: 

Hide—Hides selected features, components, and layers. 
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Unhide—Shows selected features, components, and layers. 

Isolate—Isolates the selected layers and treats all non-isolated layers as hidden. 

In the Layer Tree, icons next to a layer name indicate whether items on that 

layer are visible, isolated, or hidden. 

Hidden Lines—(Assembly and Manufacturing mode only) Hides the components 

in the hidden layers according to the environment settings for hidden-line 

display. 

Alternatively, set the status to show or display the layer by right-clicking the 

selected layer and clicking Layer > Hide and Layer > Unhide. 

3. In 3D modes, repaint the screen to see any layer status changes take effect. 

In Drawing mode, the graphics display is automatically repainted. 

4. If you want to save the display status, click View > Visibility > Save Status. 

Pro/ENGINEER saves the current layer display status. 

Note: By default, Pro/Engineer does not save the layer display status unless you 

save the layer status before saving the object.  

5. If you want to change the display status after you have saved a status, click 

View > Visibility > Reset Status to roll back the display status. 

To Create Sublayers 

A layer can contain a number of other layers that are considered sublayers. When a 

layer has been included as a sublayer, selecting the name of the top layer 

automatically selects the sublayers as well. 

Sublayers can be associated with different layers. Thus, the sublayer can be 

associated with both the DETAIL layer and any other layer.  

Multilevel layer structure can be created in one of two ways: 

Include a layer as an item on another layer 

1. Select the layer which is the sublayer from the Layer Tree and right-click Copy 

Item in the shortcut menu to copy the selected layer. 

2. Select the layer that you want to add the sublayer and right-click Paste Item in 

the shortcut menu.  This adds the first layer as a sublayer to the second layer.  

Note: You can also open the layer properties of the layer where you want to add the 

sublayer. In the Layer Properties dialog box, you can select other layers to be 

added to the top level layer. 

Deleting a row in the layer file using Settings > Setup File > Edit does not delete 

this layer from the model. However, adding a row by specifying a new layer name 

automatically creates a new layer with that name. 
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To Control the Display Status of Sublayers 

To control the display status of items in lower-level models, you must first put them 

in layers in their native models.  

Usually, then, you would have to navigate down to each model in turn to change the 

display status of its layers. 

However, if you assign common names to layers throughout the Model Tree, 

changing the display status of an upper-level layer simultaneously changes the 

status of those layers of the same name in layers below the one changed. Note that 

layers of the same name in parallel branches or above the selected one are not 

affected.  

Layer Items 

To Add Items to a Layer 

1. In the Layer Tree, right-click the layer to which you want to add items. 

2. Click Layer Properties on the shortcut menu. The Layer Properties dialog box 

opens. 

3. Select the required items to place on the selected layer. Select items in the 

graphics window, Model Tree, or use the search tool. 

If you are in Assembly mode and you select an item to add to a layer and the item 

does not belong in the top level model, then the Place External Item dialog box 

opens. Use this dialog box to add such items to a layer. 

Note: You can add datum axes and coordinate systems to layers as entities either 

through the Pro/ENGINEER graphics window or by using the search tool. Selecting a 

layer highlights the entities on that layer. 

To Add Items to Layers Using Rules 

You can also add items to layers by using the Rules to create rules that define the 

items of a layer. The layer can either store only the items gathered by the rule, or it 

can store the items and the rule itself. If the rule is stored, then the layer will update 

its items with new items that meet the rule criteria. 

1. Open the Layer Properties dialog box of a new or existing layer by right-clicking 

any item within the Layer Tree. 

2. Click the Rules tab. The layers are dependent and non-associative by default. If 

the layer is independent and the Rules Enabled check box is selected, then the 

layer is updated each time an item matches the criteria and is added to the 

model. 

3. Click Options to define the rule settings by selecting one of the following: 

o Associative—Adds all the existing and newly created items to the Query 

Builder box that currently meet the rule criteria. 
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o Rules Enabled—Controls whether items matching the rules can be 

automatically added to the layer. The newly created items are added either 

to the default layers or to the user-defined layers based on the rule criteria 

they meet. 

o Independent—The layer becomes independent and rules are created using 

Edit Rules. 

4. Select Edit Rules. The Rule Editor dialog box opens. 

5. Use the Rule Editor dialog box to create the rules for gathering items. For 

example, type Name is equal to A* to gather all component names starting 

with the letter A. 

6. Click OK in the Search Tool dialog box. 

7. Create a rule in the Rules area of the Layer Properties dialog box. 

8. Select Contents to see items added to the layer. The icon in the Status column 

of the Model Tree indicates how the item was included in the layer (by rule or 

manually). The Contents page is updated only when you close the Layer 

Properties dialog box. 

Note: 

• To define a rule the layer must be independent. 

• You can add one item to multiple layers by adding the item to one layer first 

using its Layer Properties dialog box. After one layer contains the item, you can 

select the item in the Layer Tree and right-click Copy Item on the shortcut 

menu. Select all the other layers to copy to this item and use Paste Item on the 

shortcut menu to copy the item to all the selected layers. 

To Add Items to Multiple Layers 

You can add one item to multiple layers by adding the item to one layer first using its 

Layer Properties dialog box. Once one layer contains the item, complete the 

following steps. 

1. Select the item in the Layer Tree, and right-click Copy Item in the shortcut 

menu. 

2. Select all the other layers to copy to this item. 

3. Right-click Paste Item in the shortcut menu to copy the item to all the selected 

layers. 

To Remove Items from a Layer 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears.  

2. Select one or more items under layers in the Layer Tree. Items do not have to be 

in the same layer.  
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3. Click Layer > Remove Item. You will be prompted to verify that you want to 

remove the selected items. 

Note: You can also remove items from a layer when the Layer Properties dialog is 

open by selecting items in the Contents list, and using the Remove button. 

You can also remove all items from one or more layers. 

1. Select one or more layers in the Layer Tree. 

2. Click Layer > Remove All items. Pro/ENGINEER prompts you to confirm the 

removal of all items.  

3. The selected items are removed from the selected layer or layers. 

To Purge Items from a Layer 

1. Click Show > Layer Tree on the Model Tree navigator window. The Layer Tree 

appears. 

2. Select one or more layers in the Layer Tree. 

3. Click Layer > Remove All Items. The system prompts you for confirmation of 

the purge operation.  

4. Click Yes to remove all the items in the appropriate objects from the selected 

layer or layers, or click No to cancel the deletion. 

To Copy Items from One Layer to Another Layer 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree opens. 

2. Use the Copy and Cut commands on the Layer Tree Edit menu to move items 

from one layer to another in the active model. 

3. Select one or more layer items in the Layer Tree. 

NOTE: A shortcut to select all items of a single layer is to first select the layer, 

and then right-click Select Items in the shortcut menu. 

4. Click Layer > Copy and Layer > Cut or use the shortcut menu. 

5. Specify destination layers for the item or items. Only layers from the parent 

object of the item are available. 

6. Click Layer > Paste or right-click Paste Item in the shortcut menu to copy the 

item to the selected layers. 

Notes: 

• If the item is not hidden, it is highlighted in red. 

• If the item is a hidden geometry feature (such as a hole or round), or a hidden 

component, the geometry is still visible on the screen, but remains highlighted in 

red. Pro/ENGINEER displays that the item is hidden in the message area. 
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• If the item is hidden and is not visible on the model (such as a datum or axis), 

the item is not highlighted on the model. 

• You can select items that are shown or hidden. However, you cannot select 

suppressed items.  

• If the items are visible on the model (whether or not they are hidden), they are 

highlighted in red after you select them. 

• If you select a hidden component in an assembly, the component appears on the 

assembly highlighted in red. 

• If items such as datums and axes are hidden, they are not visible on the model 

and so are not highlighted. 

To Add External Components to Layers 

You can add external components to top-level assembly layers. External components 

are located below the first level of the top-level assembly. For example, components 

within a subassembly are considered external components. You can either add all 

external components to the top-level layer or add external components to sub-model 

layers. 

Note: You cannot add external components from one branch to another branch of an 

assembly structure. 

Two methods to add external components to top-level layers are available. 

• Click Settings > Item Selection Prefs > Favor Current Layer. Select the 

Favor Current Layer checkbox to automatically add all selected sub-level 

components to the top-level layer. 

• To individually add external components to the top level layer: 

1. In the Layer Tree, right-click the layer to which you want to add items. The 

shortcut menu appears. 

2. Click Layer Properties in the shortcut menu. The Layer Properties dialog box 

opens. 

3. Select an external component to include in the top-level layer from the graphics 

window or Model Tree, or use the search tool. The Place External Item dialog 

box opens listing layers of the sub-assembly to which the component belongs. 

4. Select Place component on current layer to add the selected external 

component to the top-level layer. Otherwise, select one or more layers of the 

sub-assembly model and then select one of the following options to include the 

components so they become local to that sub-assembly: 

o Place item on all selected layers—Places the selected component on all 

layers in the active model selected in the dialog box and closes the dialog 

box. 

o New Layer—Creates a new layer in the active model and places the 

selected component on this new layer. 
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o Ignore Item—Ignores the selected component. 

o Ignore All—Ignores all the selected components that are outside the active 

model. 

To Delete a Feature or Component Using the Layer Tree 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears. 

2. Select the features or components to be deleted, right-click, and click Select 

Items on the shortcut menu. 

3. Click Edit > Delete > Delete to delete the selected features or components. 

To Suppress a Feature or Component Using the Layer Tree 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears. 

2. Select the features or components to be suppressed, right-click, click Select 

Items on the shortcut menu. 

3. Click Edit > Suppress > Suppress to suppress the selected features or 

components. 

Default Layers 

About Default Layers 

Pro/ENGINEER can automatically place certain types of items on specified layers 

when they are created. You can establish up to 32 default layers in a model. To do 

this, set the configuration file option create_numbered_layers to yes. 

You can then add these items to layers automatically as you create the items by 

setting the configuration file , def_layer <type-option layername>, where type-
option is the item type, and layername is the name that you assign to the layer. 

Whenever you create an entity of a given item type, Pro/ENGINEER automatically 

adds it to the specified default layer. 

About Creating Layers for Subtractive Features 

Subtractive features (cuts, holes, and so forth) in an assembly must be created on 

intersected models. A new layer is created if this condition is met, and the default 

layer is defined in the configuration option. 

When you create a subtractive feature, the visibility of the feature must be set to a 

level other than the top level. For example, in assembly A with parts B and C, if you 

create a hole in assembly A that goes through part B, you must go to the 

intersection section and specify that the cut be visible at the B part level. This action 
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adds the feature as an assembly cut to part B, and a default layer is created in part 

B. 

Valid Options for Item Type in a Default Layer 

The following table lists valid options for specifying item type in the def_layer 

configuration file option. 

Option  Item Type 

layer_assem_member assembly members 

layer_feature all features 

layer_axis features with axes and cosmetic 

threads 

layer_geom_feat features with geometry 

layer_skeleton_model skeleton model 

layer_nogeom_feat features without geometry 

layer_cosm_round_feat Dieface cosmetic round feature 

layer_cosm_sketch cosmetic sketches 

layer_surface surface features 

layer_datum datum plane features 

layer_datum_plane datum plane 

layer_ext_copy_geom_feat external copy geometry feature 

layer_point datum point features 

layer_copy_geom_feat copy geometry 

layer_curve datum curves 

layer_csys datum coordinate systems 

layer_curve_ent curve entities 

layer_dim all dimensions 

layer_parameter_dim parameter dimensions 

layer_driven_dim driven dimensions 

layer_draft_dim draft dimensions 

layer_refdim all reference dimensions 
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Option  Item Type 

layer_part_refdim part reference dimensions 

layer_draft_refdim draft reference dimensions 

layer_note drawing notes 

layer_gtol geometric tolerances 

layer_ribbon_feat ribbon feature 

layer_solid_geom solid geometry 

layer_symbol symbols 

layer_sfin surface finish symbols 

layer_thread_feat cosmetic thread feature 

layer_trim_line_feat Dieface trim line feature 

layer_weld_feat weld feature 

layer_detail_item draft items that include datums, 

notes, balloons, GTOLs, symbols and 

groups 

layer_draft_entity all draft entities 

layer_draft_constr draft construction entities 

layer_draft_geom draft geometry entities 

layer_draft_hidden draft hidden entities 

layer_draft_others all other draft entities 

layer_draft_grp draft groups 

layer_draft_dtm draft datums 

layer_quilt quilts 

layer_dgm_wire diagram wires 

layer_datum_point datum points 

layer_dgm_conn_comp diagram connector components 

layer_dgm_highway diagram highways 
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Option  Item Type 

layer_dgm_rail diagram rails 

layer_dwg_table drawing tables 

layer_assy_cut_feat assembly cut 

layer_chamfer_feat chamfer 

layer_corn_chamf_feat corner chamfer 

layer_cut_feat cut  

layer_draft_feat draft 

layer_hole_feat hole 

layer_protrusion_feat protrusion 

layer_rib_feat rib 

layer_round_feat round 

layer_shell_feat shell 

layer_slot_feat slot 

layer_snap_line snap lines 

layer_comp_design_model design model configuration file 

option DEF_LAYER or "SetDefLayer" 

inside the layer interface 

layer_comp_workpiece workpiece configuration file option 

DEF_LAYER or "SetDefLayer" inside 

the layer interface 

layer_comp_fixture fixture configuration file option 

DEF_LAYER 

layer_Solid_geom solid geometry in a part 

layer_intchg_funct functional interchange component 

layer_intchg_simp simplified interchange component 

Layer_nongraph_annot_elem graphical annotation element 
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Using Layer Status Files 

About Using Layer Status Files 

The file format for a layer file is as follows: 

• The first line of a layer file must always begin with 

!LAYER SETUP nnn 

• The number nnn is a version number that can change. Verify this number in the 

trail file for the model before you start to edit the layer file outside of 

Pro/ENGINEER. 

The following rules apply to the layer file format: 

• The first column must always contain the layer name. 

• There must not be any blank lines in the file. 

• The display status is optional. To specify the display status, enter one of the 

following: HIDE, UNHIDE, and ISOLATED. 

• Interface ID is optional. A number sign (#) precedes the ID. You must set this if 

you intend to export layer information. 

• You can specify any number of sublayers. 

If you use a system editor to create the file, make sure that there is at least one 

space between each entry.  

If you are using Pro/TABLE, put only one entry in each cell 

To Save Layer Display Status Settings as a File 

1. Click  or Show > Layer Tree in the Model Tree navigator window. The Layer 

Tree appears. 

2. Click Settings > Setup File > Save. The Save a Copy dialog box opens 

3. Use Look In in the Search Tool (Edit > Find) to select the directory to which to 

save the status file. You can accept the default .pro file name or enter a file 

name. The default file type is a configuration file. 

4. Specify a file name and click OK. The system saves the layers of the active model 

and their current display status to a file. 

Saving the information to a file makes the layers and their display status available 

for retrieval or to be used by other objects. 

Note: If you enter the name layer_file, in response to the prompt, the actual file 

name is layer_file.pro. 

To Open a Layer Status File 

1. Click Show > Layer Tree to open the Layer Tree. 
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2. Click Settings >  Setup File > Open to apply the file to the model. 

To Edit a Layer Status File 

1. Click Show > Layer Tree to open the Layer Tree. 

2. Click Settings > Setup File > Edit to manipulate a layer by modifying 

parameters in the layer file in Pro/TABLE. 

Using Default Layer Status Files 

Layer status files let you: 

• Change the display status of a number of layers and sublayers in one operation. 

• Associate sublayers with other layers, by editing the table.  

• Define a default setting for layer status whenever you start Pro/ENGINEER. 

You use Pro/TABLE to edit layer files. When the file is saved, the layer display status 

is saved with it. If you later end the session, then start a new one and retrieve the 

model, the system displays the model in the settings that you last saved.  

A layersetup.pro file can be used to establish company standards for layer names 

and layer structure. The system retrieves this file whenever you begin to create a 

new object with Pro/ENGINEER.  

You can also create a customized version of layersetup.pro and store it in your 

startup or home directory. When you start creating the object, Pro/ENGINEER 

searches for the layersetup.pro file in directories in the following order:  

• Current 

• Home 

• Pro/ENGINEER 

• loadpoint/text  

This ensures that the company standard is not overridden because later settings 

overwrite earlier ones.  

A default layersetup.pro file is supplied with Pro/ENGINEER in the loadpoint/text 

directory. It contains 32 layers with names 1 through 32 inclusive. 

Example: A Typical Layer File 

! LAYER SETUP 1061 

! Comment lines must begin with a "!" 

! 

! The first column must always contain the layer name. 

! As an option, entering one of the following can specify the display 
status: HIDE, UNHIDE, and ISOLATED. 
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! Interface ID can optionally be specified by preceding the ID with # 

! You can specify as many sublayers as you want. 

! 

! eg. 

! DATUMS SHOWN #100 DTM_PLANES AXES POINTS COORD_SYSTEMS 

! 

! NAME | STATUS | #ID | SUB-LAYER NAMES 

! 

LAY0001 SHOWN 

LAY0002 SHOWN 

LAY0003 HIDDEN 

Using the Layer Tree 

To Include or Define Rules in Layers 

1. Specify rules in layers or include items defined by the rules. 

2. Right-click the layer name and click Layer Properties. The Layer Properties 

dialog box opens. 

3. Click Rules. The Rules Enabled option under Options is selected by default and 

allows you to update the layer each time an item that matches the criteria is 

added to the model. 

4. Select Independent, the Edit Rules option is enabled. The layers are 

dependent and non-associative by default. 

5. Click Edit Rules. The Rule Editor dialog box opens. 

6. Search and select rule conditions using the Rule Editor. 

7. Click Preview Results to preview rule condition results or click OK. The rule 

conditions appear in Rules. 

8. Click OK. Layers and their associated items appear in the Layer Tree. 

Note: The symbol  appears in the Layer Tree indicating the layer is defined 

primarily with rules. Additionally, rules can be combined using AND and OR 

operations. 

To Nest Layers within Layers 

Use the Layer Properties dialog box or copy and paste commands to nest layers 

within layers. 

1. In the Layer Tree, right-click the layer name. The shortcut menu appears. 
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2. Click Layer Properties. The Layer Properties dialog box opens. The Include 

button is selected by default. 

3. Select the layer to nest from the Layer Tree. This layer name appears in the 

Contents list. However, items of the nested layer are not listed. 

Note: To show items of nested layers in the layer tree, click Settings > Items on 

Nested Layers. 

Alternatively, you can use copy and paste commands to nest layers. 

To Display and Select Items in the Layer Tree 

Use the following commands in the Layer Tree to display and select items: 

Under Show: 

• Highlight Geometry—When selected, items in the Layer Tree are highlighted in 

red in the graphics window. The setting is remembered in the session 

independently for 3D modes and in Drawing mode. That is, settings do not return 

to the default, so that when you open the dialog box again, the Highlight setting 

is the same as it was the last time the dialog box was closed. 

• Find—Search for layers containing or controlling specific items. 

Under Settings: 

• All Submodel Layers—Shows layers in the active object and all associated 

submodels. 

• Submodels layers if in the Active Model—Shows active object layers in all the 

associated submodels. 

• No Submodel Layers—Shows layers in the active object only. 

• Layer Items—Shows all layer items in the Layer Tree. 

• Items on Nested Layers—Shows items of nested layers in the Layer Tree. 

To Display a Layer Status File 

1. Click Show > Layer Tree to open the Layer Tree. 

2. Select a layer. 

3. Click Settings > Setup File > Display. An INFORMATION WINDOW dialog box 

showing the current display status and contents of selected layers. Using the File 

menu in the Information window, you can save this information to a tmp.pro 

default file or save it as a text file with a specified file name. 

To Expand or Collapse the Tree Menu 

Click Show and select one of the following: 

• Expand All 

• Collapse All 
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Search Tool 

About the Search Tool 

The Search Tool allows you to find entities within your model without selecting from 

the graphics window or Model Tree. You can specify rules using the Attributes, 

History, Status, and Geometry tabs to help find specific information. You can create 

a layer of the found items, or select all or a subset of the found items by transferring 

them to the active selection section of the search tool. 

You have the option to find items that are not valid for the current selection. For 

example, if you want to find a horizontal reference for a sketching plane, the 

collector filters out all datum planes not orthogonal to the sketching plane. Filtered 

Selections, on the Options menu allows you to apply the filters. 

The Search Tool is available by clicking  on the Pro/ENGINEER toolbar or by 

clicking Edit > Find menu. You can select items by attributes such as name, ID, or 

number, annotations, or the last feature you created and create rules using 

wildcards. For example, Name is equal to A* searches for item names that begin 

with the letter A. The Criteria section displays the various comparison options, 

values, categories and other criteria based on the rule set for searching items. 

Search results and corresponding locations are listed under Items Found of the 

Search Tool dialog box. The results are also highlighted in the Model Tree and 

graphics window. To select items, use  to transfer items from Items Found to 

the Items Selected section of the Search Tool dialog box. 

Note: If you are working outside a tool (no action specified), selected items are not 

cleared when you open the Search Tool. For example, if you select the feature and 

click Find Now, that feature is listed in the item selected section of the search tool. 

If the Search Tool is used while a tool is active, clicking the Close button appends 

only the search results and overrides any current selection. 

The rules and values in the Search Tool reappear when a search is performed and 

you reopen the Search Tool to perform another search. 

The Search Tool dialog box contains the following tabs and buttons: 

• Attributes—Search for items based on their attributes (Name, Type, 

Parameters, Size, Description, or Property) 

• History—Search for items based on their creation order or ID (including Last 

Feature, Failed Feature, and All, when applicable) 

• Status—Search for items based on their status (Regeneration, Layer, Display, 

Parent/Child, Copied Refs) 

• Geometry—Search for items based on geometrical relationships (Zone, Distance, 

Exterior Components) 

• Look for—Specify the type of item to search for, for example, feature, 

component, dimension, and so on. 
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• Look by—Create a more detailed query. For example, if you set Look for to 

Feature and set Look by to Dimension. The rules apply to dimensions but the 

found items are features that own the found dimensions. 

• Look in—(Available in Assembly and Drawing mode only) Select the active 

model. If the scope of your selection is already defined, this field is not displayed. 

The arrow button allows you to select the desired model from the graphics 

window or the Model Tree. Click the Include submodels check box to search 

the sub-models of the Look In model. 

• Find Now—Search by identified rules and display results under Items Found. If 

only one item is in the found list, it is automatically highlighted in the found list. 

If only one item is to be selected, select it from the list, and click  to append 

it to the selection bin or double-click the item. You can also middle-click to add it 

to the selection bin and close the dialog box. 

• New Search—Start a new search. 

• Options—Set options, build, and save queries. Save the components gathered 

by a rule or set of rules into a layer using Save Query. This prompts for a new 

layer name, and creates a new layer in the layer tree. Build a query by combining 

rules that use Boolean AND and OR operations. 

About Rules and Criteria for Searching Entities 

You can search for an entity in a model by using the Search tool. To refine the 

search, use the different rules and their corresponding criteria available in the Search 

Tool. These rules are available for each of the Attribute, History, Status, or 

Geometry tabbed pages in the Search Tool dialog box. The Criteria section 

displays the various comparison options, values, categories and other criteria based 

on the rule set for searching items. These rules and criteria change according to the 

selected Look for and Look by values.  

You can refine the search by building a query with a combination of one or more 

than one rule and the corresponding criteria in the required tabbed page. You can 

also create rules using wildcards. For example, the rule Name is equal to A* 

searches for entity names that begin with the letter A.  

Example: Using Rules and Criteria for Comparing Entity Names 

You can search for items by name in the Search Tool dialog box. To search for an 

entity by name, click the Attributes tab in the Search Tool dialog box and under 

Rules, select Name. Under Comparison, specify a condition such as, is equal to, is 

not equal to, is less than, is greater than, is less than or equal to, and is greater than 

or equal to, for comparing the name specified in the criteria with other entity names 

in the model.  

In the Search Tool dialog box, under Criteria, you can set the Value in one of the 

following ways: 

• Specify the exact name that you want to search for. Pro/ENGINEER searches for 

items in the model whose names match exactly with the specified name.  
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• Use wildcards. Pro/ENGINEER searches for all items whose names contain the 

specified character. For example, the rule Name is equal to A* searches for 

entity names that begin with the letter A. Similarly, the rule Name is equal to 
B*A searches for entity names that begin with the letter B and end with the letter 

A. 

• Use asterisk only. Pro/ENGINEER searches all the items that have a default 

feature name and for items for which you have explicitly assigned a feature name 

in the model. For example, the rule Name is equal to * searches for all entities 

that have a feature name defined in the model.  

While searching for an entity by its name, Pro/ENGINEER compares the names 

character by character. However, for groups of digits, the values of the groups are 

compared.  

Some examples of how Pro/ENGINEER compares the names, while searching for an 

entity by its name, are: 

• If the model includes datum features named DTM1, DTM2, DTM003, DTM0004, 

and DTM005 and you have created the following rules to build a query:  

Rule 1: Name is greater than DTM1  

Logical operator: AND  

Rule 2: Name is less than DTM005  

The result of the search includes DTM2, DTM003, and DTM0004. 

• If you create a rule Name is equal to DT*, the result includes DTM1, DTM2, 

DTM003, DTM0004, and DTM005 along with the other entities that have their 

names starting with DT.  

A few more examples of how Pro/ENGINEER compares the names, while searching 

for an entity by its name, are: 

• The name abc is less than the name abcd.  

• The name abcd is less than the name zabcde.  

• The name 12ab is greater than the name 2a. 

Similarly, you can use the rule-criteria combination to search for entities based on 

their attributes, history, status, and geometry properties. 

To Search for Objects in the Model Tree 

1. Click Edit > Find. The Search Tool dialog box opens. 

2. If you are searching an assembly or a drawing, select an item from the Look in 

and Look by lists, and click the Include submodels check box, if required. 

3. Click the tab to select the criteria by which you wish to search (Attributes, 

History, Status, Geometry). 
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4. Click Find Now. The found items and corresponding location list in the items 

found section of the Search Tool dialog box. The results are also highlighted in 

the Model Tree and graphics window.  

5. To select items, Click  to transfer items from Items Found to the Items 

Selected section of the Search Tool dialog box. 

6. Click Close. 

To Build a Query in the Search Tool 

You build a query in the Search Tool to combine rules for a search you want to 

perform. Use the following procedure to build a query: 

1. Click Edit > Find. The Search Tool dialog box opens. 

2. Click Options > Build Query. The Query Builder dialog box opens. 

3. Select an item type from the Look for list. 

Note: To enable the Geometry tab, Component must be selected in the Look 

for list. 

4. Select a model in the Look in list, if relevant. 

5. Select from the available tabs and list boxes to customize the rules. 

6. Click Add New to add the defined rule to the condition builder. 

7. Create a new rule using the tabs and list boxes to be combined with the previous 

view using and or or operations. 

8. Click Add New. The next rule is added to the condition builder.  

Note: The default operator is or when adding new rules. The operator can be 

changed to and by clicking the Operator cell and selecting from the list. 

9. When all the desired rules are combined, click Find Now. The search results 

from the combined query and corresponding locations are listed in items found 

section of the Search Tool dialog box. 

Note: You can click Options > Save Query to save this query for later use. 

To Save Query in the Search Tool 

You can save a query once you save it under a specified layer name. 

1. Click Edit > Find. The Search Tool dialog box opens. 

2. Click Options > Build Query. The Query Builder dialog box opens. 

3. Set the rules for the query. 

4. Click Options > Save Query. The Save Rules dialog box opens. 

5. Enter a layer name. The layer is created and a message displays Current Query 
has been saved in layer [layer name]. 
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About Searching for Multiple Values to Edit 

You can use the search tool to find and select items for multiple value editing. After 

you specify rules to find items, you can select items, and then use the Edit Value 

command in the shortcut menu to edit multiple values. The following items are 

considered valid for multiple editing: 

• Dimension Values 

• Surface Finish Values 

• Geometric Tolerances 

• Parameters 

Multiple values must meet the following conditions to be edited: 

• Same type values must exist (linear or angular) 

• Values must be either driven or non-driven 

• Read only and regular files cannot be integrated. 

To Search and Edit Multiple Values 

1. Click Edit > Find. The Search Tool dialog box opens. 

2. Specify the criteria and rules to find items with values to edit. 

3. Click Find Now. The found items and corresponding locations are listed in the 

items found section of the Search Tool dialog box. The results are also 

highlighted in the Model Tree and graphics window.  

4. Click  to transfer items from items found to the items selected section of 

the Search Tool dialog box. 

5. Click Close. The Search Tool dialog box closes. 

6. Right-click in the graphics window. The shortcut menu appears. 

7. Click Edit Value. The text box appears. 

8. Type the new value.  

To Search for Intent Objects 

1. Click  or click Edit > Find. The Search Tool:1 dialog box opens. 

2. Click the Attributes tab if it is not selected by default. 

3. To search for intent objects, use one of the following combinations for Look For 

and Look By. The items that satisfy the specified rule and criteria are listed 

under items found in the Search Tool:1 dialog box only after you click Find 

Now. 
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Look For  Look By  Items found 

Intent 

Datum 

Plane 

Intent 

Datum 

Plane 

Lists all intent datum 

planes in the model 

Intent 

Datum Axis 

  

Intent 

Datum Axis 

Lists all intent datum axes 

in the model 

Intent 

Datum point 

Intent 

Datum 

point 

Lists all intent datum 

Points in the model 

Intent 

Datum Csys  

Intent 

Datum Csys  

Lists all intent datum csys 

in the model 

Intent Chain 

  

Intent 

Chain 

Lists all the intent chains 

in the model 

Intent Chain 

  

Feature Lists all the intent chains 

that belong to a feature or 

features 

Intent Chain  Edge  Lists all intent chains, that 

contain all the edges  

Intent 

Surface   

Intent 

Surface 

Lists all the intent surfaces 

in the model 

Intent 

Surface  

Feature  Lists all the intent surfaces 

that belong to a feature or 

features 

4. Under Rule, set a rule to search for the intent objects or build a query. 

Note: You can use the Name rule to search for the intent objects, that is, search 

by intent name. The intent name is unique and is used to define the intent object 

and how Pro/ENGINEER features reference the intent object. The intent name is 

not the same as the name of the datum reference feature that defines it. 

5. Under Criteria, specify the criteria to search for the required intent object. 

6. If required, click Options > Build Query to build a query to search for intent 

objects and perform the following steps under Query Builder: 

a. Specify the rule and criteria for a query. 

b. Click Add New, the query appears under Query Builder. 

c. If required, specify the rule and criteria for another query and click 

Add New to build another query. You can build multiple such rules for a 

single search. 
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7. Click Find Now. The items and their corresponding references are listed under 

items found in the Search Tool:1 dialog box. The results are also highlighted 

on the Model Tree and in the graphics window.  

8. If required, click  to transfer items from items found to items selected. 

9. Click Close. 

To Search for Objects Referenced by an Intent Object 

1. Click  or click Edit > Find. The Search Tool:1 dialog box opens. 

2. Click the Attributes tab if it is not selected by default. 

3. To search for the objects referenced by an intent object, use one of the following 

combinations for Look For and Look By. The items that satisfy the specified rule 

and criteria are listed under items found in the Search Tool:1 dialog box only 

after you click Find Now. 

Look For Look By Items found 

Datum  Intent 

Datum 

Lists all the datums referenced by the 

intent datums in the model 

Datum 

plane 

Intent 

Datum Plane 

Lists all the planes referenced by the 

intent datum Planes in the model 

Axis  Intent 

Datum Axis 

Lists all the axes referenced by the intent 

datum axes satisfying the specified rule 

and criteria. 

Point  Intent 

Datum Point 

Lists all the points referenced by the 

intent datum points in the model 

Coordinate 

System 

 Intent 

Datum Csys 

Lists all the coordinate systems 

referenced by the intent datum csys’ in 

the model 

Edge  Intent Chain Lists all the edges in the model referenced 

by intent chains 

Surface Intent 

Surface 

Lists all the surfaces in the model 

referenced by intent surfaces 

Quilt  Intent 

Surface 

Lists all the quilts in the model referenced 

by intent surfaces 

Quilt  Intent Chain Lists all the quilts in the model referenced 

by intent chains 

4. Under Rule, set a rule to search for objects referenced by the intent objects 

or build a query. 
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Note: You can use the Name rule to search for the intent objects, that is, search 

by intent name. The intent name is unique and is used to define the intent object 

and how Pro/ENGINEER features reference the intent object. The intent name is 

not the same as the name of the datum reference feature that defines it. 

5. Under Criteria, specify the criteria to search for the required intent object. 

6. Click Find Now. The items are listed under items found in the Search Tool:1 

dialog box. The results are also highlighted in the graphics window.  

7. If required, click  to transfer items from items found to items selected. 

8. Click Close. 

Annotation Search 

To Search for Annotation Feature by Classification 

You can search for annotation features by their classification which is a feature level 

enumerated parameter. Create the first and second rule to search for annotations by 

classification. 

1. Click Edit > Find. The Search Tool dialog box opens. 

2. Click Attribute. 

3. Select Feature from the Look for list. 

4. In the Rule section, click Type. 

5. Select Annotation Feature from the Value list. 

6. Select the criteria for the annotation element type if necessary. 

7. Click Options > Build Query. The Query Builder dialog box opens. 

8. Click Add New. The query string is added to the Rule Description column. 

To create the second rule: 

1. In the Rule section, click Expression. 

2. Type the parameter name in the Symbol box. 

3. Type the desired classification parameter value in the Value box. 

4. Click Add New. The second rule is added to the Rule Description column. 

5. Click Operator and select and from the operator list. 

6. Click Find Now. The found items and corresponding locations are listed in the 

items found section of the Search Tool dialog box. The results are also 

highlighted in the Model Tree and graphics window.  

7. To select items, click  to transfer items from items found to the items 

selected section of the Search Tool dialog box. 
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8. Click Close. 

Note: If only the second rule is used, then the features found are not limited to 

annotation features. 

To Search for Annotation Elements with Missing References 

1. Click Edit > Find. The Search Tool dialog box opens. 

2. Click Status. 

3. Select Annotation Element in the Look for list. 

4. Select Annotation Element in the Look by list. 

5. In the Rule section, click Regeneration. 

6. Select Missing References in the Value list. 

7. Click Find Now. The found items and corresponding locations are listed in the 

items found section of the Search Tool dialog box. The results are also 

highlighted on the Model Tree and in the graphics window. 

8. To select items, click  to move items from the items found section to 

the items selected section of the Search Tool dialog box. 

9. Click Close. 

Data Sharing Features 

To Search for Data Sharing Features with Annotation Element 

1. Click Edit > Find. The Search Tool dialog box opens. 

2. Click Attribute. 

3. Select Feature from the Look for list. 

4. In the Rule section, click Type. 

5. Select the type of data sharing feature to search for from the Value list. 

6. Click Options > Build Query. The Query Builder dialog box opens. 

7. Click Add New. The query string is added to the Rule Description column. 

To create the second rule: 

1. Click History. 

2. Select Feature from the Look for list. 

3. Select Annotation Elements from the Look by list. 

4. Select All. 

5. Click Add New. The query string is added to the Rule Description column. 
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6. Click Operator and select and from the operator list. 

7. Click Find Now. The found items and corresponding locations are listed in the 

items found section of the Search Tool dialog box. The results are also 

highlighted in the Model Tree and graphics window.  

8. To select items, click  to transfer items from items found to the items 

selected section of the Search Tool dialog box. 

9. Click Close. 

Regenerating the Model 

About Regenerating Models 

When Pro/ENGINEER regenerates a model, it recreates the model feature by feature, 

in the order in which each feature was created, and according to the hierarchy of the 

parent-child relationship between features. In an assembly, component features are 

regenerated in the order in which they were created, and then in the order in which 

each component was added to the assembly. Pro/ENGINEER regenerates a model 

automatically in many cases, including when you open, save, or close a part or 

assembly or one of its instances and when you open an instance from within the 

Family Table. You can also use the Regenerate command to manually regenerate the 

model. 

The Regenerate command, located on the Edit menu or , allows you recalculate 

the model geometry, incorporating any changes made since the last time the model 

was saved. If no changes have been made, the system informs you that the model 

has not changed since the last regeneration. In general, it is a good idea to 

regenerate the model every time you make a change, so that you can see the effects 

of each change in the Graphics window as you build the model. Regenerating often 

helps you stay on course with your original design intent by helping you to resolve 

failures as they happen. 

You can use Regenerate to find bad geometry, broken parent-child relationships, or 

any other problem with a part feature or assembly component. 

When Pro/ENGINEER regenerates a model, the Regeneration status bar appears and 

indicates the status of the regeneration process. The status or regeneration result of 

a model is indicated by the following colors: 

• Green—Model is up to date - no regeneration needed 

• Yellow—Model has changed - regeneration may be needed 

• Red—Regeneration has failed or has warnings. 

About the Regeneration Footer 

The Regeneration Footer is a section of the Model Tree that lists certain types of 

features. You can place certain features in the Regeneration Folder that are always 

created and evaluated at the end of the feature list. In addition, some features are 
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automatically placed in the Regeneration Footer. Placing features in the Regeneration 

Footer helps you to better understand that certain features are always regenerated 

at the end of the list 

The option of placing certain features in the footer allows you to see different 

behavior for the same feature, depending on where it is placed. There are two 

classes of features, Active and Declaration. Only Declaration class features can exist 

in the Regeneration Footer: 

• Active—Features that modify the model geometry or new geometry. These 

features are rolled back during part modification. 

• Declaration—The features that do not affect the model topology and potentially 

are not rolled back. These features reference the final geometry and are 

accessible during any feature operation in the model. 

You can place the following types of Declaration features in the Regeneration Folder: 

• Zones 

• Publish Geometry 

• Annotation Features 

• Datum Reference Features 

• Interfaces 

To Move Features to the Regeneration Footer 

You can move the features that are created by default in the active list (in the Model 

Tree above the Insert Here node) to the Regeneration Footer. These features include 

the Analysis features, Publish Geometry features, Reference feature, Annotation 

features. 

Note: An Interface Feature is created in the footer by default. 

1. Right-click the feature that you want to move. The shortcut menu appears. 

2. Click Move to footer. 

You can move the feature types mentioned above from the active list to the 

Regeneration Footer or from the Regeneration Footer feature list back to the active 

list. 

1. Right-click the feature that you want to move. The shortcut menu appears. 

2. Click Move from footer. 

Note: By default, zones are created in the Regeneration Footer feature list. But, for 

legacy parts that were created in versions before Pro/ENGINEER Wildfire 2.0, you 

must use Move to footer to move the zones to the Regeneration Footer feature list. 

You cannot move zones from the Regeneration Footer feature list to the active list. 
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About Resolving Failures in Regeneration 

There are several reasons why model regeneration can fail, including: 

• Bad geometry in one or more features. 

• A component or feature is missing from the model; that is, Pro/ENGINEER cannot 

find it in the working directory. For assemblies, component part files may have 

been stored in a different directory than that in which the assembly file resides. 

When model regeneration fails, all subsequent features (features to be regenerated 

after the failed feature) remain unregenerated. The current model shows only the 

regenerated features in the Graphics window (the failed feature and all subsequent 

features are not displayed). 

Pro/ENGINEER enters Resolve mode. The Failure Diagnostics window opens and 

provides information about which features have failed and why. The window provides 

helpful links to additional information about the regeneration failure (Overview and 

Feature Info), including general information about resolving failures. 

To Regenerate a Model 

1. Click   or Edit > Regenerate. 

2. Pro/ENGINEER rebuilds your change in the part or assembly model. 

3. If a feature fails regeneration, Pro/ENGINEER enters the Resolve environment. 

To View Model Creation History 

1. Click Tools > Model Player. The Model Player dialog box opens. 

2. Select one of the following options for controlling feature regeneration and 

display: 

Regenerate features 

Display each feature 

3. Using the control buttons or the slider, select the point in the model creation 

history (that is, select the feature) at which you want to begin the regeneration 

process. To select a starting feature from the Graphics window or the Model Tree, 

click . You can also choose Feat # and type a feature number to specify a 

starting feature. Use  and  to choose a starting feature by stepping 

backward or forward through the playback operation one feature at a time. 

The feature you specify becomes the starting feature. The system suppresses all 

features that occur after it. 

4. To stop playback, click Stop. 

5. Click a command at the bottom of the Model Player to get information about the 

current feature (the feature that was currently regenerated when you stopped 
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the model playback process). For a description of each command, click See Also 

below. 

If a feature is one that intersects any other feature on the part, the system displays 

the geometry of the feature in red wireframe before intersection.  

Using the Model Player 

To open the Model Player dialog box, click Tools > Model Player. 

• You can select one of the following commands for controlling feature regeneration 

and display: 

o Regenerate features—Regenerates each feature in sequence, starting 

from the specified feature, as the model moves forward. If this box is 

cleared, features will be rolled forward without regenerating. If you have 

made changes to the model without regenerating, the command is checked 

and unavailable. 

o Display each feature—Displays each feature in the Graphics window as it 

is being regenerated or rolled forward. Future features are not displayed 

until they are regenerated. If this box is cleared, the entire display is 

updated only when the desired feature is reached and the model playback 

is complete, or when you stop model playback. 

o Compute CL—(Available in Manufacturing mode only) When selected, the 

CL data is recalculated for each NC sequence during regeneration. If 

cleared, no CL data is calculated during regeneration. 

• Select one of the following commands to select the place (feature) in the model 

creation history at which to start the regeneration process: 

—Moves immediately to the beginning of the model (suppresses all 

features). Use  to step through the features one at a time. 

—Moves immediately to the end of the model (resume all features). Use 

 to step through the features one at a time. 

—Steps backward through the model one feature at a time and regenerates 

the preceding feature in the model. 

—Steps forward through the model one feature at a time and regenerates 

the next feature in the model. 

Slider Bar—Drags the slider handle to the first feature at which you want model 

playback to begin. The features are highlighted in the Graphics window as you 

move through their position with the slider handle. The feature number and type 

are displayed in the selection panel (such as #16 (CHAMFER)), and the feature 

number is displayed in the Feat # box. When you release the slider, the model 

immediately rolls or regenerates to that feature. 
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—Lets you select a starting feature from the graphics window or the Model 

Tree. Opens the SELECT dialog box and SELECT FEAT menu. After you select a 

starting feature, its number and ID are displayed in the selection panel, and the 

feature number is displayed in the Feat # box. When you select a feature, the 

model immediately rolls or regenerates to that feature. 

Feat #—Lets you specify a starting feature by typing the feature number in the 

box. After you enter the feature number, the model immediately rolls or 

regenerates to that feature. Use  and  to step backward or forward 

through the playback one feature at a time. 

The feature you specify becomes the starting feature, and all features that occur 

after it are suppressed. 

• To stop playback, click the Stop button. 

• You can use the following commands to obtain information about the current 

feature (the feature that was currently regenerated when you stopped the model 

playback process): 

o Show Dims—Displays the dimensions of the current feature. 

o Feat Info—Provides regular feature information about the current feature 

in an Information window. 

o Geom Check—Investigates the geometry error for the current feature. This 

command is accessible only when the system encounters a geometry error. 

o Fix Model—Activates Resolve mode by forcing the current feature to abort 

regeneration. When you exit Resolve mode, Pro/ENGINEER returns to the 

Model Player at the current feature. You can then continue to move 

backward or forward through the model. 

o Close—Closes the Model Player and enters Insert mode at the current 

feature (the last regenerated feature). You can choose this command 

anytime during the model playback. 

o Finish—Closes the Model Player and returns to the last feature in the 

model. Pro/ENGINEER restores all features. You can choose this command 

anytime during model playback. 

If a feature is one that intersects any other feature on the part, the system displays 

the geometry of the feature in red wireframe before intersection. 

Integrating Changes using Pro/INTRALINK 

About Integration 

Integration is a process that lets you merge conflicting changes made by multiple 

users to the same revision of an object fetched from a Pro/INTRALINK product 

database. 
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Integration facilitates concurrent engineering by allowing multiple engineers to 

modify an object simultaneously without fear of overwriting each other’s changes or 

making irreconcilable modifications. Preparation for change integration requires steps 

to be performed in Pro/INTRALINK and Pro/ENGINEER. 

Causes of Revision Conflict 

It may occur that multiple users fetch an object from a Pro/INTRALINK product 

database and make different changes to the object independently of each other. 

When the modified objects are resubmitted to the product database, Pro/INTRALINK 

checks each submitted object for conflicts with objects already present in the product 

database. 

For example, suppose that you and another user fetch the latest revision of a part 

from a product database. You both modify the object, but the other user resubmits 

the object to Pro/INTRALINK and receives approval for the changes before you do. 

The other user’s modified part has become the latest revision in the product 

database. 

When you submit your modified part, you are informed that your changes are not 

based on the latest revision of the part, and that the revision you are attempting to 

create already exists in the product database. To resolve this conflict, you must 

merge the changes in your version, the source, with the latest version in the 

database, the target by using File > Integrate. 

Similarly, conflicts can arise when you submit an object, such as a drawing or 

assembly, which depends upon an object which itself has a conflict. If a drawing uses 

a changed part, requiring you to switch references for the drawing, then the drawing 

also must be included in the list of objects to be integrated. 

Based on information that you have already provided, Pro/ENGINEER determines 

which references in the drawing may be switched automatically, then prompts you to 

map any remaining references manually. 

To Use the INTEGRATE Menu 

1. After you have retrieved the model to be integrated, click File > Integrate. The 

difference report, source object, and target object are displayed. 

2. The MERGE_VIEW and the DIFF_VIEW Windows appear. The DIFF_VIEW Window 

displays the difference report for the object revisions. The INTEGRATE menu 

appears, listing commands for performing the integration: 

o Next—Step to the next item (difference) in the report. 

o Previous—Step to the previous item (difference) in the report. 

o Show—In the active window, highlight the entity (such as a feature or 

component) corresponding to the current item in the difference report. 

(This command is accessible only if the current item belongs to the object 

in the current Pro/ENGINEER Window.) 
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o Info—Bring up the Information window, containing information about the 

current item in the difference report such as the model name, component 

number, internal ID number, part name, and parents and/or children. 

o Action—Bring up the ACTION menu. When you specify an action for one 

occurrence of an item (such as a feature or a component) in the report, the 

specified action is set automatically for that item every time it appears in 

the report. 

o Execute—Perform automatically the actions specified in the ACTION 

column of the difference report to resolve differences between the source 

and target objects. Each item is marked as Merged, Deleted, or Ignored 

according to the action that was specified for it. 

o Save Report—Save the difference report in your local working area as an 

ASCII text file. 

o Merge View—Display the difference report with the items sorted in the 

order in which they have to be integrated to correctly resolve all the 

external references (for example, parents must be merged before children, 

children must be deleted before parents). 

o Diff View—(Default) Display the difference report sorted by object and, 

within object, by item type. This gives a quick indication of where and what 

the differences are. 

o Done/Return—Dismiss the DIFF_VIEW Window and quit the INTEGRATE 

menu. 

Accessing the Integrate Mode to Resolve Conflicts 

To resolve revision conflicts, each mode in Pro/ENGINEER includes the Integrate 

command. 

The Integrate command accesses Integrate mode for retrieving integration project 

files (created in Pro/INTRALINK) generating difference reports. 

The Difference Report 

A difference report, displayed in the DIFF_VIEW Window by default, lists the 

differences between the source object and the target object, including all of their 

modified dependent objects, and serves as the basis of the integration session. 

The MERGE_VIEW Window may be brought up, listing the differences between the 

source object and the target object in the order in which they must be resolved. 

Changes in a simplified representation of an object are shown in a difference report. 

A difference report shows differences for the object in the active window and its 

dependents, if any. For example, if an assembly is the active object, differences in 

the assembly and in its components display in the difference report. 

Using a difference report, you can specify actions that you want Pro/ENGINEER to 

perform automatically on the target object to resolve the differences with the source 

object. This includes merging changes in the source object into the target object, 
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deleting from the target those items that exist only in itself, or intentionally ignoring 

an item. (In other words, take no merge or delete action on it even though a 

difference is noted.) 

A difference report shows the differences for all of the objects included in an 

integration project. You may specify actions only for an object that is modifiable in 

the current mode. For instance, an integration project file for an assembly includes 

the differences of all of its components. 

If the active object is a part that is a member of the assembly, the differences for 

the parent assembly still display in the difference report, but in Part mode, you may 

specify actions only for the part. To specify actions for the parent assembly, you 

must retrieve it into Assembly mode. 

Sample Difference Report Before Specifying Actions shows an example of a 

difference report before commands in the ACTION menu are used to specify how a 

difference must be resolved. 

Example: A Sample Difference Report before Specifying Actions 

 

If you set the info_output_format configuration option to html, the difference 

between features of the selected parts is listed in a report in the Pro/ENGINEER 
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browser window. Alternatively, you can also view the model information in an 

INFORMATION WINDOW, if the info_output_format configuration option is set to 

text. All the differences between the objects is itemized, listing a type of change 

(feature, layer, relation, and so forth), source and target name, item ID, description, 

and space for specifying an action. 

Pro/ENGINEER provides a standard set of descriptions. Note that not all descriptions 

apply to all change categories: 

• New 

• Deleted 

• Different 

• Suppressed 

• Redefined (Attributes, Section, Scheme, and so on) 

• Moved 

Each description is appended, if applicable, with one of the following notations, 

indicating where the change is located: 

• In Target 

• In Source 

The column with the ID indicates the location of the change. If the ID appears in 

both columns, then the modified item exists in both objects. 

Note: Differences in patterns are reported only for the pattern leaders. 

Comparing Family Tables in Assemblies 

When two assemblies are compared so that they can be integrated, their Family 

Tables are compared only if the tables contain the same number of items. In 

addition, their Family Table instances are not compared if any of the following 

conditions exist: 

• Differences are found in the table-driven items (columns) of the Family Tables. 

• The numbers of instances in the Family Tables differ. 

• The names of the instances in the Family Tables differ. 

To Prepare the Objects for Integration 

In Pro/INTRALINK, select the objects that you want to integrate changes for and click 

Object > Integrate > Start in the Workspace browser. 

You are now ready to enter a Pro/ENGINEER session and merge the changes. 

To Integrate Changes in Pro/ENGINEER 

1. Start a Pro/ENGINEER session and retrieve the target object to be integrated. 
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Note: Integration must be started in Pro/INTRALINK Workspace prior to 

beginning the integration process in Pro/ENGINEER. The target object is checked 

out from the Commonspace browser and appears in the Workspace browser. The 

source object is then no longer listed in the Workspace browser. 

2. Click File > Integrate on the main menu for the mode. 

3. The MERGE_VIEW Window appears, displaying the corresponding target or 

source object (whichever is not yet active in the session), and the DIFF_VIEW 

Window appears, displaying the difference report for the object revisions. The 

INTEGRATE menu and the ACTION menu appear. 

4. Specify an action to be taken (Take From Source, To Delete, Do Manual, and 

so on) for items in the difference report. For example, if you choose to merge 

different dimensions for an item, the source dimension value is used in the 

updated target object. If you specify an action for a child item, Pro/ENGINEER 

warns you that parent items are marked with the same action; you can then 

confirm or cancel the assignment. 

5. If a feature needs to be integrated manually from the source object to the target 

object, exit Integrate mode, then use commands in the FEATURE menu (such as 

Delete or Copy) to do so. If you use Copy, specify FromDifVers and 

Independent to indicate how and from where the feature is being copied. 

6. For items that you have integrated manually, use the Merged and Deleted 

commands in the ACTION menu to indicate the updated status of each item. 

7. For items which you marked to be integrated automatically (using Take From 

Source, To Delete, and so on), click the Execute command from the 

INTEGRATE menu. 

8. Upon choosing Execute, all items are updated according to the specified action 

(for example, if you selected To Delete, the corresponding items are marked 

DELETED). If you choose to delete a feature that is new in the target object, this 

feature is removed in the updated target when Execute is chosen. If a merge is 

not possible because of missing external references, or if the merge regeneration 

fails, the standard regeneration failure interface appears. 

If the RegenBackup option in the ENVIRONMENT menu was set, then the 

system first backs up all the targets that would be affected by the Execute 

command before actually processing the command. After the execution has 

completed successfully and provided that you have not already restored all the 

affected objects from within regeneration, you can then confirm or cancel the 

changes. If you cancel them, all objects that have not been restored are restored 

from their backups. All items that are undone also become unmarked, so that 

you can execute them again. 

9. Click Done/Return from the INTEGRATE menu when the integration session is 

finished. Updated versions of target objects are saved automatically. You may 

continue to integrate changes at a later time repeating the process explained 

above. 
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After the integration process is complete and the modified target object is saved, you 

must enter a Pro/INTRALINK session to submit the modified target object back to the 

product database. 

Resolution in Pro/INTRALINK 

Submit the modified target object back to the product database for approval. Upon 

approval, it becomes the latest revision of the object in the Pro/INTRALINK product 

database. 

About Switching References in a Drawing 

If a source object being integrated is displayed in a drawing, any drawing references 

to merged items have to be switched to corresponding references in the target 

model. 

For example, if a hole was added to the source object and the diameter of the hole 

was displayed on a drawing, the dimension on the drawing has to be switched to 

reference the hole which has been merged into the target object. 

Many references can be switched automatically when items are merged between the 

source and target parts or assemblies. In some cases, however, references must be 

switched manually. 

For example, in the case of a hole added to the source object, after the hole is 

merged into the target object, the system must be able to automatically switch the 

diameter dimension shown on a drawing. 

If, however, you redefine the section of a feature in the source object so that it looks 

completely different than that in the target object, the references might not be 

readily compatible, and you must switch them manually. 

To Switch References in a Drawing Manually 

1. Retrieve the drawing that references the source object or objects. 

2. Click File > Integrate. The Open dialog box opens. 

3. Select the integration project file (*.ipf). 

4. Click Open. If the drawing contains more than one model, the DWG SW MDL 

menu appears, enabling you to select a model with which to work: 

o Pick Model—Select a model in the current object. If that model needs to 

be switched, the target for that model is retrieved in a sub-window, and the 

DW MDL MAP menu appears. 

o Next Model—You can step through models in the current object one by 

one. Models that do not need to be switched are automatically skipped. 

o Prev Model—Same as Next Model, but stepping in the opposite direction. 
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o Done—Finish switching references. Pro/ENGINEER warns you if any 

references are left unmapped. If you disregard the warning, any items that 

use the unmapped references are lost. 

o Quit—Abort the process of mapping references. 

If the drawing contains only one model that needs to be switched, that model is 

selected automatically. In either case, the selected target model is retrieved into 

a sub-window. 

5. The DW MDL MAP menu enables you to switch references from the source 

model to the target model. The DW MDL MAP commands are: 

o Next Ref—Step to the next reference that needs to be mapped. 

o Prev Ref—Return to the previous reference. 

o Pick Ref—Pick a reference to map. 

o Unmap Ref—Undo the mapping for a particular reference. 

o Show Und—Display unmapped references. 

o Show Done—Display references which have been mapped. 

o Done—Finish mapping references. Pro/ENGINEER warns you if any 

references are left unmapped. If you disregard the warning, any items that 

use the unmapped references are lost. 

o Quit—Abort the process of switching references. 

6. Click Next Ref. A referenced entity (for example, surface, edge, and dimension) 

highlights on the drawing. Select the corresponding entity on the target model in 

the sub-window. 

7. Continue this process until all references have been switched. 

Reference mappings can be changed by toggling to the correct reference (using Next 

Ref and Prev Ref), choosing Unmap Ref to undo the mapping, and then re-

selecting the target entity. 

Example: Integration Process Conflict  

The procedure that follows is based on revision conflicts produced by two users. The 

integration process can merge changes between only two versions at a time; this 

process may be repeated to integrate the conflicts of multiple users. 

The Revision Conflict 

Imagine that you and another user have retrieved the same revision of a part from a 

Pro/INTRALINK product database and made different modifications to it. The other 

user has already submitted the object back to Pro/INTRALINK and received approval 

for the changes that he or she made, and the modified object is now the latest 

revision in the product database. 
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When you attempt to submit your modified version of the object, Pro/INTRALINK 

informs you that this revision of the object already exists in the product database. 

Pro/INTRALINK provides you with two solutions. 

If your design replaces the previously submitted version, you may continue to submit 

using the Pro/INTRALINK command Override Errors. However, if you want to 

incorporate the changes made in the latest revision in the database, Pro/INTRALINK 

provides you with tools to integrate these models. 

Source and Target Objects 

When you decide to integrate the changes between two revisions of the same object, 

you must use those revisions to prepare two versions of the object, a source object 

and a target object. 

The source object is the revision of the object that contains unapproved changes that 

you want to have incorporated into the target object, which is the latest revision of 

the object in the product database. 

Pro/INTRALINK provides you with a process for creating a renamed version of the 

source object and fetching a copy of the target object, so that you can integrate the 

changes and create a new latest revision of the object without overwriting the 

original source and target objects. 

Annotation Features 

About Annotation Features 

Annotation features are data features that you can use to manage the model 

annotation and propagate model information to other models, or to manufacturing 

processes. 

An Annotation feature consists of one or more Annotation Elements. Each Annotation 

Element can contain one annotation item, along with associated references and 

parameters. You can include the following types of annotations in an Annotation 

Element: 

• Note 

• Symbol 

• Surface finish 

• Geometric tolerance 

• Set Datum Tag 

• Ordinate baseline dimension 

• Driven dimension 

• Ordinate driven dimension 

• Chamfer dimension 



Pro/ENGINEER Fundamentals 

377 

• Reference dimension 

• Ordinate reference dimension 

• Existing annotation 

You can do the following: 

• Include Annotation features in User Defined Features (UDFs). This way, you can 

define a library of company-specific annotations, and then place it in various 

models, as appropriate. 

• Include the necessary manufacturing information in the model annotation, and 

use this information when defining the manufacturing process. 

• Search for annotation options and values, or for Annotation Element parameters, 

and based on the search results, simultaneously modify multiple instances. 

• Propagate Annotation Elements from Annotation features to Data Sharing 

features, with options for dependency. 

• Duplicate annotations by placing User Defined Features, creating reference 

patterns, creating patterns of groups that have annotation features, or copying 

Annotation features. The duplicated annotations do not overlap except for free 

placed annotations. In the duplicated annotations, the relationship between the 

annotation leader attachment point and the annotation placement point is 

maintained and is the same as that of the original annotation. Similarly, in case 

of angle and length dimensions, the relationship between the annotation 

attachment point, that is, the reference point and the dimension text placement 

point is maintained and is the same as that of the original annotation. 

Note: In copy-and-paste operations where alternative attachment references are 

specified, the annotations do not overlap. 

Annotation Feature Basics 

About Annotation Feature Structure 

An Annotation feature consists of a name and one or more Annotation Elements. The 

system provides a default name for each Annotation feature as you create it, such as 

Annotation 1, Annotation 2, and so on. You can specify a different name.  

An Annotation Element is composed of: 

• Name—The system provides a default name for each Annotation Element as you 

create it. The default name includes the annotation type and a sequentially 

incremented number, such as AE_NOTE0. You can specify a different name. 

• Annotation—An Annotation Element may include not more than one annotation, 

such as note, symbol, and so on. The type of annotation determines the 

Annotation Element type. If no annotation is included, then the Annotation 

Element is Non-graphical. 
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• References—If an annotation is included in the Annotation Element, its geometric 

references become the references of the Annotation Element. You can also 

specify additional geometric references. 

• Parameters—You can add parameters to an Annotation Element. All the regular 

types of parameters, such as String, Integer, and so on, are available. You can 

also specify that certain parameters are automatically added to each Annotation 

Element at the time of its creation. 

About Annotation Types 

The following types of annotation can be included in Annotation features: 

• Note 

• Symbol 

• Surface finish 

• Geometric tolerance 

• Set Datum Tag 

• Ordinate baseline dimension 

• Driven dimension 

• Ordinate driven dimension 

• Chamfer dimension 

• Reference dimension 

• Ordinate reference dimension 

• Existing annotation 

The type of annotation defines the type of the Annotation Element. You can also 

create Non-Graphical Annotation Elements, which do not include annotation of any 

type.  

Another item that can be included in an Annotation Element is a Manufacturing 

template. For more information on defining Manufacturing templates and using them 

in Annotation features, see the Process Manager documentation in NC Manufacturing. 

About Annotation Plane 

Annotations that can be included in Annotation features have to reference an 

Annotation plane. The Annotation plane is a plane that defines the orientation of the 

annotation item with respect to the 3D model. The annotation item is not actually 

placed on the Annotation plane, but on an imaginary plane parallel to the Annotation 

plane, and facing in the direction of the front of the Annotation plane. The actual 

location of this imaginary plane with respect to the model is determined by the first 

selected attachment for the annotation. 
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When you reorient the model, the annotation is also reoriented accordingly. As you 

look at the model from different views, various annotations will be viewable (and 

some will not). 

About Annotation Orientation 

An annotation orientation refers to the plane or the parallel plane in which the 

annotation lies, the viewing direction, and the right direction or text rotation. 

An active annotation orientation refers to the annotation orientation that will be used 

for creating the next annotation or annotation element. A current annotation 

orientation refers to the annotation orientation of an annotation or Annotation 

Element that is placed.  

Using the ACTIVE ANNOTATION ORIENTATION or the CURRENT ANNOTATION 

ORIENTATION dialog boxes, you can define an annotation orientation using a 

datum plane, flat surface, or named view. You can also define annotation 

orientations such that they are placed flat to screen and also switch between these 

different types of annotation orientations.  

The ACTIVE ANNOTATION ORIENTATION dialog box opens when you click View 

> Annotation Orientation while the CURRENT ANNOTATION ORIENTATION 

dialog box opens when you right-click an annotation and click Orientation on the 

shortcut menu. 

Note the following points about annotation orientations: 

• Define the active annotation orientation, if required, before creating the first 

annotation in any session. This annotation orientation is retained per session per 

model. Thus, when you define the active annotation orientation and create a new 

annotation or Annotation Element, Pro/ENGINEER retains that annotation 

orientation and uses it to create the next annotation. All subsequently created 

annotations retain the same orientation unless the Annotation plane information 

is changed. This holds true for new Annotation Elements created in new 

Annotation Features as well. 

• The default annotation orientation is a frozen orientation in the Z-direction of the 

default coordinate system. This default annotation orientation corresponds to the 

FRONT datum plane or FRONT orientation in the PTC template for parts. 

However, this default orientation does not reference the FRONT datum or FRONT 

view. In the ACTIVE ANNOTATION ORIENTATION dialog box, the default 

orientation is defined by the view. However, view name is not specified.  

• When redefining an existing annotation, if you change its annotation orientation, 

the changed definition of the annotation orientation is not retained for the next 

created annotation. 

• If you delete or suppress a datum plane or named orientation that defines the 

annotation plane in an annotation, the next annotation orientation is frozen. 

• If an annotation cannot be placed on the current annotation orientation, then 

Pro/ENGINEER displays a message stating that the annotation plane is invalid 

and that a new annotation plane must be defined. 
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• If the last created Annotation Element created a datum plane for its annotation 

plane, thus creating an embedded datum, then the next created Annotation 

Element in the same Annotation Feature uses the same orientation as the 

Annotation Element with the embedded datum plane. If the next created 

Annotation Element is in another Annotation feature, then the Annotation 

Element does not directly reference the embedded datum plane.  

• When you open the ACTIVE ANNOTATION ORIENTATION or CURRENT 

ANNOTATION ORIENTATION dialog box, the current or active annotation 

plane is visible as a grid plane. The active annotation grid plane is displayed in 

green, that is, the Highlight-Edge system color while the annotation orientation of 

an existing annotation is displayed in orange, that is, Secondary Selected system 

color. Both grid planes show viewing direction and text direction. 

Annotation Orientation by Plane 

Annotation Orientation by Named Orientation 

Annotation Orientation by View Screen 

Annotation Plane 

About Annotation Orientation by Plane 

You can define the orientation for annotations by selecting a datum plane or flat 

surface which is parallel to the annotation. The annotation orientation defined by a 

reference plane can be driven by plane or frozen. 

Driven By Plane 

When an annotation orientation is driven by plane, the datum plane or flat surface is 

displayed as a reference of the Annotation Element in the References collector in 

the ANNOTATION FEATURE dialog box. If you delete the reference, Pro/ENGINEER 

replaces the reference with an alternative reference. If an alternative reference is not 

found, then the orientation becomes frozen. Similarly, in a model annotation if the 

reference is deleted, the annotation is not displayed. 

If you change the datum plane or flat surface orientation, the annotation orientation 

changes accordingly. 

Frozen 

When an annotation orientation is frozen, the annotation orientation is stored in the 

annotation and the annotation plane reference is not required. Therefore, even if you 

delete the plane reference, the annotation is not affected. 

Pro/ENGINEER does not display references in the References collector in the 

ANNOTATION FEATURE dialog box for an Annotation Element with a frozen 

annotation orientation. 

You can switch the annotation orientation between the driven-by-plane state and 

frozen state by clicking or clearing the Freeze Annotation Plane reference 

checkbox. However, you can revert the annotation orientation of an annotation to 

the driven-by-plane state only if the annotation plane still exists. 
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It is not necessary to place or copy datum plane of an annotation with frozen 

annotation orientation to UDF or DSF. You can change the annotation orientation of 

the target Annotation Element independent of the source Annotation Element. 

To Define Annotation Orientation by Plane 

1. Click View > Annotation Orientation. The ACTIVE ANNOTATION 

ORIENTATION dialog box opens. 

2. Click Reference Plane and select a datum plane or a flat surface to which you 

want the annotation to be parallel. The active annotation grid plane is displayed 

in light green and shows the default viewing and text directions. The text 

direction is the direction in which you read the text. 

3. Click Flip next to Viewing Direction to flip the viewing direction of the 

annotation.  

4. In the Text Rotation box, type a value for the angle of text rotation or select 

from the list of most recently used values. The direction of the arrow in the 

graphics area is updated accordingly. 

Note: The default rotation angle of the annotation plane is 0. 

5. If required, click Freeze Annotation Plane reference to freeze the annotation 

plane reference. The annotations that use this annotation do not reference the 

datum plane or named view. 

6. Click OK. 

About Annotation Orientation by Named Orientation 

You can define an annotation plane using a named orientation. If you delete the 

named orientation, the annotation orientation remains unchanged.  

Note the following points about an annotation orientation by named orientation. 

• Annotation Elements with a named orientation do not display any reference for 

the annotation plane in the References collector in the ANNOTATION 

FEATURE dialog box.  

• Pro/ENGINEER does not copy a named orientation in the UDF or DSF. The 

Annotation is frozen relative to the UDF geometry.  

• All Annotations oriented by named orientation placed with independent UDFs are 

frozen. You can change the Annotation Element orientation in the target model 

independent of the source Annotation Element. 

• If you create the annotation in a part in an assembly, then you can select only 

the named views of the part for an annotation plane. 

To Define Annotation Orientation by Named Orientation 

1. Click View > Annotation Orientation. The ACTIVE ANNOTATION 

ORIENTATION dialog box opens. 
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2. Click Named orientation and select a named orientation from the list. The 

active annotation grid plane is displayed in green and shows the default viewing 

and text directions. The text direction is the direction in which you read the text. 

3. Click Flip next to Viewing Direction to flip the viewing direction and the text 

direction of the annotation.  

4. In the Text Rotation box, type a value for the angle of text rotation or select 

from the list of most recently used values. 

5. Click OK. 

About Flat-to-screen Annotation Orientation 

You can define an annotation plane that remains flat to the screen for an annotation. 

Pro/ENGINEER places such annotations flat to the screen.  

Note the following points about an annotation orientation flat to the screen. 

• If you place flat-to-screen annotations in the graphics window and these 

annotations are not attached to the model, then the annotations do not spin, 

pan, or zoom with the model. Such annotations remain at a fixed location in the 

graphics window and have the location point placed in a relative screen position 

relative to lower left corner of the screen. 

• If you place flat-to-screen annotations that are attached to a point on an entity of 

the model, and specify the text height in standard screen units by clearing the 

Text height in model units checkbox in the ACTIVE ANNOTATION 

ORIENTATION dialog box, then such annotations pan with the model but do not 

zoom and rotate with the model. 

• If you place flat-to-screen annotations that are attached to a point on an entity of 

the model, and specify the text height in model units by checking the Text 

height in model units checkbox in the ACTIVE ANNOTATION ORIENTATION 

dialog box, then such annotations pan and zoom with the model but cannot 

rotate. 

Model units use the same size definition as the annotations placed in annotation 

planes. You can switch between model units and standard screen units (mm). 

The text height of a flat to screen annotation placed in graphics window is defined 

in standard screen units and the default text height is set to 3.5 mm. 

• You cannot attach flat-to-screen annotations to silhouette edges, or on points 

defined by the intersection of entities or for any other type of attachment which 

is dependent on a projection in a particular view direction. 

Note: Flat to screen annotations are not the same as old style flat to screen notes. 

To Define Flat-to-screen Annotation Orientation 

1. Click View > Annotation Orientation. The ACTIVE ANNOTATION 

ORIENTATION dialog box opens. 
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2. Click Flat to screen to define an annotation plane that remains flat to the 

screen. 

3. Click Screen Location to select a point in the graphics window but unattached to 

the model when defining the placement of the annotation. 

Note: Flat-to-screen annotations placed in graphics window but unattached to 

the model, do not spin, pan, or zoom with the model.  

Alternatively, click Geometry Location to use a point on the model to define 

placement of annotation. On clicking Geometry Location, the Text height in 

model units checkbox becomes available for selection. 

4. Select Text height in model units checkbox to specify text height in model 

units. To specify the text height in screen units clear the checkbox.  

Note: Flat-to-screen annotations with height specified in screen units, only spin 

and zoom with the model. However, flat-to-screen annotations with height 

specified in model units, only zoom and pan with the model. 

5. Click OK. 

About Reference Types 

Annotation Element references include all the geometric references of its annotation 

item. For example, if an Annotation Element includes a note, and the note is 

attached to two edges, then these edges and the note's Annotation plane are 

automatically included in the References list of the Annotation Element.  

Optionally, you can explicitly select additional Annotation Element references of the 

following types: 

• Datum points and geometry vertices 

• Datum curves, geometry edges, and surface edges 

• Solid or quilt surfaces 

• Datum axes 

• Coordinate systems 

• Datum planes 

• Intent objects 

• Components (only available for Annotation features within an assembly) 

• Sub-assemblies (only available for Annotation features within an assembly) 

• Entities on layers (combinations of any of the entity types above, but not rules) 

• Entities through selection, for entities such as chains of edges or sets of surfaces. 

These references can be Weak or Strong. A loss of Strong reference causes the 

failure of the Annotation feature. A loss of a Weak reference does not cause the 

failure of the Annotation feature, but it may make the annotation inactive. 
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By default, all the additional Annotation Element references that you select are 

Weak. You can change a reference to Strong by selecting the checkbox in the 

Strong column next to the reference name in the appropriate reference collector in 

the ANNOTATION FEATURE dialog box. 

You can remove a previously selected reference by right-clicking its name in the 

collector and selecting Remove on the shortcut menu. 

You cannot remove the automatically populated references directly from the 

References collector. To change these references, redefine the properties of the 

annotation item. You can, however, change the status of these references (Strong or 

Weak) by selecting or clearing the checkbox next to the reference name in the 

References collector. 

Strong and Weak References 

The Annotation Element references can be Strong or Weak: 

• Strong references are checked during regeneration of the Annotation feature. If a 

Strong reference is lost, the Annotation feature fails regeneration. 

• Weak references are checked at the end of the model regeneration. If a Weak 

reference is lost, the Annotation feature does not fail regeneration. If the missing 

Weak reference is used by an annotation leader, the leader is lost (not 

displayed). If the last remaining leader is lost, the annotation becomes inactive. 

Inactive annotation is not displayed. 

For example, if an Annotation Element includes a note, and the note is attached 

to two edges, then the two edges are Weak references. If one of the edges is not 

found at the end of regeneration (for example, if was chamfered somewhere later 

in the regeneration sequence), the leader that used to be attached to this edge is 

not displayed. The note has only one leader, attached to the second edge. 

However, if the second edge is also lost, the note would lose its last remaining 

leader and become inactive. 

When the references are automatically populated from an annotation item, they are 

designated Strong or Weak according to the following rules: 

• Annotation plane is a Strong reference. 

• Leader attachments are Weak references. 

• The reference entity of a Geometric tolerance (the entity to which the GTOL 

applies) is a Strong reference. 

• In Driven and Reference dimensions, all their references are Strong, because 

without these references, the dimension cannot exist.  

By default, all the additional Annotation Element references that you select are 

Weak. You can change a reference to Strong by selecting the checkbox in the 

Strong column next to the reference name in the appropriate reference collector in 

the ANNOTATION FEATURE dialog box. 

Creating Annotation Features 
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About Creating Annotation Features 

You can create Annotation features at any time by clicking the  icon. When you 

create Annotation Elements, you can either select existing annotation, or create 

annotation on the fly. As you select the Annotation Element type, the system invokes 

the regular user interface for creating this specific annotation type (a note, a symbol, 

and so on). Once the annotation is successfully created, you can specify parameters 

or select additional references for the Annotation Element.  

To Create an Annotation Feature 

This topic describes the general procedure of creating an Annotation feature.  

1. Define the active annotation orientation before creating the first annotation in 

any session using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation.  

Note: If you skip step 1, then Pro/ENGINEER uses the default active annotation 

orientation. However, if you have previously created annotations then 

Pro/ENGINEER uses the same annotation orientation as the previously created 

annotation. 

2. Click  on the Annotation toolbar (by default, located on the right side of the 

Pro/ENGINEER window). The ANNOTATION FEATURE and Add Annotation 

dialog boxes open simultaneously. The Add Annotation dialog box opens with 

Note or the last created annotation in the current session selected by default. 

3. Select one of the following annotation types: 

o Note—Create a note to include in the Annotation Element. 

o Symbol—Create a symbol to include in the Annotation Element. 

o Surface Finish—Create a surface finish to include in the Annotation 

Element. 

o Geometric Tolerance—Create a geometric tolerance to include in the 

Annotation Element. 

o Set Datum Tag—Create a set datum tag to include in the Annotation 

Element. 

o Ord Baseline—Create an ordinate baseline dimension. 

o Driven Dimension—Create a driven dimension with tolerance to include in 

the Annotation Element. 

o Ord Driven Dimension—Create one or more ordinate driven dimensions 

to include in the Annotation Element. 

o Chamfer Dimension—Create a 45 degree chamfer dimension to include in 

the Annotation Element. 
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o Reference Dimension—Create a reference dimension to include in the 

Annotation Element. 

o Ord Reference Dimension—Create one or more ordinate reference 

dimensions to include in the Annotation Element. 

o Manufacturing Template—Select a previously saved manufacturing 

template to include in the Annotation Element. For more information, refer 

to documentation on NC Manufacturing.  

o Non-Graphical—The Annotation Element does not contain an annotation. 

o Existing Annotation—Select an existing annotation item (such as a note, 

symbol, and so on) to include in the Annotation Element. You can also 

select an existing Annotation Element to include a copy of its annotation 

item in the current Annotation Element. 

4. Click OK or middle-click. Pro/ENGINEER invokes the user interface for creating or 

selecting the annotation item. For more information on creating an annotation of 

a particular type, follow the See Also links.  

Note:  

o If you want to change the active annotation orientation for the annotation 

you are about to create then click View > Annotation Orientation or click 

Active Orientation on the shortcut menu that opens when you right-click 

in the user interface for creating the annotation item. 

o After you place the annotation you can change the current annotation 

orientation by clicking Current Orientation on the shortcut menu that 

opens when you right-click in the user interface for creating the annotation 

item.  

Once you create or select the annotation item, Pro/ENGINEER creates the 

Annotation Element, adds its name, type, orientation, and copy flag to the 

elements list in the ANNOTATION FEATURE dialog box, and adds the 

references, along with the reference type and default reference description, to 

the References collector.  

5. Click Parameters to specify the Annotation Element parameters. 

6. You can click Edit to edit the definition of the annotation item included in the 

selected Annotation Element, or click Remove to delete the selected Annotation 

Element from the Annotation feature. 

7. You can click Columns to customize the columns in the Annotation Elements list 

and the References list. In the Annotation Columns dialog box that opens 

when you click Columns, select the list that you want to customize from the 

Type list and move the names of the columns that you want to view in the list to 

the Displayed box. You can also specify the width of the column. 

8. You can change the orientation of the annotation by clicking Current 

Orientation on the shortcut menu that appears when you right-click the 

annotation in the Annotation Elements list.   
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Note: The Current Orientation command is not available for non-graphical 

Annotation Elements. 

9. To add additional references to the Annotation Element, click References and 

then click Annotation References, Surface Collector, or Chain Collector to 

activate the respective collector (References, Chains or Surfaces) and select 

the valid entities for the specified collector. 

10. In the Strong column, if the check box next to the reference name is not 

selected, then the reference type is Weak. If you want to change the reference 

type to Strong, select the check box. 

Note: If you have selected datum points as references, then a check box in the 

Auto-Propag column is also available for the datum points in the References 

collector. Select the check box to enable automatic propagation of datum points. 

If you propagate the Annotation Element to data sharing features, then those 

datum point references for which you have selected the check box in the Auto-

Propag column are also automatically propagated. 

11. In the Reference Description column, if you want to edit the default 

description of the reference or add a new description, select the description 

corresponding to the reference name and type the new description. 

Note: The description should not exceed 32 characters. 

12. You can replace an annotation reference by clicking Replace on the shortcut 

menu that appears when you right-click the annotation reference in the 

References list and selecting a new reference entity of a similar type. 

Note: You cannot replace references that are added after the annotation is 

created. However, you can remove the unwanted references and add new 

references. 

13. To add more Annotation Elements to the Annotation feature, click Add in the 

ANNOTATION FEATURE dialog box and repeat Steps 3 through 11. 

14. Click OK or click middle-mouse button to close the ANNOTATION FEATURE 

dialog box and create the Annotation feature. 

style="x-condition: include_for_toyota;"> 

Using the ANNOTATION FEATURE Dialog Box 

The ANNOTATION FEATURE dialog box contains two tabs, Definition and 

Properties. 

The top portion of the Definition tabbed page contains Active Annotation 

Orientation box and Edit Orientation button and the elements list.  

The Active Annotation Orientation box displays the active annotation orientation. 

The Edit Orientation button allows you to change the annotation orientation to be 

used for creating the next Annotation Element. 

For each Annotation Element included in the Annotation feature, the elements list 

lists: 
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• Element Name—The name of the Annotation Element. When you create the 

element, Pro/ENGINEER gives it a default name, such as AE NOTE0. You can type 

a different name. The name has to be unique within the model. 

• Type—The type of the Annotation Element, such as Note, Symbol, and so on. 

• Backup Refs—The attribute that defines whether the backup references of the 

Annotation Element are to be created. This column is visible only if you set the 

af_copy_references_flag configuration option to yes. 

When you select a name of an Annotation Element in the elements list, it becomes 

active. You can manipulate its references, specify its parameters, edit the annotation 

item included in it, or remove it from the Annotation feature. 

If you right-click on an Annotation Element name in the elements list, the shortcut 

menu contains the following commands: 

• Edit—Redefines the properties of the annotation in the selected Annotation 

Element. Similar to the Edit command described below. 

• Repeat—Creates a new Annotation Element of the same type and the 

corresponding UI of the selected Annotation Element type appears. 

• Duplicate—Creates a new Annotation Element that is an exact copy of the 

selected Annotation Element. 

• Parameters—Specifies the parameters of the selected Annotation Element. 

Similar to the Parameters command described below, but here you can select 

multiple elements. In this case, only parameters that are common to all the 

selected elements appear in the Parameters dialog box. If you add parameters, 

they are added to all selected elements. 

• Current Orientation—Opens the CURRENT ANNOTATION ORIENTATION 

dialog box and allows you to redefine the current annotation orientation for the 

Annotation Element.  

Note: The Current Orientation command is not available for non-graphical 

Annotation Elements. 

• Text Style—Modifies the text style of the underlying annotation. This command 

is not available for non-graphical elements. 

• Remove—Removes the selected element or elements from the Annotation 

feature. Deleting an Annotation Element also deletes the underlying annotation. 

If you want to delete the Annotation Element but keep the annotation, you have 

to first make the element non-graphical, to disassociate the underlying 

annotation. 

• Make Non-Graphical—Change the type of Annotation Element to Non-Graphical 

and make the underlying annotation independent. 

Below the elements list is the References collector. It contains the names of the 

geometric references and the reference description associated with the active 

Annotation Element. The checkbox next to each reference name indicates whether 

the reference is Strong or Weak. 
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The Definition tabbed page also contains the following buttons: 

• Add—Adds an Annotation Element to the Annotation feature. Once you add a 

new Annotation Element, it becomes active. 

• Edit—Invokes the user interface that lets you redefine the properties of the 

annotation item included in the active Annotation Element. For example, if the 

Annotation Element type is Note, clicking the Edit button opens the Note dialog 

box, which lets you edit the note text, modify its placement, attachment, or 

location, add a hyperlink, and so on. If the Annotation Element type is Non-

Graphical, clicking the Edit button opens the Edit Annotation dialog box, which 

contains the same options as the Add Annotation dialog box and lets you 

change the annotation type. 

• Parameters—Lets you specify parameters of the active Annotation Element. 

Clicking this button opens the Parameters dialog box, which lists all the 

parameters currently associated with the Annotation Element, and lets you create 

additional parameters and manipulate existing ones. 

• Remove—Removes the active Annotation Element from the Annotation feature. 

• Columns—Invokes the Annotation Columns dialog box that allows you to 

select the columns of the Annotation Element list and the References list to be 

displayed. You can select the list that you want to customize from the Type list 

and move the names of the columns that you want to view in the list to the 

Displayed box. You can also specify the width of the displayed columns. 

• References—Displays a list of Annotation Element references collectors. Click 

Annotation References, Surface Collector, and Chain Collector to expand or 

hide the respective collector. These collectors let you select additional references 

of the appropriate type to be associated with the active Annotation Element. Each 

of these references can also be designated as Strong or Weak.  

o Clicking the Details button next to the Chains collector opens the Chain 

dialog box, which provides you with a variety of tools for defining chains of 

edges or curves. 

o Clicking the Details button next to the Surfaces collector opens the 

Surface Sets dialog box, which provides you with a variety of tools for 

defining surface sets. 

When references need to be addressed Pro/ENGINEER displays the collector 

names in red.  

If you right-click in any of the collectors, the shortcut menu contains the following 

commands: 

• Single References Collector—Activates the References collector, which lets 

you select single geometric references of any type. 

• Curve Collector—Activates the Chains collector, which lets you select chains of 

edges or curves.  

• Surface Collector—Activates the Surfaces collector, which lets you select sets 

of surfaces. 
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The Properties tabbed page contains the feature name and an icon to access 

feature information. 

At the bottom of the ANNOTATION FEATURE dialog box, there are two buttons: 

• OK—Create the Annotation feature, or accept its new definition, and close the 

dialog box. 

• Cancel—Cancel creation or redefinition of the Annotation feature and close the 

dialog box. 

Manipulating the References of an Annotation Element 

The ANNOTATION FEATURE dialog box contains three collectors for the geometric 

references associated with the active Annotation Element: 

• The References collector is automatically populated by the geometric references 

of the annotation item included in the Annotation Element, such as the 

Annotation plane, attachment edges, and so on. These references are grayed out. 

To change these references, redefine the properties of the annotation item. You 

can select additional references, such as datum points, coordinate systems, 

edges, surfaces, and so on. 

• The Chains collector lets you select additional curves and edges to be associated 

with the active Annotation Element. The Details button next to the Chains 

collector opens the Chain dialog box, which provides you with a variety of tools 

for defining chains of edges or curves. 

• The Surfaces collector lets you select additional surfaces to be associated with 

the active Annotation Element. The Details button next to the Surfaces collector 

opens the Surface Sets dialog box, which provides you with a variety of tools for 

defining surface sets. 

You can perform the following operations on the references: 

• To select additional references, click the appropriate collector to activate it, then 

select the geometric entities on the screen, following the usual rules of selection 

and collection. Pro/ENGINEER lists the name of each reference in the collector. 

• To change the orientation of the annotation, click Current Orientation on the 

shortcut menu that appears when you right-click the annotation in the Annotation 

Elements list.  

Note: The Current Orientation command is not available for non-graphical 

Annotation Elements. 

• To edit the default description of the reference or add a new description, in the 

Reference Description column, select the description corresponding to the 

reference name and type the new description. The description has a limit of 32 

characters. 

• To remove a reference, right-click its name in the collector, then click Remove 

on the shortcut menu. You can not remove references that were automatically 

included in the References collector. 



Pro/ENGINEER Fundamentals 

391 

• To replace an annotation reference, right-click its name in the References 

collector, and click Replace on the shortcut menu, and select a new reference 

entity of a similar type. 

Note: You cannot replace references that are added after the annotation is 

created. However, you can remove the unwanted references and add new 

references. 

• The checkbox next to each reference name indicates whether the reference is 

Strong or Weak. By default, all references are added as Weak. To change a 

reference type to Strong, select the checkbox next to the reference name. 

• To enable automatic propagation of datum points that you have selected as 

references, select the checkbox in the Auto-Propag column. If you propagate 

the Annotation Element to data sharing features, then those datum point 

references are also automatically propagated for which you have selected the 

checkbox in the Auto-Propag column. 

Creating Backup References of an Annotation Element 

The Backup Refs checkbox next to the Annotation Element name defines whether 

the backup references of the Annotation Element are to be created within the 

Annotation Element.  

Note: The Backup Refs column is visible in the ANNOTATION FEATURE dialog 

box only if you set the af_copy_references_flag configuration option to yes. Once 

you created an Annotation feature with this column visible, redefinition will show the 

Backup Refs column even if the configuration option is set to no. 

Creating the backup references of an Annotation Element ensures that the reference 

does not change during regeneration of consecutive features.  

In the following example, an Annotation Element of type Note is created and 

attached to a middle point of the front surface of the part. 

 

Later, a cut is created. The cut trims the front surface. If the Annotation Element was 

created without the backup references, the note attachment is recalculated and 

updated to reference the middle point of the new surface. 
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If, at the time of creating or redefining the Annotation Element, the Backup Refs 

checkbox is selected, the system creates an invisible backup surface, and both the 

Annotation Element and the note reference this backup surface instead of the new 

surface. In this case, the note attachment is not displaced. 

 

Note: The Backup Refs attribute status is not passed to Data Sharing Features. 

Example: Creating an Annotation Feature 

This example describes creating an Annotation feature with one Annotation Element 

of type Note in the model shown in the following illustration. 
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1. Define the datum plane named FRONT as an Annotation plane using the ACTIVE 

ANNOTATION ORIENTATION dialog box that opens when you click View > 

Annotation Orientation.  

2. Click  on the Annotation toolbar. The ANNOTATION FEATURE dialog box 

and Add Annotation dialog box open simultaneously. 

3. If the Add Annotation dialog box opens with Note selected by default then click 

middle-mouse button. If Note is not selected by default, select Note and click 

OK. The Note dialog box opens. 

4. In the Text box, type DRILL 2 THRU HOLES .50 DIA. 

5. Click the Place button in the Placement box. 

6. On the NOTE TYPES menu, click With Leader, Standard, and Done. 

7. Select edges of both holes as attachment points, as shown in the next 

illustration, then click Done on the ATTACH TYPE menu. 
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8. Click on the screen to select where the note should be placed. The system 

places the note, as shown in the following illustration. 

 

9. Click OK to return to the ANNOTATION FEATURE dialog box. The system 

creates the Annotation Element with the FRONT datum plane as a Strong 

reference and two edges of the holes as Weak references. 

10. Click OK to create the Annotation feature. 
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About Set Datum Tag Annotations in Annotation Elements 

You can create a set datum tag as an annotation placed on an annotation plane, and 

referencing a datum feature or a surface associated with a datum feature. The set 

datum tag Annotation Elements appear with the datum name in a box that is 

attached to a solid triangle. Set datum tag Annotation Elements are displayed in the 

Model Tree in the Annotation Feature as AE_SET_DATUM_TAG_<Datum_Name> while the 

set datum tag annotations are displayed as Datum_Tag_<Datum_Name>. Note the 

following points about set datum tag Annotation Elements. 

• When creating a set datum tag Annotation Element, you can reference an 

existing datum plane or datum axis. Alternatively, you can reference a planar 

surface, cylindrical surface, circular edge or curve. When you reference a planar 

surface, cylindrical surface, circular edge or curve, a datum feature is created. 

For example, if you reference a planar surface then a datum plane is created and 

if you reference a cylindrical surface, curve, or edge, then a datum axis is 

created. This datum feature that is created is used as a reference for a set datum 

tag Annotation Element. After the set datum tag Annotation Element is created, 

the relationship between the set datum tag Annotation Element and the reference 

datum feature is a parent-child relationship. 

• You can place set datum tag Annotation Elements on a datum, or attach to a 

dimension or GTOL and on geometry. You can place a set datum tag on 

geometry, such as, on a coincident surface, edge or curve, coplanar surfaces with 

set datum planes, and cylindrical surfaces with a set datum axis. 

• You can include the set datum tag annotation elements in a User Defined Feature 

(UDF), only if the UDF contains the reference datum feature, and also the 

geometry references, if any, of the set datum tag Annotation Elements. 

• Similarly, you can propagate set datum tag Annotation Elements to a Data 

Sharing Feature, only if the Data Sharing Feature contains the references of the 

set datum tag annotation element. You cannot propagate set datum tag 

annotation elements in the same model. 

To Create a Set Datum Tag Annotation Element 

1. Define the active annotation orientation before creating the first annotation in 

any session using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click  on the Annotation toolbar that is located on the right side of the 

Pro/ENGINEER window, by default. The ANNOTATION FEATURE dialog box and 

the Add Annotation dialog box open simultaneously. The Add Annotation 

dialog box opens with Note or the last created annotation in the current session 

selected by default. 

3. Click Set Datum Tag. Click OK. The Set Datum Tag dialog box opens. By 

default, Datum appears selected under Reference. 

4. To specify a reference for the set datum tag, under Reference click one of the 

following. 
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Datum—Click Datum to specify a datum plane or axis as the reference and then 

select a datum plane or axis from the model. Pro/ENGINEER uses the selected 

datum plane to create a set datum tag Annotation Element. 

o The name for the selected datum plane or axis is displayed in the Name 

box. 

o The On Datum option under Placement is selected by default. 

Geometry—Click Geometry to specify a geometry item as the reference and 

then select a planar surface, cylindrical surface, circular edge, or circular datum 

curve from the model appropriately. As soon as the entity is selected,  

o Depending upon the type of the selected geometry, a new datum plane or 

datum axis is automatically created. The datum feature is embedded inside 

the Annotation Feature on the Model Tree. Pro/ENGINEER uses this datum 

feature to create a Set Datum Tag Annotation Element. 

o The Name box displays the name of the datum feature.  

o The On Geometry option under Placement is selected by default. 

5. If required, type a new name in the Name box. This name must not be an 

existing one. 

6. To specify the placement type, under Placement click one of the following. 

o On Datum—Click to place the set datum tag on the selected datum or the 

automatically created datum. 

o In Dim—Click to place the set datum tag attached to the dimension.  

o In Gtol—Click to place the set datum tag attached to the GTOL.  

o On Geometry—Click to place the set datum tag on a geometry. 

Note: Select a location on a geometry which is coplanar with the datum plane, or 

coaxial with the datum axis. The set datum tag is placed on the geometry at the 

selected location. 

7. Depending on the type of placement that you selected, perform the following to 

place the set datum tag. 

o For On Datum, the set datum tag is placed on the datum. 

o For In Dim, select a dimension in the graphics window. The set datum tag 

is placed in the dimension.  

o For In Gtol, select a GTOL in the graphics window. The set datum tag is 

placed on the GTOL. 

o For On Geometry, select a location on a geometry which is coplanar with 

the datum plane, or coaxial with the datum axis. The set datum tag is 

placed on the geometry at the selected location. 

8. If required, specify a new location for the set datum tag annotation. 
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o To specify a new location on the datum axis click Pick on Datum. Select a 

point on the axis. The set datum tag is placed at the selected point. 

Note: Pick on Datum is not available if you are creating a set datum tag 

Annotation Element for a datum plane. 

o Similarly, to specify a new location for the set datum tag annotation on the 

geometry use Pick Geom. 

o To specify a new dimension or GTOL use Pick Dim or Pick Gtol, 

respectively. 

9. Click OK in the Set Datum Tag dialog box. The set datum tag is added to the 

ANNOTATION FEATURE dialog box. 

Note:  

• After you have created the set datum tag annotation, you can change the 

direction of the solid triangle by clicking Flip on the shortcut menu that appears 

when you right-click the set datum tag annotation element on the Model Tree or 

in the ANNOTATION FEATURE dialog box. Flipping does not affect the text 

rotation. 

• If you remove the set datum tag Annotation Element using the ANNOTATION 

FEATURE dialog box, then the old datum feature continues to exist in the model. 

The old feature displays the datum name in a box that is attached to the datum 

feature. 

About Editing a Set Datum Tag Annotation Element 

When editing the properties of the set datum tag Annotation Element, the Set 

Datum Tag dialog box that opens does not contain the References area. Therefore, 

you cannot change the reference of the set datum tag annotation when editing the 

properties of the set datum tag annotation element. You can change the placement 

type and specify a new location for the set datum tag annotation. 

Note: When editing the set datum tag in the Drawing mode, you can change the 

placement type to In Dim or In Gtol. 

You can redefine the reference datum feature to a new placement reference by right-

clicking the datum feature on the Model Tree and clicking Edit Definition on the 

shortcut menu. On redefining the reference datum feature to a new placement 

reference, the set datum tag Annotation Element fails regeneration. To regenerate 

the set datum tag Annotation Element, redefine the attachment reference of the set 

datum tag appropriately. 

Placement Behavior of Set Datum Tag Annotations 

The following points describe the behavior of the set datum tag annotations when 

you place them on a datum plane or datum axis using the placement options in the 

Set Datum Tag dialog box. 

• If you place an annotation using On Datum, then the set datum tag annotation 

appears attached to the datum. If you create a set datum tag annotation for a 
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datum plane, then the location of the set datum tag annotation on the plane is 

fixed. However, you can specify its viewing direction and Right direction using its 

Annotation plane. If you create a set datum tag Annotation for a datum axis, 

then you can redefine the location of the set datum tag annotation along the axis 

using Pick on Datum. The Annotation plane should be parallel to the axis that 

the set datum tag references. 

• If you place an annotation using In Dim, then the set datum tag annotation is 

placed on the selected dimension. If the dimension is a driving dimension, then 

the set datum tag annotation is visible only when that dimension is displayed. If 

the dimension is a driven dimension, then the set datum tag uses the annotation 

plane of the driven dimension. 

• If you place an annotation using In Gtol, then the set datum tag uses the 

annotation plane of the GTOL to which the set datum tag annotation is attached. 

• If you place an annotation using On Geometry, then you can place a set datum 

tag annotation created for a datum plane only on a coplanar surface and a set 

datum tag annotation created for an axis only on a cylindrical surface that is 

coaxial with the datum axis referenced by set datum tag. 

The solid triangle attached to a set datum tag annotation that is placed on a 

surface is normal to the surface regardless of the direction of text.  

You can also place a set datum tag annotation created for an axis on a circular 

edge or curve if the selected annotation plane contains the selected reference. 

The set datum tag annotation is normal to the selected edge or curve and the 

solid triangle appears attached to the edge or curve. 

About Ordinate Baselines 

Ordinate baseline annotation elements are reference baselines that you can use to 

create ordinate dimensions. All dimensions that reference the same baseline must 

share a common plane. You can use an existing ordinate baseline Annotation 

Element or create a new one to create ordinate dimension Annotation Elements. 

Baseline Annotation Elements are created inside an Annotation feature and reference 

model geometry or datums. You cannot make ordinate baseline Annotation Elements 

nongraphical as they do not have an equivalent 3D model annotation. 

To Create an Ordinate Baseline 

1. Define the active annotation orientation before creating the first annotation in 

any session using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click  on the Annotation toolbar located to the right of the Pro/ENGINEER 

window, by default. The ANNOTATION FEATURE and Add Annotation dialog 

boxes open simultaneously. The Add Annotation dialog box opens with Note or 

the last created annotation in the current session selected by default. 
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3. Click Ord Baseline. The ATTACH TYPE menu appears enabling you to select an 

entity or a surface as a baseline reference. 

4. Click On Entity or On Surface and select an edge or surface. Select an 

attachment point and middle-click to select the dimension text placement point. 

If Pro/ENGINEER cannot determine the direction of the witness line of the 

ordinate baseline, Pro/ENGINEER prompts you to select an additional reference to 

define the direction of the witness line of ordinate baseline Annotation Element. 

The ordinate baseline Annotation Element is added to the ANNOTATION 

FEATURE dialog box. 

Working with Annotation Features 

About Working with Annotation Features 

Annotation features do not create any geometry, therefore, you can not select them 

on the screen, like other features. The only way to select the Annotation features is 

from the Model Tree. Therefore, it is very important that the Annotation features are 

displayed in the Model Tree. 

In Part mode, the Annotation features are listed in the Model Tree by default, like 

any other type of features. In Assembly mode, they are not listed by default. Use the 

configuration option mdl_tree_cfg_file, or follow the procedure for displaying 

annotation in the Model Tree. 

When you work with Annotation features, it is helpful to display the Annotation 

Elements and individual annotation in the Model tree as well. When you display 

annotation in the Model Tree: 

• You can expand an Annotation feature name, to see all the Annotation Elements 

listed underneath. This makes it easy to see the structure of an Annotation 

feature, and to modify the Annotation Elements. 

• All the independent annotation items (such as symbols, reference dimensions, 

and so on), that are not included in Annotation features, are listed at the top of 

the tree, immediately below the part or assembly name. Notes are listed below 

its parent (assembly, part, or feature). This makes it easy to see which 

annotation items are independent. Once an annotation item is included in an 

Annotation feature, it is consumed by the Annotation Element and is not listed 

separately in the Model Tree. 

Once you set up the proper display of Annotation features in the Model Tree, you can 

work with them like with other Pro/ENGINEER features: edit definition or references, 

suppress, resume, delete, and so on. The topics in this section are discussing the 

specific aspects of working with Annotation features. 

style="x-condition: include_for_toyota;">  

To Display Annotation in the Model Tree 

In Part mode, the Annotation features are listed in the Model Tree by default, like 

any other type of features. In Assembly mode, they are not listed by default. The 
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Annotation Elements and individual annotation items are not listed by default in 

either mode. Displaying annotation in the model tree helps working with Annotation 

features. 

To display annotation in the Model Tree: 

1. In the Model Tree, click Settings > Tree Filters. The Model Tree Items dialog 

box opens. 

2. Under Display, select Annotations. This option controls the display of 

Annotation Elements and individual annotation items.  

3. If the Features checkbox is empty, select it. This option controls the display of 

all features, including Annotation features. 

4. Click OK. 

To Display Annotations in the Graphics Window 

You can hide or display the standalone annotations and annotations in Annotation 

Elements in the graphics window in 3D models using any of the following methods: 

• Click  on the datum display toolbar. 

• Click 3D Annotations in the Datum Display dialog box that opens when you 

click View > Display Settings > Datum Display.  

• Set the configuration option display_annotations.  

To Select an Annotation Feature 

Because Annotation features are only visible in the Model Tree, you can only select 

them in the Model Tree.  

When you select an Annotation feature, the following occurs: 

• All the annotations included in the Annotation Elements of the selected 

Annotation feature are highlighted in the graphics area.  

• All the geometric references of all the Annotation Elements of the selected 

Annotation feature are highlighted in the graphics area.  

Once you have selected an Annotation feature, you can rename, reorder, hide, 

suppress, or delete it, as well as edit its definition or references. 

To Redefine an Annotation Feature 

Editing the definition of an Annotation feature lets you add, remove, or redefine its 

Annotation Elements. 

To redefine an Annotation feature: 

1. Select the Annotation feature in the Model Tree. 

2. Click Edit > Definition, or right-click on the feature name and select Edit 

Definition from the shortcut menu.  
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3. Use the ANNOTATION FEATURE dialog box to add or remove the Annotation 

Elements, or edit their properties or parameters. 

4. Click OK when finished. 

To Edit References of an Annotation Feature 

Editing references of an Annotation feature lets you specify alternate references for 

its Annotation Elements.  

To edit references of an Annotation feature: 

1. Select the Annotation feature in the Model Tree. 

2. Click Edit > References, or right-click on the feature name and select Edit 

References from the shortcut menu.  

3. The system prompts whether you want to roll back the model, that is, 

temporarily suppress all the features after the Annotation feature being 

redefined. Click Yes or No. 

4. Use the following commands: 

o Reroute Feat—The system highlights each reference in turn. Select a 

geometric entity of the appropriate type to replace it or click Same Ref to 

keep the existing reference.  

o Replace Ref—Select a geometric entity, such as a surface or an edge, then 

select another entity of the same type to replace it. Click Sel Feat and 

select the Annotation feature in the Model Tree to replace, for all the 

elements of the Annotation feature, all the references to the first entity by 

the second entity, or click All Children to replace these references in all 

the features. 

5. Click Done/Return when finished. 

To Replace References of an Annotation Feature 

1. Select the Annotation Feature in the Model Tree. 

2. Click Edit > Definition or right-click the feature name and click Edit Definition 

on the shortcut menu. The Annotation Feature dialog box opens. 

3. Select the annotation reference that you want to replace from the References 

list, right-click, and click Replace on the shortcut menu. 

Note: You cannot replace references that are added after the annotation is 

created. However, you can remove the unwanted references and add new 

references. 

4. Select a new reference entity of a similar type.  

o The new entity replaces the old entity in the References list. 

o Depending on the type of reference entity replaced, the display of the 

Annotation Element is updated in the graphics window. For example, if the 
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Annotation plane is replaced, then the new Annotation plane is used to 

display the Annotation Element with the default plane as the Right 

direction, that is the direction in which the text is read. 

To Edit References  

To Rename an Annotation Feature 

When you create an Annotation feature, it is given a default name, such as 

Annotation 1. 

To change this name:  

1. Double-click on the Annotation feature name in the Model Tree, or select the 

Annotation feature in the Model Tree, right-click on its name and select Rename 

from the shortcut menu.  

2. Type the new name in the Model Tree. 

To Reorder an Annotation Feature 

If any of the Strong references of an Annotation feature are missing, the Annotation 

feature fails regeneration. If you do not want it to fail, you can either change the 

reference type to Weak, or reorder the Annotation feature to a different position in 

the regeneration sequence. 

You can reorder Annotation features in the same way as you reorder other types of 

features: 

1. Select the Annotation feature in the Model Tree. 

2. Drag it to the desired location in the Model Tree.  

You can not reorder an Annotation feature to come before any of its references. For 

example, if the Annotation feature contains a note attached to an edge of a round, 

you can not reorder the Annotation feature to come before the Round.  

For more information on reordering features, see the Part Modeling documentation. 

To Remove an Annotation Feature from Display 

You can remove the annotation associated with an Annotation feature from the 

display in the graphics area, while leaving the Annotation feature itself in the 

regeneration sequence of the model. Such an Annotation feature behaves as any 

other Annotation feature: it fails regeneration if any of its Strong references are 

missing, you can rename it, redefine, reorder, and so on. When you select this 

Annotation feature in the Model Tree, its geometric references are highlighted in the 

graphics area. 

To turn off the display of annotation associated with an Annotation feature: 

1. Select the Annotation feature in the Model Tree. 

2. Right-click on the feature name and select Hide from the shortcut menu.  
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All the annotation associated with the Annotation feature is removed from the 

display. The Annotation feature stays in the Model Tree, but the color of its icon 

changes to gray, to show that its annotation is hidden.   

To turn on the display of annotation associated with a hidden Annotation feature: 

1. Select the Annotation feature in the Model Tree. 

2. Right-click on the feature name and select Unhide from the shortcut menu.  

To temporarily remove an Annotation feature both from display and from the 

regeneration sequence, use the Suppress command. 

To Suppress or Resume an Annotation Feature 

Suppressing an Annotation feature temporarily removes it from the display and from 

the regeneration sequence. 

To suppress an Annotation feature: 

1. Select the Annotation feature in the Model Tree. 

2. Right-click on the feature name and select Suppress from the shortcut menu.  

3. The system prompts you for a confirmation. Click OK in the Suppress dialog 

box. 

All the annotation associated with the Annotation feature is removed from the 

display and the Annotation feature name is removed from the Model Tree. 

However, geometric references of the Annotation feature, even though they were 

highlighted when the Annotation feature was selected, are not suppressed. 

Resuming an Annotation feature restores it in the display and the regeneration 

sequence.  

To resume a suppressed Annotation feature: 

1. Click Edit > Resume. 

2. Select one of the options: 

o Last—Resumes only the last set of suppressed features. 

o All—Resumes all the suppressed features in the model. 

To Delete an Annotation Feature 

Deleting an Annotation feature permanently removes it from the display and from 

the regeneration sequence.  

To delete an Annotation feature: 

1. Select the Annotation feature in the Model Tree. 

2. Right-click on the feature name and select Delete from the shortcut menu.  

3. The system prompts you for a confirmation. Click OK in the Delete dialog box. 
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All the annotation associated with the Annotation feature is removed from the 

display and the Annotation feature name is removed from the Model Tree. 

However, geometric references of the Annotation feature, even though they were 

highlighted when the Annotation feature was selected, are not deleted. 

Note:  

• Annotation that was created as stand-alone and then included in an Annotation 

feature using the Existing Annotation option is not deleted when you delete the 

Annotation feature. Instead, it reverts to its stand-alone status. 

• Deleting an Annotation feature deletes all the annotation associated with it 

(unless it was added by using the Existing Annotation option). If you want to 

delete the Annotation feature but keep the annotation, you have to first redefine 

the Annotation feature and make the appropriate elements Non-Graphical, to 

disassociate the annotation from the Annotation feature. 

To Pattern an Annotation Feature 

You can pattern an Annotation feature only if some of its references belong to a 

patterned feature. 

1. Select the Annotation feature in the Model Tree. 

2. Click . This icon is available only if the selected Annotation feature has an 

Annotation Element with at least one reference that belongs to a patterned 

feature. When you click this icon, the system creates a By Reference pattern of 

the Annotation feature. This pattern follows the pattern of the feature referenced 

by the Annotation Element. 

Note: If an Annotation feature has multiple Annotation Elements, some of which 

reference a patterned entity and some of which reference non-patterned entities, 

then the Annotation Elements that do not reference the patterned entities will be 

duplicated but will still reference the same entities as the original Annotation 

Elements. 

Example: Patterning an Annotation Feature 

1. Create an Annotation feature with an Annotation Element of type Surface Finish. 

Place the Surface Finish symbol on the top plane of the patterned protrusion, as 

shown in the following illustration. 
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2. Select the Annotation feature in the Model Tree and click . The system 

creates a By Reference pattern of the Annotation feature, as shown in the next 

illustration. 

 

About Propagating Annotations in the Same Model 

When you create certain feature types such as surface copy, surface offset, or 

surface mirror, Pro/ENGINEER builds new geometry based on the original geometry, 

and assigns new IDs to this new geometry. As a result, Annotation Elements of 

previously created Annotation features do not reference this new geometry, which is 
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the design intent. Instead of reordering and rerouting the Annotation features to use 

the new geometry, you can use  to create an Annotation Element propagate 

feature that contains the propagated Annotation Elements with certain features 

within the same model. You can propagate Annotation Elements with the following 

features: 

• Surface offset 

• Surface copy 

• Surface mirror 

• Feature created using Apply Move/Rotate transformations to copies in the 

Paste Special dialog box. 

When you select one of these features and issue a command to propagate its 

annotation, Pro/ENGINEER does the following: 

1. Finds the original geometry based on a new geometry selection. 

2. Determines if the original geometry has any Annotation Elements referencing it, 

and whether all of those Annotation Element references belong to the selected 

feature. If yes, Pro/ENGINEER propagates the Annotation Elements, that is, 

creates a single new Annotation Element propagate feature, that contains copies 

of all the Annotation Elements found in the original geometry, even if they 

originally belong to different Annotation features. The geometry references in the 

copies of the Annotation Elements are replaced with the new geometric entities. 

These copies are dependent on the original. Any changes to the original Annotation 

Elements or its references after the Annotation Elements have been propagated are 

carried over to the Annotation Element propagate feature and the new Annotation 

Elements in the Annotation Element propagate feature upon regeneration. 

You can also propagate Annotation Elements within the same model automatically by 

setting the value of the auto_propagate_ae configuration option to yes. The 

Annotation Element propagate feature is automatically created. 

Note: When you create features such as Draft and Expand that replace current 

geometry that was referenced by Annotation Elements, propagation is not required 

as Pro/ENGINEER automatically searches for alternate references for existing 

Annotation Elements. 

About the Annotation Element Propagate Feature 

The Annotation Element propagate feature contains the propagated Annotation 

Elements and the references of one or more Annotation Elements. Note the following 

points about the Annotation propagate feature. 

• Upon regeneration of the model after you update the references, Pro/ENGINEER 

automatically updates the Annotation Element propagate feature and the 

propagated Annotation Elements in the Annotation Element propagate feature.  

• The propagation feature is visible in the Model Tree and you can select it only in 

the Model Tree. You can reorder the Annotation Element propagate feature by 
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dragging it in the Model Tree as long as its references precede it in the Model 

Tree. 

• If you remove the references of the Annotation Element propagate feature, the 

feature cannot be regenerated. 

• If you delete the Annotation Element propagate feature, then the Annotation 

Elements in the feature are also deleted. You can delete an Annotation Element 

from the Annotation Element propagate feature when redefining the Annotation 

Element propagate feature. 

• If you want to work with Annotation Elements propagated before Pro/ENGINEER 

Wildfire 3.0, then delete the propagated Annotation Feature and create a new 

Annotation Element propagate feature in Pro/ENGINEER Wildfire 3.0. Similarly, if 

you want to use Draft or Solid Offset features created before Pro/ENGINEER 

Wildfire 3.0, then you must create these features again in Pro/ENGINEER Wildfire 

3.0.    

Note: The af_copy_reference_flag configuration option that is used to back up 

references of Annotation Elements does not support Annotation Elements in the 

Annotation Element propagate feature. 

Controlling the Propagate Status and Dependency  

You can control the propagate status and dependency of the newly propagated 

Annotation Elements in an Annotation Element propagate feature using the Copy All 

and Dependent check boxes on the Annotation Element propagate feature 

dashboard that appears when you click . 

The status of the Copy All and Dependent check boxes does not affect the 

propagate status or dependency status of Annotation Elements that are already in 

the list of Annotation Elements in the slide up panel. This panel appears when you 

click Annotation Elements on the Annotation Element propagate feature 

dashboard.  

If you do not want any new Annotation Elements to propagate to the Annotation 

Element propagate feature after you create the Annotation Element propagate 

feature, then clear the Copy All check box before you complete the creation of the 

Annotation Element propagate feature. Subsequently, even if you add new 

Annotation Elements in the original Annotation Feature and even if these Annotation 

Elements reference the correct geometry and qualify for propagation, they do not 

propagate. If you want new Annotation Elements to propagate, you must select the 

Copy All check box before the completion of the Annotation. 

On regeneration, if you want Pro/ENGINEER to automatically make the newly 

propagated Annotation Elements in the Annotation Element propagate feature to be 

independent, then clear the Dependent check box before completing the creation of 

Annotation Element propagate feature. 
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To Propagate Annotations in the Same Model 

1. Select the feature or geometry, for example, surface offset or surface mirror, that 

was built on geometry referenced by Annotation Elements. 

2. Click  or Insert > Model Datum > AE Propagate. The dashboard for 

Annotation Element Propagate Feature appears and the propagated annotations 

are visible in the graphics window. 

3. Click References on the dashboard.  

o A slide up panel appears with the Features, Surface Sets, and Chains 

collectors. These collectors display references that were selected before you 

clicked . 

o The Copy All and Dependent check boxes are selected by default. 

4. You can use the Features, Surface Sets, and Chains collectors to add or 

remove features and references. 

5. Click Annotation Elements on the dashboard. The slide up panel displays the 

list of Annotation Elements that reference the specified features. The check boxes 

in the Propagate and Dependency columns are selected by default. 

Note:  

o Clearing the check boxes in the Copy All and Dependency column does 

not affect the propagation or dependency status of the Annotation Elements 

that are already present in the list of Annotation Elements in the slide up 

panel. 

o If you have specified a feature reference after clicking  and clearing the 

Copy All and Dependent check boxes, then in the slide up panel for the 

Annotation Elements, the check boxes in the Propagate and Dependency 

columns are not selected.  

6. In the Propagate column, if the check box next to the Annotation Element name 

is selected, then the annotation is propagated. If you do not want to propagate 

an annotation, clear the check box in the Propagate column corresponding to 

the Annotation Element. 

7. In the Dependency column, if the check box next to the Annotation Element 

name is selected, then the propagated Annotation Element is dependent on the 

original. You can change the status of the check box in the Dependency column 

only when the corresponding check box in the Propagate column is selected. 

8. On regeneration, if you do not want Pro/ENGINEER to update the propagated 

Annotation Elements in the Annotation Element propagate feature, then clear the 

Copy All check box before completing the creation of the Annotation Element 

propagate feature.  
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9. On regeneration, if you want Pro/ENGINEER to automatically make the newly 

propagated Annotation Elements in the Annotation Element propagate feature to 

be independent, then clear the Dependent check box before completing the 

creation of Annotation Element propagate feature. 

10. Click . The new Annotation Element propagate feature appears in the 

Model Tree. 

About Dependent Copies of Annotations 

Annotation Elements in an Annotation Element propagate feature are dependent on 

the original Annotation Feature. An Annotation Element propagate feature is created 

when Annotation Elements are propagated with features such as surface offset, 

surface copy, or surface mirror within the same model automatically or using . 

In these propagated Annotation Elements, the position of the annotation in the 

graphics window is independent of the original. All other properties are dependent on 

the original. However, after you convert an Annotation Element propagate feature to 

an Annotation Feature, the propagated Annotation Elements in the new Annotation 

Feature become detail dependent. 

Copies of Annotation Elements created by the following methods too are detail 

dependent on the original. 

• Annotation features that are copied using the Dimensions and Annotation 

Element Details Only option in the Paste Special dialog box that opens when 

you click Edit > Copy. 

• Annotation features that are copied using the Copy > Dependent command on 

the FEAT menu that appears when you click Edit > Feature Operations.  

In a detail dependent copy, the Annotation Element references and the position of 

the annotation in the graphics window are independent of the original. All other 

properties, such as note text, surface finish values, tolerance values of driven 

dimensions, tolerance values for geometric tolerances, text style, color and 

parameters are dependent. 

If you make changes in the original Annotation Element, these changes are carried 

over to the dependent copy of the Annotation Element upon regeneration. 

Note the following points about dependent copies. 

• In the dependent copy, the position of the annotation in the graphics window is 

independent of the original. All other properties are dependent. 

• Text properties of a dependent copy are dependent on the text properties of the 

original Annotation Element. However, when you attach an Annotation Element to 

an entity such as a dimension or another GTOL, the text properties of the 

Annotation Element become the same as that of the entity that the Annotation 

Element is attached to. 
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• You cannot modify the parameters created by the original Annotation Element in 

the dependent copy. However, you can add new parameters with full access to 

the dependent Annotation Element. 

• You cannot modify the dependent properties of copies using tools such as family 

tables or variable items in UDFs, flexible components, and inheritance features. 

These tools allow you to specify a variation for the dependent properties. 

However, on regeneration, Pro/ENGINEER gives a warning that invalid variations 

have been specified and that these dependent Annotation Elements will remain 

unchanged. 

• If you change the type of the original geometric tolerance, for example, from 

Straightness to Flatness, the dependency of the copy is removed automatically. 

The dependency between Annotation Elements is sequential. For example, consider 

three Annotation Elements, A, B, and C. B is dependent on A and C is dependent on 

B. If you change the color of A, then the color of B changes automatically and 

subsequently the color of C also changes automatically. If you make B independent, 

C is still dependent on B and any changes to the properties of B are reflected in C. 

You can restore or remove the dependency of Annotation Elements. 

You can view the parent-child information of Annotation Elements by clicking Info > 

Parent/Child on the shortcut menu that appears when you select an Annotation 

feature or Annotation Element in the Model Tree or the graphics window and right-

click. Alternatively, you can view parent-child information by clicking Info > Global 

Reference Viewer on the menu bar. 

Copies of Annotation Features that you create by clicking the Fully Dependent with 

options to vary option and the Dependent copy check box in the Paste Special 

dialog box that opens when you click Edit > Copy are fully dependent copies. 

However, in such copied features you can change the copy status of annotations, 

Annotation Element references and other properties using the Varied Items dialog 

box that opens when you click Copied feature > Varied items on the shortcut 

menu. The properties that you can change are annotation values for surface finish 

and geometric tolerances, visibility status for note, text style, color, and parameters.  

To Remove or Restore the Dependency of Annotation Elements 

You can remove or restore the dependency of Annotation Elements in an Annotation 

Element propagate feature as follows.  

• To remove the dependency of an Annotation Element, select the dependent 

Annotation Element, right-click, and click Make Independent on the shortcut 

menu.  

• To restore the dependency of the Annotation Elements, select the dependent 

Annotation Element, right-click, and click Make Dependent on the shortcut 

menu.  

If you have converted an Annotation Element propagate feature to an Annotation 

Feature, then you can remove or restore the dependency as follows. 
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• To remove the dependency of an Annotation Element, select the dependent 

Annotation Element, right-click, and click Detail Independent on the shortcut 

menu.  

• To restore the dependency of the Annotation Elements, select the dependent 

Annotation Element, right-click, and click Detail Dependent on the shortcut 

menu.  

• If you change the type of the original geometric tolerance, for example, from 

Straightness to Flatness, the dependency of the copy is removed automatically. 

To restore the dependency, change the type of geometric tolerance back to 

Straightness and click Detail Dependent on the shortcut menu. 

Note: You can restore dependency only if the original Annotation Element still exists, 

that is, the original Annotation Element has not been deleted, suppressed, or is not 

in the rollback state. 

To Convert an Annotation Element Propagate Feature to an 

Annotation Feature 

To convert an Annotation Element propagate feature to Annotation Feature, select 

the Annotation Element propagate feature on the Model Tree, right-click, and click 

Convert to AF on the shortcut menu.  

Note: The conversion of an Annotation Element propagate feature to an Annotation 

Feature is irreversible. 

 

To Select the Original of a Dependent Annotation Element 

1. Select the dependent Annotation Element and right-click. The shortcut menu 

appears. 

2. Click Select Driving AE on the shortcut menu. The original Annotation Element 

is selected. 

Note: If the dependency between Annotation Elements is sequential, the driving 

Annotation Element is selected. For example, consider three Annotation Elements, A, 

B, and C. C is dependent on B and B is dependent on A. If you right-click on C and 

click Select Driving AE on the shortcut menu, the driving Annotation Element A is 

selected. 

About Annotations in Difference Reports 

You can generate a report of differences between Annotation features and 

Annotation Elements in two versions of the same model or drawing. This report 

describes the differences between the features of the two compared models or 

drawings, including the differences between Annotation features and differences 

between Annotation Elements. Models or drawings being compared can have the 

same or different names.  
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For User Defined Features and features that are a part of a group, the report displays 

the group name or the User Defined Feature name with the actual feature in 

parentheses in the Item Name column. This enables you to sort the report for 

similar grouped features by group name and UDF name. For example, 

Group_ABD(AE_1) where Group_ABD is the group name and the AE_1 is the actual 

feature. 

Pro/ENGINEER generates a difference report by comparing the two versions in the 

following manner (only the differences are reported). 

Annotation Features in the Difference Report 

• Annotation feature name 

• Number of Annotation Elements in Annotation feature 

Annotation Elements in the Difference Report 

• Annotation Element type 

• Annotation Element name and Annotation name 

• Annotation Element dependent and independent options 

• Annotation Element references 

o Number of References 

o Reference IDs 

o Type of references (Weak or Strong) 

• Annotation Element Parameters 

o Number of parameters 

o Parameter names 

o Parameter values 

Annotations in the Difference Report 

• Annotation Display Status 

• Annotation Active or Inactive status 

• Note Properties 

o Text field value of a note 

o Uniform Resource Locator (URL) value of a note 

o Attachment references 

• Symbol Properties 

o Change information 
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o Attachment references 

• Geometric Tolerance Properties 

o Geometric Tolerance type 

o Tolerance value 

o Attachment references 

o Text value 

• Surface Finish Properties 

o Surface finish values 

o Attachment references 

• Driven Dimension and Tolerance 

o References 

o Tolerance value 

To Create a Difference Report 

1. Open the first of the two parts that you want to compare. 

2. Click Analysis > Compare Part > By Feature. The File Open dialog box 

opens. 

Note: You can compare two assemblies using Analysis > Compare Assembly 

by Feature in the Assembly mode. Similarly, you can compare two drawings 

using Analysis > Compare Drawing in the Drawing mode. 

3. Select the second part. The difference report is displayed in the Pro/ENGINEER 

browser. 

Note: If you attempt to open a part with the same name as the first part, you 

are prompted to rename one of the parts. 

4. If required, sort the difference report in ascending or descending order based on 

the contents of a column by clicking its column header. Clicking the column 

header again reverses the sort order. 

5. If required, export the difference report by clicking Export Report on the HTML 

report page. By default, the exported file is saved in the current working 

directory in Comma Separated Value (CSV) format as <model_name>_CMPR0.csv 
and <model_name>_CMPR0.csv.1. Set the export_report_format configuration 

option to rich_text to save the exported file in the rich text format as <model 
name>_CMPRO.txt and <model name>_CMPRO.txt.1. You can open these saved 

files in Microsoft Excel. 

Note: The <model_name>_CMPR0.csv.1 and <model name>_CMPRO.txt.1 are 

version files. Whenever you export the same report again, new version files are 
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created with incremented file names and the <model_name>_CMPR0.csv and 

<model name>_CMPRO.txt files are replaced by latest exported file. 

Example: Difference Report Containing Annotations 

 

Working with Annotation Elements 

About Working with Annotation Elements 

You create, delete, and redefine the type and references of Annotation Elements 

while creating or redefining Annotation features.  

When you select an Annotation Element on the screen or in the Model Tree, you can: 

• Edit the Annotation Element parameters by right-clicking and selecting Edit 

Parameters from the shortcut menu. The Parameters dialog box opens. You 

can add or delete parameters, or modify their values or other properties. You can 

simultaneously modify parameters of multiple Annotation Elements. 

• Modify properties of the annotation included in the Annotation Element by right-

clicking and selecting Properties from the shortcut menu. Depending on the 

type of the Annotation Element, the appropriate dialog box (such as Dimension 

Properties, Note, and so on) opens to let you modify the properties of the 

underlying annotation. 
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• Modify the text style of the annotation included in the Annotation Element by 

right-clicking and selecting Text Style from the shortcut menu. The Text Style 

dialog box opens to let you modify the text style of the underlying annotation. 

• For certain types of Annotation Elements, such as Surface Finish or Geometric 

Tolerance, you can modify the tolerance value of the underlying annotation by 

right-clicking and selecting Value from the shortcut menu, then typing the new 

tolerance value at the prompt. You can select multiple Annotation Elements of 

the same type and simultaneously modify value for all the underlying 

annotations.  

To Select an Annotation Element 

To select an Annotation Element, you can: 

• Select the Annotation Element in the Model Tree. 

• Select Annotation from the filter list on the Status Bar and select the 

appropriate annotation on the screen. When you select an annotation on the 

screen, and the annotation is part of an Annotation Element, the Annotation 

Element, and not the annotation itself, is selected. All the annotation operations, 

except Delete, can be performed through the Annotation Element. 

When you select an Annotation Element, the following occurs: 

• The Annotation Element that contains the annotation is highlighted in the Model 

Tree.  

• The annotation is highlighted in primary color in the graphics area.  

• All the references of the Annotation Element that contains the selected 

annotation are highlighted in secondary color in the graphics area. 

• If you right-click on the selected Annotation Element, the Select References 

command is available in the shortcut menu. Using this command lets you select 

all the references of the Annotation Element. 

To Modify Parameters of Multiple Annotation Elements 

You can simultaneously modify parameters of multiple Annotation Elements: 

1. Select multiple Annotation Elements, either by holding down the CTRL key and 

selecting their names in the Model Tree, or as a result of a search. 

2. Right-click on one of the selected names and select Edit Parameters from the 

shortcut menu.  

3. The Parameters dialog box opens. It lists only the parameters that are common 

to all the selected Annotation Elements. A parameter is considered common if its 

name, type, and units are the same for all Annotation Elements. The parameter 

values (as well as sources, descriptions, designate statuses, restrictions) that are 

the same for all the selected Annotation Elements are displayed. If a parameter 

has different values (or sources, descriptions, designate statuses, restrictions) for 
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different Annotation Elements, the appropriate field is blank. You can add or 

delete parameters, or modify their values or other properties.  

4. Click OK when finished. All the changes you have made are applied to all the 

selected Annotation Elements. 

About Moving Annotations in Annotation Elements 

You can move annotations in Annotation Elements and standalone annotations by 

clicking Move on the shortcut menu that appears when you select the Annotation 

Element in the Model Tree or the graphics window and right-click. Moving the pointer 

to a new location and clicking places the annotation at the new location. Middle-

clicking cancels the move operation. Similarly, you can move Annotation Elements 

that are propagated into data sharing features and Annotation Elements propagated 

within a model. The position of the propagated annotation is independent of the 

position of the original Annotation Element. 

You can move standalone annotations using Properties on the shortcut menu or the 

menu manager. Similarly, you can also move annotations in Annotation Elements. 

You cannot move either annotations in Annotation Elements or standalone 

annotations if they have been placed directly on an entity. 

Driving Dimension Annotation Elements 

About Driving Dimension Annotation Elements 

You can include model driving dimensions created and owned by features in 

Annotation Elements by selecting the dimensions and placing them on annotation 

planes. Such Annotation Elements are called Driving Dimension Annotation Elements 

(DDAEs) and are created in the feature that owns the dimension. In DDAEs you can 

include all driving dimensions that you can modify. DDAEs do not have user-defined 

or system references in the annotation element.  Note the following points about 

DDAEs: 

• You cannot make DDAEs nongraphical. You can delete them from the feature that 

contains them. 

• DDAEs can only exist within the feature in which you create them. 

• One DDAE can include only one dimension. After a DDAE includes a dimension, 

another DDAE cannot include the same dimension again.  

• If you modify the properties or value of the dimensions in a feature the changes 

are propagated to the DDAE. Similarly, if you modify the properties or value of 

DDAEs the changes are propagated to the dimension. 

• If you modify the feature such that the DDAE still exists but the Annotation 

Element's annotation plane is no longer compatible with its current annotation 

plane, then the Annotation Element becomes inactive.  

• If a dimension no longer exists in the feature, Pro/ENGINEER deletes the 

corresponding DDAE from the feature. 
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• You can create DDAEs for dimensions that convey the increment and number of 

instances in a pattern. 

• You cannot create a DDAE for the selected dimension of a pattern instance in the 

Edit mode. However, if one or more dimensions shown in the Edit mode for that 

instance belong to the leader, then you can create DDAEs for such dimensions, 

but they will be located under the leader feature and not under the instance. 

• You cannot create DDAEs for instances in a pattern. However, you can create 

DDAEs for the instances in a pattern table, as a pattern table creates new 

dimensions for the instances when patterning a feature. 

• When creating a family table or a relation you can select DDAEs on the Model 

Tree. 

• You can select a DDAE as an existing annotation when defining an annotation 

orientation. However, when creating a new Annotation Element you cannot select 

a DDAE as an existing annotation.  

• You can change the value of a DDAE by clicking Value on the shortcut menu that 

opens when you right-click the driving dimension annotation on the Model Tree or 

in the graphics window. 

• You can delete a DDAE by clicking Delete on the shortcut menu that opens when 

you right-click the driving dimension annotation on the Model Tree or in the 

graphics window. 

• Component placement dimensions are shown on the Model Tree with the 

placement constraints of the component. If you create a DDAE with a placement 

constraint in an assembly, and hide the placement folder using the Model Tree 

filters, then Pro/ENGINEER does not display the DDAE on the Model Tree.  

• Pro/ENGINEER displays DDAEs in the Data Sharing Features (DSFs) and merge 

features. When switching between merge and inheritance features, the 

placement constraints remain the same. Therefore, there is no change in the 

DDAEs.   

• You cannot create DDAEs for ordinate dimensions, dimensions in Auto Round 

feature, and for some dimensions in anatomic features. 

• The Undo and Redo functionality for DDAEs is similar to other annotation 

elements. In addition, the Undo and Redo commands are also available for 

actions such as creating and deleting DDAEs and changing the orientation of 

DDAEs. 

About Display of Driving Dimension Annotation Elements 

Pro/ENGINEER displays Driving Dimension Annotation Elements (DDAEs) whenever 

the driving dimensions are displayed. For example, when you edit a feature, create 

relations, or define family tables. Note that Pro/ENGINEER displays DDAEs in the 

following cases too: 

• DDAEs are located on hidden layers. 
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• DDAEs are manually hidden using View > Hide. 

• DDAEs are located in a clipped zone. 

If you hide all annotations using , then Pro/ENGINEER does not display DDAEs.  

Note: Pro/ENGINEER displays inactive DDAEs in the Edit mode in the same state as 

before the conversion of the dimensions to DDAEs. 

Naming Convention for Driving Dimension Annotation Elements 

The format for the name of a DDAE is DRV_DIM_DX, where DX is the driving dimension 

identification number, for example, DRV_DIM_D4.  

The format for independent copies and fully dependent copies of DDAEs is 

DRV_DIM_DY, where DY is the new identification number for the independent copy. 

All DDAEs have a unique name. If you change the name of a DDAE such that 

Pro/ENGINEER cannot use the default naming convention to create a unique name, 

then Pro/ENGINEER increments the default name to make the Annotation Element 

name unique. For example, DRV_DIM_DX_#, where X is the identification of the 

dimension and # is an increment that Pro/ENGINEER uses to make the name unique. 

About Creating Copies of Driving Dimension Annotation Elements 

Independent Copies 

When you copy and paste a feature, and if Driving Dimension Annotation Elements 

(DDAEs) exist in the source feature and its orientation is appropriate, Pro/ENGINEER 

copies the DDAEs to the target feature. Pro/ENGINEER displays independent copies 

of the DDAEs only if the orientation is appropriate. If the orientation is not 

appropriate, then the copies of DDAEs are inactive and are not displayed in the 

graphics window, but are visible on the Model Tree. In an independent copy, all 

DDAEs are unique and are not driven by the source dimensions. 

Fully Dependent Copies 

You can create fully dependent copies by clicking Fully dependent with options to 

vary in the Paste Special dialog box. In the fully dependent copy, all dimensions 

are driven by the dimensions in the source feature. The automatically created copies 

of DDAEs are therefore, not visible in the copy. However, if you add a driven 

dimension in the copy to the varied items table such that the primary value or 

tolerance values are varied, then the dimension becomes a driving dimension. If the 

source dimension is a DDAE, the varied target DDAE becomes visible. 

If you apply transformations to the copy, Pro/ENGINEER creates a unique dimension 

at the top level to drive the transformations of the copy. This dimension does not 

exist in the source feature. You can convert the transformation dimensions to 

DDAEs. 
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Dimension and Annotation Element Dependent Copies 

You can create dependent copies by clicking Dimensions and annotation details 

only in the Paste Special dialog box. The automatically created copies of DDAEs 

are not visible in the copy.   

If you apply transformations to the copy, Pro/ENGINEER creates transformation 

dimensions in the feature that contains them to drive the placement of the copy. 

These dimensions do not exist in the source feature. You can convert these 

transformation dimensions to DDAEs.  

If DDAEs are present in the source feature you are copying and if you make the 

dimensions corresponding to these DDAEs in the copy independent then the DDAEs 

in the copy become visible.  

If you copy a source feature without DDAES and if you make the dimensions in the 

copy independent, the dimensions become visible driving dimensions and are not 

driven by the source dimensions. You can convert independent driving dimensions in 

the dependent copies to DDAEs. If you make changes to the properties of the source 

dimensions after the dimensions are made independent, then these changes are not 

propagated to the DDAEs. You can delete DDAEs of independent dimensions in 

dependent copies. 

To Create Driving Dimension Annotation Elements 

1. Define the active annotation orientation before creating the first annotation in 

any session using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

Note: 

o You can use either a Named orientation or a frozen Reference plane to 

create Driving Dimensions Annotation Elements (DDAEs). Flat-to-screen 

annotation orientations are not supported for DDAEs. 

o If you skip step 1, then Pro/ENGINEER uses the default active annotation 

orientation. 

2. Select a one or more valid features or components. 

3. Perform one of the following actions: 

o Click Insert > Annotations > Driving Dimension AE. 

o Right-click the feature on the Model Tree or in the graphics window and 

click Create Driving Dimension AE on the shortcut menu. 

o Click  on the Model Detailing toolbar. To view the Model Detailing 

toolbar click Model Detailing in the Toolbars tabbed page in the 

Customize dialog box. To open the Customize dialog box, click Tools > 

Customize Screen. 

Note that the menu option, command, and toolbar are not available when all 

dimensions are converted to DDAEs. 
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Pro/ENGINEER creates DDAEs in the annotation plane in the selected features or 

components.  If any dimensions are not converted, Pro/ENGINEER displays a 

message in the message area that one or more dimensions were not converted to 

DDAEs.  

Note: You can also create a driving dimension in the Edit mode. In the Edit mode 

select the dimensions you want to convert to DDAEs and perform step 3. 

Pro/ENGINEER creates DDAEs using the active annotation orientation in the features 

or components you are editing. If the annotation orientation is Driven by plane, 

Pro/ENGINEER freezes the annotation plane.   

Creating Various Annotation Types 

Working with Annotation 

About Annotation 

An annotation is a note-type entity created to store model information without 

geometry. Annotations consist of:  

• Notes 

• Symbols 

• Driven dimensions 

• Reference dimensions 

• Ordinate driven dimensions 

• Ordinate reference dimensions 

• Chamfer dimensions 

• Geometric tolerances 

• Surface finish symbols  

Annotations can exist independently within the model, or be included in Annotation 

features. If an annotation is part of an Annotation feature, it becomes the graphic 

representation of an Annotation Element. 

Different annotation types are created differently and have different properties. The 

following help topics describe techniques common to working with all annotation 

types. 

Active and Inactive Status of Annotation 

If an annotation is part of an Annotation Element, it can become inactive if all of its 

Weak references are lost. For example, if an Annotation Element includes a note, and 

the note is attached to two edges, then the two edges are Weak references. If one of 

the edges was chamfered somewhere later in the regeneration sequence, this 

reference is lost and the leader that used to be attached to this edge is not 
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displayed. The note has only one leader, attached to the second edge. However, if 

the second edge is also lost, the note would lose its last remaining leader and 

become inactive. 

Inactive annotation exists in the Model Tree, but it is not displayed on the screen. 

To Select an Annotation 

If an annotation is part of an Annotation Element, selecting it on the screen results in 

selecting the Annotation Element. You can not directly select an annotation that is 

consumed by an Annotation Element. All the annotation operations, except Delete, 

can be performed through the Annotation Element. 

To select a stand-alone annotation item, you can: 

• Select Annotation from the filter list on the Status Bar and select the annotation 

on the screen. 

• Select the annotation in the Model Tree. 

When you select an annotation on the screen, the following occurs: 

• The annotation is highlighted in the Model Tree.  

• The annotation is highlighted in primary color in the graphics area.  

• All the annotation references are highlighted in secondary color in the graphics 

area. 

To Edit Properties of an Annotation 

If an annotation is part of an Annotation Element, you modify its properties by 

modifying properties of the Annotation Element. 

To modify properties of a stand-alone annotation: 

1. Select Annotation from the filter list on the Status Bar and select the annotation 

on the screen, or select the annotation in the Model Tree. 

2. Right-click on the annotation and select Properties from the shortcut menu. 

3. Depending on the type of annotation, the appropriate dialog box (such as 

Dimension Properties, Note, and so on) opens to let you modify the properties 

of the annotation. 

4. Click OK when finished. 

To Modify Multiple Annotations 

You can simultaneously modify multiple annotations of the same type by using the 

Properties or the Value shortcut command. 

The following table describes which values in which Annotations can be modified at 

once: 
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Type of annotation Value that can be 

modified 

Shortcut Command 

Driven dimension upper and lower 

tolerance values 

Properties 

Geometric tolerance primary tolerance 

value 

Value 

Surface finish surface finish value Value 

To simultaneously modify multiple annotations: 

1. Select multiple annotations of the same type on the screen or in the Model Tree.  

2. Right-click on one of the selected names and select the appropriate command 

from the shortcut menu. 

3. Type the new value. The system updates the values for all the selected 

annotations. 

Model Notes 

About Model Notes 

Model notes are text strings that you can attach to objects. You can attach any 

number of notes to any object in your model.  

You can use model notes to: 

• Tell other members of your workgroup how to review or use a model that you 

have created. 

• Explain how you approached or solved a design problem when defining the 

features of a model. 

• Explain changes that you have made to the features of a model over time. 

You can include model notes in Annotation features. This way, you can define a 

library of company-specific annotation, and then place it in various models, as 

appropriate.  

To Create a Model Note 

Use the following procedure to create a model note: 

1. Define the active annotation orientation before creating the first annotation in 

any session by using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Notes. The MDL NOTES menu appears. 

3. Click New. The Note dialog box opens. 



Pro/ENGINEER Fundamentals 

423 

4. If you want to change the default name of the note, type a name in the Name 

box. 

5. Select a parent from the Parent list, if necessary. By default, the note belongs to 

the top-level model, part, or assembly.  

6. Type the text for the note in the Text box. 

7. Use the available options (Insert, Style, and Symbols) to further create your 

note. For more information, see the topic To Modify a Model Note. 

8. Click Place under Placement. The NOTE TYPES menu appears. 

Note: You can click the Place note flat to screen in model space check box 

instead of selecting an Annotation plane. In this case, the note does not change 

its orientation with the model. You cannot include such a note in Annotation 

features. 

9. On the NOTE TYPES menu, select a leader type and define the note placement. 

10. If you are creating a note with any type of leader, or an On Item note, select 

the attachment point. You can select multiple points for certain types of leader 

attachment, then click Done on the ATTACH TYPE menu. 

11. Once you defined the attachment type, the pointer changes to . Click on 

the screen to select where the note should be placed. Pro/ENGINEER places the 

note. 

12. Click Hyperlink in the Note dialog box to create a URL and ScreenTip on 

your note. 

13. Click OK in the Note dialog box. 

To Define the Note Placement 

When you insert a note, you have a series of options to set up the note properties, 

such as attachment type and location, leader style, and text position. 

1. While creating a note, when you click Place in the Note dialog box, specify the 

Annotation plane (or place note flat to screen), the NOTE TYPES menu appears 

with the following commands: 

o No Leader—No leader. You bypass any leader setup options and are 

prompted only for the note location. 

o With Leader—Leader attached to a specified point. You have to define the 

attachment style, select the attachment point or points, then select the 

note location. If you select multiple attachment points, the note will have 

multiple leaders. 

o ISO Leader—ISO style leader. The same procedure as With Leader, 

creates a note with ISO style leader. 



Pro/ENGINEER Fundamentals – Help Topic Collection 

424 

o On Item—Note is directly attached to selected item. You bypass any leader 

setup options and are prompted only for an item to which to attach the 

note directly. 

The following commands define the leader orientation, if a leader is used: 

o Standard—Uses the default leader type. The note can have multiple 

leaders. 

o Normal Ldr—Makes the leader normal to the entity; in this case, the note 

can have only one leader. 

o Tangent Ldr—Makes the leader tangent to the entity; in this case, the 

note can have only one leader. 

2. If you are placing a note with a leader, then, once you click Done on the NOTE 

TYPES menu, the ATTACH TYPE menu appears with the following commands: 

o On Entity—Creates a leader that is attached to a model edge or curve. 

Selecting the entity near its vertex locates the leader at the vertex. 

o On Surface—Locates the leader on model geometry or surfaces. You can 

select model geometry, threads, and datum surfaces. Once you make an 

attachment on a surface, if you reorient the view, the attachment remains. 

If the size of the surface changes, the system updates the leader point 

accordingly.  

o Arrow Head—Creates a leader with an arrow head. 

o Dot—Creates a leader with a dot. 

o Filled Dot—Creates a leader with a filled dot. 

o No Arrow—Creates a leader with no arrow. 

o Slash—Creates a leader with a slash. 

o Integral—Creates a leader with an integral. 

o Box—Creates a leader with a box. 

o Filled Box—Creates a leader with a filled box.  

o Double Arrow—Creates a leader with a double arrow head. 

Note: The various leader style options appear only for notes created flat to 

screen. If a note is placed on an Annotation plane, the only leader style available 

is Arrow Head. 

3. Select the commands that define the attachment type and style, then select the 

attachment point on the screen. If the note can have multiple leaders, you can 

select multiple attachment points. Click Done on the ATTACH TYPE menu when 

finished.  

4. Finally, as the pointer changes to , select the location for the note. 
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To Create a Hyperlink in a Note 

You can associate a hyperlink and screen tip with a model note during note creation, 

or attach them to an existing note in your model. 

1. When creating or modifying a note, click Hyperlink in the Note dialog box.  

At any other time, select the note on the screen or in the Model Tree, right-click 

on it, and select Add Link from the shortcut menu. 

The Edit Hyperlink dialog box opens. 

2. In the text box, type a URL or internal link that you wish to associate with the 

Note. 

3. (Optional) To create a screen tip:  

Click Screen Tip. The Set Hyperlink ScreenTip dialog box opens. 

Type your text in the text box. Click Ok. 

4. Click Ok in the Edit Hyperlink dialog box. The note color changes to indicate 

there is a hyperlink associated with it. By default, it turns blue and underlined. 

The actual color and style depend on your Browser Options, available under 

Tools in the top menu bar. 

If a note has a hyperlink associated with it, you can edit or remove the hyperlink by 

selecting the note on the screen or in the Model Tree, right-clicking on it, and 

selecting Edit Link or Remove Link, respectively, from the shortcut menu. 

To Open a Hyperlink Defined in a Model Note 

1. Select Annotation from the filter list on the Status Bar. 

2. Move the cursor over the note with a hyperlink. It highlights and a Screen Tip 

appears. 

3. Press CTRL. The pointer changes to a hand icon.  

4. Click the mouse. The associated URL opens in the Pro/ENGINEER embedded 

browser. 

You can also open the URL by using the Open URL command from the shortcut 

menu. 

1. In the graphics window or the Model Tree, click the note to select it. Right-click 

the mouse. The shortcut menu displays. 

2. Select Open URL. The associated URL opens in the Pro/ENGINEER embedded 

browser. 

To Delete or Erase a Model Note 

Deleting a note removes the note entirely. Erasing a note removes the note from the 

screen, but the note still exists. Therefore, it is visible as a sub-level to its parents in 

the Model Tree, and is available for selection and other operations.  
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To delete selected notes: 

1. Click Insert > Annotations > Notes. The MDL NOTES menu appears.  

2. Click Delete. 

3. Select the notes you want to delete and click Ok. A Confirm dialog box opens. 

4. Click Yes to confirm the deletion and return to the MDL NOTES menu. 

To erase selected notes or all notes: 

1. Click Insert > Annotations > Notes. The MDL NOTES menu appears. 

2. Click Erase. The NOTE DISP menu opens. 

3. Select the notes to erase and click Ok, or click All to erase all notes for the 

model.  

Another way to delete or erase a note is to select the note on the screen or in the 

Model Tree, right-click on it, and select Delete or Erase, respectively, from the 

shortcut menu. 

To Display a Model Note 

To display an existing model note: 

1. Click Insert > Annotations > Notes. The MDL NOTES menu appears.   

2. Click Show. The NOTE DISP menu appears. All the notes present in the model 

are temporarily displayed. 

3. Select notes to display, or click All to display all notes in the model. 

To turn the display of model notes on or off: 

1. Click Insert > Annotations > Notes. The MDL NOTES menu appears. 

2. Click Toggle. The NOTE DISP menu appears. All the notes present in the model 

are temporarily displayed. 

3. Select notes to switch their display, or click All to switch display of all notes. 

To Modify a Model Note 

1. Select Annotation from the filter list on the Status Bar and select the note on 

the screen, or select the note in the Model Tree. 

2. Right-click on the note and select Properties from the shortcut menu. The Note 

dialog box opens. 

3. Use the following options of the Note dialog box to change your note: 

o Insert—Allows you to insert text from a file or from a note. 
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o Style—Displays the Text Style dialog box to change the following, if 

applicable: 

Under Character, you can change width factor and slant angle of selected 

text characters, and you can also set Underline on or off. The text height 

and thickness of a model note cannot be changed in Part or Assembly 

mode. 

Under Note/Dimension, you can adjust line spacing, angle, set horizontal 

and vertical justification, change your note to a mirror image of itself by 

selecting the Mirror check box, and use the Color dialog box to change 

system and user-defined colors.  

Click Reset to revert to the default settings, Apply to make the changes to 

the current settings to the selected note, and OK to make the changes and 

return to the Note dialog box. 

o Symbols—Displays the Symbol Palette dialog box from which you select 

a symbol to accompany your note. 

o Move Text—Highlights the text for the selected note and allows you to 

move it. Use the left mouse button to move the text to the new location 

and the middle mouse button to cancel the move. 

o Mod Attach—Displays the MOD OPTIONS menu, with the following 

commands for changing references for the selected note: 

Same Ref—Allows you to move the reference to a different point on the 

same entity.  

Change Ref—Displays the ATTACH TYPE menu, which allows you to 

change the reference type and characteristics of a selected reference for 

the selected note.  

Add Ref—Displays the ATTACH TYPE menu, which allows you to select a 

reference point on the model and add a new reference from the selected 

note.  

Delete Ref—Allows you to select and delete a leader for the selected note.  

o Move—Highlights the current selected note and allows you to use the 

mouse to move the entire note and its references. Click the left mouse 

button to accept the change or the middle mouse button to cancel it. 

o Unplace—Removes the selected note. The Place button then appears and 

you can place the note again.  

o Hyperlink—Allows you to add or edit a hyperlink and a screen tip for the 

note, or remove an existing link. 

2. Click OK. 

To Modify Note Text Style 

1. Click Insert > Annotations > Notes. The MDL NOTES menu appears.  
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2. Click Text Style and select the note or notes that you want to change and then 

click Ok. The Text Style dialog box opens. 

3. Under Copy From, you can click Select Text to select existing text to modify. 

4. Under Character, you can change width factor and slant angle of selected text 

characters, and you can also set Underline on or off. The height or thickness of 

the text in a model note cannot be changed in Part or Assembly mode. 

5. Under Note/Dimension, you can adjust line spacing and angle, set horizontal 

and vertical justification, change your note to a mirror image of itself by selecting 

the Mirror checkbox, and use the Color dialog box to change system and user-

defined colors.  

6. Click Reset to revert to the default settings, Apply to make the changes to the 

current settings to the selected note, and OK to make the changes and return to 

the MDL NOTES menu. 

To Move a Model Note 

You can move a note using the menu manager or start the process directly on the 

Model Tree or graphics window. To use the menu manager, see the second 

procedure in this topic. 

Note: To see notes in the model tree click Settings > Tree Filters > Annotations. 

To select notes in the graphics window, select Annotation from the Filter list on the 

Status Bar. 

1. Select the note in the Model Tree or graphics window and right click. A shortcut 

menu appears. 

2. Click Move. The note and leader line turn gray. A box outline of the note along 

with the leader line moves with the pointer. 

Note: You can also click Edit > Properties and then click Move Text in the 

Note dialog box. 

3. Move the outline of the note to the new location.  

4. Click to place the note in the new location or middle-click to cancel the move. 

To Move a Note Using the Menu Manager 

1. Click Insert > Annotations > Notes. The MDL NOTES menu appears.  

2. Click Move.  

3. From the Model Tree or graphics window, select the note you want to move and 

click OK. The note and leader line turn gray. A box outline of the note along with 

the leader line moves with the pointer. 

4. With the pointer, move the outline of the note to the new location.  

5. Click to place the note in the new location or middle-click to cancel the move. 
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To Save a Model Note as a Text File 

Use the following procedure to save an existing model note in a text file: 

1. Click Insert > Annotations > Notes. The MDL NOTES menu appears. 

2. Click Save Note. 

3. Choose one of the following commands on the NOTE SAVE menu: 

o As Symbols—Saves the text with the parametric information as symbols. 

The information in a text file saved using this command contains the note 

text as well as information required by Pro/ENGINEER to parametrically 

control the note text. If you include a dimension in the note text, saving the 

note text As Symbols saves the information required by Pro/ENGINEER to 

find the dimension in the model and output its value in a note. 

o As Numeric—Saves the text with the parametric information as numerical 

values. The information in the text file saved using this option contains only 

the note text. If you include a dimension in the note text, saving the note 

text, saving the note As Numeric saves only the current value of the 

dimension. 

4. Select the model note that you want to save as a .txt file. The Save Note dialog 

box opens. 

5. In the Save Note dialog box, enter a name for the text file or use the default 

name. Click OK to finish. 

Symbols 

About Adding Symbols to a Model 

Pro/ENGINEER lets you place drafting symbols on a 3D model. A symbol can be 

attached directly to a surface or other entity, or attached by leaders. It will be 

graphically presented as if on a plane parallel to the referenced Annotation plane, 

which you select when you place the symbol. The symbol orientation stays constant 

with the plane as the plane rotates with the model. 

To Add Symbols to a 3D Model 

To add symbols to a 3D model, in Part or Assembly mode:  

1. Define the active annotation orientation before creating the first annotation in 

any session by using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Symbol. The 3D SYMBOL menu opens with the 

following commands: 

o Custom—Lets you create custom instances from generic definitions.  

o From Palette—Lets you create symbol instances using the Symbol 

Instance Palette, which is a .dwg file dedicated to storing frequently used 
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symbol instances. These symbols are usually simple symbols, without 

graphic groups or variable text.  

o Move—Moves an existing symbol. Available only after symbols have been 

added to the model. 

o Symbol Gallery—Opens the SYM GALLERY menu, which lets you define 

new symbols, change symbol definitions, and perform other tasks working 

with symbols. 

3. The Custom Drawing Symbol dialog box appears. 

4. Use the 3D SYMBOL menu commands to place a symbol from the Symbol 

Palette, or from the Custom Drawing Symbol dialog box. The symbol can be 

attached directly to a surface or other entity, or attached by leaders. It will be 

placed parallel to the selected Annotation plane. For more instructions on defining 

symbols, or using the Symbol Palette or the Custom Drawing Symbol dialog 

box, see the documentation for Detailed Drawings. 

To Move a Symbol 

You can move a symbol using the shortcut menu or the menu manager. 

To Move a Symbol Using the Shortcut Menu 

1. Select the symbol in the Model Tree or graphics window and right-click. The 

shortcut menu appears. 

Note:  

o To view the symbol in the Model Tree, click Settings > Tree Filters > 

Annotations.  

o To select the symbol in the graphics window, select Annotation from the 

Filter list on the status bar. 

2. Click Move on the shortcut menu. 

3. Move the pointer to the new location. An outline of the symbol along with the 

leader line moves with the pointer. 

4. Click to place the symbol in the new location or middle-click to cancel the move 

operation. 

To Move a Symbol Using the Menu Manager 

1. Click Insert > Annotations > Symbol. The 3D SYMBOL menu opens. 

2. Click Move. 

3. Select the symbol in the Model Tree or graphics window. 

4. Move the pointer to the new location. An outline of the symbol along with the 

leader line moves with the pointer. 
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5. Click to place the symbol in the new location or middle-click to cancel the move 

operation. 

Dimensions 

Working with Dimensions 

About Z-extension Lines 

Z-extension lines are lines that Pro/ENGINEER automatically creates when you 

position a dimension such that the dimension does not intersect its reference in the 

Z-direction.  

Pro/ENGINEER creates a Z-extension line from the end of the witness line and 

perpendicular to the annotation plane. The Z-extension line extends to the 

dimension's reference, making the reference easier to locate. If the Z-extension line 

does not intersect the dimension's reference, Pro/ENGINEER does not create it. 

The Z-extension line is attached to the edge of the surface at a distance closest to 

the dimension witness line. The dimension witness line is aligned with the edge of 

the surface closest to the point where you place the dimension text in the direction 

of the witness line. Pro/ENGINEER displays the extension lines as dashed lines in 

hidden line color. 

Note: 

• When you create a dimension using the Intersect command on the ATTACH 

TYPE menu, Pro/ENGINEER creates a Z-extension line only if both the entities 

are located at the point of the intersection. 

• When you create a dimension using the Make Line command, Pro/ENGINEER 

does not display the line and the Z-extension line. 

• When Pro/ENGINEER creates a Z-extension line, it removes the default gap 

between the witness line and the dimension's reference. 

Example: Z-extension Lines 

The following examples are of Z-extension lines in linear, angular, diameter 

dimensions, and radius dimensions. 

Z-extension Lines in a Linear Dimension 

In the following figure, the Z-extension line is attached to the edge of the surface at 

a distance closest to the dimension witness line. 
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Z-extension Lines in an Angular Dimension 

The following figure shows Z-extension lines for angular dimensions. 

 

Z-extension Lines in a Diameter Dimension 

For diameter dimensions with two arrowheads, the Z-extension line extends from 

each arrowhead as shown in the following figure. 
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Z-extension Lines in a Radius Dimension 

For a radius dimension with a single arrowhead (no extensions), a single Z-extension 

line extends from the reference to the dimension arrowhead as shown in the 

following figure. 

 

For a radius dimension shown with flipped arrows with a leader line extension to the 

center, there are two Z-extension lines. One line extends to the reference, while the 

other extends to the center of the reference. 

 

About Modifying Attachment References for Dimensions 

You can modify the attachment references of all 3D dimensions such as driven or 

reference dimension Annotation Elements in 3D mode using the ATTACH TYPE 

menu that appears in one of the following ways: 

• When you click Edit Attach in the Dimension Properties dialog box. The 

Dimension Properties dialog box opens when you click Edit in the 

ANNOTATION FEATURE dialog box or when you right-click the dimension on 

the Model Tree or in the graphics window and click Properties on the shortcut 

menu.  

• When you click Edit Attachment on the shortcut menu that opens when you 

right-click the annotation on the Model Tree or in the graphics window. 
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When modifying the attachment references, you cannot create or select a different 

baseline reference for the dimension. You can modify the attachment reference of an 

ordinate baseline Annotation Element in 3D mode by replacing the reference from 

the ANNOTATION FEATURE dialog box.  

When you edit the attachments for a driven or reference dimension Annotation 

Element, the new references replace the automatically generated Annotation Element 

references. 

Note: You cannot undo or redo the changes to the dimension attachment references 

for ordinate baseline Annotation Elements. Therefore, you must be careful when 

modifying attachment references for ordinate baseline Annotation Elements as 

changing the references could cause the dependent ordinate dimensions to fail.   

To Modify Arrow Head Style of Leader Lines 

1. Select a dimension. 

2. Move the pointer close to the arrow head that you want to modify till the pointer 

changes to .  

3. Right-click and click Modify Arrow Style on the shortcut menu. The ARROW 

STYLE menu appears. 

4. Click the required arrow head style on the menu. Pro/ENGINEER updates the 

style in the graphics window. 

5. Click Done/Return. 

Tip: Using Configuration File Options to Modify the Number of Decimal 
Places 

Using the Number of decimal places box in the Dimension Properties dialog 

box, you can modify the number of digits for individual tolerances. This resets a 

tolerance to a default value corresponding to the specified number of decimal places. 

You can then change the value of individual tolerances.  

The value in the Number of decimal places box depends on the setting of the 

default_dim_num_digits_changes configuration option: 

• If you set it to yes (the default), the system sets the number of digits to the last 

value you entered. Also, when you create dimensions, it defaults to the number 

of digits associated with the Num Digits setting. 

• If you set it to no, it bases the value on the configuration file option 

default_dec_places. Also, it defaults to the value in default_dec_places for 

created dimensions. 

When a dimension appears in dual units, the system calculates the tolerance value of 

secondary units so that it is always within the limits established by the tolerance 

values in primary units. Thus, truncating, rather than rounding, to the secondary 

tolerances may occur. 
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To Modify the Number of Decimal Places in Dimensions 

1. Select a dimension and click Edit > Properties. The Dimension Properties 

dialog box opens. 

2. Type a new value in the Number of decimal places box and click OK. 

To Set Dimensions as Inspection Dimensions 

1. Select a dimension and click Edit > Properties. The Dimension Properties 

dialog box opens. 

2. Click Inspection and then click OK. The system encloses the value of each 

selected dimension in an oval box, along with any associated text. 

Note: To return the dimension to its original status, click Neither in the Dimension 

Properties dialog box. 

To Transform Existing Dimensions into Basic Dimensions 

1. Select a dimension and click Edit > Properties. The Dimension Properties 

dialog box opens. 

2. Click Basic and then click OK. The system encloses each dimension in a feature 

control frame. 

Note: To return the dimension to its original status, click Neither in the Dimension 

Properties dialog box. 

Working with Witness Lines 

About Modifying Witness Lines 

Witness lines are lines that indicate the start and end of a dimension. You can modify 

the witness lines of valid 3D dimensions as follows: 

• Erase witness lines 

• Restore erased witness lines 

• Insert jogs in witness lines 

• Remove jogs from witness lines 

• Insert breaks in witness lines 

• Remove breaks from witness lines 

• Clip witness lines 

• Align ends of witness lines 

• Skew witness lines 
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To Erase Witness Lines 

• To erase a single witness line: 

a. Select a dimension. 

b. Move the pointer close to the witness line that you want to erase till 

the pointer changes to .  

c. Right-click and click Erase Witness Line on the shortcut menu. The 

witness line is erased. 

• To erase one or more witness lines: 

a. Select one or more dimensions. 

b. Right-click outside the model in the graphics window. 

c. Click Erase Witness Lines on the shortcut menu. The valid witness 

lines are highlighted as you move the pointer over them. 

d. Move the pointer over a witness line. When it is highlighted, click to 

select it. If you want to erase more witness lines select additional witness 

lines by holding down the CTRL key. 

e. Middle-click. The selected witness lines are erased. 

• To erase one or more witness lines using the Dimension Properties dialog box: 

a. Select one or more dimensions. 

b. Right-click on the Model Tree or in the graphics window. 

c. Click Properties on the shortcut menu and go to the Display tabbed 

page. 

d. Click Erase. The valid witness lines are highlighted as you move the 

pointer over them. 

e. Select one or more witness lines and middle-click. The selected 

witness lines are erased. 

Note:  

• When you erase a witness line, the arrow next to it automatically changes to the 

default clipped arrow style, that is, a double arrow. You can modify the clipped 

arrow style using the Modify Arrow Style command. 

• You can erase only one witness line of a dimension at any given time. If you 

attempt to erase the second witness line of the same dimension, the first is 

automatically restored. 

• You cannot erase witness lines of ordinate dimensions. 

To Restore Erased Witness Lines 

• To restore erased witness lines: 

a. Select one or more dimensions. 



Pro/ENGINEER Fundamentals 

437 

b. Right-click outside the model in the graphics window. 

c. Click Show Witness Lines on the shortcut menu. All witness lines 

that are currently erased in the selected dimensions become visible. 

• To restore erased witness lines using the Dimension Properties dialog box: 

a. Select one or more dimensions. 

b. Right-click on the Model Tree or in the graphics window. 

c. Click Properties on the shortcut menu and go to the Display tabbed 

page. 

d. Click Show. All witness lines that are currently erased in the selected 

dimensions become visible. 

To Insert Jogs 

• To insert a jog: 

a. Select a dimension. 

b. Move the pointer close to the witness line to which you want to add a 

jog till the pointer changes to .  

c. Right-click and click Insert Jog on the shortcut menu. The witness 

line on which you want to insert a jog is highlighted as you move the 

pointer over it. 

d. Select a start point and an end point of the jog. The jog is added. 

Note: The start point must lie on the witness line. 

• To insert multiple jogs on one or more witness lines: 

a. Select one or more dimensions. 

b. Right-click outside the model in the graphics window. 

c. Click Insert Jogs on the shortcut menu. The witness lines on which 

you can insert jogs are highlighted as you move the pointer over them. 

d. Move the pointer over a witness line. When it is highlighted, select a 

start and an end point for the jog. The jog is added.  

Note: The start point must lie on the witness line. 

e. To add multiple jogs in the selected dimensions repeat step d. 

f. Middle-click when finished. 

Note:  

• When you insert a jog in a witness line Pro/ENGINEER adds a handle at the start 

and end points of the jog. These handles are called jog draggers. 

• If you attempt to place the second point of a jog within a break, the break is 

reduced or eliminated if the second point is beyond the break. 
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• You can reposition jogs by selecting the dimension and dragging the jog dragger 

to the required point. The dimension witness line changes shape as you move the 

dragger. You can move the dragger only in the XY-direction of the current 

annotation plane. 

• To position the jog end points with ease, set the orientation of the model same as 

the annotation plane of the dimension you are modifying. 

• The movement of the jog dragger closest to the attachment point of the 

dimension is restricted to movement that is parallel to the witness line. You can 

move additional jogs in the XY-direction. 

To Remove Jogs 

• To remove a jog from a witness line: 

a. Select one or more dimensions. 

b. Place the pointer over a jog dragger and right-click. 

c. Click Remove Jog on the shortcut menu. The jog dragger and its 

associated jog are removed. Jog dragger are handles at the start and end 

points of the jog. 

• To remove all jogs from a single witness line: 

a. Select a dimension. 

b. Move the pointer close to a witness line from which you want to 

remove a jog till the pointer changes to .  

c. Right-click and click Remove Jogs on the shortcut menu. All jogs on 

the witness line are removed. 

• To remove all jogs from one or more witness lines: 

a. Select one or more dimensions. 

b. Right-click outside the model in the graphics window. 

c. Click Remove All Jogs on the shortcut menu. All jogs on the witness 

lines of all selected dimensions are removed. 

• To remove jogs dynamically, drag the jog draggers at the jog points to overlap 

each other. 

Note: You cannot move the jog dragger beyond the clip witness line dragger or the 

dimension leader line. 

To Insert Breaks 

• To insert a break in a witness line: 

d. Select a dimension. 
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b. Move the pointer close to the witness line on which you want to insert 

a break till the pointer changes to .  

c. Right-click and click Insert Break on the shortcut menu.  

d. Select a start point and an end point for the break on the witness line. 

A break is added. 

• To insert multiple breaks in one or more witness lines: 

e. Select one or more dimensions. 

f. Right-click outside the model in the graphics window. 

g. Click Insert Breaks on the shortcut menu. The witness lines in which 

you can insert breaks are highlighted when you move the pointer over 

them. 

h. Move the pointer over a valid witness line. When the witness line is 

highlighted, select a start and an end point for the break on the witness 

line. The break is added. 

i. To add multiple breaks in the selected dimensions repeat steps d. 

e. Middle-click when finished. 

Note: When you insert a break in a witness line, Pro/ENGINEER adds a handle at the 

start and end points of the break. These handles are called break draggers. 

 

To Remove Breaks 

• To remove a break from a witness line: 

a. Select one or more dimensions. 

b. Place the pointer over a break dragger and right-click. 

c. Click Remove Break on the shortcut menu. The break is removed. 

Break draggers are handles at the start and end points of a break. 

• To remove all breaks from a single witness line: 

a. Select a dimension. 

b. Move the pointer close to a witness line from which you want to 

remove breaks till the pointer changes to .  

c. Right-click and click Remove Breaks on the shortcut menu. All breaks 

from the witness line are removed. 

• To remove all breaks from one or more witness lines: 

a. Select one or more dimensions. 

b. Right-click outside the model in the graphics window. 
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c. Click Remove All Breaks on the shortcut menu. All breaks from the 

witness lines of all selected dimensions are removed. 

• To remove breaks dynamically, drag the break draggers at the break points to 

overlap each other. 

About Clipping Witness Lines 

You can clip witness lines by using the Clip Witness Lines or Clip All commands on 

the shortcut menu. During the clipping operation, the end points of the selected 

witness lines are not aligned.  

When you use the Clip Witness Lines command:  

• The length of all selected witness lines of the selected dimensions is automatically 

adjusted based on the movement of the handle that you dragged and the current 

position of individual clipping draggers.  

• Selected witness lines of the angular and linear dimensions are clipped at the 

same time if the selected witness lines are parallel.  

• Pro/ENGINEER does not align the ends of witness lines automatically in the 3D 

mode. 

When you use the Clip All command: 

• The length of each witness line of the selected dimensions changes based on the 

movement of the handle that you dragged and the current position of individual 

clipping draggers.  

• For linear dimensions, you can clip the witness line only in a direction parallel to 

the witness line of the selected dragger. If you select multiple dimensions, then 

witness lines are clipped only for those dimensions whose witness lines are 

parallel to a dimension's witness line whose dragger you selected and clicked Clip 

All. 

• For angular dimensions, only those selected dimensions that share a common 

vertex with the dimension whose dragger you selected, are clipped. If you select 

multiple angular dimensions that do not share the same vertex, only those 

witness lines are clipped whose dimensions share a common vertex with the 

witness line dragger you selected to initiate the command. 

• You cannot clip linear and angular dimension witness lines at the same time. 

To Clip Witness Lines 

• To clip one or more witness lines: 

a. Select one or more dimensions. 

b. Right-click outside the model in the graphics window. 

c. Click Clip Witness Lines on the shortcut menu. The witness lines that 

you can clip are highlighted when you move the pointer over them. 
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d. Move the pointer over a witness line. When it is highlighted, click to 

select it. If you want to clip more witness lines select additional witness 

lines by holding down the CTRL key and selecting them.  

e. Middle-click. The selected witness lines display clipping draggers. 

f. Adjust the length of a witness line by dragging the handle. The length 

of each selected witness line is automatically adjusted based on the 

movement of the handle that you dragged and the current position of 

individual clipping draggers.  

g. Click outside the model in the graphics window when finished. 

• To clip all witness lines in the selected dimensions: 

a. Select one or more dimensions.  

b. Place the pointer over a witness line dragger and right-click. 

c. Click Clip All on the shortcut menu.  

d. Adjust the length of a witness line by dragging the handle. The length 

of each witness line in the selected dimensions is automatically adjusted 

based on the current position of individual clipping draggers. 

e. Click outside the model in the graphics window when finished. 

To Align Ends of Witness Lines 

1. Select one or more dimensions. 

2. Place the pointer over a clipping dragger of a witness line and right-click. 

3. Click Align Ends on the shortcut menu. Pro/ENGINEER aligns all the selected 

ends of witness lines that are parallel to the witness line that you selected and 

clicked Align Ends. 

Note:  

• For linear dimensions, Pro/ENGINEER aligns the witness lines of all the selected 

dimensions to points on a plane that intersects the clipping dragger over which 

you placed the pointer.  

• For angular dimensions, Pro/ENGINEER aligns the witness lines of all the selected 

dimensions to points at the same distance from the vertex as the clipping 

dragger over which you placed the pointer.  

About Skewing Witness Lines 

You can skew the witness lines of only one dimension at a time. When you skew the 

witness lines of a dimension, the witness lines are inclined according to the 

movement of the skew dragger. You can skew witness lines in a direction parallel to 

the dimension’s leader line. You can skew witness lines of dimensions with Z-

extension lines. 

You cannot skew the witness lines in the following cases: 
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• If dimensions have a single witness line. 

• If dimensions have witness lines that are on opposite sides of the dimension 

leader line. 

The witness lines snap to their default positions when you move the pointer near the 

default location of the witness lines. 

Note: You can skew only the witness lines of linear dimensions. 

To Skew Witness Lines of a Dimension 

1. Select one or more dimensions. 

2. Right-click outside the model in the graphics window. 

3. Click Skew Dimension on the shortcut menu. The skew draggers become 

available for all selected dimensions. The skew dragger is located at the midpoint 

of the dimension’s witness lines at some height above the dimension’s text.  

4. Drag the skew dragger of the dimension whose witness lines you want to skew. 

Pro/ENGINEER places the witness lines with an incline according to the 

movement of the skew dragger. You can skew only one dimension at a time. The 

skew dragger for that dimension disappears after you finish dragging it. The skew 

draggers of the other selected dimensions also disappear. 

Driven Dimensions 

About Driven Dimensions 

Driven dimensions are used by Pro/ENGINEER to measure the size and shape of 

features within a model. The value of a driven dimension changes when the size and 

shape of the features are modified. Driven dimensions can have tolerances, to which 

manufactured components can be accepted or rejected.  

Manipulation of the tolerances for a driven dimension is similar to that of the 

tolerances of regular dimensions. You can change the tolerance values and modify 

their format. A difference is that the driven dimension cannot be set to an upper or 

lower bound because the nominal value of the driven dimension is not changeable. 

Its value is derived from the measurement between the two reference entities.  

Driven dimensions can be included in Annotation features. 

About Annotation Plane Requirements for Dimensions with Surface 
References 

The Annotation plane requirements when creating a driven dimension that includes 

surface references are as follows: 

• Planar surface reference—The annotation plane must be perpendicular to the 

planar surface reference. 

Note: 
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o If the planar surface reference is perpendicular to the annotation plane and 

parallel to the other dimension reference, Pro/ENGINEER creates a linear 

dimension.  

o If the planar surface reference is perpendicular to the annotation plane but 

not parallel to the other dimension reference, then Pro/ENGINEER creates 

an angular dimension.  

• Cylindrical surface reference—The annotation plane must be perpendicular or 

parallel to the axis of the cylindrical surface. 

 Note: 

o If you select a cylindrical surface reference by clicking it and the annotation 

plane is perpendicular to the axis of the surface, Pro/ENGINEER creates a 

radius dimension. 

o If you select a cylindrical surface reference by double-clicking it and the 

annotation plane is perpendicular to the axis of the surface, Pro/ENGINEER 

creates a diameter dimension. 

o If you select a cylindrical surface reference by clicking it or double-clicking 

it and the annotation plane is parallel to the axis of the surface, no 

dimension is created and an error message is displayed. 

• Conic surface reference—The annotation plane must be perpendicular or parallel 

to the axis of the cone for a dimension to be created.   

• Spherical surface reference—There are no requirements for the annotation plane 

except those imposed by the other dimension reference. 

Note: If you select the spherical surface reference by clicking it or by double-

clicking it, Pro/ENGINEER creates a spherical radius dimension or diameter 

dimension, respectively. 

If the Annotation plane requirements are not fulfilled, then Pro/ENGINEER displays a 

message stating that it is unable to create a dimension. 

To Create a Driven Dimension in a Part or Assembly 

1. Define the active annotation orientation before creating the first annotation in 

any session by using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Dimension. The REFDIM menu appears with 

Create selected by default. If not then, click Create.  

3. Select entities, such as model edges or curves, to create the dimension between 

them. Use the ATTACH TYPE menu commands, if necessary, to attach the 

dimension to a surface, vertex, a midpoint of an entity, or a center of a circle or 

arc.  

4. Click the middle mouse button to place the dimension. 
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5. If the dimension is between two points, use one of the DIM ORIENT menu 

commands to specify the dimension orientation. If the dimension is attached to a 

spherical or cylindrical surface, use one of the ARC PNT TYPE menu commands 

to specify whether the dimension should be created from the center or tangent of 

the surface. 

6. Repeat Steps 2 through 5 to create more driven dimensions using the same 

Annotation plane. 

7. When finished, click Return > Done. 

Placing Dimensions Using the ATTACH TYPE Menu 

The ATTACH TYPE menu lets you select the point on the model to which you want 

to attach a driven or reference dimension. It contains the following commands: 

• On Entity—Attach the dimension to the entity at the pick point, according to the 

rules of creating regular dimensions. 

• On Surface—Attach the dimension to the surface. 

• Midpoint—Attach the dimension to the midpoint (on the screen) of the selected 

entity. 

• Center—Attach the dimension to the center of the circle or arc. 

• Intersect—Attach the dimension to the closest intersection point of two selected 

entities. 

• Make Line—Make a line to reference.  

Note: You can change the attachment type in the middle of making a dimension 

(for example, you can select one point as On Entity, then change to Center and 

select another point). 

Placing Dimensions Using the DIM ORIENT Menu 

When you create a driven or reference dimension between two reference entities, 

such as, circle or arc centers, datum points, or edge intersections, the DIM ORIENT 

menu lets you specify the dimension placement orientation. The DIM ORIENT menu 

contains the following commands: 

• Horizontal—Indicates the horizontal distance. 

• Vertical—Indicates the vertical distance. 

• Slanted—Indicates the shortest distance between two attachment points. This 

command is available only when the dimension is attached to points. 

• Parallel—Indicates distance in the direction parallel to the selected entity. Select 

an entity to determine the direction. 

• Normal—Indicates distance in the direction normal to the selected entity. Select 

an entity to determine the direction. 
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After you create the Annotation Element you can redefine the dimension orientation 

using the DIM ORIENT menu that appears when you click Orient in the Dimension 

Properties dialog box. The Dimension Properties dialog box opens when you 

perform one of the following actions: 

• Click Edit in the ANNOTATION FEATURE dialog box that opens when you right-

click the dimension in the model tree and click Edit Definition on the shortcut 

menu.   

• Right-click the dimension in the model tree or graphics window and click 

Properties on the shortcut menu.  

You can change the orientation of the selected dimension without changing the 

references or annotation planes. However, the changes to the orientation are 

retained even if you click Cancel in the Dimension Properties dialog box after the 

changes are made. Changing the orientation changes the driven value of the 

dimension. 

Placing Dimensions Using the ARC PNT TYPE Menu 

When you create a driven dimension attached to a spherical or cylindrical surface, 

the ARC PNT TYPE menu allows you to specify whether the dimension should be 

created from the center of the surface or tangent to it. This menu contains the 

following commands: 

Center—Creates a dimension from the axis or a point on the selected surface. 

Tangent—Creates a dimension from the tangent of the surface closest to the point 

selected on the surface with respect to the annotation plane. 

Concentric—Creates a linear dimension between the selected surfaces. This 

command is available only when both the selected surfaces are concentric. 

Note: The ARC PNT TYPE menu does not appear for driven dimensions attached to 

conical surfaces as Pro/ENGINEER automatically creates the dimension with the 

center as the reference.  

Example: Driven Dimensions With a Spherical Surface Reference 

When creating a driven dimension, if you select a spherical surface by clicking it or 

double-clicking it, Pro/ENGINEER creates a spherical radius or diameter dimension. 

The following figures display spherical dimensions and the prefix for the numerical 

dimension values.  

Spherical Diameter Dimension 
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Spherical Radius Dimension 

 

To Modify Tolerances of a Driven Dimension 

Manipulation of the tolerances for a driven dimension is similar to that of the 

tolerances of regular dimensions. You can change the tolerance values and modify 

their format. A difference is that you can not set an upper or lower limit of the driven 

dimension, because the nominal value of the driven dimension is not changeable. 

The system calculates the limits based on the measurement between the two 

reference entities and the tolerance values.  

Note: Make sure your environment is set to display dimension tolerances. Click 

Tools > Environment, select the Dimension Tolerances checkbox and click OK.  

1. Select a driven dimension in the Model Tree or on the screen.  

2. Right-click on the dimension name and select Properties from the shortcut 

menu. The Dimension Properties dialog box opens. 

3. To change the tolerance format, select one of the options from the Tolerance 

mode list: 

o Nominal—Only the nominal dimension value is displayed on the screen, 

but the upper and lower tolerance values are stored with the dimension and 

available for modification. 

o Limits—The dimension is displayed as two numbers, upper and lower limit. 

Upper limit is the nominal value plus upper tolerance. Lower limit is the 

nominal value minus lower tolerance. You can not modify the upper and 

lower limit values of a driven dimension, because its nominal value is not 

changeable. To modify the tolerance values, set the tolerance format to (As 

Is). 

o Plus-Minus—The dimension is displayed as nominal with plus-minus 

tolerances. The upper and lower tolerance values are independent. 

o +- Symmetric—The dimension is displayed as nominal with a plus-minus 

tolerance. The upper and lower tolerance values are the same. If at the 

time you switch to this format the values are different, the system sets the 

tolerance to the upper tolerance value. 

o +- Symmetric (Superscript)—Same as +- Symmetric. However, 

displays the plus-minus tolerance value at the half-way point of the 

dimension text and extending upwards.  

o (As Is)—Preserves the tolerance format and lets you modify the tolerance 

values. 
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4. Change the tolerance values as needed by typing the new values in the Upper 

tolerance and Lower tolerance boxes (or in the Tolerance box if the tolerance 

format is set to +- Symmetric). 

5. Click OK when finished. 

To Move a Driven Dimension 

1. Select the driven dimension in the Model Tree or graphics window and right-click. 

The shortcut menu appears. 

Note:  

o To view the driven dimension in the Model Tree, click Settings > Tree 

Filters > Annotations.  

o To select the driven dimension in the graphics window, select Annotation 

from the Filter list on the status bar. 

2. Click Move on the shortcut menu. Alternatively, click Move in the Dimension 

Properties dialog box that opens when you click Properties on the shortcut 

menu.  

3. Move the pointer to the new location.  

4. Click to place the driven dimension in the new location or middle-click to cancel 

the move operation. 

Reference Dimensions 

About Reference Dimensions 

Reference dimensions appear on models or in drawings for information only. 

Therefore, they are read-only and cannot be used to modify the model; however, 

they are automatically updated during regeneration if changes are made to the 

model. You can include reference dimension created between edges in Annotation 

features. 

You can use reference dimensions in place of some relations. For example, instead of 

defining a side of a triangle with the relation 

DIAGONAL = SQRT ((D3/2)^2 + D1^2) 

- you can use  

DIAGONAL = rd7 

Reference dimensions can be created in Part, Assembly, and Sketcher modes. They 

can also be created in Drawing mode, but only if you have a Detailed Drawings 

license. 

Reference dimensions are distinguished from standard dimensions in either of the 

following ways: 

• They are followed by the notation REF 
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• To have them appear in parentheses as the default, set the configuration file 

option parenthesize_ref_dim to yes. 

The parameter symbol for reference dimensions is rd# (or rsd# in the case of 

Sketcher). 

To Create a Reference Dimension 

1. Define the active annotation orientation before creating the first annotation in 

any session by using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Reference Dimension. The REFDIM menu 

appears with Create selected by default. If not then, click Create. 

3. Click Create. The ATTACH TYPE menu appears.  

4. Use the ATTACH TYPE menu commands, if necessary, to attach the dimension 

to an entity, a surface, a vertex, a midpoint of an entity, or a center of a circle or 

arc.  

5. Select entities, such as model edges or curves, to create the dimension between 

them. Alternatively, select two surfaces to measure the distance or angle 

between them.  

6. Click the middle mouse button to place the dimension.  

7. If the dimension is between two points, use one of the DIM ORIENT menu 

commands to specify the dimension orientation. If the dimension is attached to a 

spherical or cylindrical surface, use one of the ARC PNT TYPE menu commands 

to specify whether the dimension should be created from the center or tangent of 

the surface.  

8. Repeat Steps 2 through 6 to create more driven dimensions using the same 

Annotation plane. 

9. When finished, click Return > Done. 

Example: Some Reference Dimensions 
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To Create a Reference Dimension Between Surfaces 

1. Define the active annotation orientation before creating the first annotation in 

any session using the ANNOTATION ORIENTATION dialog box that opens 

when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Reference Dimension. The REFDIM menu 

appears with Create selected by default. If not then, click Create. 

3. Click Create. The ATTACH TYPE menu appears. 

4. Click On Surface. 

5. Select two surfaces to measure the distance or angle between them. After you 

select the second surface, Pro/ENGINEER creates and places the reference 

dimension. 

To Move a Reference Dimension 

1. Select the reference dimension in the Model Tree or graphics window and right-

click. The shortcut menu appears. 

Note:  

o To view the reference dimension in the Model Tree, click Settings > Tree 

Filters > Annotations.  

o To select the reference dimension in the graphics window, select 

Annotation from the Filter list on the status bar. 

2. Click Move on the shortcut menu. Alternatively, click Move in the Dimension 

Properties dialog box that opens when you click Properties on the shortcut 

menu.  

3. Move the pointer to the new location.  

4. Click to place the reference dimension in the new location or middle-click to 

cancel the move operation. 



Pro/ENGINEER Fundamentals – Help Topic Collection 

450 

To Delete a Reference Dimension 

1. Click Insert > Annotations > Reference Dimension. The REFDIM menu 

appears.  

2. Click Delete.  

3. Select the reference dimension. 

REF VIEW Menu 

The REF VIEW menu lets you set options for controlling the visibility of a reference 

dimension. It opens when you click Insert > Annotations > Reference 

Dimension and then click Set view on the REFDIM menu. It contains the following 

commands: 

• Any View—Make the reference dimension visible in all views. 

• Single View—Make the reference dimension visible only in the view in which it 

was created. 

Tip: Displaying View-Dependent Reference Dimensions 

When you associate a reference dimension with a view, Pro/ENGINEER does not limit 

the views in which that dimension can be displayed. Instead, Pro/ENGINEER provides 

a mechanism to display view-dependent reference dimensions in one or all views of 

the model. No action is required to turn this mechanism on or off. 

To Change the View Dependency of a Reference Dimension 

1. Reorient the model to the view in which the reference dimensions were created. 

2. Click Insert > Annotations > Reference Dimension. The REFDIM menu 

appears. 

3. On the REFDIM menu, click Show. 

4. Select a feature in the model to show the reference dimensions in the view. 

5. On the REFDIM menu, click Set View. The REF VIEW menu appears. 

6. On the REF VIEW menu, click Any view or Single view. 

7. Select the reference dimensions to which the model changes apply. 

8. Click Done to accept your selection. 
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Ordinate Dimensions 

About Ordinate Dimensions 

Ordinate dimension Annotation Elements and model ordinate dimension annotations 

use a single witness line and are associated with a baseline reference. Note the 

following points about ordinate dimensions. 

• You can create ordinate driven dimensions in 3D models as model annotations or 

as Annotation Elements. You must first define an ordinate baseline Annotation 

Element, and then define model ordinate dimension annotations and ordinate 

dimension Annotation Elements that reference the ordinate baseline Annotation 

Element. 

• Multiple ordinate dimension annotations and ordinate dimension Annotation 

Elements can reference the same ordinate baseline Annotation Element. Such 

annotations and Annotation Elements can belong to one or more annotation 

Features.  

• All ordinate dimension annotations and ordinate dimension Annotation Elements 

use the annotation plane of the baseline Annotation Element they reference. To 

change the orientation of an ordinate dimension group, you must change the 

orientation of the baseline. 

• You can select geometry such as a surface, linear entity, point, datum (datum 

plane or datum axis) or coordinate system as the reference for an ordinate 

baseline Annotation Element. You can also select an intent object, that is, a 

surface, linear entity, point, or coordinate system.  

• When creating a new ordinate dimension, you can choose to select an existing 

baseline annotation element or create a new one. If you create a new baseline 

Annotation Element, Pro/ENGINEER creates a new baseline Annotation Element in 

the same Annotation feature as the ordinate dimension Annotation Element being 

created. When creating a standalone ordinate dimension annotation, 

Pro/ENGINEER creates a new Annotation feature with an ordinate baseline 

Annotation Element. 

• If you choose to use an existing baseline to create a new ordinate dimension, you 

can select an existing ordinate baseline Annotation Element, or the geometry that 

it references or the ordinate dimension (either model or Annotation Element).  

style="x-condition: include_for_toyota;">About  

To Create an Ordinate Dimension 

1. Define the active annotation orientation before creating the first annotation in 

any session by using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Ordinate Driven Dimension or Ordinate 

Reference Dimension. The ATTACH TYPE menu appears enabling you to 

select an entity, a surface as a baseline. 
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Note: If the model contains an ordinate baseline Annotation Element, then 

Pro/ENGINEER prompts you to either select an existing baseline or create a new 

baseline. To select an existing baseline, click Select Existing Baseline. To 

create a new one, click Create a New Baseline. 

3. Click On Entity or On Surface and select an edge or surface. Select an 

attachment point and middle-click to select the dimension text placement point. 

An ordinate baseline Annotation Element is created and the On Entity, On 

Surface, Midpoint, Center, Intersect, and Make Line commands appear on 

the ATTACH TYPE menu.   

4. Use the ATTACH TYPE menu commands to select entities, such as model 

edges or curves, a surface, vertex, midpoint of an entity, or center of a circle or 

arc to create the dimensions.   

5. Middle-click to place the dimension.  

6. If the dimension is attached to a spherical or cylindrical surface, use one of 

the commands on the ARC PNT TYPE menu to specify whether the dimension 

should be created from the center or tangent to the surface.  

7. Repeat steps 2 through 6 to create more driven dimensions using the same 

Annotation plane. 

Setting the Display Style for Ordinate Dimensions 

You can set the display standard for ordinate dimensions by using Ordinate Style in 

the Properties tabbed page of the Dimension Properties dialog box. Consider the 

following points when setting the display standard. 

• If the model units are English, the default display standard of the dimension is 

ANSI. However, if the model units are Metric, the default display standard of the 

dimension is ISO.  

• If you change the units of the model after you create an ordinate dimension, the 

display standard of the existing ordinate dimensions does not change. However, 

subsequently created ordinate dimensions use the new display standard based on 

the current model units. 

• All dimensions, including the ordinate baseline Annotation Element, in a single 

ordinate dimension group use the same display standard. Changing the display 

standard of one dimension changes the display standard of all others in the 

group. An ordinate dimension group contains all the dimensions that reference 

the same ordinate baseline Annotation Element. 

• If you modify the display standard of an ordinate dimension by using the 

Dimension Properties dialog box after the dimension was created, then the 

next dimension that you create uses the last used display standard. However, 

Pro/ENGINEER does not save the display settings when you save the model. The 

display settings are valid only for a single window in the current Pro/ENGINEER 

session. 
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Tolerances 

Working with Dimensional Tolerances 

Dimensional Tolerance Basics 

About Dimensional Tolerances 

When you design a part, you specify allowable variations in size referred to as 

dimensional tolerances. All dimensions are controlled by tolerances (except basic 

dimensions, which, for the purpose of reference, are considered exact). 

In Pro/ENGINEER, you can express dimensional tolerances in one of two forms: 

general or individual. General tolerances apply to those dimensions that appear in a 

nominal format, that is, without tolerances. They are displayed in a tolerance table. 

Individual tolerances specify individual dimensions. 

You can set the tolerance standard as ANSI or ISO and drive dimensional tolerances 

using a set of tolerance tables.  

• When you switch from ISO to ANSI, the system assigns the ANSI tolerances 

based on the number of digits in the nominal dimension and deletes the tolerance 

table reference. 

• When you switch from ANSI to ISO, a set of tolerance tables drives the ISO-

standard tolerances. 

About Basic Dimensions 

A basic dimension is a theoretically exact dimension and does not have tolerances. 

The following figure shows how Pro/ENGINEER indicates basic dimensions in a model. 

You can create basic dimensions using the GEOM TOL menu or the Modify 

Dimension dialog box. 

 

1. Dimension in limits format 

2. Dimension after changing into basic 
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To Temporarily Display Dimension Tolerances  

Use the following procedure to temporarily display dimension tolerances during your 

current Pro/ENGINEER session (default settings remain the same):  

1. Click View > Display Settings > Model Display. The Model Display dialog 

box opens. 

2. Under Display on the General tabbed page, select or clear the Dimension 

tolerances check box. 

3. Click Apply > OK. 

Note: You can also temporarily display tolerance dimensions by the using the 

following procedure: 

a. Click Tools > Environment. 

b. Select or clear the Dimension tolerances check box. 

c. Click Apply > OK.  

To Set the Dimensional Tolerance Format 

Set the configuration file option tol_mode to one of the following values: 

• nominal—Displays dimensions without tolerances. 

• limits—Displays dimensions as upper and lower limits. 

• plusminus—Displays dimensions as nominal with plus-minus tolerances. The 

positive and negative values are independent. 

• plusminussym—Displays dimensions as nominal with a single value for both the 

positive and the negative tolerance. 

• plusminussym_super—Same as plusminussym. However, displays plus-minus 

tolerance beginning at the half-way point of the dimension text extending up. 

Note: 

• When you bring in groups from other models, they carry the Tolerance Display 

mode that was in effect when they were created.  

• In order to change the tolerance display for dimensions, the tolerance display 

must be shown. If the tolerance table is not visible on the screen, the 

Dimension dialog box will not allow the tolerance mode to be changed. 

Tip: Using Configuration File Options to Modify Dimensional Tolerance 
Format 

You can set the default display for dimension tolerances using the configuration file 

option tol_mode.  

Using the configuration file option maintain_limit_tol_nominal, you can maintain 

the nominal value of a dimension regardless of the changes that you make to the 

tolerance values. 
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If you set it to yes, the system does not modify the nominal value of a dimension 

with a Limits tolerance format when you set the format to Limits or change the 

value of the upper or lower tolerance. 

Controlling the Display of Dimension Tolerances 

Control the display of dimension tolerances by setting configuration options and 

tolerance values. Dimension tolerance values are displayed as one of the following: 

o nominal—Without tolerance 

o limits—Upper and lower limits 

o plusminus—Upper and lower tolerance 

o plusminussym—Nominal with single tolerance 

o plusminussym_super—Same as plusminussym. However, displays the plus-

minus tolerance value at the half-way point of the dimension text extending 

upwards.  

The order by which you set the configuration options to display dimensional 

tolerances is: 

Action Configuration Option 

1. Display tolerance tol_display to yes 

2. Set default type of tolerance 

display 

tol_mode to nominal, limits, 

plusminus, plusminussym, or 

plusminussym_super 

3. Set display to 1000 display_tol_by_1000 to yes 

4. View tolerance values in 2D 

(Drawing mode only) 

display_dwg_tol_tags to yes 

Note: Pro/ENGINEER can multiply a tolerance value for nonangular dimensions 

by 1000. The tolerance value is displayed in the graphics area (only) as x, but is 

interpreted by Pro/ENGINEER 0.00x.  

Specifying Default Dimensional Tolerances 

When you begin creating a model, Pro/ENGINEER uses default dimensional tolerance 

values. Therefore, you must specify default tolerances beforehand by setting the 

configuration file options linear_tol and angular_tol. Using linear_tol, you can 

set default tolerances for integer dimensions as well.  

A linear dimensional tolerance does not have to have the same number of decimal 

places as the dimension. That is, dimensions can acquire tolerances that have a 

higher significant number of decimal places (num digits).  

For example, a dimension with six decimal places can have a tolerance value with 

seven decimal places. To set the default display of linear dimensional tolerances, 

specify the value of linear_tol as follows: 
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# tolerance x 

- where # is an integer representing the number of decimal digits for the dimension, 

tolerance represents the default tolerance value, and x specifies the number of 

decimal digits for the tolerance.  

The x value must be equal to or greater than the # value. If x is less than #, the 

system uses the default value (equal to the number of decimal digits for the 

dimension) and rounds it to the significant number of digits of the dimension. 

Note: If you do not include x in the value, the system sets the default display 

equal to the number of decimal digits of the dimension.  

Example 

Linear_tol 0 .05 2 

For the tolerances specified in the example, a dimension of a whole number 

would have a tolerance of .05. 

When you begin creating a part, the system displays a table at the bottom of the 

window with the current default tolerances. This table appears only when you have 

set the configuration file option tol_display to yes.  

If you have not specified tolerances, Pro/ENGINEER assumes the system defaults. 

System and User-Supplied Tolerance Tables 

The configuration file option tolerance_table_dir sets the default directory for a 

user-defined tolerance table. All Holes and Shafts tables overwrite existing tables 

when loaded.  

When loading General and Broken Edge tables, keep in mind the following: 

• If you load one table that has the same set of class names as the model, the 

system accepts the new table.  

• If you load a table that contains class names that conflict with those already 

loaded in the system, the system does not load those class names.  

• If you load two tables with class names that do not conflict with those in the 

system, but that are different from them, you overwrite the ones in the system. 

• If the default class of the model does not exist in the new names, you must 

specify a new class. 

After you load the new tables, the system assigns the new dimension tolerances. 

When you regenerate the model, the system reassigns all the tolerances of the 

dimensions from the tolerance tables. If you modify a dimension tolerance, it deletes 

the tolerance table reference for that dimension, and the tolerance value remains the 

same until you modify it again or reassign the tolerance table.  

Example: Tolerance Formats 

The tolerance limit in this example is x.xx = 0.01. 
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1. Nominal 

2. Limits 

3. Plus-Minus 

4. +/- Symmetric 

To Modify a Tolerance Dimension Format 

1. Select a dimension and click Edit > Properties. The Dimension Properties 

dialog box opens. 

2. Select a tolerance format from the Tolerance mode list.  

3. Click OK. 

To Modify Default Tolerance Values 

1. Set the filter to Annotation. 

2. Select the default tolerance value in the table shown at the bottom of the screen 

for ANSI tolerances and click Value on the shortcut menu. 

3. Type a new value. 

To Modify Individual Tolerance Values 

1. Select a dimension and click Edit > Properties. The Dimension Properties 

dialog box opens. 

2. Change any of the following values, as necessary; then click OK:  

o For the Limits format, type a new value in the Upper limit and Lower 

limit boxes. 

o For the Nominal, Plus-Minus and (As Is) formats, type a new value in the 

Nominal value, Upper tolerance, and Lower tolerance boxes.  

o For the +–Symmetric formats, type a new value in the Nominal value and 

Tolerance boxes. 
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Note: The tolerance table must be set to none if a tolerance value of a table-

driven tolerance is to be modified. 

Setting Up Tolerances 

To Set the Dimension Bounds 

When you design a model, you expect the actual part dimensions to be within certain 

predetermined limits of size. Pro/ENGINEER defines these limits of size—upper and 

lower dimension boundaries—as dimension bounds. The system creates model 

geometry based on nominal values for each dimension.  

You can create a hypothetical model of a part or assembly based on upper and lower 

allowable dimensions, and later use this new geometry to measure the effects of 

various analysis functions. 

1. Click Edit > Setup > Dim Bound. 

2. On the DIM BOUND menu, do one of the following: 

o Choose Set All to set all part dimensions to the specified boundary (in 

Assembly mode, select parts or subassemblies). 

o Choose Set Selected to set only selected dimensions to the specified 

boundary.  

3. Specify the value limits by choosing one of the following commands: 

o Upper—Sets the dimension value to its maximum (generates geometry 

based on a nominal dimension value plus the tolerance).  

o Middle—Sets the dimension value to the nominal value plus the mean of 

the upper and lower tolerance values. 

o Lower—Sets the dimension value to its minimum (generates geometry 

based on a nominal dimension value minus the tolerance). 

o Nominal—Sets the dimension value to nominal (generates geometry based 

on exact ideal dimensions). 

4. Select part features to display dimensions whose boundaries must be set. 

5. Select the dimensions. 

6. Click Done to accept the dimension bounds, or click Quit to abort. 

7. To reset the part to its original state, click DIM BOUND > Set All > Nominal. 

Note: When you modify dimension bounds, the system generates geometry based 

on new dimensions. To reflect these changes, it updates reference dimensions 

present in the model accordingly. The part dimensions appear grey until the 

dimension bounds are set back to normal. 
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Tolerance Stack-Up Measurement 

When you set new dimension bounds, the system generates new model geometry 

from which you can obtain various engineering information, for example, tolerance 

stack-up, clearance and interference calculations, mass properties, assembly 

constraints, measurement, and reference dimensions. 

Tolerance stack-up is the cumulative tolerance that occurs when Pro/ENGINEER uses 

a series of dimensions with tolerances to dimension a certain feature in a part or an 

assembly member. To determine the tolerance stack-up for a particular model, you 

must first set dimensional bounds.  

For a part, set dimension bounds for selected dimensions; for an assembly, set 

dimension bounds for selected assembly members. After you have regenerated the 

model according to the new dimension bound settings, you can use the Measure 

command from the Analysis menu to calculate the tolerance stack-up. 

Example: Modifying Tolerance Values 

After you modify the tolerance value for a selected dimension, when you switch to 

the nominal format, the dimension automatically accepts the default tolerance.  

For example: Consider a case in which the tolerance of a dimension appears in 
symmetric format. If you modify it from 100.00 ± 0.01 to 100.00 ± 0.05, when you 

change the dimension format back to nominal, the tolerance acquires the nominal 
default value (for example, ± 0.01). After changing the format back to symmetric, 

the value appears as 100.00 ± 0.01. 

2 

1 

1. Modify upper tolerance to -.02 

2. Modify lower tolerance to -.02 

To Work with Dimension Bound Groups 

1. Click Edit > Setup > Dim Bound > Dim Bnd Table. 

2. Using the commands in the DIMBND TABLE menu, do one of the following: 

o Use Save Current to save the current dimension bound information as a 

separate named set in the dimension bound table. 

o Use Apply Set to select a predefined dimension set that is stored in the 

table and make it the current set in the table. 

o Use Delete Dim to remove a dimension from the dimension bound table. 
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o Use Edit to edit the dimension bound table using Pro/TABLE (and enter new 

dimensions if desired). 

o Use Show to show the dimension bound table without editing capabilities. 

ANSI-Standard Models 

To Create an ANSI-Standard Model in Part or Assembly Mode 

1. Click Edit > Setup. The menu manager opens. 

2. Click Tol Setup > Standard > ANSI. 

Pro/ENGINEER loads the system and user-supplied tables, and the General table 

drives all dimensions. 

ISO-Standard Models 

To Create an ISO-standard Model in Part or Assembly Mode 

1. Click Edit > Setup. The menu manager opens. 

2. Click Tol Setup > Standard > ISO/DIN. 

Pro/ENGINEER loads the system and user-supplied tables, and the General table 

drives all dimensions. 

ISO-Standard Models 

The system loads the tolerance tables into the model when you create it as an ISO-

standard model or switch the tolerance standard from ANSI to ISO.  

To create the model as an ISO-standard model, set the configuration file option 

tolerance_standard to ISO. Because the tables determine how the model 

regenerates, the system stores them permanently with the model and you can only 

use them with driving dimensions.  

Four types of tolerance tables are available: 

• General (one per model) 

• Broken Edge (one per model) 

• Holes (several per model) 

• Shafts (several per model) 

When you create a dimension, the system assigns it to the General table. When you 

assign the dimension to the tolerance table, the tolerance table and its dimension 

value govern the tolerance values of the dimension. You can switch the tolerance 

table reference of the dimension to any other table. 
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Changing Tolerance Values 

To Change the Tolerance Class 

Each ISO-standard model has an extra attribute called the tolerance class, which 

determines the general coarseness of the model.  

The configuration file option tolerance_class sets the default tolerance class for 

ISO models (the default is medium). The system uses the tolerance class together 

with the dimension value when retrieving tolerances for General or Broken Edge 

dimensions.  

1. Click Edit > Setup. The PART SETUP or ASSEM SETUP menu appears.  

2. Click Tol Setup > Model Class. 

3. From the TOL CLASSES menu, select a class name. 

4. All dimensions driven by the General or Broken Edge table obtain new tolerance 

values. Regenerate the model. 

To Change the Tolerance Table Reference 

1. Click Edit > Setup > Tol Setup > Tol Tables. The TOL TBL ACT menu appears 

with the following commands: 

o Modify Value—Displays the tables in the TOL TABLES menu. You can 

modify their contents using Pro/TABLE. 

o Retrieve—Retrieves a set of tables into the model. 

o Save—Saves the tolerance table. 

o Show—Displays the tolerance table. 

2. Do one of the following: 

o Choose Modify Value, select the table by choosing General Dims or 

Broken Edges, and select the dimensions. 

o Choose Holes or Shafts; then type the table name and class number. Hole 

and shaft tables must be retrieved into the model before values in the table 

can be modified. 

Tolerance Table Reference 

All instances in a family share the same set of tolerance tables, the same tolerance 

standard, and the same class. When changing the tolerance table reference, 

remember the following: 

• If you modify model units, but keep all of the dimension values the same, the 

system updates the tolerance values to reflect the change in the overall model 

size. 
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• If a Holes or Shafts tolerance table drives the tolerances of a dimension, you can 

not show it in a plus-minus symmetric format. The system assumes that the 

General and Broken Edge tables have symmetric values. 

• If you place a dimension tolerance in a Family Table, the system deletes its 

tolerance table reference. Also, if you switch a model from ANSI to ISO, or vice 

versa, it preserves the tolerances in the Family Tables and does not assign table 

references to those dimensions. 

• If a dimension value falls outside ranges specified in the table, the system uses 

the closest range to obtain tolerances (that is, it uses the last range in the 

system table (2000–4000) to determine tolerances for dimension values of 2000 

or greater). 

Example: A Tolerance Table 

 

TABLE_TYPE GENERAL    

TABLE_NAME DEFAULTS    

TABLE_UNIT MILLIMETER    

RANGE_UNIT MILLIMETER    

DESCRIPTION 0.05–3  3 – 6 6 – 30 

FINE 0.05–  0.05 0.1 

MEDIUM 0.1  0.1 0.2 

COARSE 0.2  0.3 0.5 

VERY COARSE 0.5  0.5 1 

Example: Tolerance Table (Holes) 

The following example shows a Holes table. 

TABLE_TYPE HOLES     

TABLE_NAME A     

TABLE_UNIT MICROMETER     

RANGE_UNIT MILLIMETER     

BASIC SIZE 9 10 11 12 13 

—3 295/270 310/270 330/270 370/270 410/270 

3 - 6 300/270 318/270 345/270 390/270 450/270 

6 - 10 316/280 338/280 370/280 430/280 500/280 

10 - 18 333/290 360/290 400/290 470/290 630/300 
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18-30 352/300 384/300 430/300 510/300 700/310 

30 - 40 372/310 410/310 470/310 560/310 710/320 

40 - 50 382/320 420/320 480/320 570/320 800/340 

50–65 414/340 460/340 530/340 640/340 820/340 

Working with Geometric Tolerances 

About Setting Reference Datum 

About Setting Reference Datum 

Before you can reference a datum plane or axis in a GTOL, you must set it as a 

reference. You can set a reference datum using  and . 

If you set a reference datum using , then Pro/ENGINEER creates a set 

datum tag and displays the datum name in a box that is attached to the datum. This 

is the old style display of set datum tag. 

If you set the reference datum using , then Pro/ENGINEER creates a set 

datum tag as a standalone annotation placed on an annotation plane and displays 

the datum name in a box attached to a solid triangle. This solid triangle is attached 

to the datum. 

The old_style_set_datum configuration option allows you to control the display of 

 in the Datum or Axis dialog box. Set the value of this configuration 

option to no if you do not want the Datum or Axis dialog box to display . 

The default for this option is yes. 

After you have set a datum, you can still use it in the usual way to create features 

and assemble parts. 

To Set a Reference Datum 

1. Define the active annotation orientation before creating the first annotation in 

any session using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears. 

3. Click Set Datum and select the datum plane or axis. The Datum or Axis dialog 

box opens. 

o Under Type,  is selected by default.  
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o Under Placement, On Datum is selected by default and Pro/ENGINEER 

displays the datum name in a box attached to the datum in the graphics 

window. 

o On Geometry is not available. 

Note: You can also open Datum or Axis dialog box by clicking Properties on 

the shortcut menu that appears when you right-click a datum plane or a datum 

axis, respectively, on the Model Tree or in the graphics window.  

4. To specify a placement type other than On Datum, click one of the following 

under Placement.  

o In Dim—Click to place the set datum tag attached to the dimension.  

o In Gtol—Click to place the set datum tag attached to the GTOL. 

5. Depending on the placement type that you have selected, perform the following 

to place the set datum tag. 

o For In Dim, select a dimension in the graphics window. The set datum tag 

is placed on the dimension and is displayed with the datum name in a box 

that is attached to the dimension.  

o For In Gtol, select a GTOL in the graphics window. The set datum tag is 

placed on the GTOL and is displayed with the datum name in a box that is 

attached to the GTOL. 

6. If required, change the selection of the dimension or GTOL using Pick Dim or 

Pick Gtol. 

7. If required, type a new name in the Name box of the Datum dialog box and click 

OK. 

Note: 

o You can change the name by choosing Name from the PART SETUP or 

ASSEM SETUP menu. 

o You can blank a reference datum plane only by placing it on a layer and 

then blanking the layer.  

o The Surface and Define options in the Datum dialog box are used to 

create 3D datums in drawings. 

o To return the datum to its unset state, click . 

To Set a Reference Datum Using Set Datum Tag Annotations 

1. Define the active annotation orientation before creating the first annotation in 

any session using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears. 
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3. Click Set Datum, and then select the datum plane or axis. The Datum or Axis 

dialog box opens. 

Note: You can also open the Datum or Axis dialog box by clicking Properties 

on the shortcut menu that appears when you right-click a datum plane or datum 

axis respectively on the Model Tree or in the graphics window. 

4. Click  under Type. On Geometry under Placement is selected by 

default. 

5. To specify the placement type click one of the following under Placement.  

o On Datum—Click to place the set datum tag on the selected datum.   

o In Dim—Click to place the set datum tag attached to the dimension. Pick 

Dim is selected by default.  

o In Gtol—Click to place the set datum tag attached to the GTOL. Pick Gtol 

is selected by default.  

o On Geometry—Click to place the set datum tag on a geometry. Pick 

Geom is selected by default. 

6. Depending on the placement type that you have selected, perform the following 

to place the set datum tag.  

o For On Datum, the set datum tag is placed on the datum in a default 

position.  

o For In Dim, select a dimension in the graphics window. The set datum tag 

is placed on the dimension. The selected dimension determines the 

annotation plane of the set datum tag annotation.  

o For In Gtol, select a GTOL in the graphics window. The set datum tag is 

placed on the GTOL. The selected GTOL determines the annotation plane of 

the set datum tag annotation.  

o For On Geometry, select a geometry. The set datum tag is placed on the 

geometry at the selected location. 

Note: On geometry placement is limited to coplanar surfaces with set 

datum planes and cylindrical surfaces that share a center with a set datum 

axis, or any edge by a coaxial cylinder, or a cylindrical curve that is coaxial 

with the datum axis.  

7. If required, specify a new location for the set datum tag annotation. 

o To specify a new location on the datum axis click Pick on Datum. Select a 

point on the axis. The set datum tag is placed at the selected point. 

Note: Pick on Datum is not available if you are creating a set datum tag 

annotation for a datum plane. 

o Similarly, to specify a new location for the set datum tag annotation on the 

geometry use Pick Geom. 
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o To specify a new dimension or GTOL use Pick Dim or Pick Gtol, 

respectively.  

8. If required, type a new name in the Name box of the Datum dialog box and click 

OK.  

Note: 

o You can blank a reference datum plane only by placing it on a layer and 

then blanking the layer.  

o The Surface and Define options in the Datum dialog box are used to 

create 3D datums in drawings. 

o To return the datum to its unset state, click . 

o To display the default set datum, that is, display the datum name in a box 

attached to the datum feature, click . 

Creating Geometric Tolerances 

About Geometric Tolerances 

Geometric tolerances (GTOLs) provide a comprehensive method of specifying where 

on a part the critical surfaces are, how they relate to one another, and how the part 

must be inspected to determine if it is acceptable.  

They provide a method for controlling the location, form, profile, orientation, and run 

out of features. When you store a Pro/ENGINEER GTOL in a solid model, it contains 

parametric references to the geometry or feature it controls—its reference entity—

and parametric references to referenced datums and axes. As a result, 

Pro/ENGINEER updates a GTOL’s display when you rename a referenced datum.  

In Assembly mode, you can create a GTOL in a subassembly or a part. A GTOL that 

you create in Part or Assembly mode automatically belongs to the part or assembly 

that occupies the window; however, the GTOL can refer only to set datums belonging 

to that model itself, or to components within it. It cannot refer to datums outside of 

its model in some encompassing assembly, unlike assembly created features. 

You can add GTOLs in Part or Drawing mode, but they are reflected in all other 

modes. Pro/ENGINEER treats them as annotations, and they are always associated 

with the model. Unlike dimensional tolerances, though, GTOLs do not affect part 

geometry.  

When adding a GTOL to the model, you can attach it to an edge, existing dimension, 

or existing GTOL, as well as display it as a note without a leader. However, before 

you place the GTOL, you must set datums and basic dimensions.  

style="x-condition: include_for_toyota;">  
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To Transform Existing Dimensions into Basic Dimensions 

1. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears. 

2. Click Basic Dim.  

3. Select dimensions. As you select each one, the system encloses it in a feature 

control frame.  

Note: To change the dimensions back to their original status, choose GEOM TOL 

> Clear before exiting the menu. 

4. Click EXIT > Done. 

To Set Inspection Dimensions 

1. You can set dimensions for inspection according to the DIN standard using the 

GEOM TOL menu or the Modify Dimension dialog box. 

 

2. Click Insert > Annotations > Geometric Tolerance.  

3. On the GEOM TOL menu, click Inspect Dim.  

4. Select dimensions. The system encloses the value of each selected dimension in 

an oval box, along with any associated text.  

Note: To change the dimensions back to their original status, choose GEOM TOL 

> Clear before exiting the menu. 

5. Click EXIT > Done. 

To Create a Geometric Tolerance in a Part 

To add a GTOL to a model, you may use two, three, or all four tabs of the 

Geometric Tolerance dialog box, depending on the specific characteristics of the 

GTOL you are creating. This section explains the general process for creating a GTOL 

in a part and presents an example. 

1. Define the active annotation orientation before creating the first annotation in 

any session by using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears. 

3. Click Specify Tol. The Geometric Tolerance dialog box opens. 

4. Specify the model in which to add the GTOL. By default, the current GTOL model 

is the current model. 
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5. Select the GTOL type and the reference entity (the entity to which the GTOL 

applies). 

6. Select the placement type and click Place Gtol. If you are placing the GTOL on a 

dimension or another GTOL, select the dimension or GTOL. If you are placing the 

GTOL with any kind of leader, select the item or items to attach the GTOL.  

Note: As you continue creating the GTOL, the system updates it on the model. 

You can check your work as you go along and make corrections, if necessary. 

7. Specify the datum reference or references and material condition or conditions, if 

applicable. 

8. Type a tolerance value and material condition, if applicable. 

9. Specify symbols and modifiers, the profile direction, and the projected tolerance 

zone, if applicable. The completed GTOL now appears in the model.  

10. Do one of the following: 

o Close the dialog box and save the changes by clicking OK. The system 

clears the reference entity selection and placement information from the 

dialog box, but retains all other data. When you reenter GTOL Creation 

mode, it retains all commands in the previous session of GTOL creation for 

the object in the current window. 

o Click New Gtol to continue.  

o Delete the GTOL from the model by choosing GEOM TOL > Clear.  

o Exit GTOL Creation mode and cancel the changes by clicking Cancel. 

To Specify the Geometric Tolerance Type 

1. Click Insert > Annotations > Geometric Tolerance. 

2. On the GEOM TOL menu, click Specify Tol. The Geometric Tolerance dialog 

box opens.  

The left side of the dialog box displays the GTOL symbols available for selection. 

When you place the cursor on one of the GTOL symbols, the type appears in the 

dialog box status line.  

The following table shows the types of tolerances available and the appropriate types 

of entities that you can reference. Pro/ENGINEER guides you in building a GTOL by 

limiting your choices to those that make sense in the context of the information 

already provided. The system also does error checking to help you avoid mistakes in 

selecting entities and datums.  

Start by selecting a tolerance type; then select the reference entity, specify tolerance 

values, and so on. When you have fully defined the GTOL and placed it, the system 

informs you that the GTOL is complete. 
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Class Type  Symbol Reference Entity 

Form Straightness 

 

 

Flatness 

 

Circularity 

 

Cylindricity 
 

Surface of revolution, axis, 

straight edge 

 

Plane surface (not datum 

plane) 

 

Cylinder, cone, sphere 

 

Cylindrical surface 

Profile Line 

 

Surface  

Edge 

 

Surface (not datum plane) 

Runout Circular 

 

Total  

Cone, cylinder, sphere, 

plane 

 

Cone, cylinder, sphere, 

plane 

Orientation Angularity 

 

Parallelism 

 

Perpendicularity  

Plane, surface, axis 

 

Cylindrical, surface, axis 

 

Planar surface 

Location Position 

 

Concentricity 

 

Symmetry 
 

Any 

 

Axis, surface of revolution 

 

Any 

To Specify the Model References to Place a GTOL 

1. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears. 

2. Click Specify Tol. The Geometric Tolerance dialog box opens. 

3. Use the Model Refs tabbed page, to specify the model to which to add the 

GTOL, choose the reference entity to use, and place the GTOL in the model. 

Model—Specifies the model in which to add the GTOL. You must explicitly select 

the model first. You can select the top model from the Model list or click Select 

Model to select a submodel. If you are in Part mode, the current part name 

appears in the Model field and you have no choice. If you are in Assembly mode, 

by default the system selects the top assembly.  

Reference: To Be Selected—Specifies the reference entity type (edge, axis, 

surface, feature, datum, entity, or none). Select an item from the Type list or 

click Select Entity.  
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Note: Not all reference entity types are available for all GTOL types. You must 

select a new entity whenever you change the entity type. You cannot complete 

the creation of a GTOL until you select a reference entity. The reference entity is 

the geometry or feature that the GTOL controls; you must not use it in place of a 

set datum or as an attachment type for the GTOL.  

Placement: To Be Placed—Places the GTOL in the model. Select one of the 

following items from the Type list and click Place GTOL:  

o Dimension—Attaches the GTOL to a dimension.  

o With Leader—Attaches the GTOL to on or multiple edges or surfaces by 

using leader lines. 

o Normal Leader—Attaches the GTOL to an edge along a leader line that is 

perpendicular to the selected edge. 

o Tangent Leader—Attaches the GTOL to an edge along a leader line that is 

tangent to the selected edge, orienting the GTOL text box at the same 

angle as the leader. 

o Other GTOL—Attaches the new GTOL to an existing one. You cannot attach 

the GTOL to an existing GTOL attached to a dimension. 

4. To place a GTOL attached to a dimension or other GTOL, select the dimension or 

GTOL. 

5. To place a GTOL attached with any kind of leader,  

a. For With Leader placement type, you can select the attachment type: 

On Entity—Attaches the GTOL to model edges. 

On Surface—Attaches the GTOL to points on model surfaces. 

b. Select the attachment point for the leader.  

For Normal Leader and Tangent Leader placement, the selected entity 

also specifies the GTOL orientation.  

If you are using With Leader placement, you can select multiple 

attachment points by holding down the CTRL key, then click Done when 

finished. 

c. Select the placement location for the GTOL anywhere on the screen. 

The system places the GTOL in this location, with the leaders pointing to 

the attachment points. 

To Specify GTOL Datum References and Material Conditions 

Click GEOM TOL > Specify Tol. The Geometric Tolerance dialog box opens.  

Using the Datum Refs tabbed page, you can specify the datum references and 

material conditions for a GTOL, as well as the value and datum reference of a 

composite tolerance. 
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• Datum References—Specifies the primary, secondary, and tertiary datum 

references for any GTOL that permits datum references. Click Primary, 

Secondary, or Tertiary and select an item from the Basic and Compound lists. 

The lists contain the currently selected datum and all other datums in the current 

GTOL model. If you want to select another set datum or axis, click the select 

arrow. For basic and compound datum references, you can also specify a material 

condition by selecting an item from the Basic and Compound lists.  

• Composite Tolerance—Creates a composite GTOL. Type a value in the Value 

box and select the datum references to show from the Datum Reference list. 

Note: The reference entity is the geometry or feature that the GTOL controls; 

you must not use it in place of a set datum or as an attachment type for the 

GTOL. 

To Specify GTOL Tolerance Value and Material Conditions 

Click GEOM TOL > Specify Tol. The Geometric Tolerance dialog box opens.  

Using the Tol Value tabbed page, you can specify the tolerance value and material 

condition. 

• Tolerance Value—Specifies the tolerance value. Type a value in the Overall 

Tolerance box, or select the Per Unit Tolerance check box and type a value in 

the Value/Unit and Unit Length boxes (or Unit Area for some GTOL types).  

• Material Condition—Specifies the material condition as LMC, MMC, RFS, or 

RFS/Default. 

•  

LMC 

 

Least material condition 

MMC 

 

Maximum material condition 

RFS 

 

Regardless of feature size 

RFS/Default  RFS, but does not show a symbol in 

frame 

To Specify GTOL Symbols and Modifiers 

1. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears. 

2. Click GEOM TOL > Specify Tol. The Geometric Tolerance dialog box opens. 

3. Using the Symbols tabbed page, you can specify the following: 
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o Symbols and Modifiers—Specifies the GTOL symbols and modifiers. 

Select the ASME Y14.41 Style,Statistical Tolerance, Diameter 

Symbol, Free State, All Around Symbol, or Tangent Plane check box. 

o Projected Tolerance Zone—Specifies the location of the projected 

tolerance zone. Select None, Below GTOL, or Inside GTOL. You can also 

specify the height of the projected tolerance zone by typing a value in the 

Zone Height box. 

o Profile Boundary (available for profile GTOLs only)—Specifies unilateral 

direction, bilateral direction, or unequal tolerance disposition. 

Note: The ASME Y14.41 Style check box is available only for surface 

profile GTOLs and the Unequal option is available only when ASME 

Y14.41 Style check box is selected. You can control the display of surface 

profile GTOLs in 3D mode using the ASME Y14.41 Style check box. 

To Specify the Projected Tolerance Zone 

Click GEOM TOL > Specify Tol. The Geometric Tolerance dialog box opens.  

Using the Symbols tabbed page, you can specify the projected tolerance zone for 

GTOLs of the following types: angularity, perpendicularity, parallelism, and position.  

• To indicate the projected tolerance zone and specify the height, select the Zone 

Height box and type a value. 

• To indicate the projected tolerance zone without specifying the height, placing it 

on a separate line below the GTOL, select Below GTOL.  

• To indicate the projected tolerance zone without specifying the height, placing it 

on the same line next to the GTOL, select Inside GTOL. 

• To specify no projected tolerance zone, select None. 

To Specify the Profile Boundary 

1. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears.  

2. Click Specify Tol. The Geometric Tolerance dialog box opens. 

3. Click Symbols tab. The Symbols tabbed page displays the ASME Y14.41 Style 

checkbox as not selected by default and the Unilateral and Bilateral options as 

available. If you click the ASME Y14.41 Style checkbox, the Bilateral and 

Unequal options are available.  

4. To specify the profile boundary for GTOLs, click one of the following: 

o Unilateral—Click to apply the tolerance disposition in the outward or 

inward direction of the selected profile. By default, the initial tolerance 

disposition is applied in the outward direction of the selected profile. Click 

Flip side to change the direction of application. 
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When defining the profile boundary for a surface profile GTOL, an arrow in 

the graphics window indicates the direction of a unilateral disposition 

application and points away from the selected surface reference.  

o Bilateral—Click to apply the tolerance disposition divided evenly about the 

selected profile. The annotation displays the tolerance value only. 

o Unequal—Click to apply the tolerance disposition unequally about the 

selected profile. In the Value box, type a disposition value. This value 

represents the portion of the overall tolerance value that you want to apply 

outward of the selected profile. If you have specified a positive value, the 

tolerance zone is offset outward from the selected surface. If you have 

specified a negative value, the tolerance zone is offset inward of the 

selected surface.  

The GTOL annotation displays the tolerance value, the Unequal symbol, and 

the Unequal disposition value. 

Note: Unequal disposition is available for surface profile GTOLs only when 

ASME Y14.41 Style checkbox is selected. 

Example: Display of Surface Profile GTOLs 

The surface profile GTOL annotation displays the tolerance value, the Unequal 

symbol, and the Unequal disposition value. 

 

Example: Creating a Position GTOL 

Use the characteristics and values given in the following table to create a sample 

geometric tolerance. 
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Characteristic Value 

Entity Hole 

Tolerance Location As part of a diameter dimension 

Class and Type Location/Position 

(a true position tolerance) 

Overall Tolerance Value 0.25 

Material Condition MMC 

Primary Datum (A) Material Condition RFS/Default 

Secondary Datum (B) Material 

Condition 

RFS/Default 

 

1. Click Insert > Annotations > Geometric Tolerance. The GEOM TOL menu 

appears. 

2. Click Specify Tol. The Geometric Tolerance dialog box opens. 

3. Click the Position button ( ). 

4. Specify the type of entity to which the tolerance applies. Select Feature from the 

Reference Type list; then click Select Entity and select the hole in the model. 

5. Select Dimension from the Placement Type list, and then click Place GTOL. 

Select the dimension of the hole. The GTOL appears in the model below the 

dimension. 

6. Click the Datum Refs tab. Click Primary; then select B and RFS (no symbol) 

from the Basic lists. 

7. Click the Tol Value tab and type 0.25 in the Overall Tolerance box. Select 

MMC from the Material Condition list. 

8. Click the Symbols tab. Select the Diameter Symbol check box to indicate that 

the tolerance value refers to a diameter zone; then select None as the projected 

tolerance zone. The completed GTOL appears. 

9. Click OK to close the dialog box and save the changes. 

The GTOL appears as shown: 
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Example: Geometric Tolerance Layout 

Pro/ENGINEER specifies a GTOL for an individual feature by means of a feature 

control frame (a rectangle) divided into compartments containing the GTOL symbol 

followed by the tolerance value. Where applicable, it also follows the tolerance with a 

material condition symbol.  

If a GTOL is related to a datum, it places the reference datum name in a 

compartment following the tolerance value. Where applicable, it follows the datum 

reference letter with a material condition symbol. 
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1. Matl Cond, Tertiary 

2. Matl Cond, Secondary 

3. Matl Cond, Primary 

4. Matl Cond, Tolerance 

5. Value 

6. Type 

7. Datum Ref, Primary 

8. Datum Ref, Secondary 

9. Datum Ref, Tertiary 

10. Matl Cond, Primary, Compound 

11. Matl Cond, Primary, Basic 

12. Datum Ref, Primary, Basic 

13. Datum Ref, Primary, Compound 
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Modifying GTOL Values 

To Modify the Value of an Individual Material Condition 

1. Right-click on a geometric tolerance and select Properties from the shortcut 

menu.  

2. In the Geometric Tolerance dialog box, click the Datum Refs tab. 

3. Click Primary, Secondary, or Tertiary (whichever is appropriate) in the Datum 

References box. 

4. For a basic datum reference, select a material condition from the Basic list. For a 

compound datum reference, select a material condition from the Compound list. 

The system updates the GTOL on the screen. 

5. Click OK to close the dialog box and save the changes. 

To Modify a Reference Datum to a GTOL 

1. Do one of the following: 

o Add a new reference datum by converting an existing simple reference 

datum into a compound reference feature. Add a secondary or tertiary 

reference datum by clicking either Secondary or Tertiary. Select a 

reference datum from the Compound list. Specify a material condition, if 

needed. 

o Replace a reference datum with another datum. Click Primary, 

Secondary, or Tertiary (whichever is appropriate) in the Datum 

References box; then select a different datum name from the Basic or 

Compound list. If the datum that you want to use is not on the list, click 

Select to select it in the drawing. 

o Remove a reference datum. Click Primary, Secondary, or Tertiary in the 

Datum References box (whichever is appropriate); then select None from 

the Basic or Compound list. 

The system updates the GTOL on the screen. 

2. Click OK to close the dialog box and save the changes. 

To Modify a GTOL Value on the Screen 

1. Right-click on a geometric tolerance and select Value from the shortcut menu.  

2. Type a value. The system updates the display. 

To Modify GTOL Values Using the Geometric Tolerance Dialog Box 

1. Right-click on a geometric tolerance and select Properties from the shortcut 

menu.  

2. In the Geometric Tolerance dialog box, click the Tol Value tab. 
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3. Modify the overall value or the Per Unit Tolerance Values. 

4. To modify the Zone Height Value, select Symbols. 

5. Select the Zone Height check box and type a value. The system updates the 

display to reflect the changes. 

To Move a Geometric Tolerance 

1. Select the geometric tolerance in the Model Tree or graphics window and right-

click. The shortcut menu appears. 

Note:  

o To view the geometric tolerance in the Model Tree, click Settings > Tree 

Filters > Annotations.  

o To select the geometric tolerance in the graphics window, select 

Annotation from the Filter list on the status bar. 

2. Click Move on the shortcut menu. Alternatively, click Move in the Geometric 

Tolerance dialog box that opens when you click Properties on the shortcut 

menu.  

3. Move the pointer to the new location.  

4. Click to place the geometric tolerance in the new location or middle-click to 

cancel the move operation. 

Working with Surface Finish Tolerances 

About Surface Finish Tolerances 

Surface finish is a measure of the deviation of a part surface from its normal value. 

In Pro/ENGINEER, you can specify the roughness of the surface in micrometers or 

microinches in the range of 0.001 through 2000. Surface finish can be associated 

with any model surface. As geometric tolerances, surface finish symbols represent 

annotations and do not affect model geometry. Surface finish symbols can be 

included in Annotation features. 

A surface can have only one surface finish tolerance associated with it. 

You can add surface finish symbols to a model using standard surface finish symbols 

available in Detailed Drawings, or you can create your own surface finish symbols. If 

you have a Detailed Drawings license, you can define surface finish symbols on a 

part. These symbols will appear in the associated drawings of the part, and vice 

versa.  

You can also gain access to a set of standard surface finish symbols that you can 

attach to edges, and dimensions. In Assembly mode, you can create surface finish 

symbols on surfaces created by assembly features (holes, cuts, and slots) 
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To Create a Surface Finish Tolerance 

1. Define the active annotation orientation before creating the first annotation in 

any session by using the ACTIVE ANNOTATION ORIENTATION dialog box that 

opens when you click View > Annotation Orientation. 

2. Click Insert > Annotations > Surface Finish. The SURF FINS menu appears 

with Create selected by default. The Open dialog box opens and allows you to 

retrieve the surface finish symbol definition. The name of this symbol definition is 

displayed in the Symbol name box in the Surface Finish dialog box that opens 

subsequently. 

Note: If a surface finish symbol already exists in the model, the Open dialog box 

does not open and the Surface Finish dialog box opens directly. 

3. In the Symbol name box, select the name of the symbol from the list. The list 

shows symbols that are associated with the model, if any. If the symbol you want 

has not been added to the model, browse to locate it in the symbol library, or 

click New to create a new symbol definition. 

4. Select reference surfaces, that is, surfaces that you want the Surface Finish 

symbol to represent. You can select only single surfaces as reference surfaces. 

The names of the selected references are displayed in the References collector. 

Note:  

o While including a surface finish annotation in an Annotation Feature, you 

can select single surfaces, intent surfaces, excluded surfaces, all surfaces of 

a quilt, seed and boundary surfaces, loop surfaces, or a combination of any 

of these as reference surfaces. You can use the Surface Sets dialog box 

that opens when you click Details under References to create, review, or 

edit the surface sets. 

o When creating standalone Surface Finish Annotations or Surface Finish 

Annotation Elements in an assembly, you can select surfaces that were 

created by assembly features, specifically, holes, cuts, or slots only.  

5. Under Placement Pro/ENGINEER displays the default placement type as Normal 

to Entity. You can select a different type of placement from the Type list and 

define the placement of the symbol. 

Note:  

o Normal to Entity places the surface finish annotation normal to the 

selected entity and in an annotation plane. However, if the annotation plane 

is not normal to the selected entity, then the surface finish annotation too is 

not normal to the entity. 

o You can change the default placement type for surface finishes by setting 

the default_placement_surfacefinish configuration option.   

6. If you want to move the symbol, click Move. Move the pointer to the new 

location and click to place the symbol at the new location or middle-click to 

cancel the move operation. 
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7. Under Properties, you can define the height, angle, and color of the symbol. 

8. Use the Grouping tab to specify which groups will show in the instance. 

9. Use the Variable Text tab to select the content of notes appearing with the 

symbol.  

10. Click OK. 

style="x-condition: include_for_toyota;">  

To Place Surface Finish Symbols 

While creating a Surface Finish Annotation, after selecting reference surfaces, that is, 

surfaces that you want the Surface Finish symbol to represent, you must specify the 

placement of the Surface Finish Annotation symbol. 

1. In the Surface Finish dialog box, select the placement type from the Type list in 

the Placement box.  

o With Leaders—Select to attach the symbol to model surfaces using 

leaders. 

o On Entity—Select to attach the symbol directly to a surface of the model. 

o Normal to Entity—Select to attach the symbol directly to a surface of the 

model such that it is normal to the surface. 

o Free—Select to place the symbol without attaching it to model geometry. 

2. For With Leaders attachment, select one or several locations on model surfaces 

to attach the leaders by holding down the CTRL key and selecting them. Middle-

click at the required location in the graphics window to place the symbol. A leader 

is generated for each selected location. For On Entity and Normal to Entity 

attachments, select a point on a surface of the model. For Free, select a location 

for the symbol anywhere in the graphics window. 

Note: When you select With Leaders, On Entity, or Normal to Entity 

attachments, you can select points on those surfaces that have been selected as 

references. 

3. If you want to move the symbol, click Move. Move the pointer to the new 

location and click to place the symbol in the new location or middle-click to cancel 

the move operation. 

4. Click OK when finished.  

To Modify the Value of a Surface Finish Tolerance 

1. Select the surface finish tolerance on the screen or in the Model Tree. You can 

select multiple tolerances. 

2. Right-click on one of the selected names and select Value from the shortcut 

menu. 
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3. Type the new value. The system updates the surface finish value for all the 

selected tolerances. 

To Modify the Name of a Surface Finish Tolerance 

1. Click Insert > Annotations > Surface Finish. The SURF FINS menu appears. 

2. Click Modify Name. 

3. Select the surface finish tolerance on the screen or in the Model Tree. 

4. Type the new name in the message area and press ENTER. The system updates 

the name of the surface finish tolerance. 

To Move a Surface Finish Tolerance Symbol 

1. Select the surface finish tolerance symbol in the Model Tree or graphics window 

and right-click. The shortcut menu appears. 

Note:  

o To view the symbols in the Model Tree click Settings > Tree Filters > 

Annotations.  

o To select the symbol in the graphics window, select Annotation from the 

Filter list on the status bar. 

2. Click Move on the shortcut menu.  

3. Move the pointer to the new location. An outline of the symbol along with the 

leader line moves with the pointer. 

4. Click to place the symbol in the new location or middle-click to cancel the move 

operation. 

To Delete a Surface Finish Tolerance 

1. Click Insert > Annotations > Surface Finish. The SURF FINS menu appears. 

2. Click Delete. 

3. Select the surface finish tolerance you want to delete. The tolerance symbol and 

value are deleted from the surface. 

Working with Model Properties 

About Setting Up Model Properties  

In Part mode, use the PART SETUP (Edit > Setup) menu to define basic database 

input values like material types, part accuracies and units of measure.  

• Edit feature or datum names 

• Create parameters and assign them to database objects 
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• Set measurement units for the current session 

• Create and edit notes 

• Define mass properties 

• Define dimension boundaries 

• Define Geometric Tolerances 

• Define and use three-dimensional (model) grids 

• Apply shrinkage values to the part, to be used in a mold design or casting 

process 

Renaming Objects 

About Renaming Objects 

You can use the Name command to assign names to components, features, and 

geometry. Naming these objects makes it easier to select them. For example, you 

could name an alignment hole for an assembly align_hole_1. 

Note: 

• Names can contain up to 31 characters. They cannot include spaces.  

• If a datum point array feature contains a single point only, the name of the 

point and the name of the feature are identical. 

You can rename Family Table instances using the Family Table functionality. In the 

Family Table, select the instance you want to rename and type in a new name. 

To Rename an Object 

Use the Name command to assign names to components, features, and geometry.  

1. Click Edit > Set Up > Name. The NAME SETUP menu appears. 

2. On the NAME SETUP menu, click one of the following commands: 

o Component—Name or rename components (Assembly mode only). 

o Feature—Name or rename all features, including datum points. 

o Detail Item—Name a surface finish symbol or the primary value of a 

geometric tolerance. 

o Other—Name datum axes that were created as part of another feature 

(such as a hole), curve segments making up composite curves, datum 

points, surface features, and feature edges. 

3. Select the feature or item to be modified. A text box appears below the Model 

window. 

4. Type the new name. 



Pro/ENGINEER Fundamentals 

483 

Units 

About Measurement Units 

Each model has a basic system of metric and nonmetric units to ensure that all 

material properties of that model are consistently measured and defined. All 

Pro/ENGINEER models have length, mass/force, time, and temperature units 

defined.  

Pro/ENGINEER comes with some predefined systems of units, one of which is a 

default system of units. You can change the assigned system of units, and you can 

define your own units and systems of units (called custom units and custom systems 

of units). You cannot change the predefined systems of units. 

Use the Units command to set, create, change, review, or delete a system of units 

or a custom unit for your model.  

When you use the Units command, the Units Manager dialog box opens. This 

dialog box lists the predefined systems of units and any already defined custom 

systems of units. Using this dialog box, you can create new custom units and 

systems of units. A red arrow indicates the current system of units for the model. 

Use custom units only if your model does not contain standard SI or British units or if 

your Material file (which you set up by using the Material command under Edit > 

Setup) contains units that cannot be derived from the system of units or both. 

Pro/ENGINEER uses the definition of a custom unit in interpreting material 

properties. You can also use custom units to create a new system of units. 

Note: Although the configuration options pro_unit_length and pro_unit_mass are 

still available, they are no longer recommended for use. It is recommended that you 

create a template for models that has a fully defined system of units. Use File > 

New, clear Use default template in the New dialog box, and then use the New 

File Options dialog box to create a template or modify one of the PTC standard 

templates. In any case, you must make sure that you have a defined set of units 

before you design your model. 

To Select a Measurement Units System 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens to the Systems of Units tab. 

In the system list, a red arrow points to your current system of units. 

3. Select a system of units. A description of the metric and non-metric 

measurement units appears under Description. The PTC icon (blue stripes) 

appears in front of the descriptions of the system-provided systems of units. You 

can use any of the system-provided systems of units or create a custom system 

of units. 

4. Click Set. If the units require no scaling, the model converts to the new setting. 

If the units have changed, a Warning dialog box opens offering the following 

options: 
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o Convert dimensions (for example 1" becomes 25.4mm)—Scales the 

dimension values so that the model is the same size. For example, if you 

change a cube that is 1 inch square to millimeters, it becomes 25.4 mm 

square.  

For this option: 

User-defined parameters are not scaled. You must update these parameters 

yourself. 

Angular dimensions are not scaled. For example, a 30 degree angle remains 

at 30 degrees. 

The model is regenerated. 

o Interpret dimensions (for example 1" becomes 1mm)—Does not 

change dimension values. Use this option if you want to get mass 

properties and then realize that your units are in inches. For example, if 

you change a cube that is 1 inch square to millimeters, it becomes 1 mm 

square. 

After you click Set, the red arrow points to your newly chosen system of 

units. 

5. Click Close to close the Units Manager dialog box. 

To Create Custom Units 

You create a custom measurement unit in the same way you create a custom system 

of units, by using the Units Manager dialog box. 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens to the Systems of Units tab. 

3. Click the Units tab. All system-defined and custom units are listed. A description 

of the selected unit appears under Description. 

4. Click the New button. The Unit Definition dialog box opens. 

5. Select a physical dimension from the drop-down list provided. 

6. Under Unit Definition, do the following: 

o Under Name, type a name for the new unit or accept the default name. 

o Enter a scale, and then select a reference unit from the drop-down list. The 

default unit is in (inches). 

7. Click OK to close the Unit Definition dialog box, and then click Close to close 

the Units Manager dialog box. 

Note:  

Use the Copy button to create a copy of the selected unit with a different name. 

You can also rename a unit by using this procedure. 
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You cannot edit or delete system-provided units. System-provided units are 

indicated by the PTC icon under Description. 

To Delete a Custom Unit 

You can delete a custom unit that you previously created. You cannot delete a 

predefined unit. Use caution when deleting units; you cannot undo the deletion. 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens to the Systems of Units tab. 

3. Click the Units tab. A description of the selected unit appears under 

Description. 

4. Select a custom unit that you want to delete, and then click Delete. A warning 

message appears and lists the unit you have selected for deletion. 

5. Click Confirm to delete the unit. 

To Create a Custom Units System 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens to the Systems of Units tab, 

which lists all available custom and system-defined units systems. A description 

of the selected units system appears under Description. 

3. Click the New button. The System of Units Definition dialog box opens, 

showing the units for the predefined system. 

4. Under Name, type a name for the new unit. 

5. Under Units, select the desired types of units in the appropriate drop-down lists. 

You can select either Mass or Force units by clicking the Mass or Force button. 

6. Click OK to return to the Units Manager dialog box. The new system appears in 

the list.  

7. Select the new units system and click Set to assign your custom system of units 

to your model.  

Note:  

Use the Copy button to create a copy of the selected units system with a 

different name. 

You cannot edit or delete the systems of units provided by the system. System-

provided units systems are indicated by the PTC icon under Description. 

To Edit a Custom Units System 

To redefine a units system that you previously created, 

1. In Part or Assembly mode, click Edit > Set Up. The PART SETUP or ASSEM 

SETUP menu appears. 
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2. Click Units. The Units Manager dialog box opens to the Systems of Units tab. 

3. Double-click the custom units system you want to edit, or select the system and 

then click Edit. The System of Units Definition dialog box opens. 

4. Redefine the units system as necessary, and then click OK to close the dialog 

box. 

5. Click Close to close the Units Manager dialog box. 

To Delete a Custom Units System 

You can delete a custom system of units that you previously created. You cannot 

delete a system-provided system of units. Use caution when deleting units systems; 

you cannot undo the deletion. Before you delete the units system, make sure it is 

not the set system for the current part or assembly. 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens to the Systems of Units tab, 

which lists all available custom and system-defined units systems. A description 

of the selected units system appears under Description. 

3. Select a custom units system that you want to delete, and then click Delete. A 

warning message appears and lists the units system you have selected for 

deletion. 

4. Click Confirm to delete the units system. 

About Modifying Measurement Units 

You can edit, rename, delete, or obtain information about existing measurement 

units and unit systems using the Units Manager dialog box. To open the dialog box, 

click Units from the PART SETUP or ASSEM SETUP menu that appears when you 

click Edit > Setup in Part or Assembly mode. You modify measurement unit systems 

using the Systems of Units tab, and you modify individual units using the Units 

tab. 

The following modification options are available on the Units Manager dialog box. 

For specific procedures, click See Also. 

• Copy—You can make a copy of an existing unit or system of units, or you can 

use this command to rename a unit or a custom system of units by creating a 

copy with a different name. 

• Edit—You can edit a custom unit or a custom system of units that you previously 

created. You cannot edit an existing system or unit provided by Pro/ENGINEER, 

such as Meter Kilogram Second (MKS) or cm. 

• Delete—You can delete a custom unit or system of units and revert to a 

Pro/ENGINEER-provided unit or system. You cannot delete Pro/ENGINEER-

defined units or unit systems. 

• Info—This command is available for unit systems only, not for individual units. 

You can display information about the basic units and dimensions of the current 
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system of units and about the derived units that follow from this system. You can 

save, copy, or edit this information by using the options in the Information 

window. 

To Create a Copy of a Measurement Units System 

You can create a copy of an existing units system, including custom systems you 

previously created, or Pro/ENGINEER-defined unit systems. You can also use this 

method as a way of renaming an existing units system. 

1. In Part or Assembly mode, click Edit > Set Up. The PART SETUP or ASSEM 

SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens to the Systems of Units tab. 

3. Select the units system you want to copy, and then click Copy. The Copy 

System of Units dialog box opens. 

4. Under To new Unit, use the default name for the new system of units 

(unit_system1, unit_system2, and so on), or type a new name. 

5. Click OK. The new units system is created and appears in the list. 

6. To edit the new units system, click Edit, and use the System of Units 

Definition dialog box to redefine the units system. 

To Create a Copy of an Individual Unit 

You can create a copy of any existing unit, including both custom units you 

previously created and system-provided units. You can also use this method as a 

way of renaming an existing unit. 

1. In Part or Assembly mode, click Edit > Set Up. The PART SETUP or ASSEM 

SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens to the Systems of Units tab. 

3. Click the Units tab. 

4. Select the unit you want to copy, and then click Copy. The Copy Unit dialog box 

opens. 

5. Under To new Unit, use the default name provided for the new unit (unit1, 

unit2, and so on), or type a new name. 

6. Click OK. The new unit is created and appears in the list. 

To edit the new units system, 

Double-click the new unit in the list, or select the new unit and then click Edit. Then 

use the Unit Definition dialog box to redefine the unit. 

Tip: Specifying Metric and Nonmetric Units 

When specifying your system of units, keep in mind the following guidelines: 
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• You can specify units in Part or Assembly mode. If you are working in Assembly 

mode, the units for all the parts must be the same as those for the assembly.  

• When you enter numerical data for quantities with physical dimensions, 

Pro/ENGINEER interprets the data as having units consistent with your selected 

system of units. 

• Modifying the units can invalidate your relations, as they are not scaled along 

with the model. Other non-parametric features, such as cosmetic, or IGES 

models are also not scaled with the change of units. 

• A part can have only one set of units. 

• All parts default to inches and pounds (unless otherwise set by the configuration 

file options pro_unit_length and pro_unit_mass). 

Tip: Rules for Modifying Units 

• Modifying the units can invalidate your relations, as they are not scaled along 

with the model. Other non-parametric features, such as cosmetic, or IGES 

models are also not scaled with the change of units. 

• A part can have only one set of units. 

• All parts default to inches and pounds (unless otherwise set by the configuration 

file options pro_unit_length and pro_unit_mass). 

• The initial units for an assembly are those of its base component. If, however, 

the units of the base component have been changed, the assembly units do not 

automatically change. You must re-specify the units of the assembly. 

• You cannot change the units of an assembly that contains assembly features 

which intersect a part. 

• User-defined parameters have no units; therefore, include appropriate conversion 

factors in relations. 

• Cross-sections have no units. 

• If you delete a custom measurement units system, make sure the system is not 

the selected system for the current part. 

To Get Information About Measurement Units 

You can obtain information about your system of metric and nonmetric units. 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears.  

2. Click Units. The Units Manager dialog box opens. 

3. Select a system of units. A brief description appears under Description. 

4. For more information, click the Info button. An Information window opens and 

displays the following information: 

o Units Information—The current system of units at the top of the window. 
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o Basic Quantities—The basic units and dimensions of your system of units. 

o Gravity—Displayed in a separate section. 

o Derived Quantities—The derived units that follow from your system of units.  

You can save the information to a file by using the File menu in the Information 

window. 

5. Click Close to close the Information window, and then click Close to close the 

Units Manager dialog box. 

Scaling a Model 

To Scale a Model 

You can scale the dimension values of your model by a factor you specify. 

1. If you are working in Part or Assembly, click Edit > Scale Model, otherwise, 

click Modify > Scale Model from the PART or ASSEMBLY menu. Pro/ENGINEER 

prompts you to enter a scale. 

2. Enter a scale in the message window. The default is 1.0. 

Pro/ENGINEER scales the length dimensions of your model by using the factor 

you specified. If the scale is modified, the model is regenerated. 

Notes:  

o When you scale your model, the model units are not changed.  

o Imported geometry cannot be scaled. 

Materials 

About Material Parameters 

You can create and modify material data using the Materials and the Materials 

Definition dialog boxes. The material data can be saved to the model or saved to 

material data files that have a .mtl extension. The .mtl files are stored in the 

material library directory. Each file contains the name of the material and a set of 

material parameters that are identified by an ID and units information.  

User-defined material parameters are parameters that you define by using the User 

Defined tab in the Materials Definition dialog box. All other parameter values that 

you define through the Materials Definition dialog box are stored as reserved 

parameters. If you define a user-defined parameter that has the same name as a 

reserved parameter, Pro/ENGINEER issues a warning. 

Note the following points about material parameters:  

• You can use the material parameter values in relations. 
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• You can assign materials to family table instances by adding PTC_MATERIAL_NAME 

parameter to the family table. 

• You cannot designate material parameters except the PTC_MATERIAL_NAME 

parameter. 

• When you save a material, parameters with default values are saved only if you 

have changed the default value. Additionally, only parameters that are valid for a 

specified material type are saved, for example, the Orthotropic Young's Modulus 

is not saved for an isotropic material definition. 

The reserved material parameters that you can specify are: 

PTC_YOUNG_MODULUS 
PTC_POISSON_RATIO 
PTC_MASS_DENSITY 
PTC_THERMAL_EXPANSION_COEF 
PTC_TENSILE_ULTIMATE_STRESS 
PTC_COMPR_ULTIMATE_STRESS 
PTC_SHEAR_ULTIMATE_STRESS 
PTC_THERMAL_CONDUCTIVITY 
PTC_SPECIFIC_HEAT 
PTC_HARDNESS 
PTC_CONDITION 
PTC_INITIAL_BEND_Y_FACTOR 
PTC_BEND_TABLE 
PTC_FATIGUE_MATERIAL_TYPE 
PTC_FATIGUE_MATERIAL_FINISH 
PTC_FATIGUE_STRNGTH_REDUCT_FCTR 
PTC_TSAI_WU_INTERACT_TERM_F12 
PTC_TENSILE_YIELD_STRESS 
PTC_TENSILE_ULTIMATE_STRESS_ST1 
PTC_TENSILE_ULTIMATE_STRESS_ST2 
PTC_COMPR_ULTIMATE_STRESS_SC1 
PTC_COMPR_ULTIMATE_STRESS_SC2 
PTC_POISSON_RATIO_NU21 
PTC_POISSON_RATIO_NU31 
PTC_POISSON_RATIO_NU32 
PTC_YOUNG_MODULUS_E1 
PTC_YOUNG_MODULUS_E2 
PTC_YOUNG_MODULUS_E3 
PTC_SHEAR_MODULUS_G12 
PTC_SHEAR_MODULUS_G13 
PTC_SHEAR_MODULUS_G23 
PTC_THERMAL_EXPANSION_COEF_A1 
PTC_THERMAL_EXPANSION_COEF_A2 
PTC_THERMAL_EXPANSION_COEF_A3 
PTC_THERMAL_CONDUCTIVITY_K1 
PTC_THERMAL_CONDUCTIVITY_K2 
PTC_THERMAL_CONDUCTIVITY_K3 
PTC_HARDNESS_TYPE 
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PTC_XHATCH_FILE 
PTC_FATIGUE_TYPE 
PTC_FAILURE_CRITERION_TYPE 
PTC_MATERIAL_DESCRIPTION 
PTC_MATERIAL_NAME 

To Add and Assign a Material to a Part 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 

2. Click Material. The Materials dialog box opens. 

o The Look In box displays the directory located in the path specified by the 

pro_material_dir configuration option. If you have not set the 

pro_material_dir configuration option, then the Look In box displays the 

default material directory, that is, <Pro/ENGINEER 
loadpoint>\text\materials-library. 

o The Materials in Library list displays the contents of the directory in the 

Look in box. 

o The Materials in Model list displays the list of materials present in the 

model. 

3. If required, use Look In to browse to the directory that contains the required 

material files. The names of the materials in the directory are displayed in 

Materials in Library list. Material files have a .mtl and .mat extension. The 

files with the .mat extension are files from release prior to Pro/ENGINEER Wildfire 

3.0. 

4. To add materials to a model, move the required materials from the Materials in 

Library list to the Materials in Model list. 

Note: If a model does not contain any material, then the first material that you 

add to the model is assigned to the model by Pro/ENGINEER. 

5. To assign a material, select the material that you want to assign to the model 

from the Materials in Model list and click  or click File > Assign. The 

assigned material is denoted by a red arrow that precedes the name of the 

material in the Materials in Model list. 

• You can assign only one material to a model at a time even if a model has 

multiple materials. 

• You cannot assign a material to a model in assembly mode. 

• To remove the assignment of a material from the model, select the assigned 

material from the Materials in Model list and click File > Unassign. 

To Create or Copy a Material 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 
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2. Click Material. The Materials dialog box opens. 

3. Click File > New. The Materials Definition dialog box opens. 

4. Type a name for the material in the Name box. 

5. Type a description for the material in the Description box.  

6. In the Density box, type a value for the density of the material and select the 

unit of measurement from the adjacent list.  

Note: If you select a unit of measurement that is different from the assigned 

system of units for the model, then the Changing Parameter units dialog box 

opens and allows you to convert or interpret the parameter value. Convert 

Value (for example 1 "becomes 25.4mm) is the default. 

7. Use the following tabs to define the properties of the material: 

Structural—Defines the structural properties for the material of a model. 

Thermal—Defines thermal properties for a material of a model. 

Miscellaneous—Defines sheet metal properties, surface properties, and cross-

hatching. 

Appearance—Defines appearances.  

User Defined—Defines parameter definitions and adds them to the materials 

database. For more information, click the See Also link To Create a Parameter 

and start at step 4.  

8. To save the material to the library, perform the following steps. 

a. Click SaveTo Library. The Save a Copy dialog box opens.  

b. Browse to the library folder and click OK. If you have added or edited 

appearances then the Save dialog box opens.  

c. Click OK. By default, the appearances are saved in a file named 

global.dmt in the same location where the material file is saved or in the 

location defined by the global_appearance_file configuration option. 

9. To save a material to the model, click Save To Model. The material is saved to 

the model and appears in the Materials dialog box in the Materials in Model 

column. 

10. Click OK in the Materials dialog box.  

Note:  

• To copy an existing material in a model, select the material that you want to copy 

in the Materials in Model list and click Edit > Copy in the Materials dialog 

box. The copy appears in the Materials in Model list as Copy_of_<name> while 

subsequent copies of the same material appear as Copy1_of_<name>, 

Copy2_of_<name> and so on. 

• You can define material properties as a function of temperature using the 

Functions dialog box that opens when you click Function on the shortcut menu. 
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The shortcut menu appears when you right-click in the box next to Poisson's 

Ratio, Young's Modulus, or Coeff. of Thermal Expansion in the Structural 

tabbed page. After you select or define a function and click OK in the Function 

dialog box, the function name appears in the box next to the material property. 

Similarly, you can also assign a parameter value to define a material property by 

using the Select Parameter dialog box that opens when you click Parameter 

on the shortcut menu. The shortcut menu appears when you right-click in the 

box next to the material property in the Structural or Thermal tabbed pages. 

Select a parameter from the dialog box. After you click Insert Selected, the 

parameter name appears in the box next to the material property. 

About Conversion of Material Data 

The material data in releases before Pro/ENGINEER Wildfire 3.0 is stored in 

mmatl.lib files or in files with the .mat extension. 

You can convert a mmatl.lib file created in Mechanica before Pro/ENGINEER Wildfire 

3.0 to .mtl files by clicking File > Convert pre-Wildfire 3.0 lib in the Materials 

dialog box. You can edit existing materials definitions, that is, the .mat files in 

Pro/ENGINEER. These files are saved to the .mtl format when you save the material 

definition. 

If the following parameters are present in existing material definitions, then 

Pro/ENGINEER adds the new material as user-defined parameters. 

• SHEAR_MODULUS 

• THERM_EXPANSION_REF_TEMPERATURE 

• STRUCTURAL_DAMPING_COEFFICIENT 

• EMMISIVITY 

• STRESS_LIMIT_FOR_TENSION 

• STRESS_LIMIT_FOR_COMPRESSION 

• STRESS_LIMIT_FOR_SHEAR 

• Cost (in Mechanica) 

Conversion of Material in the Model 

Before editing a model that contains a material created in Mechanica before 

Pro/ENGINEER Wildfire 3.0 and if this material is a non-isotropic material or a 

material with functions, parameters, fatigue properties, or failure criteria, then you 

must convert material data in the model to the latest format. If you edit such a 

model or material in Pro/ENGINEER without converting the material to the latest 

format, you may lose your data associated with the material. 
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To Edit a Material 

1. If you are editing a model that contains a material created in Mechanica before 

Pro/ENGINEER Wildfire 3.0 and if this material is a non-isotropic material or a 

material with functions, parameters, fatigue properties, or failure criteria, then 

you must convert material data in the model to the latest format in Mechanica 

before you begin editing. 

2. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 

3. Click Material. The Materials dialog box opens. 

4. In the Materials in Library or Materials in Model list, select the material that 

you want to edit. 

5. Click  or click Edit > Properties. The Material Definition dialog box opens. 

6. Modify the name, description, and other properties of the material. 

7. If you have selected a material in the Materials in Library list, then Save to 

Library becomes available. To save the material to the library, perform the 

following steps. 

a. Click SaveTo Library. The Save a Copy dialog box opens.  

b. Browse to the material library directory and click OK. If you have 

added or edited appearances, then the Save dialog box opens.  

c. Click OK. By default, the appearances are saved in a file named 

global.dmt in the same location where the material file is saved or in the 

location defined by the global_appearance_file configuration option. You 

are taken back to the Materials dialog box. 

8. If you have selected a material in the Materials in Model list, click OK in the 

Materials Definition dialog box. The Materials Definition dialog box closes 

and you are taken back to the Materials dialog box.  

To View Material Information 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 

2. Click Material. The Materials dialog box opens. 

3. In the Materials in Model list, select the material whose information you want 

to view. 

4. Click Show > Info. The material information is displayed in the Pro/ENGINEER 

browser. 

Note: To view only the description of a material, select the material in the Materials 

in Library or Materials in Model list and click Show > Description. The 

description is displayed in the Description area in the Materials dialog box. 
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To Save a Material From a Model to a Library 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 

2. Click Material. The Materials dialog box opens. The Materials in Model list 

displays the list of materials present in the model. 

3. Select the material that you want to save to the library directory on disk from the 

Materials in Model list. 

4. Click  or click Edit > Save a Copy. The Save a Copy dialog box opens. You 

can browse to the material library directory and click OK. If you have added or 

edited appearances, then the Save dialog box opens. 

5. Click OK. By default, the appearances are saved in a file named global.dmt in 

the same location where the material file is saved or in the location defined by 

the global_appearance_file configuration option. You are taken back to the 

Materials dialog box.   

Note: The units in the material file that you saved to the disk are the same as those 

used in the model when the material file was created or last updated.  

To Remove a Material from the Model 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 

2. Click Material. The Materials dialog box opens. 

3. In the Materials in Model list, select the material that you want to delete. 

4. Click  or click Edit > Delete in the Materials dialog box. Pro/ENGINEER 

prompts you for confirmation. 

5. Click OK. The material is removed from the Materials in Model list. The 

material is also removed from the model database. 

Note: If a material is referenced by other entities, for example, in Mechanica, you 

must first remove the dependencies before deleting the material.   

To Define Sheetmetal, Surface, and Detailing Properties 

1. Click the Miscellaneous tab in the Materials Definition dialog box when 

creating a material. The Miscellaneous tabbed page opens displaying a default 

value of 0.5 for Initial Bend Y-Factor. 

Note: Pro/ENGINEER checks for errors in the material properties that you specify 

whenever you save a material, add a material from the library to the model, and 

at run time in both Mechanica and FEM modes.  

2. Under Sheetmetal Properties, type a new value for Initial Bend Y-Factor and 

Bend Table, if required. The valid value for Initial Bend Y-Factor is a positive 

real number (includes 0.0) and for bend table is a string with a maximum length 

of 31 characters.  
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3. Under Surface Properties, type values for Hardness, Hardness Type, and 

Condition, if required. The valid value for hardness is a positive real number 

(includes 0.0) and for hardness type and condition, a string with a maximum 

length of 31 characters. 

Note: You can choose not to specify values under Surface Properties blank. If 

you specify a value for one of the surface properties, then you must specify 

values for all the surface properties.  

4. In the Cross Hatching box type the name of a file that has a .xch extension. 

This file type contains the cross hatching pattern that you want to apply to cross 

sections. Type the name without the .xch extension and limit it to 31 characters. 

Note: 

o Pro/ENGINEER searches for the specified file with .xch extension in the 

path defined by the pro_crosshatch_dir configuration option, the working 

directory, paths specified by the search_path configuration options, and 

the default crosshatch directory, that is, <loadpoint>/text/crosshatch. If 

the specified file cannot be located, then the default cross hatch pattern is 

used.  

o When creating a new material or during automatic conversion of a material 

that existed before Pro/ENGINEER Wildfire 3.0, by default, the Cross 

Hatching box displays a value that corresponds with the name of the 

material. 

o Cross sections that were created before a material is assigned to a model 

are not updated after you assign a material with a different cross hatching 

pattern to the model or when you change the material assigned to a model. 

To Add and Assign an Appearance to a Material 

1. Click the Appearance tab in the Materials Definition dialog box when creating 

a new material. 

2. Click Chooser. The Appearances dialog box and the Material Appearance 

Editor dialog box open. The appearances in the global.dmt file are listed in the 

Available Appearances list in the Appearances dialog box. 

3. To filter the list of appearances in the Available Appearances list by a specified 

name, type the name in the Apply Filter box and click Apply Filter. 

4. Select the appearances that you want to add to the material in the Available 

Appearances list and move them to the Visible Appearances list.  

5. Click OK. Alternatively, click Apply to apply changes without closing the 

Appearances dialog box. The appearances listed in the Visible Appearances 

list are displayed in the palette in the Material Appearance Editor dialog box 

and the Appearance tabbed page. 

6. To assign an appearance as the default, select the appearance in the 

Appearance tabbed page and click Default. A red arrow appears next to the 

appearance indicating that the appearance is the default.  
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Note: If the material to which you have assigned an appearance is the default 

material that is assigned to the part, then the appearance is automatically 

applied to the part in the graphics window.  

However, if you have set the mat_assign_appearance configuration option to no, 

then the appearance is not applied to the model. The default for this option is 

yes. 

To Create an Appearance for a Material 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 

2. Click Material. The Materials dialog box opens. 

3. Do one of the following: 

o If you are creating an appearance for a material that already exists, then 

select the material in the Materials in Library or Materials in Model list 

and click Edit > Properties. The Material Definition dialog box opens. 

o Click File > New. The Materials Definition dialog box opens. 

4. Click the Appearance tab in the Materials Definition dialog box. 

5. Click New. The Material Appearance Editor dialog box opens. 

6. Create a new appearance. This appearance is added to the palette in the 

Material Appearance Editor dialog box and in the Appearance tabbed page of 

the Materials Definition dialog box.   

7. Click Close in the Material Appearance Editor dialog box.  

8. Click OK in the Materials Definition dialog box. 

Note: To copy an appearance, select the appearance in the Appearance tabbed 

page and click Copy. A copy of the appearance is added to the palette in the 

Material Appearance Editor dialog box and in the Appearance tabbed page of 

the Materials Definition dialog box. The name of the copied appearance is 

incremented appropriately based on the name of the selected appearance. 

Files Associated With Material Appearances 

You can define appearances for a material using the Appearance tab in the 

Material Definition dialog box. The names of the material appearances that are 

associated with a material are stored in the material definition file, that is, the file 

with a .mtl extension. Information about material appearances is stored in the 

global.dmt file. The default location of the global.dmt file is 

\<loadpoint>\graphic-library\appearances. However, you can set the 

 global_appearance_file configuration option to a path that points to a different 

global.dmt file. This file takes precedence over the global.dmt file in the default 

location. 
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Note: The global.dmt file is different from the appearance.dmt file that stores the 

information of the appearances created using the Appearance Editor that opens 

when you click View > Color and Appearance. 

When transferring a model you must transfer the associated global.dmt file along 

with the model. The appearances information other than default is not available for 

all the materials saved with the model if the global.dmt file is missing.   

To Edit an Appearance of a Material 

1. Click Edit > Set Up. The PART SETUP or ASSEM SETUP menu appears. 

2. Click Material. The Materials dialog box opens. 

3. Select the material in the Materials in Library or Materials in Model list and 

click Edit > Properties. The Material Definition dialog box opens. 

4. Click the Appearances tab and select the appearance that you want to modify. 

5. Click Edit. The Material Appearance Editor dialog box opens displaying the 

selected appearance. 

6. Modify the appearance. 

7. If you have selected a material in the Materials in Library list, then Save to 

Library becomes available. To save the material to the library, perform the 

following steps. 

a. Click SaveTo Library. The Save a Copy dialog box opens.  

b. Browse to the material library directory and click OK. If you have 

added or edited appearances, then the Save dialog box also opens.  

c. Click OK. By default, the appearances are saved in a file named 

global.dmt in the same location where the material file is saved or in the 

location defined by the global_appearance_file configuration option. 

8. If you have selected a material in the Materials in Model list, click OK in the 

Materials Definition dialog box. The Materials Definition dialog box closes 

and you are taken back to the Materials dialog box. 

Note: If you assign a material to a part by using the Material Appearance Editor 

dialog box, then you can edit the appearance of this material by using From Model 

in the Assignment container in the Appearance Editor dialog box. 
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About the Material Library 

A material library is a directory that contains the material definition files, that is, the 

.mtl files. The Look In box in the Materials dialog box displays the directory 

located in the path specified by the pro_material_dir configuration option. If you 

have not set the pro_material_dir configuration option, then the Look In box 

displays the default material directory, that is, <Pro/ENGINEER 
loadpoint>\text\materials-library. The default material directory contains the 

standard materials available in Pro/ENGINEER. 

Adding a material to the library and saving it saves the material to a material file 

bearing the same name as the material name in Pro/ENGINEER. 

When you save a material, Pro/ENGINEER writes the value and the unit for each 

material quantity to the material file. If the unit is a user-defined unit, then the 

definition of the user-defined unit is also written to the material file. 

When you add an existing material to a model, any user-defined units that are 

defined in the material file are also added to the model. However, note the following 

points: 

• If the name of the user-defined unit in the material file does not exist in the 

model, then the user-defined unit is added to the model. 

• If the user-defined unit in the material file and the unit in the model have the 

same name and definitions, then the user-defined unit is not added to the model 

again. 

• If the user-defined unit in the material file and the unit in the model, have the 

same name but the definitions are different, then Pro/ENGINEER prompts you to 

specify a new name for the unit before adding it to the model. 

Tip: Using a Material Library 

When you finish defining the materials you use in everyday design, create a material 

library directory to which all users have access. 

Set up the directory with read and execute privileges only, to help protect its 

contents. Then assign its path to the configuration file option pro_material_dir. 

The Look In box in the Materials dialog box displays the directory located in the 

path specified by the pro_material_dir configuration option. If you do not set the 

pro_material_dir configuration option, then the Look In box displays the default 

material directory, that is, <Pro/ENGINEER loadpoint>\text\materials-library.  

To Specify or Change the Material Density of a Part 

1. On the PART SETUP menu, click Mass Props. The Setup Mass Properties 

dialog box opens. 

2. Enter the density data in the Density field. Press OK. 

The density of the part changes to the new value and the system updates the 

mp_density value in relations. If a material has been assigned to the part and 

the value of the corresponding system parameter in relations, its density is 
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updated. Any values dependent on those parameters are updated after 

regeneration. 

Note: The configuration option mass_property_calculate is set to by request 

by default. Set it to automatic to automatically calculate density. 

Specifying the Density of a Part 

You can use the system parameter mp_density in a relation to specify the density of 

a part. This density value is used for calculating mass properties. If you change the 

material density in a part, the system updates the mp_density value in relations. 

If mp_density is being driven by a relation and you change the relation, the density 

of the part is updated to the new mp_density value when the part is regenerated. In 

addition, if a material was assigned to the part at the time of regeneration, the 

material density is also updated to the new mp_density value. 

If you change the density of the part using the Density field in the Setup Mass 

Properties dialog box, mp_density is updated immediately. If a material has been 

assigned to the part, the density of the material is also updated immediately. 

If a material has been assigned to the part and you change the density of the 

assigned material using the Material Definition dialog box, the density of the part 

and mp_density are both updated immediately.  

In both of these cases, any values that are dependent on mp_density are updated 

after regeneration. 

Note: Set the configuration option mass_property_calculate to automatic. 

About Adding Material Parameters to a Family Table 

You can assign materials to family table instances by adding a parameter to the 

family table. Use family tables to control the assigned material by adding the 

PTC_MATERIAL_NAME parameter to a family table as an item. After the material 

parameter is added to the Family Table, you can select materials already in the 

model from the list that appears when you click in a cell in the PTC_MATERIAL_NAME 

column in the Family Table dialog box. 

 

Example: Specifying Material Parameters through Relations 

You can use material parameter values in relations. 

For example, in a part: 

• Assign a value to the parameter HARDNESS in the material with MTRL_ID 64. 

The material must be in the internal database of the part (but is not necessarily 

assigned to the part): 

PTC_HARDNESS:MTRL_ID_64 = 55 

• Assign a value to the parameter POISSON_RATIO in the assigned material:  
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PTC_POISSON_RATIO:MTRL_ID = 0.3 

(where MTRL_ID is ID of the assigned material) 

• Make a dimension dependent on the material parameter YOUNG_MODULUS: 

d12 = PTC_YOUNG_MODULUS:MTRL_ID/1000 

For example, in an assembly: 

• Assign a value to the material parameter POISSON_RATIO in the component with 

Session ID 10: 

PTC_POISSION_RATIO:MTRL_ID:10 = 0.30 

• Make dimension d17 dependent on the material parameter HARDNESS in the 

component with session ID 21: 

d17 = PTC_HARDNESS:MTRL_ID:21 * 40 

If a material parameter is used as driving variable and you change it, the driven 

variable or dimension, likewise, is updated after regeneration. 

Mass Property Parameters 

About Working with Mass Property Parameters 

Pro/ENGINEER can compute the mass properties of a part or assembly either based 

on the actual geometry of the object, or based on user-assigned parameter values. 

For example, when you create a simplified part for an assembly, you may want its 

mass properties to correspond to a fully detailed part. You can assign mass 

properties to a part or assembly either by assigning values to alternate mass 

parameters, or by using a mass properties file. 

When working with the mass properties of a part or assembly, you can at any time 

generate a mass properties report based on either of the following sources: 

• Geometry—Calculates mass properties based on model geometry. 

• Geometry and parameters—Calculates mass properties based on user-assigned 

alternate parameter values. Where the alternate parameters are not specified, 

the system uses the parameter values derived from the model geometry. 

• File—Calculates mass properties based on the parameter values specified in a 

mass properties file. The file has to contain all the parameter values. If the file is 

incomplete, the system does not generate a report.  

When you generate a mass properties report, it is displayed in an information 

window and written to a file in the current working directory, named 

objectname.m_p, where objectname is the name of the part or assembly. 

Reported and Alternate Parameters 

The values generated in the mass properties report are stored in the model as its 

reported mass property parameters. You can view them by clicking Tools > 
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Parameters and selecting Reported Mass Properties from the list at the bottom 

of the Parameters dialog box.  

You can not modify values of reported parameters, they are derived from the last 

generated mass property report. To change the reported parameter values, you can: 

• Specify alternate mass property parameter values and generate a report using 

Geometry and Parameters as the source. 

• Use a file to assign mass properties and generate a report using File as the 

source. 

If you generate a report using Geometry as the source, the reported parameter 

values are based on the model geometry. Before you calculate model mass 

properties for the first time, all the reported parameter values are zero. 

Alternate mass property parameters are also stored in the model. You can modify 

values of these parameters using either of the following methods: 

• When generating the mass properties report, set the source to Geometry and 

Parameters and click Edit. 

• Click Tools > Parameters and select Alternate Mass Properties from the list 

at the bottom of the Parameters dialog box. Type the parameter values in the 

appropriate boxes. 

• Click Tools > Relations and add relations to the model to define the appropriate 

parameter values. 

After you change the alternate parameter values using either of these methods, you 

have to make the changes reflect in the reported parameters. You can: 

• Generate a mass properties report with Geometry and Parameters as the 

source. 

• Make sure the PRO_MP_SOURCE parameter is set to PARAMETERS, and the 

configuration option mass_property_calculate is set to automatic, and 

regenerate the model. 

You can use both reported and alternate mass property parameter values in 

relations, to drive other model parameters.   

Configuring for Mass Property Computations 

You can use the following configuration options when working with mass property 

parameters: 

• To set Pro/ENGINEER to automatically calculate all mass properties, set the 

configuration option mass_property_calculate to automatic. Then the reported 

parameters will automatically update, based on the PRO_MP_SOURCE parameter 

value, every time you regenerate the model. 

• To include into an assembly mass property report complete listings of the mass 

properties of the components, set the configuration option mp_calc_level to 

all_models. If the report is longer than 2,000,000 characters, it is not shown on 

screen, but the objectname.m_p file is written to your working directory. 
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To Generate a Mass Properties Report Based on Model Geometry 

Generating a mass properties report based on model geometry produces the same 

results as a mass properties computation through model analysis (accessible by 

clicking Analysis > Model Analysis). However, a model analysis computation does 

not change the reported mass property parameter values.  

1. Click Edit > Setup > Mass Props. The Setup Mass Properties dialog box 

opens. 

2. Select Geometry as the source for mass properties calculation. If you have not 

changed the PRO_MP_SOURCE parameter value, this is the default source.  

3. Select the coordinate system to be used. 

4. If the object is a part, type a value in the Density box. If the object is an 

assembly, the system calculates the average density based on the densities of 

assembly components. 

5. Click Generate Report.  

6. If the object is an assembly, the system prompts you for density of each 

component part in turn. Enter the density values.  

7. The system calculates the mass properties, displays the results in the 

Information Window, and saves them in a file objectname.m_p in the current 

working directory. You can use the Edit command in the Information Window to 

edit the file, or use the File > Save As command to save it under a different 

name.  

8. Click Close when finished viewing the report. 

To Assign Parameters and Generate a Mass Properties Report 

This functionality lets you assign alternate values to certain mass property 

parameters. The system then generates the report based on these assigned values. 

If some of the values are not assigned, the system uses the default parameter 

values derived from the model geometry. 

1. Click Edit > Setup > Mass Props. The Setup Mass Properties dialog box 

opens. 

2. Select Geometry and Parameters as the source for mass properties 

calculation.  

3. Select the coordinate system to be used. 

4. If you want to change the default density, type a value in the Density box. If the 

object is an assembly, the Density box is empty. If you do not specify a value, 

the system will prompt you for densities of component parts at the time of 

generating the report, and calculate the assembly density as the average of 

component densities.  

5. To specify the alternate parameters, click Edit. The Mass Properties 

Parameters dialog box opens. 
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6. Type the parameter values in the appropriate boxes, where desired. If you do not 

specify an alternate parameter value, the system will use model geometry to 

compute the reported parameter. Follow the link under See Also for a complete 

list of mass properties parameters.  

Note: If you have previously specified alternate parameter values through the 

Parameters functionality, these values appear in the appropriate boxes. If an 

alternate parameter is driven by a relation, the appropriate box is grayed out and 

you can not type a value. 

7. Click OK when finished, to close the Mass Properties Parameters dialog box. 

8. Click Generate Report. The system calculates the mass properties, displays the 

results in the Information Window, and saves them in a file objectname.m_p in 

the current working directory. You can use the Edit command in the Information 

Window to edit the file, or use the File > Save As command to save it under a 

different name.  

9. Click Close when finished viewing the report. 

Reported and Alternate Mass Property Parameters 

The following table lists all the reported (system) and alternate (user assigned) mass 

property parameters available in the model. 

Reported 

 Parameters 

Alternate 

 Parameters 

Type Description 

 PRO_MP_SOURCE string Defines the default 

source for 

generating a mass 

properties report. 

Can be one of the 

following strings: 

GEOMETRY, 

PARAMETERS, FILE.  

PRO_MP_DENSITY MP_DENSITY real 

numb

er 

Model density. 

PRO_MP_MASS PRO_MP_ALT_MASS real 

numb

er 

Model mass. 

PRO_MP_VOLUME PRO_MP_ALT_VOLUME real 

numb

er 

Model volume. 

PRO_MP_AREA PRO_MP_ALT_AREA real 

numb

er 

Model area. 
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Reported 

 Parameters 

Alternate 

 Parameters 

Type Description 

PRO_MP_COGX PRO_MP_ALT_COGX real 

numb

er 

Center of gravity,  

X coordinate. 

PRO_MP_COGY PRO_MP_ALT_COGY real 

numb

er 

Center of gravity,  

Y coordinate. 

PRO_MP_COGZ PRO_MP_ALT_COGZ real 

numb

er 

Center of gravity,  

Z coordinate. 

PRO_MP_IXX PRO_MP_ALT_IXX real 

numb

er 

Moment of inertia 

with respect to the 

X axis. 

PRO_MP_IYY PRO_MP_ALT_IYY real 

numb

er 

Moment of inertia 

with respect to the 

Y axis. 

PRO_MP_IZZ PRO_MP_ALT_IZZ real 

numb

er 

Moment of inertia 

with respect to the 

Z axis. 

PRO_MP_IXZ PRO_MP_ALT_IXZ real 

numb

er 

Moment of inertia 

with respect to the 

XZ axes. 

PRO_MP_IYZ PRO_MP_ALT_IYZ real 

numb

er 

Moment of inertia 

with respect to the 

YZ axes. 

PRO_MP_IXY PRO_MP_ALT_IXY real 

numb

er 

Moment of inertia 

with respect to the 

XY axes. 

 

To Use a File for Assigning Mass Properties 

This functionality lets you assign mass property values by using a file. If you use this 

method, you have to specify values for all the parameters listed in the file template. 

If the file is incomplete, the system does not generate a report.  

1. Click Edit > Setup > Mass Props. The Setup Mass Properties dialog box 

opens. 

2. Select File as the source for mass properties calculation. A system window opens 

with the system editor active. Type the values for all the parameters in the 
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template file. When you exit the editor, the file is automatically saved in the 

current working directory as objectname_amp.dat. 

3. Click Generate Report. The system calculates the mass properties, displays the 

results in the Information Window, and saves them in a file objectname.m_p in 

the current working directory. You can use the Edit command in the Information 

Window to edit the file, or use the File > Save As command to save it under a 

different name.  

4. Click Close when finished viewing the report. 
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Example: An Assigned Mass Properties Template File 

 

Notes:  

• You must enter all numerical values in the preceding template. 

• Ixx, Iyy, and Izz are always > 0. 

• Ixy=Iyx, Iyz=Izy, Izx=Ixz 
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Model Grids 

About Model Grids 

When you are in Part or Assembly mode, you can define and use three-dimensional 

model grids. 

You define a model grid by choosing Grid from the PART SETUP or ASSEM SETUP 

menu that appears when you click Edit > Setup and then using the Model Grids 

dialog box to select a coordinate system that defines the origin of the grid. 

For more information about creating, using, and modifying model grids, refer to the 

topics on model grids in the Detailed Drawings portion of the online Help system. 

Relations and Parameters 

Terminology Used in Relations and Parameters 

Local parameters—Parameters that are created in the current model. You can edit 

local parameters in the model.  

External parameters—Parameters created outside the current model and used to 

control some aspects of the model. External parameters cannot be modified in the 

model. For example, you can add parameters in Layout mode to define certain part 

dimensions. When you open that part, these part dimensions are controlled from 

Layout mode and are read-only in the part. Likewise, you can create parameters in 

the PDM system and apply them to the part.  

User-defined parameters—Additional information that you can attach to geometry. 

You can add user-defined parameters to an assembly, part, feature, or entity. For 

example, you can create a COST parameter for each part in the assembly. Then, you 

can include the COST parameter in your Bill of Materials to calculate the total cost of 

the assembly.  

System parameters—Parameters defined by the system, for example, the Mass 

Properties parameter. These parameters are generally read-only. You can use them 

in relations, but you cannot control their value. 

Annotation Element parameters—Parameters defined for an Annotation Element. 

Restricted value parameters—Parameters whose values and other properties are 

defined by an external file. 

Relations—Relations are user-defined equations written between symbolic 

dimensions and parameters. Relations let you capture design intent by defining 

relationships within features or parts, or among assembly components. You can 

create relations on different levels: assembly, part, feature, or section. 

Section relations—Relations created in Sketcher to control geometry of complex 

sections. Unless a section dimension changes, section relations generally are 

regenerated during a part regeneration. 
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Part relations—Relations added on a part level. During a part regeneration, these 

relations get resolved before features are regenerated. 

Feature relations—Relations added to a selected feature. During a part 

regeneration, these relations are resolved after part relations, but before the 

regeneration of the feature to which they apply. You use feature relations to change 

feature geometry only after part relations are applied and some features have been 

regenerated. 

Relations 

Basic Relations Information 

About Relations 

Relations (also known as parametric relations) are user-defined equations written 

between symbolic dimensions and parameters. Relations let you capture design 

intent by defining relationships within features or parts, or among assembly 

components. 

You can use relations to control the modeling process in the following ways: 

• To control the effects of modifications on models 

• To define values for dimensions in parts and assemblies 

• To set constraints for design conditions. For example, by  specifying the location 

of a hole in relation to the edge of a part. 

• To describe conditional relationships between different parts of a model or 

assembly 

Relations can be simple values (for example, d1=4) or complex, conditional, 

branching statements. 

You can also use units in relations. 

Accessing Relations 

To access relations, open a model and click Tools > Relations. The Relations 

dialog box opens. 

Relation Types 

There are two types of relations: 

• Equality—Equates a parameter on the left side of the equation with an 

expression on the right side. This type of relation is used for assigning values to 

dimensions and parameters. For example: 

o Simple assignment: d1 = 4.75 

o More complex assignment:  
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d5 = d2*(SQRT(d7/3.0+d4)) 

• Comparison—Compares an expression on the left side of the equation with an 

expression on the right side. This type of relation is commonly used as a 

constraint or in conditional statements for logical branching. For example: 

o As a constraint: (d1 + d2) > (d3 + 2.5) 

o In a conditional statement: IF (d1 + 2.5) >= d7 

Rules for Using Relations 

Consider the following rules: 

• If you try to assign a relation outside the section to a parameter that is already 

driven by a section relation, you get an error message when the system 

regenerates the model. The same applies if you try to assign a relation to a 

section parameter that is already driven by a relation outside the section. 

Remove one of the relations and regenerate model.  

• If an assembly tries to assign a value to a dimension variable that is already 

driven by a part or subassembly relation, you get an error message. Remove one 

of the relations and regenerate the model.  

• Modifying the units of a model can invalidate your relations, as they are not 

scaled along with the model. 

Tip: In some cases, relations defined at different levels may conflict. Check the 

validity of relations by clicking  and make sure  your relations fulfill your design 

intent. 

About Order of Evaluation of Relations During a Regeneration 

Relations are not evaluated until the model is regenerated. During a regeneration, 

relations are evaluated in the following order: 

1. At the beginning of a regeneration, the system solves model relations in the 

order in which they were entered.  

In an assembly, the assembly relations are calculated first. Then the system 

calculates all subassembly relations in order of component placement. This 

means that all subassembly relations are calculated before any features or 

components begin regeneration. 

2. The system starts regenerating features in the order of creation. If a feature has 

feature relations attached to it, these relations are solved before regenerating 

that feature. 

3. If you specified any relations as Post Regeneration, the system solves these 

relations after the regeneration is complete. 
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About Simultaneous Equations 

Simultaneous equations are relations in which several variables or dimensions must 

be solved simultaneously.  

Consider these rules for creating simultaneous equations: 

• You must declare variables used in simultaneous equations in the beginning of 

the equations. For example, area = 100, as shown in the next example.  

• When solving the simultaneous equation, the system returns only one set of 

results even if more than one solution for the system of equations is possible. 

• You can intermix simultaneous equations with single variable relations.  

Example: Sample Simultaneous Equations 

For example, you have a box of width d1 and height d2 and you want to specify the 

following conditions: 

• The area equals 100 

• The perimeter equals 50 

You can enter the following simultaneous equations: 

SOLVE  
d1*d2 = 100 
2*(d1+d2) = 50 
FOR d1 d2 ...or... FOR d1,d2 

All lines between the SOLVE and FOR statements become part of the simultaneous 

equations. The FOR line lists the variables to be solved. Any variables that appear in 

the simultaneous equations but not in the FOR list are interpreted as constants.  

Alternatively, you can set the same conditions by entering the following simultaneous 

equations:  

area = 100 
perimeter = 50 
SOLVE 
d1*d2 = area 
2*(d1 + d2) = perimeter 
FOR d1 d2 

Tips for creating simultaneous equations: 

• Omitting area = 100 in the preceding relation causes an error. 

• You can add extra code downstream from simultaneous equations to specify a 

solution when there is more than one equation. For example, in the preceding 

examples, the two possible sets of solutions are d1=5, d2=20 and d1=20, d2=5. 

You can add the constraint d1 <= d2 by adding the following conditional code: 

IF d1 > d2 
temp = d1 
d1 = d2 
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d2 = temp 
ENDIF 

Relations Errors 

After you add or edit a relation and click OK to exit the Relations dialog box, 

Pro/ENGINEER checks the validity of relations. If errors are found, Pro/ENGINEER 

flags the erroneous relations so you can correct them. 

Error types detected by Pro/ENGINEER include: 

• Long line—The relations line has more than 80 characters. Edit the line, or break 

the relation into two lines by entering a backslash (\) to indicate that the relation 

continues on the next line. 

• Long symbol—A symbol name has more than 31 characters. Edit the symbol 

name to be less than 31 characters. 

• Parse error—A parse error occurs, for example, if a parameter is not defined.  

Note: Constraint violations are not captured by this error check. If a 

simultaneous relation fails to converge, a warning appears in the message area. 

If the system detects a simultaneous relation that is not closed, an error message 

appears on an empty line after the last relation line. 

Avoiding Circular Relations 

You may erroneously create a circular relation such as this one:  

d0 = d1 

d1 = d0 

When you sort relations, the sorting utility detects a circular relation and issues a 

warning. However, the preceding lines can be valid parts of a simultaneous equation. 

The next example of a circular relation illustrates how you can erroneously redefine a 

symbol in the course of entering relations: 

d0 = d1 

... 

d0 = 2*d1 

These relations are order-dependent and cannot be sorted. The system issues a 

warning. 

Operators and Functions Used in Relations 

About Operators Used in Relations 

The following operators can be used in relations, both in equations and in conditional 

statements. 
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Arithmetic Operators 

+ Addition 

– Subtraction 

/ Division 

* Multiplication 

^ Exponentiation 

() Parentheses for grouping 

for example, d0 = (d1–d2)*d3 

Assignment Operator 

= Equal to 

The equal (=) sign is an assignment operator that equates the two sides of an 

equation or relation. When the equal sign is used, the equation can have only a 

single parameter on the left side. 

Comparison Operators 

Comparison operators are used when a TRUE/FALSE value can be returned. For 

example, the following relation returns TRUE whenever d1 is greater than or equal to 

3.5. It returns FALSE whenever d1 is less than 3.5: 

d1 >= 3.5 

The following comparison operators are supported: 

==  Equal to 

>  Greater than 

>=  Greater than or equal to 

!=, <>,~=  Not equal to 

<  Less than 

<=  Less than or equal to 

|  Or 

&  And  

~, !  Not 

Note: The "equal to" assignment operator is different from the "equal to" 

comparison operator. 
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The operators |, &, !, and ~ extend the use of comparison relations by enabling 

several conditions to be set in a single statement. For example, the following relation 

returns TRUE whenever d1 is between 2 and 3, but not equal to 2.5: 

d1 > 2 & d1 < 3 & d1 ~= 2.5 

Conditional Statements in Relations 

Note: Relations containing conditional statements are not sorted. A condition is an 

expression that is either TRUE (or YES) or FALSE (or NO). These values can be used 

interchangeably in the conditional statement. For example, the following statements 

can all be evaluated the same way: 

IF ANSWER == YES 
IF ANSWER == TRUE 
IF ANSWER  

IF Statement 

You can add IF statements to relations to create conditional statements. For 

example, 

IF d1 > d2 
length = 14.5 
ENDIF 
IF d1 <= d2 
length = 7.0 
ENDIF 

ELSE Statement 

By adding the ELSE statements in the branches, you can create more complex 

conditional constructions. With these statements, the previous relation may be 

modified as follows: 

IF d1 > d2  
length = 14.5 
ELSE  
length = 7.0 
ENDIF  

There can be several features listed between the IF, ELSE, and the  ENDIF 

statements. In addition, the IF|ELSE|ENDIF constructions can also be nested within 

feature sequences.  

The syntax of the IF clause is as follows: 

IF <condition>  
Sequence of 0 or more relations or IF clauses  
ELSE <optional>  
Sequence of 0 or more relations or IF clauses <optional>  
ENDIF 

Consider the following rules: 
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• ENDIF is spelled as one word. 

• ELSE is added on a separate line. 

• Equal in conditional statements is entered as two equal signs (==). Assignment 

is entered as a single equal sign (=). 

About Functions Used in Relations 

Mathematical, graph, and curve evaluation functions can be used in relations. 

Mathematical Functions 

The following operators can be used in relations, both in equations and in conditional 

statements. 

Relations can include the following mathematical functions: 

cos () cosine 

tan () tangent 

sin () sine 

sqrt () square root 

asin () arc sine 

acos () arc cosine 

atan () arc tangent 

sinh () hyperbolic sine 

cosh () hyperbolic cosine 

tanh () hyperbolic tangent 

Note: All trigonometric functions use degrees. 

log() base 10 logarithm  

ln() natural logarithm 

exp() e to an exponential degree 

abs() absolute value 

ceil() the smallest integer not less than the real 

value  

floor() the largest integer not greater than the real 

value 
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Graph Evaluation Function 

Graph evaluation function enables you to use graph features to drive dimensions 

through relations. The dimensions can be section, part, or assembly dimensions. The 

format is the following: 

evalgraph("graph_name", x) 

where:  

o graph_name—the name of a graph. 

o x—the value along the x-axis of the graph for which the y value is returned. 

For sweep features, you can specify the trajectory parameter trajpar as the second 

argument of this function. 

Note: A graph feature is usually evaluated for its defined x-axis values. When it is 

evaluated beyond the defined range, the y-axis values are extrapolated. The system 

calculates the extrapolated value for values of x less than the initial value by 

extending a tangent line back from the initial point. Likewise, the system calculates 

the extrapolated value for values of x greater than the final value by extending a 

tangent line out from the final point. 

Composite Curve Trajectory Function 

The trajectory parameter of a composite curve, trajpar_of_pnt, can be used in 

relations. 

The following function returns a value between 0.0 and 1.0: 

trajpar_of_pnt("trajname", "pointname") 

where:  

o trajname—the name of a composite curve. 

o pointname—the name of a datum point. 

The trajectory is a parameter along the composite curve at which the plane, normal 

to the tangent of the curve, passes through the datum point. The datum point does 

not have to be located on the curve—the parameter is calculated at the point on the 

curve that is closest to the datum point. 

If the composite curve is used as the spine of a multitrajectory sweep, then 

trajpar_of_pnt either agrees with the parameter trajpar at this plane, or else with 

1.0 – trajpar (depending on your choice of the starting point for the sweep 

feature). 

Operators and Functions for Strings 

The following operators and functions are supported for strings: 

==  Compares strings as equal. 

!=, <>, ~=  Compares strings as unequal. 
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+  Concatenates strings. 

itos(int) Converts integers to strings. Here, int 

can be a number or an expression. 

Nonintegers are rounded off. 

search(string, substring) Searches for substrings. The resulting 

value is the position of the substring in 

the string (0 if not found). 

extract(string, position, 
length) 

Extracts pieces of strings. 

For example: 

If param = abcdef, then: 

• flag = param == abcdef—returns TRUE 

• flag = abcdef != ghi—returns TRUE 

• new = param + ghi—new is abcdefghi 

• new = itos(10 + 7)—new is 17 

• new = param + itos(1.5)—new is abcdef2 

• where = search(param, bcd)—where is 2 

• where = search(param, bcd)—where is 0 

• new = extract(param,2,3)—new is bcd 

Note: If you use the itos function on a parameter whose value is zero (0), the 

return value is an empty string. 

The following examples illustrate the itos function: 

integer_param = 4 

string_param = itos(integer_param)  

/*string_param will return 4 */ 

integer_param = -7 

string_param = itos(int_param)  

/*string_param will return -7 */ 

For an integer with zero (0) value, the itos function returns a null ("") value as 

shown below: 

integer_param = 0 

string_param = itos(int_param)  

/*string_param will return an empty or null string ("") */ 

To return a zero string value ("0"), use the following IF statement: 
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integer_param = 0 

string_param = itos(integer_param) 

IF string_param == "" 

string_param = "0" 

ENDIF 

Specifying the Number of Decimal Places 

You can add an optional argument to both the ceil and the floor functions that 

allows you to specify the number of decimal places for rounding. The syntax for 

functions with the rounding parameter is as follows: 

ceil (parameter_name or number, number_of_dec_places) 

floor (parameter_name or number, number_of_dec_places) 

where number_of_dec_places is an optional value. 

Consider the following information about number_of_dec_places: 

• It can be represented as a number or as a user-defined parameter. If the 

parameter value is a real number, it is truncated to an integer value. 

• It has a maximum value of 8. If this value is exceeded, the number being 

rounded (the first argument) is not rounded and the initial value is used. 

The next examples show how ceil and floor are used without specifying the 

number of decimal places: 

ceil (10.2) evaluates to 11 
floor (–10.2) evaluates to –11 

The next examples show the use of ceil and floor when specifying the number of 

decimal places: 

ceil (10.255, 2) evaluates to 10.26 
ceil (10.255, 0) evaluates to 11 [This is the same as ceil (10.255)] 
floor (10.255, 1) evaluates to 10.2 
floor (–10.255, 2) evaluates to –10.26 

Passing Strings as Arguments in Relations 

The following functions allow you to pass strings as arguments: 

• string_length()—Returns the number of characters in a parameter. For 

example, if the value for the string parameter material is defined as steel, 

string_length(material) equals 5, because the word "steel" has five letters. 

• rel_model_name()—Returns the current model name. For example, if you are 

currently working in a part called A, rel_model_name() is equal to A. To use this 

in a relation in an assembly, write the relation as follows: 

name = rel_model_name:2() 
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Note: The parentheses ( ) are empty. 

• rel_model_type()—Returns the current model type. If you are working in 

Assembly mode, rel_model_type() is equal to assembly. 

• exists()—Evaluates whether an item, such as a parameter or dimension, exists. 

This can apply to the model for which the relation is being evaluated, or to any 

model, component, or submodel structure. 

For example: 

o if exists("d5:20")—Checks if the model with runtime ID 20 has a 

dimension d5. 

o if exists ("par:fid_25:cid_12")—Checks if the feature ID 25 in the 

component ID 12 has parameter par. 

This allows evaluation to be based on a parameter that exists in only one part of 

a large assembly. For example, suppose that there are several systems in a large 

assembly (such as hydraulic, pneumatic, or electrical systems), but the majority 

of objects belong to no system. 

In this case, to make evaluations that are based on the parameter, you must 

assign the appropriate parameter to those models that belong to the system. For 

example, if items in the electrical system must use a part number in the BOM 

report table, instead of the model name, you can create a report parameter 

bom_name and write the following relation: 

if exists("asm_mbr_cabling") 
bom_name = part_no 
else 
bom_name = asm_mbr_name 
endif 

Example: Graph Evaluation Function 

The graph evaluation function enables you to use graph features to drive dimensions 

through relations. The dimensions can be section, part, or assembly dimensions. The 

format is: 

evalgraph("graph_name", x) 

where  

o graph_name is the name of a graph. 

o x is the value along the x-axis of the graph for which the y value is 

returned.  

The next figure shows a sample graph. 
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Graph name: stretch 

• d1=0.5 

• d2=1.5 

• d1=evalgraph ("stretch", 1) 

• d2=evalgraph ("stretch", d1*4) 

Note: For sweep features, you can specify the trajectory parameter trajpar as the 

second argument of this function. 

Parameters Used in Relations 

Using Parameter Symbols in Relations 

You can use the following types of parameters in relations: 

• Dimension symbols—The following dimension symbol types are supported: 

o d#—Dimensions in Part or Assembly mode. 

o d#:#—Dimensions in Assembly mode. The Session ID of the assembly or 

component is added as a suffix. 

o rd#—Reference dimensions in part or top-level assembly. 

o rd#:#—Reference dimensions in Assembly mode. The session ID of 

assembly or component is added as a suffix. 

o rsd#—Reference dimensions in Sketcher (section). 

o kd#—Known dimensions (in parent part or assembly) in Sketcher (section). 

o Ad#—Driven dimensions in Part, Assembly, or Drawing mode. 

• Tolerances—Parameters associated with tolerance formats. These symbols 

appear when dimensions are switched from numeric to symbolic. 

o tpm#—Tolerance in plus-minus symmetrical format; # is the dimension 

number. 

o tp#—Positive tolerance in plus-minus format; # is the dimension number. 

o tm#—Negative tolerance in plus-minus format; # is the dimension number. 
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• Number of instances—Integer parameters for the number of instances in a 

direction of a pattern. 

o p#—Where # is the number of instances. 

Note: If you change the instance number to a noninteger value, Pro/ENGINEER 

truncates it. For example, 2.90 becomes 2. 

• User-defined parameters—Parameters defined by adding a parameter or a 

relation. For example: 

Volume = d0*d1*d2  
Vendor = "Stockton Corp." 

• System parameters—You can change the values of the system parameters in 

the Local Parameters box in the Relations dialog box. The changed values are 

then used in all models for the current session. 

The following parameters are reserved for use by the system: 

o PI (geometric constant)—Value = 3.14159  

Note: You cannot change this value. 

o G (gravitational constant)—Default value = 9.8 meters/sec2  

(C1, C2, C3, and C4 are default values and equal 1.0, 2.0, 3.0, and 4.0, 

respectively.) 

• Application parameters—You can reference application-specific parameters 

from the following applications: 

o Layout 

o Sheetmetal 

o Welding 

o Piping 

o Cabling 

o Mechanism 

o Simulations 

o Manufacturing 

Using String Values for Parameters 

You can enter string values for parameters by enclosing them within double 

quotation marks.  

Consider the following example: A drawing note uses a parameter name within the 

note. The corresponding relation is as follows: 

IF d1 > d2 
MIL_REF = "MIL-STD XXXXA" 
ELSE 
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MIL_REF = "MIL-STD XXXXB" 
ENDIF 

Creating and Editing Relations 

About Adding Relations 

Typically, you add relations by clicking Tools > Relations and using the Relations 

dialog box. 

Additionally, you can add relations in the following ways: 

• Edit the relations file and add more relations. 

• When creating a feature, you can type an expression in the dimension box 

located on the dashboard. When editing a feature, type an expression as a value 

for the dimension.  

• When editing a dimension in the graphics window, double-click a dimension and 

type an expression as a dimension value. 

Adding Relations to Different Types of Objects 

You can add relations to different types of objects. The supported object types, listed 

under Look In in the Relations dialog box, are: 

• Part—Access part relations both in the Part and Assembly modes. 

• Assembly—Access relations in an assembly. 

• Feature—Access relations specific to a feature in the Part or Assembly mode. 

• Inherited—Access relations both in the Part and Assembly modes. 

• Section—If a feature has a section, access section relations in Sketcher while in 

the Part or Assembly mode. 

• Pattern—Access relations specific to a pattern in the Part or Assembly mode. 

• Skeleton—Access relations for a skeleton model in Assembly mode. 

• Component—Access relations for an assembly component. 

Rules for Creating Relations in Parts 

The following rules apply to creating or modifying relations in parts: 

• Driven variables can be as follows: 

o Dimensions in the part (d#)  

o User parameters in the part (parameter_name)  

o User parameters in features (parameter_name:fid_N or 

parameter_name:fid_feature_name)  
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o Driving variables can be the same as the driven variables. In addition, you can 

use:  

o Reference dimensions from the part (rd#)  

o Evaluation feature measurements in the following format: 

o measurement_name:fid_N 

• measurement_name:fid_feature_name 

Rules for Creating Relations in Features 

When you create relations in a feature, they are saved with the feature, and stay 

with it regardless of the model in which the feature is used. 

Feature relations are evaluated after part relations and they are solved when the 

feature to which they belong is regenerated. Therefore, if a relation performs 

geometry evaluation (such as the distance between two points), it can give different 

results if used as a feature relation versus being used as a part relation. 

Note: You can modify existing model parameters by name from the feature level. 

To Add a Relation to a Model 

1. With a model open, click Tools > Relations. The Relations dialog box opens. 

2. The Look in box shows the type of object (for example, part or feature) where 

the relation is applied. If you are in Part mode, by default the relation is added at 

the part level. You can change the object type by changing the selection in the 

Look in box, for example, you can change feature relations or section relations. 

Note: If the pattern_relations_copy configuration option is set to true, the 

relations defined for the geometry to be patterned are copied to other instances 

of the pattern. 

3. If you selected Feature, Inherited, Section, or Pattern as the object type, 

you must select the object for which you want to list relations. The selected 

object shows dimensions in symbolic form. 

4. Type a relation in the text box and press ENTER. You can type multiple 

relations by pressing ENTER after each one. Use the following tools for adding a 

relation: 

o To insert a dimension, geometric tolerance, or surface finish, click it in the 

graphics window. Tip: If dimensions are not displayed, double-click a 

feature to show its dimensions. 

o To insert a function, click . 

o To insert an operator, click an operator listed on the left toolbar of the 

dialog box. 

o To insert a parameter from a list of existing parameters, click .  
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Note: The name of a parameter, variable, or symbol cannot contain more 

than 31 characters. 

5. To specify if the relation should be evaluated in regular order or after a 

regeneration, select Initial or Post Regeneration from the list. 

6. You can verify the validity of the relations you have entered by clicking . 

7. To accept the relations, click OK. To start over, click Reset. 

Specifying a Feature and Model in a Relation 

You can write relations that use the user parameters and manufacturing parameters 

of a feature. 

In a feature relation, you can identify a parameter attached to that feature by the 

parameter name. For example: 

XYZ = parameter_name  

where parameter_name is the user parameter. 

However, if you write a relation in the feature’s parent model (part or assembly) or 

in another feature, you must use one of the following formats to reference that 

feature: 

XYZ = parameter_name:fid_N 

or 

XYZ = parameter_name:fid_feature_name 

where:  

o parameter_name—the user parameter for the feature.  

o N—the internal feature ID (as displayed when you use Info > Feature). 

o feature_name—the optional user-defined feature name. 

In Assembly mode, use the following format to access a user parameter in a feature 

of another model: 

XYZ = parameter_name:fid_N:session_id 

or 

XYZ = parameter_name:fid_feature_name:session_id 

where:  

session_id—the session ID of the model. 

For example, suppose that dia is a number-type user parameter in a part feature 

called CUT_A, CUT_A’s internal feature ID is 20, and d5 is a dimension in another 

feature. 

You can establish a relationship between d5 and dia in the part as follows: 
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d5 = dia:fid_20  

or  

d5 = dia:fid_CUT_A  

In an assembly, if the driving parameter belongs to another model with the Session 

ID 12, you can write the relation as follows: 

d5 = dia:fid_20:12  

or 

d5 = dia:fid_CUT_A:12  

Example: Sample Feature Relations 

The next table shows a sample Relations and Parameters Information window listing 

feature relations. 

Relation Parameter New Value 

/*** Relations for BRICK 

feature id = 282: 
  

param_feat2_x = 6.666 param_feat2_x 6.666000e+00 

param_feat2_yy = 

param_feat1_1:FID_1 

param_feat2_yy 

 

4.567000e+00 

param_feat2_xy:FID_1 = 

param_feat2_x 

param_feat2_xy:FID_1

 

6.666000e+00 

/*   

DEPTH = 2*param_feat2_x DEPTH 1.333200e+01 

/*** Relations for feature 

id 282, section 1: 
  

param_sect_1 = sd0 param_sect_1 5.500000e+00 

sd1 = 2*sd0 sd1 (D32) 1.100000e+01 

/*   

sd3 = 

0.03*param_part_angle1 

sd3 (D34) 2.700000e+00 

Symbolic constant X-refs Current value 

PARAM_FEAT_X Local 6.666000e+00 
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Relation Parameter New Value 

PARAM_FEAT2_YY Local 4.567000e+00 

PARAM_FEAT2_X Local 6.666000e+00 

Example: Sample Part Relations 

The next table shows a sample Relations and Parameters Information window listing 

part relations. 

Relation Parameter New Value 

/*** Relations for BRICK:   

param_part_1 = 1.234  param_part_1 1.234000e+00 

/*   

/* Part parameter 

part_param_part_angle1 is 

used as 

/* a bridge, so that the eval 

function parameter 

/* "angle:fid_angle1" can be 

accessed from a section. 

  

param_part_angle1 = 

angle:FID_ANGLE1 

param_part_angle1 9.000000e+01 

/*   

param_part_1 = 1.234 param_part_1 1.234000e+00 

/*** Relations for feature id 

282, section 1: 
  

param_sect_1 = sd0 param_sect_1 5.500000e+00 

sd1 = 2*sd0 sd1 (D32) 1.100000e+01 

/*   

sd3 = 0.03*param_part_angle1 sd3 (D34) 2.700000e+00 

Symbolic constant X-refs Current 

value 

PARAM_PART_1 Local 1.234000e+00 
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Relation Parameter New Value 

PARAM_PART_ANGLE1 Local 9.000000e+01 

PARAM_SECT_1 Local 5.500000e+00 

Using Comments in Relations 

It is good practice to use comments in your relations. Comments help you remember 

why you added the relation. They also benefit others who use your models. 

Every comment line must begin with a slash and an asterisk. For example: 

/* Width is equal to 2*height  

d1 = 2*d2 

The comment must precede the relation to which it applies. When relations are 

sorted, the comment moves with the relation and remains above it. 

To Determine the Value of an Expression 

You can obtain a value of an expression, either a single parameter or an equation, 

without adding it to the model as a relation. 

1. Click Tools > Relations. The Relations dialog box opens. 

2. Click . The Evaluate Expression dialog box opens. 

3. Enter the parameter symbol (for example, d20, $d20, d10:2, depth), user 

parameter (for example, color), or expression (for example, d5 + d6, d2!= d4) 

in the Expression box. 

4. Click Evaluate. The result of the evaluation appears in the Result box. 

Comparison equations such as d2!= d4 or d3 == d2 return either a 0 (false) or a 

1 (true).  

5. Click Close. 

To Edit a Relation 

You can edit an existing relation using the editing tools in the Relations dialog box. 

1. Click Tools > Relations. The Relations dialog box opens, listing existing part 

relations.  

2. To show relations for a different object type, change the selection in the Look in 

box. 

3. Click Edit and choose an editing command. 

4. When finished editing, click OK. 

5. Regenerate the model to reflect changes in the relations. 
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To Delete an Obsolete Relation 

When you delete or change a dimension or parameter that is used in a relation, the 

relation becomes obsolete. The driven symbol retains the last correct value of the 

dimension.  

Note: Pro/ENGINEER does not automatically delete them. You must manually delete 

obsolete relations. 

To delete an obsolete relation, click Edit > Delete on the Relations dialog box. 

Viewing Relations 

To View a Relation 

You can view existing relations using the Show command in the Relations dialog 

box.  

Tip: You can also use Info > Feature to view feature relations.  

1. Click Tools > Relations. The Relations dialog box opens. 

2. By default, the system shows part relations. You can change the object type in 

the Look in box to show relations of a particular object type, for example, 

feature relations or section relations.  

3. If you selected Feature, Inherited, Section, or Pattern in the Look in box, 

you must select the object for which you want to list relations. 

4. Click Show > Info. The Relations and Parameters Information window opens 

in the Pro/ENGINEER browser.  

Relations and Parameters Information Window 

The Relations and Parameters Information window is organized as follows: 

• In a part or assembly—Displays the relations and user parameters created in 

that model and in its feature sections. It does not list relations or parameters 

created in its features. 

• In a feature—Displays relations created in that feature and in its sections (if 

applicable), as well as user parameters created in that feature. 

• In a pattern—Displays pattern parameters, relations, and user parameters 

created in that pattern for the selected direction, as well as user parameters and 

section relations in the parent model.  

• In a section—Displays the relations created in that section only. 

User parameters are displayed under the heading Symbolic constant with the 

following information: 

• Parameter name 

• Cross-reference status—either Local (associated only with a part or assembly) or 

Global (associated with a project) 
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• Number of cross-references if the parameter is global 

• Current value of the parameter 

Sorting Relations 

About Sorting Relations 

The sort function sorts relations in order of precedence, based on how they are 

evaluated by the system. If one relation depends on the value of another relation, it 

is reordered accordingly. Sorting relations helps you detect undesired circular 

relations. 

To sort relations, click  on the Relations dialog box or click  Utilities > Reorder 

Relations. 

Note: Relations containing conditional statements are not sorted. 

Sorting Relations with Comment Lines 

Relations with comment lines can also be sorted. The comment line is attached to 

the relation below it, and moves with that relation during a sorting. If multiple 

comment lines precede a relation, they are attached to that relation. 

Example: Sorting Relations 

Example 1: Sorting Regular Relations 

For example, you entered the following relations: 

d0 = d1 + 3*d2 
d2 = d3 + d4 

When you sort the relations, the system reorders them based on the order in which 

they will be evaluated. The sorted relations appear as follows. 

d2 = d3 + d4 
d0 = d1 + 3*d2 

Example 2: Sorting Simultaneous Equations 

A set of simultaneous equations is treated as if it is a single relation, and is moved 

around as a unit. This unit is considered to be dependent upon the union of all the 

quantities that its individual lines depend upon. A simultaneous equation may 

contain additional relations that are not being solved, as shown in the following 

example: 

SOLVE 

d1 + d2 = 500 

d55 = d56 + 50 

d56 = d54 
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d1—d2 = 0 

FOR d1 d2 

The extra lines are sorted within the body of the simultaneous equation, producing 

the following result: 

SOLVE 

d1 + d2 = 500 

d1-d2 = 0 

d56 = d54 

d55 = d56 + 50 

FOR d1 d2 

Note: Lines are never inserted into or removed from simultaneous equations. 

Dimensions and Relations 

To Switch Dimension Format to Symbolic 

When you click Tools > Relations, Pro/ENGINEER switches the dimension display to 

symbolic format (for example, d0).  

You can switch between symbolic and numeric dimension formats in one of the 

following ways: 

• In the Relations dialog box, click Utilities > Switch Dimensions. 

• On the menu bar, click Info > Switch Dimensions. 

Tip: If dimensions are not already displayed on the model, select the feature or part 

whose dimensions you want to display.  

Note: Symbolic tolerances appear only for dimensions with plus-minus or 

symmetrical formats. Other format types display only the dimension symbol. 

Negative Dimensions in Relations 

If you are using negative dimensions, and you want to capture the true signed value 

in your relation, precede the symbol with a dollar sign (for example, $d20 or 

$depth). 

You must do this regardless of the setting for the  show_dim_sign configuration 

option.  

Tip: Click Utilities > Highlight in the Relations dialog box to display a specific 

dimension. 

Modifying Dimensions Driven by Relations 

If a dimension is driven by a relation, the dimension cannot be modified directly. If 

you try to do so, Pro/ENGINEER displays an error message. 

For example, if you enter the relation d0=d1+d2, you cannot modify d0 directly. You 

must modify d1 or d2, or edit the relation in order to change the value of d0. 
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If a dimension symbol is modified, the change is automatically reflected in the 

relation file. 

Relations in Sections 

About Creating Relations in Sections 

A section relation captures relationships among section entities. The section relation 

is stored with the section and is evaluated by the system regardless of where the 

section is used. 

You can use the following variables in the section relations: 

• Driven variables can be as follows: 

o Dimensions in the section (sd#) or in the parent model (d#)  

o In Assembly mode, dimensions in another model (d#:#)  

o User parameters in the parent model only (no session-ID suffix allowed) 

• Driving variables can be as follows:  

o Dimensions in the section (sd#, rsd#, or kd#), parent model (d#, rd#), or 

other model in an assembly (d#:#, rd#:#) 

o User parameters in the parent model only (no session-ID suffix allowed) 

Tips for Creating Section Relations 

• Relations that define dimensions other than section dimensions are best defined 

at the feature or model level.  

• You cannot reference a parameter in another feature as a driving variable. For 

example, if dia is a dimension in another feature with fid_20, the system does 

not accept the following section relationship: 

sd3 = dia:fid_20 

However, you can establish the same relationship at the feature level or model 

level by using the model-level equivalent (d#) of the section dimension (sd#). 

Alternatively, you can create an intermediate user parameter in the parent model 

and then reference it from the section. 

• If you try to assign a relation outside of the section to a parameter that is already 

driven by another relation in the section, the system issues an error message 

upon regeneration. The same applies if you try to assign relations in a section to 

a parameter that is already being driven by a relation outside the section. 

Remove one of the relations and regenerate again. 

• When you create a relation of a graph feature, for example, 

sd1=evalgraph("CONIC......", trajapar....), this relation becomes a 

feature relation. Feature relations are evaluated after part relations and are 

solved when the feature to which they belong is regenerated. Therefore, if a 
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relation performs geometry evaluation (for example, the distance between two 

points), it can give different results if used as a section relation as opposed to 

being used as a part relation. 

Specifying User-Defined Parameters in Sections 

At the section level (Sketcher mode), user parameters can be created only through 

relations.  

The user parameters are evaluated and stored in the parent model where they can 

be accessed as other model parameters. You can also assign relations in a section to 

user parameters in the parent model.  

Note: You cannot access user-defined parameters from the parent feature of the 

section.  

If you choose Show for the parent model (Tools > Relations > Show in the 

Relations dialog box), the Information window displays the relations in the top level 

of that model and in the feature sections (but not at the feature level) and it lists the 

user parameters under the heading Symbolic constant. It does not make any 

distinction between parameters created at the model level and those created at the 

section level. The parameters are listed in order of creation. 

You can modify or use user-defined parameters from the parent model in section 

relations. You can assign values to the same parameter in several sections. After 

regeneration, the parameter has the value of the last relation to be evaluated.  

Note: If you try to assign a relation outside the section to a parameter that is 

already driven by another relation in the section, you get an error message when the 

system regenerates the model. The same applies if you try to assign relations in a 

section to a parameter that is already being driven by a relation outside the section. 

Remove one of the relations and regenerate. 

Example: Sample Sections Relations 

The following table shows a typical Information window for one of the sections used 

in the part. 

Relation  Parameter New Value 

/*** Relations for section:   

param_sect_1 = sd0 param_sect_1 5.500000e+00 

sd1 = 2*sd0 sd1 (D32) 1.100000e+01 

/*   

sd3 = 0.03*param_part_angle1 sd3 (D34) 2.700000e+00 
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Relations in Assemblies 

To Specify a Parameter in Another Model 

If you refer to a parameter that belongs to another model, the parameter must 

include the Session ID of the referenced model. 

The format for assembly relations is as follows: 

XYZ = parameter_name:session_id 

where  

o XYZ is a parameter in the currently selected model. 

o parameter_name is a parameter in the referenced model. 

o session_id is the Session ID of the referenced model.  

In the general case, you can express the preceding relations as follows: 

XYZ:session_id_1 = parameter_name:session_id_2 

where  

o session_id_1 is the Session ID of the driven parameter’s model. 

o session_id_2 is the Session ID of the driving parameter’s model. 

To Determine the Session ID of a Model in Assembly Mode 

1. With an assembly open, click Tools > Relations. The Relations dialog box 

opens. 

2. Click Show > Session ID. The MODEL INFO menu appears. 

3. Select one of the following object types: 

o Assembly 

o Part 

o Skeleton 

4. Select a component. The name and Session ID of the object appear in the 

message window. 

Using a Session ID of a Component in Assembly Relations 

When you create a parameter that belongs to a model (assembly or component) 

other than the current model, the parameter must include the Session ID of that 

model as a suffix in the dimension symbols.  

Note: The use of Session ID for parameters in the current model is optional. 

You can view the Session ID of a component by clicking Show > Session ID in the 

Relations dialog box. 
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In an assembly, the following terms are equivalent for components: 

• Component Number = Feature Number  

• Component ID = Feature ID  

How a Session ID is Generated 

When an assembly is created or retrieved into a session, each unique model 

(whether a top assembly, subassembly, or part) is assigned its own Session ID. 

If a model is used more than once in an assembly, each occurrence of the model has 

a unique Component Number and Component ID, which relate to its parent 

assembly. However, all occurrences of the model share the same Session ID. While 

the model is in session, it retains the same Session ID, even if it is used in different 

assemblies.  

Different instances of a table-driven model have different Session IDs.  

Example: Session IDs for Models in an Assembly Tree 

The following example lists typical Session IDs assigned to the components during a 

Pro/ENGINEER session.  

Model Session ID 

TEST_ASSY.ASM 1 

BASE_ASSY.ASM 3 

BASEPLATE.PRT 6 

BUSHING.PRT 2 

SNAPRING.PRT 4 

BASEPLATE_1.PRT 8 

Using an Internal Component ID in Assembly Relations 

When creating a relation in Assembly mode, you may need to know a Component 

internal ID. Every component in an assembly has a unique Component ID, even if 

two components have the same component name and therefore the same Session 

ID.  

Use the following syntax when referencing a Component ID: 

d#:cid_(component ID #) 

To determine the Component internal ID:  

1. Click Info > Component. The Component Constraints dialog box opens.  

2. Select a component. 
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3. Click Apply on the Component Constraints dialog box. The Information 

window displays the component information including the Component ID. 

Note: The Model Tree in Assembly mode displays the Feature ID (the same as the 

Component ID) of each assembly component.  

Example: Using a Component ID in an Assembly Relation 

If you create an assembly in which the same generic components is assembled 

twice, you can write the following relation to sum up the lengths of these two 

components: 

Total_length = d3:2 + d3:2 

where d3 is the dimension and 2 is the Session ID of the generic. 

If you replace one of the generic components  with an instance from its Family Table, 

this relation is no longer accurate. If the assembly contains one generic and one 

instance, you can change the relation to read as follows: 

Total_length = d3:4 + d3:4 

where d3 is the dimension and 4 is the Session ID of the instance that replaced the 

generic. 

Pro/ENGINEER cannot determine which of the two dimensions must be updated to 

reflect the Session ID of the instance. To address this situation, you can write 

assembly relations using internal Component IDs (cid) which are unique for every 

assembly component.  

If  you are using two identical generic components as in the first example, the 

relation changes as follows: 

Total_length = d3:cid_1 + d3:cid_3 

where: 

o d3—the dimension 

o cid_1—refers to the first generic component 

o cid_3—refers to the other generic component. 

If one of the generic components is replaced with one of its instances, the relation is 

properly updated to reflect this change and total_length properly calculates the 

sum of the lengths of the generic component and the instance component. 

Example: Sample Assembly Relations 

The following example shows some typical relations for the assembly Model Tree. 
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C Programs and Relations 

About an Interactive C Program 

You can create your own interactive program to drive model geometry through 

relations. Consider the following information on creating user programs: 

• The User Prog command is available only in Part and Sketcher modes. 

• Only one user program may be edited or run at a time. However, you can write 

multiple programs for each part and then run them sequentially. 

• Each program is limited to a single entry subroutine, called "USRMAIN ()." The 

entry subroutine can call other subroutines in that program file. 

• Pro/ENGINEER provides a C file template usermain.c to help you write and use 

user programs.  

• You must capitalize Pro/ENGINEER dimensions in user programs. 

• Use D[i] to refer to a dimension on the screen. This symbol corresponds to di in 

Part or Assembly mode or to sdi in Sketcher mode. The system does not accept 
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a user-assigned symbol name, such as width, instead of the system-assigned 

dimension symbol.  

• Do not use exit statements in any of your routines. To build error handling into 

your program, use printf or fprintf statements. 

• You cannot drive assembly dimensions or pattern instance numbers using user 

programs. 

To use an interactive program, you must complete the following steps: 

1. Create a program. Alternatively, you can create a program by editing an existing 

program. 

2. Compile and link the program. 

3. Run the program to implement the changes. 

4. When the program is finished running, regenerate the model to update geometry. 

To Edit an Interactive C Program 

Use this procedure to create a new or edit an existing program. 

1. Click Tools > Relations. The Relations dialog box opens. 

2. Click Utilities > User Prog > Edit.  

3. Enter the program name without the .c extension. An editor window opens. If 

you are editing an existing program, Pro/ENGINEER retrieves the specified 

program file. 

4. If you are creating a new program, you must first copy the C file 

templateusermain.c into the editor. Do one of the following:  

o On UNIX—Use the editor defined by the configuration file option 

pro_editor_command. If you are using the vi editor, enter [:], and then 

[r $PRO_USRMAIN]. PRO_USRMAIN is an environmental variable that contains 

the path to usermain.c. 

o On Windows—Use the Windows Notepad editor. Open a template file and 

save it using Save As.  

5. Edit the program. 

6. Save the program. Pro/ENGINEER becomes active. 

Note: You can define only dimension symbols. 

Using the usermain.c Template 

Pro/ENGINEER provides a C file template usermain.c to help you write user 

programs. This template has full read and write access to the parameter list through 

the C programming environment. The template describes how to use parameters as 

variables, how to declare nonparameter variables, and where to enter the executable 

routines.  The template is stored in the .../usrprog/umain directory.  
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If you want to add your own include files, enclose their names in quotes: 

#include "my_funcs.h" 

The system looks for those files first in the current directory and then in the directory 

defined by the environment variable PRO_USRINCS. By default, PRO_USRINCS is 

usually defined as the directory that contains usermain.c. If you want the system to 

look in another directory, you can either change the value of PRO_USRINCS 

appropriately or provide the full path of the file in the include statement: 

#include "/usr/C_libs/my_funcs.h" 

To Determine Environment Variables 

Use this procedure to determine the paths of the current environment variables. 

1. Click Window > Open System Window.  

2. When the shell window opens, do the following: 

o On UNIX, enter the following command: 

[echo $PRO_USRMAIN $PRO_USRINCS] 

o On Windows, enter the following command: 

[echo %PRO_USRMAIN% %PRO_USRINCS%] 

The system prints the full paths in the shell window. 

To Link an Interactive C Program 

After you edit a C program, you must compile and link it. Consider the following 

information for compiling a program: 

• On UNIX—You must define the directory path to the compiler/linker utility "cc" in 

the search path of the environment variable PATH. 

• On Windows—You must define two environment variables: 

o NT_COMPILER—Its value must be the 32-bit incremental C compiler 

command.  

o LIB—Its value must be the directory path from the load point of the 

compiler to its libraries (.LIB files). 

1. Click Tools > Relations. The Relations dialog box opens. 

2. Click Utilities > User Prog > Link. The system starts compiling the program. If 

the system detects errors, it prints error messages in the startup window. If 

necessary, edit and relink the program.  

To Execute an Interactive C Program 

After you successfully link a user program, you can run it to implement the changes. 
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Note:  

• The system does not run user programs automatically. You must rerun the 

program each time you want to update the part.  

• Upon completion of the program, you must regenerate the part to update 

geometry. 

1. Click Tools > Relations. The Relations dialog box opens. 

2. Click Utilities > User Prog > Run.  

3. Enter the program name. The program begins executing. Any printed output is 

written to the startup window. The program prompts you for necessary input. 

When you execute the program, the system creates two temporary files: 

o spgtousr.dat lists the parameters and their values before the program is 

executed.  

o usrtospg.dat lists the parameters and their values after the program is 

executed.  

You can delete these files after you make sure the program runs properly. 

4. When the program is finished running, regenerate the model to update geometry. 

Example: User Program 

The program computes the thickness of a pressure vessel based on its diameter and 

material parameters such as working pressure and allowable stress. The program 

derives the diameter from the model. The user enters material parameters in the 

startup window according to prompts. The computed thickness is passed back to 

Pro/ENGINEER. 

[Program starts with next line] 

/* Template for writing user programs in the Pro/ENGINEER environment */ 

/* the following definition and include file are necessary */ 

#define USRMAIN 

#include "spgusrgl.h" 

/* This include file establishes useful variables for user needs. Those 
are: 

1. D[i] refers to dimensions you see on the screen. ‘i’ is the index of 
a  

dimension you see on the screen. 

So, D[0] has a value corresponding to "d0" on the screen (or "sd0" if 
you are  

in SKETCHER mode). D[4] corresponds to "d4" (or "sd4") on the screen, 
and so forth. 
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2. DIM_NUM Total number of dimensions on the screen. 

*/ 

usrmain() 

/* This program computes the thickness for a pressure vessel given the 
diameter from the model and various material and design constants input 
by the user. */ 

{  

/* ---------------------- local variables ----------------------- */ 

/* Declare any additional variables or functions you need here. */ 

double sqrt (); 

double thickness, f_s, joint_eff, allow_stress, press, dia; 

/* ---------------------- executable code ----------------------- */ 

/* Prompt user for input. Prompts appear in the startup window. You must 
also  

enter your responses there. */ 

printf("Enter material parameters\n"); 

printf("\n Working Pressure [psia]:\n"); 

scanf("%lf", &press); 

printf("\n Factor of Safety [ ]:\n"); 

scanf("%lf", &f_s); 

printf("\n Joint efficiency [ ]:\n"); 

scanf("%lf", &joint_eff); 

printf("\n Allowable stress [psia]:\n"); 

scanf("%lf", &allow_stress); 

/* Compute thickness of pressure vessel based on equations in Mechanical 
Analysis  

and Design, A.H. Burr, Elsevier, 1982. 

Note use of dimension D[2], the pressure vessel diameter, in computing 
the new  

thickness */ 

thickness = press * D[2] * f_s / (2 * joint_eff * allow_stress); 

/* Pass new thickness back to Pro/ENGINEER */ 

D[3] = thickness; 
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}  

[Program ends with previous line] 

Parameters 

About User Parameters 

User parameters are useful for providing additional information about an object. For 

example, in Family Tables the parameter Cost may have a different value for each 

instance. User parameters are stored with the model. You can add a parameter 

without defining a relation. To view existing user parameters, click Tools > 

Parameters.  

Methods for Creating Parameters 

You can add parameters in different ways: 

• Click Tools > Parameters and use the Parameters dialog box. 

• In the Model Tree, right-click a feature for which you want to add parameters, 

and then select Edit Parameters on the shortcut menu. Note: You can select 

multiple objects and then use the Edit Parameters command to simultaneously 

create or edit common parameters in all selected objects. 

• For Annotation element parameters, click  to access the Annotation Feature 

dialog box. Click an element for which you want to define a parameter, and then 

click Parameters.  

Specifying the Object Type  

You can add user parameters to different object types that are listed in the Look in 

box in the Parameters dialog box. The following object types are supported: 

• Assembly—Access assembly parameters. 

• Skeleton—Access skeleton parameters. 

• Component—Access component parameters. 

• Part—Access part parameters. 

• Feature—Access feature parameters. 

• Inherited—Access inherited parameters. 

• Quilt—Access quilt parameters 

• Surface—Access surface parameters. 

• Edge—Access edge parameters. 

• Curve—Access curve parameters.  

• Composite Curve—Access composite curve parameters. 
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• Annotation Element—Access parameters defined for an element of an 

annotation feature. 

• Material—Access material parameters. 

Rules for Naming Parameters 

Consider the following rules for naming user parameters: 

• User parameter names must begin with a letter if they are to be used in 

relations. 

• You cannot use d#, kd#, rd#, tm#, tp#, or tpm# as user parameter names 

because they are reserved for use with dimensions. 

• User parameter names cannot contain nonalphanumeric characters such as !, @, 

#, and $. 

• You cannot change the name of a user parameter once it has been created. 

About Parameter Properties 

For each parameter, you can define the following properties: 

• Name—You cannot edit the name of an existing user-defined parameter. 

• Type—The following parameter types are supported: 

o Integer—The value for this parameter is a number. 

o Real Number—The value for this parameter is a decimal number. 

o String—The value for this parameter is a string. 

o Yes No—The value for this parameter is YES or NO. 

o Note—The value for this parameter is the ID of a model note. 

o Value—Specifies the parameter value. 

o Unit—Defines units for a parameter from the list of units.  

Note: You can define units only for the parameter type Real Number and only 

while creating a parameter. 

• Designate—You can designate selected system and user parameters for use as 

attributes in Pro/INTRALINK or another PDM system. 

• Access—Defines access to the parameter as follows: 

o Full—Parameters with full access are user-defined parameters. You can 

modify these parameters from any application. 

o Limited—You can set full access parameters to limited access. You cannot 

modify parameters with Limited access by a relation. Limited access 

parameters are modified only through Family Tables and Program. 
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o Locked—Parameters with locked access are parameters that can be locked 

either by an external application such as Data Management System, 

Analysis features, Relations, or Program, or by a user. You can modify 

parameters locked by an external application only from within an external 

application. You cannot modify user-defined locked parameters from within 

any external application. 

o Source—Indicates where the parameter was created or from where it is driven. 

o Description—Provides a description for the parameter. 

o Restricted—Indicates restricted value parameter whose properties are defined 

by an external file.  

Nonassociativity of User Parameters 

The values of parameters defined using Tools > Parameters are non-associative. 

Even if you define the parameter value using a system-defined parameter such as a 

dimension or mass property parameter, these values do not update upon 

regeneration of the model. Pro/ENGINEER requires you to add a relation to make 

parameter values associative.  

For example, if you have a cube that measures 10x10x10 units, and if you create a 

parameter LENGTH = d5, LENGTH is initially evaluated to 10. However, if you modify 

d5 to 20, LENGTH remains 10. 

To associate the parameter value with the model: 

1. Click Tools > Parameters and add a parameter LENGTH=15.  

2. Click Tools > Relations and add a relation d5=LENGTH. 

3. When you regenerate the model, d5 updates to the new value of 15. 

Using the Parameters Dialog Box 

You can access the Parameters dialog box by clicking Tools > Parameters on the 

Pro/ENGINEER menu bar. However, while working with NC or CMM objects, you can 

open the Parameters dialog box by clicking Setup > Parameters on the menu 

manager. 

Use the Parameters dialog box to: 

• Search for parameters 

• Select parameters 

• Use filters 

• Delete parameters 

• Use parameter table information 

• Work with rows and columns 
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To view the properties of a parameter, select a parameter in the Parameters dialog 

box and click Properties to open the Parameter Properties dialog box. 

You can update the value of an existing parameter and use  or Edit > 

Regenerate to regenerate the model without leaving the Parameters dialog box.  

Searching for Parameters   

Use  or Edit > Find in the Parameters dialog box to search for parameters 

either by name, value, or any other property. You can select the following parameter 

properties in the Search dialog box: 

• Name 

• Type 

• Value 

• Unit 

• Designated 

• Access 

• Source 

• Description 

• Restricted 

You can search for parameter types by typing the first letter or the first few letters of 

its value followed by an asterisk (*). For example, NAME = len* displays parameter 

names starting with the letters len in the Parameters dialog box.  

Selecting Parameters 

You can select parameters in the Parameters dialog box in the following ways: 

• Select Only Shared in the Filter By list to view, select, and edit all the 

parameters shared by the multiple features selected in the Look In list. 

• Click the row header for the required parameter to select the entire row in the 

parameter table. You can also right-click the row header and use the shortcut 

menu to select a parameter, create a new parameter, edit parameter properties, 

delete a parameter, designate a parameter, specify a unit for a parameter, and 

view information for a parameter. 

Note: The row header precedes the first column of the each parameter row in 

the parameter table. 

• Press CTRL as you click for random selection of multiple items. 

• Press SHIFT as you click to select all the parameters between the first and last 

selected entries.  
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• You can select multiple parameters and perform the following operations: 

Operation Condition Result 

Delete Not applicable if 

a parameter is 

locked. 

Deletes all 

selected 

parameters. 

Designate Applicable if at 

least one or 

more 

parameters are 

not designated. 

Designates all 

selected 

parameters. 

Undesignate Applicable if at 

least one or 

more 

parameters are 

designated. 

Undesignates all 

selected 

parameters. 

Filtering Parameters 

Using Filter By, you can filter the parameters by the following main categories: 

• All 

• User Defined ONLY 

• PDM ONLY 

• Designated ONLY 

• Type 

• Access 

Note: The Sub Items option is available only when you select Type and Access. 

You can hide or show the filter by clicking Edit > Hide Filter or Edit > Show Filter, 

respectively. 

Deleting Parameters 

Consider the following rules when deleting parameters: 

• You cannot delete a user parameter that is driven by a relation or used in a 

relation. You must first delete the relations where the parameter is used before 

deleting the parameter.  

• You cannot delete an individual parameter belonging to a table restricted set. 

However, you can delete the entire table restricted set. 

• If you have added a parameter column to the Model Tree, you can delete the 

parameter by clearing the corresponding cell on the Model Tree. 
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Using Parameter Table Information 

Use File > Export in the Parameters dialog box to export the entire parameter 

table in the Comma Separated Value (CSV) format or in the text format.  You can 

open such a CSV file in Microsoft Excel. 

Working with Rows and Columns  

You can manipulate columns in the Parameters dialog box as follows: 

• You can add or remove a column in the Parameters dialog box. To add a 

column, click  to open the Parameter Table Columns dialog box. Select the 

required column name from the Not Displayed section, and click . Click OK. 

The column is added to the Parameters dialog box. Similarly, to remove a 

column click , select the required column name from the Displayed section 

and click  to transfer the column name to the Not Displayed section. 

• You can sort the listed parameters in ascending or descending order based on the 

contents of a column by clicking its column header. Clicking the column header 

again reverses the sort order. 

• You can resize the columns. Pro/ENGINEER retains the changed column size and 

its position. 

• You can also reorder parameter rows by moving one or more rows in the upward 

or downward direction by clicking the arrows located at the right of the 

parameters table in the Parameters dialog box. The new order of parameters is 

retained even after the model is saved. 

Syntax for Including Parameters in Notes 

To include parameters in a note, use the syntax shown in the next table. 

Syntax Usage 

&<param_name>:FID_<feat_ID> Include 

feature 

paramete

rs in a 

note. 

&<param_name>:SID_<surface_name> Include 

surface 

paramete

rs in a 

note. 

&<param_name>:EID_<edge_name> Include 

edge 

paramete
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Syntax Usage 

rs in a 

note. 

&<param_name>:CRV_<curve_name> Include 

curve 

paramete

rs in a 

note. 

&<param_name>:CCRV_<composite_curve_name> Include 

composite 

curve 

paramete

rs in a 

note. 

&<param_name>:NID_<annotation_element_name> Include 

Annotatio

n Element 

paramete

rs in a 

note. 

&<param_name>:QID_<quilt_name> Include 

quilt 

paramete

rs in a 

note. 

&<param_name>:MTRL_<material_ID> Include 

material 

paramete

rs in a 

note. 

Including Multiple Parameters in a Single Note 

You can include multiple parameters in a single Annotation Element note. 

Consider the following example: 

Suppose, in your note you want to reference parameters of two features: 

• Cut (id 66), which has the following parameters defined: 

o HOLE_TYPE with a value M6 

o HOLE_DEPTH with a value 10 

o Chamfer (id 115), which has the following parameters defined: 
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o CHAMFER_LENGTH with a value of 1 

o CHAMFER_ANGLE with a value of 45 

To include these parameters, create the following note: 

&HOLE_TYPE:FID_66 hole, &HOLE_DEPTH:FID_66 deep 

with chamfer &CHAMFER_LENGTH:FID_115 X &CHAMFER_ANGLE:FID_115° 

The resulting note appears as follows: 

M6 hole, 10 deep 

with chamfer 1 X 45° 

Using a Note Parameter to Include Model Notes in Family Tables 

Use a note parameter to include model notes in Family Tables and lists of relations. 

The value of a note parameter is the ID of a model note. The parameter can be 

included in a Family Table, with different instances using different notes present in 

the generic component. In addition, when you show relations for the model, all note 

parameters are listed, including their ID and textual content. 

To Create a Parameter 

1. Click Tools > Parameters. The Parameters dialog box opens. 

2. Under Look In, select the desired object type to which you want to add a 

parameter. If you select Feature, Inherited, Section, Pattern, or Annotation 

Element as the object type, you must select the object for which you want to list 

relations. 

3. Click  and type a new parameter name in the Name column. 

Note: Parameter names cannot contain nonalphanumeric characters such as !, ", 

@, and #. 

4. Under Type, select the type of parameter that you want to add.  

5. Specify the value of the selected parameter in the Value box. 

6. Optionally, select the Designate box to make the parameter visible in the PDM 

system such as Pro/INTRALINK or Windchill. 

Note: You can also designate feature level or geometry level parameters in a 

part. When you assemble a part with designated parameters in an assembly, the 

designated parameters are listed in the assembly BOM if you have configured the 

BOM to show the designated objects. 

7. Under Access, specify access to the parameter as Full, Limited, or Locked. 

The Source cell reflects the origin of the parameter, for example, User-Defined.  

8. Optionally, add a note about the parameter under Description. 
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9. Click OK. 

Note:  

• You can use Edit Parameters on the shortcut menu to edit single as well as 

multiple items. 

• If you have included a parameter in a Family Table, layout note, or relation, then 

you can also modify the parameter by editing that Family Table, note, or relation. 

Tip: Creating Common Parameters 

Use the Edit Parameters command as follows to create parameters common to 

different features in a model. 

1. Holding down the CTRL key, select multiple entities or Annotation Elements on 

the Model Tree, for which you want to create common parameters. 

2. Right-click the selected entities and click Edit Parameters on the shortcut 

menu. In the Edit Parameters dialog box that opens, the Look In list displays 

the entities selected on the Model Tree. The parameters table displays common 

parameters with the first common parameter selected by default. 

Note: To create a new common parameter for all the entities selected in the 

Look In list, you must clear the selection of the parameter selected by default. 

Otherwise, the new parameter is created for the feature to which the selected 

parameter belongs. 

3. Click  to create a parameter. A new common parameter is created. 

To Delete a Parameter 

1. Click Tools > Parameters. The Parameters dialog box opens. 

2. Click the parameter name that you want to delete. 

3. Click . The selected parameter is deleted. 

About Copying Parameter Definitions 

You can copy parameter definitions between models or features in the same session. 

However, you can copy the parameter definitions only within the Parameter dialog 

box. 

While copying the parameters or parameter definitions, you can copy: 

• Multiple parameter definitions at the same time 

• The user-defined parameters and user-locked parameters but not system 

parameters 

• Parameters from a restricted parameter table 
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• Only the value of the parameters definition but not the relation argument while 

copying a relation-driven parameter 

• Parameters from different context, such as a feature parameter and a model 

parameter at the same time if you are viewing multiple parameters 

To Copy Parameters between Two Models in Session 

1. Click Tools > Parameter. The Parameters dialog box opens. 

Note: In NC Manufacturing or Pro/CMM, you can open the Parameters dialog 

box by clicking Setup > Parameters on the menu manager. 

2. Right-click any cell for the parameter definition that you want to copy. A shortcut 

menu appears. 

Note: To select more than one parameter definition at a time, hold down the CTRL 

key and select the required parameter definitions. 

3. Click Select Parameter.  

4. Click Edit > Copy. The selected parameter definition is copied to the clipboard. 

Note: You can paste the copied parameter even if you close the Parameters 

dialog box, and open it but in the same session. The clipboard content remains 

valid as long as all source models, from where the parameters are copied, are in 

session. If you end the session, the clipboard is cleared. 

5. Open another model or select another feature to which you want to copy the 

selected parameter definition. 

6. Click Edit > Paste. The parameter definition is copied to the selected model or 

feature. 

Note: If the name of the parameter being copied already exists in the model to 

which it is being copied, the Paste Override dialog box opens. Click Confirm to 

replace the existing parameter definition with the copied parameter definition.   

To Designate Parameters for Use in Pro/INTRALINK 

Before you designate the parameter in Pro/ENGINEER, a system administrator for 

Pro/INTRALINK must create a parameter within Pro/INTRALINK. This parameter must 

have the same name as the model parameter that you want to designate, and must 

be specified as file-based. For more information about setting up parameters in 

Pro/INTRALINK, refer to the Pro/INTRALINK Administration Guide. 

1. Click Tools > Parameters. The Parameters dialog box opens. 

2. Locate the parameter and click the cell under Designate. 

Note: The designated dimensions are displayed along with its database names. For 

example, LENGTH (d0), WIDTH (d1), and so on. 
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Using the Designate Dialog Box 

The purpose of designating parameters is to: 

• Make model parameters visible to a PDM system such as Pro/INTRALINK or 

Windchill. 

• Make the part level feature or geometry level designated parameters appear as a 

component in an assembly BOM. 

You can designate a parameter using one of the following methods: 

• Click Tools > Designate. 

• Click Edit > Setup > PART SETUP > Designate. 

The Parameters Table tab that is selected by default, displays or lists the 

properties of the designated parameters. 

To add attributes of a designated item such as dimensions or detail items, click the 

Attributes tab and click . 

You can add designated items such as a Feature, Curve, Surface, Edge, Composite 

Curve, Quilt, or Annotation Element to the list of designated objects by clicking the 

Objects tab. 

Arranging Columns in the Designate Dialog Box 

You can manipulate columns in the Designate dialog box as follows: 

• Add or remove columns.  

• Sort the listed parameters in ascending or descending order. To sort, click the 

header of the column whose contents are to be sorted. For example, you can sort 

common parameters by type. The arrow next to the column header indicates the 

order of sorting, that is, ascending or descending. 

To add a column: 

1. In the Designate dialog box, click  to open the Parameter Table Columns 

dialog box.  

2. Click the column name, for example, Description, and click .  

3. Click OK. The column is added to the Designate dialog box. 

Filtering Parameters 

Using Filter By, you can filter the parameters by the following main categories : 

• All 

• User Defined ONLY 

• PDM ONLY 
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• Designated ONLY 

• Type 

• Access 

Note: The Sub Items option is available only on selecting Type and Access. 

You can hide or show the filter by clicking Edit > Hide Filter or Edit > Show Filter, 

respectively. 

Searching Parameters 

Use  to search for parameters either by name or value. You can select the 

following parameter types and values in the Search dialog box: 

• Name 

• Type 

• Value 

• Unit 

• Designated 

• Access 

• Source 

• Description 

• Restricted 

You can search for parameter types by typing the first letter or the first few letters of 

its value followed by an asterisk (*). For example, NAME = len* displays parameter 

names starting with the letters len in the Designate dialog box. 

Selecting Parameters 

You can select multiple parameters and perform the following operations: 

Operation Condition Result 

Delete Not applicable if 

a parameter is 

locked. 

Deletes all 

selected 

parameters. 

Designate Applicable if at 

least one or 

more 

parameters are 

not designated. 

Designates all 

selected 

parameters. 

Undesignate Applicable if at Undesignates all 
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least one or 

more 

parameters are 

designated. 

selected 

parameters. 

Units in Parameters and Relations 

About Units in Parameters 

You can assign units to new user-defined parameters of the type Real Number. 

existing parameters are considered unitless. 

Note: You cannot change a unitless parameter into a parameter with units. 

You can show units in the BOM and Pro/REPORT by adding units to the report table. 

Parameter units for each designated parameter are available to the PDM system such 

as Pro/INTRALINK, Windchill, or PDMLink. 

Consider the following information on the use of units: 

• Units are not supported for layout and drawing parameters. 

• The system parameters as well as alternate and reported parameters are derived 

from the current model units. 

To Specify Units for a Parameter 

By default, a new parameter is created unitless.  

1. In the Parameters dialog box, click  to add a parameter. 

2. If the Units column is displayed, click the cell under Units and select a unit from 

the list.  

Tip: To select from a refined list of units, do the following: 

a. Right-click in the Parameters dialog box and click Insert Units from 

the shortcut menu. 

b. From the Select Units dialog box, select the measure type under 

Type, select the unit from the filtered list, and then click Select.  

About Changing Parameter Units 

You can change the units of a parameter if access to that parameter is not locked. To 

change the units of a newly created parameter, select the required units from the 

Units list for the same type of measure. For example, you can change cm to ft. Use 

the Changing Parameter Units dialog box to specify if you want to convert or 

interpret the parameter value. Interpret Value is the default. 

Note: When changing the unit of a parameter, click the In the future, do not 

show this dialog check box in the Changing Parameter Units dialog box if you 

do not want the dialog box to open again in that session of parameter modification. 
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You can specify the general rule for handling parameter values by selecting one of 

the following options in the Changing Parameter Units dialog box. 

• Convert Value (for example 1 "becomes 25.4mm)—Change the parameter 

unit and scale the parameter value automatically. 

• Interpret Value (for example 1 "becomes 1mm)—Change the parameter 

unit without scaling the value. 

Effect of Changing the Model System of Units 

Changing the model system of units affects system, application, and user-defined 

parameters that use model units. When you change the system of units, parameter 

values are not scaled automatically.  

You can specify the general rule for handling parameter values by selecting one of 

these options in the Model tab of the Changing Model Units dialog box: 

• Convert dimensions (for example 1 "becomes 25.4mm)—Change the 

parameter units and scale the values. 

• Interpret dimensions (for example 1 "becomes 1mm)—Change the 

parameter units without scaling the values. 

In addition, you can set the rule individually for each parameter by clicking the 

Ignore option. Clicking Ignore leaves both the parameter units and its value 

unchanged.  

About Units in Relations 

By default, relations are unit-sensitive. Unit-sensitive relations behave as follows: 

• If you mix parameters with different units in a relation, the system converts them 

in order to solve a relation. For example, if the system units are mm, and you have 

a parameter B with the value of 1 inch, the relation d1=B is evaluated as 

d1=25.4mm. 

• You can mix unitless parameters and parameters with units in the same relation. 

For example, if you have a unitless parameter A and parameter B with units, you 

can have a relation: d3=B*A. In this case, A is used as a scalar value. You can 

also include a unitless parameter and specify units directly in the relation. For 

example, d3=A[mm] + B. 

Note: Relations created in Pro/ENGINEER Wildfire and previous releases are 

evaluated as unitless. After you change relations, they become unit-sensitive. 

Checking for Units in Relations 

You can set the configuration option relations_units_sensitive to check for units 

when solving relations. This option has the following values: 

• yes (default)—Solve relations taking units into account. If units are missing, the 

system issues a warning. 

• no—Ignore units in relations.  



Pro/ENGINEER Fundamentals 

555 

You can control whether relations for the selected object (listed in the Relations 

editor) are unit-sensitive by clicking  or clicking Utilities > Unit Sensitive in 

the Relations dialog box. 

Note: You can set the relations_units_sensitive configuration option to no, and 

then apply Unit Sensitive. This prevents the system from issuing error messages if 

units are missing. 

The Verify command checks for validity of relations from the relations perspective 

and issues and error if units are contradictory. You can set the configuration option 

relations_num_const_units to issue a warning if units are missing in a relation. If 

the option is set to yes, the system checks for units, issues a warning, and prompts 

you to fix the relation by applying units. 

Note:  

• If you want to add a relation to nonsolid models, for example, bulks, you must 

always specify units for numeric constants.  

• The setting of the relations_num_const_units configuration option is ignored 

for nonsolid models. 

To Specify Units in Relations 

You can specify units for numeric constants directly in the Relations editor of the 

Relations dialog box by enclosing the units within brackets. For example, A=5[mm]. 

You can also use the Specify Units command to do the following tasks: 

• Specify units for a new parameter by adding units directly in the Relations editor. 

• Define units for a numeric constant or unitless parameter. 

1. In the Relations dialog box, type an equation in the editor. For example, A=5. 

2. Right-click and click Specify Units from the shortcut menu. 

3. Select the units from the Select Units dialog box. The units are added to the 

equation. 

Example: Including Units with Relations 

This example uses the following parameters and dimensions: 

Parameter or 

dimension 

Units 

A unitless 

B inch 

d1 mm 

d2 mm 
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The following table lists sample relations that use parameters with and without units.  

Note: You can declare units on the left side of a relation only for newly created 

parameters.  

Sample Relation Verification 

status 

Comments 

d1=d2 OK  

d1=d2*A OK  

d1=B OK Value of B is converted to 

mm. For example, if d2=1 

and B=1, d1=25.4. 

d1=d2+B OK  

d1=5 Error This relation is not treated as 

an error if 

relation_num_const_units 

is set to no. 

d1=5[mm] OK  

A=d1 Error This relation is not treated as 

an error if 

relation_num_const_units 

is set to no. 

A[mm]=d1 Error A is a unitless parameter and 

cannot accept units on the left 

side of the equation. 

d1=A Error This relation is not treated as 

an error if 

relation_num_const_units 

is set to no. 

d1=A[mm] OK  

d1=A[inch] OK A is converted to mm. If A=1, 

then d1=25.4. 

d1=d2+5 Error This relation is not treated as 

an error if 

relation_num_const_units 

is set to no. 

d1=d2+5[mm]+.2[cm] OK Units are converted to mm. 

A=d1+d2  This relation is not treated as 

an error if 
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Sample Relation Verification 

status 

Comments 

relation_num_const_units 

is set to no. 

 

Restricted Value Parameters 

About Restricted Value Parameters 

You can create restricted value parameters that use definitions from a restriction 

definition file. This file defines the parameter name and type, and optionally, the 

value of the parameter or a range of values for the parameter, or a list of values for 

the parameter. After you create restricted value parameters, their definitions exist in 

the model independently of the parameter file.   

If the restriction definition file changes, you can generate a report to investigate if 

parameter definitions in the model are different from those in the restriction 

definition file. You can then update parameter definitions in the model by using the 

modified restriction definition file. 

Note: Drawing parameters can also be of restricted value type. 

To create restricted value parameters, click Tools > Parameters. You can also add 

or edit restricted value parameters directly on the Model Tree. 

When using the Parameters dialog box, you can create a restricted parameter in 

one of the following ways: 

• Type the appropriate parameter name. Pro/ENGINEER recognizes that parameter 

as a restricted value parameter. 

• Select a parameter under Restricted to indicate that the parameter is restricted, 

and select a parameter name from the list or type a name. 

• Type the first letter or first few letters of the parameter name. All parameters 

from the parameter table that match the typed letter or letters are displayed in 

the Name box. Select the required parameter name and press ENTER. You are 

prompted to define the value of the parameter. 

• Type the first letter or first few letters of the parameter name. If a match is not 

found for the typed letter, the restricted parameter value list is not available and 

you are notified that it is an invalid parameter name when you press ENTER. 

• Define the parameter value. As you type the first letter of the parameter name, 

the first available value for the defined restricted parameter that matches the 

typed letter is displayed in the Value box. Select the required parameter name 

and press ENTER. A default value is assigned to the parameter. You can change 

the parameter value, if required. 
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After you create a restricted value parameter, you can change its value by selecting 

a different value from the predefined (allowed) values. If you enter an incorrect 

value, you get an error message that also gives the valid range for this parameter. 

Setting up Pro/ENGINEER Environment for Restricted Value Parameters 

To load the restriction definition file, specify the path to that file by setting the 

restricted_val_definition configuration option. 

Note: The restriction definition file is loaded only when Pro/ENGINEER starts. 

Applications of the Restricted Value Parameters 

You can use restricted value parameters in relations.  

Note: If a value of a restricted value parameter changes and becomes invalid, the 

relation where this parameter is used reports an error. If the assigned value does not 

satisfy the parameter restriction, the parameter value is not changed. 

You can include a restricted value parameter in Family Tables, an Inheritance 

feature, a user-defined feature, an Annotation feature, Program, and Data Sharing 

Features. 

Note: In case of a conflict in definitions between the UDF and the model, the newly 

placed UDF takes on the model's definition, but retains its present value. If the 

parameter brought in by the UDF is marked as invalid, you can edit the value of the 

new parameter and set it to a valid value defined by the current model. 

If a restricted value parameter is defined as Designated, it is available to the PDM 

system. Only the parameter name, type, and its current value are passed to 

Pro/INTRALINK. A list of valid parameter values is not passed to Pro/INTRALINK.  

Properties of the Restricted Value Parameters 

When working with parameters, you can use the Restricted column in the 

Parameters dialog box to identify the restricted value parameters. The type and 

optionally the value of the parameter or a range of values for the parameter, or a list 

of values for the parameter are assigned based on the name. 

Note: The names of the restricted value parameters are reserved for restricted value 

parameters only and cannot be given to regular parameters. 

The restricted value parameters can be of the following types: 

• String 

• Integer 

• Real Number 

• Boolean 

For Real Number and Integer parameter types, you can select a parameter value 

from a range of values. 
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The restricted value parameters can have units or be unitless. You can also include 

comments with the parameter definition. 

Checking the Parameter Status Using the Restricted Column 

The Restricted column can have three states: 

• Empty—Not restricted. 

• Check mark—The current value complies with the restriction. 

• Check mark with —The current value is invalid. 

About a Restriction Definition File 

The restriction definition file defines parameters using the following format: 

{Name=<name> 

Type=<type>[quantity_type] 

[Default=<value>] 

[Range=<range> I Enum=<enum>] 

[Access=<access>] 

} 

Note: All data in brackets [] are optional. The vertical bar indicates a choice between 

two or more variants. 

When you apply definitions, the system updates model definitions using the 

restriction definition file. 

To apply definitions, specify the directory path to restriction definition file by setting 

the configuration option restricted_val_definition. 

Note: The restriction definition file is loaded only at Pro/ENGINEER startup. 

Syntax for Creating a Restriction Definition File 

A restriction definition parameter file has the following format: 

ND_ParamDefArr_K01 = { 

        <definition> 

        [, ...] 

    } 

where: 

[, ...]—Optional continuation of the list. 

Format for <definition> is: 

{ 
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      Name = <name> 

      Type = <type> [<quantity type>] 

      [Default = <value>] 

      [Range = <range> | Enum = <enum>] 

[Access=<access>} 

} 

Note: All data in brackets [] are optional. The vertical bar | indicates a choice 

between two or more variants. 

where: 

<name>—Any valid name of a Pro/ENGINEER parameter. 

<type>—Uses the following format: 

    integer | real | string | boolean 

<quantity type>—Either a name of any supported by Pro/ENGINEER basic 

quantity types (physical dimensions), for example, Length or Force, or an 

expression composed from such names with operations of multiplication (*), 

division (/), or power (^). 

Format for <value> is: 

<value_int> | <value_real> | <value_string> | <value_boolean> 

where:  

<value_int>—An integer. 

<value_real>—Any real number valid in Pro/ENGINEER relations, optionally 

followed by a <unit>.  

<value_string>—Any string enclosed by double quotes. Note: A quote in a 

string must be presented by the sequence \' and a backslash must be presented 

by  \\). 

<value_boolean>—True | False. 

<unit>—Either a name of any supported by Pro/ENGINEER measurement unit (for 

example, mm, lb, or N) or an expression composed from such names with operations 

of multiplication (*), division (/). Units of all values must match the quantity type of 

a parameter definition in which they occur as default or restricted values. 

Format for <range> is: 

[<value>,<value> | <value>, | ,<value>] 

where: 

variant <value>—A range with a minimum limit only. 

variant ,<value>—A range with a maximum limit only. 
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Note: Use[] or () to define the range: 

[]—The corresponding minimum or maximum value is included in the range. 

()—The corresponding minimum or maximum value is excluded from the range. 

Format for <enum> is: 

{ 

      <value> 

      [, ...] 

}     

Format for <access> is: 

full | limited | locked 

where: 

full—Indicates full access user-defined parameters that can be modified 

anywhere. 

limited—Indicates parameters cannot be modified by a relation. Restricted 

parameters can be modified only by Family Tables and Program. 

locked—Indicates  parameters were created by an external application (Data 

Management System, Analysis features, relations, Program, or Family Tables). 

Locked parameters can be modified only from within the external application. 

Note: 

• Spaces and new lines are optional. They are allowed everywhere with the 

exception of keywords and values. 

• Comments starting with either // or '/* and ending with a new line are allowed at 

any place of the file. 

Example: Sample Restriction Definition File 

The following parameter file list1.lst defines parameters with the names paint, 

color_1, color_2, num_of_coats, grade, num_1, num_2, Bool_1 (the names are 

shown in bold in the file). 

ND_ParamDefArr_K01 = { 

{ Name = color_1 

  Type = string 

  Default = 'blue_new' 

  Enum = { 'red_new', 'green_new', 'blue_new' } 

}, 

{ Name = color_2 
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  Type = string 

  Default = 'white_new' 

  ! DEFAULT IS WHITE_NEW 

  Enum = { 'yellow_new', 'white_new', 'black_new' } 

}, 

{ Name = num_of_coats 

  Type = integer 

  Default = 2   ! correct? 

  Range = [ 0 , 9 ] // 0<=Value<=9  

}, 

{ Name = grade 

  Type = integer 

  Default = 35   ! correct? 

  Range = [ 26 , 50 ] // 26<=Value<=50 

}, 

{ Name = num_1 

  Type = real 

  Default = -5.0 

  Range = [ -10.0 , 0. ] 

}, 

{ Name = num_2 

  Type = real 

  Default = 22.5 

  Range = [ 21.00 , 30.0 ] 

}, 

{Name=num_3 

Type=integer 

Default=75 

Enum={25,50,75,100} 

}, 

{Name=num_4 
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Type=real 

Default=50.5 

Enum={25.1,50.5,75.45,100.123} 

Access=full 

} 

{ Name = Bool_1 

  Type = boolean 

}, 

!!! ADD MORE RESTRICTED VALUE PARAMS HERE 

} 

To Create a Restricted Value Parameter 

1. Specify the location of the restriction definition file by setting the 

restricted_val_definition configuration option. 

2. Click Tools > Parameters. The Parameters dialog box opens. 

3. Click . 

4. Locate the column Restricted and click the cell.  

5. Click the Name cell and either type a name or select a name from a list of 

predefined parameter names. The type of the parameter is automatically 

selected. 

Note: If you add a parameter whose name matches the name of a parameter in 

the table-restricted parameter table, a warning message appears and the 

parameter is not added. 

6. Specify the parameter value by typing a valid value or selecting a value from a 

list.  

Tip: If the parameter has a range of values, you can investigate the valid range 

either by entering any value in the Value box and obtaining the message for the 

valid range, or by clicking Properties and then clicking the Definition tab in the 

Properties dialog box. 

To Update Parameter Restriction Definitions in the Model 

1. Ensure that the path to the restriction definition file is specified as the value of 

the restricted_val_definition configuration option before starting the 

Pro/ENGINEER session. 

2. Click Tools > Parameters. The Parameters dialog box opens. 
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3. Click Tools > Conflict Report. The report identifies the difference between the 

definition of the restricted parameters in the model and the restriction definition 

file.   

4. If a conflict is reported, click Tools > Update Restriction Definition.  

In case of no conflicts, you are notified that no conflicts were found between the 

model definition and restriction definition file.  

5. Select the check box in the confirmation message when prompted for 

confirmation that updating restriction definitions may cause some existing 

parameter values to become invalid and click Apply to update parameter 

restriction definitions.  

6. If required, click Report to view the conflict report. 

Generating Reports on Restricted Value Parameters 

You can generate two types of reports: Conflict report and Invalid Values report. 

Conflict Report 

The Conflict report checks whether the restricted value parameters in the model are 

in agreement with an external file. If the external file has changed and the 

definitions of the parameters in the model are old, the system identifies the 

parameters in conflict. 

To generate the Conflict report, click Tools > Conflict Report in the Parameters 

dialog box. 

Invalid Values Report 

The Invalid Values report identifies parameters with invalid values and generates two 

lists: 

• Results of comparing the parameter values with parameter definitions in the 

model. 

• Results of comparing the parameter values with parameter definitions in the 

restriction definition file. 

To generate the Invalid Values report, click Tools > Invalid Values report in the 

Parameters dialog box. 

Syntax for Creating an External Definition File for Table-restricted 

Parameters 

The external definition file uses the following format to define parameters: 

{Name=<name> 

Type=<type>[quantity_type] 

[Default=<value>] 
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Access=<access> 

TABLE=<table-name_1>,<table-name_2>,....,<table-name_n> 

} 

Note: All data in brackets ([]) are optional. The vertical bar ( | ) indicates a choice 

between two or more variants. 

When you apply definitions to parameters, Pro/ENGINEER uses the external 

definition file to update the parameters of the model. To apply definitions, specify the 

path to the restriction definition file by setting the restricted_val_definition 

configuration option. 

Note: The external definition file is loaded only at Pro/ENGINEER startup. 

Sample External Definition File 

The following parameter file, list1.lst, defines parameters with the names 

string_par_1, int_par1, real_par1, real_par2, bool_par1, respectively. 

ND_ParamDefArr_K01 = 

{ Name = string_par1 

  Type = string 

//  this is double slash comment 

  Table = Table1 

}, 

{ Name = int_par1 

  Type = integer 

!   this is an exclamation mark comment 

  Table = Table1 

}, 

{ Name = real_par1 

  Type = real 

  Table = Table1 

}, 

{ Name = real_par2 

  Type = real 

  Table = Table1 

}, 

{ Name = bool_par1 



Pro/ENGINEER Fundamentals – Help Topic Collection 

566 

  Type = Bool 

  Table = Table1 

} 

    !!! ADD MORE RESTRICTED VALUE PARAMS HERE 

ND_ParamTable_K01 = { 

NAME 

= 

TABLE-1      

HEAD 

= 

 string_par_1, int_par1, real_par1, real_par2, bool_par1 

ROWS 

= 

't1_row1-

m4-120', 

  

'M4', 120, 1.1, 2.3, true 

 't1_row2-

m5-130',  

'M5', "(, 200) 

    130", 

"[12.25, ] 

22.65", 

"[12.25, ] 

 24.65", 

false 

 't1_row3-

m6-135',  

'M6', "(-100, 

300] 

135", 

"[123.55, 

  225.5) 

200.50", 

"[123.55, 

  225.5) 

202.50", 

TRUE 

 't1_row4-

m8-140',  

'M8', "[-200,] 

    140", 

"(, 

2234.579) 

1555.75", 

"(, 

2234.579) 

 1557.75", 

FALSE 

 't1_row5-

m9-150',  

'M9', "[-300, 

500) 

150", 

"(-

12345.50, 

22345.56] 

-175.0", 

"(-

12345.50, 

22345.56] -

173.0", 

true 

 'T1_Row6-

M10-155',  

'M10', 155,  FREE 

5.675, 

FREE 7.675,  false 

 'T1_ROW7-

M12-6',  

'M12' FREE 6,  NULL, NULL, NULL 

RELATIONS = int_par1 > 1 

     real_par2 > real_par1 + 1.1 

   

       

} 

To Create Table-restricted Value Parameters 

1. Click Tools > Parameters. The Parameters dialog box opens. You can choose 

to select a restricted value parameter or a table restricted parameter. 
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2. Click  to insert a restricted value parameter. 

a. Under the Restricted column, click the cell for a parameter to make 

the parameter a restricted parameter. 

b. Click the Name cell and either type a name or select a name from a 

list of predefined parameter names. The type of the parameter is 

automatically selected. The list contains the following: 

o Parameter names in the restriction definition file that are not table-

restricted. 

o Table names (set labels) that are declared in the restriction definition file. 

c. Select a table name from the list. The Select Parameter Set dialog 

box opens displaying the contents of the selected table. 

Alternatively, click Parameters > Add Restricted Parameter Set in the 

Parameters dialog box to insert a table restricted parameter set directly. The 

Select Parameter Set dialog box opens displaying the contents of the selected 

table. 

3. Select any cell in the restricted parameters table to add the corresponding 

parameter set. All parameters that are defined for the selected set or row are 

automatically created and assigned the corresponding values. 

If you select the parameter name, the table is sorted based on the values of the 

corresponding parameter. If the parameter values are defined by a range, the 

values are sorted by the default value. 

4. Click Apply to add all defined set parameters and set labels with values defined 

in the selected set or row.  

Note: The parameters with a null value are also added. 

5. Click OK. 

Note: You can use the external parameter definition file to automatically create 

Annotation Element parameters. The Annotation Element parameters can either be 

regular or restricted parameters if they are defined in the restriction definition file. 

To Delete Table-restricted Parameters 

1. Select a table-restricted parameter or any set label parameter that you want to 

delete and click Parameters > Delete Parameter(s). The Modify Parameter 

dialog box opens. 

2. Click Yes. The selected table-restricted parameter or all parameters within the 

set are deleted. 
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To Modify Table-restricted Parameters 

To Modify a Table-restricted Parameter Whose Value is not Defined by a 
Range or a Set Label 

1. Click Tools > Parameters. The Parameters dialog box opens. 

2. Select the table-restricted parameter from the parameter set that you want to 

modify. 

3. Right-click and click Open Table. The Select Parameter Set dialog box opens 

and the corresponding parameter of the restriction table is automatically selected 

or highlighted. 

4. Select another parameter set and click Apply. 

To Modify a Table-restricted Parameter Whose Value is Defined by a 
Range and the New Value is Within the Same Range 

Select the respective parameter cell under the Value column in the Parameters 

dialog box and enter a new value. 

To Modify a Table-restricted Parameter Whose Value is Defined by a 
Range and the New Value is not Within the Same Range 

1. Select the table-restricted parameter from the parameter set that you want to 

modify. 

2. Right-click and click Open Table. The Select Parameter Set dialog box opens 

and the corresponding parameter of the restriction table is automatically selected 

or highlighted. 

3. Select another parameter set with the required range and click Apply. The 

Select Parameter Set dialog box closes. 

4. Select the respective parameter cell under the Value column in the Parameters 

dialog box and type a new value. 

To Modify a Set Label Parameter 

1. Select the table-restricted parameter from the parameter set that you want to 

modify. 

2. Click the arrow adjacent to the parameter cell under the Value column in the 

Parameters dialog box. A list of set label values with the TABLE option appears. 

The current value of the set label is highlighted in the list. 

3. If you select TABLE, the Select Parameter Set dialog box opens. 

4. Select another set label value from the list and click Apply. The values of all the 

associated parameters are updated accordingly. 

5. Select another parameter set. 
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Note: If some parameters existed in the original parameter set but not in the newly 

defined parameter set, these parameters in the original parameter set are retained 

but their value is changed to null. 

To Show Restricted Parameters 

1. Click Tools > Parameters. The Parameters dialog box opens. 

2. Click Show > Restriction Tables. The Restriction Tables dialog box opens 

and lists parameters defined in the restriction definition file. 

Tip: Converting Restricted Parameters to Table-Restricted 

Parameters 

While converting a restricted parameter to a table-restricted parameter in a model, 

consider the following: 

• If a feature contains a restricted parameter, then you can add the same 

parameter with a new table-restricted definition to a different feature. 

• If a feature contains a restricted parameter and you add a new table-restricted 

parameter with the same name, a message appears stating that a parameter 

with that name is already defined in the feature. To add a new table-restricted 

parameter, you must either delete the original restricted parameter or update the 

restriction definition file. 

• If you update the restriction definition file in a model that has original restricted 

parameters, the Select Parameter Set dialog box opens and you are prompted 

to select a parameter set. All parameters in the selected table-restricted 

parameter set are automatically added to the parameters table. 

Annotation Element Parameters 

About Annotation Element Parameters 

You can define parameters for Annotation Elements of an Annotation feature. 

Annotation Element parameters can be of the following types: 

• String (user-defined or restricted value) 

• Real number (user-defined or restricted value) 

• Integer (user-defined or restricted value) 

• Boolean (user-defined or restricted value) 

You can list Annotation Element parameters in the Model Tree just like other model 

parameters. 

Use one of the following methods to create Annotation Element parameters: 

• Add Annotation Element parameters by specifying parameter properties in the 

Parameters dialog box. You can access the Parameters dialog box from the 

ANNOTATION FEATURE dialog box. In addition, you can edit Annotation 
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Element parameters by clicking Tools > Parameters and changing the selection 

in the Look in box of the Parameters dialog box to Annotation Element. 

• Use an external file to create Annotation Element parameters automatically each 

time you create an Annotation Element.  

Note: 

• You can select and highlight the Annotation Element parameters and its values in 

the parameter table.  

• You can move the defined Annotation Element parameters and its values 

vertically. Use the SHIFT or CTRL key to select and highlight the Annotation 

Element parameters and move one or more rows in the up or down direction by 

clicking the arrows located at the right of the parameters table in the 

Parameters dialog box. 

• After repositioning specified parameters, you can save the newly ordered 

parameter list for the table for every session, and when saving the model. The 

parameter position information is retained only on saving the model.  

• You cannot reorder parameters in a filtered state. 

• The parameter order is propagated and maintained when you propagate an 

Annotation Feature (AF) through a UDF or a Copy or Paste operation. 

• The parameter order is propagated and maintained when you propagate an 

Annotation Element through the Annotation Element Propagation Feature or 

through a DSF. 

• If an Annotation Element is dependent, then parameter reordering is not allowed 

for child Annotation Elements. 

• Parameter reordering is applicable for the following parameter items: 

o Main 

o Alternate Mass Properties 

o Reported Mass Properties 

Including Annotation Element Parameters in a Note 

To include the Annotation Element parameters in a note, use the following syntax:  

&<param_name>:NID_<annotation_element_name> 

Simultaneous Editing of Multiple Annotation Element Parameters 

You can simultaneously create, edit, or delete common parameters for multiple 

Annotation Elements.  

To select objects for the simultaneous parameter editing, select several Annotation 

Elements, and then use the Edit Parameters command on the shortcut menu.  
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About Automatic Creation of Annotation Element Parameters 

You can automatically create Annotation Element parameters for each new 

Annotation Element by using an external parameter file. The external file follows 

format similar to that of the restriction definition file.  

To set up the automatic parameter creation, set the configuration option 

auto_ae_param_file by specifying the directory path to the external file. Thereafter, 

the Annotation Element parameters are added automatically each time you create an 

Annotation Element. 

Note: You cannot define parameters as restricted value parameters using automatic 

parameter creation for Annotation elements. To define parameters as restricted, use 

a restriction definition file.  

The external file defines the following parameter properties: 

• Required properties: 

o Name 

o Type 

o Default 

• Optional properties:  

o Unit—If not specified, the parameter is assumed unitless.  

Note: Units can only be defined at a parameter creation. You cannot add 

units later. 

o Access—If not specified, access is assumed Full. 

The following properties cannot be specified in the parameter file: 

• Description 

• Owner 

• Restriction 

Note: If a parameter description is in conflict with the restrictions, the parameter is 

not created. 

Example: Automatic Creation of Annotation Element Parameters 

Create a text file with the following content: 

!Default parameters for Annotation Elements /this is a comment/ 

ND_ParamDefArr_K01 = {  
   { Name = Version  
     Type = integer  
     Default = 2  
   },  
   { Name = Color  
     Type = string  
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     Default = 'green'  
   },  
   { Name = Ratio  
     Type = real  
     Default = 0.5  
   }  
}  

Save the file with the name auto_params.lst in the folder 

/shared_data/annotations. 

Set the configuration option as follows: 

auto_ae_param_file /shared_data/annotations/auto_params.lst 

Now, every time you create an Annotation Element, the system automatically adds 

to it the following parameters: 

Parameter Name Type Value 

Version Integer 2 

Color String green 

Ratio Real 0.5 

You can later manipulate these parameters like any regular parameters: search for 

them, modify their values individually or simultaneously for multiple Annotation 

Elements, and so on. 

To Define Annotation Element Parameters 

You can define Annotation Element parameters while defining Annotation Elements. 

You can also add parameters later by editing the definition of the Annotation feature. 

Alternatively, you can define Annotation Element parameters by accessing them 

directly through the Parameters dialog box. 

1. In the Annotation Feature dialog box, click an Element for which you want to 

define a parameter. 

2. Click Parameters. The Parameters dialog box opens. 

3. Click  to add a parameter. After you have defined parameter properties, click 

OK. 

4. Click Tools > Parameters. The Parameters dialog box opens. 

5. To define the object type, click Annotation Element under Look in. 

6. Select an Annotation Element for which you want to define parameters. 

7. Click  to add a parameter. After you have defined parameter properties, click 

OK. 
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Family Tables 

Basics of Family Tables 

About Family Tables 

Family Tables are collections of parts (or assemblies or features) that are essentially 

similar, but deviate slightly in one or two aspects, such as size or detail features.  

For example, wood screws come in various sizes, but they all look alike and perform 

the same function. Thus, it is useful to think of them as a family of parts. Parts in 

Family Tables are also known as table-driven parts. 

The following figure shows a family of bolts. The generic is at the top of the figure, 

and its instances are underneath. The generic is the parent. 

 

Using Family Tables, you can: 

• Create and store large numbers of objects simply and compactly 

• Save time and effort by standardizing part generation 

• Generate variations of a part from one part file without having to re-create and 

generate each one 

• Create slight variations in parts without having to use relations to change the 

model 

• Create a table of parts that can be saved to a print file and included in part 

catalogs 

Family Tables promote the use of standardized components. They let you represent 

your actual part inventory in Pro/ENGINEER. Moreover, families make it easy to 

interchange parts and subassemblies in an assembly, because instances from the 

same family are automatically interchangeable with each other. 

Family Table Structure 

Family Tables are essentially spreadsheets, consisting of columns and rows. They 

consist of the following three components: 
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1. The base object (generic object or generic) on which all members of the family 

are based. 

2. Dimensions and parameters, feature numbers, user-defined feature names, and 

assembly member names that are selected to be table-driven (hereafter referred 

to as items). 

3. Names of all family members (instances) created by the table and the 

corresponding values for each of the table-driven items. 

Rows contain instances of parts and their corresponding values; columns are used 

for items. 

The column headings include the instance name, and the names of all of the 

dimensions, parameters, features, members, and groups that were selected for the 
table. Dimensions are listed by name (for example, d9) with the associated symbol 

name (if any) on the line below it (for example, depth). Parameters are listed by 

name (dim symbol). Features are listed by feature number (for example F107) with 

the associated feature type (for example [cut] ) or feature name on the line below 

it. 

The generic model is in the first row in the table. The table entries belonging to the 

generic can be changed only by modifying the actual part, suppressing, or resuming 

features; you cannot change the generic model by editing its entries in the Family 

Tables. 

Note: Family Table names are not case-sensitive. Therefore, any subsequent 

references to inserted names show them in uppercase letters. 

For each instance, you can define whether a feature, parameter, or assembly name 

is used in the instance either by indicating whether it is present in the instance (Y or 

N) or by providing a numeric value (in the case of a dimension). All dimension cells 

must have a value, either a number or asterisk (*) to use the generic's value. 

All aspects of the generic model that are not included in the Family Table 

automatically occur in each instance. For example, if the generic model has a 

parameter called Material with a value Steel, all instances will have the same 

parameter and value. 

You can scroll horizontally through a Family Table to see additional information. The 

Instance Name column remains visible as you scroll. 

Family Table functionality varies with your Pro/ENGINEER module licenses. 

Module Available Family Table Functionality 

Basic 

Pro/ENGINEER 

Create table-driven parts by adding dimensions to 

the Family Table 

Assembly Create table-driven assemblies by adding to the 

Family Table subassembly and part names, as well 

as assembly dimensions. 

Pro/FEATURE Create table-driven user-defined groups whose 

group feature dimensions can be table-driven, 
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invariable, or variable. 

Add table-driven groups to a part Family Table. 

About Multi-Level Family Tables 

A Family Table is not restricted to a single level of a table. You can create instances 

of instances by selecting an instance and creating a new table for it, using Insert > 

Instance-Level Table in the Family Table menu bar. When you must do this 

depends on what you intend to model using Family Tables. The Pro/ENGINEER BASIC 

Library is itself constructed of several levels of tables. 

You can also add new features or components directly to an instance. This facilitates 

the construction of multi-level Family Tables (families with subfamilies or instances 

with instances). The new feature or component appears in the instance in which it is 

added and in all subsequent instances of that instance. The feature or component is 

suppressed in other instances at the same level of the table and in generics at higher 

levels. 

1. Create a generic model with the desired base features. 

2. Create a Family Table with instances designating the subfamilies to be created. 

3. Regenerate an instance and add features unique to its family. Repeat this until all 

levels of the family are completely defined. 

When Pro/ENGINEER creates a family instance, only those features that were created 

in a direct line from the top-level generic may be present. This means that some 

features may need to be re-created, because the instance is unaware that similar 

features exist in another (parallel) subfamily of the table.  

Features from a parallel subfamily can be temporarily resumed within a particular 

instance and used, for example, as a guide to sketch a similar feature. Upon 

regeneration, however, the Family Table resuppresses the resumed features. 

Similarly, suppression of a feature only lasts until the next regeneration, when the 

Family Table resumes it. 

When you create a feature that refers to the geometry of a resumed feature used in 

another instance, the new feature belongs to the other instance. It is best to create 

the sections of features that are common to different branches of the family in 

Sketcher mode and store the sections for later use. 

You cannot redefine features added to an instance. If you cannot achieve the desired 

feature shape by modifying dimensions, you must delete the feature and start over. 

Modifying or deleting a feature affects all children of the instance, regardless of the 

instance from which the feature was modified or deleted. 

About User-Defined Feature Family Tables 

User-defined feature (UDF) Family Tables differ slightly from part or assembly tables. 

The following restrictions apply when working with UDF Family Tables: 
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• You can not retrieve instances of a UDF by themselves unless you are placing the 

UDF on a part. In that case, when you select the UDF generic name, the Select 

Instance dialog box opens. You can then select an instance to use. 

• You can create a UDF Family Table at the time you define or modify the UDF, 

using the definition dialog box for the new UDF. 

• You cannot retrieve a UDF instance into a separate window. 

• You cannot verify a UDF instance. 

• When you place a UDF defined with a Family Table, any suppressed features in 

the UDF instance are not placed on the part. These features are in effect deleted 

as the UDF group is placed. 

• When you place a legacy UDF having local groups and a Family Table defined in 

it, the geometry may differ if the Family Table contains group members in the 

item list.  To avoid this, update the Family Table to remove the suppressed 

members of the group from the Family Table items list. You can then add the 

group header as a new column. 

Note: In Wildfire 4.0, you can suppress individual group members without 

suppressing the entire group. You can place the UDF instance such that only the 

specified member of a given group is suppressed. 

Creating Family Tables 

To Create a Family Table 

1. Create a generic model that will serve as an original. 

2. Click Tools > Family Table. The Family Table dialog box opens. 

The model should have no rows for design variations. 

3. Click . The Family Items dialog box opens.  

4. Under Add Item, click the object type you want to add to the new variation. 

5. Select the specific object you want to add using the Select dialog box. 

6. Click Done Sel. The object is added under Items. Make sure the Filter box is 

checked to show the item. 

7. Add all items by selecting them from the generic model. Click OK. You are 

returned to the Family Table. A "home" row is added containing the original 

object; new columns are added for each item you added. 

8. Click Insert > Instance Row, or click . A new row is added for the first 

new instance. 
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9. Place the cursor in the empty cells and add the new values. You are in effect 

creating a new part with slightly different properties than the original. Cells for 

features may be set to Y or N, to indicate whether or not the instance contains 

the feature. If you want to inspect the instance, put the cursor anywhere in the 

instance row and click Open. 

After an instance has been entered in the table, it can be retrieved and used like any 

other model. 

To Create a Multi-Level Family Table 

You can create a Family Table from a selected instance in an existing Family Table. 

The selected instance becomes the generic in the new Family Table. 

1. Open a model that contains a Family Table. 

2. Click Tools > Family Table. The Family Table dialog box opens. 

3. Select the instance you want to use to create the new Family Table. 

4. Click Insert > Instance-Level Table. A new Family Table is created. The 

selected instance becomes the generic of the new table. 

5. Immediately add instance rows and columns to the new Family Table. If you click 

OK to close the Family Table without having created instance rows or columns, 

the table creation is cancelled. 

6. Click OK when you are done creating the new Family Table. The system closes all 

Family Tables that were open at the time you created the new table. 

7. To see how your original (top-level) Family Table was modified, reopen the 

Family Table dialog box. The instance upon which the new Family Table is based 

contains a folder icon in the Type column of its instance row. 

To Modify a Family Table of an Instance 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Do one of the following: 

o Under Look In, select an instance that has its own Family Table. The 

Family Table of the selected instance is displayed. 

o Under Look In, type the name of any instance. If the instance has a table 

of its own, this table appears in the dialog box. If the instance does not 

have a table of its own, then a table to which this instance belongs appears 

in the dialog box, with the instance selected. 

3. Modify the current Family Table as desired, then click OK to close the Family 

Table and accept your changes. 
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Example: Several Levels of Family Tables 

 

Example: Slot Added as a Feature 

In the following figure, the slot is added as a feature to the F-Slotted instance of the 

fillister head screw. The slot feature appears in the Fillister Family Table and is 

automatically suppressed in both the Fillister and F-Phillips instances. Similarly, when 

the roundhead feature is added to the Round instance, it is placed in the generic 

Family Table, but is automatically suppressed in both the generic and the Fillister 

models. 
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1 Generic 

2 Fillister 

3 Round 

4 F-Slotted 

5 F-Phillips 

6 R-Slotted 

7 R-Phillips 

8 Lengths 

1 shows the top table level 

2 and 3 show table level 2 

4, 5, 6, and 7 show table level 3 

8 shows table level 4 
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To Create or Modify a UDF Family Table 

You can create a User-Defined Feature (UDF) Family Table when defining a new UDF 

or modifying a UDF. 

1. Click Tools > UDF Library. The UDF menu appears. 

2. Click one of the following: 

o Create—Creates a UDF and adds a Family Table (See To Create a UDF in 

Part Modeling) 

o Modify—Modifies or adds a Family Table in a UDF 

The UDF: <udfname> dialog box opens. 

3. After creating or selecting a UDF, click Family Table and then Define in the 

UDF: <udfname> dialog box. 

o When defining a new UDF or modifying an existing UDF that does not 

contain a family table, the Family Table:<udfname> dialog box opens 

prompting you to add a column or row. 

o When modifying a UDF that contains a Family Table, the Family 

Table:<udfname> dialog box opens with the existing Family Table 

information. 

4. Click  to add table columns. The Family Items, Generic: <udfname> 

dialog box opens. 

5. Under Add Item, select the type of item you want to add to the table and then 

select the respective item in the Pro/ENGINEER graphics window or on the Model 

Tree. The selected items appear under Items. 

If you select Parameter, the Select Parameter dialog box opens. 

1. Under Look In, select the type of object for which you want to add 

parameters. 

2. Select the respective item in the Pro/ENGINEER graphics window or on the 

Model Tree, the item name and parameters appear in the Select Parameter 

dialog box. 

3. Select a parameter you want to add and click Insert Selected. This 

parameter is added under Items in the Family Items, Generic: 

<udfname> dialog box and removed from the parameters table in the 

Select Parameter dialog box. 

4. Click Close to close the Select Parameter dialog box. 

6. After all items are added, click OK in the Family Items, Generic: <udfname> 

dialog box. The Family Table:<udfname> dialog box opens. 

7. Click  to add instance rows and informational or parameter columns as 

necessary. 
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8. Click OK to close the Family Table:<udfname> dialog box. The family table is 

defined or modified. 

9. Click OK. The UDF: <udfname> dialog box closes. 

Adding Items to Family Tables 

To Add an Assembly Member to a Family Table 

You must have a license for Assembly to create Family Tables for assemblies and to 

use assemblies. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Component. The Select dialog box opens. 

4. Select the components (parts and subassemblies) that you want to display in the 

Family Table. These components must include those that can be omitted or 

replaced in one or more instances of the family. All other components are 

included in every instance. 

5. Click OK. 

To Add a Merge Part to a Family Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Merge Part. The References dialog box opens with a list 

of merge parts needed for the model. 

4. Select the merge part or parts from the list and click Ok. 

5. Click OK to close the Family Table dialog box. 

Adding Dimensions to Family Tables 

To Add a Dimension to a Family Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click . The Family Items dialog box opens.  

3. Under Add Item, click Dimension. 

4. Select the dimension you want to add to the Family Table. You can add regular 

dimensions, pattern dimensions, and geometric tolerances. 
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5. Click OK. 

Note: You can scroll horizontally through a Family Table to see additional items. The 

Instance Name column remains visible. 

Tip: Selecting Dimensions in a Family Table 

Dimensions appear in the Family Table in the order in which they are selected. 

If there are multiple features in the model, select all the dimensions from one 

feature before proceeding to the next. This makes it easy to add instance values and 

to maintain the table. 

Note: If you cannot see all the columns in the Family Table, you can scroll 

horizontally through the table. The Instance Name column remains visible. 

Tip: Entering Negative Dimension Values in a Family Table 

When you enter a negative dimension value in a Family Table, Pro/ENGINEER 

interprets the negative value as a flip of the direction each time the feature is 

regenerated.  

This is because the dimension value is considered to be "relative" by default. To 

avoid this, you must change the column to be considered as "absolute" values. You 

can switch the column between relative and absolute by selecting a cell in the 

column and choosing Tools > Absolute / Relative Dimension Values in the 

Family Table dialog box. The dimension name at the top of the column will be 

preceded by a dollar sign ($) when the column is absolute. 

To Switch Between Absolute and Relative Dimension Values in a Family 
Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select the dimension column whose values you want to change from absolute to 

relative, or vice versa. 

3. Click Tools > Absolute / Relative Dimension Values. The dimension values 

change from absolute to relative, or vice versa. The dimension column heading 

contains a dollar sign ($) when the column values are absolute. 

Note: The value of dimensions is considered to be relative by default. 

To Add a Tolerance to a Dimension in a Family Table 

1. Click Tools > Environment. The Environment dialog box opens. 

2. Under Display, select Dimension Tolerances. 

3. Click Tools > Family Table. The Family Table dialog box opens. 

4. Click . The Family Items dialog box opens. 

5. Under Add Item, click Dimension. 
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6. Select the dimensional tolerance you want to add to the Family Table. You must 

explicitly select each dimensional tolerance to add it to the Family Table. 

7. Click OK. 

Note: You can scroll horizontally through a Family Table to see additional columns. 

The Instance Name column remains visible. 

Adding Parameters to Family Tables 

About Adding Parameters to a Family Table 

You must set the values of parameters for a Family Table by using either table-

driven values or relations. However, ensure that you do not use both methods 

simultaneously for any single parameter. 

For example, you can use a relation to establish the width of a model and a table-

driven value to determine its length, but neither parameter must be determined by 

both a relation and a table-driven value.  

If a parameter in a generic model is table-driven and evaluated by a relation, the 

value produced by the relation overwrites all values for that parameter in the Family 

Table. For family instances, however, the table-driven values for the parameter are 

not overwritten by the relation value until the instances are regenerated. 

If you must use a table-driven parameter in a relation, ensure that you keep the 

table-driven value on the right side of the operator to keep its value from being 

reevaluated and overwritten by the relation. 

You can add table-restricted parameters to Family Tables. On selecting a parameter, 

the entire parameter set is automatically selected. A Family Table can add and drive 

any parameter within the set, based on the conditions defined in the restriction 

definition file. 

Prefixes and Hierarchy 

A top-level parameter (one related to a part or assembly) is stored under its own 

name only, without any prefixes or suffixes, in the Family Table (for example, 

parameter_name).  

A lower-level parameter (one related to a component or feature) is stored under its 

own name followed by :FID_ and the feature ID or name of its parent (for example, 

parameter_name:FID_fid). For example: 

• In the model (part or assembly), the model parameter called ABC would be 

stored under the name ABC. 

• In an assembly, a particular component has a feature ID of 10. The associated 

component parameter DEF would be stored under the name DEF:CID_10. 

• In the model (part or assembly), a particular feature has a feature ID of 23. The 

associated feature parameter HIJ would be stored under the name HIJ:FID_23. 
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• In the model (part or assembly), a particular feature has a feature name 

MYHOLE. The associated feature parameter KLM would be stored under the name 

KLM:FID_MYHOLE. 

Note: In relations, if you want to add parameters of a model, features, components, 

or other items such as quilts, curves, edges, inheritance, or annotation elements 

using the Relations dialog box, click Insert > From List. The Select Parameter 

dialog box opens. Select the required parameter and click Insert Selected. The 

Select Parameter dialog box closes and the parameter with a correct suffix is 

displayed under Relations. 

To Add a Parameter to a Family Table 

1. Click Tools > Family Table. The Family Table dialog box pens. 

2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Parameter. The Select Parameter dialog box opens. 

Note: You can use the Other option to add lower-level parameters for entities 

such as edges, curves, quilts, annotation elements, surface, composite curve, or 

material. For example, to add a surface parameter to the family table, type the 

parameter name as PARAM1:SID_THESURF. 

4. Under Look In, select one of the object types. The Select dialog box opens. 

Select the components or features whose parameters you want to add. As each 

one is selected, Pro/ENGINEER checks if the component or feature has any user-

defined parameters that have not been added to the Family Table. If 

Pro/ENGINEER finds any such parameters, they are listed on the PARAMETER 

menu. 

5. Select the parameters that you want to add and click Insert Selected. 

Note: If you select a table-restricted parameter, the entire parameter set is 

selected. The set label parameter value determines the value of parameters in 

the set. Changing the set label parameter value may change the value of other 

parameters in the set for the Family Table. When adding a parameter to a Family 

Table, if the parameter is part of a set label parameter, it is good practice to add 

the set label parameter to the Family Table. 

6. Click Close when you finish selecting the parameters. The Select Parameter 

dialog box closes. 

7. Click OK in both the Family Items and Family Table dialog boxes. 

To Add System Parameters to a Family Table 

You can add system parameters to a Family Table. These parameters are standard 

parameters such as mp_density, provided by Pro/ENGINEER for part density. 

1. Click Tools > Family Table. The Family Table dialog box opens. 
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2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Parameter. The Select Parameter dialog box opens. 

4. Click the list above Close to select Alternate Mass Properties or Reported 

Mass Properties. Main is the default option. The corresponding system 

parameters are listed in the Select Parameter dialog box. 

5. Select the parameters that you want to add and click Insert Selected. 

6. Click Close when you finish selecting the parameters. The Select Parameter 

dialog box closes. 

7. Click OK in both the Family Items and Family Table dialog boxes. 

Adding Features to Family Tables 

About Adding Features to Family Tables 

Keep in mind the following when adding features to Family Tables: 

• If you give the feature a NOTE name, the name appears at the top of that feature 

column in the Family Table. 

• When a feature is omitted, all its dimensions and children are omitted or ignored. 

If a feature is present, all its parents are present. In cases of conflict, omitted 

features supersede present features. 

• In a multi-level Family Table, you cannot add a feature to an instance Family 

Table if that feature is already added as a column in the parent Family Table. The 

system displays the message Cannot add a parameter existing in a parent table 

of this object. 

• When dealing with patterns, the system automatically records the parent feature. 

Also, note that you can include the pattern instance parameter in the table. You 

can have zero instances by omitting the pattern completely. 

• When you place a UDF defined with a Family Table, any features in the UDF 

instance which have been suppressed are not placed on the part. They are in 

effect deleted as the UDF group is placed. 

The following information is helpful when adding a UDF to a Family Table: 

• When you place a UDF from a Family Table on a part, any features in the UDF 

which have been suppressed are not placed on the part. They are in effect 

deleted as the UDF is placed. 

• When a UDF contains a Family Table within it, you cannot suppress and resume 

features within that UDF by adding instance names of the UDF to the part Family 

Table. This is because when UDF is placed, any feature that is suppressed in the 

UDF Family Table will not be placed at all. Therefore, when adding that same UDF 

group to a part Family Table, any non-placed features cannot be resumed, and 
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likewise, any placed feature cannot be suppressed when creating a new part 

instance. 

Adding a Feature to a Family Table By Using Suppression 

In some cases, you must suppress some features before making and including others 

in the table. This makes it possible to include features that may conflict if they are 

present at the same time, such as a round and a chamfer on the same edge. 

For example, suppose you have an edge that can be filleted, chamfered, or left 

square depending on the instance. 

In this case, you would have to add both the fillet and the chamfer features to the 

Family Table; however, you cannot have both features on the model simultaneously. 

You can, however, create the fillet, add it to the Family Table, and then suppress it. 

You could then create the chamfer and add it to the table later. 

To Add a Feature to a Family Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Feature. The SELECT FEAT menu appears and the 

Select dialog box opens. 

4. Select the feature that you want to add graphically and click OK in the Select 

dialog box. 

5. Click Done on the SELECT FEAT menu. 

6. Click OK in the Family Items dialog box. 

Note: In a multi-level Family Table, you cannot add a feature to an instance 

Family Table if that feature is already added as a column in the parent Family 

Table. The system displays the message Cannot add a parameter existing in 
a parent table of this object. 

To Add a User-Defined Feature (UDF) to a Family Table 

Only table-driven UDFs (generic or instance) that have been placed on the model can 

be added to the model family table. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Group. A menu appears and lists the UDFs contained in 

the model. 

4. Select a UDF from the list, and then click OK. 
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Note: You cannot add a feature to an instance Family Table if that feature is already 

added as a column in the parent Family Table. The system displays the message 

Cannot add a parameter existing in a parent table of this object. 

Tip: Adding UDFs to Family Tables 

When adding a UDF to a Family Table, keep in mind that only table-driven UDFs 

(generic or instance) that have been placed on the model can be added to a family 

table. Adding UDFs to Family Tables do not work under the following circumstances: 

• When a model contains a local group or UDF group definition, the definition itself 

is not a valid group to add to the Family Table. You must first define the group, 

designate it as table-driven, and then place it on the model before you add it to 

the Family Table. 

• When a simple UDF is placed on a model, the UDF itself is not a valid group to 

add to the Family Table. You must first designate it as table-driven and then 

place it on the model before you add it to the Family Table. 

Tip: Adding Features to a Family Table Using Suppression 

In some cases, you must suppress some features before making and including others 

in the table. This makes it possible to include features that may conflict if they are 

present at the same time, such as a round and a chamfer on the same edge. 

For example, suppose you have an edge that can be filleted, chamfered, or left 

square depending on the instance. 

In this case, you would have to add both the fillet and the chamfer features to the 

Family Table; however, you cannot have both features on the model simultaneously. 

You can, however, create the fillet, add it to the Family Table, and then suppress it. 

You could then create the chamfer and add it to the table later. 

Tip: Adding Features in Multi-Level Family Tables 

In a multi-level Family Table, you cannot add a feature to an instance Family Table if 

that feature is already added as a column in the parent Family Table. The system 

displays the following message: 

Cannot add a parameter existing in a parent table of this object. 

Adding Reference Models to Family Tables 

To Add a Reference Model to a Family Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Ref Model. The REFERENCES menu appears with a list 

of reference models. 
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4. Select the reference model or models from the list and click DONE. 

5. Click OK. 

Tip: Adding Reference Models 

It is useful to add external references to the family tree of a model for a family of 

assemblies when a component refers to the generic assembly or another component 

in the generic assembly.  

Changes in the reference assembly or component can cause changes to the 

geometry of the component with the external reference.  

To ensure that the geometry of the component with the external reference is 

updated, create a Family Table for the component with the external reference in 

which each instance has an external reference to the appropriate assembly instance. 

The assembly Family Table must also have a corresponding item for the component 

with the external reference.  

Example: Adding a Reference Model to a Family Table 

This example shows a Family Table that includes an external reference. It uses two 

parts (A and B) and an assembly (AB).  

The hole in part B is dimensioned to the outside edge of part A. In different instances 

of assembly AB, the thickness of part A varies, and so the hole in part B must be 

located differently. However, since part B has an external reference, its geometry 

can only be updated if it knows which assembly instance it needs to reference. 

Part A has a Family Table that controls the values of its thickness. Assembly AB has 

a Family Table in which each instance of AB includes a different instance of part A 

and part B, Part B has a Family Table in which the external reference to assembly AB 

is established. 

Family Table for Part A (5 instances) 

Instance d2 d3 

Generic 3.00 3.00 

A01 1.00 1.00 

A02 2.00 2.00 

A03 3.00 3.00 

A04 4.00 4.00 

A05 5.00 5.00 

Family Table for Part B (5 instances) 

Instance  External Reference 0 

Generic AB 
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B01 AB01 

B02 AB02 

B03 AB03 

B04 AB04 

B05 AB05 

Family Table for Assembly AB (5 instances) 

Instance Component Component 

Generic A B 

AB01 A01 B01 

AB02 A02 B02 

AB03 A03 B03 

AB04 A04 B04 

AB05 A05 B05 
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1 Part A 

2 Part B 

The generic of Assembly AB, in the top part of the diagram, shows Part A and Part B 

joined together and then dimensioned. An Instance of Assembly AB, shown 

dimensioned at the bottom of the diagram, reveals that the hold in Part B has an 

external reference to Part A. 
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Adding Patterning to Family Tables 

To Add a Pattern Table to a Family Table 

Pattern tables can be included in Family Tables, enabling different instances of a 

family to use different pattern tables to drive the same patterned feature. The 

generic model must contain all of the pattern tables required by the family instances. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click . The Family Items dialog box opens. 

3. Under Add Item, click Pattern Table. 

4. Select the patterned feature on the model that corresponds to the pattern table 

you want to add to the Family Table. The name of the current pattern table is 

automatically entered for the generic in the table. The instances also have the 

current pattern table by default. 

Example: Patterning 

A simple example of a two-direction pattern is a bolt, where there are four different 

nominal diameters, and for each diameter there are five lengths. These bolts can be 

created using several levels of Family Tables or using patterning. With patterning, all 

instances can be quickly created in the same table. 

To pattern this bolt, make sure that the parameter LENGTH is in the table. Then, 

follow these steps: 

1. Select the parameter NOM as the first direction pattern. Specify a quantity of 4 

and an increment of 0.125. 

2. Select the parameter LENGTH as the second direction pattern. Specify a quantity 

of 5 and an increment of 1.0. 

A duplicate seed instance is created with a new name, and every instance added 

after it is incremented by one. 
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Note: There are five lengths for each nominal diameter added to the table, as shown 

in column d4 above. 

To Pattern a Family Table Instance 

Before you attempt to pattern an instance, you must create a seed instance and to 

make sure that all parameters to be patterned are present. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select an instance, and then click Edit > Copy with Increments, or click . 

The Patternize Instance dialog box opens with Direction1 under Pattern Tree 

highlighted by default and a quantity of 1. 

3. Specify a new quantity and select one parameter to increment. 

4. Click on the double arrows to accept the parameter. 

5. Enter an increment. 

6. You may select additional parameters and use the double arrows to add and 

remove them. Enter an increment for each parameter added. 

7. When you are finished, select OK to complete the pattern or add more directions 

by clicking on the Add (plus sign) button. 

8. Click OK when you are done in all directions. 

Note: You may go back and add or remove directions at any time. 
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Creating Instances of Parts or Assemblies in Family Tables 

To Create an Instance of a Part or Assembly 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click Insert > Instance row, or click . A new row for a new instance is 

added to the table.  

Instance names can be up to 31 characters long. All instance names must be 

unique, and you must not use the same instance name in different families.  

3. Click . The Family Items dialog box opens. 

4. Under Add Item, select the type to add. 

5. Click OK when you are finished adding items. The Family Table is filled in with 

values for the generic model and asterisks for the instances. 

6. For each instance, type the table-driven value of each item in the table. 

7. Click OK to store the table. 

Creating Instances by Patterning 

Patterning an instance automatically creates other instances that have incremental 

values for selected parameters or dimensions. The instance used for the patterning 

does not become a parent; it is used, in effect, as a seed to generate the new Family 

Table members.  

Features, component members, and groups in a Family Table cannot be patterned, 

but instances to which they belong can. You can then edit the table to change these 

items. 

Note that patterning an instance does not replace the original seed instance with the 

pattern instance, but instead duplicates the seed and the first instance. You must 

delete the original instance manually if you do not want it in the table. 

Patterning an instance can be done with several directions. The first direction is a set 

of parameters or dimensions that you want incremented together, the second 

direction is actually a patterning of the first, where you select a parameter that is 

incremented a certain number of times for each of the first direction instances.  

The third direction is a patterning of the second, where you select a parameter that 

is incremented a certain number of times for each of the second direction instances, 

and so on. Using patterning can propagate instances quickly. 

To Add an Instance With No Table-Driven Features 

Add the table-driven features to the Family Table. 

1. Click Tools > Family Table. The Family Table dialog box opens. 
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2. Click Insert > Instance Row, or click . Asterisks appear in all cells for the 

new instance row. 

3. Select each cell in the row and type N. For this instance, none of the table-driven 

features will appear. 

4. Click OK. 

Working with Instances in Family Tables 

About Instance Operations 

Instance operations include tasks like verifying, unlocking, renaming, and retrieving 

instances, creating new instances, and creating and updating instance indexes and 

accelerator files. You can use File > Instance Operations > Update Index or File 

> Instance Operations > Accelerator Options (which opens the Instance 

Accelerator dialog box) to perform most instance operations. You can also use the 

Family Table to perform certain instance operations.  

Retrieving Instances 

When you retrieve an instance from disk, the system first checks to see if an 

instance accelerator file exists for the instance. 

• If the instance accelerator file exists, the system retrieves the generic and the 

accelerator file. If the generic has not changed since the instance was last saved, 

the system immediately proceeds as if the instance were a separate model. 

Otherwise, if the generic has changed, the instance is regenerated before 

displaying it.  

• If the instance accelerator file does not exist, the system retrieves the generic 

and regenerates the instance. 

Verifying Instances 

When you verify an instance, you regenerate the instance. You can use Verify to 

facilitate the process of bringing newly created instances into session so that they 

can be added to the instance index file. Saving the generic after verification causes 

the names of all instances that were successfully regenerated to be added to the 

instance index file for that directory. 

Copying an Instance to the Generic 

You can copy the values of an instance to the generic model. However, you must 

remember that the generic establishes the default configuration (absence or 

presence of features, members) and dimensions for all instances. Therefore, 

replacing the values for the generic with the values from an instance may change 

instances where you used an asterisk to accept default values. 

When you copy an instance to the generic, the original generic is deleted. If you 

want to keep the generic model, create an instance identical to it. 
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Deleting Instances from a Family Table 

To delete an instance, delete the row that contains the instance. If the instance is in 

memory, Pro/ENGINEER warns you that the instance is no longer table-driven. 

After you delete an instance, you cannot undo the deletion. To retrieve the instance 

without creating it anew, you can erase the model from the current memory and 

close the window. This works only if you have not saved the model. If you have 

saved the model, you can retrieve an earlier version in which the instance still exists. 

About Verifying Instances 

When you verify an instance, you regenerate the instance. You can use Verify to 

facilitate the process of bringing newly created instances into session so that they 

can be added to the instance index file. Saving the generic after verification causes 

the names of all instances that were successfully regenerated to be added to the 

instance index file for that directory. 

To verify instances, you can click Tools > Verify, or the Verify toolbar button, both 

located in the Family Table dialog box. Both commands open the Family Tree 

dialog box, which lists and selects all instances for verification. You can verify all 

instances, or only selected instances. 

As each instance is regenerated, a red arrow icon is placed next to its name (this can 

happen very quickly). After an instance is regenerated, the status of the 

regeneration (SUCCESS or FAILURE) is displayed under the Verify status column of 

the dialog box. 

The results of the verification are written to a file named modelname.tst, where 

modelname is the name of the current generic model. This .tst file records the 

instance name, the name of the generic, and the regeneration status of each verified 

instance. 

Note: 

If a family tree has multiple branches (as in a multi-level Family Table), the 

verification process regenerates all instances in the tree. 

After each instance is regenerated, it is erased from memory. However, those 

instances that were already in memory (such as instances retrieved using 

Instance) remain available in memory. 

To Create a Real Model from an Instance 

1. Open the instance. 

2. Click File > Save or File > Save a Copy. 

3. Type a name for the new model. The instance is saved as a new model with no 

relationship to the generic. 

Note: 

o Suppressed features are deleted from the model. 

o Dimensions are set with the current instance values. 
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To Verify an Instance 

When you verify an instance, the system regenerates the instance and checks for 

failures. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. In the dialog box, click  or Tools > Verify. The Family Tree dialog box 

opens with all the instances of the family selected. 

3. Click VERIFY to regenerate each instance in sequence from the first to the last 

or select one or more instances and click VERIFY to regenerate only the selected 

instances. 

The selected instances are regenerated. If the family tree contains multiple 

branches, all selected instances in the tree are verified. The verification 

(regeneration) status (SUCCESS or FAILURE) is displayed under Verification 

 Status. 

Note: If an instance fails regeneration, Pro/ENGINEER does not automatically 

enter the Resolve environment. You must investigate the instance row in the 

Family Table to find any problems with the failed instance. 

To Copy an Instance to the Generic Model 

Note: This procedure permanently deletes the generic and replaces it with the 

values of the instance; you can not undo the change. If you click Cancel, the original 

generic is not restored. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select an instance name. 

3. Click Edit > Copy Instance to Generic. 

To Rename an Instance 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Under Instance Name, select the instance you want to rename and type the 

new name. 

3. Click OK to close the Family Table and accept your changes. 

Note: You cannot rename the generic (located in the first row). 

To Save Instances of Parts and Assemblies 

1. Click File > Instance Operations > Accelerator Options. The Instance 

Accelerator dialog box opens. 

2. Under Creation Options, select one of the following options: 

o None—Pro/ENGINEER does not save an instance by saving the generic 

model and its Family Table. 
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o Always—Pro/ENGINEER always saves the accelerator file of an instance 

both when you explicitly save the instance itself and when you save the 

instance through a higher-level object (for example, when you save the 

entire model).  

o Explicit—Pro/ENGINEER saves an instance accelerator file only when you 

retrieve the instance into the Pro/ENGINEER session and then explicitly 

save the instance.  

o Saved Objects—This is the default. This option is similar to Always except 

that Pro/ENGINEER updates the accelerator files whenever you modify or 

verify an instance and the instance verification status is not set to Failed. 

In the Instance Accelerator dialog box, one of the options is highlighted to 

reflect the current setting which was loaded from a configuration file or selected 

previously from this dialog box. 

3. Click Close. 

Alternatively, you can save instances of parts and assemblies by setting the 

save_instance_accelerator configuration option to None, Always, Explicit, or 

Saved Objects by clicking Tools > Options. 

To Lock or Unlock an Instance 

An instance of a Family Table can be locked so that table-driven characteristics of the 

instance cannot be modified. A lock icon is contained in the locked instance row in 

the Type column. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select the names of the instances that you want to lock. Press and hold the CTRL 

key to select more than one instance.  

3. Click Tools > Lock / Unlock Instance, or click . A lock icon is displayed 

next to each instance name. 

Note: The instances are locked only when you click OK to save the table, or 

when you click Open to open the instance. You can make changes to the file, but 

when you close the file, the locked values are restored. 

Follow the same procedure to unlock instances. 

Working with Instance Index Files 

About Instance Index Files 

Instance index files enable you to retrieve instances by entering their instance name 

only. An instance index file displays the total number of instances, followed by a 

column of instance names on the left and a column of their corresponding generic 

names on the right. The instance index file is named directoryname.idx (where 

directoryname is the directory in which the file is saved). 
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• Saving any generic model automatically creates a new instance index file, or 

updates the existing file. This file lists the names of all the regenerated instances 

for every generic regenerated and saved in the same directory as the current 

generic. 

The instance names that are listed in the instance index file are only those 

instances that were regenerated when their generic model was saved. The 

regenerated instances did not have to be in memory when the generic was 

saved. For example, the instances could have been retrieved, then erased from 

the session using the Erase command on the File menu. (The exception to this is 

for Pro/LIBRARY objects, such as parts from the Basic Library). 

Storing the generic part automatically adds the names of all of its instances to 

the instance index file, without the need to regenerate them. This includes the 

names of instances in subfamilies, such as instances that have instances, as well. 

Instance index files are cumulative, so instances that are retrieved in later 

sessions can be added to the list. To add new instance names to the file, you 

must save the generic after those instances have been regenerated; the instance 

index file is then updated, including the new instances. 

• You can also create or update an instance index file by clicking File > Instance 

Operations > Update Index. 

This creates or updates an instance index file for a specified directory (the 

current working directory is the default). Update Index creates the instance 

index file for all generics saved in the specified directory, not for objects that are 

in session or active in the Main Window. 

• You can use the Tools > Verify command in the Family Table to facilitate the 

process of bringing instances into session so that they can be added to the 

instance index file. Saving the generic after verification causes the names of all 

instances that were successfully regenerated to be listed in the instance index file 

for that directory. 

• The .idx file is a text file and can be edited outside of Pro/ENGINEER, within any 

text editor. However, if you edit this file outside of Pro/ENGINEER, Pro/ENGINEER 

will not recognize the file. For instance, when you click File > Open to open the 

model that contains the edited .idx file, its instance names do not display in the 

File Open dialog box. 

To Create an Instance Index File 

1. Save the generic model by clicking File > Save. The system automatically adds 

the names of all of its instances to the instance index file, without the need to 

regenerate them. This includes the names of instances in subfamilies, such as 

instances that have instances. 

Note: To add new instance names to the file, you must save the generic after 

those instances have been regenerated; the instance index file is then updated, 

including the new instances. 
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2. Click File > Instance Operations > Update Index. The system creates or 

updates an instance index file for a specified directory (the current working 

directory is the default). 

Note: Update Index creates the instance index file for all generics saved in the 

specified directory, not for objects that are in session or active in the Main 

Window. 

3. In the Family Table dialog box, click Tools > Verify to facilitate the process of 

bringing instances into session so that they can be added to the instance index 

file. Saving the generic after verification causes the names of all instances that 

were successfully regenerated to be listed in the instance index file for that 

directory. 

Tip: Updating the Instance Index File 

Whenever you move a generic model from one directory to another using operating 

system commands, update the instance index file by clicking File > Instance 

Operations > Update Index in the source and destination directories. This ensures 

that the instances of that generic can be retrieved from their new directory. 

Note: Do not edit an instance index file from outside Pro/ENGINEER. Pro/ENGINEER 

does not recognize the file if it is edited outside of the application. 

Working with Instance Accelerator Files 

About Instance Accelerator Files 

You can reduce the time that Pro/ENGINEER takes to retrieve an instance of a part or 

assembly from disk by saving the instance in a special file called an instance 

accelerator file. Each instance is saved in its own unique accelerator file, named 

instancename.xpr for part instances and instancename.xas for assembly instances. 

The system behavior in saving instances of parts and assemblies is controlled by the 

Save Instance Accelerator variable. You can set up or modify this variable in two 

ways as follows:  

• By setting the save_instance_accelerator configuration option. You can select 

one of the following values: 

o None—Pro/ENGINEER does not save an instance by saving the generic 

model and its Family Table. 

o Always—Pro/ENGINEER saves an accelerator file when you explicitly save 

the instance. You can save an instance by opening the instance in a new 

Pro/ENGINEER window using Open in the Family Table dialog box, and 

then saving it as a separate model file using File > Save or File > Save a 

Copy in the Pro/ENGINEER menu bar. You can also save the instance 

through a higher level object, that is, when you save the entire model file 

using File > Save on the Pro/ENGINEER menu bar. 
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o Explicit—Pro/ENGINEER saves an accelerator file only when you explicitly 

save the instance (see the preceding paragraph for a description of saving 

an instance). 

o Saved Objects—This is the default. This option is similar to Always except 

that Pro/ENGINEER updates the accelerator files whenever you modify or 

verify an instance and the instance verification status is not set to Failed. 

• By clicking File > Instance Operations > Accelerator Options. The Instance 

Accelerator dialog box opens. The Creation Options area contains the same 

options as the save_instance_accelerator configuration option: 

o None 

o Always 

o Explicit 

o Saved Objects (default) 

One of these options is highlighted to reflect the current setting that was loaded 

from a configuration file or selected previously using this dialog box. 

Using the Instance Accelerator dialog box, you can also: 

o Create an instance accelerator file. 

o Save instances of parts and assemblies. 

o Update the generic and all instance accelerator files. 

o Delete invalid instance accelerator files. 

To Create an Instance Accelerator File 

1. Click File > Instance Operations > Accelerator Options. The Instance 

Accelerator dialog box opens. 

2. Under Creation Options, select the desired option, that is, one of None, 

Always, Explicit or Saved Objects. One of these options is automatically 

selected to reflect the current setting that was loaded from a configuration file or 

selected previously using this dialog box. 

3. Click Update to create a new instance accelerator file. 

4. Click Close. 

Alternatively, set the save_instance_accelerator configuration option to None, 

Always, Explicit, or Saved objects by clicking Tools > Options. 

To Delete Invalid Instance Accelerator Files  

1. Click File > Instance Operations > Accelerator Options. The Instance 

Accelerator dialog box opens. 
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2. The current instance appears under Instance. To delete the invalid instance 

accelerator files for the current instance, click Purge. To delete the invalid 

accelerator files for another instance, navigate to the instance whose accelerator 

files that you want to delete, and then click Purge. 

Note: Purge (in-session generic only) checks the validity of all instance accelerator 

files on disk and deletes them if they are not current with the generic. 

To Update the Generic and All Instance Accelerator Files 

1. Click File > Instance Operations > Accelerator Options. The Instance 

Accelerator dialog box opens. 

2. Under Instance, click Update. Update updates the generic file or files and all 

existing instance accelerator files. In addition, it creates instance accelerator files 

for all Family Table instances of the generic that are listed in the instance index 

file and which do not currently have them. This has the same effect on the 

generic as clicking File > Save. 

If the save_instance_accelerator configuration option is set to None when you 

choose this command, a Confirmation dialog box opens and Pro/ENGINEER 

prompts you as to whether you still want to update the accelerator files. 

3. Click Yes to update the files, or click No to cancel the update. 

Note: The system regenerates each instance accelerator file during the update 

process. It deletes any file that fails the regeneration. 

Retrieving Instances 

About Retrieving Instances 

When you retrieve an instance, Pro/ENGINEER opens the specified instance in a new 

window. When you retrieve a generic by using File > Open, Pro/ENGINEER retrieves 

the instance rather than the generic into the main window. Pro/ENGINEER 

regenerates the instance automatically during retrieval. 

You can retrieve an instance of a family of parts or assemblies using one of the 

following methods: 

• With the generic already open and active, select the instance from the Family 

Table and click Open. 

• Open a file that contains a Family Table, select an instance from the Select 

Instance dialog box, and click Open. 

• Click File > Open. All instances for the model are listed as parts unless you 

explicitly set the menu_show_instance configuration option to no. Select the 

required instance and click Open. 
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Retrieving Assembly Instances 

When you retrieve an assembly instance, Pro/ENGINEER retrieves and assembles all 

the necessary components. 

All components of the generic assembly must be accessible, that is, they must either 

be stored locally, or they must reside along a search path. 

When you retrieve an assembly instance, Pro/ENGINEER does not prompt for an 

instance name of the generic components. It places the exact component (whatever 

is written in the component entry) at the instance line in the Family Table. 

If you set the sel_insts_on_comp_retrieval configuration file option to yes, then 

when you retrieve a generic, Pro/ENGINEER prompts you to specify an instance of 

that generic. 

Set the retrieve_instance_dependencies configuration option to an appropriate 

value to determine what set of objects are loaded into the session when retrieving 

Family Table instances with dependencies. On setting the 

retrieve_instance_dependencies configuration option to: 

o instance_deps_only—you can only retrieve an instance assembly with 

instance dependencies and the generic with no dependencies. The generic 

dependencies are never retrieved even if there are some references to them 

from the instance components.  

o Instance_req_generic—You can retrieve the instance and the required 

generic models along with their dependencies. Generic dependencies such as 

components excluded from the instance are not retrieved. 

o instance_and_generic_deps—This is set by default. You can retrieve 

instances with its dependencies and all dependencies of the generic. 

To Preview an Instance 

Follow this procedure if you want to view a smaller version of a selected instance 

without having to open it first. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select the instance you want to preview (select any cell in the instance row). 

3. In the Family Table dialog box, click Tools > Preview, or click . A picture 

of the selected instance opens in a small PREVIEW window. 

To Open an Instance from Within the Family Table 

You can open an instance by selecting it from the Family Table. The instance opens 

in a separate Pro/ENGINEER window. 

1. Click Tools > Family Table. The Family Table dialog box opens and lists all the 

instances of the current generic part. 

2. Select any cell in the row containing the instance you want to open. 

3. Click Open. The instance opens in a new Pro/ENGINEER window. 
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To Retrieve the Generic During File/Open 

1. Open a model that contains a Family Table. The Select Instance dialog box 

opens. 

2. Click the By Name tab. 

3. Select the generic from the displayed list. 

4. To preview the generic without opening it in a new Pro/ENGINEER window, click 

Tools > Preview, or click . To open the generic in a new Pro/ENGINEER 

window, click Open. 

To Retrieve an Instance During File/Open 

You can retrieve an instance by name or by parameter. 

To Retrieve an Instance by Name 

1. Open a model that contains a Family Table by clicking File > Open. The Select 

Instance dialog box opens. 

2. Click the By Name tab if it is not already active. Then, select the name of the 

instance from the displayed list. (You can also type the name of the instance.) 

3. To preview the instance without opening it in a new Pro/ENGINEER window, click 

Tools > Preview, or click . To open the instance in a new Pro/ENGINEER 

window, click Open. 

To Retrieve an Instance by Parameter 

1. Open a model that contains a Family Table by clicking File > Open. The Select 

Instance dialog box opens. 

2. Click the By Parameter tab. Then, select a parameter from the Parameter list 

and a value (if there is more than one) from the Value list. The name of the 

instances that contain the specified parameter and value appear in the Name 

box. 

3. Select the name of the desired instance from the Name box. 

4. To preview the instance without opening it in a new Pro/ENGINEER window, click 

Tools > Preview, or click . To open the instance in a new Pro/ENGINEER 

window, click Open. 

Note: To restore the entire list of instance names, click Restore. 

Tip: Speeding Up Instance Retrieval 

Pro/ENGINEER retrieves an instance from disk using the following process: 

1. Retrieves the generic 
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2. Copies the generic in memory 

3. Changes that copy according to the parameters of the Family Table instance 

4. Regenerates the copy 

The generic and the instance are then both held in memory. 

If, however, you have saved a particular instance as a separate model (using File > 

Save or File > Save a Copy), then Pro/ENGINEER retrieves it directly without going 

through the regeneration process—at a considerable savings in time (especially for 

complex models with many features and/or components). However, the instance no 

longer has any ties to its former generic. 

Searching in a Family Table 

About Searching in a Family Table 

You can search through the current level of a Family Table for instances that contain 

a common element or elements; for example, you can search for all instances that 

contain a specified parameter, character string, or yes/no variable. 

To perform the search, use the Search dialog box through the Family Table dialog 

box. The Search dialog box is identical to the one you use to perform Model Tree 

searches. The procedure for performing a search in a Family Table is the same as 

that for performing a search in the Model Tree, except that the options presented for 

types and values for the search are different for a Family Table than those for the 

Model Tree. As with Model Tree searches, you can perform single condition or 

multiple condition searches in a Family Table.  

Type allows you to search for instances by specifying the type of information you 

want to find. The following type choices are available: 

• Table Item—This is the default type choice. An item can be a dimension, a 

parameter, a feature number, a user-defined feature name, or an assembly 

member name that is selected to be table-driven. You can search for instances by 

specifying a common item. 

• Model Name—Use this type when you want to search for an instance by its 

instance name. A list of available instance names appears in the Value list box. 

• Expression—Use this type when you want to search for instances using a 

common string variable, Yes/No variable, or number variable. 

About Using Expressions When Searching a Family Table 

An expression is a method by which classes of parameters can be specified in a 

search. By defining an expression involving a string, yes/no variable, or number 

variable, groupings of parameters can be found with a single preparation of the 

search tool. 

The basic form for an expression is as follows: 

<parameter> ==, !=, <, > <variable> 
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where parameter is the name of the parameter, ==, !=, <, and > are individual 

operations, and variable is the name of the search variable. 

Sample Expressions 

A model and Family Table can contain any parameter(s) you want it to contain. For 

example, assume a model with the following model parameters: 

Parameter Possible Sample Parameter Values 

name 'bolt' or 'washer' 

generic 'yes' or 'no' 

level a number between 1 and 9 

You can use these sample parameters and values in search expressions in the 

Search dialog box, when searching in the Model Tree or in a Family Table. 

To Perform a Single-Condition Search in a Family Table 

1. In the Family Table dialog box, click Edit > Find, or click . The Search 

dialog box opens. 

2. From the Type list, select an information type, and then select corresponding 

values from the Value list. For predefined information types, predetermined 

items appear in the Value list on the right. Refine your criteria by selecting = 

(equals) or != (does not equal). 

Note: The parameter Expression refers to an expression that will be searched 

for in the parameter list. 

3. Click Add to add the current definition of the criteria to the list of search criteria 

at the bottom of the dialog box. 

4. Click Find to perform the search. Beginning from the top of the Family Table (or 

the current cell if one is selected), the search engine moves to the next item that 

meets the search criteria. Continue clicking Find to move to the next found item. 

5. To remove a search condition and use a different one, select the condition in the 

list of search criteria and click Remove. The condition clears and a new condition 

can be used. 

6. To alter a condition, select a condition and click Change. You can then redefine, 

as outlined in Steps 2 and 3. 

7. Click Close when finished searching. 

To Perform a Multiple-Condition Search in a Family Table 

To perform more accurate searches, it is necessary to have multiple search 

parameters. The search tool allows for the easy setup and customization of such 

operations. 
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1. In the Family Table dialog box, click Edit > Find, or click . The Search 

dialog box opens. 

2. From the Type list, select the required information type, and then select 

corresponding values from the Value list. For predefined information types, 

predetermined items appear in the Value list on the right. Refine your criteria by 

selecting = (equals) or != (does not equal). 

Note: The parameter Expression refers to an expression that will be searched 

for in the parameter list. 

If you select a model parameter from the Table Item type list, you can type a 

search value in the text box below the Value list. 

3. Click Add to add the current definition of the criteria to the list of search criteria 

at the bottom of the dialog box. 

4. As additional conditions are included in the search, they appear in the list of 

search criteria separated by a default AND operator. To change this operator, 

select it in the list box and then choose the option button AND or OR above the 

list box. 

Items in parentheses are evaluated together, as in the following: 

(conditional AND conditional) OR (conditional) 

5. Click Find to perform the search. Beginning from the top of the Family Table (or 

the current cell if one is selected), the search engine moves to the next item that 

meets the search criteria. Continue clicking Find to move to the next found item. 

6. To remove a search condition and use a different one, select the condition in the 

list of search criteria and click Remove. The condition clears and a new condition 

can be used. 

7. To alter a condition, select a condition and click Change. You will then be able to 

redefine, as outlined in Steps 2 and 3. 

8. Click Close when finished searching. 

To Perform a Search for Instances in a Family Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. In the Family Table, click Edit > Find, or click . The Search dialog box 

opens. 

3. Perform a single-condition or multiple-condition search by specifying search 

criteria and adding them to the list at the bottom of the dialog box. 

4. Click Find to perform your search. The system selects the first found instance in 

the table. To step through all the found instances, continue clicking Find. 
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Example: Using Expressions to Perform a Family Table Search 

The following three examples illustrate how to use model expressions to search in a 

Family Table. 

For example, assume a model with the following model parameters: 

Parameter Possible Sample Parameter Values 

name 'bolt' or 'washer' 

generic 'yes' or 'no' 

level a number between 1 and 9 

These parameters and values are used in the following sample procedures. 

Example 1: To Find Instances of a String Variable with Expression 

To find all instances of the name: "bolt" parameter, you would perform the 

following procedure: 

1. Perform a single-condition search using the Search dialog box. 

2. Select Expression as your information type. 

3. In the box below the Value list, enter the following: 

name = "bolt" 

Note: 

In a string search, you must include quotation marks around the name of the 

string variable. 

The only permissible operators in a string search are = and !=. 

4. Click Add to include this expression in the list of search criteria. 

5. Click Find to begin the search, or complete steps 2 and 3 again to add other 

parameters. 

Example 2: To Find Instances of a Yes/No Variable with Expression 

To find all instances of the generic: yes parameter: 

1. Perform a single-condition search using the Search dialog box. 

2. Select Expression as your information type. 

3. In the box below the Value list, enter the following: 

generic = yes 

Note: 

In a yes/no search, quotation marks are unnecessary. 
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The only permissible operators in a yes/no search are = and !=. 

Click Add to include this expression in the list of search criteria. 

Click Find to begin the search, or complete steps 2 and 3 again to add other 

parameters. 

Example 3: To Find Instances of a Number Variable with Expression 

To find all instances of the level parameter with a value of greater than 4: 

1. Perform a single-condition search. 

2. Select Expression as your information type. 

3. In the box below the Value list, enter the following: 

level > 4 

Note: 

You need not put the variable in quotation marks. 

Any of the operators (=,!=, <, or >) can be used. 

Decimals are permissible. 

Deleting Items from Family Tables 

About Deleting Items from Family Tables 

Instances and other items can be deleted from Family Tables. Doing so removes 

them from the control of the table and causes all instances to reflect the 

corresponding changes. All the information about an instance is contained in a single 

row of the Family Table.  

To delete an instance, you delete the row that contains the instance. If the instance 

is in memory, Pro/ENGINEER warns you that the instance is no longer table-driven. 

Note: Once you delete an instance or other item, you cannot undo the deletion. If 

you have deleted an instance or other item in error, you can erase the model from 

the current memory and close the window if you have not already saved the model. 

If you have already saved the model, you can close it and retrieve an earlier version. 

The deleted instance(s) still exist in earlier versions of the model. 

To Delete an Item from a Family Table 

1. With the generic model active, click Tools > Family Table. The FAMILY TABLE 

dialog box opens. 

2. Navigate to the appropriate Family Table. 

3. Select a cell in the column for the item you want to delete. 

4. Do one of the following: 
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• Click Edit > Delete Columns. 

• Right-click and select Delete Columns from the shortcut menu. 

5. Confirm the deletion. Once you delete an item, you cannot undo the deletion. If 

you have not saved the model, you can erase the model from the current 

memory and close the window. If you have saved the model, you can close it and 

retrieve an earlier version in which the item still exists. 

To Delete an Instance from a Family Table 

1. With the generic model active, click Tools > Family Table. The Family Table 

dialog box opens. 

2. Navigate to the Family Table that contains the instance(s) you want to delete. 

3. Select the instance(s) you want to delete. To select multiple instances, hold the 

CTRL key down as you select each instance. 

4. Click Edit > Delete Rows. The selected instance rows are deleted permanently. 

Note: You cannot undo the deletion. 

Saving Family Table Information 

About Saving Family Tables 

When you save a model or one of its instances by clicking File > Save on the 

Pro/ENGINEER menu bar, Pro/ENGINEER automatically saves Family Table 

information for that model, including the generic part, features, and dimensions 

found in the Family Table. Pro/ENGINEER saves the Family Table information 

separately from the model file by creating an external generic file named 

modelname.ptd. When you save the model, the modelname.ptd file contains the 

same Family Table information as is stored internally within the part database. Every 

time you click File > Save, Pro/ENGINEER updates the .ptd file. 

When you save the generic, the instances in the Family Table are not saved to the 

.ptd file and you can retrieve the instances only through the generic; that is, only by 

opening the generic model. However, you can set the save_instance_accelerator 

configuration option to save instances automatically every time you click File > 

Save. Instances are saved to an .xpr instance accelerator file for part instances and 

.xas instance accelerator file for assembly instances. You can set the 

save_instance_accelerator configuration option to the following values, this 

controls whether the instances are saved or not saved during the File > Save 

operation: 

• If the save_instance_accelerator configuration option is set to None , the 

instances are not saved and can be retrieved later only through the generic. 

• If the save_instance_accelerator option is set to Explicit, Always, or Saved 
Objects the instances are saved in an Instance Accelerator File. 
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Saving Family Table Information from Within a Family Table 

You can also save the contents of a Family Table separately from saving the model. 

To do so, use File > Export Table in the Family Table. You can save a Family Table 

as a text file or as a Pro/TABLE file. If you save a Family Table as a regular text file, 

you can edit the table information within an external text editor, such as Microsoft 

Word. If you save it as a Pro/TABLE file, the information is not editable. In either 

case, the file extension of the saved text file is .ptd. 

Once you have exported Family Table information, you can retrieve it into another 

Family Table using File > Import Table in the Family Table. 

To Save Family Table Information 

There are two methods to save information contained in a Family Table: 

Save the generic model 

Export the Family Table information to a text file or to a Pro/TABLE file. 

The following procedures describe each method. 

Procedure 1:  

1. Make sure you have closed the Family Table before you save it. 

2. On the Pro/ENGINEER menu bar, click File > Save. The generic model is saved, 

and all Family Table information is saved in a file named modelname.ptd. 

Note: Whether Family Table instances are saved depends upon the current 

setting for the configuration option Save Instance Accelerator. For more 

information on setting this option and what it means, refer to the Pro/HELP 

section on configuration options. 

Procedure 2:  

You can save Family Table information as an editable text file, or as a Pro/TABLE file. 

In either case, the file is saved with the extension .ptd. 

To Export a Family Table to a text (.ptd) File 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. In the Family Table dialog box, click File > Export Table > Textual Family 

Table. The Save dialog box opens. 

3. Click Save to save the Family Table information in the working directory and in 

the default file name, or enter a new file name and navigate to the directory in 

which you want to store the file. The system saves the file with the .ptd 

extension. 

To Export a Family Table to a Pro/TABLE File 

1. Click Tools > Family Table. The Family Table dialog box opens. 
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2. In the Family Table dialog box, click File > Export Table > PRO/TABLE file. 

The Save dialog box opens. 

3. Follow step 3 in the preceding procedure. The system saves the file with the .ptd 

extension. 

To Import a Family Table into a Model 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Click File > Import Table. The File Open dialog box opens. 

3. Navigate to and select the Family Table file you want to import. Family Table files 

contain the extension .ptd. 

4. Click OK. The contents of the selected Family Table text file are inserted into the 

current Family Table. 

Note: During import, the generic in the imported Family Table does not get 

imported into the current Family Table. 

Working with Family Tables 

About Modifying Family Tables 

There are several points to remember when modifying family members. The generic 

serves as the template for all instances; all of its features, dimensions, and 

characteristics are copied each time an instance is activated (though some may be 

suppressed).  

Whenever an instance is regenerated, the system uses the generic to determine the 

basic parameter values and the status of all features. It then incorporates the 

changes listed in the Family Table. Any feature or parameter that already exists in an 

instance can be suppressed, resumed, or modified. 

Observe the following rules when you are creating or using Family Tables: 

• You can modify any common dimension, in the generic or any instance, even if 

other members of the family are in use. To modify the dimension, right-click a 

feature in the Model Tree and click Edit on the shortcut menu. The updated 

dimensions are propagated to the other family members after the active one is 

regenerated. The geometry in the other family members is updated after they are 

regenerated.  

• You can modify a table-driven dimension in any instance either by editing the 

Family Table or double-clicking the table-driven dimension. The 

CONFIRMATION menu appears. Click Confirm to change the dimension and 

update the Family Table. In either case, only the particular family member is 

affected. 

• You can add a feature or component to a generic model at any time. It is added 

as a common feature or component to all family members. If an instance is in 

use at the time, it is updated after regeneration. 
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• You can delete a feature or component from the generic model at any time. It is 

also then deleted from all other family members. If an instance is in use at the 

time, it is updated when its window becomes active. 

• You can add a feature or component to an instance at any time. It is added as an 

item to the Family Table. It is enabled (resumed) in the particular instance and is 

suppressed in the generic and in all the other instances.  

• You can delete a feature or component from an instance at any time. However, in 

actuality, you are only suppressing it. If the feature or component was not 

previously in the Family Table, the system now adds it to the table. It is 

suppressed in the particular instance and enabled (resumed) in the generic and 

in all the other instances.  

• Suppressing or resuming a feature or component in an instance, however, has 

only a temporary effect and the feature resumes its regular status after the next 

regeneration. Further, you cannot resume the feature or component of an 

instance even temporarily if it is suppressed in the Family Table. 

• You can suppress or resume a feature or component in the generic model at any 

time. If the feature or component is table-driven, its status in the Family Table is 

updated immediately. If it is not table-driven, any active instances in session are 

updated accordingly after regeneration.  

• You can add or delete parameters to or from the model from either the generic or 

an instance. You can also modify or designate common parameters from either 

the generic or an instance. You can modify a table-driven parameter in the 

generic or an instance, either by editing the Family Table or using the Type list in 

the Family Table dialog box. However, only the particular family member and its 

children are affected. 

You can modify any common parameter, in the generic or an instance, through 

the Type list, even if other members of the family are in session. The updated 

parameters are propagated to the other family members, and they are all 

automatically regenerated. 

• You can change the name of a feature, datum, dimension, or other items in the 

generic only. The change is immediately propagated to the other family members 

in use. 

• You can add reference dimensions, geometric tolerances, or surface finish 

information to any member of the Family Table. All members, including the 

parent, are updated. 

• In most cases, relations for an assembly family instance are copied from the 

generic model. However, if a generic relation refers to a model that is replaced by 

a different family member in the assembly instance, the instance relation 

references the interchanged model.  

For example, if the generic assembly BLENDER contains the relation 

d0:6=d1:5*2, where 5 is the coding symbol of a generic part COVER, and this 

part is replaced in the assembly instance BLENDER1 by an instance COVER1 

(coding symbol 8), the relation for BLENDER1 is d0:6=d1:8*2.  
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• If you want to customize an instance, you can always create a duplicate part with 

a different name by choosing Save a Copy from the File menu, and then work 

on the copy.  

To Add Comments in a Family Table 

You can add comments in any location within a Family Table. This is useful if you 

want to include important notes about the table in general, other tables that are 

associated with the current table, or instances in the current table. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select an instance row below which you want to insert the comment row. 

3. Click Insert > Comment Row. A comment row is inserted below the selected 

instance row and the Comment Row icon displays in the Type column. If you 

have not selected a row, the new comment row is inserted below first row in the 

table (the first row contains the generic). 

4. Add comments in the row as desired, and then press ENTER. Click OK to close 

the Family Table and accept your changes. 

To Select an Entire Row or Column in a Family Table 

1. Click Tools > Family Table. The Family Table dilaog box opens. 

2. To select an entire row, select a cell within the row, and then click Edit > Select 

Entire Row. 

3. To select an entire column, click on its header, or select a cell within the column 

and then click Edit > Select Entire Column. 

To Hide or Show Family Table Columns 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. To hide a column or columns, do one of the following: 

3. Click any cell in the column(s) you want to hide. The columns you select do not 

have to be contiguous. 

Click Edit > Hide Columns. The selected columns are hidden from view. 

4. To show all hidden columns, click Edit > Unhide All Columns. The hidden 

columns appear in the Family Table. 

To Cut, Copy, and Paste Items in a Family Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select the cells that you want to cut or copy. You must select a rectangular 

region of cells; you cannot select a noncontiguous group of cells. 

3. Click Edit > Cut Cell, or click . 



Pro/ENGINEER Fundamentals – Help Topic Collection 

614 

4. Navigate to the location where you want to paste the cut or copied cells, and 

then click Edit > Paste Cell, or click . You need select only the cell in which 

you want to paste the first (upper left) cell in the rectangular region. The cells 

are pasted in their original relative positions. 

To Print a Family Table 

You can save a Family Table in an output file suitable for printing. The output file is 

in text format and is laid out in the same format as you see on the screen. 

1. Click Tools > Family Table. The Family Table dialog box opens.  

2. Click File > Export Table > Textual Family Table. The Save dialog box opens.  

3. Type the output file name, then click Save. The dialog box closes. The file is 

saved as filename.ptd, where filename is the name that you typed. 

4. Open the file and print it as you would any other text file. 

To Highlight Family Table Items in the Graphics Window 

While working with a Family Table, you can show table-driven dimensions and 

highlight table-driven features and assembly members in the graphic window. 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. In the Family Table dialog box, select the cells in the columns that you want to 

highlight.  

3. Click Edit > Highlight on Screen. The selected items are highlighted (redrawn 

in a different color) in the graphics window. 

To Change Column Location in a Family Table 

1. Click Tools > Family Table. The Family Table dialog box opens. 

2. Select the two columns you would like to swap. The columns must be contiguous. 

3. Click Edit > Swap Two Columns. The two columns swap positions. 

Creating a Drawing of a Family Member 

You can create a drawing of the generic model, as well as any member of its Family 

Table. You must enter the name of the instance when adding the first view to the 

drawing. The instance must be in use or listed in an instance index file. If you do not 

know the instance name, retrieve the instance using standard table retrieval 

methods and look at the name in the lower-right corner. 

Note: The drawing has the instance and generic name stored with it, and is able to 

retrieve it as long as the generic model is in the current directory or search paths. 

When you create part simplified representations, or assembly features that intersect 

a part, instances are created that do not necessarily appear on the part Family Table. 

The following operations cannot be performed when a hidden instance is in use: 
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• Feature Redefine 

• Feature Reorder 

• Feature Del Pattern 

• Feature Reroute 

• Feature Delete/Suppress/Resume (has temporary effect) 

• Feature Group Unpattern 

• Component Package (applicable only to affected subassemblies) 

• Component Copy (applicable only to affected subassemblies) 

• Relations Add/Edit 

• Program Edit/Instantiate 

• Edit Explode (applicable only to affected subassemblies) 

• Declare 

• Offset X-Section Modify 

• Assembly Feature Intersect (applicable only to affected subassemblies) 

• Component Replace (does not allow components to be replaced if they are 

intersected by or referenced by assembly features). 

• When adding a dimension to a Family Table of a subordinate table-driven user-

defined feature (UDF), the symbols of the Family Table items are driven by the 

original model for the subordinate UDF. 

Renaming Family Tables, Assemblies, and Drawings 

Renaming Family Table Files 

• If you rename an object that resides in the current directory and is not an 

instance of a table-driven family, all versions of the object are instantly renamed.  

• If you rename an object that is the generic of a table-driven family, the instance 

index file of the directory is updated to reflect the change. 

• If you retrieve an object from a non-current directory, and then rename it, only 

the object in memory is renamed. If you later save the renamed object, it is 

saved in the current working directory. If it is the generic of a table-driven 

family, the instance index file of the directory is updated to reflect the addition of 

the renamed object and its instances. 

• You can rename an instance of a table-driven object only by editing the Family 

Table of its generic either while the generic is in session (and then saving the 

generic) or after you retrieve the instance into Pro/ENGINEER.  
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• If you retrieve an instance from the current directory and then rename it, its 

name is placed immediately in the Family Table of its generic and in the instance 

index file of the directory. 

• If you retrieve an instance from a non-current directory and then rename it, only 

the instance in memory is renamed. If you later save the renamed instance, its 

generic and the Family Table of its generic both are updated in the directory that 

contains them. The instance index file of that directory is also updated 

appropriately. 

Renaming Assembly Components and Drawing Models 

If an assembly component or a model is renamed, it may cause failures in 

assemblies and drawings that reference it, because Pro/ENGINEER may not be able 

to locate the (original) file. If the assembly or drawing that contains the part being 

renamed is active in memory, it is updated automatically.  

To save the updates, however, you must save the assembly or drawing after 

renaming it. Alternatively, you can set the configuration option 

rename_drawings_with_object to part, assem, or both.  

When you copy an assembly, you can rename any or all of the components that 

make up the assembly. 

To Delete a Family Table 

1. Open the generic model. 

2. Click Tools > Family Table. The Family Table dialog box opens. 

3. Click Edit > Delete Entire Table. 

4. Confirm the deletion. Pro/ENGINEER deletes all of the Family Table contents 

except the instance name and type for the generic. 

Note: You cannot undo the deletion once it has been confirmed. 

Tip: If You Delete a Family Table Inadvertently 

After you delete a Family Table, you cannot undo the deletion. If you delete a Family 

Table inadvertently, the following are some suggestions for restoring it. 

• If you have not saved the model since deleting the Family Table, you can erase 

the model from current memory, close the window and then retrieve it. The 

Family Table will be intact. 

• If you have saved the model since deleting the Family Table, you can retrieve an 

earlier version of the model. 

• If you created the Family Table using Excel, you can link back to the original 

Excel file. 

• Before you delete the table, you can save it as a Pro/TABLE (.ptd) file using File 

> Export Table > PRO/TABLE File. Then, delete the table and close the file. 



Pro/ENGINEER Fundamentals 

617 

When you reopen the file, you can then import the .ptd file using File > Import 

Table. 

To Edit a Family Table Outside of Pro/ENGINEER 

When you save a generic part and its features and dimensions in a Family Table by 

choosing Save from the File menu, the system creates or updates an external 

generic modelname.ptd file. At that moment, the modelname.ptd file contains the 

same Family Table information as is stored internally (within the part database). 

You can edit a Family Table outside of Pro/ENGINEER, using any text editor from the 

operating system level to edit the .ptd file. Any modifications you make to the .ptd 

file are not automatically copied to the Family Table within Pro/ENGINEER. For 

example, if you delete an instance during the .ptd file edit, when you later retrieve 

the model in Pro/ENGINEER, the system detects that the table is missing an entry 

and asks you whether you want to similarly modify the Family Table in 

Pro/ENGINEER. 

You can also edit the modelname.ptd file in a different window outside of 

Pro/ENGINEER while working with the part containing the Family Table in 

Pro/ENGINEER. In this case, if you save the part by choosing Save from the File 

menu, the internally stored Family Table takes precedence over the external 

modelname.ptd file, if that external file exists in the current directory. 

When you retrieve a part containing a Family Table while an external modelname.ptd 

file exists in the current directory, the external file takes precedence over the 

internally stored table. 

Pro/ENGINEER no longer reads and writes to .ptd files by default. You can now use 

the configuration file option read_famtab_file_on_retrieve to choose whether you 

want Pro/ENGINEER to read and write to .ptd files. 

To Edit a Family Table Using Microsoft Excel 

You can edit Family Table information in Microsoft Excel. This functionality is 

available only if you are using a Windows environment and have Microsoft Excel 

installed. 

1. With the generic model active, click Tools > Family Table. The Family Table 

opens. 

2. Navigate to the appropriate Family Table. 

3. Click File > Edit with Excel. Pro/ENGINEER opens the Family Table in Microsoft 

Excel. 

4. Edit the Family Table. In Microsoft Excel you can: 

Insert new rows. 

Create additional instances. 

Reorder items or instances. 
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5. When finished, click File > Update Pro/E. Microsoft Excel checks the Family 

Table for acceptable values, names, and so forth. If an error is found, Microsoft 

Excel prompts you to fix the error. If no errors are found Microsoft Excel saves 

the changes to the Family Table and returns you to the Family Table in 

Pro/ENGINEER. 

Note: To exit Microsoft Excel without saving the changes to the family table, click 

File > Close. If Microsoft Excel prompts you save the changes, click No. 

Glossary 

Glossary for Fundamentals 

Term Definition 

annotation 

orientation 

Refers to a plane or a parallel plane in which the annotation 

lies, the viewing direction, and the right direction or text 

rotation. 

annotation plane A datum plane that defines the orientation of the 

annotation item with respect to the 3D model. The 

annotation item is not actually placed on the Annotation 

plane, but on an imaginary plane parallel to the Annotation 

plane, and facing in the direction of the front of the 

Annotation plane. The actual location of this imaginary 

plane with respect to the model is determined by the first 

selected attachment for the annotation. 

chain A series of multiple edges or curves that you can connect 

by a common vertex or by tangency. 

child An object, such as a part or a feature, that is dependent on 

another object for its existence. 

clip The process of removing portions of lines or surfaces that 

reside outside the view volume.  

clipping plane A trimming plane. Objects or parts of an object are visible 

on one side of the plane, while invisible on the other side. 

closed loop The condition required for a group of edges to form a face 

(surface) on an object. The edges must be connected end 

to end, forming a continuous path around the perimeter of 

the face. 

collector An interface tool for collecting single or multiple references 

when defining geometry. 

cross section The section of an objection as it would appear if cut 

through by an intersecting plane. 
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Term Definition 

dashboard A context-sensitive area at the bottom of the 

Pro/ENGINEER window that guides you through the 

modeling process. As you select geometry in the graphics 

window and set your preferences, the dashboard narrows 

your available options, so you make only targeted modeling 

decisions. The dashboard consists of the dialog bar, slide-

up panels, message area, and the control area. 

datum Datums are features without geometry which are displayed 

in the Model Tree. You can create datums as points, 

curves, lines, planes, coordinate systems and use them for 

placing components or dimensioning.  

depth cue Quick method of adding a feel of space to the scene or 

realistic depth effects. 

dimension bound When you design a model, you expect the actual part 

dimensions to be within certain predetermined limits of 

size. In Pro/ENGINEER, these limits of size, that is, upper 

and lower dimension boundaries, are defined as 

"Dimension Bounds." 

dimension line A thin, solid line that shows the extent and direction of a 

dimension. Dimension lines are paired with the number 

representing the physical size of the feature, and extension 

lines are used to associate the dimension to the 

corresponding feature on the drawing. 

dimension witness 

line 

Thin, solid lines that extend dimensions beyond the outline 

of a view so that you can read the dimensions easily. These 

lines are perpendicular to the dimension line, that is, the 

dimension leader arrows, and indicate which feature is 

associated with the dimension. 

driven dimension Dimensions in a drawing file derived from the 3D model. 

Driven dimensions reflect changes to part or assembly 

geometry, but you cannot modify their values in the 

drawing. The association is one-way; from the model to the 

drawing.  

driving dimension A dimension that when modified in the drawing is also 

modified in the 3D model from which it originated.   

dynamic preview A high-quality preview of geometry that dynamically 

simulates the result of direction manipulation of the model. 

face Generically refers to a planar surface of a geometric model, 

or a specific side of a geometric model which is oriented in 

a particular direction. For example, a machining tool or a 
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Term Definition 

viewer. 

Family Tables A collection of parts (or assemblies or features) that are 

essentially similar, but deviate slightly in one or two 

aspects, such as size or detail features.  

For example, wood screws come in various sizes, but they 

all look alike and perform the same function. Thus, it is 

useful to think of them as a family of parts. Parts in Family 

Tables are also known as table-driven parts. 

feature Any self-contained set of elements that can be defined and 

stored with the model and which has an impact on the 

geometry. A feature can be physical (hole, draft), 

procedural (for example, machining strategy in Expert 

Machinist), or computational (analysis). Features are listed 

on the Model Tree. 

generic model The lead model that owns a family table, consisting of 

columns of table items (dimensions, feature, and so on) for 

which each member of the family may have a differing 

value. 

graphics area The portion of the Pro/ENGINEER window used to display 

the model. 

instance An instance of an object, is the same as an exact duplicate 

of the object. An instance is really an object that shares the 

exact same properties as the original. It will always stay 

the same as the original regardless of what changes are 

made to the original.  

instance accelerator 

file 

A special file containing saved instances of a part or 

assembly, that helps reduce the time required to retrieve 

an instance of a part or assembly from disk by eliminating 

the need to first retrieve the generic into memory, 

selecting the instance according to the family table, and 

then regenerating.  

Instant accelerator files that store part instances are saved 

as instancename.xpr and that store assembly instances 

are saved as instancename.xas. 

layer User-defined logical subdivisions of data in a CAD/CAM 

database that may be viewed on the graphics screen 

individually or overlaid and viewed in groups. 

layout Functionality allowing for the creation of a 2D notebook 

that contains conceptual sketches to begin the design 
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Term Definition 

process and maintain design intent. 

line A geometric element that connects two points in space. 

Although a line itself is 2D in nature, it may connect points 

in 3D space. Lines are typically classified as either straight 

(linear) or curved. Lines are the most prominent element in 

technical drawings, defining edges of objects, indicating 

symmetry, relating text elements to geometric elements, 

creating borders, and so on. 

locked instance  An instance that cannot be deleted or modified. 

loop A closed chain of edges on a part surface. For example, the 

contour of a hole or slot. 

mirror Duplicate by symmetry about an axis. 

Model Tree 

 

A Model Tree is a list of every feature in a part file including 

the datums and coordinate system. Pro/ENGINEER displays 

the model structure in a hierarchical tree format with the 

current part or assembly as root object at the top of the 

tree. The subordinate parts or features are displayed below 

the root object. 

pan/zoom state The state in which you can change the position of or 

enlarge the model to view more details. 

parametric A term used to classify curves for which the path is 

described by a mathematical function rather than a set of 

coordinates. A parameter within the function (often 

specified as u or v) is varied from 0 to 1 to define all the 

coordinate points along the curve. 

parent An item in a model that has other items (children) 

dependent upon it for dimensions or shapes. If a parent is 

deleted, all dependent items (children) are deleted as well. 

See child 

parent/child 

relationship 

An association between the instances of one or more entity 

types in which one entity is dependent on the other. The 

entity that is dependent on the other is called the child 

entity while the entity on which the other entity depends is 

called the parent entity. The association between the 

parent entity and the child entity is called a parent/child 

relationship. 

planar Having a flat, two-dimensional characteristic. 

plane A region of space defined by a minimum of three 

noncoincident points in space. For the simplest type of 
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Term Definition 

plane surface, all points can be described by two coordinate 

axes; that is, the plane has no curvature. 

reference dimension A reference dimension is a calculated size used to show the 

intended design size of a part. A numerical value, enclosed 

in parentheses, provided for information only and not used 

in the fabrication of the part. Drawings made to older 

standards may use REF placed next to a reference 

dimension, instead of using parentheses. 

regenerate Restore, as in function or nature, to a former or original 

state. 

solid 3D volume that is filled with material. 

Not interrupted by a break. For example, a continuous line. 

solid geometry The geometry of 3D objects, such as cylinders, cubes, and 

spheres, and their relationships. 

table-driven Family Tables are collections of parts, assemblies, or 

features that are essentially similar, but deviate slightly in 

one or two aspects, such as size or detail features. These 

parts in Family Tables are known as table-driven. 

tangent edge A tangent edge is the intersection at which two surfaces 

become tangent. 

target model A model to which data that is measured or generated from 

the source model is to be sent. 

tolerance stack-up The cumulative tolerance that occurs when Pro/ENGINEER 

uses a series of dimensions with tolerances to dimension a 

certain feature in a part or an assembly member.  

trajectory The course of the tool and the table motion consisting of 

straight lines and circular arcs. 

translate To move an object in a linear fashion. 
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Annotation feature...................... 377 
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ordinate dimension .................. 452 
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C program 
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C program ................................. 538 
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cables........................................150 
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opening.....................................89 
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displaying global clearance 

information...........................198 
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clearance ...................................197 

clearance ...................................198 

Clip 

changing value for....................162 

Clip ...........................................162 

clip percentage in model view 

changing .................................162 
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assigning to another pen ...........116 

changing object colors ..............150 

define .....................................148 

for model ................................148 

colors ........................................116 

colors ........................................148 

colors ........................................150 
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as text only .............................278 
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changing an icon image.............278 
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changing the appearance of ...... 278 
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removing ................................ 279 
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about ..................................... 164 
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assembly ................................ 164 
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