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About Creo View

Creo View enables you to view and interrogate ECAD designs and 3D MCAD
products and models, assemblies, drawings, images, and documents. You can
collaborate on products of different information types without the native
applications. Using Creo View, you can do the following tasks:

* View a structure

» Edit the appearance of a structure by changing part color, render mode,
location, and orientation

*  Mark up a structure with annotations, measurements, and construction
geometry
*  QGroup parts

* Create cross sections

* Move parts and change their appearance, such as creating exploded views and
cross sections

With Creo View, team members can view, mark up, interact, and collaborate on all
forms of digital product data, and visual information is shared across the enterprise.

About Creo View Editions

Creo View comes in two licensed editions and one unlicensed edition:

* Creo View—Includes all functionality, is either MCAD or ECAD based, and
some applications require additional licenses.

* Creo View Lite—Provides limited viewing and markup functionality and
interoperability with Windchill.

* Creo View Express—Provides basic viewing functionality without a license.

The Creo View license is configured for MCAD or ECAD. The Lite edition of the
other configuration is provided. You can open the Creo View edition of the other
configuration if you need to work in it.

Depending on the Creo View license configurations set up by the systems
administrator, you can retrieve licenses for your workstation according to your
tasks. This flexibility enables efficient license sharing.

The following modules require additional licensing:

* Animator
* Interference Analysis
*  Design Check

» Massive Assemblies
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The license for these modules can be set to be retrieved at startup or when required.

To Set the Version and License Options

Click File » Creo View Options. The Creo View Options dialog box opens.

2. In the Showing box, select Global » Startup. The General-Startup dialog box
opens.

3. Clear Choose Edition at startup to open Creo View according to these settings
at startup.

4. To determine the Creo View edition at the next startup select one of the Choose
Creo View Edition options:

* Creo View Lite .

* Creo View MCAD.

* Creo View ECAD.

* Creo View MCAD and ECAD.

5. Under MCAD License Options » Edition and ECAD License Options » Edition, if
you did not select Creo View Lite , select one of these options:

* Load at startup
* Load when required

6. Select a license loading option for each of theses applications:

* Design Check

* Interference Analysis
* Animator

* Massive Assemblies

7. To update your license, under License Information type the License Server
name in the box.

8. Click Apply to apply the options. Click OK to apply the options and close the
dialog box.

9. Restart Creo View to open with the new settings.

Creo View Overview 9
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About the Context Sensitive Help

Creo View Help is context sensitive. To access a relevant topic, hover the pointer
over a button or a dialog box, and then press F1.

To access the Help system, click in the upper right corner of the Ribbon or
press F1.

To access a help topic about an open dialog box, click in the upper right corner
of the dialog box.
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About the Creo View User Interface

The Creo View user interface 1s divided into these elements:
* Viewing

O Graphics area—Shows a visualization of the file. You can change the view
to display 3D models, 2D drawings, images, and documents. Use the
commands on the shortcut menus to control the view and to set viewing
options. Several views (drawings, images and documents) can be open at
the same time. Click to toggle between the open views.

* Navigating the structure

O Primary panel

O Upper data panel

The Panels show information about the product structure. You can click the
arrow along the panel's sides or drag the edges of the panel to show or hide or
to resize it. You can also access a panel command in the status bar in the
bottom right corner of the Creo View window.

*  Performing commands
©  Ribbon
O Quick Access Toolbar
© Dialog boxes
* Configuring
O Creo View Options
*  QGetting information
O  Lower data panel

O  Status bar—Shows the name of the current view and selection and unit
settings.

About KeyTips and Keyboard Shortcuts

You can work more efficiently by using KeyTips and keyboard shortcuts to
navigate the user interface and activate commands. By typing a keystroke
combination, you can activate most of the ribbon commands. KeyTips indicate
which keys you should press to activate a command. The KeyTips for the ribbon
tabs appear when you press the ALT key. You can press the letter that is indicated
in the KeyTip .
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To Use KeyTips

1. Press the ALT key. The KeyTips appear on the ribbon.

2. Press the letter or letters in the KeyTip over the tab that you want to open. The

tab opens.

3. To hide the KeyTips, press the ALT key.

Keyboard Shortcuts

Command

Keyboard Shortcut

Clear Annotations

CTRL + SHIFT + DEL

Clear Measurements CTRL + DEL
Close Window CTRL + F4
Context Help F1

Delete DEL

Exit current mode (return to select ESC

mode)

Find CTRL +F
Help Topics F1

ONLY display View window CTRL + F8
Print CTRL + P
Render Shaded F9

Render Shaded with Edges F10
Render Hidden Line Removal F11

Render Wireframe F12

Rotate mode F4

Select All CTRL + A

Spin Center

CTRL + . (period)

Translate mode

F2

Zoom All CTRL + SHIFT + A
Zoom Out CTRL + -

Zoom In CTRL ++

Zoom Selected CTRL + SHIFT + S
Zoom Window CTRL + SHIFT + Z
Start or stop animation playback SPACEBAR

Navigating the User Interface




Undo and Redo Commands

Creo View provides commands to undo and redo actions in the view, such as
moving parts, editing properties, sectioning changes, annotations, and creating
construction geometry. Undo and Redo do not apply to standard view manipulation
such as panning or rotation, or to print, save, copy, or option commands.

* To undo or redo only the most recent action, left-click the Undo (Ctrl+Z) or
Redo (Ctrl+Y') button on the quick access toolbar.

» To display a list of multiple recent actions for selection, click the arrow next to
the Undo or Redo command icon. When you make a selection from the list, the
undo/redo action applies to all commands in the list that were executed prior to
that selection in the list. In other words, you can select the most recent
command, or a range of commands to undo/redo.

* You can use the Limit undo/redo steps to options on the General option page to
control the number of actions that are available to undo or redo.

Note
A saved annotation set cannot be undone.

Working with Panels

About Panels

Panels are portions of the Creo View window that display information about the
structure or design. The panels are below and to the left of the graphics area. Click
the arrows to show and hide panels.

Panel Name Position Information Displayed
Primary panel Left side of the Creo View | Structure, viewables,
window annotations, ECAD
substructures
Upper data panel To the right of the Layers, groups, search
Primary panel results, view content,
ECAD color and

visibility, Design Check
and Interference Detection

results
Lower data panel At the bottom of the Creo | Attributes, messages, Bill
View window of Materials, Animation
Keyframe Editor
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To Customize the Display of Panels
1. On the Status bar, toggle the display of one or more panels:

. D»Primary panel

. D»Upper data panel
. DLower data panel
2. To hide everything but the graphics area, click .

About the Structure Tree

In Creo View, use the Structure Tree to display a hierarchical view of all
components in the structure. The root structure is at the top of the Structure Tree,
and its subordinate features and parts are below it. Use this view to show all the
parts of the model, and to load or to unload parts. Items are represented in the
Structure Tree with these glyphs:

. Top-level structure
. Subassembly
. Part

Large structure trees can be cumbersome to work with, and the node names
displayed can be meaningless to the Creo View user. To improve performance and
make it easier to relate to the Structure Tree display, you can do the following:

» Filter some of the nodes out of the view.

* Change the node names displayed.
When you click the Structure Tree, the Structure tab on the Ribbon is activated.

About Messages

The Messages pane in the lower data panel lists informational, debug, warning,
and error messages logged during your session. You can configure the information
that is displayed with a message and the maximum file size for a message.

To Log Messages

1. Make sure that the pane of the lower data panel is open.

2. Right-click and choose Capturing Messages from the shortcut menu. Message
logging is enabled.
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3. To set the types of messages logged, right-click and choose Capture Types, and
then select one or more message types.

4. To display information:

a. Use the context menu or options to turn message logging on. You can also
enable message logging and specify log file size using the general options.
When message logging is on, an icon appears in the status area beside the
units of measure.

b. Messages appear in the Messages pane in the lower data panel. The type of
message is indicated by a corresponding icon.

c. In the Messages pane, use the context menu to control the types of
messages that are logged. You can click a column header to sort by that
column. The context menu lets you select which columns to display (Time,
Thread, Source, Message). You can also select Show Detail to display the
Message Detail window, which shows the message type, thread, source,
and text. In this window, you can choose to Copy All or Copy Only Message
to paste into another application.

d. In the Messages context tab that appears in the ribbon area, you can select
to Show Detail, Copy, specify visible columns, display message options,
and clear messages. You can also select which types of messages to
capture: Info, Debug, Warning, and Error.

About the Views Gallery

The Views gallery appears in the Views group on the Home tab. Use it to manage
views, to select a recently opened view, to close the current view (CTRL + F4), to
close all views, or to show multiple views.

Recently opened views appear as thumbnails. Click a thumbnail to open the view.

About the Status Bar

The status bar shows the loaded view, available selection options, and other
relevant information depending on the active file:

* Click a window arrangement icon to change the placement of windows in the
Creo View interface

» The progress bar, shown in all views, indicates the percentage of completion of
the task being executed, which advances from 0 to 100 as the task is
completed.
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» The status bar also shows the number of selected items in the view.

* Use the selection menu to choose the type of selection (smart, parts, faces, or
edges), as well as units of measure.

Navigating the User Interface
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Customizing Tooltips

About Customizing Tooltips

When you place the pointer over a part in a structure, a tooltip appears in the Status
Bar. By default, it contains the part name. You can customize the tooltip to include
other attributes, values, or any other text. You can select from these categories:

System Variables

PVS File Properties

PVZ File Properties

EDA File Properties

Creo Parametric Parameters

Creo Parametric Component Parameters

To Customize Tooltips

1.
2.

22

Click File » Creo View Options. The Creo View Options dialog box opens.

On the left, under Model, PCB Layout Viewer, or Schematic Viewer, click
Tooltips. The appropriate Tooltips options open.

Set one or more of the following options:

*  Show Part Tooltips—Displays the tooltips for parts.

* Use Default Tooltip (Part Name)—Displays the default tooltip for the
MCAD model part name. If a custom tooltip is defined in the Tooltip Editor,
this text is shown in the tooltip.

* Show Tooltips—Displays the ECAD tooltips.

* Exclude Overlays—Displays tooltips of objects underneath overlays, but
not tooltips of the overlays.

* Exclude Planes and Conductive Figures from Pre-selection of Nets—
Prevents large objects from being highlighted when you move the pointer
over them. This does not affect the selection highlighting.

In the Tooltip Editor, type additional information for the tooltip.

To include attribute names and variables in tooltips, perform the following
operations:

a. In the Tooltip Editor, right click and choose Insert Variable from the shortcut
menu. The Insert Variable dialog box opens.

b. Select variables in the Category and Attribute boxes.

c. Click Insert Name or Insert Value. The variable is inserted.

Creo™ View 1.0 Help Topic Collection



d. Repeat steps b-c for each variable to insert.
e. Click Close.
6. In the Creo View Options dialog box, click OK.

Example: Custom Tooltip Syntax

Any text surrounded by < > is replaced with the appropriate attribute name or
value. For example, the text <System Variables.Part name.Name> is
replaced by the name of the component path attribute in the system variables
group. Similarly, the text <System Variables.Part name.Value> is
replaced by the value of the same attribute.

Customizing the Quick Access Toolbar

About the Quick Access Toolbar

The Quick Access Toolbar is located at the top of the Creo View window. By
default, it contains the following commonly used commands:

. Delete

. Redo

« & save Al

. Undo

. ELCustomize

You make the following changes to customize the toolbar:
* Move the toolbar
* Add commands

 Remove commands

To Add a Command to the Quick Access Toolbar

1. On the Quick Access Toolbar, click IE' The Customize Quick Access Toolbar
options open.

2. Select one or more of the following commands to add it to the toolbar:

* Open
e SaveAll
* Print

Customizing Creo View
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* Undo

* Redo
e Delete
e Search

* Select Mode

To add a command from the Ribbon or from a dialog box, select the command,
right-click, and choose Add to Quick Access Toolbar from the shortcut menu.
The command is added.

To Remove a Command from the Quick Access

Toolbar

1. On the Quick Access Toolbar, right-click and choose More Commands. The
Customize-Main dialog box opens.

2. Select a command from the Customize Quick Access Toolbar list and click
Remove. The command is removed.

3. Click Apply to apply the settings and keep the dialog box open, or click OK to

apply the settings and close the dialog box.

To Move the Quick Access Toolbar

1.

On the Quick Access Toolbar, click IE' The Customize Quick Access Toolbar
menu opens.

Select one of the following commands:

* Place Quick Access Toolbar below the Ribbon

* Place Quick Access Toolbar above the Ribbon

The toolbar is moved.

To Set Quick Access Toolbar Options

1.
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On the Quick Access Toolbar, click IE‘ The Customize Quick Access Toolbar
menu opens.

Click More Commands. The Creo View Options dialog box opens and the
Customize-Main options open on the right.

In the Choose commands from box, select a list of commands. The command
list is displayed in the box on the left.

Select a command and click Add. The command is added to the Customize
Quick Access Toolbar box on the right.
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5. Repeat step 4 until you have added all the desired commands to the Customize
Quick Access Toolbar box.

6. To move the Quick Access Toolbar in the Creo View window, select or clear
the Place Quick Access Toolbar below the Ribbon check box.

7. Click Apply to apply the changes and continue setting options, or click OK to
apply the changes and close the dialog box.

Setting Options

About Creo View Options
Options in the Creo View Options dialog box are applied as follows:

* Global—Applies to all views of a structure.
* Active View—Affects the active view only.

* Defaults—Applies the default values to future views.
You can set global and default options before loading data.

The system administrator can lock view options for a workstation. When a view

ad
option is locked, appears alongside it.

To Set General-Main Options

1. Click File » Creo View Options. The Creo View Options dialog box opens on
the right.

2. In the Showing box, select Global, and then on the left select General. The
General-Main page opens.

3. Select one or more of these check boxes:

* Display Thumbnails in View Gallery—Clear this box if generating
thumbnails is time-consuming.

* Show dialog to confirm closing of all active views

* Switch to perspective view mode automatically when Explore navigation
method is selected

* Show alert message for advanced search with duplicate colors
Set the Limit undo/redo steps to box.

5. In the Limit the minimum page size of paged lists to box, type or select the
minimum page size of paged lists.
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In the Limit the minimum page size of the attribute list to box, type or select the
minimum page size of the attribute list.

Set or clear the Show alert message for advanced search with duplicate colors
check box.

Set or clear Log messages with its file size option.

Set Part highlighting mode to Wireframe or Filled.

. Click Apply to apply the options. Click OK to apply the options and close the

dialog box.

General Creo View Options

Select general options from the General-Main Options dialog box.

active views

Option Description

Display Thumbnails in View Gallery Displays open views in the Views
display grid.

Show dialog to confirm closing of all Displays a warning message before

closing unsaved data.

Switch to perspective view mode Activates a perspective view
automatically when Explore navigation
method is selected

automatically in Explore navigation
mode.

Show alert message for advanced Displays a warning message if you
search with duplicate colors

select the same color for more than one
query when performing a color-coded
search.

About Locking Option Settings

The Creo View administrator can lock option settings and commands as follows:

Any individual option or the entire option page can be locked. When a option
setting is locked, a lock icon appears alongside the setting on the Preference
page.

Any command can be locked. A tooltip indicating that the command has been
disabled appears when you hover the cursor over a disabled command.

If you have set PVIEW DISPLAY COMMANDS=1 config options, the Tooltips
also show the command ID.

Note

You cannot disable interface elements such as tabs and groups, but you can disable
an individual command, such as Print.
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To Lock Options
There are three ways to lock option settings and disable commands:

 Download from server

* Update {install dir}/Options/ProductView/admin prefs.
xml file.

» Update SAPPDATAS/ptc/ProductView/user prefs.xml

There is a readme . txt file in the directory {install dir}//
preferences/ProductView that provides information about disabled
commands and locked option settings.

To Reset Options to the Defaults
1. In the Creo View Options dialog box, click one of the following buttons:

» To reset a specific group of options, with that group open, on the right,
click Reset to Default. The default settings are restored.

» To reset all options, on the left, click Reset All to Default. All default
settings are restored.

2. Click OK to apply the settings and close the dialog box, or click Apply to apply
the settings and continue setting options.

Customizing the Palette

About Customizing the Palette

The Creo View palette includes 16 basic colors. In Creo View you can add any
number of custom colors. Set the palette to display all colors or only custom
colors. Use the Creo View Options menu to create, save, and edit new colors or to
delete them. You can also add a name to each color that appears in a tool tip. In
Creo View Lite, you can view custom colors, but you cannot modify the palette.

To Add Custom Colors to the Palette

1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. In the Showing box, select Global. On the right, the global options open.

3. On the left, under General, select Color Palette. On the right, the General-Color
Palette options open.

4. Click Add. The Choose Color dialog box opens.

Customizing Creo View 27



5. Select the values for red, green, and blue in one of these ways:

* Under Settings, drag the sliders next to Red, Green, and Blue, or type
values in the boxes.

» Select a color on the color wheel, and then drag the slider to adjust the tint.
Click OK.

Repeat steps 5—7 for each custom color.

= e

8. To add a tooltip, select a color and click Color Tooltip. The Name Color dialog
box opens.

9. Type a name in the Text box, and then click OK.

10. To exclude the basic colors from the palette, in the Creo View Options dialog
box, select the Use Only Custom Colors check box.

11. Click OK.

To Edit or Delete Custom Colors

1. In the Creo View Options dialog box, under the General-Color Palette options,
select a color to edit and click Edit Color.

2. Adjust the Red, Green, and Blue values, and then click OK. The color is edited.

To delete a custom color, select it and click Remove. The color is deleted.
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About Opening Structures and Designs

You can open files that contain MCAD data, ECAD designs, or both. The File
menu contains a list of recently opened files. Open Creo View files, or import one
of the supported external formats.

When you open a file, it is not automatically loaded. Instead, you can select one or
more viewables in the file to load. In MCAD structures, within the model view,
you can select one or more parts or subassemblies to load, or you can load the
entire structure. A Creo View structure contains information about the makeup,
organization, and appearance of the parts of a product. In Creo View, you can edit
the structure of a product. A structure file has one or more of the following MCAD
viewables:

*  Model

* Image

* Drawing

* Document

* Illustration

A structure can also have one or more of the following ECAD viewables:
* Schematic

+ PCB Layout

*  Overlay

After you open the structure, you can open one or more viewables associated with
it. In addition to viewable files, the following information can be linked to the
structure file:

» Appearance of parts
*  Markups

* Attributes

*  Groups of parts

e Sections

To Open a Structure or Design
1. Click Open. The Open File dialog box opens.

2. Select the folder that contains the structure or design file to open, or type a
name in the Search box.
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3. To filter the files by type, select a file type from the Type box.

4. Select the file, and then click Open.

About Creo View File Formats

Creo View files use the following suffixes:

of the types above

Type Extension

Structure * . pvs
*.ed
*.edz

3D model *,01

Annotation * . pva

Interference report *.pvc

PCB Layout *.eda

Schematic

Compressed package with one or more |*.pvz

Loading Data Automatically

About Automatic Loading of Data

Loading options control how a structure opens in Creo View. You can set an

automatic file load for all files, for a single file, or for no files. You can also set an

automatic load for branch links.

To Load Data Automatically

1. Click File » Creo View Options. The Creo View Options window opens.

2. On the left, under General, click Loading . The General-Loading options open

on the right.

3. Select an option from the Load Creo View data as box:

* Autoload single file—If there is a single node in the structure with 3D
geometry attached, this option loads only that part. If there are no parts
with 3D geometry, Creo View loads one of the other files types, using the

first one in the hierarchy (drawing, document, and image, respectively). If

there are multiple parts with 3D geometry, nothing is loaded. This is the

Opening Structures and Designs
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default setting, and is commonly used when you want to view only one part
or file.

* Autoload all files—Loads the entire product structure.

* No autoload—Disables automatic loading. This option is generally selected
when viewing a large assembly.

4. Select or clear the Autoload if Structure has 3D Thumbnails box.

To enable automatic loading and expanding of branch links, select the Autoload
branch links box.

6. Click Apply or OK.

To Set Load Options

Click File » Creo View Options. The Creo View Options dialog box opens.

2. In the left pane, under General, select Loading. The General-Loading options
open in the right pane.

3. To set the way in which files are loaded when Creo View is opened, select one
of the following options in the Load Creo View data as box:

* Autoload single file—One file is loaded.
* Autoload all files—All the files are loaded.
* No autoload—No files are loaded automatically.

4. To automatically load structure files that include 3D thumbnail previews, select
the Autoload if Structure has 3D Thumbnails check box.

5. To automatically load a structure together with its branch links, select the
Autoload branch links check box.

6. Click Apply to apply the settings and continue setting options, or click OK to
apply the settings and close the dialog box.
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About Importing and Exporting Files

You can import external MCAD or ECAD files, add annotations, and save the file
as a Creo View file. By default, the import filters for most external formats are
automatically installed when you install Creo View. However, the JT filter must be
manually installed. You can customize the installation to include only the filters
you need. In Creo View, you can export Creo View MCAD structures to 3D files,
and you can export MCAD and ECAD views to these types of 2D files:

e Vector

* Image

About Saving External File Formats in
Creo View

You can save external files that you open as Creo View files.
In Creo View Lite and Creo View, you can save data to the following formats:

e PVZ—Includes files for all viewables and annotations

» PVS—Saves the information as a directory and references the viewable and
annotations files

The following ECAD file types are not saved as EDA files when you save the
structure:

*  Gerber
e ODB++
« IDF

Instead, the resulting PVZ or PVS file includes or references the native file for
these viewables.

In Creo View, you can save MCAD files as image files, 2D vector files, or 3D
files, and ECAD files as image files or EDA files.

To Save an External File Format in Creo
View
1. To overwrite the current structure, click File » Save All. The files are saved.

2. To create a new structure, click File » Save As, and then click one of these
options:
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* Save All As PVS

* SaveAllAs PVZ

* Save Copy Of All As PVS

* Save Copy Of All As PVZ

The Save As dialog box opens. Proceed to Step 5.
3. To save an ECAD view as an EDA file, when working in Creo View, click
Save Current View As » As an EDA file.
The Save View as EDA dialog box opens.
Select a location for the file.
In the File name box, accept the default file name, or type a new one.
Click Save.

NSk

Importing MCAD and ECAD Files

Supported MCAD File Formats

You can open an IGES or MicroStation file as either a 2D or a 3D representation.
You can open the following file types in Creo View:

File Type Extension
IGES 2D drawing *.1igs
3D model *.iges
STEP 3D model *.stp
*.step
JT Parts and assemblies only |*.Jt
VRML 3D model *owrl
*.vrml
Stereolithography 3D model *.stl
*.sla
MicroStation 2D drawing *.dgn
3D model
PTC Visualizer 3D model * . gbf
*.gaf
Drawing 2D drawing * . hp2
*.hpg
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File

Type

Extension

*.pgl
*.plt
*.hgl
*.dxft
*.dwg
*.dwf
* . dwfx

3D drawing

* . dwf
* . dwfx

Supported ECAD File Formats

You can open these ECAD file types as data in Creo View:

File Type Extension
IDF ECAD-MCAD * . emn
Collaboration * . emp
IFF Schematic * iff
DSN Design Entry CIS— *.dsn
Schematic x oot
SPECCTRA—PCB
Layout
CADIF Schematic * . paf
* . cdf
Cadence Allegro Package |PCB Layout * . mcm
Designer
GenCAD *.cad
Cadence Allegro PCB *.brd
EDIF Schematic *.edf
*.eds
*.edi
Mentor Graphics Board neutral .mgn
Station Neutral tech.mgn
traces.mgn
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File Type Extension
design ascii

Mentor Design Capture *.pjr

DCE 7.9.1

Dx Designer *.pjr
*.proj

Zuken ASCII * . pcf
*.can

Mentor PADS ASCII PCB Layout *.asc

Mentor Expedition *.hkp

Requires installation of

Mentor EE2007 Interface

You can open these file types as data or as an overlay:

File

Extension

Gerber

*.art
*.grb
*.pho

ODB++

*.tar
*.2
*.tgz
*.gz
Matrix file

Opening Creo Parametric Files in Creo View

You can open Creo Parametric files in Creo View. The opened files have the

following characteristics:

File Type Comment
Part *.prt Bulk parts do not have
geometry, however, they
appear as regular parts.
Accelerator for a part *.Xpr
family table
Assembly *.asm
*.mfg

Creo View Interface
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File Type Comment
Accelerator for an * . xas

assembly family table

User-defined feature *.gph

Drawing *.drw

Format * . frm These files behave like
Layout *.lay drawings.
Diagram *.dgm

Report *.rep

Section *.sec

Picture *.pic

Note

You can also open drawings that include shaded views.

You can also open file formats that have been converted by Creo Parametric:

File Type Comment
Drawing *.dwg When a Creo Parametric
* dxf drawing is converted to
these file types, the colors
are mapped to AutoCAD

colors. In some instances
the result may not match
the original color.

Saving Display Information in Creo Parametric

When you save a Creo Parametric file with the intent of opening it in Creo View,
make sure that you set the following configuration options:

* save model display—Select one of the following values:
© shaded lod
© shaded low
© shaded high

* save drawing picture file—both

* sketcher save preview image—yes
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Exporting MCAD and ECAD Files

About Saving Views to External File Formats

You can save any view as an image file. In Creo View, you can save a drawing or
an ECAD view as a 2D vector file, and you can save a model view as a 3D file.
When you save to a 3D format, the result is a file that contains the parts selected in
the graphics area. If nothing is selected, all the loaded and visible parts in the
current view are saved.

Saving Views to External File Formats

You can export a view to DXF or to a 3D format only in Creo View. You can save
a view in these formats:

View Type File Type Format Extension
MCAD and ECAD |Image BMP * . bomp
GIF *.gif
JPEG *.Jpg
PNG *.png
TARGA *.tga
TIFF *otif
* tiff
MCAD 2D Vector CGM * . cgm
DXF *.dxf
CGM * . cgm
MCAD 3D IGES *.igs
STEP *.stp
VRML * owrl

To Save a View as an Image

1. Click File » Save Current View As > As an image file. The Save View As Image
dialog box opens.

2. In the File name box, type a name or accept the default.

3. In the Type box, select a file format.
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Click Save. The Save View As Image- Settings dialog box opens.

Under Units, select the unit of measurement for the image:

* Inches

* Centimeters

* Pixels

Under Width and Height, set the dimensions for the image.
Note

When the Lock aspect ratio check box is selected, the proportions of the image
are preserved. You can change one dimension and the other is updated
automatically.

To set a resolution for images measured in inches or centimeters, in the
Resolution box, type a number of pixels per unit.

Click OK. The settings are applied and the image is saved.

To Save a View as a DXF File

1.

A S

Click File » Save Current View As » As a 2D vector file. The Save View As
Vector dialog box opens.

In the File name box, type a name or accept the default.

In the Type box, select DXF.

Click Save. The Save View As Vector—Settings dialog box opens.
Under the Zoom Setting, select an option:

* Current Zoom

e Zoom All

Click OK. The view is saved.

To Save a View as a CGM File

1.

A
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Click File » Save Current View As > As a 2D vector file. The Save View As
Vector dialog box opens.

In the File name box, type a name or accept the default.
In the Type box, select CGM.

Click Save. The Save View As Vector dialog box opens.
Under Zoom Setting, select a zoom option for the view:
e Zoom All

e Current Zoom
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6. To create a file that meets ATA graphics standards, under Format, select the
Save as CGM ATA Profile 5 check box.

7. Click Save. The settings are applied and the file is saved.

Saving a View as a 2D Vector File

When you save a view as a 2D vector file, you can set file properties according to
the format you select:

« CGM:

@)

Unit of measurement

O  Dimensions of the image

o

Resolution

O  Compliance with ATA standards
« DXEF:

©  Number of sheets
Note

DXF files cannot contain multiple sheets. When you save to DXF all the
sheets of a multi-sheet drawing, one file is created for each sheet. The sheet
number n is added to the file name according to the syntax filename n.
dxf.

O Zoom setting for a single sheet

To Save a View as a 3D File

1. Click File » Save Current View As » As a 3D file. The Save View As 3D dialog
box opens.

In the File name box, type a name or accept the default.

In the Type box, select a file format:

+ IGES
+ STEP
+ VRML

4. Click Save. For large files, the Save View As 3D dialog box opens with a
progress bar.
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Data Saved to the VRML File

When you save a view as a VRML file, the result of the operation is one,
compressed VRML 2.0 file. VRML views include lights within a scene, while
Creo View views do not. When you save to this file format, a generic ambient light
is created for the VRML view. In addition, the following data is included:

Item

Property

Structure

Part names

Hierarchy

Part

Tessellation
Color
Opacity
Visible layers

View

Perspective Field of View setting

Camera position and orientation

Data Saved to the STEP or IGES File

IGES does not support hierarchical structures with multiple parts. When you save a
view as an IGES file, all of the structure's data is saved to a single part file. When
you save a view as a STEP or IGES file, the following data are included:

Item Property
Structure Flat list without part names
Part Color

BREP as quilts only
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Displaying Views

About Views

You can display up to 12 views at once in the graphics area. This includes
viewables of different MCAD and ECAD types and saved view states. Thumbnails
of the open views appear on the Home tab of the ribbon in the Views group.
Reducing the number of views visible in the graphics area hides the extra loaded
views, but it does not close them or remove their thumbnails from the Views group.

Note

A view does not open automatically when you open a file. After you open a file,
you can select one or more views to load.

When one or more views are open in the graphics area, additional views open as
follows:

Active View Action Result
The same type of Double-click. Replaces the active view
viewable as the new view with the new view.

Drag the view into the

to open graphics area.

A different type of Opens a new view.
viewable than the new
view to open

Any Right-click and choose
Open in New View.

When you open an ECAD view, the design’s substructure pane opens in the
primary panel.

To Manage the Display of Views

On the Home tab, in the Views group, click . The views display grid opens.

2. To manage the number of views displayed, in the views display grid, do one of
the following operations:

*  Multiple views—Move the pointer over the number and arrangement of
views that you want to display, and then select a square for the lower right
view. The graphics area is divided.

*  One view—Select the top left square. One view is displayed in the graphics
area.

3. To close one or more views, do one of the following operations:
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*  Current view—Press CTRL+F4 or, on the Home tab, in the Views group,

click .

* All views—On the Home tab, in the Views group, click .

To Open an MCAD or ECAD View

1. Click . The Viewables pane of the primary panel opens.
2. Select the partition for the type of viewable to open.

3. Do one of the following operations:

* Double-click the viewable or a view state
* Drag the viewable or view state into the graphics window

* Right-click the viewable or a view state and choose Open in New View from
the shortcut menu.

To Show Multiple Views

1. On the Home tab, in the Views group, click .

2. Move the pointer over the number and arrangement of views that you want to
display, and then select a square for the lower right view. The graphics area is
divided.

To Revert to One View

1. On the Home tab, in the Views group, click .
2. Select the top left square. One view is displayed in the graphics area.

Navigating and Selecting

Using the Mouse

About the Mouse Navigation Modes
In Creo View, you can set the mouse navigation mode to one of the following:

*  ProductView

* Creo
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Select the scheme with which you are most comfortable. The default type of
navigation for both modes is Inspection. This method works with both
orthographic and perspective viewing. In the Creo View Options dialog box, you
can also select Explore to use an advanced fly mode for 3D navigation. In Explore
mode, you can view an object from different depths and angles. This method
works only with perspective viewing. The Explore setting maximizes the effects of
fly navigation.

To Set the Mouse Navigation Mode
Click File » Creo View Options. The Creo View Options dialog box opens.

2. On the left, under General, click Navigation. The General-Navigation options
open on the right.

3. In the Navigation model box, select a mode:

*  ProductView
* Creo

4. To apply the Explore mode for navigation in the Model View, follow these
steps:

a. In the Showing box, select Defaults.
b. On the left, click Model. The Model-Main options open on the right.
c. Under 3D Navigation Method, sclect Explore.

5. Click OK to apply the changes and close the dialog box, or click Apply to apply
the changes and continue setting options.

To Set Navigation Options
Click File » Creo View Options. The Creo View Options dialog box opens.

2. On the left, under General, select Navigation. The General-Navigation options
open on the right.

3. To set the options for highlighting of selected parts, surfaces, edges, and points:
* Select or clear the Select using color check box.

* To change the highlighting color, click the color box and set a new color in
the Choose Color dialog box.

4. To set the options for secondary selection color of parts, surfaces, edges, and
points:

a. Select or clear the Secondary selection color check box.

b. To change the highlighting color, click the color box and set a new color in
the Choose Color dialog box.
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5. To set the options for pre-selection highlighting of parts, surfaces, edges, and

points:

a. Select or clear the Enable pre-selection highlighting check box.

b. To change the highlighting color, click the color box and set a new color in
the Choose Color dialog box.

A S

Select a Navigation model.

To set alternate name parts in the structure tree:

Select or clear the Enable assembly highlighting check box.

Select or clear the Use drill down in specific filters check box.

a. Select or clear the Use alternate part names in the tree check box.

Click Configure. The Configure Alternate Part Names dialog box opens.

c. In the first, third and fifth boxes enter text to display. In the second and the
fourth boxes, select attributes from the lists.

d. Click OK. The Configure Alternate Part Names dialog box closes.

10.

apply the settings and close the dialog box.

Using the Mouse in ProductView Mode

Click Apply to apply the settings and continue setting options, or click OK to

When the ProductView navigation mode is set, use the mouse in the following

ways:

ProductView Navigation Mode for the Model View

Action

Result

Details

Click.

Selects a part or geometry
within a part.

Right-click and drag.

Rotates the structure.

Press CTRL + right-click
and drag.

Pans the structure.

Press SHIFT + right-click
and drag

Middle-click and drag.

Spin the mouse wheel.

Zooms in or out.

Drag down to zoom in,
and drag up to zoom out.

Drag up to zoom in, and
drag down to zoom out.

Viewing the Structure

47



ProductView Navigation Mode for the Drawing or Image View

Action

Result

Details

Right-click and drag.

Press SHIFT+middle-
click and drag.

Pans the view.

Press SHIFT + right-click
and drag.

Middle-click and drag.

Zooms in or out.

Drag down to zoom in,
and drag up to zoom out.

Using the Mouse in Creo Mode

When the Creo navigation mode is set, use the mouse in the following ways:

Creo Mode for the Model View

Action

Result

Details

Click.

Selects a part or geometry
within a part.

Right-click and drag.

Flies.

Drag down to fly out, and
drag up to fly in.

Middle-click and drag.

Rotates the structure.

Press SHIFT+middle-
click and drag.

Pans.

Press CTRL+middle-click
and drag.

Zooms in or out.

Drag down to zoom out,
and drag up to zoom in.

Selecting MCAD Data

About Selecting MCAD Data in the Graphics Area

You can select one or more parts or markups in the graphics area for the loaded
assembly. By default, selected parts are highlighted and surrounded by a bounding
box. With Creo View’s smart selection function, you can refine the selection of a
part to a surface or edge on that part. You can then refine the selection further:

* Point
* Endpoint
* Midpoint
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Set options to enable or disable preselection highlighting for 3D parts. For other
geometry, it is enabled by default. You can set a smart selection filter, or you can
choose one filter to select that type of item. You can view a list of the items that are
selected, and you can see a summary of the number of selected items in the status
bar. You can also select or deselect all parts simultaneously.

To Set the MCAD Selection Mode

1. Click the arrow next to Home » Select Mode. The selection mode menu
opens.

On the Home tab, in the Selection group, click Select Mode.

3. Select one of these commands:

. Select Mode

i Select All Parts

. Deselect All Parts

About Smart Selection

You can use smart selection to select the geometry of a part. Select a part, and then
place the pointer over a surface or an edge of the part to select it. When you place
the pointer over a point on the selected surface or edge, you can select that point.

To Select a Point using Smart Selection

1. In the graphics area, select the part that contains the surface or edge that you
want to select.

Move the pointer over the surface or edge. The feature is pre-highlighted.
Select the pre-highlighted feature.

To select a point on the feature, move the pointer over the point. It is pre-
highlighted.

5. Select the point.

Selecting Items from the List

When you make a selection in the graphics area, all parts or annotations located
under the pointer are added to a list of selectable items. These items can be
accessed using these commands on the shortcut menu:
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Select Previous
Select Next

Select From List

You can also use these shortcuts to make selections:

Action Result
Press CTRL + right-click. Selects the next item in the list.
Press CTRL + middle-scroll. Scrolls to another item in the list.

To Change the Selection Filter

1.

On the status bar, select a filter from the list. The selection filter is changed for
the active view.

To Set Selection Options
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Click File » Creo View Options. The Creo View Options dialog box opens.

On the left, under General, select Navigation. The General-Navigation options
open on the right.

To set the options for pre-selection highlighting of parts, surfaces, edges, and
points:
e Select or clear the Enable pre-selection highlighting check box.

* To change the highlighting color, click the color box and set a new color in
the Choose Color dialog box.

To set the options for highlighting of selected parts, surfaces, edges, and points:

» Select or clear the Select using color check box.

* To change the highlighting color, click the color box and set a new color in
the Choose Color dialog box.

Click Apply to apply the settings and continue setting options, or click OK to
apply the settings and close the dialog box.
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Selecting ECAD Data

About Selecting ECAD Data

The ECAD substructure appears on the substructure pane when Creo View

ECAD is open. When you select an object from one of the partitions on the
substructure pane, the object is automatically selected in all of the partitions and in
the graphics area. For most object types, you can open every partition in which the
object appears. These are the exceptions:

* Devices
* Part Numbers

* Special Symbols

You can expand a node to select one or more objects in the node. Select an entire
node in a partition to select every object associated with that node. When you
select an object in a node, the related objects are also selected. These are some
examples:

Example of Selected Object Related Objects Also Selected
Net node All associated objects

Package node All instances of the package
Component Device and part number

Pin Net

You can make your selection stand out by adding a crosshair when one object is

selected. When you select a component, information about it appears in the
Attributes pane of the lower data panel. You can also use cross-selection mode to
select objects simultaneously in one or more of these locations:

*  Multiple views
*  Creo View MCAD
e Other Creo View ECAD tools

To Select Among ECAD Objects with the Same Location

1. Move the pointer over an object in the graphics area. The object is highlighted
and a tooltip displays its name.

2. When multiple objects exist at a location, click and hold. A list of the objects
appears.

3. In the list, move the pointer over the object name, and then release. The object
is selected.
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To Mark a Selected ECAD Object with a Crosshair

P o
1. Click Home » Crosshair. Crosshair selection mode is activated.

2. Select one object. The selection is indicated with a highlight and a crosshair.

3. To turn off crosshair selection mode, click Home > Crosshair again.

Selectable Objects in PCB Viewables

This table shows the types of objects found in PCB viewables, and whether or not
they can be selected graphically.

Object Graphically |Comments
Selectable

Board Outline Yes

Component Yes

Net No Only physical object associated with nets
can be selected.

Via Yes Does not appear as a selectable object in
the structure pane.

Figure Yes Does not appear as a selectable object in
the structure pane.
When selected, associated data appears in
the Attributes pane.

Region Yes

Pad Yes

Padstack No

Pin No

Mechanical Hole Yes If the hole is a standalone hole, only the
hole is selected.
If the hole is part of a component
definition, the component is selected.

Test Point Yes Does not appear as a selectable object in
the structure pane.

Logical Connection |Yes The pin-to-pin line connection is selected.

(ratline/ratsnest line)

Res Des No Text that is part of a component is
selectable as a part of the component.

Text Yes Text that is not part of an object or
component.

Geometry Yes Geometry is part of an object, but only the

geometry is highlighted.
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Object Graphically |Comments
Selectable
When selected, associated data appears in
the Attributes pane.
Pin Pair No
Markup Yes

Selectable Objects in Schematic Viewables

This table shows the types of objects found in Schematic viewables, and whether

or not they can be selected graphically.

Object Graphically |[Comments
Selectable

Net Yes Selectable through a wire, junction point
etc.

Symbol Yes Components, fractured components and
special symbols are selectable.

Page borders, title blocks etc. are special
symbols.

Figure Yes Defined as special symbol.

Pin Yes

Junction Point Yes Selects the net.

Res Des Yes Text that is part of a component is selected
as part of the component.

Text Yes If the text is associated with a component
or a symbol, the component or the symbol
is selected.

Some text may not be selectable.

Geometry No Usually associated with a special symbol.

Pin Pair No Part of a net.

Markup Yes

Selection Mode Functionality

When you set a selection mode, subsequent selections are made according to that
mode until another selection mode is selected, or until the end of the session. The
default is Smart Selection.

Mode

Schematic View |PCB View

Smart Selection

Use to select any object that does not
meet more specific criteria or selection
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Mode Schematic View |PCB View

options.
Component The component The component is
Selection symbol is selected |selected when any
when any of its of its associated

associated object |object are selected
are selected in the |in the graphics
graphics area. area.

Net Selection When you select
objects associated
with a net, the
entire net is
selected and
highlighted in the
graphic view and
the structure.
Deselect All Deselects all current selections

About Filtering ECAD Selection

ECAD designs, especially PCB layouts, can have thousands of objects, often
overlapping or sharing location. You can activate the selection filter in order to
search for specific types of objects by selecting an option on the Status bar or by

selecting an option from . Selection Mode.

You can use smart selection to select any object in the graphics window.

Selecting ECAD Data across Tools

About Cross-Selection Mode

In Creo View ECAD’s Cross-Selection Mode, you can select objects in two or
more open views simultaneously. Select one or more objects in the active view, and
the objects are selected automatically in the receiving views. You can select one or
more receiving views from among the views open and loaded in your session:

* PCB Layout
e Schematic
« MCAD model
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By default, the receiving views adjust to center on the selection, though you can
also choose to zoom to the selection. The active view remains unchanged. If an
object cannot be found in the receiving view, a dialog box provides more

information and a message appears in the lower data panel’s Messages pane.

When you activate the External Communication option, your receiving views can
include other open sessions of Creo View, Creo View ECAD Validate, and Creo

Parametric. To receive the selections in other sessions of Creo View, the External
Communication option must also be activated there.

Creo View can also read messages from Creo View ECAD Validate and change
proposal information from Creo Parametric when External Communication is
activated.

To Cross-Select Objects

1. Click Home > Cross-Selection Mode. The cross-selection menu opens.
2. Select one or more views to become receiving views.

3. To cross-select in other sessions of Creo View, other tools, or both, select
External Communication.

Note

Make sure that the External Communication command is also activated in the
other sessions of Creo View.

4. Select a display option for the receiving views:

* Center on Cross-Selection Sent
e Zoom to Cross-Selection Sent

5. Select one or more objects in the active view. The objects are selected
automatically in the receiving views.

6. To toggle cross-selection mode on and off with the same settings, click Home »
Cross-Selection Mode.

Objects Available for Cross-Selection

From each type of viewable, you can cross-select these objects:

Viewable Object
PCB Layout Component
Pin
Via
Net
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Viewable

Object

Route Segment
Mechanical Hole

Drill Hole

Region

Test Point

Logical Connection
Scheduled Connection
Board Outline

Planes

Conductive Figures

Schematic

Component
Pin
Net
Bus

Hierarchical Block

Cross-Selecting Objects in Different Types of Views

When the active view type is different than the receiving view type, objects are

cross-selected as follows:

Active View Receiving View |Selection Resulting
Cross-Selection
Schematic PCB Layout Net All objects
associated with the
net
Pin Pin pad
Bus All objects
logically connected
to the bus and its
bits
PCB Layout Schematic Pin pad Pin
Route segment Net
Via pad
Plane and
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Active View Receiving View |Selection Resulting
Cross-Selection

conducting figures

Logical connection
Scheduled
connection

Test point (via)

Test point (pin) Pin

About Receiving and Displaying ECAD Images

An ECAD image is an IDX file (* . 1dx) received from Creo View ECAD
Compare or Creo Parametric for the following purposes:

* Creo View ECAD Compare—Messages
* Creo Parametric—Change proposals
You can receive any number of images for each view.

The External Communication option in the Cross-Selection Mode menu must be
selected to receive images. Navigation and visibility settings in Creo View ECAD
Compare are also transmitted to Creo View ECAD. Control the visibility of an

image using the Color and Visibility pane of the upper data panel. The names
of received images appear on this pane, under the Images sublayer of the

Annotations layer. Use the View Content pane to control image transparency or
to rename or delete an image. When you apply the Transparency option to an
image, it is displayed at 50 percent opacity. You can add markup and save the view
as an annotation set.

To Receive Images

Click Home » Cross-Selection Mode » External Communication. Creo View is
configured to receive images.

To Display Received Images

1. Click the Color and Visibility pane of the upper data panel. The pane
opens.

2. Expand the Annotations layer node, and then expand the Images layer node. A
list of received images and grids opens.
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3. Select the image’s visibility check box. The image is displayed over the design.

4. To reduce the opacity of the image, perform these actions:

a. Click the View Content pane of the upper data panel. It opens with a
list of received images.

b. Right-click the image and choose Transparent from the shortcut menu. The
image is adjusted.

Interpreting Images from Creo View ECAD Validate

You can receive any number of images for each view. Messages from Creo View
ECAD Validate are the result of a comparison between two designs, the Current
design and the Compare To design. Differences in the designs are designated in
Creo View ECAD Validate as Add, Modify, or Delete. In Creo View, the
differences do not have labels. Instead, the Current design becomes the view and
the image displays a record of the differences:

* Add—Selects the added object in the design.

* Modify—Creates an object on the image layer and selects the original object in
the design.

* Delete—Creates the deleted object on the image layer.

A corresponding grid sublayer is also created when an image is received from Creo
View ECAD Validate. The grid identifies the regions containing differences. The
grid name is the name of the image with the suffix grids.

To Rename or Delete Received Images

1. Click the View Content pane of the upper data panel. The pane opens with
a list of received images.

2. To rename an image, right-click it and choose Rename from the shortcut menu.
The Rename dialog box opens.

3. Type a new name and click OK. The image is renamed.

To delete an image, right-click it and choose Delete Selected from the shortcut
menu. The image is deleted.
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About Filtering the List of Viewables

You can filter the list of viewables for any MCAD file. Set the filter to show only
viewables or parts with a certain name, or show only viewables that are associated
with selected parts. You can use wildcard characters for setting the filters. You can
make your settings the default.

To Filter the List of Viewables

1. Inthe Viewables pane of the primary panel, right-click and choose Filter Files
from the shortcut menu. The Filter list dialog box opens.

2. Select one or more of the options under Show in image list:
* Names matching
* Part names matching
¢ Only files attached to selected parts

3. To save your settings as the default, click Make Default.

4. Click OK.

MCAD Viewables

About MCAD Viewables

You can display different kinds of views of CAD objects. The Viewables panel
contains folders for the following types of views, depending on what views are
saved to the CAD object:

View Details
[ Model A 3D view. You can manipulate the
model and its components.

Image A 2D view

. A technical plan
= Drawing
A PDF
Document
. A technical illustration. You can view
lllustration . )
animations

You can add markups to any type of viewable.
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Navigating the MCAD View

Use the following commands on the Home tab, in the Navigation group, or on the
Structure tab in the Parts group, to navigate:

and Drawing

and then select a
rectangular region of the
representation.

View Action Result
All Resizes the part to fit th
Click[jZoom All. eSIZ?S © partto fitthe
graphics area.
Model, I ,D t, . Z to fit the selected
odel, Image, Documen Click [Z] Zoom Window, ooms to fit the selecte

region to the graphics
area.

Structure, Model, Image,
Document, and Drawing

Select an item in the
representation, and then

click Zoom Selected

Zooms in to the selected
item.

Model

Click IE‘ Spin Center,
and then right-click and
hold while moving the
pointer.

Rotates the representation
around the point you
selected.

Model and Structure

Click Orientation, and
then select an orientation
from the list.

Orients the model.

Image, Drawing, and
Document

Click H Zoom In or

Zooms incrementally with
each click.

Document

Rotate Left.

Zoom Out.

Image, Drawing, and . Resizes the representation
g 8 Click 2] Fit width or Feep )
Document Fit Height to the width or the height

' of the graphics area.
Image, Drawing, and . Rotates the representation
£e, & Click =) Rotate Right or p

counterclockwise or
clockwise.

Image and Drawing

Click Flip Horizontal
or Flip Vertical.

Flips the representation.

Document

Click Actual Size.

Resizes the document to
its actual size.
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Model View

About the Model View

You can open the Model View to see a 3D representation of a CAD design. In the
Model View, you can perform the following operations:

» Set the Render Mode

* Apply Display Filters

* Change the location of components in the model
» Create a sectioned view

» Create construction geometry

The Model View is a Creo View Structure (* . pvs) file. When you save the file,
changes to the display are also saved.

To Apply Display Filters

1. Click Home »> Filters. The Display Filters dialog box opens.

2. Select or clear the check boxes next to the items to display or hide.
3. Click Apply and then click OK.

About View States

A structure has one or more view states associated with it. A view state is a model
view with one or more of the following properties set:

* Orientation

* Render mode

* Transparency

» Sectioning

» Layer state

* Load status of parts

» Markup created in Creo View
* Model Annotations

« Simplified Representations
Use a view state to display the structure with the appearance and settings of your
choice. You can open one or more view states, and you can apply a new view state

to the current model view. When you apply a new view state while using the
Design Check tool in Creo View, your tags and tag notes are preserved.
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To Apply a New View State

In an open view, click . The Viewables pane of the primary panel opens.

2. To apply a view state to the current view, select it and do one of these
operations:

*  Double-click.
» Right-click and choose Apply to Current View.

3. To apply a view state to another view, right-click the view state and choose
Apply to View, and then select the view.

To Change a Display with Local Display Style

1. Select a component of the representation.

2. Activate the shortcut menu and move the pointer over Local Display Style.
3. Select a display mode.
4

The selected component is displayed accordingly.

View Orientation

About View Orientation in Figures

A view orientation is the angle of the displayed structure in the graphics area.
There are eight standard view orientations. You can add, edit, and delete view
orientations in the Custom View Orientations dialog box. These changes are
immediately implemented in the Orientation list. The Undo and Redo mechanism
is available when updating the view orientations list. Although by default view
orientations are global, you can set a view orientation relative to a coordinate
system.

You can modify view orientation in Creo View, but you can only select existing
view orientations in Creo View Lite or Creo View Express.

To Change the View Orientation

There are three ways to change the view orientation.

Working with Viewables
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From the Ribbon:

Open a structure.

2. On the Home tab in the Navigation group or on the Structure tab in the
Parts group, click Orientation. The Orientation list opens.

3. Click a view orientation from the list. The view orientation changes.

From the Custom View Orientations dialog box:

1. Open a structure.

2. On the Home tab in the Navigation group or on the Structure tab in the
Parts group, click Orientation. The Orientation list opens.

3. Click Customize. The Custom View Orientations dialog box opens.

4. Click a view orientation in the list, then either right-click and choose

]
Activate Orientation from the shortcut menu, or click L *] on the Custom
View Orientations dialog box. The view orientation changes, but the
Custom View Orientations dialog box remains open, so you can repeat this

step to compare view orientations.

From the keyboard shortcuts in some of the standard view orientations: Click
in the graphics area, and then press the keyboard shortcut letter that appears on
the Orientation list.

To Add a New View Orientation

64

Open the Custom View Orientations dialog box.

To open the Add New Orientation dialog box do one of the following actions:

*  Click New.

* Right-click in the Custom View Orientations dialog box, and then choose
New Orientation.

The coordinate values of the open structure appear in the boxes.

Type a name for the new view orientation.

Modify the values in the boxes.

Click Activate to orientate the display in the graphics area to the new values.
Note

You can click Reset Values to return the rotation values to the initial state.
Click OK. The new view orientation is added to the list for immediate use.
Click Close.
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To Change the Default View Orientation

1. Open the Custom View Orientations dialog box.

2. Right-click a view from the list and choose Set as Default. The selected view is
now boldfaced, indicating that it is default.

3. Click Close.

To Change the Order of the View Orientation List

1. Open the Custom View Orientations dialog box.

2. To change the row position in the view orientation list do one of the following
actions:

» Select a view orientation from the list and click the Move Up or Move Down
arrow.

* Select a view orientation from the list, right-click and choose Move Up or
Move Down arrow.

» Select a view orientation from the list, and drag it to the required position.

3. To set a view orientation at the beginning or end of the view orientation list,
right-click a view orientation and choose Move To Top or Move to Bottom.

4. Click Close.

To Delete View Orientation

1. Open the Custom View Orientations dialog box.

2. Delete a view orientation in one of the following ways:

* Select a view orientation from the list and click Delete.
» Select a view orientation from the list and press DELETE.
* Right-click a view orientation and choose Delete.

3. Click Close.

To Edit View Orientation

1. Open the Custom View Orientations dialog box.

2. Right-click a view in the Custom View Orientations dialog box and then choose
Edit, or select a view from the list and click Edit. Edit View Orientations dialog

box opens.

3. Modify the name or the values in the boxes, and then click Activate. The
display in the graphics area orientates to the new values.

Working with Viewables 65



Note
You can click Reset Values to return the rotation values to the initial state.
4. Click OK and Close.

Opening the Custom View Orientations Dialog Box
Open the Custom View Orientations dialog box in one of the following ways:

* Click in the graphics area, and then press U.
* From the Ribbon:

1. On the Home tab in the Navigation group or on the Structure tab in the
Parts group, click Orientation.

2. Click Customize. The Custom View Orientations dialog box opens.

To Set a View Orientation Relative to a Coordinate System
1. Open a structure with a coordinate system.

2. Select a coordinate system.

3. Right-click and select Relative View Orientation.

4

Select a view orientation from the list. The view orientation is displayed
relative to the selected coordinate system.

To Restore Original View Orientations

1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. In the Showing box, click Global.

3. On the left, click Model. The Model-Main options open on the right.

4

Click Restore to Original. A message opens, warning you that you will delete
all customized orientations and restore the original ones.

5. Click Yes and OK to continue.

Drawing View

About the Drawing View

You can view drawings of various file types, and you can annotate a drawing and
save it. Configure Creo View and Creo View Lite in the following ways to read
drawing files:
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»  HPGL—Define pen maps for viewing and printing
* DXF and DWG—Select and manage fonts
*  AutoCAD—Control the visibility of layers and blocks

If you install Creo View from the Windchill Software Downloads page, you must
select the AutoCAD Viewers option to open DXF and DWG files. You can
compare two drawings. Use the option settings to set the tolerance for arcs and to
modify the drawing viewer display.

To View Drawings with Multiple Sheets

1. Make sure that a drawing with two or more sheets is open.

2. To scroll through the sheets, do one of the following operations:

*  Click one of these buttons:

© Home » First
© Home » Previous
© Home » Next
© Home » Last

* In the graphics area, right-click and choose Next Sheet or Previous Sheet
from the shortcut menu.

3. To jump directly to a sheet, do one of the following operations:

*  On the Home tab, in the Sheets group, type the page number in the box and
press ENTER.

* In the graphics area, right-click and choose Go To Sheet from the shortcut
menu. In the Go To Sheet dialog box, type the sheet number in the Sheet
box and click OK.

About Comparing Drawings

In Creo View, you can compare 2D drawings to determine areas that overlap as
well as differences. You can specify how to align the drawings for comparison, and
there are many options for specifying comparison parameters. You can use this
feature, for example, to compare two versions of the same drawing to identify the
differences. Once you've selected the two drawings, aligned them properly, and
enabled comparison, the areas which are common will display in black, with the
areas specific to drawing A in red and areas specific to drawing B in green.
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To Compare Two Drawings

I.

In the Viewables tab, do one of the following operations:

Right-click a drawing in the list, choose Compare With, and select the
second drawing for the comparison.

Select two drawings from the list, right-click, and choose Compare
Selected.

Set one or more of the following commands on the Compare tab:

Align by Center aligns the two drawings by lining up the center point of
each drawing.

Align by References lets you select two reference locations (one on the first
drawing and one on the second drawing) by which to align the drawings.
This option displays the Select Alignment References window, where you

can either click in the drawing view to populate the Reference A and
Reference B fields to specify alignment anchors, or click CSYS to specify a

coordinate system for each field.

Show Both displays drawing A in red, drawing B in green, and their
intersection in black.

Show A displays only drawing A in red.
Show B displays only drawing B in green.

Show A-B displays drawing A in red, minus the portion of that drawing that
intersects with drawing B, which appears in black.

Show B-A displays drawing B in green, minus the portion of that drawing
that intersects with drawing A, which appears in black.

Show Overlap displays only the area that overlap between drawing A and
drawing B.

The Drawing menu lets you select which drawing the sheet control will
apply to.
Previous, Next, First, and Last sheets help you move through multi-sheet

drawings. You can also specify a sheet number, such as Sheet 2 of 5, to
display.

To Set General Drawing Viewer Options

1.
2.
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Click File » Creo View Options. The Creo View Options dialog box opens.

On the left, select Drawing Viewer. The Drawing Viewer-Main options open on
the right.

Under Load Settings, set the following options:
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* Approximate arcs from polylines—Polylines are analyzed to determine
whether they are arcs, and can then be used in radius measurements.

* Tolerance—Type a number from 0.1 to 0.75.

4. To set options for the active view, in the Showing box, select Active View. The
Active View options open.

5. On the left, select Drawing Viewer. The Drawing Viewer-Main options open on
the right.

To configure display colors, select or clear the Monochrome display check box.
Under Color, select or clear the Use background color from drawing check box.

To set a new background color, follow these steps:

a. Click the color button. The Choose Color dialog box opens.

b. Under Basic colors, select a color, or under Settings, select values for red,
green and blue.

c. Click OK. The Choose Color dialog box closes.

9. In the Creo View Options dialog box, click OK to apply the changes and close
the dialog box, or click Apply to apply the changes and keep setting options.

Setting the Tolerance for Arcs in Drawings

The tolerance setting is used for fitting arcs to polylines. If the difference in radius
between the two arcs falls within the tolerance you set, the arcs are merged. The
tolerance is a percentage: when you set a value of 0. 15, the tolerance is set at 15
percent.

Modifying the Display in Drawing View

Perform these actions to modify the display of a drawing:

Action Result
Markups are displayed or hidden.

Click Home » Filters » Markups.

Click Markup, and then type a number | Adjusts the scale.
in the Drawing Scale box.

About Pen Maps

In Creo View and Creo View Lite, a pen map is a collection of drawing viewer
option settings selected to display an HPGL drawing correctly in the graphics area
and when printing. In the Global options, you can configure one or more pen maps
and make your settings the default. In the Active View options, you can select a
pen map to apply to a selected view.
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To Configure the HPGL Pen Map

1. Click File » Creo View Options. The Creo View Options dialog box opens.

2. On the left, under Drawing Viewer, click HPGL. The Drawing Viewer-HPGL
options open on the right.

Under Pen Mapping, sclect the Use pen map check box.

To add a pen map, click Add. The HPGL Pen Map dialog box opens.
In the Name box, type a name for the pen map.

Click Add. The Choose Color dialog box opens.

Select a color and click OK. The pen map is added to the list.

To change the line width, double-click the default value in the Line Width
column of the list. The Line Width dialog box opens.

© =N kW

9. Type a new value and click OK.
10. Repeat steps 7—10 for each pen map that you want to create.
11. Click OK. The set of pen maps is added to the list.

12. Click OK to apply the changes and close the Creo View Options dialog box, or
click Apply to save the changes and continue setting options.

About Drawing Layers and Blocks

Drawing files from AutoCAD can include layers and blocks. Show or hide layers
and blocks to change the drawing display. You can save your visibility settings as
an annotation set.

To Show or Hide Drawing Layers

In an open drawing, in the upper data panel, click . The Layers pane opens.

2. Under Layers, select the check box next to one or more layers to show, and
clear the check box next to one or more layers to hide. The layer visibility is
updated automatically.

3. To revert to the original visibility settings, select a layer that is modified, right-
click, and choose a command from the shortcut menu:

* Reset to Original—Resets the selected layer.
* Reset All to Original—Resets all modified layers.

4. To save the settings, follow these steps:

a. Click File » Save Annotation Set As. The New Annotation Set dialog box
opens.
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b. Type the annotation set name details in the boxes and click OK. The layer
settings are saved.

To Manage Fonts for DXF or DWG Files

1.
2.

10.

Click File » Creo View Options. The Creo View Options dialog box opens.

On the left, under Drawing Viewer, click DXF - DWG. The Drawing Viewer-DXF
- DWG options open on the right.

To add a new font file path, follow these steps:

a. Click Add. The Add Font Search Path dialog box opens.
b. Click .... The Select DXF Font Directory dialog box opens.
To edit a file path, follow these steps:

a. Under Font, select the file path.
b. Click Edit. The Edit Font Search Path dialog box opens.
Click .... The Select DXF Font Directory dialog box opens.

Browse to and select the file path of the font, and then click Select DXF Font
Directory.

In the dialog box, click OK. The path appears in the Font box.
To delete a file path, under Font, select it and click Delete.
Select or clear the Use big font check box.

Click OK to apply the changes and close the Creo View Options dialog box, or
click Apply to save the changes and continue setting options.

To Load the Frozen Layers of Drawing File

1.
2.

Click File » Creo View Options. The Creo View Options dialog box opens.

On the left, under Drawing Viewer, click DXF - DWG. The Drawing Viewer- DXF
- DWG options open on the right.

3. Under Layers, select the Load Frozen Layers check box.

Click OK to apply the changes and close the Creo View Options dialog box, or
click Apply to save the changes and continue setting options.

To Show or Hide Drawing Blocks

In an open drawing, in the upper data panel, click . The Blocks pane opens.

Under Blocks, select the check box next to one or more blocks to show, and
clear the check box next to one or more blocks to hide. The block visibility is
updated automatically.
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3. To revert to the original visibility settings, select a block that is modified, right-
click, and choose a command from the shortcut menu:

* Reset to Original—Resets the selected block.
* Reset All to Original—Resets all modified blocks.

4. To save the settings, follow these steps:

a. Click File » Save Annotation Set As. The New Annotation Set dialog box
opens.

b. Type the annotation set name details in the boxes and click OK. The block
settings are saved.

Image View

Image Pages Commands

On the Home tab in the Sheets group, use Previous, First, Next, and Last, as well
as the current sheet number, to navigate multi-page images.

Modifying the Display in Image View

On the Home tab, in the Display group, use the following commands to modify the
display in an image view:

Action Result

Click Filters » Markups. Markups are displayed or hidden.
Click Invert Colors. The image colors are inverted.
Note

You can also right-click the graphics area and choose Invert Colors from the
shortcut menu.

Rotating and Flipping an Image
Use the following commands to rotate an image:

* On the Home tab, in the Navigation group, click Rotate Left or Rotate Right.

* In the graphics area, right-click and choose Rotate or Flip » Rotate Clockwise
or Rotate or Flip » Rotate Counterclockwise.

Use the following commands to flip an image:

*  On the Home tab, in the Navigation group, click Flip Horizontal or Flip Vertical.

 In the graphics area, right-click and choose Rotate or Flip > Flip Vertical or
Rotate or Flip » Flip Horizontal.
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Document View

About Viewing Documents

You can open documents from the L Document partition of the L& Viewables
pane in Creo View Lite and Creo View. While the PDF viewer is embedded in
Creo View, other document formats open in their appropriate programs.

Use the Find tool to search for text in PDFs. You can navigate, view markups,
and print PDF files. You can add markups to any PDF as long as either Adobe
Standard or Adobe Professional is installed. If you have only Adobe Reader then
you can only make markups when viewing a PDF with markup rights enabled.

You can view PDF drawings in Creo View, but you cannot create measurements or
construction geometry on them, or convert them to 2D vector files or illustration
files.

To View Documents with Multiple Sheets
1. To scroll through the sheets, do one of the following operations:

*  Click one of these buttons:

© Home » First
© Home » Previous
© Home » Next
© Home » Last

* In the graphics area, right-click and choose Next Page or Previous Page
from the shortcut menu.

2. To jump directly to a sheet, do one of the following operations:

*  On the Home tab, in the Pages group, type the page number in the box and
press ENTER.

* Click a page number in the Pages pane on the View pane on the
primary panel.

* Click an item in the Bookmarks pane on the View pane on the
primary panel.

To Toggle the Display of a Document’s Markups

Click Home » Filters » Markups.
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To Search PDFs Using the Find Tool
1. Click Home » Find. The Find dialog box opens.

In the Find box, type the text to search for.

2
3. To return only exact matches, select the Match whole word only check box.
4. To make the find case-sensitive, select the Match case check box.

5

Do one of the following:

« To find each instance of a name, click Find Next or Find Previous.

+ To find all instances of a specific name at one time, click Find All.

The matching text is highlighted in the document.

lllustration View

About lllustration Views

You can use Creo View to view and mark up technical illustrations created with
Arbortext IsoView. You can perform the following operations that are specific to
illustration views:

* Navigate the illustration

* Play an animation

* Create or delete annotations

*  Show or hide Hotspots

* Magnify an area of the illustration

» Use a Global View window for navigation

» Save the view as an annotation set

[lustration views are located in the lllustration folder in the Viewables pane.

Annotation sets for an [llustration view are located in the lllustration folder in the
Annotations pane.

To View an lllustration

Open a Windchill representation that contains * . i so illustrations.

2. In the primary panel, on the Viewables pane, click lllustration. The illustrations
associated with the representation are listed.

3. Select an illustration. IsoView opens, and the illustration opens in the graphics
area.
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To View an Animated lllustration

Open a representation that contains * . i so animated illustrations.

In the primary panel, on the Viewables pane, click Illustration. The illustrations
associated with the representation are listed.

Select an illustration. IsoView opens, the illustration opens in the viewing area,
and the animation begins.

To control the animation playback, on the ribbon, click Animation. The
Animation tab opens.

In the Animation group, select one of the following commands:

* Play
¢ Stop
* Rewind

To View an lllustration with the Magnifier Tool

1.
2.

Open an illustration view.

On the Home tab, in the Display group, click Magnifier. The Magnifier window
opens.

In the Magnifier window, move the slider up to increase the zoom, or move the
slider down to decrease the zoom.

In the graphics area, move the pointer over the illustration. The magnified view
appears simultaneously in the Magnifier window.

To Navigate an lllustration using the Global View Window

1.
2.

Open an illustration view.

On the Home tab, in the Display group, click Global View. The Global View
window opens.

In the graphics area, pan or zoom around the illustration. In the Global View
window, a red frame indicates the area of the model shown in the graphics area.

Using the Magnifier and the Global View

You can see a close-up of an area of the model using either of the following tools:

Working with Viewables

Magnifier—You can set the level of zoom in the Magnifier window, and then

move the mouse around the graphics area. The magnified area appears in the
Magnifier window.

Global View—You can zoom in on an area of the representation in the graphics
area, and then use the display in the Global View window to indicate the area of
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the illustration that you are viewing. The frame of the graphics area is indicated
in the Global View window by a red frame.

To Search an lllustration

1. Make sure an illustration file is open.

2. On the Home tab, in the Selection group, click Search » IsoView Search. The
Search dialog box opens.

3. Select one of the following operations:
* Search fo—Finds one of the following elements:

O  Object info

O  ObjectID

O  Object name

O Obiject tip

O  Obiject attribute
O Text

* Remove Highlight—Removes the search result highlighting.

4. Select a value to find. If you select is equal to or contains, type a value in the
box.

5. Click OK. The results are highlighted in the viewing area.

To Show or Hide Markups for lllustrations

1. Make sure an illustration file is open.
2. On the Home tab, in the Display group, click Filters.

3. To display markups, select Markups, or to hide them, clear the Markups option.

To Show or Hide lllustration Hotspots
1. Make sure an illustration file is open.
2. To show Hotspots, do one of the following operations:
*  On the Home tab, in the Display group, click Hotspots.
* In the graphics area, right-click and choose Show Hotspots.
3. To hide Hotspots, do one of the following operations:
*  On the Home tab, in the Display group, click Hotspots.
* In the graphics area, right-click and deselect Show Hotspots.
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To Set lllustration View Options

1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. In the Showing box, select Global.

3. In the left pane of the dialog box, select lllustration Viewer. The lllustration
Viewer-Main options open in the right pane of the dialog box.

4. Under Annotations, set any of the following annotation options:

¢ Line Width
e Color
* Font Size

5. Under General Display, select the Use Anti - Aliasing option to minimize line
distortion.

6. Under Hotspots, select or clear the Show alert message when Hotspot link is not
available in Creo View check box.

7. Click Apply to apply the changes and continue setting options, or click OK to
apply the changes and close the dialog box.

Note

When you change illustration options, the changes to the appearance are
applied to past illustration files as well.

Requirements for Viewing lllustrations

To view an * . iso illustration file, you must meet the following system
requirements:

*  You must use a Windows 32-bit machine.
* IsoView 7.1 must be installed and licensed.

* Illustration files must be opened from Windchill. You can only view
illustrations from Windchill using Creo View.

ECAD Viewables

About ECAD Viewables

In Creo View and Creo View Lite you can display schematic and PCB layout
views. The Creo View ECAD file format for these files is EDA (*.eda). An
ECAD viewable may be a separate file, or one or more viewables may be part of a
design package that also includes MCAD viewables. When you open an ECAD

viewable in Creo View, a substructure pane opens in the primary panel. It
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contains all the objects in the file, organized into partitions by type. You can
expand and collapse the partition labels. Objects can appear in more than one
partition on the substructure tab. For instance, a pin may be included in the
Components partition and under its net in the Nets partition. Next to each object
the following information appears in brackets, depending on the view type:

* PCB Layout—Location on the circuit board

* Schematic—Sheet where the object appears

The Color and Visibility pane opens in the upper data panel when you open an
ECAD viewable. For each viewable, a layer is added for object types that are
applicable to the whole design or that are located on more than one layer. In PCB
layout views, the Global layer lists these objects, and in schematic views, they are
on the Schematic Objects layer. You can use the color and visibility commands on

these layers to assign a common display status to all objects of an object type. The
Annotations layer contains the overlays or images associated with the viewable.

In the lower data panel, you can use the Attributes pane to show some or all of
the attributes of the design.

You can add markups to a schematic or PCB layout view. You can save the view in
these file formats:

» Structure (PVS or PVZ)
» ECAD viewable (EDA)
* Annotation set (AST) (Creo View ECAD only)

To Show an Object in All Partitions of the
Substructure Pane

In the substructure pane, right-click one or more objects, and choose Show In
Other Partitions from the shortcut menu.

To Expand or Collapse All Nodes of a Partition

1. Select any node in the partition. The node expands.

2. Right-click and choose Expand All or Collapse All from the shortcut menu.

Zoom for ECAD Viewables

Perform these actions to modify the zoom of the ECAD view:
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Action

Result

Click Home » [j Zoom All.

Zooms out to the maximum extents of
the viewable for the sheet.

Note

The maximum extents may be far
beyond the outlines of the sheet.

Click Home » El Zoom Window.

Zooms in to the window you define

On the substructure pane, double-
click one or more objects.

Click Home » Zoom Selected.

Select one or more objects, and then
right-click and choose Zoom Selected
from the shortcut menu.

Zooms in or out to include the selected
objects.

Note

For items on multiple sheets, the zoom
is performed on the first sheet with a
selection.

Select one or more object, and then
right-click and choose Center on Pick

Centers the view around the selected
objects.

from the shortcut menu.
In an ECAD schematic view, click
Home » Center on Selected.

In a PCB layout view, click Home »
Center.

Zooms in or out to the outlines of the

) B - .
Click Home » L%/ Zoom Outline. sheet or PCB outline.

About PCB Layout Views

You can display PCB layout views in Creo View and Creo View Lite. This view

shows the placement of objects in an ECAD design. The designs are made up of
layers. Some of the layers, such as the Global layer, are generated by Creo View,
while others are imported from the ECAD tool. The following layers may appear
in Creo View, depending on your ECAD data:

* Miscellaneous

* Annotations

Within each layer are one or more sublayers. The sublayers contain information
specific to the design, such as pads, vias, routes, and other geometries associated
with the conductive pattern. Use these operations to modify the view:

e Zoom

* Change Orientation

Working with Viewables
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e« Rotate
* Flip Sides

To Rotate, Flip, or Orient a PCB Layout View

1. To rotate the view click Home » Rotate Left or Home » Rotate Right.
The view is rotated by a 90—degree increment.

2. To flip the view, click Home » Flip Sides. The view is flipped along a
vertical axis.

3. To change the view’s orientation, click Home > Orientation » Top or Home >
Orientation » Bottom.

About Schematic Views

A schematic view shows the elements of the ECAD design using symbols to
represent the components and their circuits. You can display schematic views in

Creo View and Creo View Lite. The view contains standard sublayers on the
Color and Visibility pane. Schematic files can include several sheets. You can
scroll through the sheets or select a sheet name or number to view it. When a
schematic contains connectors to objects on other pages, you can jump to those
pages using the shortcut menu.

In addition to the partitions for standard symbols, the substructure pane for a
schematic view contains a partition for special symbols. Special symbols represent
logic and connectivity on the schematic but do not represent physical components
or conductors. For example, a special symbol could be voltage supply lines
connected to component symbols or pins or terminations of wires to or from
another sheet of the schematic.

You can open the hierarchical blocks of a schematic in the current view or a new
view using the shortcut menu.

To View a Schematic File with Multiple Sheets

1. To scroll through the sheets, click any of these buttons:

* Home » First
* Home » Previous
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* Home » Next
* Home » Last

2. To jump directly to a sheet, do one of these operations:

¢ Click Home » D Sheet Name, and then select a sheet from the list.
*  On the Home tab, type the page number in the box and press ENTER.

3. To view the other side of an off-page connector, right-click it and choose the
sheet name or number from the shortcut menu.

To Open a Hierarchical Block
Right-click the block and choose one of these commands from the shortcut menu:

* Open Block

* Open Block in New View

The block is displayed.

Displaying ECAD Designs

Color and Visibility

About Design Layer Color and Visibility

In an ECAD design, a layer’s appearance consists of these factors:
* Color

* Visibility status

* Position in the display order

You can control the appearance of design layers using the Color and Visibility
pane of the upper data panel. This pane appears when you open a PCB layout or
schematic view and shows the layers and sublayers of a design. Use the appearance
commands in these ways:

* Assign colors to layers to make them quickly identifiable.
* Show or hide layers to simplify the view.

» Set default display options in the Creo View Options dialog box, or make your
session settings the default.
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A layer can have sublayers of different colors, visibility statuses, or both. You can
reuse a color any number of times for multiple layers. You can also assign one
color to a group of like sublayers and select colors for groups.

Layers are displayed one on top of the other. Use the Bring to Top command to
change the order of the display. To preview a change in layers, place the pointer
over a layer to show it on top. The previous top layer becomes the second layer,
and the remaining layers move downward. You can undo your changes and revert
to the default order. In PCB layout views, perform these additional operations to
control the appearance of the design:

* Invert the layers

» Fill visible, solid shapes

To Change the Color and Visibility of a Layer

1. Onthe Color and Visibility pane of the upper data panel, select the check
box for the layers that you want to display and clear the check boxes for the
layers to hide.

2. To change the color of a layer or sublayer, double-click the category name and
select a new color in the Choose Color dialog box.

Note

*  You can also right-click the layer and choose Assign Color from the
shortcut menu to open the Choose Color dialog box.

o AE mixed state indicator for a layer’s color or visibility means that the
sublayers have different statuses.

3. Right-click the Color and Visibility pane and choose an action from the
shortcut menu:

* Apply to all—Applies the visibility setting for a sublayer to all sublayers
with the same name

* Save as defaults—Makes your display settings the default
* Reset to defaults—Reverts to the default display settings

4. To define the appearance of overlapping layers, click Home > Overlap Color.

Example: Applying Color and Visibility to Like Sublayers

Many ECAD designs have sublayers with the same name on multiple layers. For
example, more than one layer can contain a sublayer for via pads. When you right-
click one of the via pads sublayers and choose Apply to all Via pads, the visibility
settings for the sublayer are applied to every sublayer in the design named Via
pads.
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Displaying Holes and Groups

By selecting or clearing the visibility check box and setting a color on the Global
layer, you control the display of these types of holes:

e  Mechanical holes

* Holes that penetrate all layers of the circuit board

The display of non-through-hole vias depends on the display status of the layer on
which they reside. You can control the display of holes for vias and pins separately.
The display of groups may also depend on the status of the layers. When a group is
marked visible, all of its members are visible. When a group is marked hidden, the
display of its members is controlled by the visibility of the layers where the
members reside.

To Display ECAD Regions, Areas, and Lightweight Holes in the Model View

1. In an open model view, click Home » Filters. The Display Filters dialog box
opens.

2. Under Model Construction Geometry, sclect the Datum Curves check box.

Click OK. Regions and lightweight holes are visible.

To Change the Background Color or the Group Overlap Color

1. In an ECAD Schematic or PCB Layout view, click File » Creo View Options.
The Creo View Options dialog box opens.

In the Showing box, select Active View.

. In the left pane of the dialog box, under PCB Layout Viewer or Schematic
Viewer, select Color and Visibility. The PCB Layout Viewer- Color and Visibility

or the Schematic Viewer-Color and Visibility options open in the right pane of
the dialog box.

4. Click the button next to Background Color or Group Overlap Color. The Choose
Color dialog box opens.

5. To change the color, do one of these operations:

* Select a new color
* Drag the sliders next to Red, Green, and Blue.
* Type values in the boxes next to Red, Green, and Blue.

6. For PCB Layout you can set the Dimming Level by moving the slider or by
adjusting the value in the box.

7. Click Apply to apply the preferences and keep the Creo View Options dialog
box open, or click OK to apply the settings and close the dialog box.

Working with Viewables ’3



Displaying Overlapping ECAD Layers

The status of the II‘ Overlap Color button determines the display of two or more
layers at their points of overlap:

* On—Blends the colors of the layers
* Off—Covers the bottom layers with the top layer

By default, the button is off.

To Set Color and Visibility Defaults

1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. In the Showing box, select Defaults.

3. On the left, under PCB Layout Viewer or Schematic Viewer, sclect Color and
Visibility. The Color and Visibility page opens.

4. Select the objects in the list to show by default. Clear the check boxes for the
objects to hide.

5. To set a default color for an object type, double-click it, and then select a color
in the Choose Color dialog box.

6. Click the color box to change the default color for these elements of the design:
* Background Color
¢  Group Overlap Color

7. To set the brightness of colors in a PCB Layout view, move the Dimming Level
slider or adjust the brightness percentage in the box.

8. Click OK.

To Change the Display Order of Layers

Click Home » Bring to Top. A list of the layers appears.
2. Select a layer.

Note

* You can only bring a design layer to the top.

e In schematic views, Pins is the default top layer.

3. To undo your changes, click Home » Bring to Top > Reset to Default. The
original order is restored.

To Invert the Display of Layers

In a PCB Layout view, click Home »> Invert Layers. The display of the layers is
inverted.
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To Toggle the Fill of Shapes in PCB Layout Views

Click Home » Fill Shapes. All visible, solid shapes are filled or only the
outlines of shapes are shown.

Highlighting and Isolating Objects

About Highlighting and Isolating Objects

In Creo View ECAD you can use the following tools to emphasize selected objects
in a PCB Layout view:

. E Isolate—Dims the surrounding objects and displays the selected objects at
full intensity

. Highlight—Applies a different color on top of the selected objects. It does
not change the underlying color and visibility settings for the object type

You can highlight these objects:

* Components

* Nets

* Pins

* Test points

* Regions

*  Mechanical holes

Apply a solid highlight to cover the objects’ color, or select a dashed highlight to
keep the color visible underneath. When one or more highlighted objects overlap,

their display is controlled by the III Overlap Color setting. You can refine
selections to highlight or isolate by performing these actions:

» Limit your selection to visible sublayers or allow the selection of related
geometries on other sublayers.

* View and edit a list of the highlighted or isolated objects to modify the display.

In schematic views, only the Highlight tool is available. When you highlight an
object in a schematic view, all of the associated objects, such as lines, symbols, and
text, are also highlighted. When you highlight a fractured component or a net that
spans multiple sheets, the first instance is shown. When you highlight objects on
an undisplayed sheet, you must navigate to the sheet to view the highlighting.

In Creo View Lite these tools are read-only.
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To Highlight Objects

1.

Click Home, and then click the arrow next to Highlight. The Highlight
menu opens.

To define the objects available for highlighting in PCB Layout views, select
one of these options:

* Only Visible Sublayers
* All Sublayers

To set the highlight color, perform these actions:

a. Click Home » Highlight » Define Highlight Color. The Choose Color
dialog box opens.

b. Select a color and click OK.

To set the highlight style, click Home » Highlight, and then select or
deselect the Dashed Highlight option.

In the graphics area or on the substructure tab, select one or more objects to
highlight.

Click Home » Highlight » Highlight. The selected objects are highlighted.
Note

You can also right-click the graphics area and choose Highlight » Highlight from
the shortcut menu.

To Add Highlights to Additional Objects

Select the objects to highlight, and then click Home » Highlight » Add Highlight.
The additional objects are highlighted.

Note

Clicking Add Highlight adds to the existing highlights, while Highlight removes
existing highlight and highlights the selected objects.

You can also right-click the graphics area and choose Highlight » Add to
Highlight from the shortcut menu.

Highlighting Buses

When you select a bus trunk to highlight, the entire bus and all its associated nets
are highlighted. When you highlight a net associated with a bus, the net’s full path
and the bus trunk are highlighted.
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To Clear Highlighting

You can clear highlighting in two ways:

To remove all highlighting, click Home » Highlight » Clear All Highlights.
To clear the highlighting for one or more objects, select them and click Home »
% Highlight » Remove Highlight. The highlighting is removed.

Note

You can also perform these actions:

1. Click Home » Highlight » Show Highlight List. The Highlighted Objects
dialog box opens.

2. Select one or more objects and click Remove.

To Isolate Objects

1.

Click Home, and then click the arrow next to E Isolate. The Isolate menu
opens.

To define the objects available for isolation, select one of these options:

* Only Visible Sublayers

¢ All Sublayers

To set the dimming level for the rest of the objects in the design, perform these

actions:

a. Click Home » E Isolate » Dimming. The Creo View Options dialog box
opens.

b. Next to Dimming Level, adjust the slider between Dim and Bright, or select a
brightness level from the box.

c. To apply your setting to other views or to the default setting, select one or
both of these options:

¢ Update Defaults
* Update All Views
d. Click OK. The dimming level is set.
To toggle the display of logical connections for isolated routes, click Home »

Isolate, and then select or clear the Show Logical Connections option.

Select one or more objects to isolate, and then click Home » E Isolate »
Isolate. The objects are isolated.
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Note

The E Isolate button removes any previous highlighting on the selected
objects.

To Clear Isolation for One or More Objects

1. To remove all isolation, click Home » E Isolate » Clear All Isolated Objects.

2. To clear the isolation for one or more objects, select them and click Home » E
Isolate » Remove Isolated Object. The isolation is removed.

Note
You can also perform these actions:

a. Click Home » E Isolate » Show Isolated Object List. The Isolated Objects
dialog box opens.

b. Select one or more objects and click Remove.

Displaying Text

About Setting Text Data Options for PCB Layout Views

You can set the font style and the font size in PCB Layouts to prevent the text from
being illegibly small or disproportionately large.

To Set the Option for PCB Layout Text Data
1. Click File » Creo View Options. The Creo View Options dialog box opens.

2. In the Showing box, select Defaults or Active View.

3. On the left, under PCB Layout Viewer, select Text Data. The Text Data options
open.

4. In the Default Font box scroll to the required font.
In the Font Size box scroll to the required value.

Click Apply to apply the settings and keep the Creo View Options dialog box
open, or click OK to apply the settings and close the dialog box.

Adding Overlays
About Overlays

An overlay is an image that represents the following information, depending on the
file format:
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*  Gerber—Manufacturing artwork. A Gerber RS-274X file contains settings for
placement, format, scale, and other parameters, while a Gerber RS-274D file
does not.

* DXF—Mechanical or fabrication drawing

Use an overlay to compare manufacturing output data by placing the overlay over
the corresponding PCB layout design. You can set the format, unit, polarity,
placement, and scale for files without embedded settings. Then, load an overlay to
a design in either of these ways:

» Create an overlay from an external file.

* Open an overlay viewable contained in the PVS or PVZ file.

Creo View ECAD contains commands for aligning and rotating the overlay to the
design.

Note

Rotating an overlay before performing an alignment operation produces the best
result.

After you have placed an overlay on a design, you can add markup. Save the
overlay as an annotation set. You can also open a Gerber or DXF file in a new
view. You can load more than one overlay to a design, but you can only turn on the
visibility of one overlay at a time. Loaded overlays appear under Annotations on

the Color and Visibility pane of the upper data panel. Select any of the
following types of display for an overlay:

*  Opaque

* 50 percent transparent

* Opaque with an II‘ Overlap Color where the geometries of the overlay and the
design coincide.

You can view the tooltip of an object that is below the visible overlay if the
Exclude Overlays option in PCB Layout Viewer-Tooltips is selected. If the option is

not selected, you can view the tooltip of the overlay.

To Load an Overlay from the Structure

1. In an open design, click Overlays, and then click the arrow below New Overlay.
The New Overlay list opens.

2. Select an overlay from the list. It opens in the graphics area.
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To Load an Overlay from an External File

1. In an open design, click Overlays » New Overlay » Load from file. The Open
File dialog box opens.

Select a file and click Open. The overlay is loaded.

3. To save the overlay to the structure, save it as an annotation set.

To Align an Overlay by Aligning Vertices

Click Overlays » Align. The Select Alignment Vertices dialog box opens.
2. Click the Overlay Vertex reference collector to activate it.

3. Inthe graphics area, select a vertex in the overlay. It appears in the reference
collector.

4. Select the corresponding vertex in the design. It appears in the Design Data
Vertex reference collector.

5. Click OK. The overlay is aligned to the design.

To Align an Overlay by Rotating or Flipping

Click Overlays, and then select one or more commands:

. Rotate Left

. Rotate Right

. Flip Vertical

. Flip Horizontal

The overlay is repositioned.

To Change the Display of an Overlay

1. To display the overlay at 50 percent opacity, click Overlays » Transparent. The
opacity is adjusted.

2. To display a different color where the geometries of the overlay and the design

overlap, click Home » E Overlap Color. The overlap color is applied.

To Rename an Overlay

1. Click Overlays » Rename. The Rename Overlay dialog box opens.
2. In the Name box, type a new name.
3. Click OK.
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To Delete an Overlay

Click Overlays » Delete.

To Set the Format, Scale, and Position Options for Gerber

RS-274D Files

1. Click Overlays » Edit Options » Gerber RS-274D Options. The Creo View
Options dialog box opens to the PCB Layout Viewer-Gerber RS—-274D page.

2. Set options for these categories:

* Format
¢ Units
* Image Polarity

e Scale

3. To use a parameters file to set the options, under Gerber Parameters File, click
Load. The Browse Gerber Aperture File dialog box opens.

4. Select the file and click Open.

Click Apply to apply the settings and keep the Creo View Options dialog box
open, or click OK to apply the settings and close the dialog box.

Options for Gerber Files

Use these settings to control the parameters of Gerber RS-274D overlays:

Category

Option

Description

Format

Integer Places

Decimal Places

Shows the selected
number of digits for data
coordinates. You can set
the number of digits
before and after the
decimal point. For the
RS-274D file, set these to
5 and 4, respectively.

Leading zeros

Trailing zeros

Drops the zero at the
beginning or end of a data
coordinate.

Absolute

Displays data coordinates
relative to 0.0.

Incremental

Displays data coordinates
relative to the selected
coordinates.

Units

Inches

Sets the unit of
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Category Option Description
Millimeters measurement.

Image Polarity Positive Displays positive or
Negative negative images.

Scale Scale Sets the scale for
coordinates.

Gerber Aperture File Browse Loads the file containing
a description of geometry
that defines the shape of
the features.

Gerber Parameters File Load Loads a file containing

settings for the parameters
described in this table.

RS-274X files include definitions for these parameters.

To Set Scale and Position Defaults for Overlays

1. Click Overlays > Edit Options > Overlay Options. The Creo View Options dialog

box opens to the PCB Layout Viewer-Overlays page.

2. To convert the scale for an overlay with a different unit of measurement, type a

value in the Scale box.

3. To rotate the overlay, type or select an angle in the Rotation box.

To align the overlay origin to the design origin, type values in the X Offset and

Y Offset boxes.

5. To flip the overlay, select one or both of these check boxes:

¢ On horizontal axis

* On vertical axis

6. Click OK. The defaults are set.
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About Searching Structures and Designs

You can search MCAD structures for parts designs for object names or attributes.
Enter the search text and conditions in one of the search dialog boxes. The Search
function is context sensitive, so that MCAD data opens the MCAD search options,
and an ECAD viewable opens the search tool to ECAD options. Search results

appear by default in the Results pane, but you can redirect them to be saved as

a group.

You can narrow your search by using wildcard and codes to find words or phrases
that contain specific letters or combinations of letters.

Types of Searches

The Creo View Search button is a split button. Click E Search on the icon to

open the default Search Product Structure dialog box. The Find functionality is
also available in Creo View Lite. Click the arrow to select any one of the search

options:

Search Types in Creo View

Type

Description

Search

Narrows the search by defining several
context sensitive search criteria to
obtain a short, accurate results list.

Searches the MCAD structure for parts
or attributes, or perform a spatial search.

Searches the ECAD design for objects
or attributes.

E Color-coded Search

Performs multiple MCAD searches
simultaneously and color-code the
results.

Quick Search

Obtains a list of entities by name.

Searches by MCAD part name or
ECAD object name.

Find

Finds an entity with a known name, but
unknown location.
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Type Description

Searches by MCAD part name,
attribute, or construction geometry
entity, or ECAD part name or attribute.

MCAD Searches

About MCAD Searches
There are three types of MCAD searches:
Type Searches by
Part Name of entities
Attribute Defined numeric or nominal attributes
Spatial Parts within a physical distance from the bounding
box or sphere center

The Search Product Structure dialog box updates dynamically based on the option
you select.

Although you can run a search without giving it a Query Name, use the Query
Name for these tasks:

Upload the same search criteria in subsequent sessions.

Enable multiple search criteria when applying the IZI Color-coded Search tool.

You can save the search results as a @ Search group.

To Search for MCAD Parts

1.

A U o

Searching the Structure

Open an MCAD structure.

Click Home » Search. The Search Product Structure dialog box opens.
In the Query Name box, type or select a name for the search.

Choose a Search Against option from the list.

Next to Do query of type, select Part. The dialog box updates.

In the Name box, enter the text string you want to match.

Select a Loaded in active view option:
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10.

I1.

12.
13.

* Don’t Care—Search all parts in the assembly, regardless of their load state.
*  Only Loaded—Search only loaded parts.

*  Only Unloaded—Search only on parts that are not loaded.

Select Ignore Case to disregard capitalization.

To define multiple search conditions at once, select the Show Multi-line check
box, and then specify a combination of search rules to use in conjunction with
each other. Select And or Or to define the conditions of the search.

Click Apply to run the search and save the Query Name. The search results
appear under Part Name in the Results pane in the upper data panel.

Click Reset to reset the query to when it was opened or when Apply was last
pressed.

Click Save As Group to save the search results as a group.

Click OK. The search results appear in the Results pane in the upper data panel
and the Search Product Structure dialog box closes.

To Group Search Results

Set the Search configuration in the Search Product Structure dialog box.
Click Create Group. The Group Name dialog box opens.

Type a name for the group click OK. The results appear as group members in

the Group pane.

To Search for MCAD Attributes

1.

A

96

Open an MCAD structure.

Click Home » Search. The Search Product Structure dialog box opens.
In the Query Name box, type or select a name for the search.

Select a Search Against option from the list.

In Do query of type, select Attribute. The dialog box updates.

Set the attribute variables as follows:

a. Select a Name from the list or type a new name for the attribute. The Name
list contains a list of all the different attribute names that exist in the current
product structure.

b. Under the Categories to search:

» Select Selected to narrow the choice of property sets.

* Select All to search all property sets.
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10.
I1.

Note
For one component, a single property often has multiple values.
c. Define the type of comparison:

*  Check Numeric Comparison to apply the basic arithmetic operators list,
or leave it unchecked to apply two string comparison operators list.

» Set the Which is variables.
The Which is arithmetic operators are <, <=, =, !=, >, >=; and the two
string comparison operators are 1 ike and unlike.

* Check Value and type a value in the adjoining box, or check Attribute
and select an attribute name from the list. The search tool will then
match the property against the named property on the same component.

Note

If you use an arithmetic operator, a numeric comparison is performed, and
if you use a string operator, a string comparison is performed. As a result,
"prop name a" = "prop * b" will be converted into numbers for matching.

Select Ignore Case to disregard capitalization.

To define multiple search conditions at once, select the Show Multi-line check
box, and then specify a combination of search rules to use in conjunction with
each other. Select And or Or to define the conditions of the search.

Click Apply to run the search and save the Query Name. The search results
appear in the Results pane in the upper data panel.

Click Save As Group to save the search results as a group.

Click OK. The search results appear in the Results pane in the upper data panel
and the Search Product Structure dialog box closes.

To Search an MCAD Structure Using Spatial Criteria

1.

A

Searching the Structure

Open an MCAD structure.

Click Home » Search. The Search Product Structure dialog box opens.
In the Query Name box, type or select a name for the search.

Select a Search Against option from the list.

In Do query of type, select Spatial. The dialog box updates.

Set the center of the spatial query by selecting a Local to option. The dialog
box updates.

Continue as follows:
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* Sphere
a. Type the X, Y, and Z global coordinate values of the center of the
sphere, or drag the sphere into position.
b. Type a Radius value.

c. Click the pin icon to the right of the coordinate values to lock the
specified values. Click again to unlock the values.

d. Check Preview to see the coordinate and radius positions.

e. Drag the sphere’s surface to resize it.

f. Drag the green, red, or blue arrows to change the sphere’s position.
* Box—Enter the Minimum and Maximum X, Y, and Z coordinate values to

find the parts that fall within the bounding box.

Note

Check Preview to see the coordinate and radius positions.

* Part Bounding Box

a. Select a Part from the Structure Tree or the graphics area.

b. Click the pin icon to the right of the part name to lock the specified
value. Click again to unlock the value.

c. Enter the Proximity value to expand or shrink the bounding box in all
directions. For example, a proximity value of 9 would expand the
bounding box 9 units to the left, 9 units to the right, 9 to the top, and so
on.

8. To define multiple search conditions at once, select the Show Multi-line check
box, and then specify a combination of search rules to use in conjunction with
each other. Select And or Or to define the conditions of the search.

9. Click OK. The search results appear in the Results tab in the Navigator.

About Color-coding Search Results

Use the Color-coded Search tool to assign a different color the results of
different MCAD search queries and view them together in order to differentiate the
results on the Structure Tree and on the model in the graphics area. You can assign
an extra color to accommodate search results that include items from more than
one color category. Components that are not included in the search results are
rendered semitransparent.
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To Search by Color

I.
2.

Open an MCAD model.

Click Tools » Color-coded Search. The Color-coded Search dialog box
opens.

In the Query name box, type or select a name for the search.

Note
This Query name is saved in a ditferent folder to Search » Query name items.

Under Assign colors to queries, click Add Condition. A condition line appears
in the box.

Fill in the condition line:

* Under Color, click the button. The Manage Colors box opens. Select a
color.

*  Check Condition Type » Named. The Search Name list is populated with
Search » Query name items.

* Select an item from the Search Name list to attach defined search criteria to
the query.

* To define new search criteria, click Refine. The Search » Search Product
Structure dialog box opens.

Under Assign colors to queries, click Add Condition to add another condition
line to the box.

Click Show matched multiple search conditions in. The Manage Colors box
opens. Select a color.

Click Ok. The search results appear in the Results tab of the Navigator.

Using Wildcards to Retrieve Part Names

You can enter wildcard characters to find part names. You cannot use wildcards in
place of version numbers.

This is the match syntax:

An asterisk (*) can replace any number of characters.
A question mark (?) can replace any one character.

You can type a question mark alone to get a complete listing of the appropriate
names in the directory

For example, when you type : *1237? you get the parts whose names match:

<any characters>123<one character>.

Searching the Structure
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About Editing or Deleting Query Names

The Manage Queries button on the Search Product Structure, the Color-coded
Search, and the Search ECAD Design dialog boxes opens the MCAD and the

ECAD Manage Queries dialog boxes.

The Manage Queries dialog box lists all the saved queries by name. You can
rename or delete queries from the list.

The MCAD Manage Queries dialog box includes the Color-coded Search option,

allowing the user to choose either simple Search query names and Color-coded
Search query names.

To Edit Search Query Names

1. With the MCAD Search Product Structure or the ECAD Search ECAD Design
dialog box open, click Manage Queries . The Manage Queries dialog box
opens.

2. Select an item from the list and click Rename. The Rename Query dialog box
opens.

3. Type a new name and click OK. The name updates in the Manage Queries
dialog box.

To Delete Search Query Names

1. With the MCAD Search Product Structure or the ECAD Search ECAD Design
dialog box open, click Manage Queries. The Manage Queries dialog box
opens.

2. Select an item from the list and click Delete. The name in the Manage Queries
dialog box is deleted.

MCAD Search Results

About Working With MCAD Search Results

The Search results open in the Results pane in the upper data panel. Select
items in the Results pane to view their corresponding entities on the Structure Tree
and in the graphics area. The Results tab in the Ribbon contains these options:

100 Creo™ View 1.0 Help Topic Collection



Select in Structure—Highlights the part currently selected in the Results pane
in the graphics area and selects it in the Structure Tree.

|:| Color Code All—Displays results in their respective colors in the Structure
Tree and in the graphics area, making the correspondences between the product
structure, assembly, and part in the query list easy to identify. Components that
do not appear in the results list appear in semitransparent white in the graphics
area.

Clear Color Coding—Removes color coding.

Select all of Color—Colors all parts in the graphics area that match the
color code of the currently selected part in the results pane.

Clear Results—Empties the results pane and undoes color coding.

Show Query—Opens the Search Product Structure dialog box and displays the
configuration of the currently displayed search results.

Show Paths—Toggles the display of the full path name in the Results pane.

Filter Results

You can use the shortcut menu to activate the above-listed options.

To Filter Search Results

In the upper data panel, click . The Results pane opens.

Right-click in the Results pane and choose Filter Results, or click Filter at the
bottom of the results pane. The Filter Results dialog box opens.

To filter the items by name, check Names matching and type text in the Enter
text to match field.

To filter results by color when the results of an Advanced Search are displayed,
check Colors matching, and select one or more of the colors to display the
items with the color.

Click OK. The results are filtered.
Right-click in the Results pane and choose Reset Filters to undo the filter.

ECAD Searches

About ECAD Searches
There are two types of ECAD searches:
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Type Searches by

Name or Object ID Name of object or part

Attributes Defined numeric or nominal attributes

The Search Product Structure dialog box updates dynamically based on which
option you select.

Although you can run a search without giving it a Query Name, use the Query
Name to upload the same search criteria in subsequent sessions.

To Search for an ECAD Object
1. Open an ECAD PCB Layout or Schematic file.

Click Home » Search. The Search ECAD Design dialog box opens.

2.

3. In the Query Name box, type a name, or select a name from the list.

4. In the Search For box, type a name, or select a name from the list.

5. Select an entity from the Search Within list, or leave the control at All the
default value.

6. Select an option from the Search By list.

7. Select an option from the Rule list.

8. In the Value box, enter the text string you want to match when searching parts.

9. Select Ignore Case to query all text case options when performing the search.

10. Select Show Multi-line to enable the option, and then specify a combination of
search rules to use in conjunction with each other. Select And or Or to define
the conditions of the query. This option is unchecked by default and is relevant
only if the query definition consists of more than one line.

11. Select Apply to run the search and save the Query Name. The search results
appear in the Results pane in the upper data panel.

12. Select Reset to reset the query to when it was opened or when Apply was last
pressed.

13. Click OK. If the query is named, it is saved. The query results appear in the
results tab in the Secondary Navigation pane.

To Search for ECAD Attributes
1. Open an ECAD PCB Layout or Schematic file.

2. Click Home » Search. The Search ECAD Design dialog box opens.

3. Inthe Query Name box, type a name, or select a name from the list.
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10.

11.

12.

Select a Search Within category.

Note

If you select Selected or Highlight, the Search By option automatically set to
Attribute.

Under Search By, select Attribute. The dialog box updates.
Select the Value or the Name radio button.

If you checked Value, then continue as follows:

a. Select All or another option in the Within Attribute field which contains a list
of all the different attribute names that exist in the current product structure.

b. Select Numeric Comparison to apply the basic arithmetic operators list, or
leave it unchecked to apply two string comparison operators list.

c. Set the Comparison variables. The Comparison arithmetic operators are <,
<=,=, !=,> >=;and the two string comparison operators are Equals
and Does not equal.

d. Type a value in the Value box.
If you selected Name, then continue as follows:

a. Set the Comparison variable to Equals or Does not equal.
b. Select an option from the Value list.
Select Ignore Case to query all text case options when performing the search.

Select Show Multi-line to enable the option, and then specify a combination of
search rules to use in conjunction with each other. Select And or Or to define
the conditions of the query. This option is unchecked by default and is relevant
only if the query definition consists of more than one line.

Click Apply to run the search and save the Query Name. The search results
appear in the Results pane in the upper data panel.

Click Reset to reset the query to when it was opened or when Apply was last
pressed.

Click OK to run the query. If the query is named, it is saved. The query results
appear in the <2 . results tab in the upper data panel.

ECAD Search Criteria

Search Within —Leave at default All, or select one object type.

These objects apply to both Schematics and PCB layout:

Components
Nets
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* Pins

* Selected

» Highlighted

These objects appear only when searching a PCB, and only if they have a unique

identifier, such as Name/Ref Des, Type, Attribute, or Object ID to distinguish one
from the other:

* Test Points

* Vias

* Regions

* Mechanical Holes

Search By—Narrows the search within the selected Search Within field.

Rule-Narrows the search further by filtering options such as Top or Bottom side for
components, or Routed or Unrouted for nets.

Value—Enter alphanumeric values including variables and wildcard characters.
The field is blank by default.

Working With ECAD Search Results

The Search results appear in Results pane of the upper data panel.

The results are sorted alphanumerically. You can control the order from the column
header. If you search for All, and the results include different types of objects, you
can click in the icon column header to sort the results by object type. Each type has
a different icon.

* Right-click and choose Select or double-click a result in the Results pane to
view its corresponding entities on the Model Tree and in the graphics area, and
its details in the lower data panel.

* Right-click and choose Select All and then Select in the results pane. A list of
details of all the search results opens in the lower data panel.

* Right click and choose Show Query to open the Search ECAD Design dialog
box with the configuration from which the displayed results were attained.

* You can change the query configuration, but if you click Reset , the
configuration reverts to what it was when you opened the dialog box.

* Clear Results clears the results from the Results pane.
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The Quick Search Tool

About the Quick Search Tool

Use the Quick Search tool for MCAD or ECAD to obtain a list of entities with

a common string in their names. You can type a new search string, or select an
existing search string from the drop-down list.

To Perform a Quick Search
1.

Viewing ECAD Quick Search Results
The order for ECAD object names is:

Do one of the following:

¢ Click Home » Quick Search.
*  Click the Results tab of the Navigator.

The Quick Search box at the top of the Results pane in the upper data panel is

activated.

In the Quick Search box, type the text that you want to search for, or select the
text from the drop-down list, then press ENTER. The results list appears on the

Results pane in the upper data panel.

Components
Nets

Pins

Test Points

Vias

Route Segments
Regions

Mechanical Holes

Searching the Structure
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The Find Tool

About the Find Tool

You can find the location of MCAD parts and ECAD objects, as well as attributes

of either in the loaded assembly using the Find tool. you can also use the tool
to look for words and phrases in PDF documents.

In the Find dialog box, you can enter a search string in the Find what box, and
specify whether to search for part names, attribute names, or construction
geometry. You can also select whether to match the whole word when searching,
and whether to match the case of the text you entered.

The results are selected in the structure tree, and highlighted in the upper data
panel. You can view the results individually or all at once.

To Search using the Find Tool

1.
2.
3.
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Click Home » Search » Find. The Find dialog box opens.
In the Find what box, type the text you want to search for.
Select one of the following definitions for the element that you want to find:
*  When finding an MCAD object:
O Part and Attribute name
O  Part name only
O Attribute name only
O Construction geometry only
*  When finding an ECAD object:
O  Object and Attribute name
O  Object name
O Attribute name
To return only exact matches, select the Match whole word only check box.
To make the find case-sensitive, select the Match case check box.
Do one of the following:
« To find each instance of a name, click Find Next or Find Previous.

* To find all instances of a specific name at one time, click Find All.

The matching object attributes appear in the Data Panel and are highlighted in
the Graphics Area and in the Structure Tree.
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About Viewing ECAD or MCAD Attributes

An attribute is descriptive information to a selectable ECAD object or MCAD part
or subassembly in Creo View. The attributes of these items are derived from source
data and vary according to company procedures and design software. These are
some examples of attributes:

* Numerical data

*  Manufacturer

* Device Type

* Location of a product in a warechouse

*  Product serial number

You can view attributes of the associated separate window. Object ID’s enable
cross-product collaboration between Creo Parametric, Creo View, and native
ECAD tools. You also can copy attribute data to applications such as Microsoft
Excel or Word.

In Creo View Lite and in Creo View you can view the attributes of one item at a
time. In Creo View you can also view a list of attributes of multiple items.

Example: Viewing Attribute Information

View the attribute information in the Attribute pane on the lower data panel.
The name of a single selected part, subassembly, or object is appended to the pane
title. The names of multiple items appear in the left column of the Attributes list.
The objects are highlighted in the graphics area and the parts and subassemblies in
the Model View.

The first four columns (NAME, OBJECT TYPE, NET, COMPONENT) in an ECAD
attributes list are permanent. You can filter and rearrange the order of the other
columns. The attribute value fields that do not require values are shaded,
otherwise, the value field can remain empty.

To expand the lower data panel to show all attributes, click IH in the top-right
corner of the lower data panel. The contents are resized.

To View ECAD or MCAD Attributes

Presentation and Action Result
As a vertical list—Select one ECAD The item and its attributes are displayed

OI‘IDJect o MCAD part or ;ubasslemlbly "™ | as a vertical list in the 52| Attributes
the graphics area, a search results list, or pane in the lower data panel. A
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Presentation and Action

Result

in the primary panel.

subassembly is displayed as one item.

On one line—Right-click the Attributes

pane and choose Show Single Select as
List.

The item and its attributes are displayed
on one line.

Multiple items—Select multiple objects,
parts or subassemblies in the graphics
area or in the primary panel.

The items are displayed with their

attributes as a list in the Attributes
pane.

To move an attribute to the fifth column
—Right-click in an ECAD attributes
column header to the right of the fifth
column and choose Move to 5th Column.

The selected column shifts to the fifth
column, and the order of the other
columns is maintained.

About Filtering the Display of Attributes

You can filter the display of attribute columns for an ECAD object or an MCAD
part or subassembly. If you select an attribute name shared by two of more ECAD
objects, all objects with identical names are displayed.

To Filter MCAD Attributes

1. In the Attributes pane, right-click and choose Filter Attributes. The Filter

Attributes dialog box opens.

2. To select the attribute categories to display, perform one of these actions:

» Select Categories matching and Category Name and choose the categories.

* Select Names matching and in the Enter text to match field, type the name

of a category.

3. Click Make Default to keep the settings as the default.
4. Click OK. The Attributes list is filtered.
5. To revert to the original default settings, right-click in the Attributes pane and

choose Reset Filters.

To Filter ECAD Attributes

1. In the Attributes pane right-click and choose Filter Attributes. The Filter

Attributes dialog box opens.
2. Select a filter mode for the attributes:

Viewing the Attributes
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*  Show All—View all attribute columns.

* Match Names—In the Enter text to match box, type the name of a category
to add to the attribute display.

* Filter by object type and attribute names—Select an ECAD Object Type

from the list, or use the arrows to move attribute names between the
Available Attributes and Selected Attributes lists.

SARENANEE S

Click Make Default to save the settings.

choose Reset Filters.

Display of ECAD Attributes

Click Reset to default to return to the original default settings.
Click OK. The Attributes list is filtered.
To revert to the original default settings, right-click in the Attributes pane and

In a schematic view, select an object and the following attribute columns are

displayed:
Object Attribute Column Displayed by Default
Symbol Reference Designator Yes
Function/Device Type Yes
Sheet Yes
Part Number
Part Name
Pin Number Yes
Net Yes
Function Yes
Sheet Yes
Wire Net Name Yes
Sheet Yes
Miscellaneous Object Name (or unique ID) Yes
Other Attributes
In a PCB layout view, select an object and the following attribute columns are
displayed:
Object Attribute Column Displayed by Default
Component Reference Designator Yes
Package Name Yes
Device Type Yes

110
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Object

Attribute Column

Displayed by Default

Part Number
Part Name
Location Yes
Layer Yes
Rotation Yes
Height
Object ID

Net Net Name Yes
Manbhattan Length
Routing Status Yes
Pin Name Yes

Route Segment Net Name Yes
Layer Yes
Width Yes
Length Yes

Test Point Name Yes
Net Name Yes
Layer Yes
Location Yes
Padstack Name Yes
Parent type
Parent name
Object ID

Region Board Outline
Type
Usage Yes
Object ID

Via Pad Net Name Yes
Size Yes
Location Yes
Padstack Name Yes
Padstack Layer Range Yes
Padstack Drill Size
Via Object ID

Pin Pad Pin Name Yes
Pin #1
Net Name Yes
Pad Size Yes
Location Yes

Viewing the Attributes
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Object Attribute Column Displayed by Default
Padstack Name Yes
Padstack Layer Range Yes
Padstack Drill Size
Pin-Pin Logical Net Name Yes
connection
Manhattan Length Yes
Route Length
Routing Status
Pin Names Yes
Mechanical hole Drill Diameter Yes
Style
Location Yes
Plating Status Yes
Layer Range
Net Name
Object ID
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About Modifying the Structure Tree

You can modify the Structure Tree to facilitate finding a specific part or
subassembly. Use these methods to change display of parts in the Structure Tree:

* Navigating parts
+ Filtering

* Positioning

These methods only affect the Structure Tree display. They do not affect the view

of the model.

To Navigate the Structure Tree

Use the commands on the Structure pane to select nodes in the Structure Tree:

Action Result

Selects parent of the current node.
Click Select Parent » Select P
Parent.

Click E Select Parent » Select

Common Parent.

Selects common parent of the selected
nodes.

Click 2] select Instances » = Select

All Instances.

Selects all instances of the current node.

Click '=#] select Instances » Select
Peer Instances.

Selects all instances of the current node
at the same hierarchical level.

Click Select Children.

Selects all descendants of the selected
nodes.

About Node Names

The automated names of nodes in the Structure product design can be meaningless
and confusing. You can use the Configure Alternate Part Names dialog box to
configure more meaningful names based on the attributes of that part. For example,
you can perform the following modification:

114
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Default Structure Tree Display Modified Structure Tree Display

) B STOUUM- U a8m, URULYF, LD f 'HMB@EM Sirschse
¥ @ 33903284-001 pit, K0D7, 1.2 1 @ Innes Mounting Bracket
] @ 33903284001 pit, KOD7, 1.2 &1 @ Inner Mounting Bracket
] @ 73903284-001 pit, OKOD7. 1.2 1 @ Inner Mowing Brocket
7 @ 33900200-001 pit, 0K0D7.1.2 v, . Innet Contiod Ring
] @ nas552-052 pat, 80205, A.2 7 @ Machine Sciew, Cap

To create alternate names for the parts you can select up to two attributes that can
be preceded and followed by static text. You can save and reuse the settings in
subsequent Creo View sessions.

To Configure Alternate Node Names

1.

Open the Creo View Options dialog box in one of the following ways:

* Click File » Creo View Options.

*  On the Structure tab or the Home tab, in the Structure Tree group, click the
arrow.

On the left, under General, select Navigation. The General-Navigation options

open.

Select Use alternate part names in the tree, and then click Configure. The
Configure Alternate Part Names dialog box opens.

In the first, third and fifth boxes enter text to be displayed. In the second and
the fourth boxes, select attributes from the lists. These attributes are replaced
by their value for the part being named. For instance, if you select material, the
display shows steel or aluminum.

Note

e The contents of the lists depends on the attributes in the PVS file.

e The filter for the Structure Tree only works on the original names, not the
alternate part names.

e Ifa part has neither of the attributes selected, the original part name
remains.

Click OK. The Configure Alternate Part Names and the Creo View Options
dialog boxes close, and the Structure Tree displays the new node names.

To revert to the original node names, open the Creo View Options dialog box,
clear the Use alternate part names in the tree check box, and then click OK.
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About the Structure Tree Filter

When you apply the Structure Tree filter, only nodes defined in the Filter
Viewables dialog box are displayed. You can expand and collapse the nodes to see

all or only the filtered nodes for a part or subassembly. The number of nodes
viewed versus the total number of nodes is displayed. You can save the current
filter settings for use across multiple sessions.

To Filter the Structure Tree Display

1.

8.
9.

At the bottom of the Structure Tree click Filter or Filtering. The Filter Viewables
dialog box opens.

Select Part names matching and type a string to display matching nodes and
their ancestors.

Select Only selected parts to include only the parts selected and their ancestors.
Note

You can designate a maximum number of parts to display. If more than the
designated number of parts are selected, then only the root node is shown.

Select Results from a search query to include the contents of search results
even if they would be hidden by the filter.

Select Add siblings of filtered parts to include the siblings of the filtered parts.

Select Dynamically re-apply filter if changes occur to update the Structure Tree
automatically according to the filters and commands. Otherwise it updates only
when you click the refresh icon.

Select Expand tree to show filtered parts to show all the filtered in nodes and
their ancestors. This is the default state.

Click (click to expand) to display the filtered out nodes from that location.

Select Make Default to save the current filter settings across multiple sessions.

10. Click OK. The filters are applied.
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About Creating and Editing Structures

You can insert viewables from other files into the Structure Tree and change the
position of nodes and their children in the Structure Tree. You can also rename or
delete nodes and save substructures as independent files. Although you can use
Structure Edit only in Creo View, you can view the modified structures in Creo
View Lite.

Some structure editing operations can break the internal references used with
annotation sets of open views, causing the loss of unsaved work. These operations

are grouped in the Advanced Editing subcategory. Before performing these
operations, you are prompted to save your changes.

After you insert new parts or assemblies into a structure, you can change the
location and the orientation or both of the new objects using the Assemble tool.

Saving Substructures

You can select a subassembly and save it as an independent structure. You can
include settings and viewables that are linked to the source structure in the new
substructure file. These settings and viewables can be added to the new file:

* Attributes—Saves attributes linked to the relevant structure nodes. Selected by
default.

*  Structure to root—Saves the full structure path from the selected or visible
entities to the root of the structure tree. If deselected, the selected or visible
nodes are saved as individual root nodes. Selected by default.

* Children of selected—Includes children of selected nodes in the new file.
Selected by default.

* Specified file types—Displays a list of file types that are available to include in
the substructure file.

To Save a Substructure

1. In the Structure Tree, select the parts to save, and then click File » Save As »
Save Selected As PVS or File » Save As » Save Selected As PVZ. The Save
Selected As PVS: Settings or the Save Selected As PVZ: Settings dialog box

opens.

2. Select any of these settings to include in the new file:
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* Attributes—Saves attributes linked to the relevant structure nodes. Selected
by default.

*  Structure to root—Saves the full structure path from the selected or visible
entities to the root of the Structure Tree. If cleared, the selected or visible
nodes are saved as individual root nodes. Selected by default.

*  Children of selected—Includes children of selected nodes in the new file.
Selected by default

* Specified file types—Displays a list of available file types to include in the
substructure file. If you select Specified file types, then select file types in
the Included column.

3. Click Save. The Save Selected As PVS: Settings or the Save Selected As PVZ:
Settings dialog box closes and the Save Copy As PVS File or Save Copy As
PVZ File dialog box opens.

Select a location for the file.
5. In the File name box, accept the default file name, or type a new one.
6. Click Save.

Adding Viewables to Structures

About Adding Viewables to Structures

You can add a part or a subassembly to the structure at selected locations, or you
can insert it into the structure root and then merge and reposition it afterwards.

You can also attach associated viewables, such as a PDF or a 2D illustration file to
the structure.

To Add a Viewable to the Root of the Structure

1. Click Structure » L1 Add Viewable To Root. The Open File dialog box opens.

2. Browse to a file and click Open. The viewable is added at the bottom of the
structure.

To Insert a Structure

1. Click Tools » Edit Structure or Structure » Edit Structure.

2. Select the target node, and then click Insert Branch Link or E Insert
Branch. The Open File dialog box opens.
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3.

4.

Browse to and select a PVS, PVZ, ED, EDZ, or ZIP file. The selected file
becomes the last child of the target node.

Click Close Edit.

To Add a Viewable to a Structure

I.
2.

Click Tools » Edit Structure or Structure » Edit Structure.
Select a node and then click E Create Child Node. The Create Part dialog box
opens.

Type a name for the new node, and click OK. An empty node is added.

Select the empty node, and click Add Viewable. The Open File dialog box
opens.

Browse to and select a file, and then click Open. The viewable is added to the
model.

Click Close Edit.

To Create a New Structure

1. Click File » |:| New. The Create new PVS File dialog box opens.

Type the name for the new file and click OK. A message appears asking if you
want to save the structure.

Click Save As *.pvs or Save As *.pvz. The Save As PVS File or the Save As
PVZ File dialog box opens.

Type a name for the new file and click Save. The new file and the Structure
Edit tool open.

Add a structure to the file.

About Advanced Structure Editing

The structure editing actions that can break internal references are grouped in
Advanced Editing mode. You are prompted to save or discard your changes before

performing any of these actions:
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Deleting nodes
Merging branch links—To move nodes into the root structure.
Dragging and cutting and pasting nodes

Renaming nodes
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When you edit using the Advanced Edit tool, keep the following guidelines in
mind:

You can drag any node. All children are dragged along.
All dragged parts move together to the target location.
You cannot drag any substructure onto its own children.

You can drag to and from a branch link. This updates the branch and the
current structure.

The physical location of parts does not change.
The way parts are instanced might change.

You cannot delete the top-level node.

Guidelines for Using Advanced Structure Editing

When you cut and paste using the Advanced Editing mode, keep the following
guidelines in mind:

You cannot use cut and paste in multiple locations simultaneously.

Cut marks the selected nodes and does not remove them. The removal and
placement change occurs with the Paste command.

The Cut selection is discarded in the following circumstances:
©  When you insert a structure.

O When the node is deleted.

©  When you close the Structure Edit tool.

To Delete a Structure

1.
2.

Click Structure > Edit Structure. The Structure Edit tab opens.

Click Advanced Editing. A message to warn you that you can lose unsaved

changes appears. Select Save or Discard to proceed.

Select a node from the Structure Tree or from the graphics area and click
Delete. A message to confirm the deletion appears.

Click Yes. The node and its children are deleted.

5. Click Close Edit.
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To Rename a Part

1.

. Q
Click Structure » Edit Structure. The Structure Edit tab opens.

Select one or more parts to rename, and then click Advanced Editing. A

2.
message to warn you that you can lose unsaved changes appears. Select Save
or Discard to proceed.

3. Click Rename. The Rename Part(s) dialog box opens.

4. Type a new name for the parts and click OK. The parts are renamed.

Note

You can only set one new name at a time. If you select two or more parts, they will
be renamed with the same new name.

To Cut and Paste Nodes

You can select more than one part to move at once, but you can only set one
position for all of the selected parts.

1.
2.

Click Structure » Edit Structure. The Structure Edit tab opens.

Select one or more parts to relocate, and then click Advanced Editing. A
message to warn you that you can lose unsaved changes appears. Select Save
or Discard to proceed.

Do one of the following operations:
* Click Cut.
* In the Structure Tree, right-click and choose Cut from the shortcut menu.

Select the location on the Structure Tree to insert the parts, and click Paste.
The selected parts are relocated in the structure.

To Merge a Branch Link

1.
2.
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Click Structure » Edit Structure. The Structure Edit tab opens.

Select one or more parts to merge, and then click Advanced Editing. A
message to warn you that you can lose unsaved changes appears. Select Save
or Discard to proceed.

Click Merge Branch Link. The branch links are merged.
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The Assemble Tool

About Assembling Entities

Use the Assemble tool to accurately change the location or the orientation or both
of one or more parts, groups, or assemblies in a model. Select the entities to move,
and then define an origin and a destination coordinate system. The Origin
coordinate system is the reference point for the selected entities. The Destination
coordinate system is the reference point for the entities’ new locations. The
selected entities move as one rigid body. Use the linear and rotational offsets to
fine-tune the position of the moved entities.

The reference collector in the Selection group shows the number of selected

entities by type. You can view a list of the selected entities in the Assemble:
Selection List dialog box, and you can remove entities from the list.

You can use the Structure Edit tool to insert new parts, groups, or assemblies into a
structure, and then you can use the Assemble tool to position them.

To Assemble Coordinate Systems
Click Tools » EI Assemble. The Assemble tab opens.
2. Select an Assemble mode:
. IZ‘I Mate—Moves and rotates the selected object
. Orient—Rotates the selected object

. II-I Locate—Translates the selected object
3. In the graphics area or the Structure parts, groups, subassemblies, or assemblies
to move, and then click Add Selected.

4. Define the Origin CSYS coordinate system. The Origin coordinate system
appears.

5. Define the Destination CSYS coordinate system. The Destination
coordinate system appears.

6. To preview the move, click Preview. Click Preview again to undo

the preview.

7. To adjust the destination position of the origin coordinate system, type or select
linear and rotational offsets in the Offset group.
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8. To approve the operation and create another one, click Apply, or to
approve the operation and exit the Assemble tool, click OK.

9. Click Home » Capture Location and choose an option to save the new

location, or Home » Restore Location and choose an option to return the
parts to their original locations.

To View and Modify the List of Parts to Assemble

1. Click the arrow in Selection group. The Assemble: Selection List dialog box
opens with a list of selected items.

2. Select an entity from the list and click Remove. The entity is deleted.
3. Click Close.

Defining the Coordinate Systems for Assemble
The Origin CSYS and the Destination CSYS options follow:

* Parts—Calculates the Origin CSYS from the objects that will move in the
operation.

* Global—Calculates the Origin CSYS from global coordinates. (The selected
input model coordinate system is the default.)

* Select from Graphics Area—Opens the Select Origin CSYS collector. Select a
part or a suitable edge, face, or construction geometry to define the coordinate
system.

» Define—Opens the Construct Coordinate System dialog box. Create the
coordinate system.

The most recently used coordinate systems are added to the Origin CSYS list for
later use. You can select one from the list.
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Editing Appearance

About Modifying Appearance

You can modify the appearance of one or in the model view by adjusting the
following attributes:

e Render
* Color

* Transparency

You can select parts to modify from the model view. You can use these appearance
modification tools to show hidden parts, emphasize contrasts between parts, or set
a systematic color code. Use the visibility options to show, hide, or isolate specific
parts or layers of a structure. You can modify appearance in Creo View in
standalone mode. Saved appearances are read-only in Creo View Lite or Creo
View Express.

About Render Mode
Render mode determines the appearance of the display:

Options Function |Result

Key

Shaded F9 Displays the part as a shaded solid.

Shaded with |F10 Displays the part as a shaded solid with the lines of
Edges forward surfaces emphasized.

Hidden Line |F11 Displays only the frame lines of the forward surfaces.
Removal

Wireframe F12 Displays front and back frame lines equally.

Mesh Displays a mesh frame.

If you select Hidden Line Removal, Wireframe, or Mesh, all parts of the viewed
representation are affected. If you select Shaded or Shaded with Edges, you can
choose to set different colors and degrees of transparency to different parts of the
structure.

If you select Shaded or Shaded with Edges, you can select one of the following
modes:

* Global Render Mode—Displays all parts of the viewed representation as
shaded.

* Mixed Render Mode—Displays the parts of the viewed representation as
classified by their appearance attributes. This is the default working mode.
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Note
Global Render Mode or Mixed Render Mode options do not modify the parts'
attributes, only their display on the screen.

To Set Render Mode
1. Open a Creo View structure.
2. Open the Render Mode list in one of the following ways:
*  On the Home tab, in the Display group, click Render Mode, then choose an
options from the list.
* Press a function key.
* Right-click and choose Render Mode, then point to an option from the list.
3. Ifyou selected Shaded or Shaded with Edges, open the Render Mode list again

and click Global Render Mode or Mixed Render Mode.

To Change the Render Mode

1.

On the Home tab, in the Display group, click Render Mode. The Render Mode
menu opens.

Set the extent of the render mode:

* Global Render Mode—Applies the render mode to all components of the
model.

* Mixed Render Mode—Applies the render mode to selected components.
Select a render mode:

¢ Shaded

* Hidden Line Removal

*  Wireframe

* Mesh

To Display Parts in Transparent Mode

1.

2.
3.
4

Open a structure.
Select the parts of the structure to make transparent.
Set Render Mode to Shaded or Shaded with Edges.

Open the Appearance tab on the Part(s) Properties dialog box in one of the
following ways:
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» Right-click and choose Edit Properties.
e Click Structure » Edit Properties. The Part(s) Properties dialog box
opens. Click the Appearance tab.

*  Click Tools » Edit Structure. The Structure Edit tool opens. Click Edit
Properties. The Part(s) Properties dialog box opens. Click the Appearance

tab.

*  On the Home tab click the arrow in the Location group. The Part(s)
Properties dialog box opens. Click the Appearance tab.

5. Select one of the Display Style options:
¢ Shaded

* Transparent

6. Set the Transparency level by moving the slider, by typing in the percentage
value, or by adjusting the value in the box. When the Transparency value is
100%, the selected part is completely transparent, whereas at 0% it is fully
shaded.

Note

e Ifthe selected part is set to Shaded mode and transparency is set, the
Display Style indicator switches to Transparent.

e After the transparency level is set for the part, it remains the default value.

7. You can select one of the Restore Display Style options:

* Restore to Original—Returns the display style to the original structure
value.

* Restore to Saved—Returns the display style to the last saved style in the
current annotation set.

To Set Transparency
1. Select a part of the structure.
2. On the Model Parts tab in the Appearance group, there are two display styles:
* Shaded
* Transparent
3. Click the mode you require. The selected part is displayed accordingly.
Note
This option is enabled only if Render Mode is set to Shaded or Shaded with Edges.
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Rules for Setting Render Mode
If you select Shaded or Shaded with Edges, choose one of the following options:

* Global Render Mode—Displays all parts of the viewed structure with the same
color and transparency attributes.

* Mixed Render Mode (default}—Displays parts of the viewed structure with
different colors and degrees of transparency.

If Global Render Mode is selected and transparency is set, the mode automatically
switches to Mixed Render Mode.

When the Global Render Mode and Mixed Render Mode are both available, the last
checked option becomes active.

To Set Visibility Options

Use the visibility options to show, hide, or isolate specific parts or layers of a
structure.

* Isolate—Shows only the selected parts.

* Unhide All and Show—Shows all hidden parts in the view.

* Hide—Hides the parts that are selected in the view.

The visibility options appear in the following locations on the Ribbon:
*  On the Home tab in the Display group.

*  On the Structure tab in the Parts group.

*  On the Structure Edit tab in the Parts group.

To Edit Color

1. In an open a structure, select one or more parts to edit.

2. Right-click and choose Color or click Model Parts » Color. The Choose Color
dialog box opens.

3. Select the color and click OK. The color of the selected part updates.
Note

To select a basic color when the Choose Custom Color dialog box opens, click
More, and then select from the Choose Color dialog box.

4. To reset colors, open the Appearance tab on the Part(s) Properties dialog box
and select Restore Color and then choose a restore option:
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* Restore to Original—Returns the color to the original structure value.

* Restore to Saved—Returns the color to the last saved style in the current
annotation set.

Methods to Open the Choose Color Dialog Box

Open the Choose Color dialog box in one of the following ways:

Right-click and choose Color. The Choose Color dialog box opens.

On the Model Parts tab in the Appearance group, click Color. The Choose
Color dialog box opens.

On the Structure tab, click Edit Properties. The Part(s) Properties dialog box
opens on the Appearance tab. Click the color indicator. The Choose Color
dialog box opens.

Click Tools » Edit Structure. The Structure Edit tool opens. Click Edit
Properties. The Part(s) Properties dialog box opens on the Appearance tab.
Click the color indicator. The Choose Color dialog box opens.

Right-click and choose Edit Properties. The Part(s) Properties dialog box
opens on the Location tab.

1. Click the Appearance tab. Display Style and Color options open on the right

of the dialog box.
2. Click the color indicator. The Choose Color dialog box opens.

On the Home tab from the Location group:

1. Click the arrow in the Location group. The Part Properties dialog box
opens on the Location tab.

2. Select the Appearance tab. Display Style and Color options open on the
right.

3. Click the color indicator. The Choose Color dialog box opens.

Click Color on the Model Parts tab in the Appearance group.

Moving Parts

About Relocating and Reorienting Parts

You can use Translation mode to drag selected parts in the graphics area, to
communicate design intent, and reveal hidden geometry. Use Rotation mode to
spin the selected parts around their center.

You can rotate or translate a part in any of these ways:
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* Use the commands on the Ribbon to drag and spin selected parts.

* Type specific dimensions on the Location tab of the Part(s) Properties dialog
box.

* Relocate and reorient objects with the Mate tool.

The Smart Explode option moves parts along a specific axis and coordinate system
to quickly create exploded views for illustrations or for viewing internal elements.
You can use Preset Explode only if you have previously saved top-level explode

states.

You can save location changes both in standalone mode and in Windchill.

To Translate and Rotate Parts Using the Location
Dialog Box

1. Choose one or more parts in the Structure Tree.

2. Open the Location dialog box in any of these ways:

Right-click and choose Edit Properties.

Click Structure » Edit Properties.
Click Tools » Edit Structure » Edit Properties.

Click the arrow on the Model Parts tab in the Appearance group or on the
Home tab in the Location group.

3. Select one of the Relative to options:

Parent—Places the selected parts according to internal coordinate systems.
Default when the selected parts are from the same parent.

Global—Places the selected parts according to the coordinate system of the
whole model.

Pick from geometry—Create a reference coordinate systems on an object in
the view.

Note

If you only change the referenced coordinate system, the coordinate system
values change, not the part's location.

In case of multiple parts with offsetting, changing Relative to zeros the
offset and keeps the previous state.

Set the values in the Translation boxes to change the part location.

Set the values in the Rotation boxes to revolve the part.

To control the scale of the selected parts, set the Scale Factor.
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To invert parts and create mirrored structures, click Invert Part(s).

To return selected parts to the original or to a previously saved location, select
a Restore Location option:

* Restore to Original
* Restore to Saved

9. Click Home » Capture Location to save the location change.
10. Click Close to exit the dialog box.

To Move Parts

1. Activate the Translation mode in any of the following ways:

¢ Press F2.

* Right-click and choose Home » Translation Mode from the shortcut menu.

¢ Click Home » Translation Mode or Model Parts » Translation
Mode.

2. Translate parts in the following ways:

* Drag the green, red, or blue arrows to move selected parts along the x-, y-,
or z-axis, relative to your viewing orientation.

* Drag the white box to move parts in the plane of the graphics window.
3. Activate Rotation Mode in any of the following ways:
* Press F4.

* Right-click and choose Location » Rotation Mode from the shortcut menu.

* Click Home » Rotation Mode or Model Parts » Rotation Mode.
4. Rotate parts in the following ways:

* Drag the colored rings in the virtual track ball to rotate selected parts.

* Drag the second outer sphere to rotate the part in the viewing plane.

* Right-click and drag the part in the graphics area to rotate the whole
structure.

5. Click Home » Capture Location and choose an option to save the new location,

or Home » Restore Locationand choose an option to return the parts to their
original locations.
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Exploded Views

About Exploded Views

This feature is available for Creo View only.

Smart Explode lets you explode parts, subassemblies, or groups to move them

along a specified axis and coordinate system, from an anchor that you select in the

3D view. Smart explode moves each item in the Explode list in the specified
direction until its bounding box is clear of any parts not in the Explode list. You

can explode parts individually or coupled together. You can view elements that are

obscured, or create an assembly or disassembly sequence for training purposes
with Smart Explode.

Preset Explode works explode states saved in Creo Parametric, and allows you to
select from those explode statues. If no explode states are available, this option is

dimmed.

To Perform a Smart Explode

Click Tools » Smart Explode. The Smart Explode tab opens.

2. Click Add Selected and select one or more parts. The selected parts are
highlighted on the representation and appear in the Explode list.

3. Choose an explode type from the Add Selected list.

* Smart Add—Automatically adds the selected parts as single or coupled.
* Add Single Parts—Add parts to explode individually.
* Add Coupled—Add parts to move together.
4. Set the following options under Direction:
* CSYS—Sets the coordinate system.
* Axis—Sets the axis along which to move parts.

* Bidirectional—Move the parts in opposite directions along the selected
axis.

5. In the Options group, set from the following parameters as required:
+ Set the explosion Anchor option:
O Model Center (default)
O  Global

©  Non-Exploding Parts—Sets a center that is calculated based on non-
exploding parts.
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O Select from Graphics Area—Sets a user-defined reference point on the
structure.

* Explode clear of all parts—Moves all exploding parts until their bounding
boxes do not overlap.

* Preview—Select to preview the explode.

6. To preview the explode, click Preview. Click Preview again to
undo the preview.

7. To approve the operation and create another one, click Apply, or to approve the
operation and exit the Smart Explode tool, click OK.

8. Click Home » Capture Location and choose an option to save the new

location, or Home » Restore Location and choose an option to return the
parts to their original locations.

Sectioning

About Sectioning

You can section a structure to display internal alters the display of the structure, but
it does not affect the geometry of the structure. Place one or two sectioning planes
to cut the structure. You can make the following kinds of sections:

* Planar—A cut made by one plane
* Quarter Cut—A cut made by two perpendicular planes

When you modify the section, the views are You can save the section view as part
of an annotation set.

To Section in the 3D View

1. On the Sectioning tab, in the Setup group, click View Section. A sectioning
plane is previewed on the structure in the graphics area.

2. Click one of the following buttons to define the section type:

* Planar
¢ Quarter Cut

3. Move the sectioning plane or planes into position.
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4. Set any of the following options:

* Show 2D View—Opens the sectioned structure in a new drawing view.

* Cap Section—Gives the parts the appearance of a solid interior.

* Show Boundaries—Displays the sectioning plane or planes.

5. To exclude one or more parts from the cut, do the following operations:

a. In the Intersection group, clear the Intersect with all check box.

In the graphics area, select one or more parts that you want to section and

click Add Selected.

c. Continue selecting parts and clicking Add Selected until you have selected
all the parts that you want to section.

Manipulating Sectioning Planes

Manipulate sectioning planes in the following ways:

Action

|Result

In the 3D View

Select and drag the plane.

Moves the plane in the direction that is
normal to the plane.

Press and hold CTRL + select and drag
the plane.

Rotates the plane around its center
point.

On the Sectioning tab, in the Setup

group, click Initial Section and select X-
Axis, Y-Axis, or Z-Axis.

Places the plane along the selected axis.

In the 2D View

Click or B Moves the plane in the direction that is
- normal to the plane.

Drag the slider.

Press the UP or DOWN arrow keys.

In the Section Properties dialog box

Under Section Plane Orientation, click
Set by Reference and select a reference

in the graphics area.

Positions the plane at a reference.

Under Section Plane Orientation, select
an axis of rotation and type an angle.

Rotates the plane.

Under Section Plane Orientation, click
Flip.

Flips the section view.

Under Intersecting Point Location, click
Set by Reference and select a reference

in the graphics area.

Positions the plane at a reference point.
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Action Result
Under Intersecting Point Location, Translates the plane.
select a translation direction and type a

distance, or click or IEI

To Section in the 2D View

1. On the Sectioning tab, in the Setup group, click Show 2D View. A 2D view of
the structure opens.

Click the graphics area of the 2D view. The view becomes active.

Move the sectioning plane into position.

Sections for 2D Views

When you are in Sectioning mode and you click Show 2D View, the 2D section
window is displayed in a new view in the graphics area. Click this button again to
remove the 2D section from the view.

You can perform the following operations in the 2D section view:

e Zoom

* Pan

*  Measure

*  Mark up

* Drag

When you modify the section in the 2D view, it is simultaneously updated in the

3D view. Use the slider to move the section plane. You can also move a section
plane using the up and down keyboard arrows.

To Set Sectioning Options

1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. In the Showing box, select Defaults. The Defaults options open on the left.

3. On the left, under Model, select Sectioning. The Model-Sectioning options open
on the right.

4. To set the level of precision for sectioning, select or clear the Use high level
section detailing check box.

5. To set the default sectioning behavior, under Behavior, select or clear any of the
following check boxes:
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¢ Hide construction geometry while sectioning
* Hide all parts while sectioning

* Cap Sections

O Use single color for section cap—Select a color.

6. To outline the cut edges in a single color, select the Use single color for section
lines check box and select a color.

7. Click Apply to apply the changes and keep the dialog box open, or click OK to
apply the changes and close the dialog box.
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Annotation Sets and Folders

About Annotation Sets

An annotation set is a group of saved markups When you save an annotation set,
the file is saved with the structure or design file. You must save an external file in a
Creo View format before you can add and save an annotation set. You can create
annotation sets in Creo View when working both with MCAD structures and
ECAD objects. When working in Creo View Lite with MCAD structures you can
create annotation sets, but when working with ECAD objects you can only view

annotation sets. Annotation sets are on the Annotation Sets pane of the upper
data panel. The pane has two display modes:

» List View—Displays thumbnail previews of the annotation sets.

» Tree View—Lists the names of the annotation sets and annotation folders. You
must be in Tree View to create, view, edit, and delete annotation folders.

These markups are saved to an annotation set:
* Annotations
* Measurements

* Construction geometry (MCAD only)

Animate the transition between animation sets by setting a Loading option. You
can merge MCAD annotation sets and views by applying an annotation set to a
base view or annotation set. In Creo View ECAD, additional properties are saved
to the annotation set:

* Color and Visibility settings
* Navigation settings

» Highlights

» Isolation

* Overlays

* Images

If you designate an ECAD annotation set it opens when you load the design.
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About Annotation Folders

Annotation folders are shown in the tree view of the Annotation Sets navigator.
When you select a folder, thumbnail previews of the annotation sets in the folder
are displayed in the lower half of the Annotation Sets Tree. You must be in Tree
View to work with annotation folders. You can perform the following operations
on Annotation Folders:

* Create new folders and name them according to their context.

» Edit folder name and content.

* Organize and reorder folders by dragging and dropping them in the tree view.
* Nest folders.

* Load the annotation set in the viewer.

You cannot keep an empty folder in the Annotation Sets Tree. When you remove
all the annotation sets from a folder, the folder is automatically deleted.

To Open an Annotation Set

Click Annotation Sets, and then select an action:

* Double-click the annotation set.
» Drag the annotation set into the graphics area.

» Right-click the annotation set and choose Open in New View from the shortcut
menu.

* Right-click the annotation set and choose Replace View from the shortcut
menu, and then select a view name to replace with the annotation set view.

To Animate the Transition Between Annotation Sets

1. Click File » Creo View Options. The Creo View Options dialog box opens.
In the Showing box, select Global. On the right, the global options open.
On the left, under General, select Loading. The General-Loading options open.

Select the Perform animated transitions between files check box.

A

In the Transition duration box, type or select a transition time in seconds.
Transitions between annotation sets are animated.

Viewing InterComm Bookmarks in Creo View

Bookmark (* . imx) files created in InterComm Expert are read-only annotation
sets in Creo View ECAD. They include this data:
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» URL association with an ECAD design

e Name
e Text
» Redlines

* Highlighting

» Isolation

* Visibility

* Pan and zoom status
« Fill

* Color

*  Crosshairs

About Applying an Annotation Set

You can merge annotation sets and views by applying an annotation set to a base
view or annotation set. The base view must be open and loaded in the graphics
area to apply an annotation set. When you apply an annotation set, the base view
remains the active view. All the content from the base view remains, including
content from previously-applied annotation sets, though some content may be
hidden. The view retains the title of the base view. Each annotation set can contain
only one of each of these data sets:

* Animation
* Design Check tags
Note

The base animation or Design Check tags are overwritten if you apply another
annotation set with the same type of data set.

To Apply an Annotation Set to Another View

1. Open the base view or annotation set and load it in the graphics area.

2. Click E Annotation Sets.

3. Right-click the annotation set to apply and choose Apply to View, and then
select the base view.
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To Save an Annotation Set

I.

Click File » Save Annotation Set or File » Save Annotation Set As. The New
Annotation Set dialog box opens.

2. Type information in one or more of the following boxes:
* Name
¢ Author
¢ Telephone
* E-Mail
* Comments
3. Click OK.
Note

Annotation sets are also saved when you click File » Save All.

To Create an Annotation Folder

1.
2.

Make sure you have created and saved at least one annotation set.

In the Annotation Sets pane, right-click and choose Switch to Tree View from
the shortcut menu. The annotation sets are listed in a tree.

Select the first annotation set to be included in the folder, right-click, and
choose Create a Folder from the shortcut menu. A new folder is created with a
default name.

To rename the folder, right-click and choose Rename, and then type a new
name and press ENTER.

To Filter the MCAD Annotation Set List

In an open representation, select the Annotation Sets pane.

On the Annotation Sets pane, right-click and choose Filter Annotations. The
Filter Model List dialog box opens.

Select the Names matching check box.

In the Enter text to match box, type the name of the annotation set that you
want to find.

To set the filter as a Creo View option, click Make Default.

Click OK. The matching annotation sets are displayed on the Annotation Sets
pane.

To remove the filter, right-click the Annotation Sets pane and choose Reset
Filters.
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To Filter the ECAD Annotation Set List

1. Inan open design, select the Annotation Sets pane.

2. On the Annotation Sets pane, right-click and choose Filter Files. The Filter
Ecad List dialog box opens.

3. Select any or all of the following check boxes. Type the names of the
annotation sets that you want to find in the corresponding Enter text to match
box:

* Names matching
* File names matching
* Part names matching
4. Select or clear the Only landmarks attached to selected parts check box.
To set the filter as a Creo View option, click Make Default.

Click OK. The matching annotation sets are displayed on the Annotation Sets
pane.

7. To remove the filter, right-click the Annotation Sets pane and choose Reset
Filters.

Annotations

About Annotations

You can view and create annotations for every type of MCAD and ECAD
viewable. Use the annotations to document the design, for product definition
purposes, or as part of collaborative reviews. You can perform the following
operations on annotations that you add during a view session:

o Edit
e Move
e Delete

e Hide or unhide
e Save
Note

A saved annotation set is stored to an * . etb file that is linked to the structure
file. You can also save an annotation set and upload it to the server.

Annotations appear in the graphics area, and a list of the annotations appears on

@ .
the View Content pane of the upper data panel. In Creo View ECAD, when you
select the annotation in either location, it is selected in both places.
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To Create an Annotation

1. On the Markup tab, in the Annotations group, click an annotation type and
select a subtype. The pointer becomes an annotation pointer.

2. Place the annotation using the corresponding placement method. When you
create an annotation that includes a note, the Note dialog box opens.

3. Type the note and select the Font Size, Font Color, and Background Color, and
then click OK.

General Annotation Types for MCAD and ECAD

Create these types of annotation for the following views:

Viewable Annotation Description
Model Note Adds explanation or
Drawing Note with Leader details.

Reference Note Marks a reference datum.
Image Reference Note with
Schematic Leader
PCB Layout Leader Line Points to a spot on the

representation. You can
select a point on the
leader to insert a new
point at that location to
move the leader line from
that point. Any leader line
can be divided into
segments, and a new
leader line can be merged
with an existing note.
Leader line settings such
as head, tail, width, style,
and color are defined in
Edit Properties » Leader
options.

Shape Draws the following
shapes:

* Rectangle

» Shaded rectangle
* Ellipse

» Shaded ellipse
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Viewable Annotation Description

* Polygon

* Shaded polygon
Freehand Draws a freehand shape.
Stamp Adds a stamp to the

representation. You can
define stamp settings

using the Creo View
Options dialog box.

Model Gtol Adds Geometric
Drawi Dimensioning and
rawing .
Tolerancing (GDT)
Image symbols. GDT is an

industry-standard
language used by detailers
to describe how
components are fitted
together. You can drag the
GDT box to move it in
the graphics area.

Annotation Types for the Document View

The following types of annotations are available on the Markup tab for the
document view:

Annotation Description

Note Add explanation or details.
Note with Leader

You can define text size, color, and

background in Creo View Options »
Defaults » Annotations » Text.

Leader Line Points to a spot on the document. You
can select a point on the leader to insert
a new point at that location to move the
leader line from that point. Any leader
line can be divided into segments, and a
new leader line can be merged with an
existing note.
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Annotation

Description

You can define leader line settings such
as head, tail, width, style, and color in
Creo View Options » Defaults »
Annotations > Line Styles.

Shape

Draws the following shapes.

* Rectangle

* Polygon

* Ellipse

* Filled Rectangle
+ Filled Polygon

* Filled Ellipse

Freehand

Creates a frechand annotation.

Text Highlight

Text Strikethrough

Text Underline

Mark up text.

Stamp

Adds a stamp to the document. You can
define stamp settings using Stamp
options.

Annotation Types for the lllustration View

The following annotation types are available on the Markup tab for the illustration

view:

Annotation

Description

Note

Adds explanation or details.

Line

Points to a spot on the representation.
You can select a point on the leader to
insert a new point at that location to
move the leader line from that point.
Any leader line can be divided into
segments, and a new leader line can be
merged with an existing note. Leader
line settings such as head, tail, width,

style, and color, are defined in Edit
Properties > Leader options.

Shape

Draws the following shapes:
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Annotation Description

* Rectangle
» Ellipse
Freehand Draws a freehand shape.

Placing Annotations

Different annotation types use different placement methods, as follows:

Type Placement in the Graphics Area
Note Select a placement point.

Reference Note

Note with Leader Select an endpoint for the leader and
Reference Note with Leader drag it to the point where you want to

place the note.

Leader Line Select a start point for the leader line,
and then select the end point. Double-
click to finish creating the line.

When you create a leader line with jogs,
click once to place each jog.
Note

For leader lines with arrowheads, the
arrow is placed at the line's end point.

Shape Quadrilaterals and ellipses—Click and
drag the shape to the desired size.

Freehand polygons—Click once to
create each corner of the polygon and
double-click to finish creating it.
Freehand Click and drag to draw the shape.
Gtol Select a placement point and set the
parameters in the Gtol dialog box.

To Hide or Show an Annotation

. i . .

In the graphics area or the View Content pane of the upper data panel, right-
click the annotation and choose Hide or Unhide from the shortcut menu. The
annotation is hidden or shown.
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To Edit an Annotation

1. Right-click the annotation and choose Edit Properties from the shortcut menu.
2. Make your changes and click OK.

3. To rename the annotation, right-click it and choose Rename from the shortcut
menu.

To Add Annotation Stamps

1. Click File » Creo View Options. The Creo View Options dialog box opens.

2. On the left, under Annotations, select Stamps. The Annotations-Stamps options
open on the right.

3. Click Add. The Add Stamp dialog box opens.
4. Select a stamp file and click Open. The stamp is added to the list.

To Delete an Annotation

. ] . .
In the graphics area or the View Content pane of the upper data panel, right-

click the annotation and choose Delete from the shortcut menu. The annotation
is deleted.

To Delete All Annotations

1. Make sure a view with at least one annotation is open.

2. In the graphics area, right-click and choose Delete > Delete All Annotations.

To Set Annotation Options

1. Click File » Creo View Options. The Creo View Options dialog box opens.

2. On the left, select Annotations. The Annotations-Main options open on the
right.

3. Under Annotation Set Save Defaults, type default the signature details in the
following boxes:

* Name
* Telephone
* E-Mail

4. To receive a warning when you load a not support saving annotation sets,

select the Warn if a data set for which an annotation set cannot be saved is
loaded check box.
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To change the default annotation appearance, in the Showing box, select
Defaults.

On the left, under Annotations select an item to change its appearance:

* Line Style—Sets a shape for the head and the tail, and sets the width, style,
and color of the line.

* Text—Sets a font size and a color for the text and the text background.

* Shape—Sets a color for the shape.

Measurements

To Set Measurement Options

1.
2.
3.

Click File » Creo View Options. The Creo View Options dialog box opens.
In the Showing box, select Defaults. The defaults options open.

On the left, under General, select Measurement. The General-Measurement
options open on the right.

To mark approximated measurements, under Measurement Precision, select the
Mark with ~ approximated measurement results check box.

To show or hide units, under Display, select or clear the Show units check box.
Under Decimal Places, set the degree of accuracy for measurements:

* Length

* Angle

* Volume / Mass / Area

To Change the Unit of Measurement

1.

150

To open the General-Units page of the Creo View Options dialog box, perform
one of these actions:

* In the Selection and Display Bar, double-click the unit of measurement.

» Use the Application Menu:

a. Click File » Creo View Options. The Creo View Options dialog box
opens.

b. In the Showing box select Defaults or Active View.
c. In the Showing box select Defaults.

d. Select Units. The General-Units dialog box opens.
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2. Select a unit in one or more of these boxes:

* Default MCAD length units
* Default MCAD mass units
¢ Default MCAD density units
* Default ECAD length units
3. Click OK. The unit is changed for the active view.

Selecting Measurement References

When you select elements to measure, you can use one of the following selection
types:
* Smart—Selects details within a representation.

» Part—Selects a part or an annotation.
Use one of the following methods to select a detail:

* Choose Previous or Next from the shortcut menu.
* Hold down CTRL and select the detail.

* Right-click and choose Select From List from the shortcut menu, and then
select an object from the list on one of the following tabs:

O Parts & Markup
O  Part Geometry

MCAD Measurements

About MCAD Measurements

You can create measurements for 3D models and 2D drawings. Measure one or
more components or the distance or angle between components. Measurement
results are displayed in the graphics area.

The measurements together with the reference to the parts measured are saved
when you save the measurements in an Annotation Set.

Types of Measurements

Create the following kinds of measurements in Creo View:

» Distance

e Diameter/Radius
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*  Angle
* Summary

* Part dimension (Creo View only)

Measurement Units

You can set the default unit of measurement for the structure as part of the
measurement options. The default units appear in the lower right corner of the
graphics area. When the data is converted using an adapter or import filter, you can
set an option to read and save the units of the original file. The default unit is
applied when units conflict or the original units are not supported.

Note

For an assembly structure, the units of all components are the units from the top-
level assembly. For drawings, each drawing can have its own units. As a result,
when switching between the model view and the drawing view of a structure, the
units may change.

The display and the decimal places are defaults settings that can be changed locally
for each view. Measurement precision is a global setting for all views.

Summary and Part Dimensions

Summary measurements and part dimensions are sets of measurement data for one
or more parts in the structure.

Summary Measurements

Measurement Summary includes the following information, depending on the
representation you are measuring:

* 2D drawing—Total length of two or more entities

* 3D model—Total length, area, perimeter, and volume data for one or more
edges, surfaces, or parts. If a part has a material assigned, the summary also
includes the part’s mass, centroid, and envelope.

When you select entities for Summary, the information is displayed in the graphics
area with a leader line from the summary information to each item that is
measured.

Part Dimensions

Part Dimension is a measurement of the bounding box around one or more parts.
You can set a Part Dimension measurement to include one of the following data
sets:
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* Length, width, and height

* Coordinates for each of the corners

To Create an MCAD Distance Measurement
Click Markup » [T Distance. The Measure Distance dialog box opens.

2. In the graphics area, select the start point for the distance measurement.
Note

In a model representation, click once to select the part, and then click again to
select an edge or surface. Click a third time to select a point on the edge or
surface.

3. In the Measure Distance dialog box, click the second reference collector.

4. In the graphics area, select the end point for the measurement. A minimum
distance measurement is created.

To Create a Projected Distance Measurement

1. In the Measure Distance dialog box, click B4. The dialog box expands.

o

2. Click L1 The measurement is projected on the global coordinate system by
default.

3. To change the coordinate system, select the Projection on reference collector,
and then select a new coordinate system.

4. To change the direction of the measurement, select or clear the X, Y, or Z check

boxes. The measurement is created in the directions that are selected.

5. To project the measurement on a face or an edge, select the Projection on
reference collector, and then click on the face or the edge. The measurement is
projected on the face or the edge.

6. Click O to remove the absolute distance, or leave it selected to include both
measurements in the annotation set.

7. Click OK.

To Create an Angle Measurement

Click Markup » Angle. The Measure Angle dialog box opens.
2. In the graphics area, select the start point for the measurement.

Note
Click once to select a part, and then click again to select an edge or surface.
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In the Measure Angle dialog box, select the second reference collector.
In the graphics area, select the end point for the measurement.

To flip the angle, select Use supplementary angle.

Click OK.

AN S

To Measure a Radius or Diameter

1. On the Markup tab, in the Measurements group, click Diameter or Radius. The
Measure Diameter dialog box opens.

In the graphics area, select the circle to measure.
Click Measure Radius to measure the radius instead of the diameter.
Click OK.

To Create an MCAD Summary Measurement

Click Markup » Summary. The Measurement Summary dialog box opens.
2. In the graphics area, select a part to measure.

3. To add another part to the measurement, in the Measurement Summary dialog
box, click Add, and then select the part.

4. Click OK.

To Create a Part Dimension

You can create part dimensions in Creo View only.

Click Markup » Component. The Bounding Box dialog box opens.
2. In the graphics area, select one or more parts to measure.

In the Bounding Box dialog box, under Show, select one of the following
measurement types:

* Extents—Bounding box dimensions in the X, Y, and Z directions

* Corner coordinates—Coordinate positions for each corner of the bounding
box.

4. Click OK.

To Display Original Units
1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. In the Showing box, select Defaults. On the right, the defaults options open.
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3. On the left under General, select Units. The General-Units options open on the
right.
Select the Use same units as in the original file (when present) check box.

5. For a warning when for an unsupported unit, select the Show alert message
when original units are not present check box.

ECAD Measurements

About the ECAD Measurements User Interface

In Creo View Lite you can only measure distance for PCB layout views, and in
Creo View you can measure all these dimensions for PCB Layout views:

. Distance—Distance between two points or two object vertices. You can
also measure between the centers of these objects:

O Pads
o Holes

O Route centerlines

You can limit your selections to a layer or an object.

. Minimum Gap—Dielectric span between the edges of two objects. In some
cases, such as between two large planes or conductive figures or between two
long routes, more than one result can exist. You can scroll through all results in
the Measure Minimum Gap dialog box.

. Conductive Path—Minimum electrical path between the centers of two
objects on the same net. After you select the first object, all objects not on the
same net are unavailable. The resulting measurement path is shown using a
white line in the graphics area.

. Summary—All dimensions of a single object

Measurement results are displayed in the measurement dialog box and in the
graphics area. When you modify the references, the result is automatically updated
in both locations. When you close the measurement dialog box, you can choose to
keep a measurement or discard it. You can save your measurements in an
annotation set.

To Create an ECAD Distance Measurement
1. Click Markup » [ Distance. The Measure Distance dialog box opens.

2. Under Options, select one of these rules:
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* Same Layer—Limits the selection of the second point to the first point’s
layer.

* Free Select—Selects a point without snapping to an object or layer.

* Same Object—Limits the selection of the second point to the same object
on which the first point resides.

Click the From box, and then select a location for the start point of the
measurement. It appears in the first reference collector.

Note

To select a different point on the same object, you can use the mouse wheel to
scroll through the options in the reference collector.

Click the To box, and then select a location for the end point of the
measurement. It appears in the second reference collector, and the
measurement appears under Results.

To adjust the measurement, click a reference collector and then select a new
endpoint. Under Results, the measurement updates automatically.

To accept the measurement, click OK.

To Create a Minimum Gap Measurement

You can select two points in the graphics area, and then click Markup »
Minimum Gap to create the measurement or perform the following steps:

1.

- -
Click Markup » Minimum Gap. The Measure Minimum Gap dialog box
opens.

Click the From reference collector. The collector is activated.
Select a point. It appears in the From reference collector.

In the Measure Minimum Gap dialog box, click the To reference collector, and
then select the second point for the measurement. It appears in the reference
collector. The results appear under Results.

To scroll through multiple results, click Preview Next Instance. The next result
in the list is displayed.

To accept the measurement, click OK.

Calculating the Minimum Gap on Different Layers

You cannot calculate distance between geometries on different layers. To calculate
the minimum gap measurement between objects that spanned on more than one
layer such as Pins, Vias, Nets or Drill holes, calculate the minimum gap between
geometries related to the same layer.
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For example: to measure the minimum gap between two pins, the first spanned on
layers 1-3 and the second on 2-4, measure the distance between geometries on
layer 2 taken from both pins and then measure the distance for geometries on layer
3 and take the minimum. This calculation gives us the minimum gap.

To Create a Conductive Path Measurement

Tip

To aid your selection of the references for this measurement, first isolate the net by
selecting it and click Home » E Isolate » Isolate.

You can select two pin pads or vias on the net in the graphics area and then click

Markup *> Conductive Path to create the measurement, or perform the following
steps:

1. Click Markup » Conductive Path. The Measure Conductive Path dialog box
opens.

2. Select a point on a net. It appears in the From reference collector, and all
objects not located on the same net are dimmed.

3. In the Measure Conductive Path dialog box, click the To reference collector,
and then in the graphics area, select a pin pad or via on the same net. It appears
in the To reference collector.

4. In the Measure Conductive Path dialog box, under Results, select the type of
result to display in the graphics area:

* Rat’s Nest Line—Shortest distance between the centers of two objects on
the same net

» dX, dy—Difference in X and Y positions between the centers of two
objects

* Manhattan—Direct, rectilinear path between the centers of two objects
¢ Path Length

5. To accept the measurement, click OK.

Working with Markups 157



To Create an ECAD Summary Measurement

You can select the object and then click Markup » Summary to create the
measurement, or perform the following steps:

Click Markup » Summary. The Measurement Summary dialog box opens.

2. In the graphics area, select an object. It appears in the Object box and the
results appear under Results.

3. To accept the measurement, click OK.

ECAD Objects Eligible for Measurement

Select points on any of these objects as a measurement reference:
* Board outline
* Component

* Geometry associated with a net

« Pad

« Via

* Figure
* Region
* Hole

» Test point

You cannot use these objects as measurement references:
» Padstacks

+ Rat’s Nest lines

* Reference designators

* Pin numbers

*  Markups
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Defining Materials and Calculating
Properties

About Assigning Materials and Calculating
Properties

When a part’s material is defined, its mass and other material-dependent properties
are calculated automatically. The creator of the part can define the material in the
CAD tool, or you can assign a material to a part in Creo View. Select a default
material to have automatically assigned to parts without a defined material. Create
a list of materials manually, or import an XML (* . xm1) file that contains each
material’s name, density, and unit of measurement. Use the Creo View Options
dialog box to add, edit, or delete materials.

Using the Part(s) Properties dialog box, you can view the following information
and copy it to the clipboard:

* Mass properties
* Inertia tensor

* Center of mass

You can also create a summary measurement to display the properties.

To Calculate the Mass of a Part

1. Select one or more parts, right-click, and choose Edit Properties from the
shortcut menu. The Part(s) Properties dialog box opens.

2. On the left, click Material. The materials information opens on the right.
Note

If the part has a material assigned, its properties are calculated automatically.
The results appear under Component Summary.

3. To view the data for the inertia tensor and the center of mass, click Inertia
Tensor. The Moments of Inertia dialog box opens.

4. To copy data to the clipboard, click in the Part(s) Properties or Moments of
Inertia dialog box.
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To Assign a Material to One or More Parts

I.

Select one or more parts, right-click, and choose Edit Properties from the
shortcut menu. The Part(s) Properties dialog box opens.

Under Component Material, click Set Material. The Set Material dialog box
opens.

In the Density Units box, select a unit.

Select the material from the list and click OK. The properties are calculated and
the results appear under Component Summary.

To Import a List of Materials

A AT o

Click File » Creo View Options. The Creo View Options dialog box opens.

In the Showing box, select Global.

On the left, under Model, select Materials. The Model-Materials options open.
Click Import. The Import Material dialog box opens.

Browse to the folder with the list of materials, and select the file.

Click Load.

Click Yes to overwrite the current list of materials. The list is imported.

To Export a List of Materials

1.

With a list of materials open in the Model-Materials page of the Creo View
Options dialog box, click Export. The Export Material dialog box opens.

Browse to a folder for the report on materials.

3. In the File name box, accept the default name or type a new one.

4. Click Save. The report is exported.

To Add, Edit, or Delete Materials

1.
2.
3.

Click File » Creo View Options. The Creo View Options dialog box opens.
In the Showing box, select Global.

On the left, under Model, select Materials. The Model-Materials options open
on the right.

Click Add or select a material and click Edit. A dialog box opens.

5. In the boxes, type or select values for the properties:
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¢ Material Name
* Density
* Density Units

6. Click OK. The material is added or its properties are updated in the Materials
list.

7. To delete a material, select it and click Delete.
Click OK. The Delete Material dialog box opens.
Click OK. The material is deleted from the list.

To Set the Default Material

1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. In the Showing box, select Global.

3. On the left, under Model, select Materials. The Model-Materials options open
on the right.

4. Under Materials, select a material, and then click Set as Default.

Generating Reports

About a Bill of Materials

In Creo View, you can generate a Bill of Materials (BOM) for an MCAD structure

or an ECAD design. Use the @ Column Chooser in the Bill Of Materials tool
to select the data to include in the report. In the Column Chooser, you can also set

the order of the columns. Select the columns to appear by default in the Creo View
Options dialog box.

When you generate a BOM, a Bill Of Materials pane opens in the lower data
panel. The information you select to include is displayed in this pane in columns.
You can sort each column by clicking the column heading. When you select an
item in the Bill Of Materials pane, it is automatically selected in the graphics area
and vice versa.

About an MCAD Bill of Materials

You can generate an MCAD BOM for all or part of a structure. Use the Column
Chooser to configure and automatically update a BOM before or after it is

generated. You can have one BOM for each view of the structure. Select one of
these types to generate:
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* Parts only

* Assemblies only

* Top-level components only
* All (flat)
* All (hierarchical)

You can export the BOM as a CSV file (* . csv) or as a Web page (* .htm or *.
html). You can also use the shortcut menu to copy one or more of the rows to the
clipboard.

About an ECAD Bill of Materials

You can create an ECAD BOM for the components of a Schematic or PCB Layout

design. Create one BOM for each design as a whole. You can use the Column
Chooser to select data to include in the report after you generate the report.

To Generate an MCAD Bill of Materials

1. With a structure open, click Tools » Bill Of Materials. The Bill Of Materials
tab of the ribbon opens.

Select a BOM Type from the box.
3. Specify the inventory for the BOM in the Selection box.
4. To select the information to include in the BOM:

a.

f.

Click @ Column Chooser. The BOM Column Chooser dialog box opens.

Under Available Fields, select a category of information:

¢ System Variables
* Properties

To add one or more columns to the BOM, select them in the list under
Available Fields and click Add. The columns are added to the Displayed
Fields list.

To remove one or more columns from the BOM, select them in the list
under Displayed Fields and click Remove. The columns are removed from
the Displayed Fields list.

To reorder the columns, select a column in the Displayed Fields list, and
then click IZI or IE‘ to change its position.
Click OK. The BOM Column Chooser dialog box closes.

5. Click Bill Of Materials » @ Generate BOM. The bill of materials is created.
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To Set Bill of Materials Options for MCAD

1.
2.
3.

Click File » Creo View Options. The Creo View Options dialog box opens.
In the Showing box, select Global. On the right, the global options open.

On the left, under Model, select Bill Of Materials. On the right, the Model-Bill Of
Materials options open.

To add one or more columns to the list of defaults, select them in the Available
Fields list, and then click Add. The columns are added to the Displayed Fields

list.

To remove one or more columns from the list of defaults, select them in the list

under Displayed Fields and click Remove. The columns are removed from the
Displayed Fields list.

To reorder the columns, select a column in the Displayed Fields list, and then
click IEI or IE‘ to change its position.
Click OK. The options are saved.

To Generate an ECAD Bill of Materials

1.

2.
3.
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Click Tools » Bill Of Materials. The Bill Of Materials tab of the ribbon opens.

Click Bill Of Materials » @ Generate BOM. The bill of materials is created.
To select the information to include in the BOM:
a. Click @ Column Chooser. The ECAD BOM Column Chooser dialog box
opens.
b. Under Available Fields, select a category of information:
* System Variables
* Properties

c. To add one or more columns to the BOM, select them in the list under
Available Fields and click Add. The columns are added to the Displayed
Fields list.

d. To remove one or more columns from the BOM, select them in the list
under Displayed Fields and click Remove. The columns are removed from
the Displayed Fields list.

e. To reorder the columns, select a column in the Displayed Fields list, and
then click IZI or IE‘ to change its position.
f. Click OK. The BOM Column Chooser dialog box closes.
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About a Design Data Report
In Creo View, you can create these types of ECAD design report:

* Object Specific—Includes all available information about each component of
the selected type.

* Design Statistics—Provides information about the creation of the design along
with the number of components of each type. Create a Design Statistics report
for the design as a whole, a group of selected objects, or a selected subcircuit.

For a Object Specific report, you can use the @ Column Chooser before or after

you generate the report to select the data to include. In the ECAD Report Column
Chooser dialog box, you can also set the order of the columns. Some columns are

ad
locked and cannot be removed from the report using the Column Chooser.

When you generate a report, report pane opens in the lower data panel. The
information you select to include is displayed in this pane in columns. Rows of pin
information associated with components are not included on the report pane, but
they appear in an exported report. You can sort fixed columns with single-value
entries by clicking the column heading. When you select an item in the report
pane, the graphics area, or the substructure pane of the primary panel, it is
automatically selected in all three locations.

To Generate a Design Data Report

1. Click Tools » Design Data. The Design Data tab of the ribbon opens.
2. Inthe Report Type box, select Object Specific.

3. In the Selection box, select the object type for the report.

4. Click Design Data » Generate Report. The report is created.

To Generate a Design Statistics Report

1. Click Tools » Design Data. The Design Data tab of the ribbon opens.
2. Inthe Report Type box, select Design Statistics.
3. In the Selection box, select the objects to include in the report:
* Entire design
* Selected objects
¢ Highlighted objects
4. Click Design Data » Generate Report. The report is created.
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To Export a Bill of Materials or Design Data Report

1. Inan open BOM or report, perform one of these actions:

» Click Bill Of Materials > Export. The Export Bill of Materials dialog box
opens.

* Click Design Data » Export. The Export Report dialog box opens.
Browse to the folder where you want to save the report.
3. In the File name box, accept the default name or type a new one.

4. Inthe Type box, select a file format:

e CSV
* Web page
5. Click Save. The report is exported.
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About Animation

Use the Animation module of Creo View to coordinate the components of an
animation sequence and play back an animation. You can animate Model Views
only, and you must have an Animation license to create and edit animations. You
can play, create, and manage your animation using the Keyframe Editor, the
ribbon, and the shortcut menu. Animate these types of items:

* Parts

* Subassemblies
* Assemblies

* Annotations

* Measurements

* Section cuts

Access to the Animation functions depends on your edition of Creo View and
whether you have an Animation license installed.

Creo View Configuration Animation Functions
Creo View with an Animation license | Create, edit, and playback
Creo View without an Animation Playback only

license

Creo View Lite

Creo View Express

Preview the path of a moving item in an animation by displaying a line with a
coordinate system marking the position of the item at each key. You can play

animations and set playback options to control the speed, looping, range, and

direction.

Example: Possible Uses of Animation

Use Animation for these purposes:

* Visualize your assembly’s operation. If you have the concept, but have not
defined the mechanics, you can drag bodies to different positions and take
snapshots to create an animation.

» Create an assembly or disassembly sequence animation of your structure.

» Create a maintenance sequence, a short animation of steps to take to instruct a
user in how to repair or build a product.
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* Conduct a packaging study for the product.

» Present the product in a specific environment for marketing purposes.

About Tracks and Keys

A track describes the motion in an animation. A key is a milestone in time that
signifies a change in the animation.

Tracks

There are three types of tracks:

* Container—Contains one or more container or item tracks.
* Item—Animates a part or camera. Each item has its own track.

* Property—Includes the keys that define the motion and properties of a part,
subassembly, markup, section, or camera.
Keys

When you create or edit an animation, a new key is created each time you perform
one of these actions on an object or content:

e Move
*  Modify
e Create

Each frame of the animation sequence contains a key for each recorded item. The
type of transition between keys is the Interpolation Mode. Select one of these kinds
of transitions for each key to define the movement in your animation:

. Step—Changes only at the key’s position on the timeline.
g y ysp
. Linear—Transitions between keys at a constant rate.

. Spline—Transitions between keys at an increasing or decreasing rate.

To Play an Animation

Perform one of these actions:
*  On the playback bar, click .
e Click Animation »
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To Set Playback Options

1. Click Animation, and then set the following options in the Play group:
» Playback speed—Select a relative speed from the box.
* Loop—Loop the animation continuously.
* Range—Set the start and end points in one of these ways:
o Click Range, and then set a Start point and an End point in
seconds.
O Drag @ and IE in the Keyframe Editor

O Type start and end times in the boxes in the Track Tree.

* Direction—Click to play the animation in reverse.

2. To toggle the display of the playback bar in the view from show to hide,
perform one of these actions:

e Click Animation » Playback Controls.
* Set the option in the Creo View Options dialog box:

a. Click File » Creo View Options. The Creo View Options dialog box
opens.

b. In the Showing box, select Global.

c. On the left, under Model, select Animation. The Model—Animation
options open.

d. Under Animation Tool, select or clear the Show in-view playback bar
box.

Creating Animations and Movies

About Creating, Saving, Importing, and Exporting
Animations

You can create an animation by recording There are two automatic recording
modes:

fz) .. .
. Record Content—Records changes to the position of items, markup, and
sections.

. IEI Record Camera—Records changes to the camera’s position.
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In the automatic recording modes, a recording indicator IE‘ appears in the graphics
area and the status bar. Tracks are added in the Keyframe Editor when you move a

new item or create new content. Every time you make a change, the timeline in the
Keyframe Editor is extended by an increment and a new key is created. The

manual recording mode is called Capture. Use it to take a manual snapshot of
selected items, camera positions, or both. New tracks are created for cameras that

@
do not already have them. In Record Content mode, you can add these effects
to one or more parts:

. Fade Out—Adds a transition from opaque to transparent.

. Fade In—Adds a transition from transparent to opaque.

Screw—Rotates the part.
. Unscrew—Rotates the part.

. D Color—Adds a transition from the original color to another color.

You can import Creo Parametric (* fra), and you can open ProductView Standard
animations. You cannot, however, open Creo View animations in ProductView
Standard. The imported animation must match the current structure. An imported
animation replaces the current animation. It may contain information about the
conversion factors for time and space definitions, or you may have to specify them
in the import dialog box. Animations are saved in an annotation set. You can also
export an animation as a movie. Choose an encoding format from the list of codecs
available on your computer.

To Create and Save an Animation

1. With a Model View open, click Animation » Advanced. The Animation tool
opens.

2. Click Animation » %
Note

The first time you open the Animation tool for a view, a new animation is
created automatically.

Animations » New. The Keyframe Editor opens.

. . @
3. To set the recording mode, click Animation » Record Content or Animation
> IEI Record Camera.

4. For each part, subassembly, or assembly to move, perform these actions:

a. Select the item to move.
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b. Select a motion type.
c. Drag the item to a new location in one or more increments.

5. Save the animation as an annotation set.

To Add or Change an Animation Effect

1. In an open animation, select one or more parts.

2. Click the arrow below the current effect. The default effect is Fade Out.
3. Select an effect from the list:

. Fade Out
Fade In
Screw
Unscrew
IE‘ Set Color

To Preview the Path of an Item

1. In the Track Tree, select the item’s track.

2. Click Track Tools > Preview. The item’s path appears. You can preview the
path of only one item at a time.

You can also right-click the track and choose Preview from the shortcut menu.

To Import an Animation

1. Click Animation » Advanced. The Animation tool opens.

2. Click [*H| Animations » Import. The Import Animation dialog box opens.
3. Click Yes to confirm the import. The Load Animation dialog box opens.
4

Select the animation file to import and click Load. The animation is loaded, or
the FRA file importer settings dialog box opens.

5. Specify time and space information about the animation:
a. Select a conversion factor in the boxes next to Units.
b. In the Frames per second box, select or type a value.

c. Click Import. The animation is loaded.
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To Export an Animation as a Movie

Click Animation » Export. The Export Movie : Settings dialog box opens.

2. In the Save to file box, type a path for the movie, or click Browse to browse to
the file location.

In the Record using codec box, select an encoding format.

Select values for the following options:

* Frames per second

*  Width

* Height

To maintain the animation's proportions, select the Lock aspect ratio check box.

To play the movie automatically after creating it, select the Launch movie
player when complete check box.

7. Click Create movie. The movie is created.

Editing Animations

About Editing Animations
In Creo View, you can edit an animation using these methods:
* Add or remove tracks or keys
*  Modify tracks
© Drag
©  Lock or unlock

O Place in a container track

© Reverse
©  Mirror
© Merge
o  Split

O Stretch

*  Modify keys
o [Edit properties
© Drag
©  Duplicate
o Cut
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©  Copy

O Paste

©  Change mode

O Delete

You can find these tools in the Keyframe Editor and on the shortcut menu. You can
also access the tools from the Track Tools and Key Tools tabs of the Ribbon.

To Edit the Keys Using Different Methods

Access each of the key editing operations in one of these ways:

menu, and then
select a mode from
the list:

e Step
* Linear
* Spline

Edit from the
shortcut menu.
The Key Editor
dialog box
opens.

2. Inthe
Interpolation
Mode box,

select a mode:
* Step
* Linear

e Spline

Operation Keyframe Editor |Key Editor Dialog |Key Tools
Box
Move Dragfthe keytoa |} Rightclick the |1. Select the key.
new Irame. key and choose |5 Click Key
Edit from the Tools, and then
;ILOYtCUt menu. select or type a
e Key Editor . M
dialog box X.?;:fég;he
opens. .
2. Type anew
value in the
Time box.
Change Right-click the key | | pione click the | 1. Select the key.
interpolation mode |and choose Mode kev and choose .
from the shortcut i 2. ClickKey

Tools, and then
click the arrow
under the
current
interpolation
mode.

3. Select a new
mode:

. Step
. Linear
. Spline
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menu, or right-
click a frame and
choose Paste from
the shortcut menu.

Operation Keyframe Editor |Key Editor Dialog |Key Tools
Box
Duplicate 1. Right-click the 1. Select the key.
key e_lnd choose 2. Click Key Tools
Duplicate from
the shortcut > =
menu. The key Dupl.lcate. The
is duplicated key 1
and selected. duplicated and
selected.
2. Drag the key to
a new frame. 3. Drag the key to
a new frame.
Cut Right-click the key 1. Select a key or
Copy and choose Copy a frame.
from the shortcut )
Paste 2. Click Key

Tools, and then
click one of the
following:

. Copy
. Cut
. Paste

Duplicating and Copying Keys

Use the Duplicate command to create an identical key that appears on top of the
original. After you perform the Duplicate operation, the new key is automatically
selected, and you can drag it to a new location. Use the Copy command to create a
copy of the key on the clipboard. Then, paste it in a new location on the timeline,
or paste it in another animation.

About Easing Movement

Easing is the acceleration or deceleration of a part or a camera's movement. You
can add easing to any number of keys, and you can perform the operation on one
or more keys at once. A key must have the Spline interpolation mode set to add
easing. Each ease controls the velocity of the item at these points around the key:

* Ease to—Approach

* Ease from—Departure
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The body moves according to the ease value you set:

e Slow—Decelerates

* Normal—Travels at a constant velocity

» Fast—Accelerates

For example, when you select a key at the 5—second mark and set the Ease to value
to Slow and Ease from to Normal, the object decelerates as it approaches 00:05.
After the 5—second mark, the object continues traveling at a constant speed toward

the location set by the next key.

To Accelerate or Decelerate a Body Using Easing
1. Right-click a key and choose Edit from the shortcut menu. The Key Editor

dialog box opens.

2. In the Interpolation Mode box, select Spline.

Click Control. The Spline Control dialog box opens.

Select a value in one or both of the boxes under Transition:

e Easeto
e Ease from
5. Click OK.

To Edit Tracks Using the Track Tools

Use the Track Tools to modify one or more tracks of the animation as follows:

Tool

Description

Lock

Locks the track to prevent unintended
changes.

=9 Focus

Shows in the Keyframe Editor the
selected tracks and hides all other
tracks.

| Insert Keyframe

Adds a new key at the location of the
time insertion point.

Start and Duration

Defines the exact start time and duration
in seconds of a track.

Split

Slices the track at a selected location.

Merge

Splices together two consecutive
segments on the same track. The
segments do not have to be adjacent.
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Tool Description

Creates a copy of the track whose keys
are reversed relative to the original.

| Mirror

Reverses the order of the keys in the
32l | Reverse track

To Insert Tracks and Keys

1. Inthe Keyframe Editor, select the location for the insertion:
* Key—Any point in the timeline
* Track—Another track

2. Click Track Tools » == Insert Keyframe or Track Tools > Insert Folder. The

item is inserted.

You can also insert a track by dragging a part from the Structure Tree to the
Keyframe Editor.

To Stretch a Track

1. In the Keyframe Editor, select the beginning or end of the track to stretch.

2. Drag the track end to a new location on the timeline. The track is stretched.

To Delete a Track or Key

In the Keyframe Editor, right-click the track or key and choose Delete from the
shortcut menu.

You can also use these tools on the ribbon:

* Track Tools » Delete
* Key Tools » Delete

About Locking and Unlocking Tracks

You can lock one or more tracks in an animation. Locking prevents an
unintentional change to the track, but it does not limit access to changing it. When
you lock a parent track, its children are also locked.
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To Lock or Unlock a Track

1. To lock a container or track, right-click it and choose Lock from the shortcut
menu.

2. To unlock, right-click the container or track and choose Unlock from the
shortcut menu.

You can also select a track and then click Track Tools » Lock to toggle its lock
status.
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Interference Detection

About Interference Detection

Use Interference Detection to determine whether parts of a model overlap, touch,
or are too close to each other. An interference detection test is called a query. You
can save the query settings and the results. One user can define the query and
another user can perform it. You can also compare different query settings to the
same model input and examine different iterations of the same model using the
same query settings.

You must have an Interference Detection license to use the Interference Detection
tool.

Creo View Edition Interference Detection Functions
Creo View with an Interference Read and write

Detection module license

Creo View without an Interference Read only

Detection module license View results and open reports.

Creo View Lite Read only

Creo View Express None

You can set Creo View to open Interference Detection information as read-only
data.

To Perform an Interference Detection Query

1. Click Tools » I:‘ Interference Detection. The Interference Detection tab and
the Interference Detection Settings dialog box open.

2. Select a Query Name from the list or type a new one.
3. Select an option from the Calculation Mode list.

Select an interference Detect option of the following type or combination of
types:

* Interference
* Contact + Interference
* Clearance + Contact + Interference

5. Type a value for one or more of the following boxes:
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* Tolerable Penetration
* Tolerance
* Required Clearance

6. Create an input list in the Input panel.

7. To test interference between entities, create a second input list by clicking .
The second Input panel opens.

Create the second input list.

9. To test parts within the assembly or group, click the Self Intersection check
box.

10. To exclude parts or assemblies from the tests, click the Exclusion tab and create
an exclusion list.

11. Click to leave the dialog box open after the calculation.
12. Perform the following steps to save the query settings:

a. Click Manage Queries. The Manage Queries dialog box opens with the
given Query Name inside.

b. Click Save. The Name dialog box opens.

c. Click OK to save the query, or change the name and then click OK. The
query name is added to the list in the Manage Queries dialog box.

d. Click Close. The Manage Queries dialog box closes.

13. Click Calculate. The results appear in a list in the Interference Detection
panel and graphically in the Interference View.

Calculation Mode Options
Calculation mode uses the following types of geometric data as options:
* Quick— Approximate geometry

* Accurate— B-rep geometry
Note

If you select Accurate for models with mixed data, the Accurate option is run for
parts with B-rep and the Quick option is run for other parts.
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Example: Interference Detection Options

Detect
Option

Detection

Figure

Interference

Parts overlap
in 3D

1 Tolerable Penetration

Contact

Parts touch
one another,
but do not
overlap

1 Tolerance

Clearance

Parts are closer
than the
defined
minimum
distance

1 Required Clearance

Setting Interference Detection Types

You can select one of these interference detection types or combinations:

* Interference

* Contact and Interference

» Clearance, Contact, and Interference

Interference Detection |Default Tolerance Interference
Type Value Detection Value
Interference Tolerable Penetration = 0 |Negative

Contact Tolerance = 0 Positive
Clearance Required Clearance =1 | Positive
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Note
e The tolerance value boxes match the interference detection type.

e The Tolerable Penetration value must be greater than or equal to 0. The box
appears only when Interference is selected.

» The +/- symbol appears in the Tolerance value prefix, as the value is
symmetrical.

e The Required Clearance value cannot be less than the Tolerance value.

Input of Entities for Interference Detection
Use the following entities as input in an Interference Detection query.
* Parts

* Assemblies

. Groups—Dynamic or Static

Input can be grouped in these ways:

* Self Intersection—Checks interferences inside assemblies and groups. The
default state of Self Intersection for assemblies and groups is selected.

. DiVides the input into two groups to test for interferences between them.

To Create Input Lists and Exclusion Lists

1. To create the Input list for interference detection, move items to the Input panel

in one of the following ways:

* Drag parts or assemblies from the Structure Tree.

* Select one or more parts on the Structure Tree and click Selected Part.

* Drag groups from the Groups pane.

e C(Click a shortcut commands on the Input tab:

Structure—All entities in the Structure Tree
Loaded—All loaded parts

O

O

Selected—The selected group

O

Visible—All loaded and visible entities

2. Create the Exclusion list in one of these ways:

O
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* Drag parts or assemblies from the Structure Tree or groups from the Groups
pane to the Exclusion panel.

* Right-click an item in the Input list, and then and choose Exclude.

* Right-click an item in the Results list, and then and choose Exclude Pair.
Select the Instances check box to exclude all instances of the selected pair.

3. To remove an entity from the Input list, right-click and choose Clear.

Save the query settings as an annotation set to use them in future tests or to
compare the results for future model iterations.

About Grouping Interference Detection Input

When working with large models, it is good practice to create groups to drag into
the Input and the Exclusion lists for interference detection. You can organize
groups in the following ways:

* Create Static groups by adding parts from different assemblies to the input list.
* Populate Dynamic groups automatically by attribute types.

* Define Dynamic groups by creating an assembly hierarchy.

After you perform interference detection, you can select a result and add it to the
Exclusion list. In this way, you can exclude known and expected interferences,

such as bolt-bracket pairs, from the Results list. You can also exclude all instances
of the pair.

When you select a pair group to exclude, the prompt (Not Synchronized)
appears next to the Annotation Set name in the graphics area. Recalculate the
interference detection.

About Managing Queries for Interference Detection

The Manage Queries dialog box shows all available queries for the loaded file by
name. If you create a query without naming it, you cannot save it. You can rename
or delete queries from the list.

* The Local check box shows the queries that were saved per the specific loaded
data set. By default, new queries are saved from the current data set as Local
queries.

» The Global check box shows the queries that were set as global per any data
set. Global queries do not include the input as input is data-specific.
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To Set Local Queries to Shared Queries

1. In the Interference Detection Settings dialog box, click Manage Queries. The
Manage Queries dialog box opens.

2. Right-click an item in the Local query list and choose Set As Shared Query,
then click Save.

To Rename Interference Detection Queries

1. In the Interference Detection Settings dialog box, click Manage Queries. The
Manage Queries dialog box opens.

2. Select an item from the list and click Rename. The Rename Query dialog box
opens.

3. Type a new name and click OK. The name updates in the Manage Queries
dialog box.

To Delete Interference Detection Queries

1. In the Interference Detection Settings dialog box, click Manage Queries. The
Manage Queries dialog box opens.

2. Select an item from the list and click Delete. The query is deleted.

To Set Message Options for Interference Detection
1. Click File » Creo View Options. The Creo View Options dialog box opens.
2. On the left, click Interference. The Model-Interference options open.
3. Under Messages, select one or both of the following check boxes:
* Show information message when interference calculation is completed
* Check for unsaved reports

4. Click Apply to apply the options and keep the Creo View Options dialog box
open, or click OK to apply the options and close the dialog box.
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Working with Interference Detection
Results

About Interference Detection Results

Save the interference query as an XML* . pvc annotation set file. The file includes
both the interference settings and the calculation results. Each saved annotation set
contains the results of only one calculation.

The results are generated as a list of pairs of entities between which interference is

detected. The Results list appears in the Interference Detection pane of the
lower data panel, and an image of two interfering parts of a selected row appears in
the Interference View in the graphics area.

You can add notes and predefined tags to each detected interference in the Results

list to monitor Interference Detection results. You can create and export a Summary
Report and a Full Report.

About Monitoring Interference Detection Results

Tags and notes can convey the information that a tag can convey:
»  Status

* Related tasks

*  Assignment

Your tags and notes remain in the Interference Detection results and become part of
the Full Report. Custom tags and default tags can be modified and deleted. A box
for optional legend is provided.

Four tags are included with Creo View:

Symbol Highlight Name Description

@ Accept Approves the object

@ Reject Rejects the object

|:| In Work Flags the object for
checking

D None Adds the object without

assigning a specific status
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To Create, Reply to, and Delete a Note in
Interference Detection Results

Select a result in the Interference Detection pane.

Right-click and choose Note or click Interference Detection » Note to open the
Note Properties dialog box.

Type the note, and then click OK. A note box appears in the Note column of the
selected result.

To open the note, right-click the result and choose Note. The Note Properties
dialog box opens.

To reply to the note, click . The reply box opens in the Note Properties
dialog box. Type the reply, and then click OK.

To delete the note, right-click the result and choose Delete Note.

To Add or Replace a Tag

1.

In the Interference Detection pane, select the item to add a tag or replace
the tag.

Right-click and choose Tag, and then select a tag from the list, or click
Interference Detection > Tag. The Tag list opens.

Select a tag from the Tag list. The tag appears in the Tag column in the
Interference Detection pane.

Viewing Legends on Tags

You can click the arrow in the Markup group on the Interference Detection tab to
view the Tag Legend. The legend includes the name and image of each tag and an
optional comment.

To Create a Tag for Interference Detection
1. Click File » Creo View Options . The Creo View Options dialog box opens.

On the left, click Tags. The Annotations-Tags options open.

. Under Palette Type sclect Multiple » Interference Detection.

Note

You can manage one tag palette for all applications if you choose Uniform.

The palette opens in the Tags box.
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Click Add. The Edit Tag dialog box opens.

Type a name in the Tag Name box and check Navigator Symbol (16x16), and
then click Browse. The Select Image palette opens.

To import an image, follow these instructions:

a. Click Import. The Add Stamp dialog box opens.

b. Browse to an image file and click Open. The selected image is added to the
Select Image palette.

Select an image from the palette and click OK. The image appears alongside
Navigator Symbol (16x16) in the Edit Tag dialog box.

. Under Comments add a description of when to use the tag. The description will

appear in the tag Legend dialog box.

Click Apply to apply the options and keep the Creo View Options dialog box
open, or click OK to apply the options and close the dialog box.

To Filter Interference Detection Results

1.

Click Filter on the Results list in the upper data panel or on the Full Report. The
Interference Detection Navigator Filters dialog box opens.

Clear the check box for any instance in the list to exclude it.

Click Apply to apply the settings, or click OK to apply the settings and close the
dialog box. The filters are applied either to the Results list or the Full Report.

About the Interference View

When you select an interference instance in the Results list, the pair of interfering
parts are displayed in the Interference View in the graphics area. You can scroll
through the items to view each instance in turn, and you can examine the view
with tools that visualize the detected interferences.

When the Interference View opens, the noninterference entities in the Model View
are grey and transparent by default.

To Explore the Interference View
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To open the Interference View in the graphics area, double-click a result in the
Interference Detection results on the lower data panel, or click Interference

Detection » ':I Open.

To display an interference result’s compared parts in the Interference View
display, double-click it.
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» To scroll through the results, click Interference Detection » Next or

Interference Detection » Previous.

]
» To display all detected interferences, click Interference Detection » Show

All

To Change the Display of the Model View

When the Interference View is open, you can change the appearance of

noninterfering parts in the model view:

» To show only interference entities, click Interference Detection > Display

Selected Pairs.

» To show all parts in the view, click Interference Detection » Display All

Inputs.

Inspecting the Interference View

The Interference View displays the following aspects of the Interference Detection

tools:
Tool Interference Display Default
Type
|:| Secti Interference, Section Shown in the
ection Contact middle of the
bounding box.
Bounding B Interference, Location of the Show Bounding
ounding BoX | contact interference Box [?mensmns 18
not displayed.
EI . Clearance Minimum required
Min. Distance .
clearance distance
between two parts
Volume Interference Volume of the
penetration
Interference Contour of the

Contour

penetration

To Modify Display Colors for Interference Detection
1. Click File » Creo View Options. The Creo View Options dialog box opens.

2. In the Showing box, select Active View.
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On the left, click Interference. The Model-Interference options open.

Select one of these check boxes and click the color button for the item for any
of the following options:

* Part1

e Part2

* Contour
* Volume

* Bounding Box
* Model Color

The Choose Color dialog box opens.

Select a color from the Basic colors list or from the color wheel, or set the Red,
Green, and Blue values.

Click OK.
To set a color for another item, repeat steps 4—6.

To change the Transparency Default of the Noninterfering Component Display,
type or scroll to the required value.

Click Apply to apply the options and keep the Creo View Options dialog box
open, or click OK to apply the options and close the dialog box.

Comparing Interference Detection
Results

About Comparing Interference Detection Results

There are two ways to compare Interference Detection results:

190

Compare—Compares the recently performed query with a saved query. The
detection settings and the input data can vary.

Recalculate—Compares the results of two calculations of the same input data
where changes were made to the location of some parts. Recalculate can also
compare calculations if changes were made to some of the test settings, such as
changing the detection option from Interference to Clearance.
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To Compare Two Queries

1. Perform an interference detection calculation.

2. Click Interference Detection » Compare. The Compare Interference Results
dialog box opens. The Active Set contains the present results.

3. Select a Referenced Set from the list of previous interference detection
calculations.

4. Click Save as new Report to save the results as a new results set. Otherwise the
results will overwrite those of the active set. The Report Name dialog box
opens.

5. Type the new name and then click OK.

6. Click Compare. The new query results appear in the Interference Detection
pane in the lower data panel.

To Recalculate Interference Detection Queries

Save an interference detection query as an annotation set.
2. Update the model.

3. Click Interference Detection > IEI Recalculate. The query results override

the previous results in the Interference Detection pane in the lower data
panel.

Understanding the Status of Query Recalculations
and Query Comparisons

You can compare the results of two calculations of the same query, or you can
compare the results of two different queries. When you compare the results of two

calculations of the same query, the status of the item in the Interference
Detection pane is assigned as follows:

* Resolved—The interference appears in the first calculation but not in the
second.

* Exists—The interference appears in both calculations.

* New—The interference appears in the second calculation.

When you compare the results of two different queries, the status is assigned as
follows
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* Resolved—The interference appears in the reference set but not in the active
set.

» Exists—The interference appears in both the reference set and the active set.
* New—The interference appears in the active set but not in the reference set.
Note

The first time a query is performed, the resulting status for all interference sets is
New.

Interference Detection Results Reports

About Interference Detection Results Reports
You can generate and export summary reports and full reports:

* The summary report includes general information about the progress of the
design procedure. It is useful for managers.

» The full report provides specific details in addition to the general information,
allowing hands-on users to read and analyze results case by case.

Both summary and full reports provide this information about the current
calculation:

* General Details
* Interferences by Type and Tags

* Interferences by Top Level Selection—Lists the groupings between which
interference cases were found and the number of cases between the two
groupings.

The Full Report also includes information on Interferences by Components and

items added in Tag and Note. You can filter the results in the Interferences by
Components partition. Reports do not include resolved interferences.

Save or export the reports using one of the following file formats:

« CSV
« HTML

To Generate and Export an Interference Detection

Results Report

1. Select a report:
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* Interference Detection » Summary Report
* Interference Detection > Full Report
The Summary Report or Full Report dialog box opens.
2. To export the report, do the following operations:
a. Click Export. The Export Interference Detection Report dialog box opens.
b. Browse to the folder in which to save the report.
c. Click Save.
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About Design Check Mode

Use Design Check mode to computerize the design check process. You can tag one
or more parts, portions of geometry, and Model Annotations to signify information
about the item. You can create and define your own set of tags. The following are
examples of information that a tag can convey:

e Status
* Related tasks

* Assignment

After you tag items, you can perform the following operations in Design Check
mode:

* Lock the tag

* Add atag note

* Reply to an existing tag note

* Change the tag

* View a list of the tagged objects

* View a legend for the tags

* Generate a report that lists the history of tag changes for the item

» Save the tags and tag notes as an annotation set

You can configure Design Check mode to make tags recognizable at a glance. Set a
neutral color for the display of the structure, geometry, and all of the associated
Model Annotations. Assign a color to each tag that you apply to the item. You can
define and design any number of other tags for use in Design Check mode. Four
tags are included with Creo View. Custom tags and out-of-the-box tags can be
modified and deleted.

Access to Design Check functions depends on your edition of Creo View and
whether you have a Design Check license installed.

About Design Check Review Mode

You have read-only access to Design Check data in Design Check Review mode.
This data includes the following information:

» Tagnotes

* Information on the @ pane of the upper data panel
e  Summary report

* Legend
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* Review history

» Tag color in the graphics area

Access to Design Check Functions

Access to the Design Check functions depends on your edition of Creo View and
whether you have a Design Check license installed.

Creo View Configuration Design Check Functions
Creo View with a Design Check license |Read and write

Creo View without a Design Check Read-only

license
Creo View Lite Read-only
Creo View Express None

You can also set Creo View to open Design Check information as read-only data.

Working with Tags

About Tagging Designs

When you tag an item in a design, it is added to a list of tagged items in the upper
data panel. If the tag includes a color, then the item appears in the graphics window
with the color. Tags are only visible in Design Check mode. They do not change
the color of the item in the structure. You can tag the following items:

* Part

* Face

* Edge
* Point

e Model Annotation

A Model Annotation is an annotation that is created in the CAD tool along with the
structure. You cannot tag a markup created in Creo View. You can assign one tag
to a part and a different tag to a piece of the part's geometry.

To Tag an Iltem

1. On the Home tab, in the Model-Based Design group, click Design Check »>
Design Check. Design Check mode is activated.

2. Select the part, geometry, or Model Annotation that you want to tag.
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3. On the Design Check tab, in the Design Check Tags group, select a tag to apply
to it. The item is tagged.

Note
You can also use the keyboard shortcuts for Design Check mode to apply tags.

4. To lock the tag, on the Design Check tab, in the General group, click Locked.
5. On the Design Check tab, in the Close group, click Close Design Check.

Keyboard Shortcuts for Design Check Mode

Tags in the Design Check Tags group each have a corresponding number based on
the order they appear. After you select an item to tag, you can press CTRL+1 to
apply the first tag in the Design Check Tags group, CTRL+2 to apply the second
tag, and so on.

Default Tags for Design Check Mode

The following default tags are included with Creo View:

Symbol Highlight Name Description

@ Accept Approves the object.

|i| Reject Rejects the object.

|:| In Work Flags the object for
checking.

@ None Adds the object to the

pane of the upper data
panel without assigning a
specific status.

Selecting a Tagged Item
Select an item with a tag from one of the following locations:

* QGraphics area
* Structure Tree
* Any pane of the upper data panel
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To Lock or Unlock a Tag

1. In Design Check mode, select the part, geometry, or Model Annotation whose
tag you want to lock or unlock.

2. On the Design Check tab, in the General group, select or clear the Locked
check box.

Locking the Tag

Locking prevents an unintentional change to the tag, but it does not limit access to
changing the tag. You can lock a tag when you apply it, or you can lock or unlock
an existing tag. In Creo View, any user can lock or unlock a tag. When a tag is
locked, you cannot do the following operations:

* Change the tag

* Addanote
* Delete the tag
Note

When a part's tag is locked, for the part's geometry you can still add or change a
tag.

Lock or unlock a tag from one of the following locations:

*  On the Design Check tab, in the General group

* From the shortcut menu in the @ pane of the upper data panel

» In the Design Check Tag Properties dialog box

When you define a tag, you can set the locking mechanism to one of the following
states:

* Manual Lock—The tag must be locked manually.
* Automatic Lock when created—The tag is locked automatically.

» Disabled Lock Mechanism—The tag cannot be locked.

You can also configure a tag to lock a note when the tag is locked.

To Change a Tag
You can only change a tag that is unlocked.

1. In Design Check mode, select the part, geometry, or Model Annotation whose
highlight you want to change. The Design Check Tags group becomes
available.

2. On the Design Check tab, in the Design Check Tags group, select a new tag.
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Note

You can also change the tag using the upper data panel's shortcut menu, the
Design Check Tag Properties dialog box, or CTRL+1 for the tirst tag, CTRL+2

for the second tag, and so on.

Changing a Tag
Change an item's tag from one of the following locations:
*  On the Design Check tab, in the Design Check Tags group

* From the shortcut menu in the L1 pane of the upper data panel
* In the Design Check Tag Properties dialog box

To Add a Tag Note

1. Make sure that Design Check mode is activated and that at least one part or
Model Annotation has a tag.

Select the highlight to which you want to add a note.

3. On the Design Check tab, in the Properties group, click Tag Note. The Design
Check Tag Properties dialog box opens.

4. In the Notes box, type a comment.

Customize the note with the following settings for the graphics area:

. @»Notes are expanded.

Notes are collapsed.

*  Font size

L]

Text color
e Background color
6. Click OK.

To Reply to a Tag Note

1. Double-click the tag note to which you want to reply. The Design Check Tag
Properties dialog box opens.

2. In the Notes box, click Reply. A reply box opens.
3. Type areply and click OK.
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Selecting a Tag Note

Select a tag note using one of the following methods:

* In the graphics area, double-click the note.

» In the graphics area, select the note, right-click, and choose Edit Properties.

* Onthe @ pane of the upper data panel, double-click = for the item.

» Select the note. On the Annotations tab, in the General group, click Edit
Properties.

To Delete a Tag
1. Make sure that Design Check mode is activated.
2. Select the item whose tag you want to delete.

3. On the Design Check tab, in the General group, click Delete » Delete Entire
Tag. The tag, including all properties such as the Review History and notes, is

deleted.

To Apply the None Tag and Keep Tag Properties
1. In Design Check mode, select the tag you want to change to None.

Note
Make sure the tag is unlocked.

2. Select the None tag from one of the following locations:

*  Onthe @ pane of the upper data panel, right-click the tag and choose
None.

*  On the Design Check tab, in the Design Check Tags group, select None.

The tag is updated and its properties are preserved.

Applying the None Tag and Deleting a Tag

During the design check process, you may want to remove a tag—for instance, to
signify the resolution of an issue. To accomplish this, you can apply the None tag,
or you can delete the entire tag. The results of each strategy are listed below.

Action Result

Apply the None tag. In the graphics area, the item is
highlighted with the None color. The
default color is white.

In the upper data panel, the item
remains in the list of tags.
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Action

Result

In the Design Check Tag Properties
dialog box, the Review History is
preserved.

You can lock the None tag. Notes that
were previously added are preserved
and editable. You can add a new note.

Delete the entire tag.

In the graphics area, the item is
displayed in the neutral Design Check

color that you set in the Creo View
Options dialog box. Notes are deleted.

In the upper data panel, the item is
removed from the list of tags.

In the Design Check Tag Properties
dialog box, the Review History is
deleted.

In a report, the item does not appear.

Getting Tag Information

About a Design Check Report

You can generate and export the following types of Design Check report:

*  Summary—Provides each tag, the number of items with that tag, and the total

number of tagged items.

* Full—Provides each tagged item and the following additional data for each

item:

© Type

© Name

© Status

© Locked or unlocked

© Note

O Associated component

O User that first tagged the item
O Date and time of the first tag
O User that last modified the tag

O Date and time of the last modification
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Export the report to one of the following file formats:

*  CSV—CSV file for use in a spreadsheet
*  Web page—HTM or HTML file for use in a Web page

To Generate and Export a Design Check Report
1. Do one of the following operations, depending on the mode:

* Design Check mode—On the Design Check tab, in the General group,
click Report and select one of the following types:

O Summary Report
O  Full Report

* Design Check Review mode—On the Design Check tab, in the General
group, click Summary Report.

The Summary Report or Full Report dialog box opens.
2. To export the report, do the following operations:
Click Export. The Export Design Check Report dialog box opens.

a.
b. Browse to the folder where you want to save the report.

c. In the File name box, accept the default name or type a new one.
d. Inthe Type box, select a file format:

e CSV

* Web page

e. Click Save.

To Filter the Design Check Display in the Upper Data
Panel

1. Make sure that Design Check mode is activated and that you have at least two
tags.
2. In the upper data panel, click . The Design Check pane opens.

3. On the Design Check pane, click Filter. The Design Check Navigator Filters
dialog box opens.

4. To filter the items by type, in the Design Check Navigator Filters dialog box,
select one or more check boxes to display the corresponding type of item.

5. To filter the tags, in the Design Check Navigator Filters, under Tag, select one
or more of the check boxes to display the items with the corresponding tag.

6. Click OK.
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Understanding Symbols on the Upper Data Panel's
Design Check Pane

The @ pane of the upper data panel contains symbols that indicate the type of
item with a tag, whether the tag is locked, and whether a note is attached.

Symbol Description
|§| Part

@ Face

Edge

E Point

@ Note
Measurement
Locked

e Note attached

To View the Review History

Select the tag for which you want to see the review history.

—

2. On the Design Check tab, in the Properties group, click Review History. The
Design Check Tag Properties dialog box opens with the tag changes listed in

the Review History area.

To View a Legend for the Tags

1. Make sure that Design Check mode or Design Check Review mode is activated
and that you have at least one tag.

2. Do one of the following operations, depending on the mode:

*  Design Check mode—On the Design Check tab, in the Status group, click
the arrow.

* Design Check Review mode—On the Design Check tab, in the General
group, click I;I Legend.
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Creating and Modifying Tags

About Creating and Modifying Tags

You can define any number of tags for use in Design Check and Interference
Detection modes in addition to the tags that are included with Creo View. Give
users in your organization access to some or all of the tags. When you define a tag,
you assign one or more of the following properties to it:

* Color in the graphics area
» Symbol for the Ribbon and the upper data panel

* Information on when to use the tag

You can also edit any existing tag. Manage the tags using the Creo View Options
dialog box. The properties of the tags are global properties. When you create a tag,
you can add comments to a legend. Use the comments section to explain its use.

Users outside your organization can see your tags, and they can change the tag.
They cannot apply your tag to the design.

To Create a Tag

1. Click File » Creo View Options . The Creo View Options dialog box opens.
2. On the left, click Tags. The Annotations-Tags options open.
3. Select a Palette Type option:

* Uniform—To manage one palette for all applications.
* Multiple » Design Check—To create a tag only for Design Check

* Multiple > Interference Detection—To create a tag only for Interference
Detection

Click Add. The Edit Tag dialog box opens.
Type a name in the Tag Name box.

To display a tag in a different background color, follow these instructions:

a. Under Appearance, select the Tag Color check box.
Click the color button. The Choose Color dialog box opens.

c. Select a color from the Basic colors list or from the color wheel, or set the
Red, Green, and Blue values.

d. Click OK.

7. Select the Navigator Symbol (16x16) or Ribbon Icon (32x32) box and click
Browse. The Select Image dialog box opens.

Checking Designs 205



10.
11.

12.

13.

To import an image, follow these instructions:

a. Click Import. The Add Stamp dialog box opens.

b. Browse to the image file that you want to add and click Open. The selected
image is added to the tags display in the Select Image dialog box.

In the Edit Tag dialog box, under Options, select or clear the Show confirmation
message when tag is changed check box.

Under Lock Mechanism, select a lock setting.

To protect against overwriting for locked notes, select the Switch Note to 'Read
Only' when locked check box.

In the Comments box, type more information about the tag, or type instructions
on when to use the tag.

Click OK.

To Redefine a Tag

I.
2.

Click File » Creo View Options. The Creo View Options dialog box opens.

On the left, click Design Check. The Design Check-Main options open on the
right.

Select the tag to redefine, and then click Edit. The Edit Tag dialog box opens.
Change one or more tag settings:

* Name

*  Color

+ Symbol for the upper data panel, the Ribbon, or both

* Locking options

¢ Comments

To Add Symbols for a Tag

I.
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In the Edit Tag dialog box, select the check box for one or both of the following
items:

* Navigator Symbol (16x16)
* Ribbon Icon (32x32)
Click Browse. The Select Image dialog box opens.

Select an image from the dialog box and click OK, or to import images, follow
these instructions:

a. Click Import. The Add Stamp dialog box opens.
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b. Select the image that you want to add and click Open.

c. Repeat steps a-b until all the desired images are in the Select Image dialog
box.

d. Select an image and click OK.

To Set Design Check Options

1.
2.

Click File » Creo View Options . The Creo View Options dialog box opens.

On the left, under Model, click Design Check. The Model-Design Check
options open.

Under Options, select or clear the Highlight reference geometry when Model
Annotation is selected check box.

To display parts, geometry, Model Annotations, or all three in a neutral color in
Design Check mode, do the following operations:

a. In the Showing box, select Active View.

On the left, under Model, select Design Check. The Model-Design Check
options open.

c. Under Initial State, select or clear the check boxes for either or both of the
following options:
* Geometry Color
* Model Annotation Color

d. Click the color button for the item to define. The Choose Color dialog box
opens.

e. Select a color from the Basic colors list or from the color wheel, or set the
Red, Green, and Blue values.

f. Click OK.
g. To set a neutral color for the other item, repeat steps d-f.

Click Apply to apply the options and keep the Creo View Options dialog box
open, or click OK to apply the options and close the dialog box.
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About Construction Geometry

You can use construction geometry tools to create points, planes, curves, axes,
coordinate systems, and lines in 3D views. You can create points, axes, and lines in
2D Drawing views. Construction geometry appears in the 2D or 3D view, and is
also displayed in the Annotation Sets pane.

You can select construction geometry to perform certain viewing operations, such
as translating one or more components along an axis, rotating about an axis,
cutting a section plane, or taking measurements. You can load, save, and clear
construction geometry you've created.

You can use Search to find construction geometry in the structure, and you can use
the Save button to save the construction geometry.

Create the following types of construction geometry:

* Point
* Plane
* Curve
* Axis

* Coords—Coordinate system

* Line

To Create Construction Geometry

To create construction geometry, use the commands in the Constructions group on
the Markup tab. When you select a construction geometry command, a
corresponding collector window displays. Click in the 3D view to select a
reference, and use the Add button to add rows and click to select new references.
When you select an item to populate the collector , the available constraints (drop-
down menu) vary based on your selection in the view. The OK button becomes
available when a construction geometry can be created. Click OK to create and
select the construction geometry.

Construction Geometry References

Use the following references to create construction geometry:

Type Reference
Point Vertex

Edge

Curve
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Type Reference

Line
Axis
Plane

Coordinate system

Axis Two points

Vertex

Construction geometry point
Edge, curve, line, or axis

Circular edge or curve

Surface
Plane
Primary axis of geometry An edge or a curve of an object
Normal vector Normal vector of the surface at the
point you select on the object
Plane
Coords Point
Cylindrical surface
Coordinate system
Curve Point
Surface
Line Point

Curve or edge

Circular entity

Using the Bounding Box as Construction
Geometry

The bounding box of a component can be designated as construction geometry.
You can rotate the object in the bounding box, and you can use the bounding box
to view and manipulate the object as you would view and manipulate an axis,
point, or plane. When this option is selected, the bounding box always appears
around the object as construction geometry, and it does not indicate selection.
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Loading Construction Geometry

In the Constructions group in the Markup tab, you can click the Load command to
display the Load Construction Geometry dialog box, where you can browse to
select the geometry you want to import.
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About Groups

You can create groups to manage and maintain a set of entities that share a
common purpose or meaning. Create groups by selecting MCAD or ECAD entities
in the graphics area, from the structure, or by redirecting search results. The group
functionality is context-sensitive. MCAD group options open to MCAD data, and
the ECAD group options open to ECAD viewables.

Perform the following operations on groups:
* Name

» Edit the name, content, and display

* Sort the contents

* Add comments

You can use groups to modify the view in the graphics area. Select a group, and
then select a view operation to perform on the group members:

* Isolate
* Hide and unhide
e Zoom

* Highlight ECAD groups

Groups are on the Groups pane of the upper data panel. When you select a
group name from the list, the members appear in the MCAD Part Name partition,
or the ECAD Group Contents partition below. You can create an empty group and
add members later.

You can save the contents of selected groups, or of all groups.

In Creo View, you can create and modify groups. In Creo View Lite, you can view
groups.
To Save One or More Groups

1. Onthe Groups pane, select the groups to save.

2. Perform one of the following actions:

* Right-click and choose Save from the shortcut menu.

. L]
e Click Groups » Save » Save Group.
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To Save All Groups

1. In the upper data panel, click . The Groups pane opens.

2. Perform one of the following actions:
* Right-click in the Groups pane and choose Save All from the shortcut

menu.

e Click Groups » Save » Save All Groups.

Creating MCAD Groups

About MCAD Groups

You can select parts and subassemblies for four types of groups:

. 2 Static—Groups parts and assemblies that you select.

. Nested—Creates a group of groups. It can contain static, nested, search

and rule groups. The ¥| Nested group appears in the Groups pane with its
child groups.

When you select a nested group, all the members of all of its children appear
under Part Name. When you select a child group, only its members appear in
the Part Name partition.

You can delete only entire child groups from a Nested group. You cannot delete
parts individually.

. Search—Saves the results of a search as a group in the Part Name partition
of the Groups pane instead of in the Part Name partition of the search results
pane.

. Dynamic—Defines criteria to subdivide MCAD groups according to the
hierarchy of parts or the value of a specific attribute. For instance, a group
called Motor Parts subdivided according to the attribute material, will have
subgroups called Motor Parts steel and Motor Parts aluminum.

Create a Dynamic group without parts, import the parts from an existing
MCAD group, and then select the criteria for inclusion into the subgroups.

You can share an MCAD group. Shared groups are applied to any MCAD
representation that you open. When a group is shared, appears alongside the
group icon in the Groups pane.
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To Create a Static Group

You can create a Static group with or without preselecting entities.

1.

To include selected entities, select one or more entities from the View pane,

the ECAD Results pane, the Part Name partition of the Groups pane, the

search results list, or the graphics area, and then click Create Static Group or
Create Group * Static in one of these locations:

e Groups tab

*  Structure tab

* Model Parts tab

The Group Name dialog box opens.

Type a name for the group and click OK.

To Create a Nested Group

You can create a nested group in two ways:

From the Groups Pane

1.

2.

or

Select groups in the Groups pane, and then click Create Group > Nested.
The Group Name dialog box opens.

Type a name for the group and click OK.

From the Group Name Dialog Box

1.
2.

3.

Click Create Group > Nested. The Group Name dialog box opens.
Type a name for the group click OK. The group is created.

In the Groups pane, drag group names to the new group.

To Create a Search Group

You can create a search group in two ways:

From the Group Name Dialog Box

1.

2.

or
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In an open search configuration, click Save As Group. The Group Name dialog
box opens.

Type a name for the group click OK. The group is created.
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From the Create Group Dialog Box

1.
2.

Click Create Group > Search. The Create Group dialog box opens.

Type a name for the group and click OK. The Search Product Structure dialog
box opens.

Define the search and click Apply. The group is created.

To Edit a Search Group

1.

Right-click a Search group and choose Edit Properties, or select a

Search group in the Groups pane and then click Groups » Edit
Properties. The Properties dialog box opens.

Click Query. The Search Product Structure dialog box opens.
Modify the settings in the Search Product Structure dialog box, and then click

. Apply. The group is edited.

Click OK.

To Create a Rule Group

1.

Select a group in the Groups pane, and then click Create Group > Rule, or
click Groups > Create Group *> Rule on the ribbon. The Group Name dialog box
opens.

Type a name for the Rule group and click OK. The Rule group is created.
By default each group member is a EI Subgroup.

Right-click the Dynamic group on the Groups pane and choose Edit
Properties from the shortcut menu, or select the Dynamic group and click

Groups » Edit Properties. The Properties dialog box opens.

4. Under Source, select a Group from the list.

Under Grouping Criteria, sclect By attribute or By hierarchy, and then select an
option from the list.

Set the Group naming criteria.
Select Shared to apply the group to other representations.

Click Close. The EI Subgroups update. Select a EI Subgroup to view its
members in the Part Name partition.
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Setting Subgroup Criteria

Subgroup criteria divides the group’s members into subgroups. There are two
categories of subgroup:

* By attribute—Includes parts with the selected attribute. The options include
attributes from all components in the design.

* By hierarchy—Sets a level of hierarchy to appear in the subgroup.
O  Top level—Includes only the top level of each entity.

O Children—Includes only the children of entities.

Select Include descendants in group contents to include the children of parts
that appear in a subgroup.

Specify the naming of the resulting subgroups under Group naming criteria. You
can edit the field to change the naming criteria. Use the Insert Special list to
include an option from the list.

To Share a Group
1. Right-click the group and choose Edit Properties, or select an MCAD group in

=
the Groups pane and then click Groups » Edit Properties. The
Properties dialog box opens.

2. Click Shared, and click Close.

Creating ECAD Groups

About ECAD Groups

You can select objects for an ECAD group from the graphics area, the Viewables
pane, search results, or the contents of another group. ECAD groups are viewable-
specific. If you have two views of the same ECAD design and add a group in one
of them, the new group appears in the other view when it is activated. You can
duplicate an ECAD group and save it with another name.

You cannot include markup objects in an ECAD group.

Control the color and visibility of ECAD groups in the Groups branch of the Color
and Visibility Controls pane.
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To Create an ECAD Group

You can create an ECAD group with or without preselecting objects.

1. To include selected object, select one or more objects from the View pane,

the graphics area, the ECAD Results pane, or the Group Contents partition
of the Groups pane.

2. Right-click the primary panel and choose Create Group, or click Groups »
Create Group.

The Create Group dialog box opens.
3. Type a name for the group and click OK. The new group name is added in the

Groups pane in the upper data panel.

To Duplicate an ECAD Group

1. Select a group from the Groups pane then click Groups » Create
Group. The Create Group dialog box opens.

2. Type a name for the new group and click OK. The new group is created.
Modifying Groups

About Modifying Groups

You can modify groups in any of these ways:
* Refresh contents

* Add or remove members

* Rename

* Delete

* Add comments

When you open an MCAD group after the model has been modified, use the
Refresh Contents command to update the group contents. Refreshing a group

contents includes or excludes relevant parts in the group.
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To Refresh MCAD Group Contents

I.
2.

On the Groups pane, right-click and choose a group.

Right-click in the Part Name pane and choose Refresh Contents. The group
contents update.

To Add Entities to a Static or an ECAD Group

You can add entities to a group in different ways:

1.

or

or

Select one or more entities from the primary panel, the graphics area, or the
search results list on the upper data panel.

*u
Click L=3| Add to Group, and then select the group name from the list. The
entities are added to the group.

Select the group name from the group list.

Select one or more entities on the primary panel and drag them to the Part
Name pane.

Select one or more entities and then right-click and choose Add to Group.

Select the group name from the list on the shortcut menu.

To Rename a Group

1.

On the Groups pane, right-click a group and choose Rename from the

shortcut menu, or select the group and click Groups » Rename Group. The
Group Name dialog box opens.

Type a new name and click OK.

To Add Comments to a Group

1.
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Select an MCAD group in the Groups pane and then click Groups »
Edit Properties, or right-click the group and choose Edit Properties. The
Properties dialog box opens.

Click Comments. The Comments tab opens.
Type your comments and click Close.

Repeat this procedure to view comments.
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To Remove Parts from a Group

1. Onthe Groups pane, select the group.

2. Under ECAD Group Contents or MCAD Part Name, select one or more parts,
and perform one of these actions:

* Right-click and choose Remove from Group from the shortcut menu.

¢ Click Group Contents » Remove from Group.

To Delete a Group

1. On the Groups pane, select the group, and perform one of these actions:

* Right-click and choose Delete from the shortcut menu.

e Click Groups » Delete Group.
Modifying Views Using Groups

About Modifying Group Views
You can modify group views in any of these ways:
» Show or hide group members’ paths

» Filter the list of groups

» Filter the list of members of one group

» Isolate, show, or hide groups

» Highlight groups

e Zoom

About Showing or Hiding Group Paths

Use the Show Paths option to show or hide the structure paths to MCAD group
members in the Part Name partition. The option that you choose will apply to all
groups that you select.
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To Show or Hide Paths for Part Names
1. Select a group in the 21 Groups pane.

2. Under Part Name, select any part, and then click Group Contents » Show
Paths, or right-click Part Name and choose Show Paths. The full path of each

part is shown or hidden.

To Modify the View Using Groups

In the Groups pane, select the group and then choose a command from the
ribbon, or right-click and choose it from the shortcut menu. The view is updated.

* Open in new view (MCAD only)

. E Isolate Group
. Hide

. Unhide All

. Zoom to Group

. Highlight Group (ECAD only)

About Filtering the List of Groups

You can filter MCAD groups by type. You can also apply a filter to show shared
groups or saved groups in the current structure. Only the selected group types are
displayed. You can filter the display of one or more ECAD and MCAD groups by
name.

To Filter the List of Groups

1. Inthe Groups pane, right-click and choose Filter Group List. The Filter
Groups dialog box opens.

2. To filter by name, select Names matching and then type the name of a group in
the Enter text to match box.

3. To filter by local or shared status, select Only groups stored and then select
either In the current structure or Shared across all structures.

4. To filter by type in an MCAD project, select Groups of type, and then select
one or more group types to display.

5. Click Make Default to apply the filter settings to all groups.
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6.
7.

Click OK. The list is filtered.

To cancel the filter settings, in the Groups pane, right-click and choose
Reset Filter.

To Filter the List of Items in One Group

1.

Under ECAD Group Contents or MCAD Part Name, right-click and choose
Filter Group Contents. The Filter Group Contents dialog box opens.

Select Names matching and then type the name of a group to display in the
Enter text to match box.

Click Make Default to save the settings as the default.
Click OK. The Groups list is filtered.

To cancel the filter settings, in the ECAD Group Contents or MCAD Part
Name partition, right-click and choose Reset Filter.
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About Watermarks

Watermarks are text, images, or both that are overlaid on a view when it is
displayed or printed. This information can be derived from any of the following
sources:

» System attributes such as time and date
* PDM such as release status

» User-defined attributes such as company name and logo

You can specify a number of different watermarks to use, based on values of
attributes in the product structure. The Property Name field defines the name of the
property to look for, and the table lists the possible values for this property, along
with the watermark to use when the specified attribute has a matching value in the

product structure. If the property name or value is not found in a particular file, the
Default Watermark is used instead.

To Define and Apply Watermarks

Click File » Creo View Options. The Creo View Options dialog box opens.

2. On the left, under General, click Watermarks. The General — Watermarks
dialog box opens.

3. To add a watermark perform theses steps:

a. Click . The Add Watermark dialog box opens

b. Type a name and browse to and add an . in1i file, and then click OK.

To set a watermark as default, select the watermark and click Set As Default.
To remove a watermark, select the watermark and click Delete.

Select or clear the Include watermark when printing box.

Select or clear the Include watermark when viewing box.

© =Nk

Click Apply to apply the options and keep the General — Watermarks dialog
box open, or click OK to apply the options and close the dialog box.
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About Saving MCAD and ECAD Files

You can save MCAD structures, ECAD designs, and their associated viewables
and annotation sets:

e PVZ—Includes files for all viewables and annotations.

* PVS—Saves the information as a directory and references the viewable and
annotations files.

To Save an MCAD and ECAD File

Click File » Save All. The file is saved.

About Printing Viewables

You can print one or more parts or viewables associated with a structure at one
time. You can print multiple items in these ways:

» List—Each selected item is a separate print job. You can select Print Settings
for each item.

* Combined—All selected items are included in one print job. You can select one
set of Print Settings for all items in the print job.

You can include Illustration or Document views in the list of a multiple print job,
but you cannot include them in a combined print job, or as part of a single job
derived from a multiple print job. Use the advanced options to print a background
color and control the margins of printed images.

To Set Advanced Print Options

1. Access the advanced print options in one of these ways:

*  From the Print dialog box—Click Preferences » Advanced.

) |
*  From the Print Multiple Iltems dialog box—Click Print Settings » Global
Advanced options.

The Advanced Print dialog box opens.

2. Select one or more of these options for your viewable:

¢ 3D Model—Print background color

* Drawing—Print background color
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* Drawing—Monochrome printing
* Image—Print without margins

3. Click OK. The Advanced Print dialog box closes.

To Print a Viewable

1. Make sure the viewable you want to print is open and that the correct view is
displayed.
2. Click File » Print. The Print dialog box opens.
3. Under Printer, do one or more of the following operations:
* Select a printer.
» Select the Print to file check box.
* Click Properties and set printer properties.

4. Under Print Range, set the level of Zoom for the printout:

* As Displayed—Prints according to the level of zoom you set in the graphics
area.

*  All—Prints the entire item.

5. Under Copies, set the number of copies and select or clear the Collate check
box.

6. Under Layout, set one or more of the following parameters:

¢ Fitto Page

* Scale—Select a scale from 10 percent to 100 percent.

* Rotate and Center for best fit—The viewable is manipulated to fit the page.
7. Click Preferences to set the following options:

¢ Watermark

* Advanced

Click OK in the Advanced Print dialog box.
8. Click OK.

To Print Multiple Items

- N .
1. Click File » Print » Print Multiple Items, and then click OK. The Print
Multiple Items dialog box opens.

2. Drag the items to the print list from any of these locations:
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* Viewables pane of the primary panel
* Annotation sets
* Views group of the Home tab

3. To print all the viewables associated with a structure, including annotation sets,
click Add All Viewables.

4. To reorder the printing list, click IEL IEL Igl, and IEI
To remove an item from the list, click .

To print all the items as a combined print job, click the arrow next to Print
Settings, and then click Print as single job.

Note
PDF and ISO files cannot be combined in a single job.

7. To configure the print settings for an item or a combined job, select it and then
click Print Settings.

8. Click Print.

About Print Preview

Use Print Preview to change how the display content appears on the screen and is
printed. You can change the page setup, the print settings and scale, and determine
whether to include a watermark or not. The status bar provides information
regarding the current page number and number of pages or sheets, the paper size,
and the name of the currently selected printer.

All view types are supported, except for PDF and IsoDraw . Print preview for pdf
is handled in the acrobat window, and Isodraw displays its own print dialog.

Print Preview is available in both Creo View and Creo View Lite

To Preview a Print Job

1. Click File » Print » D Print Preview. The Print Preview dialog box opens.
2. Adjust the page settings:

* Orientation—Switches the pages between portrait and landscape layouts.
» Size—Selects the page size for the current view.

3. Select one or more of these options:
*  Print Watermarks—Includes watermark when printing.

¢ Print background color
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*  Print without margins
*  Print monochrome

*  Print Watermarks > Edit Watermarks to open the watermarks dialog box to
select a watermark.

4. Use one of these modes to define the image size and position on the page:
e Zoom
* Fitto Page—Opens scale size options
Click Options to open the Document Properties dialog box.

Click Print to open the Print dialog box and print the image, or Close Print
Preview to return.

To Add a Watermark to a Print Job

1. Open the General-Watermarks dialog box in one of these ways:

* From the Print dialog box—Click Preferences » Watermarks

*  From the Print Multiple Items dialog box—Click Print Settings »>
Watermarks.

e Click File » Creo View Options.
2. Under Default Watermark, select the watermark to apply.

3. Select the Include watermark when printing check box, and then click OK.

To Print a PDF

1. Open a PDF in Creo View.

2. Click File » Print » Print. The Print dialog box opens.
3. Configure the printing settings and click OK. The document is printed.

To Save a PDF Locally

1. Open a PDF in Creo View.

2. Click File » Save Current View As » As a PDF file. The Save View as PDF
dialog box opens.

3. Select a location and type a name for the file. Click OK. A copy of the file is
saved.
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To Send a View by E-mail

I.

Make sure the representation you want to send is open and the correct view is
displayed.

Click File » Send » Active view by E-Mail. The Save View As Image-Settings
dialog box opens.

Under Units, select the unit of measurement for the image:

* Inches

* Centimeters

* Pixels

Under Width and Height, set the dimensions for the image.
Note

When the Lock aspect ratio check box is selected, the proportions of the image
are preserved. You can change one dimension and the other is updated
automatically.

To set a resolution for images measured in inches or centimeters, in the
Resolution box, type a number of pixels per unit.

Click OK. An e-mail message opens with the image file attached.

To Configure Print Settings

1.
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In the Print Multiple Items dialog box, select the a viewable, and then click Print
Settings. The Print dialog box opens.

Under Printer, do one or more of the following operations:
* Select a printer.

* Select the Print to file check box.

* Click Properties and set printer properties.

Under Print Range, select one of these options:

* Sheets—Prints selected pages.

* All Pages—Prints the entire item.

*  Current Page—Prints current page.

If enabled, you can set the level of Zoom for the printout.

Under Copies, set the number of copies and select or clear the Collate check
box.

Under Layout, set one or more of the following parameters:
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* Fitto Page
* Scale—Select a scale from 10 percent to 100 percent.
* Rotate and Center for best fit—Manipulates the item to fit the page.

Note
Zoom, Collate, Scale, Rotate and Center for best fit are not available for PDF
documents.

6. Click OK. The Print dialog box closes.
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