4 Replies Latest reply: Aug 11, 2011 8:25 AM by DHLewis RSS

    Pro/Intralink 3.4 M062 and Windows 7 64-bit

    RyanG Copper

      I know how to get Pro/Intralink to run on Windows 7 64-bit, but my question is if there is anyone out there that is currently running this environment in production and if so what issues have you experienced.  Due to the "unsupported" status by PTC of Pro/Intralink, we hesitate to change our standard workstation configurations to a Windows 7 64-bit platform.  However, many of our Pro/Engineer users could benefit from this.  

        • Re: Pro/Intralink 3.4 M062 and Windows 7 64-bit
          ToddSwartz Copper

          We have about 20-30 users running on the Win 7-64 bit.  No real issues to speak of other than what you have likely found about running the javac in compatibility mode.   Other than that, I have not noticed any differences from Win XP.

           

          We see some issues around printer drivers etc and other software, but none from Intralink or Pro/E (both Wildfire 3 & 4)

            • Re: Pro/Intralink 3.4 M062 and Windows 7 64-bit
              FilipeDuarte Copper

              Hi Todd,

              I was able to get Pro/Intralink 3.4 M062 to work in 64-bit Windows 7 following tips by DHLewis. I then created a workspace called test.  I also managed to install WF 4.0 M170 for 64-bit  XP and Vista and it works OK independently or when selecting Workspace menu Intralink "Launch Pro/Engineer - No Workspace. Unfortunately I am unable to get Pro/E to work in linked mode with Intralink. The error message in std.out reads "ERROR: cannot register workspace "test"."

               

              Can you help me to fix this?

                • Re: Pro/Intralink 3.4 M062 and Windows 7 64-bit
                  DHLewis Silver

                  Filipe,

                   

                  Have you looked at the proilink.bat file to verify that the path's for the variables to Pro/E are correct? 

                  the variables that control linking in the bat file are:

                  PROE_DIR  and PROE_START

                   

                  PROE_DIR is set to the root folder of the Pro/E Install (Location where the bin folder is)

                  PROE_START is set to the command run to use Pro/E (If you want to choose the configuration use ProE.exe, or else use the .bat file name here)

                   

                  Also make sure that your .psf files have the correct Intralink Dir and command defined.

                   

                  That should be everything needed for the link to work correctly.

                   

                  David

                    • Re: Pro/Intralink 3.4 M062 and Windows 7 64-bit
                      FilipeDuarte Copper

                      David,

                       

                      The problem was that I was using a SMS installation package for 32-bit Windows!

                      I have reinstalled INTRALINK with the original media and applied the changes you suggested to javaw.exe and the start /B ... and now Pro/E and Intralink work in a linked mode.

                       

                      Thanks a lot for your reply -- it made me review the proilink.bat file and then I realized that there was something wrong with the installation.

                       

                      Filipe